安装 SQL Server 2005

SQL Server 安装程序帮助
安装 SQL Server 2005 |
 | 请参阅

SQL Server 2005 安装向导基于 Microsoft Windows 安装程序，并且为所有 Microsoft SQL Server 2005 组件的安装提供单一的功能树：

  • SQL Server 数据库引擎

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • 管理工具

  • 文档和示例

注意 SQL Server 2005 有 32 位和 64 位两种版本可用。SQL Server 2005 的 64 位版本安装方法与 32 位版本相同，即通过安装向导或命令提示符进行安装。有关 SQL Server 2005 组件的详细信息，请参阅 SQL Server 2005 的版本和组件。无论使用 SQL Server 2005 安装向导还是命令提示符安装 SQL Server 2005，安装过程都包括下列步骤。

步骤 1：准备计算机以安装 SQL Server 2005

若要为安装 SQL Server 2005 而准备计算机，请检查硬件和软件要求、系统配置检查器的要求和妨碍性问题以及安全注意事项。

有关详细信息，请参阅： 准备安装 SQL Server 2005

步骤 2：安装 SQL Server 2005

若要安装 SQL Server 2005，请使用 SQL Server 2005 安装向导运行安装程序，或从命令提示符安装。也可以将组件添加到 SQL Server 2005 的实例，或从 SQL Server 早期版本升级到 SQL Server 2005。

有关详细信息，请参阅： 安装 SQL Server 2005 组件

步骤 3：配置 SQL Server 2005 安装

安装程序完成 SQL Server 2005 的安装后，可以使用图形化实用工具和命令提示实用工具配置 SQL Server。

有关详细信息，请参阅： 配置 SQL Server 安装

请参阅

任务

如何升级到 SQL Server 2005（安装程序）

其他资源

配置高可用性
数据库引擎安装帮助主题

© 2006 Microsoft Corporation。保留所有权利。


SQL Server 2005 的版本和组件

SQL Server 2005 的版本和组件 |
 | 请参阅
安装 SQL Server 2005 >

根据应用程序的需要，安装要求可能有很大不同。SQL Server 2005 的不同版本能够满足企业和个人独特的性能、运行时以及价格要求。需要安装哪些 SQL Server 2005 组件也要根据企业或个人的需求而定。下列部分将帮助了解如何在 SQL Server 2005 的不同版本和可用组件中做出最佳选择。

在 SQL Server 2005 的各版本之间选择

大多数企业都在三个 SQL Server 版本之间选择：SQL Server 2005 Enterprise Edition、SQL Server 2005 Standard Edition 和 SQL Server 2005 Workgroup Edition。大多数企业选择这些版本是因为只有 Enterprise Edition、Standard Edition 和 Workgroup Edition 可以在生产服务器环境中安装和使用。

除 Enterprise Edition、Standard Edition 和 Workgroup Edition 外，SQL Server 2005 还包括 SQL Server 2005 Developer Edition 和 SQL Server 2005 Express Edition。以下段落分别说明其中的每个版本，并建议应在何时使用哪个版本。

SQL Server 2005 Enterprise Edition（32 位和 64 位）

Enterprise Edition 达到了支持超大型企业进行联机事务处理 (OLTP)、高度复杂的数据分析、数据仓库系统和网站所需的性能水平。Enterprise Edition 的全面商业智能和分析能力及其高可用性功能（如故障转移群集），使它可以处理大多数关键业务的企业工作负荷。Enterprise Edition 是最全面的 SQL Server 版本，是超大型企业的理想选择，能够满足最复杂的要求。

SQL Server 2005 Evaluation Edition（32 位和 64 位）

SQL Server 2005 还推出了适用于 32 位或 64 位平台的 120 天 Evaluation Edition。SQL Server Evaluation Edition 支持与 SQL Server 2005 Enterprise Edition 相同的功能集。

SQL Server 2005 Standard Edition（32 位和 64 位）

Standard Edition 是适合中小型企业的数据管理和分析平台。它包括电子商务、数据仓库和业务流解决方案所需的基本功能。Standard Edition 的集成商业智能和高可用性功能可以为企业提供支持其运营所需的基本功能。Standard Edition 是需要全面的数据管理和分析平台的中小型企业的理想选择。

SQL Server 2005 Workgroup Edition（仅适用于 32 位）

对于那些需要在大小和用户数量上没有限制的数据库的小型企业，Workgroup Edition 是理想的数据管理解决方案。Workgroup Edition 可以用作前端 Web 服务器，也可以用于部门或分支机构的运营。它包括 SQL Server 产品系列的核心数据库功能，并且可以轻松地升级至 Standard Edition 或 Enterprise Edition。Workgroup Edition 是理想的入门级数据库，具有可靠、功能强大且易于管理的特点。

SQL Server 2005 Developer Edition（32 位和 64 位）

Developer Edition 使开发人员可以在 SQL Server 上生成任何类型的应用程序。它包括 SQL Server 2005 Enterprise Edition 的所有功能，但有许可限制，只能用于开发和测试系统，而不能用作生产服务器。Developer Edition 是独立软件供应商 (ISV)、咨询人员、系统集成商、解决方案供应商以及创建和测试应用程序的企业开发人员的理想选择。Developer Edition 可以根据生产需要升级至 SQL Server 2005 Enterprise Edition。

SQL Server 2005 Express Edition（仅适用于 32 位）

SQL Server Express 数据库平台基于 Microsoft SQL Server 2005。它也可以替换 Microsoft Desktop Engine (MSDE)。通过与 Microsoft Visual Studio 2005 集成，SQL Server Express 简化了功能丰富、存储安全且部署快速的数据驱动应用程序的开发过程。

SQL Server Express 是免费的，可以再分发（受制于协议），还可以充当客户端数据库以及基本服务器数据库。SQL Server Express 是独立软件供应商 ISV、服务器用户、非专业开发人员、Web 应用程序开发人员、网站主机和创建客户端应用程序的编程爱好者的理想选择。如果需要更多的高级数据库功能，可将 SQL Server Express 无缝升级到更复杂的 SQL Server 版本。

SQL Server Express 还提供了一些附加组件，这些组件都作为具有高级服务的 Microsoft SQL Server 2005 Express Edition (SQL Server Express) 的一部分提供。除了 SQL Server Express 的功能外，具有高级服务的 SQL Server Express 还包括以下功能：

  • SQL Server Management Studio Express (SSMSE)，SQL Server Management Studio 的子集。

  • 支持全文目录。

  • 支持通过报表服务器查看报表。

SQL Server 2005 Mobile Edition（仅 32 位）

SQL Server Mobile Edition 是简版数据库，将企业数据管理功能扩展到小型设备上。SQL Server Mobile Edition 能够复制 Microsoft SQL Server 2005 和 Microsoft SQL Server 2000 的数据，并且允许用户维护与主数据库同步的移动数据存储。SQL Server Mobile Edition 是唯一为智能设备提供关系数据库管理功能的 SQL Server 版本。

在 Internet 服务器上使用 SQL Server 2005

在 Internet 服务器（如运行 Internet 信息服务 (IIS) 的服务器）上通常都会安装 SQL Server 2005 客户端工具。客户端工具包括连接到 SQL Server 实例的应用程序所使用的客户端连接组件。

注意：
尽管可以在运行 IIS 的计算机上安装 SQL Server 实例，但这种做法通常只用于单服务器的小型网站。大多数网站都将其中间层 IIS 系统安装在一个服务器上或服务器群集上，将数据库安装在另外一个服务器或服务器联合体上。SQL Server 2005 Reporting Services 通常安装在中间层。有关 Reporting Services 软件要求的详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。有关联合体的详细信息，请参阅联合数据库服务器。

在客户端/服务器应用程序中使用 SQL Server 2005

在运行直接连接到 SQL Server 实例的客户端/服务器应用程序的计算机上，只能安装 SQL Server 2005 客户端组件。如果要在数据库服务器上管理 SQL Server 实例，或者打算开发 SQL Server 应用程序，那么客户端组件安装也是一个不错的选择。

客户端组件选项安装以下 SQL Server 功能：命令提示工具、报表服务器工具、连接组件、编程模型、管理工具、开发工具、联机丛书、示例数据库以及示例应用程序。有关详细信息，请参阅如何安装 SQL Server 2005（安装程序）。

在 SQL Server 2005 组件之间选择

使用 SQL Server 安装向导的“功能选择”页选择 SQL Server 2005 安装中要包括的组件。默认情况下不选择树中的任何功能。

根据下面的说明确定满足需要的功能集。

服务器组件 | 说明
SQL Server 数据库引擎 | 数据库引擎 包括数据库引擎（用于存储、处理和保护数据的核心服务）、复制、全文搜索以及用于管理关系数据和 XML 数据的工具。
Analysis Services | Analysis Services 包括用于创建和管理联机分析处理 (OLAP) 以及数据挖掘应用程序的工具。
Reporting Services 1,2 | Reporting Services 包括用于创建、管理和部署表格报表、矩阵报表、图形报表以及自由格式报表的服务器和客户端组件。Reporting Services 还是一个可用于开发报表应用程序的可扩展平台。
Notification Services | Notification Services 是一个平台，用于开发和部署将个性化即时信息发送给各种设备上的用户的应用程序。
Integration Services | Integration Services 是一组图形工具和可编程对象，用于移动、复制和转换数据。

1Reporting Services 的安装需要 Internet 信息服务 (IIS) 5.0 或更高版本。

2Reporting Services 的报表设计器组件需要 Microsoft Internet Explorer 6.0 Service Pack (SP) 1。

客户端组件 | 说明
连接组件 | 安装用于客户端和服务器之间通信的组件，以及用于 DB-Library、ODBC 和 OLE DB 的网络库。

管理工具 | 说明
SQL Server Management Studio 1 | SQL Server Management Studio (SSMS) 是 Microsoft SQL Server 2005 中的新组件，这是一个用于访问、配置、管理和开发 SQL Server 的所有组件的集成环境。SSMS 将 SQL Server 早期版本中包含的企业管理器、查询分析器和分析管理器的功能组合到单一环境中，为不同层次的开发人员和管理员提供 SQL Server 访问能力。
SQL Server 配置管理器 | SQL Server 配置管理器为 SQL Server 服务、服务器协议、客户端协议和客户端别名提供基本配置管理。
SQL Server 事件探查器 | SQL Server 事件探查器 提供了图形用户界面，用于监视数据库引擎 实例或 Analysis Services 实例。
数据库引擎 优化顾问 | 数据库引擎 优化顾问可以协助创建索引、索引视图和分区的最佳组合。

1要安装 SQL Server Management Studio，需要 Internet Explorer 6.0 SP1。

开发工具 | 说明
Business Intelligence Development Studio 1 | Business Intelligence Development Studio 是用于 Analysis Services、Reporting Services 和 Integration Services 解决方案的集成开发环境。

1要安装 Business Intelligence Development Studio，需要 Internet Explorer 6.0 SP1。

文档和示例 | 说明
SQL Server 联机丛书 | SQL Server 2005 的核心文档。
SQL Server 示例 | 提供数据库引擎、Analysis Services、Reporting Services 和 Integration Services 的示例代码和示例应用程序。

请参阅

参考

要安装的组件
功能选择

概念

SQL Server 外围应用配置器


SQL Server 2005 隐私声明

SQL Server 2005 隐私声明
安装 SQL Server 2005 >

有关 Microsoft SQL Server 2005 中用户数据收集组件的信息，请访问此 Microsoft 网站。


法律声明

法律声明
安装 SQL Server 2005 >

本文档（包括其中的示例应用程序）仅供参考，并且本文档不提供任何明示或暗示的保证。本文档中的信息（包括 URL 和其他 Internet 网站引用）如有更改，恕不另行通知。由于使用本文档而带来的任何风险或后果均由用户自行承担。

本文档中包含的示例主要用于说明概念以及特定语句或子句的合理用法。大多数示例不包括完整的生产系统通常所包含的全部代码，因为其中删除了某些常用的数据验证和错误处理，以便使示例突出特定的概念或语句。对这些示例或所包括的源代码，我们不提供技术支持。

除非另行说明，否则在本文档示例中涉及的公司、单位、产品、域名、电子邮件地址、人员、地点和事件等都是虚构的，与任何真实的公司、单位、产品、个人或事件没有任何刻意或隐含的联系。用户有责任遵守所有适用的版权法。除了版权法所规定的权利以外，未经 Microsoft Corporation 的明确书面许可，不得对本文档中的任何部分进行复制、存储或引入检索系统，也不能以任何形式或借助任何手段（电子、机械、影印、录制或其他手段）、出于任何目的进行传播。

Microsoft 可能拥有本文档中内容的专利、专利申请、商标、版权或其他知识产权。除非 Microsoft 提供了明确的书面许可协议，否则提供本文档并不意味着赋予您有关这些专利、商标、版权或其他知识产权的任何许可。

版权所有 ? 2006 Microsoft Corporation。保留所有权利。

Microsoft、Windows、Windows NT、Windows Server、Active Directory、ActiveX、BackOffice、bCentral、BizTalk、DirectX、Excel、Hotmail、IntelliSense、J/Direct、Jscript、Microsoft Press、MSDN、MS-DOS、Outlook、PivotChart、PivotTable、PowerPoint、SharePoint、Visual Basic、Visual C#、Visual C++、Visual FoxPro、Visual InterDev、Visual J#、Visual J++、Visual SourceSafe、Visual Studio、Win32、Win32s、Windows Mobile、Windows Server System 和 WinFX 是 Microsoft Corporation 在美国和/或其他国家（地区）的注册商标或商标。

SAP NetWeaver 是 SAP AG 在德国和其他几个国家的注册商标。

所有其他商标归其各自拥有者所有。

SQL Server 2005 支持和升级文档策略

SQL Server 文档中的内容在发布之前已进行了充分测试。产品文档（SQL Server 联机丛书、自述文件、已知问题文档和知识库文章）包含与 SQL Server 功能相关的内容，这些内容非常可靠，在所有客户的一般性应用中都是安全的。此政策适用于所有 SQL Server 文档，包括发行版和 Service Pack 的自述文件；自述文件被视为联机丛书的扩展。

在某些情况下，如果某项特定功能不应由客户直接使用，则这项功能将不会记录在文档中。除非 Microsoft 发布的 SQL Server 文档中也介绍了某项功能，否则 Microsoft 客户支持服务部门 (CSS) 不会对来自第三方书籍或网站的相关内容提供支持，并且这些内容也不应该应用于生产环境中的数据库或应用程序。

客户不得使用未记录的 API，包括但不仅限于：存储过程、扩展存储过程、函数、视图、表、列、属性或元数据。Microsoft 客户支持服务部门将不为利用或使用未记录入口点的数据库或应用程序提供支持。

对于利用或使用未记录入口点的应用程序和数据库，将不保证其服务器和数据库升级至 SQL Server 的未来版本。因此，只应使用 Microsoft SQL Server 文档中包含的那些 SQL Server 功能。如果某功能未记录到 Microsoft SQL Server 文档中，则其为 SQL Server 不支持的部分。


关于 SQL Server 2005 最终用户许可协议

关于 SQL Server 2005 最终用户许可协议
安装 SQL Server 2005 >

安装 SQL Server 2005 后，会将 Microsoft 软件许可条款复制到本地计算机。这些文件将写入到：%ProgramFiles%\Microsoft SQL Server\90\EULA\ 或 %ProgramFiles(x86)%\Microsoft SQL Server\90\EULA\。

将相同 SQL Server 2005 版本和语言的多个实例安装到同一台计算机中时，软件许可条款的单个副本将应用于该版本和语言的所有实例。

软件许可条款文件名可指示 SQL Server 2005 的版本及其语言版本。例如：

  • License_DEV_ENU.txt 表示 SQL Server 2005 Developer Edition，英文版。

  • License_STD_ITA.txt 表示 SQL Server 2005 Standard Edition，意大利文版。

  • License_UA_JPN.txt 表示 SQL Server 2005 升级顾问，日文版。

  • License_SQLNCLI_ENU.txt 表示 SQL Native Client，英文版。

  • License_SQLXML4_KOR.txt 表示 SQLXML，韩文版。

以下文件名段用于标识 SQL Server 2005 的版本：

  • ENT - Enterprise Edition

  • DEV - Developer Edition

  • STD - Standard Edition

  • WKGP - Workgroup Edition

  • EXPR - Express Edition

  • UA - 升级顾问

以下文件名段用于标识 SQL Server 2005 的语言：

  • ENU - 英语

  • JPN - 日语

  • FRA - 法语

  • ITA - 意大利语

  • KOR - 韩文

  • DEU - 德语

  • ESN - 西班牙语

  • CHS - 简体中文

  • CHT - 繁体中文

  • NLA - 荷兰语

  • PTB - 葡萄牙语（巴西）

  • SVE - 瑞典语

SQL Server 2005 许可选项

有关 SQL Server 2005 定价和许可选项的信息，请参阅此 Microsoft 网站。


准备安装 SQL Server 2005

准备安装 SQL Server 2005 |
 | 请参阅

根据需要，Microsoft SQL Server 2005 安装程序可以安装 SQL Server 的新实例、升级现有实例或者提供维护选项。下列主题介绍对要安装 SQL Server 2005 的计算机的重要注意事项。在安装 SQL Server 2005 之前，请查看下列信息。

所有 SQL Server 2005 安装

  • 请确保该计算机符合 SQL Server 2005 的系统要求。有关详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。

  • 阅读 安装 SQL Server 的安全注意事项。

  • 安装程序包括安装前检查，用于确定在安装的计算机上不予支持的配置，并指导用户解决遇到的问题。有关详细信息，请参阅系统配置检查器的检查参数。

  • 请确保您在将安装 SQL Server 的计算机上拥有管理员权限。如果通过远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。若要创建故障转移群集，您必须是本地管理员，具有作为服务登录的权限以及在虚拟服务器的所有节点上作为操作系统的一部分进行操作的权限。

    安全说明：
    如果为了运行 SQL Server 安装程序而修改域用户帐户的权限，那么在完成安装后一定要撤消这些权限。

  • 如果在运行 Microsoft Windows XP 或 Windows 2003 的计算机上安装 SQL Server 2005，并且要求 SQL Server 2005 与其他客户端和服务器通信，则请创建一个或多个域用户帐户。有关详细信息，请参阅设置 Windows 服务帐户。

  • 请不要在域控制器上安装 SQL Server 2005。有关详细信息，请参阅 安装 SQL Server 的安全注意事项中的“服务隔离”部分。

  • 如果要在欲安装 SQL Server 2005 的计算机上运行 SQL Server 的实例，请备份 SQL Server 的当前安装。

  • 请验证要安装 SQL Server 的磁盘未压缩。如果尝试将 SQL Server 安装到压缩驱动器，安装程序将失败。

  • 安装 SQL Server 时，请退出防病毒软件。

  • 请停止依赖于 SQL Server 的所有服务，包括所有使用开放式数据库连接 (ODBC) 的服务，如 Internet 信息服务 (IIS)。退出事件查看器和注册表编辑器（Regedit.exe 或 Regedt32.exe）。

  • 请检查所有 SQL Server 安装选项，并准备在运行安装程序时作适当选择。有关详细信息，请参阅 SQL Server 2005 的版本和组件、安装程序用户界面参考和如何安装 SQL Server 2005（安装程序）。

升级到 SQL Server 2005

  • 有关所支持升级方案的列表，请参阅升级到 SQL Server 2005。

  • 有关 SQL Server 2005 与早期 SQL Server 版本一起运行的信息，请参阅使用 SQL Server 的多个版本和向后兼容性。

  • 有关涉及分步升级说明的主题，请参阅如何升级到 SQL Server 2005（安装程序）。

  • 有关已知问题和向后兼容性的注意事项，请参阅版本升级、使用升级顾问来准备升级和向后兼容性。

故障转移群集安装

如果要安装故障转移群集，请参阅安装故障转移群集前的准备工作。

国际用户

如果正在使用具有非英语(美国)区域设置的操作系统，或者要自定义字符集或排序顺序设置，请参阅排序规则选项与国际支持。

有关由安装程序指定的默认排序规则，请参阅安装程序中的排序规则设置。

请参阅

概念

安装 SQL Server 2005
故障转移群集

其他资源

安装 SQL Server 2005 组件
升级到 SQL Server 2005

© 2006 Microsoft Corporation。保留所有权利。


安装 SQL Server 2005 的硬件和软件要求

安装 SQL Server 2005 的硬件和软件要求 |
 | 请参阅
准备安装 SQL Server 2005 >

以下部分列出了运行 Microsoft SQL Server 2005 的最低硬件和软件要求。

注意：
在 32 位平台上运行 SQL Server 2005 的要求与在 64 位平台上的要求有所不同。

硬件和软件要求（32 位和 64 位）

监视器

SQL Server 图形工具需要 VGA 或更高分辨率：分辨率至少为 1,024x768 像素。

定点设备

需要 Microsoft 鼠标或兼容定点设备。

CD 或 DVD 驱动器

通过 CD 或 DVD 媒体进行安装时需要相应的 CD 或 DVD 驱动器。

群集硬件要求

在 32 位和 64 位平台上，支持 8 节点群集安装（即，Microsoft Windows Server 2003 支持的最大节点数量）。有关高可用性解决方案的详细信息，请参阅配置高可用性和安装故障转移群集前的准备工作。

网络软件要求

64 位版本的 SQL Server 2005 的网络软件要求与 32 位版本的要求相同。Windows 2003、Windows XP 和 Windows 2000 都具有内置网络软件。

注意：
SQL Server 2005 不支持 Banyan VINES 顺序包协议 (SPP)、多协议、AppleTalk 或 NWLink IPX/SPX 网络协议。以前使用这些协议连接的客户端必须选择其他协议才能连接到 SQL Server 2005。

独立的命名实例和默认实例支持以下网络协议：

  • Shared Memory

  • Named Pipes

  • TCP/IP

  • VIA

注意 故障转移群集不支持 Shared memory。

Internet 要求

32 位版本和 64 位版本的 SQL Server 2005 的 Internet 要求相同。下表列出了 SQL Server 2005 的 Internet 要求。

组件 | 要求
Internet 软件1 | 所有 SQL Server 2005 的安装都需要 Microsoft Internet Explorer 6.0 SP1 或更高版本，因为 Microsoft 管理控制台 (MMC) 和 HTML 帮助需要它。只需 Internet Explorer 的最小安装即可满足要求，并且不要求 Internet Explorer 是默认浏览器。 然而，如果只安装客户端组件且不需要连接到要求加密的服务器，则 Internet Explorer 4.01（Service Pack 2）即可满足要求。
Internet 信息服务 (IIS) | 安装 Microsoft SQL Server 2005 Reporting Services (SSRS) 需要 IIS 5.0 或更高版本。 有关如何安装 IIS 的详细信息，请参阅如何安装 Microsoft Internet 信息服务。
ASP.NET 2.02 | Reporting Services 需要 ASP.NET 2.0。安装 Reporting Services 时，如果尚未启用 ASP.NET，则 SQL Server 安装程序将启用 ASP.NET。

1SQL Server Management Studio、Business Intelligence Development Studio 和 Reporting Services 的报表设计器组件需要 Microsoft Internet Explorer 6.0 SP1 或更高版本。

2如果在 64 位服务器上安装 Reporting Services（64 位），则必须安装 64 位版本的 ASP.NET。如果在 64 位服务器的 32 位子系统 (WOW64) 上安装 Reporting Services（32 位），则必须安装 32 位版本的 ASP.NET。Reporting Services 不支持同时在 64 位平台上和 64 位服务器的 32 位子系统 (WOW64) 上进行并行配置。有关详细信息，请参阅如何将 IIS 配置为在 WOW64 模式下运行 32 位 Reporting Services。

软件要求

SQL Server 安装程序需要 Microsoft Windows Installer 3.1 或更高版本以及 Microsoft 数据访问组件 (MDAC) 2.8 SP1 或更高版本。您可以从此 Microsoft 网站下载 MDAC 2.8 SP1。

SQL Server 安装程序安装该产品所需的以下软件组件：

  • Microsoft Windows .NET Framework 2.0

  • Microsoft SQL Server 本机客户端

  • Microsoft SQL Server 安装程序支持文件

注意：
SQL Server 2005 Express Edition 不安装 .NET Framework 2.0。在安装 SQL Server 2005 Express Edition 之前，您必须从此 Microsoft 网站下载并安装 .NET Framework 2.0。

如果尚未安装，SQL Server 安装程序将分别安装这些组件。卸载 SQL Server 2005 时，仅自动删除 Microsoft SQL Server 安装程序支持文件。有关卸载此版本的详细信息，请参阅如何卸载 SQL Server 2005 的现有实例（安装程序）。

注意：
SQL Server 2005 不安装 .NET Framework 2.0 软件开发包 (SDK)。SDK 包含文档、C++ 编译器和其他工具，这些工具在您使用 .NET Framework 进行 SQL Server 开发时十分有用。您可以从此 Microsoft 网站下载 .NET Framework SDK。

安装所需组件之后，SQL Server 安装程序将验证要安装 SQL Server 的计算机是否也满足成功安装所需的所有其他要求。有关详细信息，请参阅系统配置检查器的检查参数。

SQL Server 2005 故障转移群集要求至少在服务器群集的一个节点上运行 Microsoft Cluster Server (MSCS)。只有将 MSCS 安装在通过 MSCS 软件兼容性测试的硬件配置上，才支持 MSCS。有关详细信息，请参阅安装故障转移群集前的准备工作。

跨语言支持

对于升级：

  • SQL Server 英文版可以升级到 SQL Server 2005 的任一本地化版本。

  • SQL Server 的本地化版本可以升级到同一语言的 SQL Server 2005 本地化版本。

  • SQL Server 的本地化版本无法升级到 SQL Server 2005 英文版。

  • SQL Server 的本地化版本无法升级到其他本地化语言的 SQL Server 2005 本地化版本。

所有本地化升级都必须遵循支持的升级路径。有关支持的升级路径的特定信息，请参阅版本升级。

其他跨语言支持：

  • 所有支持的操作系统的本地化版本均支持 SQL Server 2005 英文版。

  • 与 SQL Server 本地化版本使用同一语言的本地化操作系统支持 SQL Server 2005 的本地化版本。

  • 通过使用 Windows 多语言用户界面包 (MUI) 设置，支持的英语操作系统版本还支持 SQL Server 2005 的本地化版本。不过，在运行英语操作系统（具有非英语 MUI 设置）的服务器上安装 SQL Server 2005 的本地化版本之前，必须先验证某些操作系统设置。必须验证以下操作系统设置是否与要安装的 SQL Server 本地化版本的语言相匹配：

    • 操作系统用户界面设置

    • 操作系统用户区域设置

    • 系统区域设置

    如果这些操作系统设置与 SQL Server 本地化版本的语言不匹配，则必须按照如何更改操作系统设置以支持本地化版本中的说明，正确设置这些操作系统设置。

虚拟操作系统支持

您可以在支持的操作系统和硬件上的 Microsoft 虚拟服务器和 Microsoft 虚拟 PC 上安装 SQL Server 2005。有关虚拟服务器的详细信息，请访问此 Microsoft 网站。有关虚拟 PC 的信息，请访问此 Microsoft 网站。

注意：
请不要在下面“硬件和软件要求”部分中未列出的硬件上的 Microsoft 虚拟服务器或 Microsoft 虚拟 PC 上安装 SQL Server 2005。

硬件和软件要求（仅 32 位）

硬件要求（32 位）

此表显示在 32 位平台上安装和运行 SQL Server 2005 的硬件要求。

SQL Server 2005（32 位） | 处理器类型1 | 处理器速度2 | 内存 (RAM)3
SQL Server 2005 Enterprise Edition 4 SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition | Pentium III 兼容处理器或更高速度的处理器 | 最低：600 MHz 建议：1 GHz 或更高 | 最小：512 MB 建议：1 GB 或更大 最大值：操作系统最大内存
SQL Server 2005 Workgroup Edition | Pentium III 兼容处理器或更高速度的处理器 | 最低：600 MHz 建议：1 GHz 或更高 | 最小：512 MB 建议：1 GB 或更大 最大值：操作系统最大内存
SQL Server 2005 Express Edition | Pentium III 兼容处理器或更高速度的处理器 | 最低：500 MHz 建议：1 GHz 或更高 | 最小：192 MB 建议：512 MB 或更高 最大值：操作系统最大内存
具有高级服务的 SQL Server 2005 Express Edition | Pentium III 兼容处理器或更高速度的处理器 | 最低：600 MHz 建议：1 GHz 或更高 | 最小：512 MB 建议：1 GB 或更大 最大值：操作系统最大内存

1如果不满足处理器类型的要求，系统配置检查器 (SCC) 将阻止安装程序运行。

2如果不满足最低或建议的处理器速度要求，SCC 将向用户发出警告但不会阻止安装程序运行。多处理器计算机上将不会出现警告。

3如果不满足最低或建议的 RAM 要求，SCC 将向用户发出警告但不会阻止安装程序运行。内存要求仅针对此版本，它不反映操作系统的其他内存要求。SCC 将在安装开始时确认内存是否可用。

4SQL Server Evaluation Edition 支持与 SQL Server 2005 Enterprise Edition 相同的功能集。

注意：
SQL Server 2005 软件运行在经验证可用于 Microsoft Windows 操作系统的硬件上。有关经过验证可用于 Windows 操作系统的硬件的详细信息，请参阅以下 Microsoft 网站：专用于 Microsoft Windows 的产品 - Windows 目录和 HCL（英文）。

硬盘空间要求（32 位和 64 位）

在安装 SQL Server 2005 的过程中，Windows 安装程序会在系统驱动器中创建临时文件。在运行安装程序以安装或升级到 SQL Server 2005 之前，请验证系统驱动器中是否具有 1.6 GB 的可用磁盘空间来存储这些文件。即使在将 SQL Server 组件安装到非默认驱动器中时，该要求也适用。

实际硬盘空间要求取决于系统配置和选择安装的应用程序和功能。下表显示了 SQL Server 2005 各组件对磁盘空间的要求。

功能 | 磁盘空间要求
数据库引擎和数据文件、复制以及全文搜索 | 150 MB
Analysis Services 和数据文件 | 35 MB
Reporting Services 和报表管理器 | 40 MB
Notification Services 引擎组件、客户端组件和规则组件 | 5 MB
Integration Services | 9 MB
客户端组件 | 12 MB
管理工具 | 70 MB
开发工具 | 20 MB
SQL Server 联机丛书和 SQL Server Mobile 联机丛书 | 15 MB
示例和示例数据库 | 390 MB

操作系统要求（32 位）

此表显示对于每种 32 位版本的 SQL Server 2005，操作系统是否可以运行其服务器软件。

 | Enterprise Edition1 | Developer Edition | Standard Edition | Workgroup Edition | Express Edition 和具有高级服务的 Express | Evaluation Edition
Windows 2000 | 否 | 否 | 否 | 否 | 否 | 否
Windows 2000 Professional Edition SP42，4 | 否 | 是 | 是 | 是 | 是 | 是
Windows 2000 Server SP42 | 是 | 是 | 是 | 是 | 是 | 是
Windows 2000 Advanced Server SP42 | 是 | 是 | 是 | 是 | 是 | 是
Windows 2000 Datacenter Edition SP42 | 是 | 是 | 是 | 是 | 是 | 是
嵌入式 Windows XP | 否 | 否 | 否 | 否 | 否 | 否
Windows XP Home Edition SP2 | 否 | 是 | 否 | 否 | 是? | 否
Windows XP Professional Edition SP24 | 否 | 是 | 是 | 是 | 是 | 是
Windows XP Media Edition SP2 | 否 | 是 | 是 | 是 | 是? | 是
Windows XP Tablet Edition SP2 | 否 | 是 | 是 | 是 | 是 | 是
Windows 2003 Server SP1 | 是 | 是 | 是 | 是 | 是 | 是
Windows 2003 Enterprise Edition SP1 | 是 | 是 | 是 | 是 | 是 | 是
Windows 2003 Datacenter Edition SP1 | 是 | 是 | 是 | 是 | 是 | 是
Windows 2003 Web Edition SP1 | 否 | 否 | 否 | 否 | 是 | 否
Windows Small Business Server 2003 Standard Edition SP1 | 是 | 是 | 是 | 是 | 是 | 是
Windows Small Business Server 2003 Premium Edition SP1 | 是 | 是 | 是 | 是 | 是 | 是
Windows 2003 64 位 Itanium Datacenter Edition SP1 | 否 | 否 | 否 | 否 | 否 | 否
Windows 2003 64 位 Itanium Enterprise Edition SP1 | 否 | 否 | 否 | 否 | 否 | 否
Windows 2003 64 位 X64 Standard Edition SP1 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643
Windows 2003 64 位 X64 Datacenter Edition SP1 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643
Windows 2003 64 位 X64 Enterprise Edition SP1 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643
Windows XP x64 Professional 2003 | 否 | WOW | WOW | WOW | WOW | 否

1SQL Server 2005 Evaluation Edition 支持与 SQL Server 2005 Enterprise Edition 相同的功能集，但并非所有支持 Evaluation Edition 的操作系统都支持 SQL Server 2005 Enterprise Edition。

2您可以从此 Microsoft 网站下载 Windows 2000 SP4。必须通过原始设备制造商 (OEM) 来获取 Windows 2000 Datacenter Edition 的 Service Pack。

3这些版本的 SQL Server 2005 可以安装到 64 位服务器的 Windows on Windows (WOW64) 32 位子系统中。

4您可以在 Windows 2000 Professional SP4 和 Windows XP SP2 上为 SQL Server 2005 Enterprise Edition 安装 Microsoft SQL Server 联机丛书、客户端工具和某些早期工具。客户端工具包括 SQL Server Management Studio 和 SQL Server 2005 软件开发包 Business Intelligence Development Studio。早期工具包括 Data Transformation Services 运行时和 SQL-DMO。

如果在安装具有高级服务的 SQL Server Express 时安装 Reporting Services，则不会在不含 Internet 信息服务 (IIS) 的操作系统上安装 Reporting Services。

以下限制或问题将影响在支持的操作系统上进行的安装：

  • 只有在 Windows 2003 上运行的 SQL Server 2005 实例中，才支持本机 Web 服务 (SOAP/HTTP)。

  • Microsoft SQL Server 2005 Integration Services (SSIS) 编程文档、分析管理对象 (AMO) 文档和 ADOMD.NET 文档中的单个主题可能说明支持以前版本的 Windows，如 Windows 98、Windows ME 或 Windows NT 4.0。但对于本版本，只有 Windows XP、Windows 2000 和 Windows 2003 支持这三个编程接口。

  • SQL Server 2005 故障转移群集要求至少在服务器群集的一个节点上运行 Microsoft Cluster Server (MSCS)。只有将 MSCS 安装在通过 MSCS 软件兼容性测试的硬件配置上，才支持 MSCS。有关详细信息，请参阅安装故障转移群集前的准备工作。

支持的客户端（32 位）

SQL Server 2005 32 位客户端组件可以安装到 Windows 2000 Professional SP4 或更高版本上。

注意：
此版本通过旧的 MDAC/DB-Library，而不是通过使用新的 SQL Server 2005 功能来支持表格格式数据流 (TDS) 4.2 客户端连接。

硬件和软件要求（仅 64 位）

硬件要求（64 位）

此表显示在 64 位平台上安装和运行 SQL Server 2005 的硬件要求。

SQL Server 2005（64 位） | 处理器类型1 | 处理器速度2 | 内存 (RAM)3
SQL Server 2005 Enterprise Edition 4 SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition | IA64 最低：Itanium 处理器或更高 X64 最低：AMD Opteron、AMD Athlon 64、支持 Intel EM64T 的 Intel Xenon、支持 EM64T 的 Intel Pentium IV | IA64 最低：1 GHz IA64 建议：1 GHz 或更高 X64 最低：1 GHz X64 建议：1 GHz 或更高 | IA64 最小：512 MB IA64 建议：1 GB 或更大 IA64 最大：32 TB 操作系统的最大内存允许的最小值：512 MB X64 建议：1 GB 或更大 X64 最高：操作系统的最大内存

1如果不满足处理器类型的要求，系统配置检查器 (SCC) 将阻止安装程序运行。

2如果不满足最低或建议的处理器速度要求，SCC 将向用户发出警告但不会阻止安装程序运行。

3如果不满足最低或建议的 RAM 要求，SCC 将向用户发出警告但不会阻止安装程序运行。内存要求仅针对此版本，它不反映操作系统的其他内存要求。SCC 将在安装开始时确认内存是否可用。

4SQL Server 2005 Evaluation Edition 支持的功能集与 SQL Server 2005 Enterprise Edition 相同。

注意：
SQL Server 2005 软件运行在经验证可用于 Microsoft Windows 操作系统的硬件上。有关经过验证可用于 Windows 操作系统的硬件的详细信息，请参阅以下 Microsoft 网站：专用于 Microsoft Windows 的产品 - Windows 目录和 HCL（英文）。有关安装高可用性解决方案的信息，请参阅配置高可用性。

操作系统要求（64 位）

此表显示对于每种 64 位版本的 SQL Server 2005，操作系统是否可以运行其服务器软件。

 | Enterprise Edition1(IA64) | Enterprise Edition1(X64) | Developer Edition (IA64)2 | Developer Edition (X64)3 | Standard Edition (IA64) | Standard Edition (X64) | Express Edition 和具有高级服务的 Express | Evaluation Edition (IA64) | Evaluation Edition (X64)
Windows 2003 64 位 Itanium Datacenter Edition SP1 | 支持4 | 否 | 支持4 | 否 | 支持4 | 否 | 否 | 支持4 | 否
Windows 2003 64 位 Itanium Enterprise Edition SP1 | 支持4 | 否 | 支持4 | 否 | 支持4 | 否 | 否 | 支持4 | 否
Windows 2003 64 位 X64 Standard Edition SP1 | 否 | 支持4 | 否 | 支持4 | 否 | 支持4 | WOW644 | 否 | 支持4
Windows 2003 64 位 X64 Datacenter Edition SP1 | 否 | 支持4 | 否 | 支持4 | 否 | 支持4 | WOW644 | 否 | 支持4
Windows 2003 64 位 X64 Enterprise Edition SP1 | 否 | 支持4 | 否 | 支持4 | 否 | 支持4 | WOW644 | 否 | 支持4
Windows XP x64 Professional 2003 | 否 | 支持4 | 否 | 支持4 | 否 | 支持4 | WOW64 | 否 | 支持4

1SQL Server 2005 Evaluation Edition 支持与 SQL Server 2005 Enterprise Edition 相同的功能集，但并非所有支持 Evaluation Edition 的操作系统都支持 Enterprise Edition。

2IA64 = Intel Itanium 体系结构。

3X64 = AMD 体系结构/Intel Extended Systems 体系结构。

4本机/WOW64 工具。有关 WOW64 的详细信息，请参阅“扩展系统支持”。

扩展系统支持

SQL Server 2005 64 位版本中包含对扩展系统的支持，也称为 Windows on Windows (WOW64)。WOW64 是 64 位版本的 Microsoft Windows 中的一个功能，使用该功能可以以 32 位模式在本机执行 32 位应用程序。尽管基本的操作系统是在 64 位平台上运行，但应用程序以 32 位模式工作。

支持的客户端（64 位）

在 Windows 2003（64 位）上，可以安装 SQL Server 2005 64 位客户端组件。

请参阅

参考

SQL Server 2005 的版本和组件
SQL Server 2005 的各种版本所支持的功能


系统配置检查器的检查参数

系统配置检查器的检查参数 |
 | 请参阅
准备安装 SQL Server 2005 >

作为 SQL Server 2005 安装程序的一部分，系统配置检查器 (SCC) 会扫描将安装 Microsoft SQL Server 2005 的计算机。SCC 将检查会使安装无法成功 SQL Server 的情况。安装程序启动 SQL Server 2005 安装向导之前，SCC 将检索每个检查项的状态，将结果与所要求的条件进行比较，并提供解决妨碍性问题的相关指导。所有 SCC 检查项均支持网络；检查不仅可以在本地计算机上运行，也可以在远程和群集情况中运行。

下表说明了 SCC 的检查参数、要求以及使安装程序可以成功安装 SQL Server 2005 的补救方法。

检查项 说明 失败补救方法

Windows Management Instrumentation (WMI) 服务要求

WMI 服务必须可用。如果对此项的检查失败，将阻止安装。

SCC 将报告不兼容问题。

Microsoft XML Core Services (MSXML) 要求

某些 SQL Server 2005 组件需要 MSXML。如果需要，SQL Server 安装程序将安装它。

这不是安装程序的妨碍性问题。

操作系统最低级别要求

SCC 检查操作系统的最低要求。

有关详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。

操作系统版本和 service pack (SP) 级别要求

需要 Microsoft Windows 2000 SP4、Microsoft Windows XP SP2 或 Microsoft Windows Server 2003。任何不受支持的操作系统都将阻塞安装程序。

注意：
如果不通过原始设备制造商 (OEM)，用户无法将 service pack 应用到 Datacenter 操作系统版本中。

用户被引导至联机帮助以查看操作系统要求，或被引导至 Windows Update 组件以在目标计算机上安装 Windows Service Pack。如果计算机运行的是 Datacenter 版本，用户必须与 OEM 联系有关 Service Pack 安装的问题。有关详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。

SQL Server 的操作系统兼容性要求

操作系统类型必须支持给定的 SQL Server 版本。例如，SQL Server Enterprise Edition 只能安装在 Windows 2000 或更高版本上。如果对此项的检查失败，将阻止安装。

用户被引导至联机帮助以查看操作系统和 SQL Server 版本矩阵。有关详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。

最低硬件要求

硬件必须满足最低 CPU 和内存要求。如果不满足最低或建议的处理器速度要求，SCC 将向用户发出警告，但不会阻止安装程序运行。多处理器计算机上将不会出现警告。

SCC 将在安装开始时确认内存是否可用。如果不满足最低或建议的 RAM 要求，SCC 将向用户发出警告，但不会阻止安装程序运行。内存要求仅针对此版本，它不反映操作系统的其他内存要求。

有关详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。

功能可用性1,2

在显示可以安装的 SQL Server 组件之前，SQL Server 功能选择树将检查必备组件。

SCC 在 SCC 报告中显示结果，包括不可用的功能及其依赖项。

挂起的重新启动要求

如果安装程序所需的文件被其他服务、进程或应用程序锁定，SQL Server 安装程序将无法运行。如果对此项的检查失败，将阻止安装。

SCC 将建议用户重新启动操作系统，然后再次运行安装程序。

性能监视器计数器要求

SCC 检查注册表项的值以验证 SQL Server perfmon 计数器安装的增量是否正确。如果对此项的检查失败，将阻止安装。

用户必须更新注册表。若要手动更新注册表项，请参阅如何在 SQL Server 2005 中为安装程序增加计数器注册表项值。

默认安装路径权限要求

SCC 将验证驱动器格式和读写权限。安装程序还要求在未压缩的驱动器上安装 SQL Server。如果对此项的检查失败，将阻止安装。

如果驱动器未格式化、为只读或经过压缩，SCC 将生成错误。

COM+ 目录要求

SCC 将验证当前 COM+ 目录配置。

SCC 将识别问题并提出建议。有关详细信息，请参阅 SQL Server 2005 CD 上的自述文件或安装程序已知问题文档。

系统管理员特权要求

运行安装程序的用户必须在下列所有目标计算机上都拥有管理员特权：本地、远程以及将安装 SQL Server 的所有群集节点。

SCC 将通知用户先注销，然后在向此帐户添加管理员特权后再次登录，或使用另一个拥有管理员特权的帐户再次登录。

启用默认管理共享目录要求（仅限于远程／群集）

所有群集节点上必须启用了默认管理共享 admin$，以使群集安装进程可以访问其系统文件。如果对此项的检查失败，将阻止安装。

SCC 将请求通过启用此默认共享目录来解决该问题。

1安装 Reporting Services 需要 Microsoft Internet Information Services (IIS) 5.0 或更高版本。

2安装 Reporting Services 的报表设计器组件需要 Microsoft Internet Explorer 6.0 SP1。

请参阅

参考

安装 SQL Server 2005 的硬件和软件要求


安装 SQL Server 的安全注意事项

安装 SQL Server 的安全注意事项 |
 | 请参阅
准备安装 SQL Server 2005 >

安全很重要，这不只是对 Microsoft SQL Server 和 Microsoft 而言的，而是对每个产品和每家企业都很重要。遵循简单的最佳做法，可以避免很多安全漏洞。本主题讨论安装 SQL Server 之前和安装 SQL Server 之后应使用的一些最佳安全做法。功能的参考主题中包括了特定功能的安全指南。

安装 SQL Server 前的工作

设置服务器环境时，请遵循以下最佳做法：

  • 增强物理安全性

  • 使用防火墙

  • 隔离服务

  • 创建具有最低特权的服务帐户

  • 配置安全的文件系统

  • 禁用 NetBIOS 和服务器消息块

增强物理安全性

物理和逻辑隔离是构成 SQL Server 安全的基础。若要增强 SQL Server 安装的物理安全性，请执行以下任务：

  • 将服务器置于专门的房间，未经授权的人员不得入内。

  • 将数据库的宿主计算机置于受物理保护的场所，最好是上锁的机房，房中配备水灾检测和火灾检测监视系统或灭火系统。

  • 将数据库安装在公司 Intranet 的安全区域中，任何时候都不要直接连接到 Internet。

  • 定期备份所有数据，并将副本存储在远离工作现场的安全位置。

使用防火墙

防火墙是保护 SQL Server 安装所不可或缺的。若要使防火墙发挥最佳效用，请遵循以下指南：

  • 在服务器和 Internet 之间放置防火墙。

  • 将网络分成若干安全区域，区域之间用防火墙分隔。先阻塞所有通信流量，然后有选择地只接受所需的通信。

  • 在多层环境中，使用多个防火墙创建屏蔽子网。

  • 如果在 Windows 域内部安装服务器，请将内部防火墙配置为允许 Windows 身份验证。

  • 在所有版本的 Windows 都是 Windows XP、Windows Server 2003 或更高版本的 Windows 域中，禁用 NTLM 身份验证。 .

  • 如果应用程序使用分布式事务处理，可能必须要将防火墙配置为允许 Microsoft 分布式事务处理协调器 (MS DTC) 在不同的 MS DTC 实例之间以及在 MS DTC 和资源管理器（如 SQL Server）之间进行通信。

隔离服务

隔离服务可以降低风险，防止已受到危害的服务被用于危及其他服务。若要隔离服务，请遵循以下指南：

  • 请尽可能不要在域控制器中安装 SQL Server。

  • 在不同的 Windows 帐户下运行各自的 SQL Server 服务。

  • 在多层环境中，在不同的计算机上运行 Web 逻辑和业务逻辑。

创建具有最低特权的服务帐户

SQL Server 安装程序可以自动配置服务帐户或具有 SQL Server 所需特定权限的帐户。修改或配置 SQL Server 2005 使用的 Windows 服务时，应仅授予它们需要的权限。有关详细信息，请参阅设置 Windows 服务帐户。

禁用 NetBIOS 和服务器消息块

边界网络中的服务器应禁用所有不必要的协议，包括 NetBIOS 和服务器消息块 (SMB)。

NetBIOS 使用以下端口：

  • UDP/137（NetBIOS 名称服务）

  • UDP/138（NetBIOS 数据报服务）

  • TCP/139（NetBIOS 会话服务）

SMB 使用以下端口：

  • TCP/139

  • TCP/445

Web 服务器和域名系统 (DNS) 服务器不需要 NetBIOS 或 SMB。在这些服务器上，禁用这两个协议可以缓解用户枚举的威胁。有关如何禁用这些协议的详细信息，请参阅如何禁用基于 TCP/IP 的 NetBIOS 和如何禁用服务器消息块。

安装 SQL Server 后的工作

安装完成后，若要增强所安装的 SQL Server 软件的安全性，请遵循以下有关帐户和身份验证模式的最佳做法：

服务帐户

  • 以可能的最低特权运行 SQL Server 服务。

  • 将 SQL Server 服务与 Windows 帐户相关联。

身份验证模式

  • 连接 SQL Server 时要求 Windows 身份验证。

强密码

  • 始终给 sa 帐户分配强密码。

  • 始终启用密码策略检查。

  • 始终对所有 SQL Server 登录名使用强密码。

请参阅

其他资源

密码策略


设置 Windows 服务帐户

设置 Windows 服务帐户 |
 | 请参阅
准备安装 SQL Server 2005 >

根据您选择要安装的 Microsoft SQL Server 组件，SQL Server 2005 安装程序可安装以下十种服务：

  • SQL Server Database Services

  • SQL Server 代理

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • 全文搜索

  • SQL Server 浏览器

  • SQL Server Active Directory Helper

  • SQL 编写器

注意：
SQL Server 和 SQL Server 代理在所有支持的操作系统上都作为 Microsoft Windows 服务来运行。由于 SQL Server 和 SQL Server 代理在 Windows 中作为服务来运行，因此必须给 SQL Server 和 SQL Server 代理指派 Windows 用户帐户。通常，给 SQL Server 和 SQL Server 代理指派相同的用户帐户，要么是 Local System 用户帐户要么是 Domain User 帐户。但是，也可以在安装过程中为每个服务自定义设置。有关如何为每个服务自定义帐户信息的详细信息，请参阅服务帐户。

SQL Server 中的每个服务代表一个进程或一组进程，用于在 Microsoft Windows 中管理 SQL Server 操作的身份验证。

安全说明：
始终以尽可能低的特权运行 SQL Server 服务。

本主题的其余部分提供的信息有助于了解默认行为，还有助于为您安装的 SQL Server 配置 SQL Server 服务帐户：

  • 配置 SQL Server 安装程序中出现的服务

    有些服务可在安装期间进行配置，而其他服务必须在安装完成后才能配置。

  • 辨别识别实例的服务和不识别实例的服务

    有些服务是识别实例的服务。即，这些服务专用于服务器上的特定 SQL Server 实例。不识别实例的服务由服务器上的所有 SQL Server 实例共享。

  • 本地化的服务名称

  • 使用 SQL Server 服务的启动帐户

  • 查看为 SQL Server 服务帐户授予的 NT 权限和特权

  • 查看 SQL Server 服务的 Windows 权限

  • 查看其他注意事项

配置 SQL Server 安装程序中出现的服务

不是所有的 SQL Server 服务都可通过 SQL Server 安装程序来配置。对于可在安装时配置的服务，仅限于配置启动帐户以及该帐户是否自动启动。不能在安装时配置的服务以默认设置进行安装。

下表显示了 SQL Server 安装向导中出现的各 SQL Server 服务以及这些服务是否可在安装期间进行配置。对于无人参与的安装，该表还提供了可通过安装文件或命令提示符进行安装的每个服务所用的开关。

SQL Server 服务名称 | 是否可在安装向导中配置？ | 无人参与安装的开关1
MSSQLSERVER | 是 | SQLACCOUNT、SQLPASSWORD、SQLAUTOSTART
SQLServerAgent | 是 | AGTACCOUNT、AGTPASSWORD、AGTAUTOSTART
MSSQLServerOLAPService | 是 | ASACCOUNT、ASPASSWORD、ASAUTOSTART
ReportServer | 是 | RSACCOUNT、RSPASSWORD、RSAUTOSTART
NotificationServices | 否 | 无
MSDTSServer | 否 | 无
MSFTESQL | 否 | 无
SQLBrowser | 是 | SQLBROWSERACCOUNT、SQLBROWSERPASSWORD、SQLBROWSERAUTOSTART2
MSSQLServerADHelper | 否 | 无
SQLWriter | 否 | 无

1有关远程安装和无人参与的安装的详细信息和示例语法，请参阅如何从命令提示符安装 SQL Server 2005。

2即使已安装 SQL Server 浏览器，仍可指定 SQLBROWSERAUTOSTART。

辨别识别实例的服务和不识别实例的服务

有些 SQL Server 服务是识别实例的服务，而其他服务是不识别实例的服务。

辨别识别实例的服务

每个识别实例的服务都与某个特定 SQL Server 实例相关联，并且具有自己的注册表配置单元。通过为每个组件或服务的安装运行 SQL Server 安装程序，可以安装识别实例服务的多个副本。

在 Microsoft SQL Server 2005 中，识别实例的服务包括：

  • SQL Server

  • SQL Server 代理

  • 分析服务器

  • 报表服务器

  • 全文搜索

请注意，共享同一实例名称的所有 SQL Server 组件必须满足以下条件：

  • 版本相同。例如，不能在一台计算机上安装同名的 SQL Server 2005 Analysis Services (SSAS) 实例和 SQL Server 2000 数据库引擎 实例。此外，将具有给定实例名的一个组件升级到新版本或新 Service Pack 时，必须升级该实例的所有组件。

  • 版本类别相同。例如，不能在一台计算机上安装同名的 SQL Server 2005 Integration Services (SSIS) Evaluation Edition 实例和 SQL Server 2005 数据库引擎 Enterprise Edition 实例。

  • 语言相同。例如，不能在同一台计算机上安装同名的德语 SQL Server 2005 数据库引擎 实例和葡萄牙语（巴西）SQL Server Management Studio 实例。

  • 群集状态相同。例如，不能在同一台计算机上安装同名的 SQL Server 2005 Analysis Services (SSAS) 群集实例和 SQL Server 2005 数据库引擎 非群集实例。

    注意：
    Reporting Services 不是识别群集的服务。

  • 平台相同。例如，不能安装同名的 Business Intelligence Development Studio（32 位）实例和 SQL Server 2005 数据库引擎（64 位）实例。

辨别不识别实例的服务

不识别实例的服务由所有已安装的 SQL Server 实例共享；它们不与特定实例相关联，仅安装一次且不能并行安装。在 SQL Server 2005 中，不识别实例的服务包括：

  • Notification Services

  • Integration Services

  • SQL Server 浏览器

  • SQL Server Active Directory Helper

  • SQL 编写器

本地化的服务名称

下表显示了 Microsoft Windows 的本地化版本所使用的服务名称。

语言 | Local Service 的名称 | Network Service 的名称 | Local System 的名称 | Admin Group 的名称
英语 简体中文 繁体中文 朝鲜语 日语 | NT AUTHORITY\LOCAL SERVICE | NT AUTHORITY\NETWORK SERVICE | NT AUTHORITY\SYSTEM | BUILTIN\Administrators
德语 | NT-AUTORIT?T\LOKALER DIENST | NT-AUTORIT?T\NETZWERKDIENST | NT-AUTORIT?T\SYSTEM | VORDEFINIERT\Administratoren
法语 | AUTORITE NT\SERVICE LOCAL | AUTORITE NT\SERVICE RESEAU | AUTORITE NT\SYSTEM | BUILTIN\Administrateurs
意大利语 | NT AUTHORITY\SERVIZIO LOCALE | NT AUTHORITY\SERVIZIO DI RETE | NT AUTHORITY\SYSTEM | BUILTIN\Administrators
西班牙语 | NT AUTHORITY\SERVICIO LOC | NT AUTHORITY\SERVICIO DE RED | NT AUTHORITY\SYSTEM | BUILTIN\Administradores

使用 SQL Server 服务的启动帐户

为了启动和运行，SQL Server 2005 中的每个服务必须具有用户帐户。用户帐户可以是内置系统帐户或 Domain User 帐户。

除具有用户帐户外，每个服务还有用户可控制的三种可能的启动状态：

  • 已禁用 服务已安装但当前未运行。

  • 手动 服务已安装但仅当另一个服务或应用程序需要该服务的功能时才启动。

  • 自动 在引导时加载设备驱动程序后，操作系统启动该服务。

下表显示了每个 SQL Server 服务的默认帐户和可选帐户，以及每个服务的启动状态。

SQL Server 服务名称 | 默认帐户 | 可选帐户 | 启动类型 | 安装后的默认状态
SQL Server | Windows 2000 上的 SQL Server Express Edition：Local System 所有其他支持的操作系统上的 SQL Server Express Edition：Network Service 所有支持的操作系统上的所有其他版本类别：Domain User1 | SQL Server Express Edition：Domain User、Local System、Network Service1 所有其他版本：Domain User、Local System、Network Service1 | 自动2 | 已启动 仅当用户选择不自动启动时才停止
SQL Server 代理 | Domain User3 | Domain User、Local System、Network Service1.6 | 已禁用 仅当用户选择自动启动时才成为“自动” | 已停止 仅当用户选择自动启动时才启动
分析服务器 | Domain User3 | Domain User、Local System、Network Service、Local Service | 自动 | 已启动 仅当用户选择不自动启动时才停止
报表服务器 | Domain User3 | Domain User、Local System、Network Service、Local Service | 自动 | 已启动 仅当用户选择不自动启动时才停止
Notification Services4 | 不适用 | 不适用 | 不适用 | 不适用
Integration Services | Windows 2000：Local System 所有其他支持的操作系统：Network Service | Domain User、Local System、Network Service、Local Service | 自动 | 已启动 仅当用户选择不自动启动时才停止。
全文搜索 | 与 SQL Server 的帐户相同 | Domain User、Local System、Network Service、Local Service | 手动 | 已停止 仅当用户选择自动启动时才启动。
SQL Server 浏览器 | Windows 2000 上的 SQL Server Express Edition：Local System 所有其他支持的操作系统上的 SQL Server Express Edition：Local Service 所有支持的操作系统上的所有其他版本类别：Domain User1,3 | Domain User、Local System、Network Service、Local Service | 已禁用5 仅当用户选择自动启动时才成为“自动”。 | 已停止5 仅当用户选择自动启动时才启动。
SQL Server Active Directory Helper | Network Service | Local System、Network Service | 已禁用 | 已停止
SQL 编写器 | Local System | Local System | 手动 | 已停止

1重要提示 Microsoft 建议，对于 SQL Server 服务或 SQL Server 代理服务，不要使用 Network Service 帐户。本地用户帐户或域用户帐户更适用于这些 SQL Server 服务。

2在故障转移群集配置中设置为手动。

3对于无人参与的安装，此属性是必需的。如果未指定此属性，安装程序将失败。若要指定 Local System，请使用 SQLAccount=LocalSystem 或 ASAccount=LocalSystem。有关远程安装和无人参与的安装的详细信息和示例语法，请参阅如何从命令提示符安装 SQL Server 2005。

4SQL Server 安装程序可安装但不配置 Notification Services。有关安装后启用 Notification Services 的详细信息，请参阅 SQL Server 2005 联机丛书中的“配置 Notification Services Windows 服务”主题。

5对于故障转移群集安装，SQL Server 浏览器设置为自动启动，并且默认情况下为在安装后启动。

6有关用于 SQL Server 代理的受支持 Windows 帐户的详细信息，请参阅 The supported Windows account types that you can use to run the SQL Server Agent service in SQL Server 2005。

重要事项：
对于故障转移群集安装，不允许将 Local System 帐户和 Local Service 帐户用于 SQL Server、SQL Server 代理和 SSAS 等群集服务。有关详细信息，请参阅安装故障转移群集前的准备工作。

使用域用户帐户

当服务必须与网络服务交互时，应首选 Domain User 帐户。许多服务器到服务器的活动只能使用域用户帐户来执行，例如：

  • 远程过程调用。

  • 复制。

  • 备份到网络驱动器。

  • 涉及远程数据源的异类联接。

  • SQL Server 代理邮件功能和 SQL Mail。如果使用 Microsoft Exchange 则受此限制。大多数其他邮件系统同样要求客户端（如 SQL Server 服务和 SQL Server 代理服务）以具有网络访问权限的帐户运行。

使用 Local Service 帐户

本地服务帐户是一个特殊的内置帐户，它与通过身份验证的用户帐户类似。本地服务帐户与 Users 组的成员具有相同级别的资源和对象访问权限。如果有个别服务或进程的安全受到威胁，则此有限访问权限有助于保护系统的安全。以本地服务帐户身份运行的服务将以一个没有凭据的空会话形式访问网络资源。

使用 Network Service 帐户

网络服务帐户是一个特殊的内置帐户，它与通过身份验证的用户帐户类似。网络服务帐户与 Users 组的成员具有相同级别的资源和对象访问权限。以网络服务帐户身份运行的服务将使用计算机帐户的凭据访问网络资源。

重要事项：
Microsoft 建议，对于 SQL Server 服务或 SQL Server 代理服务，不要使用 Network Service 帐户。本地用户帐户或域用户帐户更适用于这些 SQL 服务。

使用 Local System 帐户

Local System 帐户是一个高特权帐户；向 SQL Server 服务帐户分配 Local System 权限时应谨慎。

安全说明：
要增强安装的 SQL Server 的安全性，请使用权限尽可能低的本地 Windows 帐户运行 SQL Server 服务。

更改用户帐户

若要更改任何 SQL Server 相关服务的密码或其他属性，请使用 SQL Server 配置管理器。如果 Windows 密码发生了更改，请确保更新 Windows 中的 SQL Server 服务设置。如果启用了 Kerberos，请确保更新 Active Directory 的服务主体名称 (SPN) 目录属性。

有关详细信息，请参阅更改密码和用户帐户。

查看为 SQL Server 服务帐户授予的 Windows NT 权限和特权

SQL Server 安装程序为不同的 SQL Server 服务创建用户组，并根据需要向这些用户组添加服务帐户。这些组可以简化运行 SQL Server 服务和其他可执行文件所需权限的授予过程，并有助于增加 SQL Server 文件的安全性。请注意，在域控制器上安装 SQL Server 2005 时，组名必须唯一。

由 SQL Server 安装程序创建的用户组被授予以下 Windows NT 权限和特权：

SQL Server 服务 用户组 SQL Server 安装程序授予的默认权限

SQL Server

默认实例：SQLServer2005MSSQLUser$ComputerName$MSSQLSERVER

命名实例：SQLServer2005MSSQLUser$ComputerName$InstanceName

以服务身份登录 (SeServiceLogonRight)

充当操作系统的一部分 (SeTcbPrivilege)（仅限 Windows 2000）

以批处理作业身份登录 (SeBatchLogonRight)

替换进程级别标记 (SeAssignPrimaryTokenPrivilege)

跳过遍历检查 (SeChangeNotifyPrivilege)

调整进程的内存配额 (SeIncreaseQuotaPrivilege)

启动 SQL Server Active Directory Helper 的权限

启动 SQL 编写器的权限

SQL Server 代理

默认实例：SQLServer2005SQLAgentUser$ComputerName$MSSQLSERVER

命名实例：SQLServer2005SQLAgentUser$ComputerName$InstanceName

以服务身份登录 (SeServiceLogonRight)

充当操作系统的一部分 (SeTcbPrivilege)（仅限 Windows 2000）

以批处理作业身份登录 (SeBatchLogonRight)

替换进程级别标记 (SeAssignPrimaryTokenPrivilege)

跳过遍历检查 (SeChangeNotifyPrivilege)

调整进程的内存配额 (SeIncreaseQuotaPrivilege)

分析服务器

默认实例：SQLServer2005MSOLAPUser$ComputerName$MSSQLSERVER

命名实例：SQLServer2005MSOLAPUser$ComputerName$InstanceName

以服务身份登录 (SeServiceLogonRight)

报表服务器1

默认实例：SQLServer2005ReportServerUser$ComputerName$MSSQLSERVER and SQLServer2005ReportingServicesWebServiceUser$ComputerName$MSSQLSERVER

命名实例：SQLServer2005ReportServerUser$ComputerName$InstanceName and SQLServer2005ReportingServicesWebServiceUser$ComputerName$InstanceName

以服务身份登录 (SeServiceLogonRight)

Notification Services2

默认实例或命名实例：SQLServer2005NotificationServicesUser$ComputerName

不适用

Integration Services

默认实例或命名实例：SQLServer2005DTSUser$ComputerName

以服务身份登录 (SeServiceLogonRight)

应用程序事件日志的写入权限。

跳过遍历检查 (SeChangeNotifyPrivilege)

创建全局对象 (SeCreateGlobalPrivilege)

身份验证后模拟客户端 (SeImpersonatePrivilege)

全文搜索

默认实例：SQLServer2005MSFTEUser$ComputerName$MSSQLSERVER

命名实例：SQLServer2005MSFTEUser$ComputerName$InstanceName

以服务身份登录 (SeServiceLogonRight)

SQL Server 浏览器

默认实例或命名实例：SQLServer2005SQLBrowserUser$ComputerName

以服务身份登录 (SeServiceLogonRight)

SQL Server Active Directory Helper

默认实例或命名实例：SQLServer2005MSSQLServerADHelperUser$ComputerName

无3

SQL 编写器

不适用

无3

1对于 Reporting Services，SQL Server 安装程序还必须创建“SQLServer2005ReportingServicesWebServiceUser$实例名”用户组和“SQLServer2005ASP.NETUser”用户组，并授予它们访问控制列表 (ACL) 权限。有关详细信息，请参阅下面有关访问控制列表的部分。

2SQL Server 安装程序可安装但不配置 Notification Services。有关安装后启用 Notification Services 的详细信息，请参阅 SQL Server 2005 联机丛书中的“配置 Notification Services Windows 服务”主题。

3SQL Server 安装程序不检查此服务或为其授予权限。

查看为 SQL Server 服务帐户创建的访问控制列表

SQL Server 2005 服务帐户必须具有对资源的访问权限。访问控制列表 (ACL) 是在用户组级别设置的。下表列出了 SQL Server 安装程序设置的访问控制列表 (ACL)。

重要事项：
对于故障转移群集安装，不能为本地用户组中的任何 ACL 设置共享磁盘上的资源。而要为本地帐户的 ACL 设置这些资源。

服务帐户所属服务 | 文件和文件夹 | 访问权限
MSSQLServer | Instid\MSSQL\backup | 完全控制
 | Instid\MSSQL\binn | 读取、执行
 | Instid\MSSQL\data | 完全控制
 | Instid\MSSQL\FTData | 完全控制
 | Instid\MSSQL\Install | 读取、执行
 | Instid\MSSQL\Log | 完全控制
 | Instid\MSSQL\Repldata | 完全控制
 | 90\shared | 读取、执行
 | 90\shared\Errordumps | 读取、写入
 | 90\com | 读取、执行
 | Instid\MSSQL\Template Data（仅限 SQL Server Express） | 读取
SQLServerAgent | Instid\MSSQL\binn | 完全控制
 | Instid\MSSQL\Log | 完全控制
 | Instid\MSSQL\jobs | 完全控制
 | 90\com | 读取、执行
 | 90\shared | 读取、执行
 | 90\shared\Errordumps | 读取、写入
FTS | Instid\MSSQL\FTData | 完全控制
 | Instid\MSSQL\FTRef | 读取、执行
 | 90\shared | 读取、执行
 | 90\shared\Errordumps | 读取、写入
 | Instid\MSSQL\Install | 读取、执行
MSSQLServerOLAPservice | 90\shared | 读取、执行
 | 90\shared\msmdlocal.ini | 完全控制
 | Instid\OLAP | 读取、执行
 | Instid\Olap\Data | 完全控制
 | Instid\Olap\Log | 读取、写入
 | 90\shared\Errordumps | 读取、写入
SQLServer2005ReportServerUser | Instid\Reporting Services\Log Files | 读取、写入、删除
 | Instid\Reporting Services\ReportServer | 读取、执行
 | Instid\Reportingservices\Reportserver\global.asax | 完全控制
 | Instid\Reportingservices\Reportserver\Reportserver.config | 读取、写入
 | Instid\Reporting Services\reportManager | 读取、执行
 | Instid\Reporting Services\RSTempfiles | 读取、写入
 | 90\shared | 读取、执行
 | 90\shared\Errordumps | 读取、写入
SQLServer2005ReportingServicesWebServiceUser | Instid\Reporting Services\Log Files | 读取、写入、删除
 | Instid\Reporting Services\ReportServer | 读取、执行
 | Instid\Reportingservices\Reportserver\global.asax | 完全控制
 | InstID\Reporting Services\reportservice.asmx | 完全控制
 | Instid\Reportingservices\Reportserver\Reportserver.config | 读取、写入、删除
 | Instid\Reporting Services\reportManager | 读取、执行
 | Instid\Reporting Services\RSTempfiles | 读取、写入
 | Instid\Reporting Services\reportManager\pages | 读取
 | Instid\Reporting Services\reportManager\Styles | 读取
 | Instid\Reporting Services\reportManager\webctrl_client\1_0 | 读取
 | 90\shared | 读取、执行
 | 90\shared\Errordumps | 读取、写入
Notification services | 90\Notification services | 读取、执行、列出文件夹内容
 | 90\shared | 读取、执行
 | 90\shared\Errordumps | 读取、写入
MSDTSServer | 90\dts\binn\MsDtsSrvr.ini.xml | 读取
 | 90\dts\binn | 读取、执行
 | 90\shared | 读取、执行
 | 90\shared\Errordumps | 读取、写入
SQL Server 浏览器 | 90\shared\msmdlocal.ini | 读取
 | 90\shared | 读取、执行
 | 90\shared\Errordumps | 读取、写入
MSADHekper | 不适用（以内置帐户身份运行） |
SQLWriter | 不适用（以 Local System 身份运行） |
用户 | Instid\MSSQL\binn | 读取、执行
 | Instid\Reporting Services\ReportServer | 读取、执行
 | Instid\Reportingservices\Reportserver\global.asax | 读取
 | InstID\Reporting Services\reportservice.asmx | 读取、执行
 | Instid\Reporting Services\reportManager | 读取、执行
 | Instid\Reporting Services\reportManager\pages | 读取
 | Instid\Reporting Services\reportManager\Styles | 读取
 | 90\dts | 读取、执行
 | 90\tools | 读取、执行
 | 80\tools | 读取、执行
 | 90\sdk | 读取
 | Microsoft SQL Server\90\Setup Bootstrap | 读取、执行

除 SQL Server 服务启动帐户外，可能还必须向内置帐户或其他 SQL Server 服务帐户授予访问控制权限。下表列出了 SQL Server 安装程序设置的其他 ACL。

请求组件 | 帐户 | 资源 | 权限
MSSQLServer | 性能日志用户 | Instid\MSSQL\binn | 列出文件夹内容
 | 性能监视器用户 | Instid\MSSQL\binn | 列出文件夹内容
 | 性能日志用户 | Instid\MSSQL\binn\sqlctr90.dll | 读取、执行
 | 性能监视器用户 | Instid\MSSQL\binn\sqlctr90.dll | 读取、执行
 | 仅限于管理员 | \\.\root\Microsoft\SqlServer\ServerEvents\<sql_instance_name>1 | 完全控制
 | 管理员 | \tools\binn\schemas\sqlserver\2003\03\showplan | 完全控制
 | 系统 | \tools\binn\schemas\sqlserver\2003\03\showplan | 完全控制
 | 用户 | \tools\binn\schemas\sqlserver\2003\03\showplan | 读取、执行
Reporting services | <报表服务器 Web 服务帐户> | <安装目录>\Reporting Services\LogFiles | DELETE READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_WRITE FILE_READ_DATA FILE_WRITE_DATA FILE_APPEND_DATA FILE_READ_EA FILE_WRITE_EA FILE_READ_ATTRIBUTES FILE_WRITE_ATTRIBUTES
 | 报表管理器应用程序池标识 | <安装目录>\Reporting Services\ReportManager | 读
 | ASP.NET 帐户 | <安装目录>\Reporting Services\ReportManager | 读
 | Everyone | <安装目录>\Reporting Services\ReportManager | 读
 | 报表管理器应用程序池标识 | <安装目录>\Reporting Serivces\ReportManager\Pages\*.* | 读
 | ASP.NET 帐户 | <安装目录>\Reporting Serivces\ReportManager\Pages\*.* | 读
 | Everyone | <安装目录>\Reporting Serivces\ReportManager\Pages\*.* | 读
 | 报表管理器应用程序池标识 | <安装目录>\Reporting Serivces\ReportManager\Styles\*.* | 读
 | ASP.NET 帐户 | <安装目录>\Reporting Serivces\ReportManager\Styles\*.* | 读
 | Everyone | <安装目录>\Reporting Serivces\ReportManager\Styles\*.* | 读
 | 报表管理器应用程序池标识 | <安装目录>\Reporting Serivces\ReportManager\webctrl_client\1_0\*.* | 读
 | ASP.NET 帐户 | <安装目录>\Reporting Serivces\ReportManager\webctrl_client\1_0\*.* | 读
 | Everyone | <安装目录>\Reporting Serivces\ReportManager\webctrl_client\1_0\*.* | 读
 | <报表服务器 Web 服务帐户> | <安装目录>\Reporting Services\ReportServer | 读
 | <报表服务器 Web 服务帐户> | <安装目录>\Reporting Services\ReportServer\global.asax | 完全
 | Everyone | <安装目录>\Reporting Services\ReportServer\global.asax | READ_CONTROL FILE_READ_DATA FILE_READ_EA FILE_READ_ATTRIBUTES
 | Network Service | <安装目录>\Reporting Services\ReportServer\ReportService.asmx | 完全
 | Everyone | <安装目录>\Reporting Services\ReportServer\ReportService.asmx | READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_EXECUTE FILE_READ_DATA FILE_READ_EA FILE_EXECUTE FILE_READ_ATTRIBUTES
 | ReportServer Windows 服务帐户 | <安装目录>\Reporting Services\ReportServer\RSReportServer.config | DELETE READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_WRITE FILE_READ_DATA FILE_WRITE_DATA FILE_APPEND_DATA FILE_READ_EA FILE_WRITE_EA FILE_READ_ATTRIBUTES FILE_WRITE_ATTRIBUTES
 | Everyone | 报表服务器密钥（Instid 配置单元） | 查询值 枚举子项 通知 读取控制
 | 终端服务用户 | 报表服务器密钥（Instid 配置单元） | 查询值 设置值 创建子项 枚举子项 通知 删除 读取控制
 | 超级用户 | 报表服务器密钥（Instid 配置单元） | 查询值 设置值 创建子项 枚举子项 通知 删除 读取控制

1这是 WMI 提供程序命名空间。

查看 SQL Server 服务的 Windows 权限

下表显示服务名称、用于指代 SQL Server 服务的默认实例和命名实例的术语、服务功能的说明以及所需的最低权限。

显示名称 服务名称 说明 所需的权限

SQL Server (实例名)

默认实例：MSSQLSERVER

命名实例：MSSQL$实例名

SQL Server 数据库引擎.

执行文件的路径为 \MSSQL\Binn\sqlservr.exe。

建议使用本地用户。

最低权限 功能

MSSQLServer 服务启动帐户

该帐户必须对安装 SQL Server 的根驱动器以及存储 SQL Server 文件的任何其他驱动器的根目录具有“列出文件夹”权限。

注意：
子文件夹不必继承根驱动器的“列出文件夹”权限。

MSSQLServer 服务启动帐户

该帐户必须对数据或日志文件（.mdf、.ndf、.ldf）将驻留的任何文件夹都有“完全控制”权限。

SQL Server 代理 (实例名)

默认实例：SQLServerAgent

命名实例：SQLAgent$实例名

执行作业、监视 SQL Server、激发警报以及允许自动执行某些管理任务。

其可执行文件的路径为 \MSSQL\Binn\sqlagent90.exe。

最低权限 | 功能
该帐户必须是 sysadmin 固定服务器角色的成员。 |
该帐户必须具有以下 Windows 权限1 | 以服务身份登录。 以批处理作业身份登录。 替换进程级别标记。 调整进程的内存配额。 充当操作系统的一部分。 跳过遍历检查。

Analysis Services 服务 (实例名)

默认实例：MSSQLServerOLAPService

命名实例：MSOLAP$实例名

为商业智能应用程序提供联机分析处理 (OLAP) 和数据挖掘功能的服务。

其可执行文件的路径为 \OLAP\Bin\msmdsrv.exe。

报表服务器

默认实例：ReportServer

命名实例：ReportServer$实例名

管理、执行、呈现、计划和传递报表。

其可执行文件的路径为 \Reporting Services\ReportServer\Bin\ReportingServicesService.exe。

Notification Services

Notification Services 是生成并发送通知的应用程序的开发和部署平台。SQL Server 安装程序可安装但不配置 Notification Services。有关安装后启用 Notification Services 的详细信息，请参阅 SQL Server 2005 联机丛书中的“配置 Notification Services Windows 服务”主题。

Integration Services

默认实例或命名实例：MSDTSServer

为 Integration Services 包存储和执行提供管理支持。

其可执行文件的路径为 \DTS\Binn\msdtssrvr.exe。

SQL Server 浏览器

默认实例或命名实例：SQLBrowser

向客户机提供 SQL Server 连接信息的名称解析服务。多个 SQL Server 和 SSIS 实例共享此服务。

其可执行文件的路径为 \90\shared\sqlbrowser.exe。

Microsoft 全文搜索 (MSFTESQL)

默认实例：MSFTESQL

命名实例：MSFTESQL$实例名

对结构化和半结构化数据的内容和属性快速创建全文索引以允许对此数据的快速语言搜索。

其可执行文件的路径为 \MSSQL\Binn\msftesql.exe。

SQL Server Active Directory Helper

默认实例或命名实例：MSSQLServerADHelper。

在 Windows active directory 中发布和管理 SQL Server 服务。

其可执行文件的路径为 \90\Shared\sqladhelper.exe。

SQL 编写器

SQLWriter

允许备份和还原应用程序以便在 Volume Shadow Copy Service (VSS) 框架中进行操作。服务器上的所有 SQL 实例只有一个 SQL Server 编写器服务实例。

其可执行文件的路径为 \90\Shared\sqlwriter.exe。

1有关如何验证是否设置了所需的每个 Windows 权限的详细信息，请参阅如何验证 SQL Server 服务的权限。

查看其他注意事项

下表显示了使 SQL Server 服务提供其他功能所需的权限。

Service/aApplication | 功能 | 所需的权限
SQL Server (MSSQLSERVER) | 使用 xp_sendmail 写入邮件槽。 | 网络写入权限。
SQL Server (MSSQLSERVER) | 运行用户的而不是 SQL Server 管理员的 xp_cmdshell。 | 充当操作系统的一部分以及替换进程级别标记。
SQL Server 代理 (MSSQLSERVER) | 使用自动重新启动功能。 | 必须是本地 Administrators 组的成员。
数据库引擎 优化顾问 | 优化数据库以获得最佳查询性能。 | 第一次使用时，具有系统管理员权限的用户必须初始化该应用程序。初始化后，拥有表的用户（dbo 用户）可使用数据库引擎 优化顾问来只优化属于他们的表。有关详细信息，请参阅 SQL Server 2005 联机丛书中的“在第一次使用时初始化数据库引擎优化顾问”。
重要事项：
升级到 SQL Server 2005 之前，请先启用 SQL Server 代理的 Windows 身份验证，并验证 SQL Server 代理的服务帐户是否是 SQL Server sysadmin 组的成员。

请参阅

参考

服务帐户
服务帐户（分类）

概念

安装 SQL Server 的安全注意事项

更改历史记录

版本 历史记录

已更改的内容：
  • 从 SQL Server 代理可以使用的帐户列表中删除 LocalService。

  • 更新了由 SQL Server 安装程序创建的用户组。


SQL Server 2005 的各种版本所支持的功能

SQL Server 2005 的各种版本所支持的功能 |
 | 请参阅
准备安装 SQL Server 2005 >

使用下表可以确定各种版本的 Microsoft SQL Server 2005 支持哪些功能。

SQL Server 2005 数据库引擎功能

以下缩写分别表示各 SQL Server 2005 版本：

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = 具有高级服务的 SQL Server 2005 Express Edition

功能/数据库引擎增强功能 | EE（32 位） EE（64 位） DE（32 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
可编程性功能 |  |  |  |  |
Microsoft .NET Framework | 支持 | 支持 | 不支持 | 不支持 | 不支持
公共语言运行时集成 | 支持 | 支持 | 支持 | 支持 | 支持
用户定义聚合 | 支持 | 支持 | 支持 | 支持 | 支持
用户定义数据类型 | 支持 | 支持 | 支持 | 支持 | 支持
用户定义函数 | 支持 | 支持 | 支持 | 支持 | 支持
SQL Server 托管访问接口（托管数据访问） | 支持 | 支持 | 支持 | 支持 | 支持
扩展触发器 | 支持 | 支持 | 支持 | 支持 | 支持
事件 | 支持 | 支持 | 支持 | 支持 | 支持
功能/数据库引擎增强功能 | EE（32 位） EE（64 位） DE（32 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
数据类型 |  |  |  |  |
CLR 用户定义数据类型 | 支持 | 支持 | 支持 | 支持 | 支持
新的 XML 数据类型 | 支持 | 支持 | 支持 | 支持 | 支持
功能/数据库引擎增强功能 | EE（32 位） EE（64 位） DE（32 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
Transact-SQL 增强功能 |  |  |  |  |
异常处理 | 支持 | 支持 | 支持 | 支持 | 支持
查询支持扩展插件 | 支持 | 支持 | 支持 | 支持 | 支持
FOR XML 增强功能 | 支持 | 支持 | 支持 | 支持 | 支持
内部函数（字符串函数） | 支持 | 支持 | 支持 | 支持 | 支持
LOB 编程模型 | 支持 | 支持 | 支持 | 支持 | 支持
新的分析函数（排名函数） | 支持 | 支持 | 支持 | 支持 | 支持
新的 Apply 运算符（关系运算符） | 支持 | 支持 | 支持 | 支持 | 支持
新的 Pivot 和 Unpivot 运算符（关系运算符） | 支持 | 支持 | 支持 | 支持 | 支持
通知支持 | 支持 | 支持 | 支持 | 支持 | 支持
递归查询 | 支持 | 支持 | 支持 | 支持 | 支持
顶级增强功能 | 支持 | 支持 | 支持 | 支持 | 支持
分布式查询 | 支持 | 支持 | 支持 | 支持 | 支持
功能/数据库引擎增强功能 | EE（32 位） EE（64 位） DE（32 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
全文搜索增强功能 |  |  |  |  |
全文链接服务器查询 | 支持 | 支持 | 支持 | 不支持 | 支持
多列间全文搜索 | 支持 | 支持 | 支持 | 不支持 | 支持
指定查询中使用的语言 | 支持 | 支持 | 支持 | 不支持 | 支持
新的消息 Service Broker | 支持 | 支持 | 支持 | 仅限客户端 | 仅限客户端
HTTP 支持（本机 HTTP） | 支持 | 支持 | 支持 | 不支持 | 不支持
功能/数据库引擎增强功能 | EE（32 位） EE（64 位） DE（32 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
可管理性功能 |  |  |  |  |
全文目录的备份和还原 | 支持 | 支持 | 支持 | 不支持 | 支持
数据库附加/分离操作中包括的全文目录 | 支持 | 支持 | 支持 | 不支持 | 支持
全文搜索升级 | 支持 | 支持 | 支持 | 不支持 | 支持
针对视图查询（以前为视图索引） | 支持 | 支持 | 支持 | 不支持 | 不支持
对 XML 数据类型进行索引 | 支持 | 支持 | 支持 | 不支持 | 不支持
索引性能改善（以前为 MSSearch 3.0 中的内联收集） | 支持 | 支持 | 支持 | 不支持 | 不支持
并行服务安全性（以前为安全上下文更改） | 支持 | 支持 | 支持 | 不支持 | 不支持
丰富的状态报告 | 支持 | 支持 | 支持 | 不支持 | 不支持
功能/数据库引擎增强功能 | EE（32 位） EE（64 位） DE（32 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
安全功能 |  |  |  |  |
所有权限均可授予 | 支持 | 支持 | 支持 | 支持 | 支持
细粒度管理权限 | 支持 | 支持 | 支持 | 支持 | 支持
SQL 授权的集成安全性 | 支持 | 支持 | 支持 | 支持 | 支持
用户和架构分离 | 支持 | 支持 | 支持 | 支持 | 支持
功能/数据库引擎增强功能 | EE（32 位） EE（64 位） DE（32 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
可用性功能（数据库故障和冗余） |  |  |  |  |
故障转移群集 | 支持 | 2 节点 | 不支持 | 不支持 | 不支持
多个实例支持 | 50 | 16 | 16 | 16 | 16
数据库镜像 | 支持 | 仅限 FULL 安全级别 | 不支持 | 不支持；可以用作见证 | 不支持；可以用作见证
日志传送 | 支持 | 支持 | 支持 | 不支持 | 不支持
数据库快照 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
功能/数据库引擎增强功能 | EE（32 位） EE（64 位） DE（32 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
数据库维护功能 |  |  |  |  |
数据和备份校验和完整性检查 | 支持 | 支持 | 支持 | 支持 | 支持
专用管理员连接 | 支持 | 支持 | 支持 | 支持1 | 支持1
动态 AWE | 支持 | 支持 | 不支持 | 不支持 | 不支持
恢复撤消期间数据库可用 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
高可用升级 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
热添加内存2 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
镜像备份媒体 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
联机索引操作 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
页面还原 | 支持 | 支持 | 支持 | 支持 | 支持
联机页面和文件还原 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
并行索引操作 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
功能/数据库引擎增强功能 | EE（32 位） EE（64 位） DE（32 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
XML 功能 |  |  |  |  |
XML 数据类型 | 支持 | 支持 | 支持 | 支持 | 支持
Xquery 支持 | 支持 | 支持 | 支持 | 支持 | 支持
XML 数据操作语言 (XML DML) | 支持 | 支持 | 支持 | 支持 | 支持
XML 视图 | 支持 | 支持 | 支持 | 支持 | 支持
FOR XML 增强功能 | 支持 | 支持 | 支持 | 支持 | 支持
XML 类型系统支持（XML 架构支持) | 支持 | 支持 | 支持 | 支持 | 支持
功能/数据库引擎增强功能 | EE（32 位） EE（64 位） DE（32 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
可伸缩性和性能增强功能 |  |  |  |  |
数据库引擎优化顾问（代替索引优化向导） | 支持 | 支持 | 支持 | 不支持 | 不支持
可更新的分布式分区视图 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
增强的预读和扫描 (Super Scan) | 支持 | 不支持 | 不支持 | 不支持 | 不支持
索引视图（具体化视图）3 | 支持 | 支持 | 支持 | 支持 | 支持
多个活动的结果集 (MARS) | 支持 | 支持 | 支持 | 支持 | 支持
持久化计算列 | 支持 | 支持 | 支持 | 支持 | 支持
队列支持 | 支持 | 支持 | 支持 | 支持 | 支持
快照隔离级别（行级版本控制） | 支持 | 支持 | 支持 | 支持 | 支持
表和索引分区 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
VIA 支持 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
并行 DBCC | 支持 | 不支持 | 不支持 | 不支持 | 不支持
功能/数据库引擎增强功能 | EE（32 位） EE（64 位） DE（32 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
国际化功能（排序规则、字符支持和全局部署） |  |  |  |  |
复杂脚本/双向支持 | 支持 | 支持 | 支持 | 支持 | 支持
GB18030 支持 | 支持 | 支持 | 支持 | 支持 | 支持
代理项支持 | 支持 | 支持 | 支持 | 支持 | 支持
语言包 | 支持 | 支持 | 支持 | 支持 | 支持

1跟踪标志 7806 支持 SQL Server Express Edition 的专用管理员连接功能。有关跟踪标志的详细信息，请参阅 SQL Server 2005 联机丛书中的“跟踪标志 (Transact-SQL)”主题。

2此功能需要 SQL Server 2005 Enterprise Edition，并且仅适用于 64 位 SQL Server 和启用了 AWE 的 32 位 SQL Server。

3所有版本的 SQL Server 2005 都支持此功能，但只有 Enterprise Edition 和 Developer Edition 才支持查询优化器自动匹配功能。

SQL Server 2005 管理工具功能

以下缩写分别表示各 SQL Server 2005 版本：

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = 具有高级服务的 SQL Server 2005 Express Edition

功能/管理工具增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SE（64 位） | SSE（32 位） | SSEA（32 位）
可编程性功能 |  |  |  |  |  |
设计工具方面的增强功能 |  |  |  |  |  |
查询设计器 | 支持 | 支持 | 支持 | 不支持 | 不支持 | 不支持
查询编辑器 | 支持 | 支持 | 支持 | 不支持 | 不支持 | 不支持
MDX 查询编辑器 | 支持 | 支持 | 支持 | 不支持 | 不支持 | 不支持
MDX IntelliSense | 支持 | 支持 | 支持 | 不支持 | 不支持 | 不支持
Transact-SQL IntelliSense | 支持 | 支持 | 支持 | 不支持 | 不支持 | 不支持
版本控制支持 | 支持 | 支持 | 支持 | 不支持 | 不支持 | 不支持
XML/A | 支持 | 支持 | 支持 | 不支持 | 不支持 | 不支持
功能/管理工具增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SE（64 位） | SSE（32 位） | SSEA（32 位）
管理编程 |  |  |  |  |  |
SQL 管理对象 (SMO) | 支持 | 支持 | 支持 | 不支持 | 支持 | 支持
WMI 配置提供程序 | 支持 | 支持 | 支持 | 不支持 | 不支持 | 不支持
可管理性功能 |  |  |  |  |  |
配置 |  |  |  |  |  |
SQL Server 配置管理器、MMC 管理单元 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
功能/管理工具增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SE（64 位） | SSE（32 位） | SSEA（32 位）
管理 |  |  |  |  |  |
Microsoft Visual Studio Integration | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
新的对话样式（完全可编写脚本和可计划的用户界面） | 支持 | 支持 | 支持 | 不支持 | 不支持 | 不支持
SQL Server Management Studio | 支持 | 支持 | 支持 | 支持 | 不支持 | SQL Server Management Studio Express（
主服务器 | 支持（自动） | 支持（手动） | 不支持 | 不支持 | 不支持 | 不支持
目标服务器 | 支持 | 支持 | 支持 | 不支持 | 不支持 | 不支持
功能/管理工具增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SE（64 位） | SSE（32 位） | SSEA（32 位）
操作 |  |  |  |  |  |
适用于 SQL Server 2005 的 Microsoft Operations Manager 包 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
SQLCMD 命令提示工具（以前为 OLESQL） | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
SQL Server 代理作业的重用 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
SQL Server 代理性能计数器 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
SQL Server 代理计划 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
SQL Server 代理安全性 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
适用于 OLAP 和 SSIS 的 SQL Server 代理子系统 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
SQL Server 代理 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
Web 助手 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
SQL Mail | 支持 32 位 不支持 64 位 | 支持 | 支持 | 不支持 | 不支持 | 不支持
数据库邮件 | 支持 32 位 不支持 64 位 | 支持 | 支持 | 不支持 | 不支持 | 不支持
功能/管理工具增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SE（64 位） | SSE（32 位） | SSEA（32 位）
可伸缩性和性能 |  |  |  |  |  |
数据库引擎 优化顾问 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
性能计数器关联 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
SQL Server 事件探查器 增强功能 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
探查 Analysis Services | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
可导出的显示计划和死锁跟踪 | 支持 | 支持 | 支持 | 支持 | 不支持 | 不支持
功能/管理工具增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SE（64 位） | SSE（32 位） | SSEA（32 位）
国际化功能（排序规则、字符支持和全局部署） |  |  |  |  |  |
复杂脚本/双向支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
GB18030 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
代理项支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持

SQL Server 2005 Analysis Services 功能

以下缩写分别表示各 SQL Server 2005 版本：

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = 具有高级服务的 SQL Server 2005 Express Edition

功能/Analysis Services 增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SSE （32 位）和 SSEA（32 位） | SE（64 位）
可编程性功能 |  |  |  |  |
.NET Framework | 支持 | 支持 | 不支持 | 不支持 | 支持
.NET 存储过程 | 支持 | 支持 | 不支持 | 不支持 | 支持
跨平台、零需求量客户端访问 | 支持 | 支持 | 不支持 | 不支持 | 支持
本机 XML Web 服务 | 支持 | 支持 | 不支持 | 不支持 | 支持
HTTP 访问 | 支持 | 支持 | 不支持 | 不支持 | 支持
二进制和压缩的 XML 传输 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
可管理性功能 |  |  |  |  |
自动处理引用完整性 | 支持 | 支持 | 不支持 | 不支持 | 支持
捕获和重播 | 支持 | 支持 | 不支持 | 不支持 | 支持
细粒度管理权限 | 支持 | 支持 | 不支持 | 不支持 | 支持
事件探查器 | 支持 | 支持 | 不支持 | 不支持 | 支持
跟踪 | 支持 | 支持 | 不支持 | 不支持 | 支持
网络流量记录器 | 支持 | 支持 | 不支持 | 不支持 | 支持
功能/Analysis Services 增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SSE （32 位）和 SSEA（32 位） | SE（64 位）
管理编程功能 |  |  |  |  |
分析管理对象（AMO 和 DMO） | 支持 | 支持 | 不支持 | 不支持 | 支持
可用性功能 |  |  |  |  |
增强的备份和还原 | 支持 | 支持 | 不支持 | 不支持 | 支持
故障转移群集 | 支持 | 支持 | 不支持 | 不支持 | 支持
多实例 | 50 | 16 | 不支持 | 不支持 | 16
服务器同步 | 支持 | 支持 | 不支持 | 不支持 | 支持
功能/Analysis Services 增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SSE （32 位）和 SSEA（32 位） | SE（64 位）
商业智能功能 |  |  |  |  |
自动打包和部署 | 支持 | 支持 | 不支持 | 不支持 | 支持
商业智能向导 | 支持 | 支持 | 不支持 | 不支持 | 支持
数据源视图管理 | 支持 | 支持 | 不支持 | 不支持 | 支持
集成的 Business Intelligence Development Studio | 支持 | 支持 | 不支持 | 不支持 | 支持
Autobuild 生成器技术 | 支持 | 支持 | 不支持 | 不支持 | 支持
MDX 调试器 | 支持 | 支持 | 不支持 | 不支持 | 支持
多分区编辑器 | 支持 | 支持 | 不支持 | 不支持 | 支持
源代码管理和版本控制 | 支持 | 支持 | 不支持 | 不支持 | 支持
统一计算编辑器 | 支持 | 支持 | 不支持 | 不支持 | 支持
功能/Analysis Services 增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SSE （32 位）和 SSEA（32 位） | SE（64 位）
数据挖掘功能 |  |  |  |  |
增强的集成 OLAP 和数据挖掘功能（MDX 预测函数、DM 维度） | 支持 | 支持 | 不支持 | 不支持 | 支持
并行模型处理 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
并行模型预测 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
文本挖掘字词提取转换 (SSIS) | 支持 | 不支持 | 不支持 | 不支持 | 不支持
文本挖掘字词查找转换 (SSIS) | 支持 | 不支持 | 不支持 | 不支持 | 不支持
数据挖掘查询转换 (SSIS) | 支持 | 不支持 | 不支持 | 不支持 | 不支持
数据挖掘处理目标 (SSIS) | 支持 | 不支持 | 不支持 | 不支持 | 不支持
算法插件 API | 支持 | 不支持 | 不支持 | 不支持 | 不支持
算法查看器 | 支持 | 支持 | 不支持 | 不支持 | 支持
数据挖掘工具（包括向导、编辑器、查询生成器、提升图） | 支持 | 支持 | 不支持 | 不支持 | 支持
标准数据挖掘算法 | 支持 | 支持 | 不支持 | 不支持 | 支持
数据挖掘算法的高级配置和优化选项 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
报表服务与 DM 预测查询集成 | 支持 | 支持 | 不支持 | 不支持 | 支持
功能/Analysis Services 增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SSE（32 位）和 SSEA（32 位） | SE（64 位）
高级分析功能 |  |  |  |  |
帐户智能 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
跨数据库/跨服务器链接度量值和维度 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
元数据翻译 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
透视 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
半累加性度量值 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
写回维度 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
功能/Analysis Services 增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SSE（32 位）和 SSEA（32 位） | SE（64 位）
数据仓库生成功能 |  |  |  |  |
在没有数据库的情况下创建多维数据集 | 支持 | 支持 | 不支持 | 不支持 | 不支持
自动生成临时的数据仓库架构 | 支持 | 支持 | 不支持 | 不支持 | 不支持
自动生成更新数据仓库数据的 DTS 包 | 支持 | 支持 | 不支持 | 不支持 | 不支持
扩展的维建模功能 |  |  |  |  |
度量值表达式 | 支持 | 支持 | 不支持 | 不支持 | 支持
可伸缩性和性能增强功能 |  |  |  |  |
主动缓存 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
自动并行分区处理 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
分区多维数据集 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
分布式分区多维数据集 | 支持 | 不支持 | 不支持 | 不支持 | 不支持

SQL Server 2005 Reporting Services 功能

以下缩写分别表示各 SQL Server 2005 版本：

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = 具有高级服务的 SQL Server 2005 Express Edition

功能/Reporting Services 增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） SE（64 位） | WG（32 位） | SSE（32 位） | SSEA（32 位）
对远程和非关系数据源的支持 | 支持 | 支持 | 不支持 | 不支持 | 不支持
DHTML、Excel、PDF 和图像呈现扩展插件 | 支持 | 支持 | 支持 | 不支持 | 支持
MHTML、CSV、XML 和空呈现扩展插件 | 支持 | 支持 | 不支持 | 不支持 | 不支持
电子邮件和文件共享传递扩展插件 | 支持 | 支持 | 不支持 | 不支持 | 不支持
自定义数据处理扩展插件、传递扩展插件和呈现扩展插件 | 支持 | 支持 | 不支持 | 不支持 | 不支持
自定义身份验证扩展插件 | 支持 | 支持 | 支持 | 不支持 | 不支持
报表缓存 | 支持 | 支持 | 不支持 | 不支持 | 不支持
报表历史记录 | 支持 | 支持 | 不支持 | 不支持 | 不支持
计划 | 支持 | 支持 | 不支持 | 不支持 | 不支持
订阅 | 支持 | 支持 | 不支持 | 不支持 | 不支持
数据驱动订阅 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
用户定义的角色定义 | 支持 | 支持 | 不支持 | 不支持 | 不支持
报表模型数据源 | 支持 | 支持 | 支持 | 不支持 | 不支持
报表模型项安全性 | 支持 | 支持 | 不支持 | 不支持 | 不支持
对即席报表的无限制链接点击的支持 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
报表生成器 | 支持 | 支持 | 支持 | 不支持 | 不支持
报表管理器 | 支持 | 支持 | 支持 | 不支持 | 支持
SQL Server Management Studio | 支持 | 支持 | 支持 | 不支持 | 不支持
Business Intelligence Development Studio 中的报表设计器 | 支持 | 支持 | 支持 | 不支持 | 支持1
报表服务器扩展部署 | 支持 | 不支持 | 不支持 | 不支持 | 不支持

有关 SQL Server 2005 中可用的其他 Reporting Services 功能的信息，请参阅 SQL Server 2005 联机丛书中的“Reporting Services 功能”。

1使用 SQL Server 2005 Express Edition 工具包安装 Business Intelligence Development Studio。有关详细信息，请参阅 SQL Server 2005 Express Edition 联机丛书中的SQL Server Express Toolkit。

SQL Server 2005 Notification Services 功能

以下缩写分别表示各 SQL Server 2005 版本：

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = 具有高级服务的 SQL Server 2005 Express Edition

功能/Notification Services 增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SSE（32 位）和 SSEA（32 位） | SE（64 位）
Notification Services SDK（API、NSControl、ICF/ADF） | 支持 | 支持 | 不支持 | 不支持 | 支持
Notification Services 引擎和客户端组件 | 支持 | 支持 | 不支持 | 不支持 | 支持
伸缩性（并行、多播、分布式部署） | 支持 | 不支持 | 不支持 | 不支持 | 不支持

SQL Server 2005 Integration Services 功能

以下缩写分别表示各 SQL Server 2005 版本：

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = 具有高级服务的 SQL Server 2005 Express Edition

功能/Integration Services 增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位） | SE（32 位） | WG（32 位） | SSE（32 位）和 SSEA（32 位） | SE（64 位）
SQL Server 导入和导出向导并支持连接、源适配器和目标适配器以及任务 | 支持 | 支持 | 支持 | 不支持 | 支持
执行 SQL 任务 | 支持 | 支持 | 支持 | 不支持 | 支持
OLE DB 源适配器和 OLE DB 目标适配器 | 支持 | 支持 | 支持 | 不支持 | 支持
SSIS 命令提示工具 | 支持 | 支持 | 支持 | 不支持 | 支持
SSIS 包设计器 | 支持 | 支持 | 支持 | 不支持 | 支持
对早期版本的 DTS 包的支持 | 支持 | 支持 | 支持 | 支持 | 支持
SSIS 服务 | 支持 | 支持 | 不支持 | 不支持 | 支持
除下面列出之外的所有其他源适配器和目标适配器、任务及转换 | 支持 | 支持 | 不支持 | 不支持 | 支持
数据挖掘查询转换 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
数据挖掘模型定型目标适配器 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
模糊分组转换 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
模糊查找转换 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
字词提取转换 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
字词查找转换 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
渐变维度转换和向导 | 支持 | 支持 | 不支持 | 不支持 | 不支持
维度处理目标适配器 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
分区处理目标适配器 | 支持 | 不支持 | 不支持 | 不支持 | 不支持

SQL Server 2005 复制功能

以下缩写分别表示各 SQL Server 2005 版本：

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = 具有高级服务的 SQL Server 2005 Express Edition

功能/复制方面的增强功能 | EE（32 位） DE（32 位） EE（64 位） DE（64 位）4 | SE（32 位） | WG（32 位） | SSE（32 位）和 SSEA（32 位） | SE（64 位）
合并复制 | 支持 | 支持 | 支持1 | 仅订阅服务器2 | 支持
事务复制 | 支持 | 支持 | 支持1 | 仅订阅服务器3 | 支持
快照复制 | 支持 | 支持 | 支持 | 仅支持订阅服务器 | 支持
非 SQL Server 订阅服务器 | 支持 | 支持 | 不支持 | 不支持 | 支持
Oracle 发布 | 支持 | 不支持 | 不支持 | 不支持 | 不支持
对等事务复制 | 支持 | 不支持 | 不支持 | 不支持 | 不支持

1如果将 WG 实例用作发布服务器，则它支持最多 25 个针对所有合并发布的订阅，以及最多 5 个针对所有事务性发布的订阅。对于快照发布，它支持的订阅数量没有限制。

2对于任何复制类型，都不能将 SSE 配置为发布服务器或分发服务器。但是，SSE 可以是订阅服务器，而且合并复制允许在发布服务器和订阅服务器之间双向复制更改。

3SSE 不支持使用请求订阅进行排队更新。SSE 确实支持使用推送订阅进行排队更新，并且支持使用推送或请求订阅进行立即更新（立即更新需要在运行 SSE 实例的计算机上运行 Microsoft 分布式事务处理协调器 (MS DTC)。

4复制功能支持同一拓扑中同时存在 SQL Server 的 32 位版本和 64 位版本。64 位版本支持所有复制功能，以下是有关的注意事项：

  • 来自 64 位分发服务器的推送订阅要求该分发服务器中有相应的 64 位 OLEDB 访问接口或 ODBC 驱动程序；来自 64 位订阅服务器的请求订阅要求该订阅服务器中有相应的 64 位访问接口或驱动程序。有关推送订阅和请求订阅的详细信息，请参阅订阅发布。

  • 基于 IA-64 的体系结构当前不支持 Microsoft OLE DB Provider for DB2。因此，SQL Server 复制不支持将数据复制到此平台上的 DB2 订阅服务器。

  • 若要在以 Windows on Windows 模式 (WOW) 运行的 64 位订阅服务器上使用 Windows 同步管理器，必须直接从 \Windows\Syswow64 目录而不是从“开始”菜单启动可执行文件 mobsync.exe。直接启动该可执行文件可确保使用正确的版本。有关 WOW 的详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。有关 Windows 同步管理器的详细信息，请参阅 Windows 同步管理器。

  • 由于必要的 64 位 Data Transformation Services (DTS) 组件不可用，因此不支持来自 64 位分发服务器的可转换推送订阅。来自安装的 32 位 SQL Server 2005 的请求订阅将使用 64 位发布服务器或分发服务器。有关可转换订阅的详细信息，请参阅转换已发布数据。

请参阅

其他资源

SQL Server 2005 的产品规格

更改历史记录

版本 历史记录

已更改的内容：
  • 添加了有关具有高级服务的 SQL Server 2005 Express Edition 的支持信息。

  • 加入了对 SQL Server 2005 Express Edition 专用管理员连接功能的支持的说明文档。


配置高可用性

配置高可用性 |
 | 请参阅
准备安装 SQL Server 2005 >

本节介绍了几个提高服务器或数据库可用性的 Microsoft SQL Server 2005 高可用性解决方案。高可用性解决方案可减少硬件或软件故障造成的影响，保持应用程序的可用性，尽可能地减少用户所感受到的停机时间。

SQL Server 2005 提供了几个使服务器或数据库具有高可用性的可选方案。高可用性可选方案有：

  • 故障转移群集

    故障转移群集可对整个 SQL Server 实例的高可用性提供支持。故障转移群集由具有两个或多个共享磁盘的一个或多个节点（服务器）组成。每个 Microsoft 群集服务 (MSCS) 的群集组（称为“资源组”）中均安装有应用程序（如 SQL Server）和 Notification Service。在任何给定的时间点，每个资源组仅属于群集中的一个节点。应用程序服务具有与节点名称无关的“虚拟名称”，因此它将作为虚拟服务器来引用。应用程序可以通过引用虚拟服务器的名称的方法连接到虚拟服务器，并不需要知道虚拟服务器的宿主是哪个节点。

    SQL Server 虚拟服务器将像单个计算机一样显示在网络中，不过，它还具有一种功能，在当前节点不可用时，可以在节点之间进行故障转移。例如，在发生非磁盘硬件故障、操作系统故障或进行计划的操作系统升级时，可以在故障转移群集的一个节点上配置 SQL Server 实例，使其故障转移到磁盘组中的任意其他节点。故障转移群集不能防止磁盘故障。您可以使用故障转移群集来减少系统停机时间，提供较高的应用程序可用性。SQL Server 2005 Enterprise Edition 和 Developer Edition 均支持故障转移群集。Standard Edition 也支持故障转移群集，但有一些限制。有关故障转移群集的详细信息，请参阅故障转移群集和创建虚拟服务器，安装故障转移群集。

  • 数据库镜像

    数据库镜像实际上是个软件解决方案，可提供几乎是瞬时的故障转移，以提高数据库的可用性。数据库镜像用来维护相应的读写数据库（称为“主体数据库”）的单个“热”备用数据库（或“镜像数据库”）。通过还原但不恢复主体数据库的完整备份可创建镜像数据库。客户端不能访问镜像数据库。但是，为了进行报告，可创建镜像数据库的数据库快照来间接地使用镜像数据库。数据库快照为客户端提供了快照创建时对数据库中数据的只读访问。

    每个数据库镜像配置均包含一个主体服务器（包含主体数据库）、一个镜像服务器（包含镜像数据库）和一个见证服务器，其中见证服务器是可选的。镜像服务器不断地使镜像数据库随主体数据库一起更新。从主体数据库到镜像数据库的故障转移是真正瞬时完成的。

    数据库镜像以同步操作或异步操作运行。在异步操作下，事务不需要等待镜像服务器将日志写入磁盘便可提交，这样可最大程度地提高性能。在同步操作下，已提交的事务将在伙伴双方上提交，但会延长事务滞后时间。

    数据库镜像的最简单形式仅涉及主体服务器和镜像服务器。

    备用配置仅用于同步操作，它涉及第三个服务器实例（称为见证服务器）。

    有关数据库镜像的信息，请参阅数据库镜像。

  • 日志传送

    与数据库镜像一样，日志传送是数据库级操作。日志传送可用来维护相应的读写数据库（称为“主数据库”）的“暖”备用数据库（称为“辅助数据库”）。通过还原但不恢复主数据库的完整备份可创建辅助数据库。

    日志传送配置包括一个主服务器（包含主数据库），一个或多个辅助服务器（每个服务器包含一个辅助数据库）和一个监视服务器。每个辅助服务器从“主数据库”的日志备份以固定的时间间隔更新辅助数据库。在发生从主数据库到其中一个辅助数据库的故障转移之前，必须手动完全更新辅助数据库。在还原期间，辅助数据库具有有限的可用性，因此它们可能不能用于进行报告。

    日志传送具有支持多个备用数据库的灵活性。如果需要多个备用数据库，可以单独使用日志传送或将其作为数据库镜像的补充。当这些解决方案一起使用时，当前数据库镜像配置的主体数据库同时也是当前日志传送配置的主数据库。而且，日志传送允许用户将延迟时间定义为：从主服务器备份主数据库日志到辅助服务器必须还原日志备份之间的时间。SQL Server 2005 Enterprise Edition、Standard Edition 和 Workgroup Edition 均支持日志传送。有关日志传送的详细信息，请参阅日志传送。

  • 复制

    复制使用的是发布-订阅模式，即由主服务器（发布服务器）向辅助服务器（订阅服务器）发布数据。复制可在这些服务器间提供实时的可用性和可伸缩性。它支持筛选，以便为订阅服务器提供数据子集，同时还支持分区更新。订阅服务器处于在线状态，并且可用于报告或其他功能，而无需进行查询恢复。SQL Server 提供了三种复制类型：快照、事务以及合并；事务复制的滞后时间最短，在要求高可用性的情况下最常用。有关详细信息，请参阅改善伸缩性和可用性。

    SQL Server 2005 的所有版本都支持复制。SQL Server Express 或 SQL Server Mobile 不提供复制发布功能。有关各版本所支持的复制功能的完整列表，请参阅 SQL Server 2005 的各种版本所支持的功能。

    重要事项：
    完善地设计与实施备份和还原策略对任何高可用性解决方案都十分重要。有关详细信息，请参阅备份和还原数据库和备份和还原复制的数据库。

选择高可用性解决方案：

下面列举了选择高可用性解决方案的注意事项：

  • 故障转移群集与数据库镜像

    这两种解决方案都提供：

    • 自动检测和故障转移。

    • 手动故障转移。

    • 透明客户端重定向。

    此外，故障转移群集具有下列约束：

    • 需要在服务器实例作用域内进行操作。

    • 硬件需经过认证。

    • 备用部分不具有报告功能。

    • 仅利用数据库的单个副本。

    • 不能防止磁盘故障。

    此外，数据库镜像具有下列优势：

    • 需要在数据库作用域内操作。

    • 使用数据库的单一、重复的副本。

      注意：
      如果需要其他副本，则除了数据库镜像之外，还可以使用数据库的日志传送功能。

    • 需使用标准服务器。

    • 只能使用数据库快照对镜像服务器进行有限的报告。

    • 同步操作时，为了提供零工作丢失，将在主体数据库上延迟提交。

    数据库镜像所带来的可用性等级比以前使用 SQL Server 所能达到的可用性等级有了大幅提升，并提供了故障转移群集这一易于管理的可选方案。

    注意：
    有关在故障转移群集中使用数据库镜像的信息，请参阅数据库镜像和故障转移群集。有关在 Notification Services 中使用故障转移群集的信息，请参阅在 Notification Services 中使用故障转移群集。有关在 Notification Services 中使用数据库镜像的信息，请参阅在 Notification Services 中使用日志传送或数据库镜像。

  • 日志传送

    日志传送可以用于补充或替代数据库镜像。虽然异步数据库镜像与日志传送在概念上很相似，但它们仍有很大差异。日志传送具有下列独特的功能：

    • 针对单个主数据库在多个服务器实例上支持多个辅助数据库。

    • 允许用户将延迟时间定义为：从主服务器备份主数据库日志到辅助服务器必须还原日志备份之间的时间。例如，如果主数据库上的数据被意外更改，则较长的延迟会很有用。如果很快发现意外更改，则通过延迟，您可以在辅助数据库反映此更改之前从其中检索仍未更改的数据。

      另一方面，与日志传送将更改反映到辅助数据库所需的最短时间相比，异步数据库镜像具有的潜在优势为：在主数据库中进行指定更改与此更改反映到镜像数据库之间的时间更短。

      数据库镜像相对于日志传送的一个优势是：它是一种作为简单故障转移策略在本机上受支持的“无数据丢失”配置。SQL Server 2005 Enterprise Edition 和 Standard Edition 都支持数据库镜像，但 Standard Edition 在支持方面有一些限制。

      注意：
      有关结合使用数据库镜像和日志传送的信息，请参阅数据库镜像和日志传送。有关在 Notification Services 中使用日志传送的信息，请参阅在 Notification Services 中使用日志传送或数据库镜像。

  • 复制

    复制具有下列优势：

    • 在数据库作用域中进行操作，支持在数据库中进行筛选，以便为辅助数据库提供数据子集。

    • 支持多个冗余数据库副本。

    • 支持在多个数据库间实现实时的可用性和可伸缩性，支持分区更新。

    • 支持辅助数据库对报告或其他功能的完全可用性，而无需查询恢复。

    注意：
    有关结合使用数据库镜像和复制的信息，请参阅复制和数据库镜像。

本节的相关信息

主题 | 说明
故障转移群集 | 介绍共享具有两个或两个以上硬盘的节点（服务器）组合。
数据库镜像 | 包含有关数据库镜像工作原理以及如何配置和管理数据库镜像会话的信息。
日志传送 | 介绍日志传送如何工作以及如何配置和管理日志传送配置。

请参阅

参考

SQL Server 2005 的各种版本所支持的功能

其他资源

SQL Server 复制


故障转移群集

故障转移群集 |
 | 请参阅
准备安装 SQL Server 2005 > 配置高可用性 >

Microsoft SQL Server 2005 中的故障转移群集为整个 SQL Server 实例提供高可用性支持。例如，您可以将故障转移群集的一个节点上的 SQL Server 实例配置为在发生硬件错误、操作系统错误或计划升级时故障转移到此群集中的任何其他节点。

故障转移群集是一个或多个节点（服务器）与两个或多个共享磁盘的组合，即资源组。一个资源组及其网络名称、构成群集应用程序或服务器的 Internet 协议 (IP) 地址的组合称为“虚拟服务器”。SQL Server 虚拟服务器在网络中就像单个计算机一样，不过，它还具有一种功能，在当前节点不可用时，可以在节点之间进行故障转移。故障转移群集显示为常规应用程序或服务器，但它具有提高可用性的附加功能。服务器群集本身和群集服务器上安装的 SQL Server 实例都可以视为虚拟服务器。

在故障转移群集方案中，对多个 SQL Server 2005 实例的支持各不相同，因此您可以在群集中创建多个虚拟服务器，但是每个虚拟服务器只能安装一个 SQL Server 实例。

何时使用故障转移群集

使用故障转移群集可以执行下列操作：

  • 从群集 SQL Server 配置中的任何节点管理故障转移群集。有关详细信息，请参阅创建虚拟服务器，安装故障转移群集。

  • 允许一台虚拟服务器故障转移到虚拟服务器故障转移群集配置中的任何其他节点。有关详细信息，请参阅创建虚拟服务器，安装故障转移群集。

  • 为故障转移群集配置 Analysis Services。有关详细信息，请参阅如何在故障转移群集上安装 Analysis Services。

  • 使用 Microsoft Search 服务与故障转移群集执行全文查询。有关详细信息，请参阅在故障转移群集中使用 SQL Server 工具。

安装故障转移群集

必须按照具体的安装步骤进行操作，才能使用故障转移群集。

若要安装、配置和维护 SQL Server 故障转移群集，请使用 SQL Server 安装程序。还可以使用安装程序将现有 SQL Server 7.0 或 Microsoft SQL Server 2000 32 位实例升级到 SQL Server 2005 故障转移群集。有关详细信息，请参阅版本升级。

使用故障转移群集中的 SQL Server 安装程序可以执行下列操作：

  • 在故障转移群集内的多个节点上安装 SQL Server。此操作只受操作系统所支持节点数的限制。

    在安装故障转移群集之前，必须确保系统满足最低要求并配置 Microsoft 群集服务 (MSCS)。有关故障转移群集的具体要求的详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求和安装故障转移群集前的准备工作。

    故障转移群集中的所有节点都必须处于同一平台（32 位或 64 位）。而且，64 位 SQL Server 版本必须安装在运行 64 位版本的 Microsoft Windows 操作系统的 64 位硬件上。有关详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。

  • 若要安装 Microsoft SQL Server 2005 故障转移群集，必须通过运行 SQL Server 安装程序来创建和配置虚拟服务器。有关详细信息，请参阅创建虚拟服务器，安装故障转移群集。

  • 在不影响其他群集节点的情况下，通过虚拟服务器配置添加或删除节点。有关详细信息，请参阅维护故障转移群集。

  • 为每个虚拟服务器指定多个 IP 地址。使用 SQL Server 2005，可以为每个服务器指定多个 IP 地址，并可以使用所有可用的网络 IP 子网。SQL Server 2005 使您只能为每个网络指定一个 IP 地址。这可以在一个子网出现故障时提供其他网络连接。

故障转移群集支持

在 Microsoft SQL Server 2005 中，故障转移群集支持的节点数取决于操作系统。有些操作系统可能需要为群集使用光纤通道。有关详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。

有关 SQL Server 2005 故障转移群集支持的一系列工具、功能和服务，请参阅 SQL Server 2005 的各种版本所支持的功能。

请参阅

任务

如何创建新的 SQL Server 2005 故障转移群集（安装）

概念

安装故障转移群集前的准备工作


安装故障转移群集前的准备工作

安装故障转移群集前的准备工作 |
 | 请参阅
准备安装 SQL Server 2005 > 配置高可用性 > 故障转移群集 >

安装 Microsoft SQL Server 2005 故障转移群集之前，必须选择运行 SQL Server 2005 的硬件和操作系统。还必须配置 Microsoft 群集服务 (MSCS)、检查网络和安全性，以及了解将在故障转移群集上运行的其他软件的注意事项。

安装准备一览表

开始安装故障转移群集之前，请仔细阅读下列各项。

验证您的硬件解决方案

  • 您的硬件必须是 Microsoft Windows Catalog and Hardware Compatibility List 中列出的。硬件系统必须是群集解决方案类别中包含的。

    重要事项：
    各个群集组件组合在一起并不能构成核准的故障转移群集系统。只有作为群集解决方案购买的并且在群集组中列出的系统才是核准系统。检查 Microsoft Windows 目录和 Windows 硬件兼容性列表时，请将类别指定为“群集”。所有其他类别均用于 OEM。有关详细信息，请参阅 The Microsoft support policy for server clusters, the Hardware Compatibility List, and the Windows Server Catalog。

  • 在存储区域网络 (SAN) 上实施故障转移服务器群集时，需要测试特殊硬件的兼容性。整个硬件解决方案都必须包含在 Microsoft Windows 目录和硬件兼容性列表中的“群集/多群集设备”类别中。有关详细信息，请参阅 Microsoft 知识库文章 Support for multiple clusters attached to the same SAN device。

  • 如果群集解决方案中包含位置分散的群集节点，那么还必须验证附加项（如网络滞后时间和共享磁盘支持）。整个方案都必须包含在地理群集硬件兼容性列表中。有关详细信息，请参阅 Microsoft 知识库文章 Windows clustering and geographically separate sites。

  • Microsoft Windows 2000 Advanced Server 和 Datacenter Edition 也支持 SAN 配置。Microsoft Windows 目录和硬件兼容性列表中的“群集/多群集设备”类别中列出了一组支持 SAN 的存储设备，这些设备已经过测试，并且附加的多个 MSCS 群集支持它们作为 SAN 存储单元。通过将此列表中的设备与 Microsoft Windows 目录和硬件兼容性列表的“群集”类别中定义的完整群集配置相匹配，可以通过 Microsoft 支持的方式在 SAN 结构中用共享存储设备来部署一组 Windows 服务器和群集。有关详细信息，请参阅 Microsoft 知识库文章 The Datacenter Program and Windows 2000 Datacenter Server Product。

  • 如果您在 Internet 小型计算机系统接口 (iSCSI) 技术组件上配置 SQL Server 2005 故障转移群集，建议您多加注意。有关详细信息，请参阅 Microsoft 知识库文章 Support for SQL Server 2000 on iSCSI technology components。

  • 有关支持信息，请参阅 Microsoft 知识库文章 Microsoft support policy for a SQL Server failover cluster。

  • 考虑仲裁磁盘资源共享问题。在服务器群集中，仲裁磁盘包含服务器群集配置的主控副本，并在群集节点之间所有网络通信失败时用作补救措施。根据实现的服务器群集类型，仲裁磁盘可能是共享群集磁盘阵列上的物理磁盘，也可能不是。尽管最好是将整个群集磁盘用作仲裁磁盘，但也可以允许仲裁资源之外的其他资源访问仲裁磁盘。

    然而，使仲裁资源与其他资源共享同一磁盘会使您处于两难境地。您要么必须配置资源以使组不受其故障的影响，要么必须允许组受其他资源故障的影响。在第一种情况下，资源将不再支持故障转移；在第二种情况下，仲裁资源将对组（包含仲裁资源和失败的资源）的其余部分进行故障转移。结果是，在将组故障转移之前，整个群集处于离线状态。

    有关正确的仲裁驱动器配置的详细信息，请参阅知识库文章 Quorum Drive Configuration Information。

  • 当源安装文件与 SQL Server 2005 故障转移群集位于不同的域中时，若要安装该群集，请将安装文件复制到该群集的主节点，然后从主节点开始安装。

验证您的操作系统设置

  • 确保您的操作系统已正确安装并支持故障转移群集。有关支持的操作系统的详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。

  • 在 Windows Server 2003 上启用 Windows 加密服务提供程序 (CSP)。如果在任何群集节点上停止或禁用 CSP 服务，SQL Server 安装程序将失败，并显示 Windows Logo Requirement 对话框。

  • 在所有操作系统上启用任务计划程序服务以进行远程群集安装。如果禁用任务计划程序，SQL Server 安装程序将失败，错误为 1058。有关详细信息，请参阅如何启用 Windows 任务计划程序服务。

  • SQL Server 2005 支持装入点；SQL Server 的群集安装数取决于可用驱动器号的数量。假设您的操作系统只使用一个驱动器号，而所有其他驱动器号均用作正常群集驱动器或群集驱动器宿主装入点，则每个服务器上最多 25 个 SQL Server 实例。

    通过已装入卷或装入点可以使用单个驱动器号来引用多个磁盘或卷。如果您有一个驱动器号 D: 引用常规磁盘或卷，则您可以在附加磁盘或卷不需要拥有各自的驱动器号的情况下，在驱动器号 D: 下连接或“装入”附加磁盘或卷作为目录。

    SQL Server 2005 故障转移群集的特殊装入点的注意事项：

    • SQL Server 安装程序要求已装入驱动器的基准驱动器具有关联驱动器号。对于故障转移群集安装，此基准驱动器必须是群集驱动器。

    • 具有驱动器号的基准驱动器不能在虚拟服务器之间共享。这是对虚拟服务器的正常限制，而不是对独立的多实例服务器的限制。

    • 特别要注意的是，设置虚拟服务器时要确保基准驱动器和已装入磁盘或卷都已作为资源列在资源组中。SQL Server 安装程序不会自动注意这种情况，SQL Server 也不会在 CREATE/ALTER DATABASE 时检查这种情况。

    • 确保装入的磁盘或卷被装入到正确的基准驱动器号下，并确保装入的驱动器被设置为依赖于上一级驱动器。

配置 Microsoft 群集服务器

  • 必须至少在服务器群集的一个节点上配置 Microsoft 群集服务器 (MSCS)。只有将 MSCS 安装在通过 MSCS 软件兼容性测试的硬件配置上，才支持 MSCS。您还必须将 SQL Server 2005 Enterprise Edition 与 MSCS 一起运行。

    有关在 Windows Server 2003 上安装和配置 MSCS 的详细信息，请参阅 Server clusters。

    有关在 Windows 2000 操作系统上安装和配置 MSCS 的详细信息，请参阅 Step by Step Guide to Installing Cluster Service。

  • MSCS 必须能够使用 IsAlive 线程验证虚拟服务器是否正在运行。这需要使用可信连接来连接到服务器。您必须确保已在群集的所有节点上将运行群集服务的帐户配置为管理员，并且 BUILTIN\Administrators 组具有登录到 SQL Server 的权限。这些权限为默认权限，所以这些设置只有在更改对群集节点的权限时才会更改。

    删除 BUILTIN/Administrators 帐户后，请确保运行群集服务的帐户可以登录到 SQL Server 以进行 IsAlive 检查。如果不能，则 IsAlive 检查将失败。MSCS 群集服务帐户对 SQL Server 必须具有 sysadmin 权限。

  • 安装 MSCS 时，务必使用不同的服务帐户登录到 MSCS 和 SQL Server。否则，无法使用群集命令更改群集服务密码。

  • 使用 MSCS 时，在其他节点在线之前，一个节点必须受共享 SCSI 总线的控制。不这样做会导致应用程序故障转移进入在线挂起状态，并阻止故障转移到其他节点或者完全失败。如果您的群集系统具有专有安装进程，则必须使用该专有进程。

配置 Microsoft 分布式事务处理协调器

  • Microsoft 强烈建议您在故障转移群集上安装 SQL Server 2005 之前，在 Windows 2000 和 Windows Server 2003 操作系统上安装和配置 Microsoft 分布式事务处理协调器 (MS DTC)。SQL Server 2005 要求群集中具有 MS DTC，以用于分布式查询和两阶段提交事务以及一些复制功能。

    安装操作系统并配置群集后，您还必须使用群集管理器配置 MS DTC 以便在群集中使用。配置 MS DTC 群集失败不会终止 SQL Server 2005 安装程序，但是如果 MS DTC 配置不正确，SQL Server 2005 应用程序的功能可能会受到影响。

    在群集中的任意节点上运行的任何进程都可以使用 MS DTC。这些进程只需调用 MS DTC 代理，MS DTC 代理就会自动将 MS DTC 调用转发到控制整个群集的 MS DTC 事务管理器。

    如果运行 MS DTC 事务管理器的节点失败，则事务管理器将自动在群集中的另一节点上重新启动。新重新启动的事务管理器读取共享群集磁盘上的 MS DTC 日志文件，以确定挂起事务和最近完成的事务的结果。

    资源管理器重新连接到事务管理器并执行恢复以确定挂起事务的结果。应用程序重新连接到 MS DTC，以便可以启动新的事务。

    例如，假设 MS DTC 事务管理器在系统 B 上处于活动状态。系统 A 上的应用程序和资源管理器将调用 MS DTC 代理。系统 A 上的 MS DTC 代理将所有 MS DTC 调用转发到系统 B 上的 MS DTC 事务管理器中。

    如果系统 B 失败，则系统 A 上的 MS DTC 事务管理器将接管。它读取共享群集磁盘上的整个 MS DTC 日志文件，执行恢复，然后作为事务管理器为整个群集提供服务。

    Windows 服务器群集的每个节点上都安装有 MS DTC 事务管理器、MS DTC 代理和组件服务管理工具。群集在安装 Windows 服务器群集的过程中使用 Microsoft 群集服务 (MSCS)。

    若要在运行 MSCS 的 Windows 2003 Server 操作系统上手动配置 MS DTC，请参阅知识库文章 How to configure Microsoft Distributed Transaction Coordinator on a Windows 2003 cluster 和 How to enable network DTC access in Windows Server 2003。

    为了帮助确保多个群集应用程序之间的可用性，Microsoft 强烈建议 MS DTC 具有自己的资源组和资源。如果不能为 MS DTC 配置自己的资源组，建议使用群集组和仲裁驱动器。

其他软件的注意事项

  • 确保所有群集节点配置相同，包括 COM+、磁盘驱动器号和 Administrators 组中的用户。

  • 验证群集互连（信号）已正确配置。有关详细信息，请参阅知识库文章建议在群集服务器上使用的专用“信号”配置。

  • 验证已清除所有节点中的系统日志并再次查看了系统日志。确保在继续操作之前，日志中没有任何错误消息。

  • 如果将 SQL Server 2005 安装到具有多个磁盘驱动器的 Windows 2000 群集组中，并选择将数据放在其中某个驱动器上，则 SQL Server 资源被设置为仅依赖于该驱动器。若要将数据或日志放在其他或附加磁盘资源上，必须先将依赖关系添加到附加磁盘的 SQL Server 资源。有关详细信息，请参阅如何为 SQL Server 2005 资源添加依赖关系。

  • 如果在原先不存在 Microsoft Windows 2000 或 Windows Server 2003 域控制器的环境中部署 Windows 2000 或 Windows Server 2003 群集节点，请参阅 Windows 2000 and Windows Server 2003 cluster nodes as domain controllers。

  • 若要使用加密，请在故障转移群集的所有节点上安装带有完全限定的虚拟服务器 DNS 名称的服务器证书。例如，如果您有一个包含两个节点的群集（节点的名称分别为“Test1.DomainName.com”和“Test2.DomainName.com”）和名为“Virtsql”的虚拟 SQL Server，则您必须获取“Virtsql.DomainName.com”的证书，并在 test1 和 test2 节点上安装该证书。然后，您可以在 SQL Server 配置管理器上选中“强制协议加密”复选框，从而配置故障转移群集以进行加密。

    重要事项：
    将证书安装在虚拟服务器中的所有参与节点上之前，请勿选中“强制协议加密”复选框。

  • 验证 MSCS 群集上未安装防病毒软件。有关详细信息，请参阅知识库文章 Antivirus software may cause problems with cluster services。

  • Windows Server 2003 终端服务器不支持 SQL Server 2005。有关详细信息，请参阅知识库文章 SQL Server 2000 is not supported on Windows Server 2003 Terminal Server application server。

  • 验证未压缩要安装 SQL Server 的磁盘。如果尝试将 SQL Server 安装到压缩驱动器上，SQL Server 安装程序将失败。

网络的注意事项

  • 验证在开始安装 SQL Server 之前，已对所有专用网卡禁用 NetBIOS。

  • SQL Server 的网络名称和 IP 地址不能用于任何其他目的，例如共享文件。如果要创建文件共享资源，请为该资源指定唯一的网络名称和 IP 地址。

重要事项：
Microsoft 建议您不要在数据驱动器上使用文件共享，因为它们可能影响 SQL Server 的行为和性能。

  • 虽然 SQL Server 2005 在群集中支持 TCP/IP 上的命名管道和 TCP/IP 套接字，但 Microsoft 建议在群集配置中使用 TCP/IP 套接字。

其他注意事项

  • 若要创建故障转移群集，您必须是本地管理员，具有作为服务登录的权限并在虚拟服务器的所有节点上作为操作系统的一部分。

  • 为将要作为 SQL Server 2005 故障转移群集的一部分安装的群集服务创建域组。必须以属于域组成员的域帐户身份运行 SQL Server 服务、SQL Server 代理服务、Analysis Services 服务和全文搜索服务。如果需要，请向域管理员询问现有域组的名称，或者为故障转移群集创建域组。有关详细信息，请参阅群集服务的域组。

  • 群集节点作为域控制器的位置不支持 SQL Server 故障转移群集。

  • 配置域名服务 (DNS) 或 Windows Internet 名称服务 (WINS)。DNS 服务器或 WINS 服务器必须在要安装 SQL Server 虚拟服务器的环境中运行。SQL Server 安装程序要求 SQL Server IP 接口虚拟引用注册动态域名服务 (DDNS)。如果无法完成动态注册，安装程序将失败，安装将回滚。如果无可用的动态注册，则必须在 DNS 中预注册服务器。

  • 请查阅 安装 SQL Server 的安全注意事项中的内容。

  • 请查阅 系统配置检查器的检查参数中的内容。

  • 考虑故障转移群集是否支持您要使用的 SQL Server 工具、功能和组件。有关详细信息，请参阅故障转移群集。

  • 考虑您将如何监视和维护故障转移群集以实现高可用性目标。有关详细信息，请参阅维护故障转移群集和在故障转移群集中使用 SQL Server 工具。

  • 若要减少安装 SQL Server 2005 故障转移群集所需的时间，可以在运行 SQL Server 安装程序之前在所有故障转移群集节点上预安装 Microsoft .NET Framework 2.0。

请参阅

参考

安装 SQL Server 2005 的硬件和软件要求
系统配置检查器的检查参数

概念

创建虚拟服务器，安装故障转移群集
安装 SQL Server 的安全注意事项


创建虚拟服务器，安装故障转移群集

创建虚拟服务器，安装故障转移群集 |
 | 请参阅
准备安装 SQL Server 2005 > 配置高可用性 > 故障转移群集 >

若要安装 Microsoft SQL Server 2005 故障转移群集，必须通过运行 SQL Server 安装程序来创建和配置虚拟服务器。本主题介绍了虚拟服务器的元素以及有关命名虚拟服务器的重要信息。还介绍了安装故障转移群集的基本步骤。

虚拟服务器的元素

虚拟服务器可以在作为故障转移群集参与节点的一个或多个计算机上运行。参与节点的数量仅受操作系统的限制。

虚拟服务器包含：

  • Microsoft 群集服务 (MSCS) 群集组（也称为“资源组”）中的一个或多个磁盘的组合。每个资源组最多可以包含一个 SQL Server 实例。

  • 虚拟服务器的网络名称。此网络名称是虚拟服务器的名称。

  • 分配给虚拟服务器的一个或多个 IP 地址。

  • 包含 SQL Server、SQL Server 代理和全文搜索 (FTS) 服务的一个 SQL Server 2005 实例。

命名虚拟服务器

SQL Server 虚拟服务器始终像一台计算机一样显示在网络上。您必须使用 SQL Server 虚拟服务器名称连接到 SQL Server 虚拟服务器，而不是使用运行虚拟服务器的节点的计算机名称。这样做可以确保无论哪个节点运行 SQL Server，都可以始终使用同一名称连接到虚拟服务器。

虚拟服务器名称对于域必须是唯一的。SQL Server 不侦听本地服务器的 IP 地址，而是侦听在安装虚拟 SQL Server 期间创建的虚拟 IP 地址。

SQL Server 根据故障转移群集中的非重复注册表项和服务名称，确保在故障转移后 SQL Server 功能继续有效。因此，为 SQL Server 实例（包括默认实例）提供的名称在故障转移群集内的所有节点中以及故障转移群集内的所有虚拟服务器中都必须是唯一的。使用唯一实例名称可以确保配置为故障转移到单个服务器的 SQL Server 实例具有非重复的注册表项和服务名称。

SQL Server 与故障转移群集合并的注意事项

  • 计划将多个独立服务器合并到在故障转移群集上的虚拟 SQL Server 实例时，我们建议在计划进程中，确保群集节点硬件配置足以支持要承载的 SQL Server 实例数。

    下面是两个常用方案和可以应用到站点配置的建议解决方案的基础。

    方案 1

    您是一个宿主站点，并且希望最多向 23 个 SQL Server 实例提出下列资源要求：

    • 23 个 SQL Server 实例作为单个群集节点，每个实例需要 2 个处理器，共需要 46 个 CPU。

    • 23 个 SQL Server 实例作为单个群集节点，每个实例需要 2 GB 内存，共需要 48 GB 内存（多出来的 2 GB 内存用于操作系统）。

    • 23 个 SQL Server 实例作为群集磁盘阵列，每个实例需要 4 个磁盘，共需要 92 个磁盘。

    如果将故障转移成员数限制为可用节点的一半，则硬件要求将降为：

    • 23 个处理器、每节点 24 GB 内存和 46 个可用磁盘。

    在支持装入点的情况下，可以进一步减少磁盘总数。SQL Server 将需要每一宿主 3 个装入点具有 23 个磁盘或更多，以增加可用的磁盘空间。

    潜在的限制是，如果处理器和内存要求增加了，在保证现有 SQL Server 实例性能的情况下，现有硬件可能无法支持那些要求。

    方案 2

    将现有 SQL Server 迁移到故障转移群集

    首先，必须收集现有服务器的当前基准，注意所有现有瓶颈。假设基准性能统计信息提出下列要求，并且具有装入点的单个驱动器满足驱动器要求，则您将具有以下配置：

    • SQL Server 1 - 8 个处理器、16 GB 内存

    • SQL Server 2 - 4 个处理器、8 GB 内存（需要内存，预计 12 GB）

    • SQL Server 3 - 2 个处理器、16 GB 内存（基准表明需要其他处理器）

    • SQL Server 4 - 4 个处理器、8 GB 内存（需要更多网络带宽，为 4 个专用连接添加网络适配器）

    若要替换上述四个服务器，群集节点需要的最小配置如下：

    • 18 个处理器、54 GB 内存和 6 个网络适配器

在计算故障转移群集中的单个节点的最小配置的过程中要考虑下列内容：

  • 所需 CPU 总数

  • 所需总内存和

  • 所需磁盘数

  • 为操作系统添加 2 GB 的内存

请注意，在以前版本的 SQL Server 中遇到的磁盘约束不会影响 SQL Server 2005。在 SQL Server 2005 支持装入驱动器的情况下，每个 SQL Server 实例仅需要一个存储数据文件的群集磁盘。

安装故障转移群集

若要安装故障转移群集，您必须是本地管理员，具有作为服务登录的权限以及在虚拟服务器的所有节点上以操作系统方式操作的权限。

若要使用 SQL Server 安装程序安装故障转移群集，请执行下列操作：

  1. 标识创建虚拟服务器所需的信息（例如，群集磁盘资源、IP 地址和网络名称）以及故障转移可用的节点。有关详细信息，请参阅：

    • 安装故障转移群集前的准备工作

    • SQL Server 安装的安全注意事项

    在运行 SQL Server 安装程序之前必须执行上述配置操作；使用 Windows 群集管理器执行这些操作。对每个要配置的虚拟服务器都必须具有一个 MSCS 组。

  2. 启动 SQL Server 安装程序以开始安装故障转移群集。输入所有必要信息后，安装程序将把新的 SQL Server 二进制文件实例安装在虚拟服务器中每台计算机的本地磁盘上，把系统数据库安装在指定群集磁盘上。二进制文件以完全相同的路径安装在每个群集节点上，因此必须确保每个节点与群集中所有其他节点共享一个本地驱动器号。SQL Server 安装程序完成安装时，将创建新的具有所有故障转移群集资源的虚拟 SQL Server。

    安装完成后，如果由于任何原因而导致任何资源（包括 SQL Server）出现故障，则将在同一节点上重新启动资源或者组移动到可用的故障转移群集节点，具体取决于故障转移群集阈值配置。可用故障转移群集节点是一个在 SQL Server 安装时定义为对虚拟服务器可用的节点。

    注意：
    您还可以使用 SQL Server 安装 CD 上提供的 .ini 文件创建虚拟服务器。使用命令提示符安装故障转移群集仅适用于高级用户。有关使用 .ini 文件安装的详细信息，请参阅从命令提示符运行安装程序。

请参阅

参考

安装 SQL Server 2005 的硬件和软件要求

概念

安装故障转移群集前的准备工作

其他资源

升级到 SQL Server 2005


故障转移群集示例

故障转移群集示例 |
 | 请参阅
配置高可用性 > 故障转移群集 > 创建虚拟服务器，安装故障转移群集 >

以下示例说明了如何配置 Microsoft SQL Server 2005 故障转移群集。

前提条件

继续操作之前，请阅读安装故障转移群集前的准备工作。

示例

CLUSTERNODEA 和 CLUSTERNODEB 是故障转移群集中的两台计算机。

在群集磁盘（将在其中存放 SQL Server 数据文件）控制下的群集节点上运行 SQL Server 安装程序，并在名为 SQLCLUSTA 的虚拟服务器上创建 SQL Server 的默认实例。此虚拟服务器可以在 CLUSTERNODEA 上运行，也可以在 CLUSTERNODEB 上运行。

接下来，通过在连接字符串中将服务器名称指定为 SQLCLUSTA，连接到该服务器。

在群集磁盘（将在其中存放 SQL Server 数据文件）控制下的群集节点上再次运行安装程序。

重要事项：
SQL Server 使用的群集磁盘必须显示为独立磁盘。不能使用上一次安装虚拟服务器时使用的磁盘逻辑分区。

在名为 SQLCLUSTB 的新虚拟服务器上创建命名实例 Inst1。此服务器实例必须安装在另一个 Microsoft 群集服务 (MSCS) 群集资源组中。此虚拟服务器可以在 CLUSTERNODEA 上运行，也可以在 CLUSTERNODEB 上运行，这是由安装时添加到群集定义中的节点定义的。

接下来，通过将连接字符串指定为 SQLCLUSTB\Inst1，连接到该服务器。

两台虚拟服务器在由 CLUSTERNODEA 和 CLUSTERNODEB 组成的 MSCS 群集中运行。然而，它们是彼此完全独立的。每台虚拟服务器位于不同的 MSCS 资源组中，并且各有一组唯一的 IP 地址、不同的网络名称以及位于独立共享群集磁盘组上的数据文件。

MSCS 资源组中任何资源发生故障转移时，作为该组成员的所有资源也将发生故障转移。对于 SQLCLUSTA，一旦达到故障转移阈值，出现任何错误（如磁盘资源、IP 地址、网络名称或虚拟服务器内 SQL Server 安装错误）都将导致群集组的所有成员发生故障转移。

下图显示了包含二进制文件和数据且具有两个节点的群集。在此图中，每个虚拟服务器必须具有存放数据和日志文件的磁盘的独占所有权。

典型的 SQL Server 2005 故障转移群集

SQL Server 客户端只能看到粗体显示的连接点名称。

请参阅

概念

安装故障转移群集前的准备工作


升级到 SQL Server 2005 故障转移群集

升级到 SQL Server 2005 故障转移群集 |
 | 请参阅
配置高可用性 > 故障转移群集 > 创建虚拟服务器，安装故障转移群集 >

SQL Server 2005 支持升级数据库引擎和分析服务。有关升级支持的详细信息，请参阅升级到 SQL Server 2005 和版本升级。

请参阅

任务

如何升级到 SQL Server 2005 故障转移群集（安装程序）

参考

版本升级

概念

准备安装 SQL Server 2005

其他资源

升级到 SQL Server 2005


维护故障转移群集

维护故障转移群集 |
 | 请参阅
准备安装 SQL Server 2005 > 配置高可用性 > 故障转移群集 >

安装 Microsoft SQL Server 2005 故障转移群集后，可以使用 SQL Server 安装程序对现有的 SQL Server 虚拟服务器进行更改或修复。例如，可以向故障转移群集中的虚拟服务器添加节点，将群集实例作为独立实例运行，或者从群集实例配置中删除节点。

注意：
在此版本的 SQL Server 中，群集维护只能在“控制面板”中的“添加或删除程序”中进行。

向现有虚拟服务器中添加节点

SQL Server 安装程序包含维护现有虚拟服务器的选项。如果选择该选项，可以将其他节点添加到故障转移群集配置中。添加的节点数最多可以达到 Microsoft Windows 操作系统支持的节点数。

有关详细信息，请参阅如何创建新的 SQL Server 2005 故障转移群集（安装）。

从现有虚拟服务器中删除节点

可以从虚拟服务器配置中删除节点。虚拟 SQL Server 配置中的每个节点都是对等的，相互之间不存在依赖关系，因此可以删除任意节点。已损坏的节点不一定能被删除，并且删除过程将不会从不可用的节点中卸载 SQL Server 二进制文件。有关详细信息，请参阅如何创建新的 SQL Server 2005 故障转移群集（安装）。

可以随时将已删除的节点重新添加到故障转移群集内。

将 SQL Server 群集实例作为独立实例运行

通常情况下，SQL Server 群集实例在 Microsoft 群集服务 (MSCS) 的控制下运行。然而，也可能有必要将 SQL Server 群集实例作为独立实例运行。例如，若要以单用户模式运行 SQL Server 实例，则有必要从命令提示符将 SQL Server 群集实例作为独立实例运行，而不是通过 MSCS 启动 SQL Server。若要在独立模式下使用套接字连接到 SQL Server 群集实例，则对于安装了实例的虚拟服务器而言，IP 地址和网络名称资源都必须联机。

如果这些资源不能联机，可以使用命名管道进行连接。必须在客户端创建一个别名才能与 SQL Server 实例正在监听的管道名称通信。可以使用 SQL Server SQL Server 配置管理器来找出管道名称。

更改服务帐户

在故障转移群集节点关闭或脱机时，不得更改任何 SQL Server 服务帐户的密码。如果一定要这么做，则在所有节点回到联机状态后，必须使用 SQL Server 配置管理器重置该密码。

如果 SQL Server 的服务帐户不是群集中的管理员，则无法在该群集的任何节点上删除管理共享。管理共享必须在群集中可用，SQL Server 才能运行。

重要事项：
请勿对 SQL Server 服务帐户和 MSCS 帐户使用同一帐户。否则，如果更改了 MSCS 帐户的密码，SQL Server 安装将会失败。

请参阅

任务

如何从方案 1 中的故障转移群集故障中恢复
如何从方案 2 中的故障转移群集失败中恢复
如何删除 SQL Server 2005 故障转移群集实例（安装程序）

概念

安装故障转移群集前的准备工作


优化故障转移群集的性能

优化故障转移群集的性能 |
 | 请参阅
配置高可用性 > 故障转移群集 > 维护故障转移群集 >

若要在使用故障转移群集时优化其性能，请考虑以下问题。

写缓存

如果磁盘控制器不在群集计算机之外，则必须关闭控制器内的写缓存以防止在故障转移期间发生数据丢失。

在群集中的主机控制器上使用回写高速缓存会影响性能。但是，如果使用外部控制器，则仍然可以提高性能。外部磁盘阵列不受故障转移群集的影响，甚至能通过 SCSI 总线使高速缓存正确地同步。

文件共享

不要将同一个驱动器用于文件共享和群集 SQL Server 数据库。使用这样的驱动器会影响恢复所需的时间，并且会在出现资源故障时引起群集组故障转移。

最大内存大小

分配充足的内存有助于提高故障转移群集的性能。理论上，最大内存是总的可用内存减去操作系统、其他群集和本地到节点所安装资源占用的内存，再除以安装的 Microsoft SQL Server 实例数。请使用此公式确定并设置最大内存大小。我们建议将您的工作最大内存设置为此值的 80% 到 90%，并收集性能基本统计信息，以进一步优化该设置。

最小内存大小

当存在多个 SQL Server 实例并且已设置好最大内存设置时，应设置最小内存。设置最小内存大小可减少故障转移的时间。

群集 CPU 关联

CPU 关联的默认设置在大多数情况下都是首选设置。但是，如果系统超过了最大推荐性能阈值，请使用 N-1 方案设置群集 CPU 关联。

固定 IP 端口和固定内存设置

使用固定 IP 端口和固定内存设置。

请参阅

其他资源

sp_configure (Transact-SQL)
设置服务器配置选项


在故障转移群集中使用 SQL Server 工具

在故障转移群集中使用 SQL Server 工具 |
 | 请参阅
配置高可用性 > 故障转移群集 > 维护故障转移群集 >

您可以将大部分 Microsoft SQL Server 工具和服务用于故障转移群集。但是，在使用之前，应当了解下列注意事项。

全文查询

若要在故障转移群集中使用 Microsoft 搜索服务执行全文查询，请遵循下列要求：

  • 为了使全文查询在故障转移群集中正常工作，必须有一个 Microsoft SQL Server 2005 实例以同一个系统帐户运行在所有故障转移群集节点上。

    注意：
    这是故障转移群集的常规要求，并不仅限于 Microsoft 搜索服务。

  • 若要在故障转移群集中更改 SQL Server 2005 的启动帐户，必须使用 SQL Server 配置管理器。如果使用 Microsoft Windows 中的“控制面板”或“服务”应用程序来更改启动帐户，将破坏 SQL Server 的全文配置。

SQL Server 配置管理器

若要在故障转移群集中使用 SQL Server 配置管理器，请遵循下列要求：

  • 若要在故障转移群集中更改 SQL Server 2005 的启动帐户，必须使用 SQL Server 配置管理器。如果使用 Windows 中的“控制面板”或“服务”应用程序，则可能会破坏服务器配置。

  • 在创建或更改数据库时，只能查看本地虚拟服务器的群集磁盘。

  • 如果使用 SQL Server 配置管理器重置 SQL Server 服务账户属性，系统将提示您重新启动 SQL Server。在故障转移群集配置中，这样会使全文资源和 SQL Server 代理资源离线，并且在重新启动 SQL Server 后，不会使全文资源或 SQL Server 代理资源重新在线。必须使用 Windows 群集管理器实用工具，手动重新启动这些资源。

SQL Server Management Studio

  • 如果您正在使用 SQL Server Management Studio 浏览表并且在故障转移时丢失了到 SQL Server 的连接，便会看到错误消息“通信链接失败”。您必须按 Esc 键撤消更改并退出 SQL Server Management Studio 窗口。

    不能运行查询、保存任何更改或编辑网格。

服务控制管理器

使用服务控制管理器启动或停止 SQL Server 群集实例。不能暂停 SQL Server 群集实例。

SQL Server Profiler

可在故障转移群集中使用 SQL Server 事件探查器。但是，如果在运行 SQL Server 事件探查器 跟踪时发生故障转移，则必须在服务器重新在线后重新启动跟踪。

SQL Mail

如果客户端使用 Microsoft SQL Server 2000 Service Pack 3.0 或更高版本进行远程连接，则可以通过配置管理器对 SQL Server 2005 中的 SQL Mail 进行远程配置。

请参阅

参考

SQL Server 2005 的各种版本所支持的功能


故障转移群集故障排除

故障转移群集故障排除 |
 | 请参阅
配置高可用性 > 故障转移群集 > 维护故障转移群集 >

本主题介绍了下列问题：

  • 故障排除的基本步骤。

  • 从故障转移群集故障中恢复。

  • 解决最常见的故障转移群集问题。

  • 使用扩展存储过程和 COM 对象。

故障排除的基本步骤

使用 SQL Server 2005 故障转移群集时，请注意服务器群集是由运行在 Microsoft 群集服务 (MSCS) 下的虚拟服务器组成的。该虚拟服务器可驻留在基于 Microsoft 虚拟服务器的节点上，而这些节点提供了 Microsoft 服务器群集。

如果服务器群集所驻留的节点存在问题，则这些问题本身可视为虚拟服务器的问题。若要调查并解决这些问题，请按以下顺序对 SQL Server 故障转移群集进行故障排除：

  1. 硬件：查看 Microsoft Windows 系统事件日志。

  2. 操作系统：查看 Windows 系统和应用程序事件日志。

  3. 网络：查看 Windows 系统和应用程序事件日志。根据知识库文章 Recommended Private "Heartbeat" Configuration on a Cluster Server 验证当前配置。

  4. 安全性：查看 Windows 应用程序和安全性事件日志。

  5. MSCS：查看 Windows 系统和应用程序事件日志以及群集日志。

  6. SQL Server：验证硬件、操作系统、网络、安全性和 MSCS 基础均没有问题后，像平常一样进行故障排除。

从故障转移群集故障中恢复

通常，故障转移群集故障有以下两个原因：

  • 双节点群集的一个节点出现硬件故障。此硬件故障可能是由 SCSI 卡或操作系统中的故障造成的。

    若要从此故障中恢复，请使用 SQL Server 安装程序将故障节点从虚拟服务器中删除，在计算机脱机的情况下解决硬件故障，重新启动计算机，然后将修复后的节点添加回虚拟服务器。

    有关详细信息，请参阅如何创建新的 SQL Server 2005 故障转移群集（安装）和如何从方案 1 中的故障转移群集故障中恢复。

  • 操作系统故障。在这种情况下，节点处于脱机状态，但并非无法解决该故障。

    若要从操作系统故障中恢复，请恢复节点并测试故障转移。如果 SQL Server 实例未能正确地进行故障转移，必须使用 SQL Server 安装程序从故障转移群集中删除 SQL Server，进行必要的修复，重新启动计算机，然后将修复后的节点添加回虚拟服务器。

    使用此方法从操作系统故障中恢复可能要花些时间。如果很容易从操作系统故障中恢复，请不要使用此方法。

    有关详细信息，请参阅如何创建新的 SQL Server 2005 故障转移群集（安装）和如何从方案 2 中的故障转移群集失败中恢复。

另外请注意，SQL Server 2005 中对故障转移群集进行了下列更改：

  • 在 SQL Server 2005 中，日志文件所在的目录与 SQL Server 早期版本中的日志文件所在的目录不同。有关详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。

  • 在 SQL Server 2005 中，不识别实例的组件仅安装在主节点上；而在 SQL Server 2000 中，不识别实例的组件安装在所有节点上。有关详细信息，请参阅设置 Windows 服务帐户。

  • 在 SQL Server 2005 中，目录和注册表结构与早期版本中的不同。有关详细信息，请参阅设置 Windows 服务帐户和SQL Server 2005 的默认实例和命名实例的文件位置。

解决常见问题

以下列表介绍了常见的使用问题并说明如何解决这些问题。

问题：不正确地使用命令提示符语法安装 SQL Server 2005

问题 1：在命令提示符中使用 /qn 开关时，很难诊断安装程序问题，因为 /qn 开关取消了所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。

解决方法 1：使用 /qb 开关替代 /qn 开关。如果使用 /qb 开关，则将显示每个步骤中的基本 UI（包括错误消息）。

问题 2：未遵循 template.ini 文件中使用的格式，该文件位于 SQL Server 2005 安装介质的根目录下。

解决方法 2：在安装命令中包含所有必要变量，尽管安装程序可能会忽略不需要的字符。

在命令行中，变量与其值之间不应有空格。例如，“ADDLOCAL=ALL”中没有空格。如果使用“ADDLOCAL = ALL”，则安装程序将失败。再如 IP 及其值。“IP=www.xxx.yyy.zzz,Local Area Connection”是正确的。如果在“,”后插入一个空格，则安装程序将失败。

问题：SQL Server 2005 在迁移到另一个节点后无法登录到网络

问题 1：SQL Server 服务帐户无法与域控制器取得联系。

解决方法 1：检查事件日志以查看是否存在网络连接问题，例如适配器故障或 DNS 问题。验证是否能成功对域控制器运行 ping 命令。

问题 2：所有群集节点上的 SQL Server 服务帐户密码并非全都一致，或者节点没有重新启动从失败的节点迁移过来的 SQL Server 服务。

解决方法 2：使用 SQL Server 配置管理器更改 SQL Server 服务帐户密码。如果不这样做，并且更改了其中一个节点上的 SQL Server 服务帐户密码，也必须更改所有其他节点上的密码。SQL Server 配置管理器会自动执行此操作。

问题：SQL Server 无法访问群集磁盘

问题 1：并未在所有节点上都更新了固件或驱动程序。

解决方法 1：确保所有节点都使用正确的固件版本和相同的驱动程序版本。

问题 2：如果失败的节点位于具有不同驱动器号的共享群集磁盘上，则其他节点无法恢复从该节点迁移过来的群集磁盘。

解决方法 2：两台服务器上的群集磁盘的磁盘驱动器号必须相同。如果不相同，请检查操作系统和 Microsoft 群集服务 (MSCS) 的原始安装。

问题：SQL Server 服务故障导致故障转移

解决方法：若要防止特定服务的故障导致 SQL Server 组进行故障转移，请使用 Windows 中的群集管理器配置这些服务，如下所示：

  • 在“全文属性”对话框的“高级”选项卡中，清除“影响组”复选框。但是，如果 SQL Server 导致故障转移，则全文搜索服务将重新启动。

问题：SQL Server 不自动启动

解决方法：使用 MSCS 中的群集管理器自动启动某个故障转移群集。SQL Server 服务应该设置为手动启动，应该在 MSCS 中配置群集管理器，使其启动 SQL Server 服务。

问题：网络名称离线，无法使用 TCP/IP 连接到 SQL Server

问题 1：DNS 失败，而群集资源设置为需要 DNS。

解决方法 1：更正 DNS 问题。

问题 2：网络上存在重复的名称。

解决方法 2：使用 NBTSTAT 查找重复的名称，然后更正问题。

问题 3：SQL Server 不是使用 Named Pipes 进行连接。

解决方法 3：若要使用 Named Pipes 进行连接，请使用 SQL Server 配置管理器创建一个别名，以连接到适当的计算机。例如，如果有一个群集包含两个节点（Node A 和 Node B）和一个具有默认实例的虚拟服务器 (Virtsql)，则可以执行下列步骤连接到网络名称资源已离线的服务器：

  1. 使用群集管理器确定包含 SQL Server 实例的组在哪个节点上运行。对于本例，此节点是 Node A。

  2. 使用 net start 在该计算机上启动 SQL Server 服务。有关使用 net start 的详细信息，请参阅手动启动 SQL Server。

  3. 在 Node A 上启动 SQL Server 配置管理器。查看服务器正在侦听的管道名称。它应类似于 \\.\$$\VIRTSQL\pipe\sql\query。

  4. 在客户机上，启动 SQL Server 配置管理器。

  5. 创建别名 SQLTEST1 以通过命名管道连接到此管道名称。为此，请输入 Node A 作为服务器名称并将管道名称编辑为 \\.\pipe\$$\VIRTSQL\sql\query。

  6. 使用别名 SQLTEST1 作为服务器名称连接此实例。

问题：群集上的 SQL Server 安装程序因发生错误 1058 而失败

问题：在群集节点上禁用任务计划程序服务会导致安装程序失败并出现代码为 1058 的错误。core.log 中包含以下一项：

复制代码
Error: SetTargetComputer on \\machinename failed with
Unable to start service (1058)
Error: RunRemoteProcess Received return code 1058 from STPCOMPAQ3790N2

这是日志的最后一行：

复制代码
<EndFunc Name='DwLaunchMsiExec' Return='1058' GetLastError='183'>

解决方法：使用群集管理器在所有群集节点上都启用任务计划程序服务。有关详细信息，请参阅如何启用 Windows 任务计划程序服务。

问题：群集上的 SQL Server 安装程序因发生错误 11001 而失败

问题：[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.X\Cluster] 中存在孤立的注册表项

解决方法：确保当前未使用 MSSQL.X 注册表配置单元，然后删除该群集项。

问题：群集安装错误：“安装程序没有足够的特权来访问目录 <驱动器号>\Microsoft SQL Server。安装无法继续。请以管理员身份登录，或与您的系统管理员联系”

问题：此错误是由于 SCSI 共享驱动器未正确分区而引起的。

解决方法：执行下列步骤以在该共享磁盘上重新创建一个分区：

  1. 从群集中删除磁盘资源。

  2. 删除磁盘上的所有分区。

  3. 在磁盘属性中验证磁盘是否为基本磁盘。

  4. 在共享磁盘上创建一个分区、格式化该磁盘并为磁盘分配一个驱动器号。

  5. 使用群集管理器 (cluadmin) 将磁盘添加到群集中。

  6. 运行 SQL Server 安装程序。

问题：应用程序无法在分布式事务处理中登记 SQL Server 2005 资源

问题：由于在 Windows 中未完全配置 Microsoft 分布式事务处理协调器 (MS DTC)，因此应用程序可能无法在分布式事务中登记 SQL Server 2005 资源。此问题可能会影响使用分布式事务的链接服务器、分布式查询和远程存储过程。

解决方法：若要避免此类问题，必须在安装 SQL Server 2005 的服务器上完全启用 MS DTC 服务。

若要完全启用 MS DTC，请执行下列步骤：

  1. 在“控制面板”中，打开“管理工具”，然后打开“计算机管理”。

  2. 在“计算机管理”的左侧面板中，展开“服务和应用程序”，然后单击“服务”。

  3. 在“计算机管理”的右侧面板中，右键单击 Distributed Transaction Coordinator，并选择“属性”。

  4. 在“Distributed Transaction Coordinator 的属性”窗口中，单击“常规”选项卡，再单击“停止”来停止此服务。

  5. 在“Distributed Transaction Coordinator 的属性”窗口中，单击“登录”选项卡，将登录帐户设置为 NT AUTHORITY\NetworkService。

  6. 单击“应用”和“确定”，关闭“Distributed Transaction Coordinator 的属性”窗口。关闭“计算机管理”窗口。关闭“管理工具”窗口。

注意：
在故障转移群集内的计算机上安装 SQL Server 2005 时，必须在运行安装程序之前完全启用 MS DTC 并为其设置群集。如果 MS DTC 未设置群集，安装程序将失败。在运行安装程序之前，请使用 Microsoft 群集管理器确保 MS DTC 已设置了群集。

使用扩展存储过程和 COM 对象

如果在故障转移群集配置中使用扩展存储过程，所有扩展存储过程都必须安装在与 SQL Server 相关的群集磁盘中。这样做可确保当某节点发生故障转移时，仍能继续使用扩展存储过程。

如果扩展存储过程使用 COM 组件，管理员必须在群集的所有节点中都注册 COM 组件。活动节点的注册表中必须包含加载和执行 COM 组件所需的信息，才能创建这些组件。否则，这些信息将保留在最先注册 COM 组件的计算机的注册表中。

请参阅

概念

如何查看 SQL Server 2005 安装日志文件

其他资源

How Extended Stored Procedures Work
Execution Characteristics of Extended Stored Procedures


配置可用性帮助主题

配置可用性帮助主题 |
 | 请参阅
准备安装 SQL Server 2005 > 配置高可用性 >

本节的主题是说明如何设置和使用 SQL Server 2005 中的故障转移群集功能：

  • 故障转移群集操作指南帮助主题

  • 数据库镜像帮助主题

  • 日志传送操作指南帮助主题

请参阅

概念

故障转移群集

其他资源

数据库镜像
日志传送


故障转移群集操作指南帮助主题

故障转移群集操作指南帮助主题 |
 | 请参阅
准备安装 SQL Server 2005 > 配置高可用性 > 配置可用性帮助主题 >

本节中的操作指南帮助主题包含有关创建或维护故障转移群集的信息。在创建 Microsoft SQL Server 2005 故障转移群集前，您必须使用群集管理器对 Microsoft 群集服务 (MSCS) 进行配置。

本节内容

  • 如何创建新的 SQL Server 2005 故障转移群集（安装）

  • 如何为 SQL Server 2005 资源添加依赖关系

  • 如何删除 SQL Server 2005 故障转移群集实例（安装程序）

  • 如何从方案 1 中的故障转移群集故障中恢复

  • 如何从方案 2 中的故障转移群集失败中恢复

  • 如何更改 SQL Server 2005 故障转移群集的 IP 地址

  • 如何启用 Windows 任务计划程序服务

  • 如何安装 Microsoft 分布式事务处理协调器

相关主题

  • 故障转移群集

  • 安装故障转移群集前的准备工作

请参阅

其他资源

配置可用性帮助主题


如何创建新的 SQL Server 2005 故障转移群集（安装）

如何创建新的 SQL Server 2005 故障转移群集（安装） |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

使用 SQL Server 2005 安装向导可以安装 Microsoft SQL Server 2005，或将 SQL Server 以前的版本升级为 SQL Server 2005。SQL Server 2005 安装程序基于 Microsoft Windows 安装程序，以功能树的形式呈现所有可以安装的 SQL Server 2005 组件；您无需单独安装各组件。

有关升级的信息，请参阅版本升级和升级到 SQL Server 2005。

若要安装独立的 SQL Server 2005 实例，请参阅如何安装 SQL Server 2005（安装程序）。

必备项

在开始之前，请查阅以下 SQL Server 联机丛书主题：

  • 准备安装 SQL Server 2005

  • 安装故障转移群集前的准备工作

  • 请务必阅读并严格按照此 Microsoft 网站上文章中的说明进行操作。

  • 在创建 Microsoft SQL Server 故障转移群集之前，必须配置 Microsoft 群集服务 (MSCS) 并使用 Microsoft Windows 2000 或 Windows Server 2003 Enterprise Edition 中的群集管理器在共享驱动器上至少创建一个群集磁盘资源。

  • 对于本地安装，必须以管理员身份运行 SQL Server 安装程序。如果从远程共享位置安装 SQL Server，必须使用对该远程共享位置具有读取和执行权限的域帐户。

注意：
在运行 SQL Server 安装程序之前，请记录群集管理器中共享驱动器的位置，因为在创建新的故障转移群集时将需要此信息。

创建新的 SQL Server 2005 故障转移群集

  1. 将 Microsoft SQL Server 2005 DVD 插入 DVD 驱动器。如果 SQL Server 安装向导没有自动启动，请双击 DVD 根目录下的 Splash.hta。

    如果从网络位置安装，请共享安装文件，并将要安装 SQL Server 的计算机连接到该位置。

  2. 若要开始安装过程，请单击“安装 SQL Server”。

  3. 在“最终用户许可协议”页上，阅读许可协议，再选中相应的复选框以接受许可条款和条件。接受许可协议后即可激活“下一步”按钮。若要继续，请单击“下一步”。若要结束安装程序，请单击“取消”。

  4. 此时，将运行“SQL Server 组件更新”，以便在安装 SQL Server 前安装必需的软件。有关组件要求的详细信息，请单击该页底部的“帮助”按钮。若要在组件更新运行后继续执行操作，请单击“完成”。

  5. 在 SQL Server 安装向导的“欢迎”页上，单击“下一步”以继续安装。

  6. 在“系统配置检查 (SCC)”页上，将扫描安装计算机，以检查是否存在可能妨碍安装程序的条件。有关配置检查项的详细信息，请参阅系统配置检查 (SCC)。

    若要中断扫描，请单击“停止”。若要在扫描完成后继续进行安装，请单击“继续”。

    注意：
    如果扫描操作检查出任何错误，请确定是哪些错误，再单击“退出”。只有在解决可能妨碍安装的错误之后，才能完成安装。有关详细信息，请参阅系统配置检查器的检查参数。

  7. 在“Microsoft SQL Server 安装”页上，SQL Server 安装向导将进行一些准备工作，以便安装该软件。在准备工作完成后，安装向导将继续往下进行。

  8. 在“注册信息”页上的“姓名”和“公司”文本框中，输入相应的信息。若要继续，请单击“下一步”。

  9. 在“要安装的组件”页上，请选择要安装的组件。

    选择各个组件组时，“要安装的组件”窗格中会显示相应的说明。您可以选中任意一些复选框。在选择 SQL Server 或 Analysis Services 时，如果安装程序检测到您要安装到虚拟服务器，则会启用“创建 SQL Server 故障转移群集”或“创建分析服务器故障转移群集”复选框。必须选择此选项才可以安装故障转移群集。如果在另一台服务器上已经安装了管理工具，并且您希望缩短安装时间，则可以选择在初始安装时不安装管理工具，这样，您可以在第二次运行 SQL Server 安装程序时远程配置新服务器来安装管理工具。

    若要安装个别的组件或指定文件的安装位置，请单击“高级”。否则，请进行选择，再单击“下一步”。

  10. 如果在上一页中单击了“高级”，此时将显示“功能选择”页。在“功能选择”页上，使用下拉框选择要安装的程序功能。若要将组件安装到自定义的目录下，请选择相应的功能，再单击“浏览”。有关此页功能的详细信息，请参阅功能选择。若要继续安装，请在完成功能选择后单击“下一步”。

  11. 在“实例名”页上，请为安装的软件选择默认实例或已命名的实例。如果已经安装了默认实例或已命名实例，并且为安装的软件选择了现有实例，安装程序将升级所选的实例，并提供安装其他组件的选项。

    计算机上必须没有默认实例，才可以安装新的默认实例。

    若要安装新的命名实例，请单击“命名实例”，然后在提供的空白处键入一个唯一的实例名。有关实例命名规则的详细信息，请参阅实例名称。

  12. 在“虚拟 SQL Server 名称”页上，为您安装的软件键入一个唯一的实例名。此名称用于在网络中标识故障转移群集。虚拟 SQL Server 的名称在网络中必须是唯一的，并且必须与主机群集和群集节点的名称不同。若要继续安装，请单击“下一步”。

    重要事项：
    不能将实例命名为 DEFAULT 或 MSSQLSERVER。名称必须遵循 SQL Server 标识符的规则。有关实例命名规则的详细信息，请参阅实例名称。

    注意：
    只有在安装程序检测到您正在运行 MSCS 时，才会显示“虚拟 SQL Server 名称”页。如果没有显示“虚拟 SQL Server 名称”页，请取消安装程序，然后配置 MSCS。有关此页的详细帮助信息，请参阅虚拟服务器名称。

  13. 在“虚拟 SQL Server 配置”页上，为每个配置为提供客户端访问的网络输入一个 IP 地址。也就是为符合以下条件的每个网络输入一个 IP 地址：公共（或混合）网络中的客户端可以访问此网络的虚拟 SQL Server。每个子网络只能有一个 IP 地址。

    若要避免 IP 地址冲突，请确保没有其他任何应用程序共享分配给信号的 IP 地址和分配给 SQL Server 2005 的 IP 地址。

    选择要为其输入 IP 地址的网络，然后输入 IP 地址。单击“添加”按钮。

    将显示该 IP 地址及子网。子网由 MSCS 提供。继续为每个已安装的网络输入 IP 地址，直到所有需要的网络都填充了 IP 地址。若要继续安装，请单击“下一步”。有关详细信息，请参阅虚拟服务器配置。

  14. 在“选择群集组”页上，从“可用群集组”中选择包含要用于 SQL Server 的驱动器的组。选择的群集组就是 SQL Server 虚拟 SQL Server 资源所在的组。如果选择了包含群集仲裁资源的组，则会显示一条警告，建议您不要安装到群集仲裁资源。此外，您还可以在“数据文件”字段中为数据文件指定自定义的路径。若要继续安装，请单击“下一步”。有关详细信息，请参阅群集组选择。

  15. 在“群集节点配置”页上，指定将要包含在虚拟 SQL Server 中的节点。若要向虚拟 SQL Server 中添加一个节点，请从“可用节点”列表中选择计算机，再单击“添加”。若要从虚拟 SQL Server 中删除一个节点，请从“所选节点”列表中选择计算机，再单击“删除”。所有不可用的节点显示在“不可用节点”列表中，其中还将显示节点不可用的原因。

    若要创建单节点故障转移群集，应该在“所需节点”列表中只列出将要安装在虚拟 SQL Server 上的节点。

    若要继续安装，请单击“下一步”。有关详细信息，请参阅群集节点配置。

  16. 在“远程帐户信息”页上，您可以通过键入对群集的所有节点都具有管理员权限的用户名和密码来指定远程登录信息。此对话框仅在安装到远程节点时才会出现。您提供的凭据仅用于在安装 SQL Server 期间为虚拟 SQL Server 中的每个节点配置 SQL Server。此帐户必须是群集的所有节点的有效管理员帐户。若要继续安装，请单击“下一步”。有关详细信息，请参阅远程帐户信息。

  17. 在“服务帐户(群集)”页上，为 SQL Server 服务帐户指定用户名、密码和域名。您可以对所有服务使用一个帐户。虚拟 SQL Server 的所有服务帐户都必须是域帐户。选中“为每个服务帐户进行自定义”框后，即可从“服务”列表中选择特定的服务，相应地指定“用户名”、“密码”和“域”。SQL Server 代理服务的帐户必须是群集节点的管理员。使用的帐户不得与分配给群集服务的帐户相同。

    根据需要，可以为各个服务指定单独的帐户。若要为各个服务指定单独的帐户，请选中“为每个服务帐户进行自定义”，从下拉框中选择服务名称，然后为该服务提供登录凭据。若要继续安装，请单击“下一步”。有关详细信息，请参阅服务帐户（分类）。

    注意：
    域名不能为完整的 DNS 名称。例如，如果 DNS 名称为 my-domain-name.com，请在“域”字段中使用 my-domain-name。在 SQL Server 中，“域”字段不接受 my-domain-name.com。

  18. 在“群集服务的域组”页中，为要安装的每个群集服务提供一个域名\组名 (DomainName\GroupName)：必须以属于域组成员的域帐户身份运行 SQL Server 服务、SQL Server 代理服务、Analysis Services 服务和全文搜索服务。若要继续安装，请单击“下一步”。有关详细信息，请参阅群集服务的域组。

  19. 在“身份验证模式”页上，选择要用于 SQL Server 安装的身份验证模式。此外，还必须输入并确认系统管理员 (sa) 登录时所使用的强密码。若要继续安装，请单击“下一步”。

    安全说明：
    如果可能，请使用 Windows 身份验证。

    安全说明：
    此版本中，对于 Windows Server 2003（安装该系统的计算机不是域成员）的一些默认配置，SQL Server 安装程序可能不会限制必须设置强密码。设置强密码对于确保系统的安全至关重要。请务必使用强密码。有关强密码的指南，请参阅 SQL Server 2005 联机丛书中的身份验证模式。

  20. 在“排序规则设置”页上，指定服务器的排序规则。您可以对 SQL Server 和 SQL Server Analysis Services 使用一种排序规则，也可以为各个组件指定相应排序规则。

    若要为 SQL Server 和 SQL Server Analysis Services 设置单独的排序规则，请选中“为每个服务帐户进行自定义”复选框。选中该复选框后，将显示一个下拉框。从下拉选择框中选择一个服务，然后分配其排序规则。对每个服务重复以上操作。若要继续安装，请单击“下一步”。有关详细信息，请参阅排序规则设置。

  21. 在“错误和使用情况报告设置”页上，根据需要清除某些复选框以禁用错误报告和功能使用情况报告。若要继续安装，请单击“下一步”。有关详细信息，请参阅错误和使用情况报告设置。

  22. 在“准备安装”页上，查看要安装的 SQL Server 功能和组件的摘要。若要继续安装，请单击“安装”。

  23. 在“安装进度”页上，您可以通过从“节点”下拉框中选择节点来监视各个群集节点的安装进度。将显示所选节点的安装进度。若要在安装期间查看某个组件的日志文件，请单击“安装进度”页上的产品或状态名称。

  24. 在“完成 Microsoft SQL Server 安装向导”页上，可以通过单击此页上提供的链接查看安装摘要日志。若要退出 SQL Server 安装向导，请单击“完成”。

  25. 如果提示您重新启动计算机，请立即重新启动。完成安装后，阅读来自安装程序的消息是很重要的。如果有任何指定的节点未重新启动，均可能会导致以后运行安装程序失败。

后续步骤

  • 配置新安装的 SQL Server - 为减少系统的可攻击范围，SQL Server 2005 将选择性地安装并激活一些重要服务和功能。有关如何激活 SQL Server 2005 相应功能的详细信息，请参阅 SQL Server 外围应用配置器。

有关日志文件位置的信息，请参阅如何查看 SQL Server 2005 安装日志文件。

有关验证新安装的 SQL Server 的详细信息，请参阅如何验证 SQL Server 2005 服务的安装成功。

请参阅

任务

如何从命令提示符安装 SQL Server 2005


如何在 SQL Server 2005 故障转移群集中添加或删除节点（安装程序）

如何在 SQL Server 2005 故障转移群集中添加或删除节点（安装程序） |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

使用此过程管理 Microsoft SQL Server 2005 故障转移群集实例中的节点。

重要事项：
若要更新或删除 SQL Server 故障转移群集，您必须是一个本地管理员，且具有作为故障转移群集的所有节点上的服务进行登录的权限。

在 SQL Server 2005 故障转移群集中添加或删除节点

  1. 双击“控制面板”中的“添加或删除程序”。

  2. 选择要更新的 SQL Server 2005 组件，然后单击“更改”。将启动 SQL Server 2005 安装向导。

  3. 在“选择组件”页上，选择要更改的 SQL Server 2005 实例名。单击“下一步”。

  4. 在“功能维护”页上，从所选的 SQL Server 2005 实例中选择要更改的组件。单击“下一步”。将启动 SQL Server 2005 系统配置检查器。

    在“欢迎”页上，单击“下一步”。系统配置检查器将扫描计算机的现有配置。

  5. 在系统配置检查器完成扫描后，单击“下一步”。

  6. 在“更改或删除实例”页上，单击“维护虚拟服务器”。

  7. 在“群集节点配置”页上，指定要包含在虚拟 SQL Server 中的节点。若要向虚拟 中添加节点，请从“可用节点”列表中选择计算机并单击“添加”。若要从虚拟 SQL Server 中删除节点，请从“所选节点”列表中选择计算机并单击“删除”。不可用的节点显示在“不可用节点”列表中，还会显示不可用的原因。

    若要创建单节点故障转移群集，只有要与 SQL Server 以前安装的节点才列在“所需节点”列表中。

    单击“下一步”。有关详细信息，请参阅群集节点配置。

  8. 在“准备更新”页上，检查 SQL Server 安装摘要。如果对您的选择满意，请单击“更新”。

  9. 在“安装进度”页上，可以通过从“节点”列表中选择节点来监视单个群集节点的安装进度。将显示所选节点的安装进度。若要在安装期间查看某个组件的日志文件，请单击“安装进度”页上的产品或状态名称。

  10. 在“正在完成 Microsoft SQL Server 安装向导”页上，可以通过单击此页上提供的链接来查看安装摘要日志。若要退出 SQL Server 安装向导，请单击“完成”。

    如果安装程序指示您重新启动计算机，请立即重新启动计算机。安装完成之后，按照安装程序的指示进行操作非常重要。如果不重新启动任何指定的节点，可能会导致再次运行安装程序失败。

请参阅

任务

如何阅读 SQL Server 2005 安装日志文件
如何手动卸载 SQL Server 2005 故障转移群集

概念

如何查看 SQL Server 2005 安装日志文件


如何更改 SQL Server 2005 故障转移群集的 IP 地址

如何更改 SQL Server 2005 故障转移群集的 IP 地址 |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

若要维护或更新 Microsoft SQL Server 2005 故障转移群集，请使用“控制面板”中的“添加/删除程序”。有关命令提示符语法的信息，请参阅如何从命令提示符安装 SQL Server 2005。

开始之前，请查看下面的联机从书主题：安装故障转移群集前的准备工作。

有关更改群集节点中的网络适配器的 IP 地址的其他信息，请参阅此 Microsoft 知识库文章。

重要事项：
若要维护或更新 SQL Server 故障转移群集，您必须是本地管理员，有权作为服务登录该故障转移群集的所有节点。

更改现有 SQL Server 2005 故障转移群集的 IP 地址

  1. 从“开始”菜单中，单击“运行”，然后键入 cluadmin . 以启动群集管理器并连接到本地实例。

  2. 在左侧窗格中，展开“组”节点，然后选择要更新的组。

  3. 在右侧窗格中，右键单击“SQL IP Address1(虚拟 SQL Server 名称)”，然后选择“属性”。

  4. 单击“参数”选项卡，然后在“地址”字段中更新“SQL IP Address1(虚拟 SQL Server 名称)”的 IP 地址。

  5. 单击“应用”以实现更改。可能会显示下面的警告对话框：

    “群集管理器标准扩展: 尝试设置属性时出错: 已存储属性，但是只有在下次资源联机时所有更改才会生效。错误 ID: 5024 (000013a0)。”

  6. 单击“确定”清除“群集管理器标准扩展”对话框，此时您将返回到“群集管理器”。若要使资源脱机，然后再使其重新联机，请使用下列步骤。

  7. 在右侧窗格中，右键单击“SQL IP Address1(虚拟 SQL Server 名称)”，然后选择“脱机”。您将看到“SQL IP Address1(虚拟 SQL Server 名称)”、“SQL 网络名称(虚拟 SQL Server 名称)”和 SQL Server 的状态从“联机”更改为“脱机挂起”，然后更改为“脱机”。

    注意：
    将 IP 更改传播到整个企业网络可能需要 30 分钟或更长的时间。您应当尝试使“SQL IP Address1(虚拟 SQL Server 名称)”和“SQL 网络名称(虚拟 SQL Server 名称)”联机，然后尝试对虚拟 SQL Server 名称执行 ping 并等待 DNS 将该名称解析为新的 IP 地址。

  8. 在右侧窗格中，右键单击 SQL Server，然后选择“联机”。您将看到“SQL IP Address1(虚拟 SQL Server 名称)”、“SQL 网络名称(虚拟 SQL Server 名称)”和 SQL Server 的状态从“脱机”更改为“联机挂起”，然后更改为“联机”。

  9. 关闭“群集管理器”。

请参阅

概念

如何查看 SQL Server 2005 安装日志文件


如何安装 Microsoft 分布式事务处理协调器

如何安装 Microsoft 分布式事务处理协调器 |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

安装操作系统并配置群集之后，必须在 Microsoft Windows 2000 和 Microsoft Windows Server 2003 操作系统上配置 Microsoft 分布式事务处理协调器 (MS DTC)，才能使用群集管理器在群集中工作。配置 MS DTC 群集失败不会终止 SQL Server 2005 安装程序，但是如果 MS DTC 配置不正确，SQL Server 2005 应用程序的功能可能会受到影响。为了确保多个群集应用程序的可用性，强烈建议将 Microsoft 分布式事务处理协调器配置为拥有自己的资源组和资源。

手动在运行 MSCS 的 Windows Server 2003 操作系统上配置 MS DTC

  1. 请参阅如何在 Windows Server 2003 群集上配置 Microsoft 分布式事务处理协调器。

请参阅

任务

如何创建新的 SQL Server 2005 故障转移群集（安装）


如何启用 Windows 任务计划程序服务

如何启用 Windows 任务计划程序服务
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

本主题中所述的过程可以解决由于在群集节点上禁用 Windows 任务计划程序服务而导致在群集中无法运行 SQL Server 安装程序（错误 1058）的情况。如果群集节点上禁用了 Windows 任务计划程序服务，in_core.log 中的错误将类似于：

Connection to remote computer's scheduler service.

Error: SetTargetComputer on \\machinename failed with

Unable to start service (1058)

在 Windows 用户界面中将显示下面的错误消息：

无法启动服务，这可能是因为服务已被禁用，或者是因为它没有与其相关的启用的设备。

该错误的解决方法是在运行 Microsoft SQL Server 2005 安装程序之前使用群集管理器在所有群集节点上启用任务计划程序服务。

启用任务计划程序服务

  1. 在 Windows 的管理工具中，双击“服务”。

  2. 在“名称”列中，右键单击“任务计划程序”，再单击“启动”。

  3. 运行 SQL Server 2005 安装程序安装 SQL Server。


如何在包括 SQL Server 虚拟服务器的服务器群集上启用 Kerberos 身份验证

如何在包括 SQL Server 虚拟服务器的服务器群集上启用 Kerberos 身份验证 |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

Kerberos 是一种网络身份验证协议，用于为客户端/服务器应用程序提供严格的身份验证。Kerberos 为互操作性奠定了基础，同时增强了企业范围的网络身份验证的安全性。

您可以将 Kerberos 身份验证用于 Microsoft SQL Server 2005 的独立实例，或者用于在带有 Microsoft Windows 2000 Service Pack 3 (SP3) 的虚拟服务器上运行的故障转移群集实例。SQL Server 2005 支持 Microsoft Windows 2000 Active Directory 域典型安装中包含的这个功能。

当 SQL Server 所依赖的网络名称资源在基于 Windows 2000 的群集中时，将计算机升级到 Windows 2000 SP3 后，就可以对该资源使用 Kerberos 身份验证。有关对服务器群集启用 Kerberos 的其他信息，请参阅知识库文章“Kerberos Support on Windows 2000-based Server Clusters”。

下一节介绍了如何连接到运行 Microsoft Internet 信息服务 (IIS) 的服务器，以便与运行 SQL Server 的服务器建立 Kerberos 连接。

必备项

只有在运行 Windows 2000 SP3 时才能使用此功能。

在执行设置过程之前，请先下载 Kerbtray 和 SetSPN 实用工具。

  • 若要下载 Kerbtray 实用工具，请访问 Microsoft 网站。使用 Kerbtray.exe，您可以在所使用的任意关联计算机上轻松地验证和/或删除 Kerberos 票证。

  • 若要下载 SetSPN 实用工具，请访问 Microsoft 网站。

仅在客户端使用 TCP/IP 协议连接到 SQL Server 时，SQL Server 才使用 Kerberos。例如，如果客户端使用命名管道协议，则不使用 Kerberos。如果计算机上存在多个 SQL Server 实例，则必须为每个 SQL Server 实例配置服务器主体名称，因为每个 SQL Server 实例都使用唯一的 TCP-IP 端口。

对 SQL Server 2005 启用 Kerberos

连接到运行 Microsoft Internet 信息服务的服务器，并与 SQL Server 2005 建立 Kerberos 连接

  1. 步骤 1：配置域控制器

在域控制器的“Active Directory 用户和计算机”中：

  1. 右键单击要设置委托的计算机（IIS 服务器），再单击选中“此计算机可以信任，可用来委托”。如果运行 SQL Server 的计算机似乎是所连接的最后一台计算机，但该计算机有一台链接服务器，则还必须向其授予委托权限。如果它不是链中的最后一台计算机，则必须信任中间的所有计算机，使它们可用于委托。

  2. 向 SQL Server 服务帐户的域用户帐户授予委托权限。您必须有一个域用户帐户用于所安装的 SQL Server 群集（对于使用本地系统帐户运行 SQL Server 的计算机，不需要此步骤）：

    1. 在 Users 文件夹中，右键单击用户帐户，再单击“属性”。

    2. 在“用户帐户属性”对话框中，单击“帐户”选项卡。

    3. 在“帐户选项”下，单击以选中“帐户可以信任，可用来委托”复选框。确保为此帐户取消选中“帐户是敏感帐户，不能被委托”复选框。

  3. 使用 Kerbtray.exe 实用工具验证是否已从域控制器和主机接收到 Kerberos 票证：

    1. 右键单击通知区域中的 Kerbtray 图标，再单击“清除票证”。

    2. 等待绿色的 Kerbtray 图标从绿色变为黄色。之后，立即打开命令提示符窗口，然后运行以下命令：

      net session* /d

      这将删除现有会话，然后强制建立新会话并接收 Kerberos 票证。

步骤 2：配置 IIS 服务器

  1. 用 .asp 示例文件替换默认网站的 Wwwroot 文件。若要创建 .asp 示例文件，请使用“用于检索 SQL Server 数据的 ASP 测试脚本”一节中提供的代码。

  2. 将该文件添加到 Wwwroot 文件夹。若要执行此操作，请使用“用于检索 SQL Server 数据的 ASP 测试脚本”一节中的代码。将该文件另存为 Default.asp。

  3. 将 Web 服务器重新配置为仅使用集成 Windows 身份验证：

    1. 右键单击默认的 Web 服务器，再单击“安全性”文件夹。

    2. 在“安全性”文件夹中，进行正确的更改，再单击以清除“匿名访问”。

    3. 从命令提示符运行以下命令：

      cscript C:\Inetpub\Adminscripts\adsutil.vbs get w3svc/NTAuthenticationProviders

      如果启用了“协商”，将返回以下信息：

      NTAuthenticationProviders : (STRING) Negotiate,NTLM

    有关将 IIS 配置为支持 Kerberos 和 NTLM 身份验证的其他信息，请参阅知识库文章“How to Configure IIS to Support Both Kerberos and NTLM Authentication”。

注意：
必须在 IIS 服务器上安装 Microsoft 数据访问组件 (MDAC) 2.8 SP1 或更高版本。若要执行此操作（并使工具可用于测试），请在 Web 服务器上安装 Microsoft SQL Server 2000 客户端工具。若要只安装 MDAC 2.8 SP1 或更高版本，而不安装客户端工具，请访问 Microsoft 网站。

  1. 验证注册表中是否存在 HKLM\SW\MS\MSSQLSERVER\Client\DSQUERY 值。如果未显示该值，请将该值作为 DSQUERY:Reg_SZ:DBNETLIB 添加。

  2. 使用 Kerbtray.exe 实用工具验证是否已从域控制器和主机接收到 Kerberos 票证：

    1. 右键单击通知区域中的 Kerbtray 图标，再单击“清除票证”。

    2. 等待绿色的 Kerbtray 图标从绿色变为黄色。之后，立即打开命令提示符窗口，然后运行以下命令：

      net session * /d

      这将删除现有会话，然后强制建立新会话并接收 Kerberos 票证。

步骤 3：为 SQL Server 创建 SPN

注意：
仅在客户端使用 TCP/IP 协议连接到 SQL Server 时，SQL Server 才使用 Kerberos。例如，如果客户端使用命名管道协议，则不使用 Kerberos。如果计算机上存在多个 SQL Server 实例，则必须为每个 SQL Server 实例配置服务器主体名称，因为每个 SQL Server 实例都使用唯一的 TCP-IP 端口。

重要事项：
如果 SQL Server 服务在 LocalSystem 帐户下运行，则不必为 SQL Server 手动配置 SPN。启动 SQL Server 服务时会自动创建 SPN。如果 SQL Server 服务在域用户帐户下运行，则必须手动配置 SPN。为此，请按下列步骤进行操作。

若要为 SQL Server 配置 SPN，请使用 Microsoft Windows 资源工具包中的 SETSPN 实用工具。若要下载 SETSPN 实用工具，请访问 Microsoft 网站。

在运行 SETSPN 之前，请注意下列事项：

  • 必须以有权注册 SPN 的登录帐户运行 setspn.exe。

  • 请注意运行 SQL Server 实例的域用户帐户。在下列示例中，此帐户命名为 <SQL_Service_Account>。

    重要提示：如果在 LocalSystem 帐户下运行 SQL Server 实例，则不必运行 SETSPN 实用工具。

  • 必须拥有运行 SQL Server 的计算机的完全限定域名 (FQDN)。若要确定运行 SQL Server 的计算机的 FQDN，请使用 ping 实用工具。为此，请按下列步骤进行操作：

  1. 对运行 SQL Server 的计算机执行 ping 来确定其 IP 地址：

    C:\>ping MySQLServer

    Pinging MySQLServer.MyDomain.com [10.10.10.10] with 32 bytes of data:

    Reply from 10.10.10.10: bytes=32 time=1ms TTL=128

  2. 使用 ping -a 对 IP 地址执行反向查找，以确保域名系统 (DNS) 协议正确返回了 FQDN：

    C:\>ping -a 10.10.10.10

    Pinging MySQLServer.MyDomain.com [10.10.10.10] with 32 bytes of data:

    Reply from 10.10.10.10: bytes=32 time<1ms TTL=128

  3. 对虚拟 SQL Server 名称执行 ping 获取 IP 地址，然后运行 ping -a 以确保 DNS 正确返回了 FQDN。

注意：
如果使用了 SQL Server 故障转移群集，则对虚拟 SQL Server 使用 FQDN。请注意 SQL Server 实例所使用的正确 TCP/IP 端口。若要确定此信息，请在运行 SQL Server 的计算机上打开 SQL Server 配置管理器，单击 SQL Server 实例，然后查看 TCP/IP 协议（默认端口）的属性。

在确定运行 SQL Server 服务的域用户帐户、运行 SQL Server 的计算机的 FQDN 以及 SQL Server 实例所使用的 TCP/IP 端口之后，请按照下列步骤为 SQL Server 创建 SPN。

注意：
您必须是域管理员组的成员才能运行 SETSPN 命令。

  1. 如果使用了 SQL Server 故障转移群集，请运行以下 SETSPN 命令：

    setspn -A MSSQLSvc/<FQDN> <SQL_Service_Account>

    例如，如果 MySQLServer.MyDomain.com 在域用户帐户 SQLSVC 下运行，其中 MySQLServer.MyDomain.com 是 SQL Server 2005 群集实例的名称，请运行以下命令：

    setspn -A MSSQLSvc/MySQLServer.MyDomain.com SQLSVC

  2. 对于运行 SQL Server 的群集和非群集计算机，请运行以下 SETSPN 命令，为运行 SQL Server 的计算机所使用的端口注册 SPN：

    setspn -A MSSQLSvc/<FQDN>:<Port> <SQL_Service_Account>

    例如，如果 MySQLServer.MyDomain.com 在域用户帐户 SQLSVC 下、端口 1433 上运行，请使用以下 SETSPN 命令：

    setspn -A MSSQLSvc/MySQLServer.MyDomain.com:1433 SQLSVC

  3. 注册 SPN 后，使用 SETSPN 实用工具的 LIST 功能（-L 开关）验证是否已正确注册 SPN。运行 SETSPN -L <SQL_Service_Account> 以列出在运行 SQL Server 实例的域用户帐户中注册的所有 SPN：

    setspn -L <SQL_Service_Account>

    例如，如果 MySQLServer.MyDomain.com 在域用户帐户 SQLSVC 下、端口 1433 上运行，请使用以下命令：

    setspn -A SQLSVC

    在步骤 1（如果 SQL Server 是群集服务器）和步骤 2（如果 SQL Server 不是群集服务器）中创建的 SPN 将显示在以下输出中：

    C:\>setspn -l SQLSVC

    Registered ServicePrincipalNames for CN=SQLSVC,CN=Users,DC=MyDomain,DC=com:

        MSSQLSvc/MySQLServer.MyDomain.com

        MSSQLSvc/MySQLServer.MyDomain.com:1433

注意：
如果使用了 SQL Server 故障转移群集，则必须注册一个不带端口号的 SPN 和一个带端口号的 SPN。对于运行 SQL Server 的典型、非群集计算机，只需要注册带端口号的 SPN。但是，即使有不带端口号的其他 SPN，也不会给非群集计算机带来任何问题。

注意：
您也可以在域控制器上使用 Ldifde.exe 实用工具来验证这两个 SPN 注册。本主题中的“如何收集 Active Directory 服务器主体名称信息”一节对此进行了介绍。

步骤 4：配置客户机

  1. 对于每个将要连接的客户端，验证 Microsoft Internet Explorer 是否已配置为使用 Windows 身份验证：

  2. 在 Internet Explorer 中，在“工具”菜单上，单击“Internet 选项”。

  3. 单击“高级”选项卡。

    在“安全”下，单击以选中“启用集成 Windows 身份验证(需要重启动)”，然后单击“确定”。

步骤 5：测试配置

对于涉及的每台计算机：

  1. 登录到该计算机，然后使用 Kerbtray.exe 来验证该计算机是否可以从域控制器获取有效的 Kerberos 票证。

  2. 使用 Kerbtray.exe 删除该计算机上的所有票证。

  3. 创建并连接到用于返回 SQL Server 数据的网页。

注意：
将 SQLSERVERNAME 替换为运行 SQL Server 的计算机的名称：

  • 如果返回了数据，此页将显示身份验证类型 Negotiate 和 sp_helpdb 存储过程的结果 SQL Server 数据，该存储过程应返回通过 .ASP 页连接到的服务器上的数据库列表。

  • 如果在 SQL Server 上启用了审核，则在应用程序日志中，将看到该连接是“可信”的。

用于检索 SQL Server 数据的 ASP 测试脚本

下面是用于 SQL Server 数据的 ASP 测试脚本。如果使用此代码示例，请确保将 SQLSERVERNAME 替换为运行 SQL Server 的计算机的名称：

<%@ Language=VBScript %>

<HTML>

<HEAD>

<META NAME="GENERATOR" Content="Microsoft Visual Studio 6.0">

</HEAD>

<BODY>

<%="'auth_user' is" & request.servervariables("auth_user")%>

<P>

<%="'auth_type' is" & request.servervariables("auth_type")%>

<P>

Connections string is <B>" Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=pubs;Data Source=SQLSERVERNAME </B>

<P>

<%

set rs = Server.CreateObject("ADODB.Recordset")

set cn = Server.CreateObject("ADODB.Connection")

cn.Open "Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=pubs;Data Source=SQLSERVERNAME"

rs.open "MASTER..sp_helpdb",cn

Response.Write cstr(rs.Fields.Count) +"<BR>"

while not rs.EOF

Response.Write cstr(rs(0))+"<BR>"

rs.MoveNext

wend

rs.Close

cn.Close

set rs = nothing ' Frees memory reserved by the recordset.

set cn = nothing ' Frees memory reserved by the connection.

%>

</BODY>

</HTML>

如何收集 Active Directory 服务器主体名称信息

若要收集 Active Directory 服务器主体名称 (SPN) 信息，请在某个域控制器上键入下面的命令，其中 betaland 是 NetBIOS 域名，NewoutputUsers.txt 是用于输出结果的输出文件名。如果不使用完整路径，则文件将被放到运行命令行时的当前文件夹中。此示例命令可查询整个域：

复制代码
ldifde -d "CN=Users,DC=betaland" -l servicePrincipalName -F NewoutputUsers.txt

此语法创建名为 NewoutputUsers.txt 的文件，其中包含的信息与本主题的“NewouputUsers.txt 的域级输出”一节的输出相似。

收集整个域的信息时，此输出文件可能会过大。因此，若要仅收集与特定用户名相关的信息，请使用下面的语法，其中 User Name 是用户名，betaland 是要查询的域：

复制代码
ldifde -d "CN=User Name,DC=betaland" -l servicePrincipalName -F NewoutputUsers.txt

收集特定用户的信息可以大大减少搜索所涉及的数据。如果收集整个域的信息，请搜索相关服务器的特定用户名。在输出示例中，可以看到：

  • 服务器项不再存在，但并未从 Active Directory 中完全删除。

  • 用户“User Name”在大约十台不同服务器上拥有有效的 SPN 信息。

另外，可以使用 Active Directory 服务接口 (ADSI) 工具更正无效的 Active Directory 项。

注意：如果使用 ADSI 编辑管理单元、LDP 实用工具或其他 LDAP 版本 3 客户端，并且错误修改了 Active Directory 对象的属性，可能会导致严重问题。若要解决这些问题，可能需要重新安装 Microsoft Windows 2000 Server 和/或 Microsoft Exchange 2000 Server。Microsoft 不能保证解决由于错误修改 Active Directory 对象的属性而出现的问题。若要修改这些属性，您必须自行承担风险。

NewouputUsers.txt 的域级输出

dn: CN=User Name,CN=Users,DC=betaland

changetype: add

servicePrincipalName: MSSQLSvc/CLUSTERDEFAULT.betaland:1257

servicePrincipalName: MSSQLSvc/INST3.betaland:3616

servicePrincipalName: MSSQLSvc/INST2.betaland:3490

servicePrincipalName: MSSQLSvc/SQLMAN.betaland:1433

servicePrincipalName: MSSQLSvc/VSS1.betaland:1433

servicePrincipalName: MSSQLSvc/INST1.betaland:2536

servicePrincipalName: MSSQLSvc/INST4.betaland:3967

servicePrincipalName: MSSQLSvc/SQLVIRTUAL1.betaland:1434

servicePrincipalName: MSSQLSvc/SQLVIRTUAL.betaland:1433

servicePrincipalName: MSSQLSvc/SQLBUSTER.betaland:1315

请参阅

概念

安装 SQL Server 2005

其他资源

配置可用性帮助主题
升级到 SQL Server 2005


如何升级到 SQL Server 2005 故障转移群集（安装程序）

如何升级到 SQL Server 2005 故障转移群集（安装程序） |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

您可以使用 SQL Server 2005 安装向导安装 Microsoft SQL Server 2005 或从以前的 SQL Server 版本升级到 SQL Server 2005。

有关升级的信息，请参阅版本升级和升级到 SQL Server 2005。

若要安装独立的 SQL Server 2005 实例，请参阅如何安装 SQL Server 2005（安装程序）。

必备项

在开始之前，请阅读下列重要信息：

  • 准备安装 SQL Server 2005

  • 安装故障转移群集前的准备工作

  • 使用升级顾问来准备升级

  • 升级数据库引擎

  • 请务必阅读并严格按照此 Microsoft 网站上文章中的说明进行操作。

  • 若要进行本地安装，必须以管理员身份运行 SQL Server 安装程序。如果从远程共享位置安装 SQL Server，必须使用对该远程共享位置具有读取和执行权限的域帐户。

  • 若要将 SQL Server 实例升级到 SQL Server 2005 故障转移群集，要升级的实例必须是一个故障转移群集。若要将独立的 SQL Server 实例升级到 SQL Server 2005 故障转移群集，请安装一个新的 SQL Server 2005 故障转移群集，然后使用复制数据库向导迁移独立实例中的用户数据库。有关数据库迁移的详细信息，请参阅使用复制数据库向导。

升级到 SQL Server 2005 故障转移群集

  1. 将 SQL Server 2005 DVD 插入 DVD 驱动器。如果 SQL Server 安装向导没有自动启动，请双击 DVD 根目录下的 Splash.hta。

    如果从网络位置安装，请共享安装文件，并将要安装 SQL Server 的计算机连接到该位置。

  2. 若要开始安装过程，请单击“安装 SQL Server”。

  3. 在“最终用户许可协议”页上，阅读许可协议，再选中相应的复选框以接受许可条款和条件。接受许可协议后即可激活“下一步”按钮。若要继续，请单击“下一步”。若要结束安装程序，请单击“取消”。

  4. 此时，将运行“SQL Server 组件更新”，以便在安装 SQL Server 前安装必需的软件。有关组件要求的详细信息，请单击该页底部的“帮助”按钮。若要在运行组件更新后继续执行操作，请单击“下一步”。

  5. 在 SQL Server 安装向导的“欢迎”页上，单击“下一步”以继续安装。

  6. 在“系统配置检查 (SCC)”页上，将扫描安装计算机，以检查是否存在可能妨碍安装程序的条件。有关配置检查项的详细信息，请参阅系统配置检查 (SCC)。

    若要中断扫描，请单击“停止”。若要在扫描完成后继续运行安装程序，请单击“下一步”。
注意：
如果扫描操作检查出任何错误，请确定是哪些错误，再单击“退出”。只有在解决可能妨碍安装的错误之后，才能完成安装。有关详细信息，请参阅系统配置检查器的检查参数。

  1. 在“Microsoft SQL Server 安装”页上，SQL Server 安装向导将进行一些准备工作，以便安装该软件。在准备工作完成后，安装向导将继续往下进行。

  2. 在“注册信息”页上的“姓名”和“公司”文本框中，输入相应的信息。若要继续，请单击“下一步”。

  3. 在“要安装的组件”页上，请选择要安装的组件。

    选择各个组件组时，“要安装的组件”窗格中会显示相应的说明。您可以选中任意一些复选框。在选择 SQL Server 或 Analysis Services 时，如果安装程序检测到您要安装到虚拟服务器，则会启用“创建 SQL Server 故障转移群集”或“创建 Analysis Server 故障转移群集”复选框。必须选择此选项才可以安装故障转移群集。如果您已在另一台服务器上安装了管理工具，并且希望缩短安装时间，则可以选择在初始安装时不安装管理工具，这样，您可以在下次运行 SQL Server 安装程序时从远程配置新服务器来安装管理工具。

    若要安装个别的组件或指定文件的安装位置，请单击“高级”。否则，请进行选择，再单击“下一步”。

  4. 如果在上一页中单击了“高级”，此时将显示“功能选择”页。在“功能选择”页上，使用下拉框选择要安装的程序功能。若要将组件安装到自定义的目录下，请选择相应的功能，再单击“浏览”。有关此页功能的详细信息，请参阅功能选择。若要继续安装，请在完成功能选择后单击“下一步”。

  5. 在“实例名”页上，请为安装的软件选择默认实例或已命名的实例。如果已经安装了默认实例或已命名实例，并且为安装的软件选择了现有实例，安装程序将升级所选的实例，并提供安装其他组件的选项。

    计算机上必须没有默认实例，才可以安装新的默认实例。

    若要安装新的命名实例，请单击“命名实例”，然后在提供的空白处键入一个唯一的实例名。有关实例命名规则的详细信息，请参阅实例名称。

  6. 在“虚拟 SQL Server 名称”页上，为您安装的软件键入一个唯一的实例名。此名称用于在网络中标识故障转移群集。虚拟 SQL Server 的名称在您的网络中必须是唯一的，并且不同于主机群集和群集节点。若要继续安装，请单击“下一步”。

重要事项：
不能将实例命名为 DEFAULT 或 MSSQLSERVER。名称必须遵循 SQL Server 标识符的规则。有关实例命名规则的详细信息，请参阅实例名称。

注意：
只有在安装程序检测到您正在运行 MSCS 时，才会显示“虚拟 SQL Server 名称”页。如果没有显示“虚拟 SQL Server 名称”页，请取消安装程序，然后配置 MSCS。有关此页的详细帮助信息，请参阅虚拟服务器名称。

  1. 在“现有组件”页上，选择您要升级的组件，再单击“详细信息”查看验证该组件是否可以升级的报告。如果安装选项报告显示组件可以升级，请单击“关闭”返回到“现有组件”页，再单击“下一步”继续运行安装程序。

  2. 在“服务帐户(群集)”页上，为 SQL Server 服务帐户指定用户名、密码和域名。您可以对所有服务使用一个帐户。虚拟 SQL Server 的所有服务帐户都必须是域帐户。选中“为每个服务帐户进行自定义”框后，即可从“服务”列表中选择特定的服务，相应地指定“用户名”、“密码”和“域”。SQL Server 代理服务的帐户必须是群集节点的管理员。使用的帐户不得与分配给群集服务的帐户相同。

    根据需要，可以为各个服务指定单独的帐户。若要为各个服务指定单独的帐户，请选中“为每个服务帐户进行自定义”，从下拉框中选择服务名称，然后为服务提供登录凭据。若要继续安装，请单击“下一步”。有关详细信息，请参阅服务帐户（分类）。

注意：
域名不能为完整的 DNS 名称。例如，如果 DNS 名称为 my-domain-name.com，请在“域”字段中使用 my-domain-name。在 SQL Server 中，“域”字段不接受 my-domain-name.com 格式。

  1. 在“升级登录信息”页上，为要升级的 SQL Server 实例提供登录凭据，因为 SQL Server 2005 安装向导在升级过程中必须连接到现有 SQL Server 实例。若要继续安装，请单击“下一步”。

  2. 在“错误和使用情况报告设置”页上，选择清除复选框以禁用错误报告或功能使用情况报告。若要继续安装，请单击“下一步”。有关详细信息，请参阅错误和使用情况报告设置。

  3. 在“准备安装”页上，查看要安装的 SQL Server 功能和组件的摘要。若要继续安装，请单击“安装”。

  4. 在“完成 Microsoft SQL Server 安装向导”页上，可以通过单击此页上提供的链接查看安装摘要日志。若要退出 SQL Server 安装向导，请单击“完成”。

  5. 如果提示您重新启动计算机，请立即重新启动。完成安装后，阅读来自安装程序的消息是很重要的。如果有任何指定的节点未重新启动，均可能会导致以后运行安装程序失败。

后续步骤

  • 配置新安装的 SQL Server。为了减少系统的可攻击外围应用，SQL Server 2005 将有选择地安装并激活一些重要服务和功能。有关如何激活 SQL Server 2005 功能的详细信息，请参阅 SQL Server 外围应用配置器。

有关日志文件位置的信息，请参阅如何查看 SQL Server 2005 安装日志文件。

有关验证新安装的 SQL Server 的信息，请参阅如何验证 SQL Server 2005 服务的安装成功。

请参阅

任务

如何从命令提示符安装 SQL Server 2005


如何重命名 SQL Server 2005 虚拟服务器

如何重命名 SQL Server 2005 虚拟服务器 |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

如果 SQL Server 实例包括在故障转移群集中，则重命名虚拟服务器的过程不同于重命名独立实例的过程。有关重命名独立的 SQL Server 2005 实例的信息，请参阅如何重命名 SQL Server 2005 的独立实例。

虚拟服务器的名称始终与 SQL 网络名称（SQL 虚拟服务器的网络名称）相同。尽管您可以更改虚拟服务器的名称，但不能更改实例名。例如，您可以将名为 VS1\instance1 的虚拟服务器更改为其他名称（例如 SQL35\instance1），但是名称的实例部分 (instance1) 将保持不变。

准备工作

开始重命名进程之前，请阅读下列各项：

  • 除了在复制时使用日志传送的情况之外，SQL Server 不支持对复制所涉及的服务器进行重命名。如果主服务器永久丢失连接，则可以重命名日志传送中的辅助服务器。有关详细信息，请参阅复制和日志传送。

  • 当您重命名被配置为使用数据库镜像的虚拟服务器时，必须在进行重命名操作之前先关闭数据库镜像，然后用新的虚拟服务器名称重新建立数据库镜像。数据库镜像的元数据将不会自动更新来反映新的虚拟服务器名称。

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

重命名虚拟服务器

  1. 使用群集管理器将 SQL 网络名称更改为新名称。

  2. 使网络名称资源脱机。这将使 SQL Server 资源和其他相关资源也脱机。

  3. 使 SQL Server 资源重新联机。

验证重命名操作

虚拟服务器被重命名之后，任何使用旧名称的连接现在都必须使用新名称来连接。

若要验证重命名操作是否完成，请从 @@servername 或 sys.servers 中选择信息。@@servername 函数将返回新的虚拟服务器名称，sys.servers 表将显示新的虚拟服务器名称。若要验证故障转移过程是否能够使用新名称正常工作，用户还应尝试将 SQL Server 资源故障转移到其他节点。

对于从群集中任何节点进行的连接，都可以立即使用新名称。但是，对于从客户机使用新名称进行的连接，则必须在新名称对该客户机可见之后，才能使用新名称连接到服务器。根据网络配置，通过网络传播新名称所需的时间长度可能为几秒钟，也可能长至 3 到 5 分钟；旧的虚拟服务器名称在网络上不再可见也可能会需要一些时间。

若要最小化虚拟服务器重命名操作的网络传播延迟，请使用下列步骤：

最小化网络传播延迟

  1. 在服务器节点上从命令提示符发出下列命令：

    复制代码
    ipconfig /flushdns
ipconfig /registerdns
nbtstat –RR

请参阅

任务

如何重命名 SQL Server 2005 的独立实例


如何为 SQL Server 2005 资源添加依赖关系

如何为 SQL Server 2005 资源添加依赖关系 |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

如果将 Microsoft SQL Server 2005 安装到具有多个磁盘驱动器的 Windows 2000 群集组，并选择将数据放在其中一个驱动器上，则 SQL Server 资源将被设置为只依赖于该驱动器。若要将数据或日志放到另一个磁盘上，必须先为该磁盘的 SQL Server 资源添加依赖关系。

需要特别注意的是：如果要将其他任何资源添加到 SQL Server 组中，这些资源必须始终具有自己的唯一 SQL 网络名称资源以及自己的 SQL IP 地址资源。

不要将现有的 SQL 网络名称资源和 SQL IP 地址资源用于 SQL Server 以外的任何组。如果将 SQL Server 资源与其他资源共享，可能会发生下列问题：

  • 可能会发生意外停歇。

  • Service Pack 安装可能会失败。

  • SQL Server 安装程序可能会失败。如果出现此问题，将不能安装更多的 SQL Server 实例，也不能执行例程维护。

还需要考虑下列问题：

  • 使用 FTP 进行 SQL Server 复制：如果 SQL Server 实例使用 FTP 进行 SQL Server 复制，则 FTP 服务必须与被设置为使用 FTP 服务的 SQL Server 安装使用同一个物理磁盘。

  • SQL Server 资源依赖关系：如果将某个资源添加到 SQL Server 组中，并且与 SQL Server 资源具有依赖关系来确保 SQL Server 可用，则 Microsoft 建议您添加与 SQL Server 代理资源的依赖关系。不要添加 SQL Server 资源依赖关系。若要确保运行 SQL Server 的计算机保持高可用性，请对 SQL Server 代理资源进行配置，使 SQL Server 代理资源的失败不会影响 SQL Server 组。

  • 文件共享和打印机资源：安装文件共享资源或打印机群集资源时，不应将它们放在运行 SQL Server 的计算机的同一物理磁盘资源上。如果将它们放在这些物理磁盘资源上，可能会降低运行 SQL Server 的计算机的性能或丢失该计算机上的服务。

  • MS DTC 注意事项：安装操作系统和配置群集后，必须使用群集管理器配置 MS DTC 以在群集中使用。配置 MS DTC 群集失败不会终止 SQL Server 2005 安装程序，但是如果 MS DTC 配置不正确，SQL Server 2005 应用程序的功能可能会受到影响。

    如果在 SQL Server 组中安装 Microsoft 分布式事务处理协调器 (MS DTC)，并且具有依赖于 MS DTC 的其他资源，则当此组脱机时，或者在故障转移期间，MS DTC 将不可用。默认情况下，当您对新的安装运行 SQL Server 故障转移向导时，SQL Server 会要求将 MS DTC 资源放在 SQL Server 组中。如果 MS DTC 已经设置了群集，SQL Server 7.0 会使用现有的位置和资源，而 SQL Server 2000 则不会。Microsoft 建议尽可能将 MS DTC 放在自己的组和自己的物理磁盘资源中。

为 SQL Server 2005 资源添加依赖关系

  1. 打开 Windows 管理工具中的群集管理器。

  2. 查找包含要添加依赖关系的可用 SQL Server 资源的组。

  3. 如果磁盘资源已经位于此组中，请转到步骤 4。否则，请查找包含该磁盘的组。如果该组与包含 SQL Server 的组不属于同一节点，请将包含磁盘资源的组移到拥有 SQL Server 组的节点中。

  4. 使 SQL Server 资源离线。

  5. 选择 SQL Server 资源，打开“属性”对话框，然后使用“依存关系”选项卡将磁盘添加到 SQL Server 依赖关系集中。

请参阅

任务

如何阅读 SQL Server 2005 安装日志文件

概念

安装故障转移群集前的准备工作
如何查看 SQL Server 2005 安装日志文件


如何删除 SQL Server 2005 故障转移群集实例（安装程序）

如何删除 SQL Server 2005 故障转移群集实例（安装程序） |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

此过程用于卸载 Microsoft SQL Server 2005 故障转移群集实例。

重要事项：
为了更新或删除 SQL Server 故障转移群集，您必须是本地管理员，具有在故障转移群集的所有节点上作为服务登录的权限。

开始之前

请在卸载 SQL Server 2005 故障转移群集之前考虑以下重要事项：

  • 在同时运行 SQL Server 2005 和 SQL Server 早期版本的计算机上，企业管理器和其他依赖于 SQL-DMO 的程序可能被禁用。这可能出现在以下情况中：

    • 并行安装了 SQL Server 2005、SQL Server 2000 和/或 SQL Server 7.0，又卸载了其中任意一个版本。

    • 并行安装了 SQL Server 2000 和 SQL Server 2005，且是在安装 SQL Server 2005 后安装 SQL Server 2000。

    这个问题是由于删除了 SQL Server 2005 SQL-DMO COM 库的注册造成的。若要重新启用具有 SQL-DMO 依赖关系的 SQL Server 2000 企业管理器和其他程序，请从命令提示符运行“regsvr32.exe sqldmo.dll”来注册 SQL-DMO。

  • 如果在群集环境中并行安装了 SQL Server 2000 和 SQL Server 2005，则卸载 SQL Server 2005 时不应卸载 SQL 本机客户端。SQL Server 2005 的 SQL Server Resource DLL 一直使用 SQL 本机客户端连接到 SQL Server。安装 SQL Server 2005 后，SQL Server Cluster Resource 就会升级。卸载 SQL Server 2005 后，SQL Server Resource DLL 不替换为 SQL Server 2000 所需的版本。在群集节点上保留 SQL 本机客户端使得 SQL Server Resource DLL 可以继续连接到 SQL Server 2000 的实例。

  • 如果不小心卸载了 SQL 本机客户端，SQL Server 资源将无法启动。若要重新安装 SQL 本机客户端，请运行 SQL Server 2005 安装程序来安装 SQL Server 2005 必备组件。

有关命令提示符语法的信息，请参阅如何从命令提示符安装 SQL Server 2005。

删除 SQL Server 2005 故障转移群集

  1. 若要开始卸载过程，请在“控制面板”中启动“添加/删除程序”。

  2. 选择要卸载的 SQL Server 2005 组件，再单击“删除”。这将启动 SQL Server 2005 安装向导。

  3. 在“选择组件”页上，选择“删除 SQL Server 2005 实例组件”，然后单击要卸载的实例名称和公共组件。若要继续，请单击“下一步”。

  4. 在“远程登录信息”页上，输入所有群集实例的节点上的管理员帐户的密码。若要继续，请单击“下一步”。

  5. 在“确认”页上，验证选择的要删除的 SQL Server 组件。若要继续执行卸载过程，请单击“完成”。

  6. SQL Server 安装向导将从您的计算机中删除 SQL Server 2005 组件。如果安装程序需要访问 SQL Server 2005 安装介质，系统会提示您将 CD/DVD 插入 CD 驱动器/DVD 驱动器。用于卸载 SQL Server 的 CD/DVD 的内部版本号必须与要卸载的 SQL Server 实例的内部版本号相同。对于网络安装，安装程序必须对网络版文件夹具有访问权限。

  7. SQL Server 系统配置检查器将扫描计算机的现有配置。在“欢迎”页上，单击“下一步”。在系统配置检查器完成扫描后，单击“下一步”继续。

  8. “安装进度”页将显示它从计算机上删除 SQL Server 2005 时的状态。在“完成 Microsoft SQL Server 安装向导”页上，可以通过单击此页上提供的链接查看安装摘要日志。若要退出 SQL Server 安装向导，请单击“完成”。

  9. SQL Server 被卸载后，SQL Server 帐户不会从域组中删除。域管理员必须确保在删除 SQL Server 后删除所有不需要的帐户。
注意：
请勿尝试卸载 MSXML 或 SQLXML；卸载了所有相关组件后，它们会自动删除。

请参阅

任务

如何阅读 SQL Server 2005 安装日志文件
如何手动卸载 SQL Server 2005 故障转移群集

概念

如何查看 SQL Server 2005 安装日志文件


如何手动卸载 SQL Server 2005 故障转移群集

如何手动卸载 SQL Server 2005 故障转移群集 |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

在卸载 Microsoft SQL Server 2005 故障转移群集之前，需考虑以下重要事项：

注意：
在同时运行 SQL Server 2005 和 SQL Server 早期版本的计算机上，企业管理器和其他依赖于 SQL-DMO 的程序可能被禁用。在同一台计算机上安装了 SQL Server 2005、SQL Server 2000 和 SQL Server 7.0，并卸载了任一版本的情况下，可能会出现这种情况。在同一台计算机上安装了 SQL Server 2000 和 SQL Server 2005，且是在安装 SQL Server 2005 后安装 SQL Server 2000 的情况下，也会出现这种情况。

这个问题是由于删除了 SQL Server 2005 SQL-DMO COM 库的注册造成的。为了重新启用具有 SQL-DMO 依赖关系的企业管理器和其他程序，请从命令提示符运行 regsvr32.exe sqldmo.dll 注册 SQL-DMO。有关详细信息，请参阅 SQL Server 数据库引擎的安装故障排除。

在使用 SQL Server 安装程序卸载失败后，卸载 SQL Server 2005 故障转移群集

  1. 备份每个节点上的现有注册表，然后删除 SQL Server 2005 之前。

  2. 使用注册表编辑器实用工具 (regedit.exe) 找到注册表项 HKLM\Software\Microsoft\Microsoft SQL Server\<instid>\Setup，其中 <instid> 表示的是要卸载的 SQL Server 2005 的特定实例（例如，MSSQL.1 表示第一个实例，MSSQL.2 表示第二个实例等）。在该项中，设置 SqlCluster=0。这将对 SQL Server 2005 群集实例取消聚集。

    注意：如果注册表编辑不当，可能会导致出现要求重新安装操作系统的严重问题。Microsoft 不能保证因注册表编辑不当而导致的问题会得到解决。编辑注册表之前，请备份注册表及所有重要数据。

  3. 确保共享磁盘对于要删除的节点可用。

  4. 在控制面板中启动“添加或删除程序”。

  5. 选择要卸载的 SQL Server 2005 实例，然后单击“删除”。这将启动 SQL Server 2005 安装向导。

  6. 在“选择组件”页上，选择“删除 SQL Server 2005 实例组件”，然后单击要卸载的实例名称和公共组件。若要继续，请单击“下一步”。

  7. 在“远程登录信息”页上，输入所有群集实例的节点上的管理员帐户的密码。若要继续，请单击“下一步”。

  8. 在“确认”页上，验证选择的要删除的 SQL Server 组件。若要继续执行卸载过程，请单击“完成”。

  9. SQL Server 2005 安装向导将从计算机中删除 SQL Server 2005 组件。如果安装程序需要访问 SQL Server 2005 安装介质，系统会提示您将 CD/DVD 插入 CD 驱动器/DVD 驱动器。用于卸载 SQL Server 的 CD/DVD 的内部版本号必须与要卸载的 SQL Server 实例的内部版本号相同。对于网络安装，安装程序必须对网络版文件夹具有访问权限。

  10. SQL Server 2005 系统配置检查器将扫描计算机的现有配置。在“欢迎”页上，单击“下一步”。在系统配置检查器完成扫描后，单击“下一步”以继续。

  11. “安装进度”页将显示它从计算机上删除 SQL Server 2005 时的状态。在“完成 Microsoft SQL Server 安装向导”页上，可以通过单击此页上提供的链接查看安装摘要日志。若要退出 SQL Server 安装向导，请单击“完成”。

    1. 注意：请勿尝试卸载 MSXML 或 SQLXML；卸载所有相关组件后，它们会自动删除。

  12. 将共享磁盘移动到下一个要卸载的节点，在此节点上，重复步骤 1 - 11。继续备份每个节点上的注册表和任何其他重要数据、编辑注册表以对群集取消聚集、移动共享磁盘以便它可用于要删除的节点，然后使用“添加或删除程序”来从该节点删除 SQL Server 2005。

  13. 针对剩余每个节点，重复该移动和卸载过程。

请参阅

任务

如何删除 SQL Server 2005 故障转移群集实例（安装程序）


如何从方案 1 中的故障转移群集故障中恢复

如何从方案 1 中的故障转移群集故障中恢复 |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

在此情况中，失败是由两个节点的群集中节点 1 的硬件故障造成的。例如，该硬件故障可能是由磁盘控制器或操作系统的故障引起的。

从故障转移群集硬盘故障中恢复

  1. 节点 1 失败后，Microsoft SQL Server 故障转移群集将有关的操作转移到节点 2 上。

  2. 运行 SQL Server 安装程序删除群集中的节点 1。有关详细信息，请参阅如何在 SQL Server 2005 故障转移群集中添加或删除节点（安装程序）。

  3. 从 Microsoft 群集服务 (MSCS) 中逐出节点 1。若要从 MSCS 中逐出节点，可在节点 2 中打开群集管理器，右键单击要删除的节点，再单击“逐出节点”命令。

  4. 验证节点 1 是否已从群集定义中逐出。

  5. 安装新的硬件，以替换节点 1 中发生故障的硬件。

  6. 使用群集管理器配置 Microsoft 群集服务器 (MSCS) 以便将节点 1 添加到现有群集。有关详细信息，请参阅安装故障转移群集前的准备工作。

  7. 确保所有群集节点上的管理员帐户都相同。有关详细信息，请参阅如何创建新的 SQL Server 2005 故障转移群集（安装）。

请参阅

任务

如何阅读 SQL Server 2005 安装日志文件

概念

如何查看 SQL Server 2005 安装日志文件


如何从方案 2 中的故障转移群集失败中恢复

如何从方案 2 中的故障转移群集失败中恢复 |
 | 请参阅
配置高可用性 > 配置可用性帮助主题 > 故障转移群集操作指南帮助主题 >

在方案 2 中，失败由节点 1 关闭或离线引起，但不是无法挽回的损坏。这可能是由操作系统故障或硬件故障引起的。

过程

从故障转移群集失败中恢复

  1. 节点 1 失败后，Microsoft SQL Server 故障转移群集将有关的操作转移到节点 2 上。

  2. 解决节点 1 的问题。

  3. 确保 Microsoft 群集服务 (MSCS) 群集正在工作且所有节点均处于在线状态。

  4. 试图将 SQL Server 故障转移到恢复的节点。如果该操作成功，则不需要执行进一步的操作，但必须进行常规测试。如果 SQL Server 在恢复的节点上无法在线，请参阅故障转移群集故障排除。

请参阅

任务

如何阅读 SQL Server 2005 安装日志文件

概念

故障转移群集故障排除
如何重新生成 SQL Server 2005 的 Master 数据库
如何为 SQL Server 2005 重新生成注册表
如何查看 SQL Server 2005 安装日志文件


排序规则选项与国际支持

排序规则选项与国际支持 |
 | 请参阅
准备安装 SQL Server 2005 >

Microsoft SQL Server 2005 支持 Microsoft Windows 操作系统所支持的所有语言。此主题详细说明 SQL Server 2005 中的语言支持以及 SQL Server 如何支持 Unicode 和非 Unicode 数据格式。

SQL Server 2005 中的排序规则更改

以下是 SQL Server 2005 中的新的更改和增强功能：

  • 支持自 Windows Server 2003 和 Windows XP 以后的新的和已更新的排序规则，包括支持增补字符的远东地区排序规则。

  • 用 SQL Server 2005 中的新排序规则支持基于码位的增补字符串比较。

  • 增加了实码位比较的二进制标志 BIN2。

  • 改进了从 SQL Server 7.0 和 SQL Server 2000 到 SQL Server 2005 的迁移路径。

  • 不推荐使用印地语和 Lithuanian_Classic Windows 排序规则，并且不推荐使用 SQL_ALTDiction_CP1253_CS_AS SQL 排序规则。虽然支持这些排序规则，但它们不会在 ::fn_helpcollations() 内置函数中出现。在 SQL Server 的未来版本中将删除对这些排序规则的支持。有关 SQL Server 的不推荐使用策略的详细信息，请参阅向后兼容性。

有关详细信息，请参阅安装程序中的排序规则设置。

请参阅

参考

安装程序中的排序规则设置
选择 SQL 排序规则

概念

排序规则术语


排序规则术语

排序规则术语 |
 | 请参阅
准备安装 SQL Server 2005 > 排序规则选项与国际支持 >

若要充分利用 SQL Server 2005 的语言支持，应了解本主题中所定义的术语。

术语

  • 代码页

  • 排序规则

  • 数据类型

  • 全球化

  • 区域设置

  • 读取顺序

  • 排序次序

  • Unicode

代码页

代码页是给定脚本的有序字符集，其中数值索引（即码位值）与每个字符相关联。通常将 Microsoft Windows 代码页称为“character set”或“charset”。代码页用于支持不同的 Windows 区域设置所使用的字符集和键盘布局。

相关主题： 设置客户端代码页

返回页首

排序规则

排序规则指定表示数据集中每个字符的位模式。排序规则还决定用于数据排序和比较的规则。SQL Server 2005 支持在单个数据库中存储具有不同排序规则的对象，即 SQL Server 数据库中每列都可以有各自的排序规则。对于非 Unicode 列，排序规则设置指定数据的代码页，从而指定可以表示哪些字符。数据可以在 Unicode 列之间无缝地移动。在非 Unicode 列之间移动数据时，数据不能无缝地移动，而必须经当前代码页转换。

如果 Transact-SQL 语句运行于各自都具有不同排序规则设置的数据库的上下文中，则其运行结果可能会不同。如果可能，最佳实践应包括对组织使用标准化排序规则。如果已在组织中的所有系统上使用标准的排序规则设置，则无需在每个字符或 Unicode 表达式中显式地指定排序规则。如果必须使用具有不同排序规则和代码页设置的对象，则必须对查询进行编码以考虑排序规则优先级的规则。有关详细信息，请参阅排序规则的优先顺序 (Transact-SQL)。

排序规则的特征是区分语言、区分大小写、区分重音、区分假名以及区分全半角。

SQL Server 2005 排序规则包括下列分组：

Windows 排序规则

Windows 排序规则根据关联的 Windows 区域设置来定义字符数据的存储规则。在 Windows 排序规则中，使用与 Unicode 数据相同的算法实现非 Unicode 数据的比较。Windows 基本排序规则指定应用字典排序时所用的字母表或语言，以及用于存储非 Unicode 字符型数据的代码页。Unicode 排序和非 Unicode 排序都与特定 Windows 版本中的字符串比较相兼容。这可以保持 SQL Server 中不同数据类型间的一致性，也使开发人员能够使用与 SQL Server 所使用的相同的规则（即通过调用 Microsoft Win32 API 的 CompareStringW 函数）在应用程序中对字符串进行排序。有关详细信息，请参阅安装程序中的排序规则设置。

二进制排序规则

二进制排序规则基于区域设置和数据类型所定义的编码值的顺序，对数据进行排序。SQL Server 中的二进制排序规则强制使用二进制排序顺序，定义了要使用的语言区域设置和 ANSI 代码页。由于二进制排序规则相对简单，因此对改进应用程序的性能非常有用。对于非 Unicode 数据类型，数据比较将基于 ANSI 代码页中定义的码位。对于 Unicode 数据类型，数据比较将基于 Unicode 码位。对于 Unicode 数据类型的二进制排序规则，数据排序将不考虑区域设置。例如，对 Unicode 数据应用 Latin_1_General_BIN 和 Japanese_BIN，会得到完全相同的排序结果。

SQL Server 中早期的二进制排序规则对 Unicode 数据执行的是不完整的逐码位比较，因为 SQL Server 早期版本中的二进制排序规则将首字符作为 WCHAR 比较，然后才进行逐字节比较。出于向后兼容的原因，现有的二进制排序规则语义保持不变。

此版本的 SQL Server 中的二进制排序规则包含一组新的纯码位比较排序规则。客户可以选择迁移到新的二进制排序规则，以利用真正的码位比较，并且应该使用新的二进制排序规则来开发新的应用程序。新的 BIN2 后缀标识了实现新的码位排序规则语义的排序规则名称。另外，还为新的二进制排序规则添加了与 BIN2 对应的新比较标志。有关详细信息，请参阅使用二进制排序规则。

SQL Server 排序规则

SQL Server 排序规则提供与 SQL Server 早期版本兼容的排序顺序。SQL Server 排序规则基于由 SQL Server 为非 Unicode 数据（例如 char 和 varchar 数据类型）定义的早期 SQL Server 排序顺序。非 Unicode 数据的字典排序规则与 Windows 操作系统提供的任何排序例程都不兼容，但 Unicode 数据的排序与特定版本的 Windows 排序规则兼容。由于 SQL Server 排序规则对非 Unicode 数据和 Unicode 数据使用不同的比较规则，因此对于相同数据的比较可能看到不同的结果（取决于基本数据类型）。有关详细信息，请参阅使用 SQL 排序规则。

注意：
升级 SQL Server 的实例时可以指定 SQL Server 排序规则，以便与现有 SQL Server 实例兼容。由于 SQL Server 实例的默认排序规则是在安装过程中定义的，因此在以下情况下切记要慎重指定排序规则设置：

  • 应用程序代码在某些方面依赖早期 SQL Server 排序规则的行为。

  • 将在 SQL Server 6.5 或 SQL Server 7.0 的现有安装中使用 SQL Server 2005 复制。

  • 必须存储反映多种语言的字符数据。

SQL Server 2005 支持在 SQL Server 2005 实例的下列级别设置排序规则：

服务器级排序规则

SQL Server 实例的默认排序规则在安装过程中设置。实例的默认排序规则也会成为系统数据库（master、model、tempdb、msdb 和 distribution）的默认排序规则。将排序规则指派给列或数据库以外的其他对象后，就无法再更改排序规则，除非删除并重新创建对象。可以在创建新的数据库或数据库列时指定排序规则，而不用更改 SQL Server 实例的默认排序规则。

若要查询 SQL Server 实例的服务器排序规则，请使用下列 Transact-SQL SERVERPROPERTY 函数：

复制代码
SELECT CONVERT (varchar, SERVERPROPERTY('collation'))

若要查询服务器以找到所有可用的排序规则，请使用以下 fn_helpcollations() 内置函数：

复制代码
SELECT * from ::fn_helpcollations()
数据库级排序规则

在创建数据库时，可以使用 CREATE DATABASE 语句的 COLLATE 子句指定数据库的默认排序规则。如果在数据库创建过程中未指定排序规则，则为数据库指派 model 数据库的默认排序规则。model 数据库的默认排序规则与 SQL Server 实例的默认排序规则相同。

可用如下 ALTER DATABASE 语句更改用户数据库的排序规则：

复制代码
ALTER DATABASE myDB COLLATE Greek_CS_AI

可以使用如下语句检索数据库的当前排序规则：

复制代码
SELECT CONVERT (varchar, DATABASEPROPERTYEX('database_name','collation'))
注意：
更改数据库级排序规则不会影响用户级、表级或列级排序规则。

列级排序规则

创建表时，可以使用 CREATE TABLE 语句的 COLLATE 子句指定每个字符串列的排序规则。如果在表创建过程中未指定排序规则，则为列指派数据库的默认排序规则。

可用如下 ALTER TABLE 语句更改列的排序规则：

复制代码
ALTER TABLE myTable ALTER COLUMN mycol NVARCHAR(10) COLLATE Greek_CS_AI
表达式级排序规则

表达式级排序规则在语句运行时设置，并且影响结果集的返回方式。这样便可以对结果进行排序，而使得 ORDER BY 子句可以是语言特定的。使用如下 COLLATE 子句可以实现表达式级排序规则：

复制代码
SELECT name FROM customer ORDER BY name COLLATE Latin1_General_CS_AI

返回页首

数据类型

数据类型为一种定义，用于指定值的范围、可对值执行的操作以及值在计算机内存中的存储方式。对数据类型加以定义可使 SQL Server 以可预测的方式对数据进行操作。非 Unicode 字符数据类型为 char、varchar 和 text。Unicode 数据类型使用 Unicode 字符表示形式；这些数据类型为 nchar、nvarchar 和 ntext。建议在应用程序中使用 Unicode 数据类型，尤其是存储反映多种语言的字符数据时。

相关主题：数据类型（数据库引擎）、数据类型 (Transact-SQL) 和 Integration Services 数据类型

返回页首

全球化

全球化是指一种开发软件应用程序的过程，其特点为程序的功能和代码设计要兼顾多种语言和区域设置。全球化应用程序设计为数据输入、处理、显示和输出提供了多区域设置和支持 Unicode 的语言。

相关主题：SQL Server 的国际化注意事项

返回页首

区域设置

区域设置是一组与地点和区域性相关联的信息：语言的名称和标识符、用以书写语言的文字以及文化习俗。SQL Server 2005 支持由 Windows XP 所支持的全部 135 种区域设置。在这些区域设置中，包括五种中文区域设置（香港特别行政区、澳门特别行政区、中华人民共和国、新加坡和台湾）、十三种英语区域设置（澳大利亚、伯利兹、加拿大、加勒比、爱尔兰、牙买加、新西兰、菲律宾、南非、特立尼达、英国、美国和津巴布韦）和六种法语区域设置（比利时、加拿大、法国、卢森堡、摩纳哥和瑞士）。

下表说明 Windows 所支持的四种常用区域设置间的差异。

区域设置 | 英语(美国) | 法语(法国) | 日语 | 阿拉伯联合酋长国
国家/地区 | 美国 | 法国 | 日本 | 阿拉伯联合酋长国
语言 | 英语 | 法语 | 日语 | 阿拉伯语
文字书写 | 拉丁文 | 拉丁文 | 假名、日本汉字 | 阿拉伯语
读取顺序 | 从左到右 | 从左到右 | 从左到右 | 从右到左
Windows 定义的代码页 | 1252 | 1252 | 932 | 1256
时间格式 | 1:00 pm | 13:00 | 13:00 | 1:00 p
日历 | 公历 | 公历 | 公历（本地化） | 公历（本地化）
默认纸张大小 | U.S. Letter | A4 | A4 | A4
小数分隔符 | . | , | . | ,
列表分隔符 | , | ; | , | ;
千位分隔符 | , | 空格 | , | ,

返回页首

读取顺序

读取顺序为有序文本序列的首尾方向，它与单词的顺序有关，而与输入字符的顺序无关。例如，使用阿拉伯语作为键盘语言意味着新字符将始终从右向左出现。而拉丁语为键盘语言时，新字符将从左向右出现。

返回页首

排序次序

排序顺序指定数据值的排序方式，它影响数据比较的结果。数据的排序通过排序规则实现，且可以使用索引对其进行优化。

相关主题： Windows 排序规则排序样式、索引

返回页首

Unicode

Unicode 使用两个而不是一个字节来表示语言的字符，这使得单个 Unicode 字符集可以表示世界上几乎所有书面语言。Unicode 由非营利性计算机行业组织 Unicode Consortium 开发，并且现在仍由该组织进行维护和升级。有关详细信息，请参阅 Unicode Consortium 网站。

如果存储的字符数据反映多种语言，则应始终使用 Unicode 数据类型（nchar、nvarchar 和 ntext），而不要使用非 Unicode 数据类型（char、varchar 和 text）。使用 Unicode 可以体验到显著的性能提升，因为所需的代码页转换较少。非 Unicode 数据类型有明显的局限性，因为非 Unicode 计算机只能使用单个代码页。若要全面评估与使用 Unicode 或非 Unicode 数据类型相关的问题，必须测试您的具体方案以确定在特定环境下的性能差异大小。至少应对站点排序规则进行标准化，并尽可能部署 Unicode 服务器和客户端。

多数情况下，SQL Server 实例将与其他服务器或客户端进行交互，并且实例可以使用多种数据访问标准。SQL Server 客户端是两种主要类型之一：

  • 使用 OLE DB 和开放式数据库连接 (ODBC) 3.7 版或更高版本的 Unicode 客户端。

  • 使用 DB-Library 和 ODBC 3.6 版或更低版本的非 Unicode 客户端。

下表显示以 Unicode 和非 Unicode 服务器的各种组合使用多语言数据的注意事项。

服务器 | 客户端 | 优点或局限性
Unicode | Unicode | 该方案是理想配置，因为 Unicode 数据将在整个系统中使用。该方案提供最佳性能，可以最大程度地防止检索数据的损坏。Microsoft ActiveX 数据对象 (ADO)、OLE DB 和 ODBC 3.7 版或更高版本都是这样的配置。
Unicode | 非 Unicode | 在此方案中，数据存储可能不是问题，但在向客户机移动数据时可能有限制。至少，必须使用非 Unicode 客户端上的代码页转换 Unicode 数据。
非 Unicode | Unicode | 该方案对使用多语言数据不是理想配置。在此方案下不能向非 Unicode 服务器写入 Unicode 数据。向服务器发送代码页与服务器不同的数据时可能发生问题。
非 Unicode | 非 Unicode | 这是对多语言数据有极大局限性的方案。将只能使用单个代码页。理想配置是一台 Unicode 服务器配合多台 Unicode 客户端。

相关主题： Unicode 基础知识

返回页首

请参阅

参考

排序规则选项与国际支持


安装程序中的排序规则设置

安装程序中的排序规则设置 |
 | 请参阅
准备安装 SQL Server 2005 > 排序规则选项与国际支持 >

排序规则设置，包含字符集、排序顺序和其他区域特定的设置，是 Microsoft SQL Server 数据库结构和功能的基础。在您的单位内，应开发排序规则设置的标准，并在安装 SQL Server 时应用这些设置。如果服务器之间的排序规则设置不一致，许多服务器对服务器的活动就可能失败或生成不一致的结果。选择 Microsoft Windows 区域设置以匹配其他 SQL Server 2005 实例中的排序规则设置；或者选择“SQL 排序规则”以匹配 SQL Server 早期版本中的排序顺序设置。

SQL Server 2005 支持在 SQL Server 2005 实例的以下级别设置排序规则：

  • 服务器级

  • 数据库级

  • 列级

  • 表达式级

有关排序规则级别的详细信息，请参阅排序规则术语。有关重新生成系统数据库以指定新的系统排序规则的详细信息，请参阅如何从命令提示符安装 SQL Server 2005。

Windows 系统区域设置

仅当 SQL Server 的安装必须与另一个 SQL Server 实例使用的排序规则设置相匹配时，或者当排序规则设置必须与另一台计算机的 Windows 系统区域设置相匹配时，才应更改 Windows 排序规则的默认设置。

排序规则指示符

从“排序规则指示符”列表中选择特定的 Windows 排序规则的名称。例如：

  • 美国英语字符集(代码页 1252)使用 Latin1_General。

  • 对于使用与美国英语(代码页 1252)相同字符集的所有西班牙语变体使用 Modern_Spanish。

  • 使用阿拉伯语字符集(代码页 1256)的所有阿拉伯语变体使用 Arabic。

  • 对于日语的 Unicode 版本使用 Japanese_Unicode(代码页 932)。此版本具有与 Japanese 不同的排序次序，但二者的代码页同为 932。

排序次序

选择用于所选排序规则指示符的排序顺序选项。二进制是最快的排序顺序，并且区分大小写，但是可能会产生意外的排序顺序。如果选择了“二进制”，则“区分大小写”、“区分重音”、“区分假名”和“区分全半角”选项将不可用。有关详细信息，请参阅 Windows 排序规则排序样式。

二进制排序规则

二进制排序规则基于每个字符的位模式来排序和比较 SQL Server 中的数据。SQL Server 中的每个二进制排序规则都映射到特定的语言区域设置和 ANSI 代码页，且每个都执行区分大小写和区分重音的数据排序。二进制排序规则提供最快的数据排序。有关详细信息，请参阅 Windows 排序规则排序样式和使用二进制排序规则。

SQL 排序规则

“SQL 排序规则”选项用于确保与旧版本的 SQL Server 兼容。选择此选项可以匹配 SQL Server 2000、SQL Server 7.0 或更早版本的设置。有关详细信息，请参阅使用 SQL 排序规则。

新排序规则版本

对早期排序规则行为做出了下列排序规则改进：

  • 对远东地区排序规则提供对增补字符比较的支持

  • 增加了新 Indic_General_90_CI_AS（仅 Unicode）排序规则版本，以支持对排序行为的更改

    重要事项：
    这些版本更新都显著影响排序和比较行为。在这些排序规则升级到 Microsoft SQL Server 2005 的过程中，不会强制迁移到新版本。如果用户迁移到新排序规则以便支持补充字符，则所有数据库和 SQL Server 对象都必须重新索引。由于重新索引的过程可能很耗时，所以应考虑增补字符支持的成本收益。当客户选择不迁移到新排序规则时，SQL Server 2000 中的排序规则在 SQL Server 2005 中将受到支持。

已为此 SQL Server 2005 版本更新以下排序规则，以使用 Windows Server 2003 码位排序行为。

旧排序规则名称 | 新排序规则名称
日语 | Japanese_90
中文 | Chinese_PRC_90
Chinese_PRC_Stroke | Chinese_PRC_Stroke_90
Chinese_Taiwan_Bopomofo | Chinese_Taiwan_Bopomofo_90
Chinese_Taiwan_Stroke | Chinese_Taiwan_Stroke_90
朝鲜语 | Korean_90
印地语(此版本中不推荐使用) | Indic_General_90_CI_AS（仅 Unicode）

SQL Server 安装程序中的默认排序规则

在控制面板中，找到“区域选项”(Windows 2000) 或“区域和语言选项”(Windows XP) 中的 Microsoft Windows 区域设置名称，然后使用下表找到相应的排序规则指示符和代码页，以匹配下面 SQL Server 2005 排序规则表中现有 Windows 区域设置的排序规则设置。

Windows 系统区域设置 | LCID(区域设置 ID) | 默认 SQL 排序规则 | 代码页
南非荷兰语 | 0x436 | Latin1_General_CI_AS | 1252
阿尔巴尼亚语 | 0x41c | Albanian_CI_AS | 1250
阿拉伯语(阿尔及利亚) | 0x1401 | Arabic_CI_AS | 1256
阿拉伯语(巴林群岛) | 0x3c01 | Arabic_CI_AS | 1256
阿拉伯语(埃及) | 0xc01 | Arabic_CI_AS | 1256
阿拉伯语(伊拉克) | 0x801 | Arabic_CI_AS | 1256
阿拉伯语(约旦) | 0x2c01 | Arabic_CI_AS | 1256
阿拉伯语(科威特) | 0x3401 | Arabic_CI_AS | 1256
阿拉伯语(黎巴嫩) | 0x3001 | Arabic_CI_AS | 1256
阿拉伯语(利比亚) | 0x1001 | Arabic_CI_AS | 1256
阿拉伯语(摩洛哥) | 0x1801 | Arabic_CI_AS | 1256
阿拉伯语(阿曼) | 0x2001 | Arabic_CI_AS | 1256
阿拉伯语(卡塔尔) | 0x4001 | Arabic_CI_AS | 1256
阿拉伯语(沙特阿拉伯) | 0x401 | Arabic_CI_AS | 1256
阿拉伯语(叙利亚) | 0x2801 | Arabic_CI_AS | 1256
阿拉伯语(突尼斯) | 0x1c01 | Arabic_CI_AS | 1256
阿拉伯语(阿拉伯联合酋长国) | 0x3801 | Arabic_CI_AS | 1256
阿拉伯语(也门) | 0x2401 | Arabic_CI_AS | 1256
亚美尼亚语(亚美尼亚共和国) | 0x42b | Latin1_General_CI_AS | Unicode
阿泽里语-西里尔语(阿塞拜疆)1 | 0x82c | Azeri_Cyrillic_90_CI_AS | 1251
阿泽里语-拉丁语(阿塞拜疆)1 | 0x42c | Azeri_Latin_90_CI_AS | 1254
巴斯克语 | 0x42d | Latin1_General_CI_AS | 1252
白俄罗斯语 | 0x423 | Cyrillic_General_CI_AS | 1251
保加利亚语 | 0x402 | Cyrillic_General_CI_AS | 1251
加泰罗尼亚语 | 0x403 | Latin1_General_CI_AS | 1252
中文(香港特别行政区)1 | 0xc04 | Chinese_Hong_Kong_Stroke_90_CI_AS | 950
中文(澳门特别行政区)2 | 0x1404 | Chinese_PRC_90_CI_AS | 950
中文(中华人民共和国)2 | 0x804 | Chinese_PRC_CI_AS | 936
中文(中华人民共和国) | 0x20804 | Chinese_PRC_Stroke_CI_AS | 936
中文(新加坡) | 0x1004 | Chinese_PRC_90_CI_AS | 936
中文(台湾) | 0x404 | Chinese_Taiwan_Stroke_CI_AS | 950
中文(台湾) | 0x30404 | Chinese_Taiwan_Bopomofo_CI_AS | 950
克罗地亚语 | 0x41a | Croatian_CI_AS | 1250
捷克语 | 0x405 | Czech_CI_AS | 1250
丹麦语 | 0x406 | Danish_Norwegian_CI_AS | 1252
马尔代夫语1 | 0x465 | Divehi_90_CI_AS（仅 Unicode） | Unicode
荷兰语(比利时) | 0x813 | Latin1_General_CI_AS | 1252
荷兰语(荷兰) | 0x413 | Latin1_General_CI_AS | 1252
英语(澳大利亚) | 0xc09 | Latin1_General_CI_AS | 1252
英语(伯里兹) | 0x2809 | Latin1_General_CI_AS | 1252
英语(加拿大) | 0x1009 | Latin1_General_CI_AS | 1252
英语(加勒比海) | 0x2409 | Latin1_General_CI_AS | 1252
英语(香港特别行政区) | 0x3c09 | Latin1_General_CI_AS | 1252
英语(印度) | 0x4009 | Latin1_General_CI_AS | 1252
英语(印度尼西亚) | 0x3809 | Latin1_General_CI_AS | 1252
英语(爱尔兰) | 0x1809 | Latin1_General_CI_AS | 1252
英语(牙买加) | 0x2009 | Latin1_General_CI_AS | 1252
英语(马来西亚) | 0x4409 | Latin1_General_CI_AS | 1252
英语(新西兰) | 0x1409 | Latin1_General_CI_AS | 1252
英语(菲律宾) | 0x3409 | Latin1_General_CI_AS | 1252
英语(新加坡) | 0x4809 | Latin1_General_CI_AS | 1252
英语(南非) | 0x1c09 | Latin1_General_CI_AS | 1252
英语(特立尼达) | 0x2c09 | Latin1_General_CI_AS | 1252
英语(英国) | 0x809 | Latin1_General_CI_AS | 1252
英语(美国) | 0x409 | SQL_Latin1_General_CP1_CI_AS | 1252
英语(津巴布韦) | 0x3009 | Latin1_General_CI_AS | 1252
爱沙尼亚语 | 0x425 | Estonian_CI_AS | 1257
法罗语 | 0x438 | Latin1_General_CI_AS | 1252
现代波斯语 | 0x429 | Arabic_CI_AS | 1256
芬兰语 | 0x40b | Finnish_Swedish_CI_AS | 1252
法语(比利时) | 0x80c | French_CI_AS | 1252
法语(加拿大) | 0xc0c | French_CI_AS | 1252
法语(法国) | 0x40c | French_CI_AS | 1252
法语(卢森堡) | 0x140c | French_CI_AS | 1252
法语(摩纳哥) | 0x180c | French_CI_AS | 1252
法语(瑞士) | 0x100c | French_CI_AS | 1252
加利西亚语(西班牙) | 0x456 | Latin1_General_CI_AS | 1252
格鲁吉亚语 | 0x437 | Latin1_General_CI_AS | Unicode
德语(奥地利) | 0xc07 | Latin1_General_CI_AS | 1252
德语(德国) | 0x407 | Latin1_General_CI_AS | 1252
德语(列支敦士登) | 0x1407 | Latin1_General_CI_AS | 1252
德语(卢森堡) | 0x1007 | Latin1_General_CI_AS | 1252
德语(电话簿风格) | 0x10407 | German_PhoneBook_CI_AS | 1252
德语(瑞士) | 0x807 | Latin1_General_CI_AS | 1252
希腊语 | 0x408 | Greek_CI_AS | 1253
古吉拉特语(印度)3 | 0x447 | Indic_General_90_CI_AS（仅 Unicode） | Unicode
希伯来语 | 0x40d | Hebrew_CI_AS | 1255
印地语3 | 0x0439 | Indic_General_90_CI_AS（仅 Unicode） | Unicode
匈牙利语 | 0x40e | Hungarian_CI_AS | 1250
匈牙利语(技术) | 0x104e | Hungarian_Technical_CI_AS | 1250
北日耳曼语 | 0x40f | Icelandic_CI_AS | 1252
印度尼西亚语 | 0x421 | Latin1_General_CI_AS | 1252
意大利语(意大利) | 0x410 | Latin1_General_CI_AS | 1252
意大利语(瑞士) | 0x810 | Latin1_General_CI_AS | 1252
日语 | 0x411 | Japanese_CI_AS | 932
日语 (Unicode) | 0x10411 | Japanese_Unicode_CI_AS | 932
卡纳达语(印度)3 | 0x44b | Indic_General_90_CI_AS（仅 Unicode） | Unicode
哈萨克语(哈萨克斯坦)1 | 0x43f | Kazakh_90_CI_AS | 1251
贡根语(印度)3 | 0x457 | Indic_General_90_CI_AS（仅 Unicode） | Unicode
朝鲜语 (Extended Wansung) | 0x0412 | Korean_Wansung_CI_AS | 949
吉尔吉斯语-西里尔语(吉尔吉斯坦共和国) | 0x440 | Cyrillic_General_CI_AS | 1251
拉脱维亚语 | 0x426 | Latvian_CI_AS | 1257
立陶宛语 | 0x427 | Lithuanian_CI_AS | 1257
马其顿语 (FYROM) | 0x42f | Macedonian_FYROM_90_CI_AS | 1251
马来语(文莱达鲁萨兰国) | 0x83e | Latin1_General_CI_AS | 1252
马来语(马来西亚) | 0x43e | Latin1_General_CI_AS | 1252
马拉地语(印度)3 | 0x44e | Indic_General_90_CI_AS（仅 Unicode） | Unicode
蒙古语-西里尔语(蒙古) | 0x450 | Cyrillic_General_CI_AS | 1251
挪威语(博克马尔) | 0x414 | Danish_Norwegian_CI_AS | 1252
挪威语(尼诺斯克) | 0x814 | Danish_Norwegian_CI_AS | 1252
波兰语 | 0x415 | Polish_CI_AS | 1250
葡萄牙语(巴西) | 0x416 | Latin1_General_CI_AS | 1252
葡萄牙语(葡萄牙) | 0x816 | Latin1_General_CI_AS | 1252
旁遮普语-果鲁穆奇语(印度)3 | 0x446 | Indic_General_90_CI_AS（仅 Unicode） | Unicode
罗马尼亚语 | 0x418 | Romanian_CI_AS | 1250
俄罗斯语 | 0x419 | Cyrillic_General_CI_AS | 1251
梵语(印度)3 | 0x44f | Indic_General_90_CI_AS（仅 Unicode） | Unicode
塞尔维亚语(西里尔) | 0xc1a | Cyrillic_General_CI_AS | 1251
塞尔维亚语(拉丁) | 0x81a | Cyrillic_General_CI_AS | 1250
斯洛伐克语 | 0x41b | Slovak_CI_AS | 1250
斯洛文尼亚语 | 0x424 | Slovenian_CI_AS | 1250
西班牙语(阿根廷) | 0x2c0a | Modern_Spanish_CI_AS | 1252
西班牙语(玻利维亚) | 0x400a | Modern_Spanish_CI_AS | 1252
西班牙语(智利) | 0x340a | Modern_Spanish_CI_AS | 1252
西班牙语(哥伦比亚) | 0x240a | Modern_Spanish_CI_AS | 1252
西班牙语(哥斯达黎加) | 0x140a | Modern_Spanish_CI_AS | 1252
西班牙语(多米尼加共和国) | 0x1c0a | Modern_Spanish_CI_AS | 1252
西班牙语(厄瓜多尔) | 0x300a | Modern_Spanish_CI_AS | 1252
西班牙语(萨尔瓦多) | 0x440a | Modern_Spanish_CI_AS | 1252
西班牙语(危地马拉) | 0x100a | Modern_Spanish_CI_AS | 1252
西班牙语(洪都拉斯) | 0x480a | Modern_Spanish_CI_AS | 1252
西班牙语(国际风格) | 0xc0a | Modern_Spanish_CI_AS | 1252
西班牙语(墨西哥) | 0x80a | Modern_Spanish_CI_AS | 1252
西班牙(尼加拉瓜) | 0x4c0a | Modern_Spanish_CI_AS | 1252
西班牙语(巴拿马) | 0x180a | Modern_Spanish_CI_AS | 1252
西班牙语(巴拉圭) | 0x3c0a | Modern_Spanish_CI_AS | 1252
西班牙语(秘鲁) | 0x280a | Modern_Spanish_CI_AS | 1252
西班牙语(波多黎各) | 0x500a | Modern_Spanish_CI_AS | 1252
西班牙语(传统) | 0x40a | Traditional_Spanish_CI_AS | 1252
西班牙语(乌拉圭) | 0x380a | Modern_Spanish_CI_AS | 1252
西班牙语(委内瑞拉) | 0x200a | Modern_Spanish_CI_AS | 1252
斯瓦希里语 | 0x441 | Latin1_General_CI_AS | 1252
瑞典语 | 0x41d | Finnish_Swedish_CI_AS | 1252
瑞典语(芬兰) | 0x81d | Finnish_Swedish_CI_AS | 1252
叙利亚语(叙利亚)1 | 0x45a | Syriac_90_CI_AS（仅 Unicode） | Unicode
泰米尔语(印度)1 | 0x449 | Indic_General_90_CI_AS（仅 Unicode） | Unicode
鞑靼语(鞑靼斯坦)1 | 0x444 | Tatar_90_CI_AS | 1251
泰卢固语(印度)1 | 0x44a | Indic_General_90_CI_AS（仅 Unicode） | Unicode
泰国语 | 0x41e | Thai_CI_AS | 874
土耳其语 | 0x41f | Turkish_CI_AS | 1254
乌克兰语 | 0x422 | Ukrainian_CI_AS | 1251
乌尔都语 | 0x420 | Arabic_CI_AS | 1256
乌兹别克语(拉丁)1 | 0x443 | Uzbek_Latin_90_CI_AS | 1254
乌兹别克语-西里尔语(乌兹别克斯坦共和国) | 0x843 | Cyrillic_General_CI_AS | 1251
越南语 | 0x42a | Vietnamese_CI_AS | 1258

1SQL Server 2005 的新排序规则；这些排序规则使用 Windows 2003 排序表，因此支持补充字符。BIN 和 BIN2 二进制排序都受新的 90 Windows 排序规则支持。

2使用拼音或发音排序。

3排序行为的主要更改；使用新的默认排序规则 Indic_General_90_CI_AS（仅 Unicode）。

4SQL Server 2005 中不推荐使用印地语排序规则，因为在此 SQL Server 版本中使用了 Windows 2000 Beta 2 排序表。此排序规则仍然存在于服务器中，但它在将来的 SQL Server 版本中将不受支持，目前也不出现在 ::fn_helpcollations() 中。

5SQL Server 2005 中不推荐使用印地语和 Lithuanian_Classic 排序规则。这些排序规则仍然存在于服务器中，但他们在将来的 SQL Server 版本中将不受支持，目前也不出现在 ::fn_helpcollations() 中。

请参阅

参考

排序规则选项与国际支持
排序规则设置
Windows 排序规则排序样式

概念

使用 SQL 排序规则

更改历史记录

版本 历史记录

已更改的内容：
  • 增加了对 Macedonian_FYROM_90 排序规则支持的说明。


Windows 排序规则排序样式

Windows 排序规则排序样式 |
 | 请参阅
准备安装 SQL Server 2005 > 排序规则选项与国际支持 >

SQL Server 安装过程中将提示选择 Windows 排序规则或二进制排序规则。此选择将影响 Microsoft SQL Server 实例的数据比较和排序顺序行为。本主题提供为您的 SQL Server 实现选择 Microsoft Windows 排序规则或二进制排序规则时的注意事项。

注意：
对于 Windows 排序规则，nchar、nvarchar 和 ntext 这些 Unicode 数据类型与 char、varchar 和 text 这些非 Unicode 数据类型的排序行为相同。

Windows 排序规则根据关联的 Windows 区域设置来定义字符数据的存储规则。Windows 基本排序规则指定应用字典排序时所用的字母表或语言，以及用于存储非 Unicode 字符数据的代码页。二进制排序规则基于区域设置和数据类型所定义的编码值的顺序，对数据进行排序。SQL Server 中的二进制排序规则强制使用二进制排序顺序，定义了要使用的语言区域设置和 ANSI 代码页。由于二进制排序规则相对简单，因此对改进应用程序的性能非常有用。对于非 Unicode 数据类型，数据比较将基于 ANSI 代码页中定义的码位。对于 Unicode 数据类型，数据比较将基于 Unicode 码位。对于 Unicode 数据类型的二进制排序规则，数据排序将不考虑区域设置。例如，对 Unicode 数据应用 Latin_1_General_BIN 和 Japanese_BIN，会得到完全相同的排序结果。

SQL Server 中早期的二进制排序规则对 Unicode 数据执行的是不完整的逐码位比较，因为更早的 SQL Server 二进制排序规则将首字符作为 WCHAR 比较，然后才进行逐字节比较。为了实现向后兼容，将不更改现有的二进制排序规则语义。

此版本 SQL Server 中的二进制排序规则还包括一套新的纯码位比较排序规则。客户可以选择迁移到新的二进制排序规则，以利用真正的码位比较，并且应该使用新的二进制排序规则来开发新的应用程序。新的 BIN2 后缀标识了实现新的码位排序规则语义的排序规则名称。另外，还为新的二进制排序规则添加了与 BIN2 对应的新比较标志。有关详细信息，请参阅使用二进制排序规则。

下表说明 SQL Server 2005 的 Windows 排序规则排序顺序选项。

排序顺序（后缀） | 排序顺序说明
二进制 (_BIN)1 | 根据为每个字符定义的位模式对 SQL Server 表中的数据进行排序和比较。二进制排序顺序既区分大小写，也区分重音。二进制排序顺序的速度也最快。有关详细信息，请参阅使用二进制排序规则。 如果未选择此选项，则 SQL Server 将遵循字典中定义的相关语言或字母表的排序和比较规则。
BIN2 (_BIN2)1 | 根据 Unicode 数据的 Unicode 码位对 SQL Server 表中的数据进行排序和比较。对于非 Unicode 数据，BIN2 将使用与二进制排序相同的比较方式。 使用 BIN2 排序顺序的优点是：对已排序的 SQL Server 数据进行比较的应用程序不必重新对数据进行排序。因此，如果使用 BIN2，则应用程序开发更为简单，并且可能会提高性能。有关详细信息，请参阅使用二进制排序规则。
区分大小写 (_CS) | 区分大写字母和小写字母。如果选择此项，排序时小写字母将在其对应的大写字母之前。 如果未选择此选项，则 SQL Server 认为字母的大小写形式对于排序目的而言是相同的。
区分重音 (_AS) | 区分重音字符和非重音字符。例如，“a”和“?”将被视为不同的字符。 如果未选择此项，在排序时，SQL Server 将把字母的重音形式和非重音形式视为相同。
区分假名 (_KS) | 区分日语中的两种假名字符类型：平假名和片假名。 如果未选择此选项，则 SQL Server 认为片假名字符和平假名字符对于排序目的而言是相等的。
区分全半角 (_WS) | 区分字符的单字节形式和双字节形式。 如果未选择此项，在排序时，SQL Server 将把同一字符的单字节形式和双字节形式视为相同。

1如果选择此选项，则区分大小写、区分重音、区分假名和区分全半角选项均不可用。

Windows 排序规则示例

每个 Windows 排序规则都由一系列定义大小写、重音、全半角或假名的后缀组合而成。下列示例说明各种后缀组合的排序顺序行为。

Windows 排序规则后缀 | 排序顺序说明
_BIN1 | 二进制排序。
_BIN21 | BIN2 二进制排序顺序（SQL Server 2005 的新增功能）。
_CI_AI | 不区分大小写、不区分重音、不区分假名、不区分全半角。
_CI_AI_KS | 不区分大小写、不区分重音、区分假名、不区分全半角
_CI_AI_KS_WS | 不区分大小写、不区分重音、区分假名、区分全半角
_CI_AI_WS | 不区分大小写、不区分重音、不区分假名、区分全半角
_CI_AS | 不区分大小写、区分重音、不区分假名、不区分全半角
_CI_AS_KS | 不区分大小写、区分重音、区分假名、不区分全半角
_CI_AS_KS_WS | 不区分大小写、区分重音、区分假名、区分全半角
_CI_AS_WS | 不区分大小写、区分重音、不区分假名、区分全半角
_CS_AI | 区分大小写、不区分重音、不区分假名、不区分全半角
_CS_AI_KS | 区分大小写、不区分重音、区分假名、不区分全半角
_CS_AI_KS_WS | 区分大小写、不区分重音、区分假名、区分全半角
_CS_AI_WS | 区分大小写、不区分重音、不区分假名、区分全半角
_CS_AS | 区分大小写、区分重音、不区分假名、不区分全半角
_CS_AS_KS | 区分大小写、区分重音、区分假名、不区分全半角
_CS_AS_KS_WS | 区分大小写、区分重音、区分假名、区分全半角
_CS_AS_WS | 区分大小写、区分重音、不区分假名、区分全半角

1如果选择 BIN 或 BIN2，则区分大小写、区分重音、区分假名和区分全半角选项均不可用。

请参阅

参考

安装程序中的排序规则设置

概念

使用二进制排序规则


使用二进制排序规则

使用二进制排序规则 |
 | 请参阅
准备安装 SQL Server 2005 > 排序规则选项与国际支持 >

以下注意事项将帮助您决定是旧的还是新的二进制排序规则适合实现您的 Microsoft SQL Server。在 SQL Server 的未来版本中将继续支持 BIN 及 BIN2 排序规则。

二进制排序规则基于区域设置和数据类型所定义的编码值的顺序，对数据进行排序。SQL Server 中的二进制排序规则强制使用二进制排序顺序，定义了要使用的语言区域设置和 ANSI 代码页。由于二进制排序规则相对简单，因此对改进应用程序的性能非常有用。对于非 Unicode 数据类型，数据比较将基于 ANSI 代码页中定义的码位。对于 Unicode 数据类型，数据比较将基于 Unicode 码位。对于 Unicode 数据类型的二进制排序规则，数据排序将不考虑区域设置。例如，对 Unicode 数据应用 Latin_1_General_BIN 和 Japanese_BIN，会得到完全相同的排序结果。

SQL Server 中的早期二进制排序规则对 Unicode 数据执行的是不完整的逐码位比较。更早的 SQL Server 二进制排序规则将第一个字符作为 WCHAR 比较，接下来是逐字节比较。为了实现向后兼容，将不更改现有的二进制排序规则语义。

使用二进制排序规则的准则

如果您的 Microsoft SQL Server 2005 应用程序与使用二进制排序规则的旧版 SQL Server 交互，那么请继续使用二进制排序规则。二进制排序规则可能更适合混合环境。

使用 BIN2 排序规则的准则

此版本的 SQL Server 中的二进制排序规则包含一组新的纯码位比较排序规则。客户可以选择迁移到新的二进制排序规则，以利用真正的码位比较，并且应该使用新的二进制排序规则来开发新的应用程序。新的 BIN2 后缀标识了实现新的码位排序规则语义的排序规则名称。另外，还为新的二进制排序规则添加了与 BIN2 对应的新比较标志。其优点包括更简单的应用程序开发和更清楚的语义。

请参阅

参考

排序规则选项与国际支持
安装程序中的排序规则设置


使用 SQL 排序规则

使用 SQL 排序规则 |
 | 请参阅
准备安装 SQL Server 2005 > 排序规则选项与国际支持 >

Microsoft SQL Server 排序规则设置取决于安装类型。一般而言，可以选择支持您的站点最常用的 Microsoft Windows 系统区域设置的 SQL Server 排序规则。若要在运行 Microsoft Windows 2000 的计算机上确定您的 Windows 系统区域设置，请在控制面板中单击“区域设置”，然后，如有必要请单击“常规” 选项卡以显示当前系统区域设置。若要在运行 Windows Server 2003 的计算机上确定您的 Windows 系统区域设置，请在控制面板中单击“区域和语言选项”，然后单击“区域选项”选项卡以显示当前系统区域设置。大多数情况下，计算机运行符合用户语言要求的 Windows 系统区域设置，因此 Microsoft SQL Server 安装程序会自动检测 Windows 区域设置并选择适当的排序规则。

SQL Server 排序规则控制：

  • 用于在 SQL Server 中存储非 Unicode 数据的代码页。

  • 控制 SQL Server 如何排序和比较以非 Unicode 数据类型存储的字符的规则。SQL Server 安装程序会在安装 SQL Server 的计算机上检测 Windows 排序规则，并为您的 SQL Server 实例自动选择排序规则。Unicode 字符和非 Unicode 字符的排序和比较可能不同。

在下列情况下，请选择 SQL Server 排序规则：

  • 对 SQL Server 6.5、SQL Server 7.0 或 SQL Server 2000 的现有实例使用复制功能。

  • 应用程序代码依赖早期 SQL Server 排序规则的行为。

用下表确定是否需要选择排序规则，以及在需要的情况下，应选择哪种排序规则。

注意：
将 SQL Server 7.0 或 SQL Server 2000 升级到 SQL Server 2005 可以保留早期的 SQL Server 排序规则设置；不需要选择排序规则。

任务 | 排序规则
在不需要与任何现有系统同步的新系统上安装 | 采用安装程序确定的排序规则，然后选择所需的二进制、大小写或其他选项。 当 SQL Server 安装程序检测到计算机正在运行美国英语系统区域设置时，安装程序会自动选择 SQL Server 排序规则：字典顺序，不区分大小写，用于 1252 字符集。 若要选择等效的 Windows 排序规则，请选择“排序规则指示符”，选择 Latin1_General，清除“区分大小写”，然后选择“区分重音”。
将已安装的 SQL Server 6.5 或 SQL Server 7.0 升级到 SQL Server 2005 的默认实例，或者安装将与已安装的 SQL Server 6.5 进行版本切换的 SQL Server 2005 的默认实例 | 使用安装程序所选的 SQL Server 排序规则。
与 SQL Server 2005 的现有实例同步（例如复制） | 在现有实例上从代码编辑器选择“SERVERPROPERTY(N'Collation')”，并指定排序规则。有关详细信息，请参阅 SERVERPROPERTY (Transact-SQL)。如果现有实例的排序规则名称是以“SQL”开头，请在安装程序中选择相同的 SQL Server 排序规则。如果现有实例的排序规则名称不是以“SQL”开头，则排序规则名称指的是 Windows 排序规则名称，由排序规则指示符名称后加说明组成，说明的内容是所指定的二进制、区分大小写、区分重音、区分假名以及区分全半角的选项。请在 SQL Server 安装程序中选择相同的 Windows 排序规则指示符和排序选项。 有关排序规则行为的详细信息，请参阅 Windows 排序规则排序样式。
与 SQL Server 6.5、SQL Server 7.0 或 SQL Server 2000 的现有安装同步 | 在现有系统上运行 sp_helpsort，然后使用排序 ID 选择 SQL Server 排序规则，以使您的 SQL Server 2005 实例与现有安装兼容。 有关详细信息，请参阅选择 SQL 排序规则。
与另一台计算机的 Windows 系统区域设置同步 | 在控制面板中，在“区域选项”（Windows 2000 或 Windows 2003）或“区域和语言选项”(Windows XP) 下找到区域设置名称，然后使用安装程序中的排序规则设置主题中提供的表。设置排序选项，详见联机丛书主题Windows 排序规则排序样式中的介绍。
注意：
在执行取决于排序规则的操作时，引用的对象所使用的 SQL Server 排序规则必须使用计算机上运行的操作系统所支持的代码页。

请参阅

参考

选择 SQL 排序规则
设置客户端代码页

其他资源

SQL 排序规则名称 (Transact-SQL)


选择 SQL 排序规则

选择 SQL 排序规则 |
 | 请参阅
准备安装 SQL Server 2005 > 排序规则选项与国际支持 > 使用 SQL 排序规则 >

本主题介绍 Microsoft SQL Server 实例的 SQL Server 排序规则选项，这些实例要求与不使用排序规则的 SQL Server 早期版本兼容。

以下 SQL Server 排序规则列于 SQL Server 安装向导的“排序规则设置”页上。

SQL 排序顺序 ID | 排序顺序名称 | 说明 | SQL 排序规则
31 | diction.437 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp437_CS_AS_KI_WI
32 | nocase.437 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp437_CI_AS_KI_WI
33 | nocasepr.437 | 字典顺序，不区分大小写，大写字母优先 | SQL_Latin1_General_Pref_Cp437_CI_AS_KI_WI
34 | noaccent.437 | 字典顺序，不区分大小写，不区分重音 | SQL_Latin1_General_Cp437_CI_AI_KI_WI
40 | cp437bin.437 | Binary | SQL_Latin1_General_Cp437_BIN
40 | cp850bin.850 | Binary | SQL_Latin1_General_Cp850_BIN
41 | diction.850 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp850_CS_AS_KI_WI
42 | nocase.850 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp850_CI_AS_KI_WI
44 | noaccent.850 | 字典顺序，不区分大小写，不区分重音 | SQL_Latin1_General_Cp850_CI_AI_KI_WI
44 | nocase34.850 | 字典顺序，不区分大小写，大写字母优先 | SQL_Latin1_General_Pref_Cp850_CI_AS_KI_WI
49 | nocase34.850 | 与 1.x 版不区分大小写的数据库严格兼容 | SQL_1xCompat_Cp850_CI_AS_KI_WI
51 | diction.iso | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1_CS_AS_KI_WI
52 | nocase.iso | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1_CI_AS_KI_WI
53 | nocasepr.iso | 字典顺序，不区分大小写，大写字母优先 | SQL_Latin1_General_Pref_Cp1_CI_AS_KI_WI
54 | noaccent.iso | 字典顺序，不区分大小写，不区分重音 | SQL_Latin1_General_Cp1_CI_AI_KI_WI
55 | altdict.850 | 可选字典顺序，区分大小写 | SQL_AltDiction_Cp850_CS_AS_KI_WI
56 | altnocsp.850 | 可选字典顺序，不区分大小写，大写字母优先 | SQL_AltDiction_Pref_Cp850_CI_AS_KI_WI
57 | altnoacc.850 | 可选字典顺序，不区分大小写，不区分重音 | SQL_AltDiction_Cp850_CI_AI_KI_WI
58 | scan.850 | 斯堪的纳维亚文字典顺序，不区分大小写，大写字母优先 | SQL_Scandainavian_Pref_Cp850_CI_AS_KI_WI
59 | scandict.850 | 斯堪的纳维亚文字典顺序，区分大小写 | SQL_Scandainavian_Cp850_CS_AS_KI_WI
60 | scannocase.850 | 不区分大小写的斯堪的纳维亚文字典顺序，无大小写字母优先 | SQL_Scandainavian_Cp850_CI_AS_KI_WI
61 | altnocs.850 | 可选字典顺序，不区分大小写 | SQL_AltDiction_Cp850_CI_AS_KI_WI
80 | binary.250 | Binary | SQL_Latin1_General_1250_BIN
81 | diction.250 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1250_CS_AS_KI_WI
82 | nocase.250 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1250_CI_AS_KI_WI
83 | csydic.250 | 捷克文字典顺序，区分大小写 | SQL_Czech_Cp1250_CS_AS_KI_WI
84 | csync.250 | 捷克文字典顺序，不区分大小写 | SQL_Czech_Cp1250_CI_AS_KI_WI
85 | hundic.250 | 匈牙利文字典顺序，区分大小写 | SQL_Hungarian_Cp1250_CS_AS_KI_WI
86 | hunnc.250 | 匈牙利文字典顺序，不区分大小写 | SQL_Hungarian_Cp1250_CI_AS_KI_WI
87 | plkdic.250 | 波兰文字典顺序，区分大小写 | SQL_Polish_Cp1250_CS_AS_KI_WI
88 | plknc.250 | 波兰文字典顺序，不区分大小写 | SQL_Polish_Cp1250_CI_AS_KI_WI
89 | romdic.250 | 罗马尼亚文字典顺序，区分大小写 | SQL_Romanian_Cp1250_CS_AS_KI_WI
90 | romnc.250 | 罗马尼亚文字典顺序，不区分大小写 | SQL_Romanian_Cp1250_CI_AS_KI_WI
91 | shldic.250 | 克罗地亚文字典顺序，区分大小写 | SQL_Croatian_Cp1250_CS_AS_KI_WI
92 | shlnc.250 | 克罗地亚文字典顺序，不区分大小写 | SQL_Croatian_Cp1250_CI_AS_KI_WI
93 | skydic.250 | 斯洛伐克文字典顺序，区分大小写 | SQL_Slovak_Cp1250_CS_AS_KI_WI
94 | skync.250 | 斯洛伐克文字典顺序，不区分大小写 | SQL_Slovak_Cp1250_CI_AS_KI_WI
95 | slvdic.250 | 斯洛文尼亚文字典顺序，区分大小写 | SQL_Slovenian_Cp1250_CS_AS_KI_WI
96 | slvnc.250 | 斯洛文尼亚文字典顺序，不区分大小写 | SQL_Slovenian_Cp1250_CI_AS_KI_WI
104 | binary.250 | Binary | SQL_Latin1_General_1251_BIN
105 | diction.251 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1251_CS_AS_KI_WI
106 | nocase.251 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1251_CI_AS_KI_WI
107 | ukrdic.251 | 乌克兰文字典顺序，区分大小写 | SQL_Ukrainian_Cp1251_CS_AS_KI_WI
108 | ukrnc.251 | 乌克兰文字典顺序，不区分大小写 | SQL_Ukrainian_Cp1251_CI_AS_KI_WI
112 | binary.253 | Binary | SQL_Latin1_General_1253_BIN
113 | diction.253 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1253_CS_AS_KI_WI
114 | nocase.253 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1253_CI_AS_KI_WI
121 | graltdct.253 | 字典顺序，区分大小写，区分重音 | SQL_Latin1_General_Cp1253_CI_AS_KI_WI
124 | grnoacce.253 | 字典顺序，不区分大小写，不区分重音 | SQL_Latin1_General_Cp1253_CI_AI_KI_WI
128 | binary.254 | Binary | SQL_Latin1_General_1254_BIN
129 | diction.254 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1254_CS_AS_KI_WI
130 | nocase.254 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1254_CI_AS_KI_WI
136 | binary.255 | Binary | SQL_Latin1_General_1255_BIN
137 | diction.255 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1255_CS_AS_KI_WI
138 | nocase.255 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1255_CI_AS_KI_WI
144 | binary.256 | Binary | SQL_Latin1_General_1256_BIN
145 | diction.256 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1256_CS_AS_KI_WI
146 | nocase.256 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1256_CI_AS_KI_WI
152 | binary.257 | Binary | SQL_Latin1_General_1257_BIN
153 | diction.257 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1257_CS_AS_KI_WI
154 | nocase.257 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1257_CI_AS_KI_WI
155 | etidic.257 | 爱沙尼亚文字典顺序，区分大小写 | SQL_Estonian_Cp1257_CS_AS_KI_WI
156 | etinc.257 | 爱沙尼亚文字典顺序，不区分大小写 | SQL_Estonian_Cp1257_CI_AS_KI_WI
157 | lvidic.257 | 拉托维亚文字典顺序，区分大小写 | SQL_Latvian_Cp1257_CS_AS_KI_WI
158 | lvinc.257 | 拉托维亚文字典顺序，不区分大小写 | SQL_Latvian_Cp1257_CI_AS_KI_WI
159 | lthdic.257 | 立陶宛文字典顺序，区分大小写 | SQL_Lithuanian_Cp1257_CS_AS_KI_WI
160 | lthnc.257 | 立陶宛文字典顺序，不区分大小写 | SQL_Lithuanian_Cp1257_CI_AS_KI_WI
183 | danonocp.iso | 丹麦/挪威文字典顺序，不区分大小写，大写字母优先 | SQL_Danish_Pref_Cp1_CI_AS_KI_WI
184 | islanocp.iso | 瑞典/芬兰文[电话簿]字典顺序，不区分大小写，大写字母优先 | SQL_SwedidhPhone_Pref_Cp1_CI_AS_KI_WI
185 | svf2nocp.iso.iso | 瑞典/芬兰文[标准]字典顺序，不区分大小写，大写字母优先 | SQL_SwedishStd_Pref_Cp1_CI_AS_KI_WI
186 | islanocp.iso | 冰岛文字典顺序，不区分大小写，大写字母优先 | SQL_Icelandic_Pref_Cp1_CI_AS_KI_WI
注意：
每个 SQL Server 排序规则名称在 Transact-SQL 代码中都有等效的字符串。有关排序顺序标识符及其 Transact-SQL 等效项的列表，请参阅 SQL 排序规则名称 (Transact-SQL)。

请参阅

参考

安装程序中的排序规则设置

概念

使用 SQL 排序规则


设置客户端代码页

设置客户端代码页 |
 | 请参阅
准备安装 SQL Server 2005 > 排序规则选项与国际支持 >

客户端使用的代码页取决于操作系统的设置。若要在 Microsoft Windows 2000、Microsoft Windows XP 或 Microsoft Windows Server 2003 操作系统上设置客户端代码页，请使用控制面板中的“区域设置”，详见 Windows 文档中的说明。

请参阅

参考

排序规则选项与国际支持


使用 SQL Server 的多个版本

使用 SQL Server 的多个版本 |
 | 请参阅
准备安装 SQL Server 2005 >

Microsoft SQL Server 2005 支持同一台计算机上数据库引擎、Microsoft SQL Server 2005 Analysis Services (SSAS) 和 Microsoft SQL Server 2005 Reporting Services (SSRS) 的多个实例。也可以在已安装 SQL Server 早期版本的计算机上升级 SQL Server 的早期版本，或安装 SQL Server 2005。

并行使用 SQL Server 2005 与早期版本的 SQL Server

可以在已运行 SQL Server 早期版本实例的计算机上安装 SQL Server 2005。如果计算机上已存在默认实例，SQL Server 2005 将作为命名实例安装。

并行支持如下：

并行支持 | SQL Server 2000（32 位） | SQL Server 2000（64 位） | SQL Server 2005（32 位） | SQL Server 2005（64 位）IA64 | SQL Server 2005（64 位）X64
SQL Server 7.0 | 是 | 否 | 是 | 否 | 否
SQL Server 2000（32 位） | 是 | 否 | 是 | 否1 | 是
SQL Server 2000（64 位） | 否 | 是 | 否 | 是 | 否
SQL Server 2005（32 位） | 是 | 否 | 是 | 否 | 是
SQL Server 2005（64 位）IA64 | 否 | 是 | 否 | 是 | 否
SQL Server 2005（64 位）X64 | 是 | 否 | 是 | 否 | 是

1SQL Server 的 32 位版本仅受 X64 版本的 64 位操作系统上的 WOW64 支持。SQL Server 的 32 位版本不受 IA64 版本的 64 位操作系统上的 WOW64 支持。

请参阅

任务

如何安装 SQL Server 2005（安装程序）

参考

安装 SQL Server 2005 的硬件和软件要求

概念

使用升级顾问来准备升级

其他资源

升级到 SQL Server 2005
向后兼容性


SQL Server 2005 准备帮助主题

SQL Server 2005 准备帮助主题 |
 | 请参阅
准备安装 SQL Server 2005 >

此部分包含有关如何准备 SQL Server 2005 的信息。

本节的相关信息

  • 如何更改操作系统设置以支持本地化版本

  • 如何禁用基于 TCP/IP 的 NetBIOS

  • 如何禁用服务器消息块

  • 如何验证 SQL Server 服务的权限

请参阅

参考

排序规则选项与国际支持
设置 Windows 服务帐户


如何更改操作系统设置以支持本地化版本

如何更改操作系统设置以支持本地化版本 |
 | 请参阅
准备安装 SQL Server 2005 > SQL Server 2005 准备帮助主题 >

在受支持的操作系统的英文版上，通过使用 Microsoft Windows 多语言用户界面包 (MUI) 设置，支持 Microsoft SQL Server 2005 的本地化版本。

不过，在运行英语版操作系统（具有非英文 MUI 设置）的服务器上安装 SQL Server 2005 的本地化版本之前，必须先验证某些操作系统设置。需要验证下列操作系统设置是否匹配要安装的本地化 SQL Server 的语言：

  • 操作系统用户界面设置

  • 操作系统用户区域设置

  • 系统区域设置

如果这些设置与要安装的本地化 SQL Server 的语言不匹配，请使用下列过程正确设置这些操作系统设置。

注意：
不支持在同一台计算机上安装 SQL Server 实例的不同语言版本。示例：德语 SQL Server 2005 和葡萄牙语（巴西）SQL Server 2005 不能作为同一台计算机上的多个实例。

更改操作系统用户界面设置

  1. 安装与 SQL Server 2005 本地化版本匹配的操作系统 MUI（如果尚未安装）。

  2. 在 Control Panel 中，打开 Regional and Language Options。

  3. 在 Languages 选项卡上，从列表中为 Language used in menus and dialogs 选择一个值。

    此设置将影响 SQL Server 2005 的用户界面语言，所以它必须与 SQL Server 2005 的本地化版本匹配。

  4. 单击 Apply 确认更改，然后单击 OK 关闭窗口。

更改操作系统用户区域设置

  1. 安装与 SQL Server 2005 本地化版本匹配的操作系统 MUI（如果尚未安装）。

  2. 在 Control Panel 中，打开 Regional and Language Options。

  3. 在 Regional Options 选项卡上，从列表中为 Select an item to match its preferences 选择一个值。

    此设置将影响特定于区域性的数据格式。

  4. 单击 Apply 确认更改，然后单击 OK 关闭窗口。

更改系统区域设置

  1. 安装与 SQL Server 2005 本地化版本匹配的操作系统 MUI（如果尚未安装）。

  2. 在 Control Panel 中，打开 Regional and Language Options。

  3. 在 Advanced 选项卡上，从列表中为 Select a language to match the language version of the non-Unicode programs you want to use 选择一个值。

    此设置将使 SQL Server 安装程序可以为 SQL Server 2005 安装选择最佳默认排序规则。

  4. 单击 Apply 确认更改，再单击 OK 关闭窗口。

请参阅

参考

排序规则选项与国际支持
安装 SQL Server 2005 的硬件和软件要求

其他资源

SQL Server 2005 准备帮助主题


如何禁用基于 TCP/IP 的 NetBIOS

如何禁用基于 TCP/IP 的 NetBIOS |
 | 请参阅
准备安装 SQL Server 2005 > SQL Server 2005 准备帮助主题 >

周边网络中的服务器应禁用所有不必要的协议，包括 NetBIOS。Web 服务器和域名系统 (DNS) 服务器不需要 NetBIOS。应该禁用此协议，以减少由用户枚举造成的风险。

禁用 TCP/IP 上的 NetBIOS

  1. 从“开始”菜单，右键单击“我的电脑”，然后单击“管理”。

  2. 展开“系统工具”，然后清除“设备管理器”复选框。

  3. 右键单击“设备管理器”，指向“查看”，再选择“显示隐藏设备”。

  4. 展开“非即插即用驱动程序”。

  5. 右键单击“TCP/IP 上的 NetBios”，然后单击“禁用”。

    此操作禁用 TCP/445 和 UDP 445 上的 SMB 直接主机侦听器。

    注意：
    此过程禁用 nbt.sys 驱动程序。“高级 TCP/IP 设置”对话框的 WINS 选项卡中包含“禁用 TCP/IP 上的 NetBIOS”选项。选择此选项只能禁用 NetBIOS 会话服务（该会话服务侦听 TCP 端口 139），而不能完全禁用 NetBIOS。

请参阅

任务

如何禁用服务器消息块

概念

安装 SQL Server 的安全注意事项

其他资源

SQL Server 2005 准备帮助主题


如何禁用服务器消息块

如何禁用服务器消息块 |
 | 请参阅
准备安装 SQL Server 2005 > SQL Server 2005 准备帮助主题 >

周边网络中的服务器应该禁用所有不必要的协议，其中包括服务器消息块 (SMB)。Web 服务器和域名系统 (DNS) 服务器不需要 SMB。应该禁用此协议，以防来自用户枚举的威胁。

禁用 SMB

  1. 在“开始”菜单中，指向“设置”，然后单击“网络和拨号连接”。

    右键单击 Internet 连接，然后单击“属性”。

  2. 选中“Microsoft Networks 客户端”复选框，然后单击“卸载”。

  3. 执行卸载步骤。

  4. 选择“Microsoft Networks 文件和打印机共享”，然后单击“卸载”。

  5. 执行卸载步骤。

在可通过 Internet 访问的服务器上禁用 SMB

  • 在本地连接属性中，使用“传播控制协议/Internet 协议 (TCP/IP) 属性”对话框删除“Microsoft Networks 文件和打印共享”和“Microsoft Networks 客户端”。

请参阅

任务

如何禁用基于 TCP/IP 的 NetBIOS

概念

安装 SQL Server 的安全注意事项

其他资源

SQL Server 2005 准备帮助主题


如何验证 SQL Server 服务的权限

如何验证 SQL Server 服务的权限 |
 | 请参阅
准备安装 SQL Server 2005 > SQL Server 2005 准备帮助主题 >

为使 Microsoft SQL Server 和 SQL Server 代理在 Windows 中作为服务运行，必须为其指派 Microsoft Windows 用户帐户。通常为 SQL Server 和 SQL Server 代理指派相同的用户帐户，要么是本地系统用户帐户，要么是域用户帐户。但是，也可以在安装过程中为每个服务自定义设置。有关在安装期间如何自定义每个服务的帐户信息的详细信息，请参阅服务帐户。

安全说明：
始终用尽可能低的权限运行 SQL Server 服务。

验证 SQL Server 服务的权限

  1. 单击“开始”，打开“控制面板”，然后打开“管理工具”。

  2. 打开“本地安全策略”，选择“本地策略”文件夹，然后双击“用户权利指派”。

  3. 右键单击一个权限，然后选择“属性”。

  4. 在“属性”对话框中，验证是否列出了欲运行 SQL Server 代理的帐户。如果没有列出，请单击“添加用户或组”，然后添加要运行 SQL Server 代理服务的用户帐户。

  5. 完成所需的更改后，单击“确定”。

  6. 对每个权限和服务重复此过程。

安全性

配置 SQL Server 2005 的服务，以使它们用所需的最低权限运行。

请参阅

参考

设置 Windows 服务帐户
服务帐户
服务帐户（分类）

概念

安装 SQL Server 的安全注意事项


升级到 SQL Server 2005

升级到 SQL Server 2005 |
 | 请参阅

可以将 SQL Server 2000 Service Pack 3 (SP3) 或更高版本的实例以及 SQL Server 7.0 SP4 或更高版本的实例直接升级到 SQL Server 2005。通过安装程序可以完成大多数升级操作；但是，某些组件支持或要求在运行安装程序后迁移应用程序或解决方案。有关详细信息，请参阅升级 SQL Server 组件。

在运行安装程序以升级到 SQL Server 2005 之前，应该首先检查系统要求和升级矩阵。若要检查系统要求，请参阅准备安装 SQL Server 2005。若要检查升级矩阵，请参阅版本升级。

检查系统要求和升级矩阵之后，请运行 SQL Server 升级顾问以分析 SQL Server 2000 和 SQL Server 7.0 的实例。升级顾问针对您的安装生成问题列表，必须在升级之前或之后解决这些问题。SQL Server 安装程序将检测阻止升级到 SQL Server 2005 遇到的问题，但不会列出可能影响应用程序的问题。

本节的相关信息

主题 | 说明
版本升级 | 列出从 SQL Server 的一个版本升级到另一个版本或者升级到 SQL Server 同一版本的某个版本类别的规则。
使用升级顾问来准备升级 | 介绍升级顾问，该升级顾问分析 SQL Server 2000 和 SQL Server 7.0 的实例，并报告已知的升级问题。
升级 SQL Server 组件 | 包含将各个 SQL Server 组件升级到 SQL Server 2005 的信息和说明。
向后兼容性 | 列出在升级到 SQL Server 2005 时可能影响应用程序的重大变更。

请参阅

概念

准备安装 SQL Server 2005
安装 SQL Server 2005


版本升级

版本升级 |
 | 请参阅
升级到 SQL Server 2005 >

此 SQL Server 2005 版本支持以下升级方案：

升级前的版本 | 支持的升级路径
SQL Server 7.0 Enterprise Edition SP4 | SQL Server 2005 Enterprise Edition
SQL Server 7.0 Developer Edition SP4 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition
SQL Server 7.0 Standard Edition SP4 | SQL Server 2005 Standard Edition SQL Server 2005 Enterprise Edition
SQL Server 7.0 Desktop Edition SP4 | SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 7.0 Evaluation Edition SP4 | 不支持的升级
SQL Server Desktop Engine (MSDE) 7.0 SP4 | SQL Server 2005 Express Edition
SQL Server 2000 Enterprise Edition SP3 或更高版本1 | SQL Server 2005 Enterprise Edition
SQL Server 2000 Developer Edition SP3 或更高版本1 | SQL Server 2005 Developer Edition
SQL Server 2000 Standard Edition SP3 或更高版本1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition
SQL Server 2000 Workgroup Edition SP3 或更高版本1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 2000 Personal Edition SP3 或更高版本1 | SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition 具有高级服务的 SQL Server 2005 Express Edition
SQL Server 2000 Evaluation Edition SP3 或更高版本1 | SQL Server 2005 Evaluation Edition
SQL Server Desktop Engine (MSDE) 2000 SP3 或更高版本1 | SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition 具有高级服务的 SQL Server 2005 Express Edition
SQL Server 2000 IA64（64 位）Enterprise Edition | SQL Server 2005 IA64（64 位）Enterprise Edition
SQL Server 2000 IA64（64 位）Developer Edition | SQL Server 2005 IA64（64 位）Enterprise Edition SQL Server 2005 IA64（64 位）Developer Edition
SQL Server 2005 Developer Edition 1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 2005 Standard Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition
SQL Server 2005 Workgroup Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition
SQL Server 2005 Evaluation Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition
SQL Server 2005 Express Edition 1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition 具有高级服务的 SQL Server 2005 Express Edition
具有高级服务的 SQL Server 2005 Express Edition 1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 2005 IA64（64 位）Developer Edition | SQL Server 2005 IA64（64 位）Enterprise Edition SQL Server 2005 IA64（64 位）Standard Edition
SQL Server 2005 X64（64 位）Developer Edition | SQL Server 2005 X64（64 位）Enterprise Edition SQL Server 2005 X64（64 位）Standard Edition
SQL Server 2005 IA64（64 位）Standard Edition | SQL Server 2005 IA64（64 位）Enterprise Edition SQL Server 2005 IA64（64 位）Developer Edition
SQL Server 2005 X64（64 位）Standard Edition | SQL Server 2005 X64（64 位）Enterprise Edition SQL Server 2005 X64（64 位）Developer Edition
SQL Server 2005 IA64（64 位）Evaluation Edition | SQL Server 2005 IA64（64 位）Enterprise Edition SQL Server 2005 IA64（64 位）Developer Edition SQL Server 2005 IA64（64 位）Standard Edition
SQL Server 2005 X64（64 位）Evaluation Edition | SQL Server 2005 X64（64 位）Enterprise Edition SQL Server 2005 X64（64 位）Developer Edition SQL Server 2005 X64（64 位）Standard Edition

1可在 64 位服务器的 32 位子系统 (WOW64) 上将此版本的 SQL Server 升级到 SQL Server 2005。

升级说明

  • 从其他版本的 SQL Server 2005 升级到 SQL Server 2005 后，必须对升级后的 SQL Server 实例重新应用所有修补程序或 Service Pack 更新。

  • SQL Server 2005 不支持跨版本的实例。在 SQL Server 2005 的实例中，数据库引擎、Analysis Services 和 Reporting Services 组件的版本号必须相同。

  • 升级到 SQL Server 2005 之前，请先启用 SQL Server 代理的 Windows 身份验证，并验证 SQL Server 代理的服务帐户是否是 SQL Server sysadmin 组的成员。

  • 在从 SQL Server 2005 的某一版本升级到另一版本之前，请验证要升级到的版本是否支持当前使用的功能。有关详细信息，请参阅 SQL Server 2005 的各种版本所支持的功能中相关组件的部分。

  • 若要将 SQL Server 实例升级为 SQL Server 2005 故障转移群集，要升级的实例必须是故障转移群集。若要将独立的 SQL Server 实例升级为 SQL Server 2005 故障转移群集，请安装新的 SQL Server 2005 故障转移群集，然后使用复制数据库向导迁移独立实例中的用户数据库。有关升级的详细信息，请参阅如何升级到 SQL Server 2005 故障转移群集（安装程序）。有关数据库迁移的详细信息，请参阅使用复制数据库向导。

  • 在 X64 平台上不支持将 SQL Server 2000 的 32 位实例从 64 位服务器的 32 位子系统 (WOW64) 升级到 SQL Server 2005（64 位）。但是，如上表所示，可在 64 位服务器的 WOW64 上将 SQL Server 的 32 位实例升级为 SQL Server 2005。如果数据库未在复制过程中发布，也可以从 SQL Server 2000 的 32 位实例中备份或分离数据库，并将它们还原或附加到 SQL Server 2005（64 位）的实例。在此情况下，还必须在 master、msdb 和 model 系统数据库中重新创建任何登录名和其他用户对象。

向 SQL Server 2005 的实例添加组件

从“控制面板”的“添加或删除程序”中，可以将组件添加到 SQL Server 2005 的现有安装中，然后选择要对其添加或删除功能的 SQL Server 实例。有关详细信息，请参阅如何在 SQL Server 2005 的现有实例中更改组件（安装程序）。

跨语言支持

对于升级：

  • SQL Server 英文版可以升级为 SQL Server 2005 的任意本地化版本。

  • SQL Server 本地化版本可以升级到相同语言的 SQL Server 2005 本地化版本。

  • SQL Server 本地化版本无法升级到 SQL Server 2005 英文版。

  • SQL Server 本地化版本无法升级到其他本地化语言的 SQL Server 2005 本地化版本。

其他跨语言支持：

  • 所有支持的操作系统的本地化版本均支持 SQL Server 2005 英文版。

  • 与 SQL Server 本地化版本使用同一语言的本地化操作系统支持 SQL Server 2005 的本地化版本。

  • 通过使用 Windows 多语言用户界面包 (MUI) 设置，支持的英语操作系统版本还支持 SQL Server 2005 的本地化版本。不过，在运行英语操作系统（具有非英语 MUI 设置）的服务器上安装 SQL Server 2005 的本地化版本之前，必须先验证某些操作系统设置。必须验证以下操作系统设置是否与要安装的 SQL Server 本地化版本的语言相匹配：

    • 操作系统用户界面设置

    • 操作系统用户区域设置

    • 系统区域设置

    如果这些操作系统设置与 SQL Server 本地化版本的语言不匹配，则必须按照如何更改操作系统设置以支持本地化版本中的说明，正确设置这些操作系统设置。

请参阅

参考

安装选项
安装 SQL Server 2005 的硬件和软件要求

概念

准备安装 SQL Server 2005


使用升级顾问来准备升级

使用升级顾问来准备升级 |
 | 请参阅
升级到 SQL Server 2005 >

Microsoft SQL Server 2005 升级顾问是用于为升级到 SQL Server 2005 作准备的工具。升级顾问对已安装的 SQL Server 2000 或 SQL Server 7.0 组件进行分析，然后生成一个报表，报表中标识出升级到 SQL Server 2005 之前或之后必须或应解决的问题。

升级顾问如何工作

运行升级顾问时，将显示“升级顾问”主页。通过该主页，可以启动以下工具：

  • 升级顾问分析向导

  • 升级顾问报表查看器

  • 升级顾问帮助

第一次使用升级顾问时，应运行升级顾问分析向导以分析 SQL Server 组件。该向导完成分析后，可以使用升级顾问报表查看器查看结果报表。报表提供的链接内包含有助于修复或缓和已知问题的信息。

升级顾问分析

升级顾问会对以下 SQL Server 组件进行分析：

  • 数据库引擎

  • Analysis Services

  • Notification Services

  • Reporting Services

  • Data Transformation Services (DTS)，现在称为 SQL Server Integration Services

在每个 SQL Server 组件的升级顾问的环境中都运行有专用分析器。该分析会检查可由各个分析器进行访问的对象，例如脚本、存储过程、触发器和跟踪文件。升级顾问不能对桌面应用程序和加密的存储过程进行分析。

每个单独分析器的输出是该组件的 XML 报表。使用升级顾问报表查看器可查看 XML 报表。

如何安装和运行升级顾问

Microsoft SQL Server 2005 升级顾问的安装位置取决于您将分析的内容。升级顾问支持对所有受支持组件（除 Reporting Services 外）进行远程分析。如果未扫描 Reporting Services 的实例，则可在能够连接到 SQL Server 实例并满足升级顾问前提条件的任何计算机中安装升级顾问。如果正在扫描 Reporting Services 实例，则必须在报表服务器中安装升级顾问。

可从 SQL Server 2005 产品介质和此 Microsoft 网站获取升级顾问。安装升级顾问的前提条件如下：

  • Windows 2000 SP4 或更高版本、Windows XP SP2 或更高版本，或者 Windows Server 2003 SP1 或更高版本。

  • Microsoft Windows Installer 3.1 或更高版本。

    .NET Framework 2.0 版需要 Windows Installer 3.1。可以从此 Microsoft 网站安装 Windows Installer。

  • Microsoft .NET Framework 2.0 或更高版本。SQL Server 2005 产品介质和此 Microsoft 网站提供了 .NET Framework 2.0 版。

    • 若要从 SQL Server 2005 介质安装 .NET Framework 2.0 版，请找到 CD/DVD 驱动器的根目录，双击 redist 文件夹，再双击 2.0 文件夹，然后根据您使用的操作系统运行 dotnetfx.exe（适用于 32 位）或 dotnetfx64.exe（适用于 64 位）。

  • 扫描 Analysis Services 中的升级问题时需要使用 SQL Server 2000 决策支持对象 (DSO)。若要安装 DSO，请将 SQL Server 2000 介质插入 CD/DVD 驱动器。这将启动 SQL Server 2000 安装程序。单击“安装 SQL Server 2000 组件”。单击“Analysis Services”启动 Analysis Services 安装程序。在“选择组件”中，确保选择了“决策支持对象”组件。

  • 扫描 DTS 包时需要使用 SQL Server 2000 客户端组件。如果计算机没有安装这些组件，请将 SQL Server 2000 媒体插入 CD/DVD 驱动器并安装这些组件。

安装升级顾问后，可以从“开始”菜单启动升级顾问：

  • 单击“开始”，依次指向“所有程序”和 Microsoft SQL Server 2005，再单击“SQL Server 2005 升级顾问”。

有关运行升级顾问的详细信息，请参阅随升级顾问一起安装的升级顾问帮助和自述文件。

请参阅

其他资源

升级到 SQL Server 2005
向后兼容性


升级 SQL Server 组件

升级 SQL Server 组件 |
 | 请参阅
升级到 SQL Server 2005 >

此部分提供有关从 Microsoft SQL Server 的早期版本向 SQL Server 2005 升级和迁移组件，以及在 SQL Server 2005 的各版本之间升级和迁移组件的信息。升级通常由 SQL Server 安装程序执行。迁移通常在安装或升级 SQL Server 2005 后完成。

本节的相关信息

主题 | 说明
升级数据库引擎 | 提供有关将数据库引擎 从 SQL Server 7.0 或 SQL Server 2000 升级的信息。
升级或迁移 Analysis Services | 包含有关 Analysis Services 的升级选项以及如何升级或迁移 Analysis Services 数据库的信息。
升级或迁移 Data Transformation Services | 包含有关升级到 SQL Server 2005 Integration Services (SSIS) 以及如何将包迁移到 SQL Server 2005 的信息。
迁移 Notification Services 实例 | 包含有关将 Notification Services 的实例从 Notification Services 2.0 迁移或升级到 SQL Server 2005 的更高版本的信息。
升级 Reporting Services | 说明升级 Reporting Services 的要求和步骤，并提供关于哪些组件被删除的信息。
升级复制数据库 | 提供有关升级已复制数据库的信息。
升级 SQL Server 组件帮助主题 | 包含升级 SQL Server 组件的分步说明。

请参阅

概念

安装 SQL Server 2005

其他资源

升级到 SQL Server 2005


升级数据库引擎

升级数据库引擎 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 >

可以将 Microsoft SQL Server 数据库引擎 从 Microsoft SQL Server 7.0 版或 Microsoft SQL Server 2000 升级至 Microsoft SQL Server 2005。有关受支持的升级路径的信息，请参阅版本升级。

SQL Server 2005 安装程序只需最少的用户干预就可升级 SQL Server 的早期版本。不过，适当准备和熟悉升级过程可以更容易防止或解决出现的任何问题。

此主题提供了为升级过程做准备和了解升级过程所需的信息，其中包括：

  • 已知升级问题。

  • 升级前的任务和注意事项。

  • 将数据库引擎 升级至 SQL Server 2005 的过程主题的链接。

  • 将数据库迁移至 SQL Server 2005 的过程主题的链接。

  • 故障转移群集的注意事项。

  • 升级后的任务和注意事项。

已知升级问题

在将数据库引擎 升级至 SQL Server 2005 前，请查看 SQL Server 2005 数据库引擎的向后兼容性。有关其他 SQL Server 组件的向后兼容性的内容，请参阅向后兼容性。

重要事项：
在从 SQL Server 2005 的某一版本升级到另一版本之前，请验证要升级到的版本是否支持当前使用的功能。有关详细信息，请参阅 SQL Server 2005 的各种版本所支持的功能中相关组件的部分。

升级前的检查表

SQL Server 2005 安装程序支持从早期 SQL Server 版本升级至 SQL Server 2005。也可以将数据库从早期 SQL Server 版本迁移至 SQL Server 2005 的实例。可以从一个 SQL Server 实例迁移至同一台计算机上的另一个实例，也可以从另一台服务器上的 SQL Server 实例迁移。迁移选项包括使用复制数据库向导、备份和还原功能、使用 SQL Server 2005 Integration Services 导入和导出向导，以及大容量导出/大容量导入方法。

在升级数据库引擎 前，请确保执行下列操作：

阅读与升级到 SQL Server 2005 有关的文档：

  • 阅读安装 SQL Server 2005 的硬件和软件要求。

  • 阅读系统配置检查器的检查参数。

  • 阅读 安装 SQL Server 的安全注意事项。

  • 阅读使用升级顾问来准备升级。

  • 阅读 SQL Server 2005 数据库引擎的向后兼容性。

如有必要，请在升级到 SQL Server 2005 之前检查下列问题并做出更改：

  • 从 Microsoft SQL Server 2000 的 64 位版本升级到 Microsoft SQL Server 2005 的 64 位版本时，必须先升级 Analysis Services，然后再升级数据库引擎。

  • 如有必要，备份要升级实例中的所有 SQL Server 数据库文件，以便可以完全还原这些文件。

  • 在数据库上运行适当的数据库控制台命令 (DBCC)，以确保这些数据库处于一致状态。

  • 估计升级 SQL Server 组件以及用户数据库所需的磁盘空间。有关 SQL Server 2005 组件所需磁盘空间的信息，请参阅安装 SQL Server 2005 的硬件和软件要求。

  • 确保将现有的 SQL Server 系统数据库（master、model、msdb 和 tempdb）配置为自动增长，并确保它们具有足够的硬盘空间。

  • 确保所有数据库服务器的 master 数据库中都有登录信息。这对还原数据库很重要，因为 master 数据库中有系统登录信息。

  • 禁用所有启动存储过程，因为升级过程在升级 SQL Server 实例时将停止然后再启动服务。在启动时处理的存储过程可能会阻塞升级过程。

  • 停止复制并确保复制日志是空的。

  • 将 SQL Server 2000 数据库引擎实例升级到 SQL Server 2005 时，将保留 max worker threads 的配置值。但是，建议在升级前将 max worker threads 值更改为 0，以允许数据库引擎计算最佳线程数。有关详细信息，请参阅 max worker threads 选项。

  • 退出所有应用程序，包括所有依赖 SQL Server 的服务。如果有本地应用程序连接到正在升级的实例，则升级可能会失败。有关详细信息，请参阅SQL Server 数据库引擎的安装故障排除。

升级数据库引擎

可以用升级至 SQL Server 2005 的版本覆盖 SQL Server 7.0 或 SQL Server 2000 的安装。如果在运行 SQL Server 2005 安装程序时检测到 SQL Server 的早期版本，将升级所有早期 SQL Server 程序文件，并且保留早期 SQL Server 实例中存储的所有数据。此外，计算机上早期版本的 SQL Server 联机丛书将保持不变。若要访问早期版本的 SQL Server 联机丛书，请参阅如何访问 SQL Server 7.0 联机丛书或如何访问 SQL Server 2000 联机丛书。

注意：
在升级到 SQL Server 2005 后，早期的 SQL Server 实例将被覆盖，在计算机中不再存在。因此在升级前，请备份 SQL Server 数据库以及与早期的 SQL Server 实例相关的其他对象。

可以使用 SQL Server 安装向导（用户界面模式中的 Setup.exe）或从命令提示符 (Setup.exe) 升级数据库引擎。

注意：
如果计算机安装了 SQL Server 2000 管理工具和 SQL Server 2005 的默认实例，则 SQL Server 安装程序将允许您安装 SQL Server 2000 默认实例。但这样做将禁用已安装的 SQL Server 2005 实例。因此，当计算机中已存在 SQL Server 2000 管理工具和 SQL Server 2005 的默认实例时，请不要安装 SQL Server 的默认实例。

升级后的数据库兼容级别

升级后，SQL Server 2005 自动将数据库兼容级别设置为早期版本 SQL Server 的数据库兼容级别。因此，如果从 SQL Server 7.0 升级到 SQL Server 2000，然后再升级到 SQL Server 2005，则兼容级别将被设置为 SQL Server 2000 的级别。

将数据库引擎升级至 SQL Server 2005

  • 如何升级到 SQL Server 2005（安装程序）

  • 如何升级到 SQL Server 2005 故障转移群集（安装程序）

  • 升级复制数据库

将数据库迁移至 SQL Server 2005

可以使用 SQL Server 2005 中的备份和还原功能或分离和附加功能将用户数据库移动到 SQL Server 2005 实例。

重要事项：
数据库在源服务器和目的服务器上的名称相同时，不能进行移动或复制。在这种情况下，它被标记为“已存在”。

将用户数据库迁移至 SQL Server 2005

  • 使用复制数据库向导

  • 如何使用复制数据库向导升级至 SQL Server 2005

升级数据库引擎时的故障转移群集注意事项

SQL Server 2005 故障转移群集为整个 SQL Server 实例提供高可用性支持。故障转移群集是 Microsoft 群集服务 (MSCS) 群集组（称为资源组）中参与群集节点的一个或多个物理磁盘的组合。资源组配置为承载 SQL Server 实例的虚拟服务器。

SQL Server 虚拟服务器在网络中看起来好像单台计算机，但是当某一节点不可用时，它具有提供故障转移从一个节点到另一个节点的功能。例如，在发生硬件故障、操作系统故障或进行计划内升级时，可以在故障转移群集的一个节点上配置 SQL Server 实例，以便故障转移至磁盘组中的任何其他节点。可以使用故障转移群集减少系统停机时间并提供更高的应用程序可用性。

若要将 SQL Server 实例升级至 SQL Server 2005 故障转移群集，则要升级的实例必须是故障转移群集。若要将 SQL Server 的独立实例升级至 SQL Server 2005 故障转移群集，请安装新的 SQL Server 2005 故障转移群集，然后使用复制数据库向导迁移独立实例中的用户数据库。有关升级的详细信息，请参阅如何升级到 SQL Server 2005 故障转移群集（安装程序）。有关数据库迁移的详细信息，请参阅使用复制数据库向导。

有关故障转移群集的详细信息，请参阅故障转移群集和创建虚拟服务器，安装故障转移群集。有关升级至 SQL Server 2005 故障转移群集的详细信息，请参阅如何升级到 SQL Server 2005 故障转移群集（安装程序）。

升级数据库引擎后

将数据库引擎 升级到 SQL Server 2005 之后，请完成以下任务：

  • 从其他版本的 SQL Server 2005 升级到 SQL Server 2005 后，必须对升级后的 SQL Server 实例重新应用所有修补程序或 Service Pack 更新。

  • 注册服务器 - 升级会删除早期的 SQL Server 实例的注册表设置。升级之后，必须重新注册服务器。

  • 重新填充全文目录 - 在升级过程中数据库被标记为禁用全文。目录必须重新填充，但是因为此操作耗费时间很长，所以安装程序不会自动运行此操作。由于此操作可增强 SQL Server 2005 安装的性能，因此管理员应计划在方便的时候重新填充全文目录。

  • 更新统计信息 - 建议您在升级之后对所有数据库更新统计信息，以便优化查询性能。使用 sp_updatestats 存储过程更新 SQL Server 2005 数据库用户定义表中的统计信息。

  • 更新使用计数器 - 在 SQL Server 的早期版本中，表和索引的行计数与页计数的值可能会不正确。若要更正任何无效的行或页计数，建议在升级完成后对所有数据库运行 DBCC UPDATEUSAGE。

  • 配置新安装的 SQL Server - 为了减少系统的可攻击外围应用，SQL Server 2005 将有选择地安装并激活一些重要服务和功能。有关如何激活 SQL Server 2005 功能的详细信息，请参阅 SQL Server 外围应用配置器。

在升级前标记为启用或禁用全文的数据库，在升级后也将保持该状态。升级后，将为所有启用全文的数据库自动重新生成并填充全文目录。此项操作既耗时又耗费资源。可以通过运行以下语句暂停全文索引操作：

复制代码
EXEC sp_fulltext_service 'pause_indexing', 1

若要恢复全文索引填充，请运行以下语句：

复制代码
EXEC sp_fulltext_service 'pause_indexing', 0

请参阅

概念

使用 SQL Server 的多个版本
升级复制数据库

其他资源

向后兼容性


升级或迁移 Analysis Services

升级或迁移 Analysis Services |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 >

注意：
有关 Microsoft SQL Server 2005 产品和技术的升级方案的一般信息，我们建议您查看版本升级。

如果您正在使用 Microsoft SQL Server 2000 Analysis Services，则安装 Microsoft SQL Server 2005 Analysis Services (SSAS) 时，以下选项可供选择：

  • 将 Analysis Services 与早期版本并行安装。

  • 升级早期版本的 Analysis Services。

  • 迁移现有的 Analysis Services 数据库。

重要事项：
无论选择哪个安装选项，都应知道哪些 SQL Server 2000 Analysis Services 特性和功能已停止使用、不推荐使用或已更改。有关详细信息，请参阅 SQL Server 2005 Analysis Services 的向后兼容性。

已知升级问题

升级到 SQL Server 2005 Analysis Services 之前，请先查看 SQL Server 2005 Analysis Services 的已知升级问题。

升级前的检查表

升级到 SQL Server 2005 Analysis Services 之前，请先检查以下要求：

  • 安装 SQL Server 2005 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

  • 使用升级顾问来准备升级

将 Analysis Services 与早期版本并行安装

SQL Server 2000 SQL Server 2000 Analysis Services 不支持命名实例。因此，在同时运行 SQL Server 2000 Analysis Services 实例和 SQL Server 2005 Analysis Services 实例的计算机上，SQL Server 2000 Analysis Services 的实例必须始终是默认实例。在这种情况下，SQL Server 安装程序只允许安装 SQL Server 2005 Analysis Services 的命名实例。SQL Server 2000 Analysis Services 可继续作为默认实例与 SQL Server 2005 Analysis Services 的命名实例并行运行。

有关详细信息，请参阅如何将 Analysis Services 与早期版本并行安装。

修改并行安装

可使用 Analysis Services 迁移向导将数据库从 SQL Server 2000 Analysis Services 的实例迁移到 SQL Server 2005 Analysis Services。有关运行迁移向导的详细信息，请参阅迁移现有 Analysis Services 数据库。

如果迁移 SQL Server 2000 Analysis Services 的数据库后，删除其默认实例，则可使用 Analysis Services 实例重命名工具使 SQL Server 2005 Analysis Services 的命名实例成为服务器上的默认实例。

有关详细信息，请参阅如何迁移 Analysis Services 数据库和如何重命名 Analysis Services 实例。

升级早期版本的 Analysis Services

升级 SQL Server 2000 Analysis Services 涉及安装 SQL Server 2005 Analysis Services 以及将现有 Analysis Services 数据库迁移为 SQL Server 2005 Analysis Services 数据库格式。可以在安装过程中升级 SQL Server 2000 Analysis Services 并迁移现有数据库，也可以在安装 SQL Server 2005 Analysis Services 之后，使用除 SQL Server 安装程序之外的其他软件工具迁移数据库。

重要事项：
从 Microsoft SQL Server 2000 的 64 位版本升级到 Microsoft SQL Server 2005 的 64 位版本时，必须先升级 Analysis Services，然后再升级数据库引擎。

在安装过程中升级 SQL Server 2000 Analysis Services 的实例

  1. 在 SQL Server 安装向导的“实例名”页中，选择“默认实例”。

  2. 若要确认是否存在 SQL Server 2000 Analysis Services 实例，可以单击“已安装的实例”按钮。
完成安装后迁移 SQL Server 2000 Analysis Services 的实例

  1. 使用 SQL Server 安装向导或其他安装方法，安装 SQL Server 2005 Analysis Services 的命名实例。有关详细信息，请参阅使用安装程序安装 SQL Server Analysis Services 或从命令提示符安装 SQL Server Analysis Services。

  2. 使用 Analysis Services 迁移向导将 SQL Server 2000 Analysis Services 数据库元数据迁移到 SQL Server 2005 Analysis Services。此步骤以新的 SQL Server 2005 Analysis Services 数据库格式重新创建数据库结构，同时保持原始数据库不变。有关详细信息，请参阅迁移现有 Analysis Services 数据库。

  3. 处理新的 SQL Server 2005 Analysis Services 数据库。此步骤会在新的数据库结构中填充数据。有关详细信息，请参阅处理 Analysis Services 对象。

  4. 验证数据库升级的处理情况。在 SQL Server Management Studio 中检查已升级的数据库，并且使用客户端应用程序测试这些数据库。

  5. 如果不再需要 SQL Server 2000 Analysis Services，就卸载它。

  6. 如果删除了 SQL Server 2000 Analysis Services 默认实例，则可使用 Analysis Services 实例重命名工具将 SQL Server 2005 Analysis Services 的命名实例重命名为默认实例。

有关详细信息，请参阅如何升级 Analysis Services 实例、如何迁移 Analysis Services 数据库和如何重命名 Analysis Services 实例。

迁移现有 Analysis Services 数据库

使用 Analysis Services 迁移向导可将 SQL Server 2000 Analysis Services 数据库升级为 SQL Server 2005 Analysis Services 格式。在迁移期间，向导复制 SQL Server 2000 Analysis Services 数据库对象，然后对 SQL Server 2005 Analysis Services 的特定实例重新创建这些数据库对象。源数据库将保持不变且不会被修改。

有关迁移到 SQL Server 2005 Analysis Services 的详细信息，请参阅迁移现有 Analysis Services 数据库和如何迁移 Analysis Services 数据库。

迁移数据库之后，必须从原始数据源处理这些数据库，然后才能对其运行查询。有关详细信息，请参阅处理 Analysis Services 对象。

请参阅

概念

安装 SQL Server Analysis Services

其他资源

升级 SQL Server 组件


迁移现有 Analysis Services 数据库

迁移现有 Analysis Services 数据库 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级或迁移 Analysis Services >

您可以使用 Analysis Services 迁移向导将 Microsoft SQL Server 2000 Analysis Services 数据库升级到 Microsoft SQL Server 2005 Analysis Services (SSAS)。在迁移期间，向导复制 SQL Server 2000 Analysis Services 数据库对象，然后在 SQL Server 2005 Analysis Services 实例上重新创建这些对象。源数据库将保持不变且不会被修改。在您验证新的数据库完全可操作后，可以手动删除旧的数据库。

最佳做法是：一次迁移一个数据库或一小批数据库，以便可以验证每个数据库对象是否按要求出现在目标服务器上，然后再迁移其他对象。使用迁移向导时，必须在源服务器和目标服务器上都运行 MSSQLServerOLAPService 服务。（如果迁移命名实例，则必须在源服务器和目标服务器上都运行 MSOLAP$instancename 服务）。

迁移数据库之后，必须从原始数据源处理这些数据库，然后才能对其运行查询。有关详细信息，请参阅处理 Analysis Services 对象。

使用迁移向导

可以从 SQL Server Management Studio 的对象浏览器中的 Analysis Services 服务器节点启动迁移向导。也可以通过在命令提示符处运行程序 MigrationWizard.exe 来启动该向导。

指定源和目标

向导中的初始“欢迎”页之后，显示“指定源和目标”页。在此页上，指定要迁移的数据库的源服务器和目标服务器。Analysis Services 的目标实例可以是本地的，也可以是远程的。如果指定的目标计算机运行 SQL Server 2005 Analysis Services 的多个实例，请使用格式 computername\instancename。

也可以选择将数据库架构保存到脚本文件，以后再通过在 SQL Server 2005 Integration Services (SSIS) 包中使用 Analysis Services 执行 DDL 任务来完成迁移。有关 Analysis Services 执行 DDL 任务的详细信息，请参阅 Analysis Services 执行 DDL 任务。

选择要迁移的数据库

向导的下一页是“选择要迁移的数据库”页，它显示所有 SQL Server 2000 Analysis Services 数据库和相应的要创建的 SQL Server 2005 Analysis Services 数据库的列表。默认情况下，所有数据库都是选中的，但是也可以清除不想迁移的任何数据库的名称旁边的复选框。

默认情况下，源数据库的名称与相应的目标数据库的名称是相同的。但是，如果在目标服务器上已经有其他数据库使用同一名称，迁移向导将为新的数据库分配一个唯一的名称。（例如，AdventureWorks 的第二个副本将命名为 AdventureWorks 1。）您可以使用向导中提供的名称，也可以在向导中键入新的名称，或在完成向导之后重命名该数据库。

有关 SQL Server 2000 Analysis Services 对象如何与 SQL Server 2005 Analysis Services 对象相对应的详细信息，请参阅 Analysis Services 数据库迁移注意事项。

注意：
迁移向导不支持 Microsoft SQL Server 7.0 Analysis Services 数据库的迁移。

验证数据库

在“验证数据库”页上，迁移向导验证要迁移的数据库的结构。验证数据库时，向导生成一个日志。若要查看日志或日志项的子集，请单击“查看日志”，然后从以下选项中进行选择：

  • 全部显示

  • 显示错误

  • 显示警告

  • 显示成功

如果发生错误，则验证停止。若要继续进行迁移，请修复导致错误的数据库，然后单击“重新启动”。

任何时候都可以通过单击“停止”来停止验证过程。向导将显示一条消息，在消息中指示尚未验证的数据库的数量。

迁移数据库

在“迁移数据库”页上，向导将 SQL Server 2000 Analysis Services 对象迁移为 SQL Server 2005 Analysis Services 格式。通过单击“停止”，然后单击“取消”，可以停止该过程并回滚整个事务。

迁移完成之后，您可以通过单击“上一步”返回向导中前面的页来更改以前所做的选择。但是，如果更改以前所做的选择，则必须重新运行迁移过程。重新运行迁移过程将会删除已经迁移的数据库。

完成向导

“完成向导”页显示已经创建的 SQL Server 2005 Analysis Services 数据库的摘要。单击“完成”即可完成向导。

迁移数据库之后，必须从原始数据源处理数据库，然后才能查询数据库。有关详细信息，请参阅处理 Analysis Services 对象。

请参阅

概念

升级或迁移 Analysis Services


Analysis Services 数据库迁移注意事项

Analysis Services 数据库迁移注意事项 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级或迁移 Analysis Services >

本文档将摘要介绍从 Microsoft SQL Server Analysis Services 的早期版本迁移到 Microsoft SQL Server 2005 Analysis Services 时最重要的一些方面。

若要查看更详细的文档，请参阅以下列表中的内容：

  • SQL Server 2005 Analysis Services 的已知升级问题

  • 迁移现有 Analysis Services 数据库

  • SQL Server 2005 中已废弃的 Analysis Services 功能

  • SQL Server 2005 中不推荐使用的 Analysis Services 功能

OLAP 迁移注意事项

自定义级别公式

赋值替换计算单元和自定义级别公式。SQL Server 2005 Analysis Services 支持计算单元，从 SQL Server 2000 Analysis Services 迁移来的计算单元作为已定义的计算单元，而自定义级别公式迁移为赋值。

在 SQL Server 2005 Analysis Services 中，计算传递随每次传递而自动加 1。因此，如果多维数据集包含自定义级别公式，请一定要验证所得结果与预期结果是否相同。

数据源视图

数据源视图是 SQL Server 2005 Analysis Services 中的新增功能。数据源视图不同于 SQL Server 2000 Analysis Services 中的多维数据集架构，因为数据源视图是源数据的逻辑表示形式，可使用这些源数据定义多个多维数据集，而 SQL Server 2000 Analysis Services 中的多维数据集架构是一种物理表示形式，表示每个多维数据集中各表之间的关系。

迁移多重层次结构的维度

多重层次结构维度的模型已从 SQL Server 2000 Analysis Services 改为 SQL Server 2005 Analysis Services。如果可能，此类层次结构将迁移为同一维度，但是也有无法迁移为同一维度的情况。在这种情况下，依赖原始名称的计算可能会失败。

SQL 语法

SQL Server 2005 Analysis Services 中声明 SQL 查询的方法已发生变化。SQL Server?2005 联机丛书中有新语法的 BNF。

架构行集更改

SQL Server 2005 Analysis Services 中扩充了许多架构行集以提供附加信息。在大多数情况下，现有行集和列的位置及含意与以前完成相同。下表列出了 SQL Server 2005 Analysis Services 中的架构行集更改。

架构 | 列 | 更改
DBSCHEMA_TABLES_INFO | 全部 | 不再支持此架构。
MDSCHEMA_CELL_FORMULAS | 全部 | 不再支持此架构。
MDSCHEMA_DIMENSIONS | DIMENSION_CARDINALITY | 此列返回维度键属性成员的数目。
MDSCHEMA_MEMBERS | LEVELS_LIST | 此架构列为空。
MDSCHEMA_MEMBERS | MEMBER_ORDINAL | 此列已不推荐使用。返回的将是值 0 而不是成员序号。

唯一成员名称

SQL Server 2005 Analysis Services 中的唯一成员名称与 SQL Server 2000 Analysis Services 中的唯一成员名称不同。由于对成员唯一名称的限制，当使用原始唯一名称在成员架构中进行检索时，其返回的结果可能与 SQL Server 2000 Analysis Services 中返回的结果不同。

数据挖掘迁移注意事项

迁移向导会将所有挖掘模型从 SQL Server 2000 Analysis Services 数据库传输到目标 SQL Server 2005 Analysis Services 数据库。对于源数据库中的每个挖掘模型，迁移向导会在目标数据库中创建一个新的挖掘结构。挖掘结构只包含一个模型，并且该模型的名称与源数据库中挖掘模型的名称相同。

若要将各个挖掘模型从 SQL Server 2000 Analysis Services 迁移到 SQL Server 2005 Analysis Services 的某个实例，可以使用预测模型标记语言 (PMML) 来完成。

若要检索 SQL Server 2000 Analysis Services 挖掘模型的 PMML，请运行以下语句：

SELECT * FROM [Model_Name].PMML

检索 OLE?DB 架构 DMSCHEMA_MINING_MODEL_XML，也可以获取这一信息。

检索 PMML 之后，使用类似于下面的语句，可以将 PMML 用于在 SQL Server 2005 Analysis Services 的实例中创建新的挖掘模型：

CREATE MINING MODEL [Model_Name] FROM PMML ‘pmml here’

如果使用 Analysis Services 迁移向导迁移挖掘模型，请注意该向导仅支持对元数据的迁移。因此，已迁移的挖掘模型是未经处理的。但是，这些模型仍包含原始数据绑定，因此，迁移完成后，可以在 SQL Server 2005 Analysis Services 中处理它们。另一方面，如果使用 PMML 来迁移模型，则原始数据绑定不会被保留。因此，无法重新处理已迁移的模型。尽管如此，这些模型仍可供使用，因为 PMML 包含源模型所发现的模式和走向。

已知的数据挖掘迁移问题：

  • 无法迁移具有多个事例级别键，且其中的多个键在嵌套表中的挖掘模型。

  • 无法迁移使用聚合数据挖掘提供程序创建的挖掘模型。

了解 Microsoft SQL Server 2005 Analysis Services 对象

下表介绍 SQL Server 2000 Analysis Services 对象与 SQL Server 2005 Analysis Services 对象的对应情况。

SQL Server 2000 Analysis Services 对象 | SQL Server 2005 Analysis Services 对象 | 其他信息
聚合 | 聚合 | 仅迁移混合 OLAP (HOLAP) 与多维 OLAP (MOLAP) 分区的聚合。
Analysis Services 数据库 | Analysis Services 数据库 | 无
命令 | MDX 脚本 | 多维表达式 (MDX) 脚本是为包含命令集合的对象编写的。
多维数据集 | 多维数据集 | 还为共享同一数据源的所有维度、虚拟维度和多维数据集创建一个数据源视图。然后为每个挖掘模型和数据挖掘维度创建一个数据源视图。
多维数据集和数据库角色命令 | 不迁移 | 无
多维数据集角色 | 多维数据集权限 | 不迁移维度和单元权限。
数据挖掘维度 | 数据挖掘维度 | 还为每个数据挖掘维度创建一个数据源视图。
数据源 | 数据源 | 无
数据库角色 | 数据库角色和数据库权限 | 无
维度 | 具有单一层次结构的维度 | 无
共享同一名称前缀的维度（代表多个层次结构） | 单独的维度，每个维度具有单一层次结构 | 引用原始层次结构名称的 MDX 表达式不再有效。
层次结构中的级别 | 维度中的属性，以及多级层次结构中的一级 | 无
链接多维数据集 | 对于此版本不迁移 | 无
某个级别的成员属性 | 某个级别的成员属性 | 无
挖掘模型 | 挖掘模型 | 在数据库中为每个挖掘模型创建一个数据源视图。
挖掘模型角色 | 迁移为两个权限：一个用于挖掘结构，另一个用于挖掘模型 | 无
一个维度中的多个父子层次结构 | 由父属性中的设置定义的单个父子层次结构 | 引用原始层次结构的 MDX 表达式不再有效。一个 SQL Server 2005 Analysis Services 维度只能有一个父子层次结构。
远程分区 | 不迁移 | 在远程分区所在的服务器得到升级之前，或包含远程分区的数据库被迁移之前，远程分区不可用。包含远程分区的数据库可以单独迁移。必须更新远程分区的定义才能识别新服务器实例的名称。
存储库 | XML 格式的对象定义语言 (ODL) 文件 | 无
虚拟多维数据集 | 链接度量值组 | 无
虚拟维度 | 源维度的层次结构 | 虚拟父子维度迁移为单独的维度，因为父子维度不能有多个层次结构。

请参阅

概念

升级或迁移 Analysis Services


升级 Reporting Services

升级 Reporting Services |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 >

可以将 Reporting Services 从 SQL Server 2000 Reporting Services 升级到 SQL Server 2005 中提供的版本。升级方式取决于安装的复杂性，是否使用了自定义扩展插件，以及是否有服务器可用性要求。

自定义安装、面向 Internet 的安装以及有正常运行时间要求的生产服务器都需要一个迁移计划，用于提前确定执行升级的最佳时间，升级报表服务器数据库的最佳方法，确认升级是否成功的验证步骤；还需要确定一个备份计划，以备因某些意外原因导致升级失败时使用。如果使用的是用于数据处理、传递、安全性或呈现的自定义扩展插件，则可能需要在升级前重新编译这些扩展插件。如果有生产服务器，则可能需要迁移安装，而不是进行就地升级。此外，还应考虑安装一个与现有的 Reporting Services 安装并行的新实例。通过这种方法，可以在删除 SQL Server 2000 实例前对安装进行彻底的测试。

从 SQL Server 2000 升级到 SQL Server 2005

使用下表可查看不同部署方案的升级选项。

初始状态 | 操作 | 升级后的状态
同一 SQL Server 2000 默认实例上的 Reporting Services 和数据库引擎。 | 运行升级程序。 选择默认实例。 | 将 Reporting Services 和数据库引擎升级到 SQL Server 2005。
作为默认实例运行的一个 SQL Server 2000 Reporting Services 实例。 作为命名实例运行的一个 SQL Server 2000 数据库引擎实例。 两个实例都在同一台计算机运行。 | 运行升级程序。 选择要升级的实例。可以分别升级每个实例。也可以一次升级所有实例。 | 单独的 Reporting Services 和数据库引擎实例升级到 SQL Server 2005。以下是有效组合： SQL Server 2005 Reporting Services 加 SQL Server 2000 数据库引擎实例。 SQL Server 2000 Reporting Services 加 SQL Server 2005 数据库引擎实例。 Reporting Services 和数据库引擎同时升级到 SQL Server 2005。

升级单个服务器安装

如果当前运行的是未经修改的默认安装，则可以通过运行一次安装程序升级整个 Reporting Services 安装。必须使用 SQL Server 数据库引擎的本地实例来承载报表服务器数据库。有关详细信息，请参阅升级 Reporting Services 的默认安装。

如果运行的是自定义安装，则可能需要迁移 Reporting Services。有关迁移和升级注意事项的详细信息，请参阅迁移 Reporting Services、如何并行安装 Reporting Services 及其早期版本、使用升级顾问来准备升级和 SQL Server 2005 Reporting Services 中的重大更改。

升级分布式服务器安装

可以将一个 Reporting Services 安装配置为在远程计算机上承载报表服务器数据库。还可将某个安装配置为在扩展部署中运行多个报表服务器。如果在远程计算机上安装报表服务器数据库，则安装程序将会自动更新架构。如果由于权限不足或连接出错导致安装程序无法更新架构，则必须手动升级报表服务器数据库。有关详细信息，请参阅升级报表服务器数据库。

可以升级报表服务器数据库，而不升级承载该数据库的数据库引擎实例。如果升级数据库引擎实例，请注意，要承载报表服务器数据库必须满足版本要求。有关版本要求的详细信息，请参阅创建报表服务器数据库。有关升级多个报表服务器实例的详细信息，请参阅升级报表服务器 Web 场。

本节内容

主题 | 说明
升级 Reporting Services 的默认安装 | 讲解如何升级现有的 Reporting Services 安装，在该安装中所有组件都配置为使用默认值。
升级报表 | 解释如何升级在前一个版本的报表设计器中创建的报表。
更新基于角色的安全性以访问报表生成器 | 解释如何修改基于角色的安全设置以使用新的即席报表生成功能。
升级报表服务器数据库 | 提供有关升级报表服务器数据库架构的信息。
升级 Reporting Services 的版本 | 描述评估版和标准版之间的功能差异。您可以升级任何版本的 Reporting Services，包括尚未过期的评估版。
升级报表服务器 Web 场 | 讲解如何升级共享单个报表服务器数据库的多个报表服务器。
迁移 Reporting Services | 说明如何升级已修改的安装，以及如何升级由安装在多个计算机上的组件组成的安装。

请参阅

任务

如何并行安装 Reporting Services 及其早期版本

概念

安装 SQL Server Reporting Services


升级 Reporting Services 的默认安装

升级 Reporting Services 的默认安装 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 Reporting Services >

在已经有了 Reporting Services 默认安装的计算机上运行安装程序时，可选择就地升级现有实例，或者安装新实例。就地升级有如下要求：

  • 用于访问报表服务器和报表管理器的虚拟目录必须使用默认配置设置。虚拟目录必须在默认的网站下创建。应用程序和内容映射、虚拟目录安全设置和权限必须具有默认值。

  • 在 machine.config 文件中未加密 ASP.NET 进程标识。加密进程标识对某些企业而言是最佳安全操作。但如果加密进程标识，SQL Server 安装程序将不能升级 Reporting Services 安装。

  • 未添加自定义扩展插件，并且报表服务器是用默认的安全扩展部署的。

上述各项将阻止升级，且在现有安装上运行升级顾问时会触发这些项。有关这些问题和纠正操作的详细信息，请参阅升级顾问产品文档。如果不选择升级，可迁移 Reporting Services 安装。有关迁移和使用升级顾问的详细信息，请参阅迁移 Reporting Services和使用升级顾问来准备升级。

升级前的检查表

使用此检查表可以使 Reporting Services 安装就绪以进行升级。

  1. 备份报表服务器数据库和配置文件。如果修改了示例文件或样式表，并且想保留修订后的版本，则还要备份它们。

  2. 备份对称密钥。

  3. 如果安装了 Reporting Services 联机丛书文档刷新，请卸载它。

  4. 在报表服务器所在的计算机上运行安装程序。安装程序检测现有的安装，并提供用于升级的选项。

升级报表服务器数据库

在升级期间，安装程序连接到安装在本地默认 SQL Server 数据库引擎实例上的报表服务器数据库，然后将现有表结构更新为新架构。将报表服务器数据库升级为新格式后，无法撤消。数据库就地进行迁移。安装程序使用 RSReportServer.config 文件中的数据库连接信息来查找报表服务器数据库并与它建立连接。

升级安装不会修改报表服务器数据库的名称或连接信息。报表服务器用于访问报表服务器数据库的帐户信息也保持不变。有关升级数据库的详细信息，请参阅升级报表服务器数据库。

升级报表服务器内容

升级报表服务器的同时会升级报表，但不会升级存储在报表服务器中的其他内容。已发布的报表和快照在安装结束时升级，所用的时间较长。升级后的订阅、计划、共享数据源和资源与升级前版本中的相同。有关对报表就地升级的详细信息，请参阅升级报表。

升级角色分配以使用新的即席报表功能

在升级过程中，不会修改角色定义和角色分配。这表示不会在已升级的安装中实施 SQL Server 2005 中引入的新任务和角色定义。若要使用新任务和新角色，必须手动更新角色和角色分配。

新的任务和角色支持即席报表功能，用户可使用此功能创建模型和使用报表生成器。在使用新的功能之前，必须更新现有角色和角色分配。有关详细信息，请参阅更新基于角色的安全性以访问报表生成器。

升级配置文件

升级后的系统中仍然使用现有安装的配置文件。在升级过程中添加并设置新的设置。不是所有的新设置在升级完成后都存在。运行 Reporting Services 配置工具时可以添加其他设置。

如果要升级到 SQL Server 2005 Service Pack 1，则不会更新配置文件更新使之包含任何新设置。Service Pack 1 安装程序不会修改配置文件。Service Pack 1 中仅添加了针对 SAP NetWeaver BI 数据处理扩展插件的新配置设置。有关如何手动配置这些设置的详细信息，请参阅Configuring Reporting Services to Use the Microsoft .NET Data Provider for SAP NetWeaver Business Intelligence。

同时升级 Reporting Services 组件

Reporting Services 包含客户端组件和服务器组件。如果升级服务器组件，则也应该升级所有相应的客户端组件。对于报表设计器尤其如此。尽管可以同时运行 SQL Server 2005 报表服务器和 SQL Server 2000 版的报表设计器，但是您可能会发现报表设计器中预览的报表与运行时呈现的报表不一致。请注意，升级报表设计器后，不能再用它向 SQL Server 2000 报表服务器发布报表。报表命名空间的不同会阻止向报表服务器的两个版本同时发布。

同时升级 SQL Server 组件

您可以选择是分别升级报表服务器和数据库引擎还是同时进行升级。下面摘要列出了如何升级组件：

  • 如果仅升级数据库引擎，则报表服务器和报表服务器数据库不受影响。升级后的数据库引擎承载由旧架构定义的现有报表服务器数据库。

  • 如果仅升级报表服务器，则安装程序会将报表服务器数据库的表结构修改为新格式。

  • 如果要升级这两个组件，则首先升级数据库引擎，然后升级报表服务器。

对于 Reporting Services 安装，仅当安装程序检测到 SQL Server 2000 版的报表服务器组件或报表设计器时，才启动升级进程。

升级过程中删除的组件

在升级过程中，安装程序会删除被 SQL Server 2005 版本中的新组件所取代的所有组件。下面列出了对将会升级或删除的组件的说明。有关如何在安装程序中选择组件的详细信息，请参阅使用安装程序安装 Reporting Services。

  • 将会升级报表服务器、报表管理器和报表服务器数据库。

  • 将会卸载报表设计器，代之以安装 Business Intelligence Development Studio。在 SQL Server 2005 中，报表设计器在 Business Intelligence Development Studio 内运行。将会卸载运行在 Visual Studio 2003 中的早期版本，并将程序文件从系统中删除。

  • 将会删除 Reporting Services 联机丛书。在新版本中，产品文档包含在 SQL Server 2005 联机丛书中。

重要事项：
如果安装了文档刷新，请确保先卸载它再升级。此步骤必须手动执行。尽管升级功能将删除文档文件，但不从“添加/删除程序”中删除程序项。

  • 将会删除示例。安装程序将安装新版本。

  • 将会删除管理命令行工具。请注意，在此版本中不再安装和使用 rsactivate.exe。

请参阅

概念

升级 Reporting Services

其他资源

Reporting Services 的向后兼容性


升级报表

升级报表 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 Reporting Services >

安装新版本的 Reporting Services 时，可升级报表定义、已发布的报表以及报表快照。SQL Server 2005 引入了对报表定义语言 (RDL) 和报表对象模型的更改，这些更改影响在早期版本的软件中创建的报表。在报表设计器中打开报表定义时，可升级打开的报表定义。已发布的报表和快照可在安装过程中升级。升级报表时，将通过以下方式修改报表：

  • 报表定义命名空间升级到 http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition。

  • Actions 元素已被修改为支持多个操作。它现在可包括多个子元素。

  • CustomReportItem 元素已被修改为支持数据绑定控件和报表处理扩展插件。该元素包含子元素，这些子元素描述报表中控件的控件、属性和维度所使用的数据。在报表设计器中升级时用于 CustomReportItem 的 XML 结构是用 HTML 编码的，在将报表发布到报表服务器的过程中，将对该 XML 结构解码。

  • Custom 元素已被包含“名称-值”对的自定义属性集合替换。升级时，Custom 元素的所有实例被映射到自定义属性集合中的自定义属性。

升级报表后，您可能注意到出现附加的错误、警告和消息。这是对内部报表对象模型和处理组件进行改进的结果，当在报表中检测到根本问题时，将导致出现这些消息。

报表定义 (.rdl) 文件和报表设计器

在 SQL Server 2005 版本的报表设计器中打开 .rdl 时，可将报表定义升级到新的命名空间。打开报表时，系统会提示您是否要升级报表定义。升级报表定义后，将无法在早期版本的报表设计器中打开该报表定义。

将在早期版本的 Reporting Services 中创建的 .rdl 文件发布或上载到 SQL Server 2005 报表服务器时，也会升级报表定义。报表将以 SQL Server 2005 版本的 RDL 发布。除非在报表设计器中打开原始文件，否则不升级原始文件。

注意：
不能将具有 SQL Server 2005 报表定义命名空间的报表发布到 SQL Server 2000 报表服务器上。

可以在同一台计算机上并行运行不同版本的报表设计器。有关详细信息，请参阅如何并行安装 Reporting Services 及其早期版本。

已发布的报表和报表快照

已发布和已存储的报表将自动升级，您不需要执行任何特定操作。在第一次使用报表时，升级报表。即当用户打开报表或报表快照时，或者当报表服务器处理订阅时，将进行升级。一旦升级了已发布的报表和快照，就不能在产品的较早版本上运行该报表或快照。

能够升级的版本

以下版本的 Reporting Services 中创建的报表可进行升级：

  • SQL Server 2000

  • 带有 Service Pack 1 的 SQL Server 2000

  • 带有 Service Pack 2 的 SQL Server 2000

  • SQL Server 2005 Beta 3

  • SQL Server 2005 产品版本到 SQL Server 2005 Service Pack 1。

请参阅

概念

升级 Reporting Services 的版本


更新基于角色的安全性以访问报表生成器

更新基于角色的安全性以访问报表生成器 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 Reporting Services >

SQL Server 2005 提供了允许用户创建模型和使用报表生成器的新任务。如果升级现有安装，安装程序将不会修改现有角色定义，以包括授予这些功能的访问权限的新任务。升级安装后，必须手动更新现有角色定义和角色分配，以包括这些新任务。以下是 SQL Server 2005 Reporting Services 中新增的任务：

名称 | 类型 | 说明
查看模型 | 项级任务 | 允许用户在文件夹层次结构中查看模型，将模型用作报表的数据源，以及对模型运行查询以检索数据。 此任务对于查看即席报表（由报表服务器自动生成）和使用报表生成器是必需的。
管理模型 | 项级任务 | 允许用户创建、查看和删除模型，以及查看和修改模型属性。能够执行此任务的用户还有权分配模型项安全性，并将预定义的静态报表映射为模型部件。
使用报表 | 项级任务 | 允许用户将已发布的报表从报表服务器加载到本地报表生成器实例。可执行此任务的用户可以打开和编辑基于模型的已发布报表。
执行报表定义 | 系统级任务 | 允许用户处理当前未存储在报表服务器中的报表定义。 在 Reporting Services 包含的工具中，此任务用于访问报表生成器。执行此任务的用户可以单击报表管理器中的“报表生成器”按钮，以启动报表生成器。 以编程方式使用时，此任务可支持范围更广的实施。能够执行此任务的用户有权处理未发布的报表定义 (.rdl) 文件。
浏览模型 | 模型项任务 | 允许用户查看模型的一部分。可以使用此任务指定用户或组可以看到模型的哪些部分。

SQL Server 2005 Reporting Services 的新安装包括名为“报表生成器”的新角色定义。此角色定义了使用报表生成器所需的任务的集合。升级现有安装时系统不会为您创建报表生成器角色。不过，如果您希望获得可在新 Reporting Services 安装中使用的一整套角色定义，那么可以手动创建角色定义。

如何更新现有项级角色定义

如果使用预定义的角色定义，则可以编辑这些定义以包括新的任务。向现有角色定义中添加新任务是对当前用户授予查看和管理报表生成器报表和模型的权限的最简单方法。向现有角色定义中添加新任务时，包含该角色定义的所有角色分配都将自动获得新任务。

  1. 查找在报表服务器中定义的角色定义。在 Management Studio 中，角色定义位于“角色”文件夹中的“安全性”节点下。在报表管理器中，打开“站点设置”页，然后单击“配置项级角色定义”。

  2. 展开“浏览者”角色定义。将“查看模型”任务添加到该角色，然后单击“确定”。

  3. 展开“内容管理员”角色定义。添加“管理模型”、“查看模型”和“使用报表”以授予对模型的完全权限以及在报表生成器中创建和修改报表的能力。单击“确定”。

  4. 展开“发布者”角色定义。添加“管理模型”以授予创建、查看和删除报表服务器中的模型的权限。单击“确定”。

如何更新现有系统级角色定义

若要使用户能使用报表生成器，必须将任务添加到系统级角色。

  1. 在 Management Studio 中，展开“系统角色”文件夹。在报表管理器中，打开“站点设置”页，然后单击“配置系统级角色定义”。

  2. 展开“系统管理员”角色定义。添加“执行报表定义”任务。单击“确定”。

  3. 展开“系统用户”角色定义。添加“执行报表定义”任务。单击“确定”。

创建新的报表生成器角色定义

SQL Server 2005 Reporting Services 的新安装包括一个新角色定义，该角色可将用于使用报表生成器的一组任务组织到单个任务集合中。如果是升级现有安装，则必须手动创建此角色定义。创建单独的角色定义可确保报表生成器用户只拥有创建即席报表所需的任务。

  1. 使用 Management Studio 或报表管理器创建新的角色定义。有关详细信息，请参阅如何创建、删除或修改角色（报表管理器）或如何创建、删除或修改角色 (Management Studio)。

  2. 命名角色报表生成器。

  3. 添加下列任务：使用报表、查看报表、查看模型、查看资源、查看文件夹和管理单独的订阅。

  4. 保存角色定义。

使用新报表生成器角色定义的提示

如果使用本主题前面提供的说明修改了现有角色定义，则只有映射为“内容管理员”的用户才有足够的权限使用报表生成器创建和保存报表。若要使用户能够使用报表生成器功能，则必须创建或修改将组或用户帐户映射到刚创建的报表生成器角色的角色分配。

  • 如果可能，创建包含需要访问报表生成器的所有用户的域组帐户。如果您有组帐户，则可以为所有用户创建一个角色分配。

  • 如果不能创建组帐户，则可以创建将特定用户帐户映射到角色定义的角色分配。如果已经具有针对特定用户的现有角色定义，则可以对其进行修改以包括新的角色定义。有关详细信息，请参阅创建、修改和删除角色分配。

  • 可以编写一个创建角色分配的脚本，并在报表服务器上运行。有关详细信息，请参阅脚本示例 (Reporting Services)。

请参阅

其他资源

“浏览者”角色
“内容管理员”角色
“发布者”角色
“系统管理员”角色
“系统用户”角色
“报表生成者”角色
保护报表生成器
保护模型


升级报表服务器数据库

升级报表服务器数据库 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 Reporting Services >

报表服务器数据库架构可能会因为推出新的 Reporting Services 版本而有所变化。本主题解释如何升级数据库架构以使用最新格式。请注意，一旦升级了架构，就无法将升级内容回滚到以前的版本。请务必在升级前备份报表服务器数据库，以备需要重新创建以前安装时使用。

注意：
可以升级 SQL Server 2000 数据库引擎实例上运行的报表服务器数据库，而无需将数据库引擎升级为 SQL Server 2005。还可以将 SQL Server 2000 数据库引擎实例用于承载为 SQL Server 2005 Reporting Services 安装新建的报表服务器数据库。

升级报表服务器数据库需分三个步骤：

  1. 在安装过程中自动升级架构，或者通过 Reporting Services 配置工具手动升级架构。

  2. 升级架构后，首次使用报表服务器数据库时，升级元数据和安全性说明。

  3. 首次使用时，升级已发布报表和已编译报表快照。有关详细信息，请参阅升级报表。

除了报表服务器数据库外，报表服务器还会使用临时数据库。升级报表服务器数据库时，会自动升级临时数据库。

如何升级报表服务器数据库

可以自动或手动升级报表服务器数据库。

  • 如果运行的是默认配置，并且报表服务器数据库安装在本地，则安装程序将自动升级报表服务器数据库。

  • 从命令提示符运行安装程序时，安装程序也可以自动升级报表服务器数据库。如果报表服务器数据库安装在远程 SQL Server 实例上，或者运行在同一台计算机上的不同命名实例上，则可从命令提示符运行安装程序，并使用 RSUPGRADEDATABASEACCOUNT 和 RSUPGRADEPASSWORD 参数指定有权更新架构的凭据。

  • 不管报表服务器数据库运行在本地服务器上还是远程服务器上，都可以进行手动升级。若要手动升级报表服务器数据库，请使用 Reporting Services 配置工具。“数据库安装”页上有一个升级选项，可以运行脚本将架构更新为最新版本。

升级远程服务器上的报表服务器数据库

如果要升级的 Reporting Services 安装包含远程报表服务器数据库，则可能会在升级数据库架构时遇到一些问题。默认情况下，安装程序会使用运行安装程序的用户的安全令牌连接到远程 SQL Server 实例，然后更新架构。如果您对本地和远程计算机上都有管理员权限，则将成功升级数据库。同样，如果从命令提示符运行安装程序，并为有权修改远程计算机上的架构的帐户指定 RSUPGRADEDATABASEACCOUNT 和 RSUPGRADEPASSWORD 参数，也将成功升级数据库。但是，如果您无权更新远程计算机上的架构，则系统将拒绝连接，并出现以下错误：

“安装程序无法升级报表服务器数据库架构。必须在安装完成后手动更新数据库架构。若要更新架构，请运行 Reporting Services 配置工具，再打开“数据库安装”页，然后单击“升级”。有关详细信息，请参阅 Microsoft 知识库文章 91310。”

报表服务器程序文件将被升级，但报表服务器数据库将使用以前版本的格式。如果报表服务器数据库使用了较旧的格式，则报表服务器将不可用。

手动升级数据库

如果安装程序没有自动升级报表服务器数据库，则只能升级部分报表服务器安装。若要完全升级，必须在安装完成后运行 Reporting Services 配置工具，手动升级报表服务器数据库。

  1. 运行 Reporting Services 配置工具，并连接到刚升级的报表服务器。有关如何启动该工具和连接到服务器的详细信息，请参阅如何启动 Reporting Services 配置。

  2. 打开“数据库安装”页，然后单击“连接”，连接到承载报表服务器数据库的 SQL Server 实例。

  3. 选择要升级的报表服务器数据库。

  4. 单击“升级”，升级数据库架构。

完成上述步骤后，就可使用报表服务器了。

请参阅

任务

如何启动 Reporting Services 配置

概念

创建报表服务器数据库
升级 Reporting Services
升级 Reporting Services 的默认安装
迁移 Reporting Services


升级 Reporting Services 的版本

升级 Reporting Services 的版本 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 Reporting Services >

本主题介绍了在某些 Reporting Services 版本间升级时的要求和注意事项。本主题中讨论的升级方案如下：

  • 不同版本和版本类别的 Reporting Services 的升级路径。

  • 升级到拥有更多功能的版本（例如，从 Standard Edition 升级到 Developer Edition 或 Enterprise Edition）。

  • 升级到拥有较少功能的版本（例如，从 Evaluation Edition 升级到 Standard Edition）。

可以从具有高级服务的 SQL Server 2005 Express Edition (SQL Server Express) 升级到其他版本。有关详细信息，请参阅如何将 SQL Server Express Report Server 升级到其他版本的 SQL Server。

从 SQL Server 2000 升级

下表显示了从 SQL Server 2000 版本升级到 SQL Server 2005 Reporting Services 的可能路径。

SQL Server 2000 版本 | SQL Server 2005 版本
Evaluation | Evaluation
Standard | Standard、Developer、Enterprise
Developer | Developer
Enterprise | Enterprise

也可能存在其他升级路径（例如，从 SQL Server 2005 Developer Edition 直接升级到 SQL Server 2005 Enterprise Edition），但安装程序不会自动执行所有步骤。在这种情况下，可以安装一个想要使用的版本的新实例，然后将报表服务器数据库移到新的安装上。有关详细信息，请参阅迁移 Reporting Services。

升级 Evaluation Edition

若要升级 Evaluation Edition，必须在该版本过期前升级。如果评估副本已过期，则可按照上一步的说明安装新版本，然后将新的报表服务器实例配置为使用现有报表服务器数据库。如果软件的评估副本没有过期，则可使用安装程序，但升级必须分两步操作：

  1. 将 SQL Server 2000 Evaluation Edition 升级到 SQL Server 2005 Evaluation Edition。

  2. 将 SQL Server 2005 Evaluation Edition 升级到其他 SQL Server 2005 版本。

在 SQL Server 2005 范围内升级版本

可以在相同的 SQL Server 版本范围内升级版本类别。下表显示了 SQL Server 2005 Reporting Services 不同版本类别的升级路径。每个版本类别都必须满足各自的软件要求。如果系统不能满足新版本的最低软件要求，则升级将会失败。有关详细信息，请参阅版本升级。

SQL Server 2005 | SQL Server 2005
Evaluation | Express、Workgroup、Standard、Developer、Enterprise
Express | Workgroup、Standard、Developer、Enterprise
Workgroup | Standard、Developer、Enterprise
Standard | Developer、Enterprise
Developer | Workgroup、Standard、Enterprise

升级到功能较多的版本

如果现有的安装是 Reporting Services Standard Edition、Reporting Services Express Edition 或 Reporting Services Workgroup Edition，则可运行安装程序升级到 Developer Edition 或 Enterprise Edition。这些版本包括其他功能。在版本升级中，不会降低功能。在标准版中创建的所有报表、模型和应用程序将在升级后的版本中继续生效。

升级到功能较少的版本

如果将 Evaluation Edition 升级到 Standard Edition、Express Edition 或 Workgroup Edition，则升级后的版本将不再提供以下功能：

  • 数据驱动订阅

  • 报表服务器扩展部署

  • 自定义身份验证扩展插件

  • 支持四个以上的处理器

如果在评估版中使用了以上任何功能，请阅读以下部分，以确定升级到标准版将会对现有文件和功能产生的影响。有关 Express Edition 提供的功能的详细信息，请参阅 SQL Server 联机丛书中的Reporting Services in SQL Server 2005 Express Edition with Advanced Services。

数据驱动订阅

数据驱动订阅将停用（即不再运行），但并不删除。必须手动删除该订阅。有关详细信息，请参阅创建、修改和删除数据驱动订阅。

报表服务器扩展部署

如果将扩展部署中的报表服务器实例升级到 Standard Edition，则升级后的节点将不再有效。若要使用升级后的报表服务器，可从以下两个选项中选择：

  • 新建报表服务器数据库。有关详细信息，请参阅创建报表服务器数据库。

  • 或者，删除在部署中为各个节点创建的密钥信息，从而修改现有报表服务器数据库。或者，也可以复制现有报表服务器数据库、附加该数据库、删除密钥信息，然后将升级后的报表服务器配置为使用该数据库。

    若要删除未用的密钥，请使用 Reporting Services 配置工具中的“初始化”页。有关详细信息，请参阅添加和删除扩展部署的加密密钥和初始化（Reporting Services 配置）。

自定义身份验证扩展插件

Standard Edition 或 SQL Server Express 不支持自定义身份验证扩展插件。如果升级到上述任何一个版本，都必须换成使用默认的 Windows 身份验证扩展插件。

自定义身份验证扩展插件还会阻止升级进程。安装程序不能升级对其部署了任何类型自定义扩展插件的报表服务器。若要使用新版本，必须将报表服务器数据库迁移到新安装的系统中。有关详细信息，请参阅升级顾问文档和迁移 Reporting Services。

支持四个以上的处理器

安装程序不会将在超过四个处理器上运行的现有安装版本升级为标准版。必须安装一个新的实例，然后迁移安装。

请参阅

概念

升级 Reporting Services 的版本
升级报表服务器 Web 场

更改历史记录

版本 历史记录

2006 年 4 月 14 日

新增内容：
  • 具有高级服务的 SQL Server 2005 Express Edition


升级报表服务器 Web 场

升级报表服务器 Web 场 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 Reporting Services >

本主题解释如何升级共享同一个报表服务器数据库的多个报表服务器实例。在早期版本中，此部署模型称为“报表服务器 Web 场”。该术语今后不再使用。共享单个数据库的各报表服务器称为报表服务器扩展部署。可以在服务器群集上运行扩展部署。配置扩展部署的报表服务器节点是运行扩展部署的必备条件。如果已在扩展部署中部署了 Reporting Services，则必须升级扩展部署中的每个报表服务器。如果对报表服务器数据库架构进行更改，则将无法配置包含不同版本的 Reporting Services 的扩展部署。

可以使用以下方法升级扩展部署：

  • 执行就地升级，用新的版本替换现有安装。可以按任意顺序升级节点。报表服务器数据库在第一次升级时更新。应该先使服务器脱机，直到所有报表服务器节点和数据库均已升级为止（即停止 IIS 和报表服务器 Windows 服务）。开始升级服务器后，就需要升级所有节点。否则，其余报表服务器节点将不能工作，直到这些节点升级为使用新的数据库格式为止。

  • 执行并行升级，在包含现有安装的计算机上安装新的 SQL Server 2005 Reporting Services 实例。如果有时间要求，或安装不符合就地升级的要求，则可安装与现有安装一起运行的 SQL Server 2005 Reporting Services 新实例。在配置和测试新软件时，用户可以继续使用现有的扩展部署。

准备升级

请使用以下检查表准备升级：

  1. 备份报表服务器数据库和对称密钥。

  2. 验证连接到承载报表服务器数据库的 SQL Server 数据库引擎时所用的用户帐户和密码。该帐户必须具有本地管理员权限才能执行升级。

  3. 备份每个报表服务器实例上的所有配置文件（包括 Machine.config 和 Web.config 文件）。

  4. 备份日志文件。

  5. 先在测试服务器上执行升级，以便了解升级生产服务器时会出现的情况。

  6. 如果使用了 Microsoft Windows 网络负载平衡，则可设置宿主优先级别，将节点与新连接分离。此步骤可最大程度地降低对现有用户会话的影响。

    1. 登录到每台计算机。

    2. 在第一台计算机上启动网络负载平衡管理器，并打开宿主列表。

    3. 在宿主优先级中，记录每个节点的优先级别。使用优先级别确定节点的升级顺序。先升级优先级最低的节点。

    4. 在优先级最低的节点上，右键单击宿主名称，选择“控件宿主”，然后单击“停止”。这样一来，所有新的连接将被传送到其他节点。现有会话将继续运行。如果可能，请在开始升级之前停止新连接若干小时，以便最大程度地减少打开会话的数量。

    5. 关闭网络负载平衡管理器（如果已打开）。关闭其他任何打开的 MMC 管理单元。

如何升级到 SQL Server 2005 Report Server 扩展部署

以下步骤假设要安装一个与现有安装并行的新实例。如果要执行就地升级，则可按安装 Service Pack 1 的说明进行操作。

  1. 停止 Windows Management Instrumentation (WMI) 服务。

  2. 停止报表服务器 Windows 服务。

  3. 重置 Internet 信息服务 (IIS)。

  4. 停止 IIS。

  5. 运行安装程序。在“实例名称”中，验证是否选择了默认实例（在 SQL Server 2000 中，Reporting Services 只作为默认实例运行）。

  6. 安装完成后，查看程序文件的时间戳信息，验证是否成功复制了文件。

  7. 启动报表服务器 Windows 服务。

  8. 打开 reportserverservice.log 文件，搜索“操作已成功完成”条目。此条目可确认升级已成功。

  9. 启动 IIS。

  10. 打开浏览器窗口，键入报表服务器 URL。验证页面底部的版本信息是否反映了产品版本。

  11. 启动 WMI 服务。

如何升级 Service Pack 1

应用 Service Pack 1 时，将在现有 SQL Server 2005 安装上运行软件包。如果要将 SQL Server 2005 扩展部署升级到 Service Pack 1，必须将 Service Pack 应用于每个节点。升级第一个节点时，会升级报表服务器数据库；因此，请确保在升级完所有节点之前，让其他所有节点脱机。使用下列步骤执行就地升级，将报表服务器节点升级到 Service Pack 1。

  1. 选择最先升级的节点。让其他所有节点脱机。

  2. 停止 Windows Management Instrumentation (WMI) 服务、报表服务器 Windows 服务以及要升级的安装中包含的其他任何 SQL Server 服务。

  3. 重置 Internet 信息服务 (IIS)，然后停止该服务。

  4. 运行安装 Service Pack 1 的软件包。如果计算机有多个实例，请确保选择的是运行 Reporting Services 的实例。如果报表服务器数据库在远程计算机上，则系统将会提示您指定具有报表服务器数据库升级权限的凭据。

  5. 升级完成后，查看程序文件的时间戳信息，验证是否成功复制了文件。

  6. 启动报表服务器 Windows 服务。

  7. 打开 ReportServerService_<timestamp>.log 文件，搜索“操作已成功完成”信息。此条目可确认升级已成功。

  8. 启动 IIS。

  9. 打开浏览器窗口，键入报表服务器 URL（默认情况下，该值为 http://localhost/reportserver）。验证页面底部的版本信息是否反映了您预期的产品版本。

  10. 启动 WMI 服务。

为扩展部署中的其他节点重复以上步骤。

请参阅

概念

升级 Reporting Services 的版本
升级 Reporting Services 的版本
升级 Reporting Services 的版本
配置报表服务器扩展部署


迁移 Reporting Services

迁移 Reporting Services |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 Reporting Services >

本主题提供了将 SQL Server 2000 Reporting Services 部署迁移到新的 SQL Server 2005 Reporting Services 实例的分步说明。如果存在阻止升级的程序、大规模部署或紧急需求，或者要更改硬件或安装的拓扑结构，迁移安装是个不错的办法。Reporting Services 的迁移过程包括手动步骤和自动步骤。报表服务器迁移包括以下任务：

  • 安装一个与现有 SQL Server 2000 安装并行的新 SQL Server 2005 实例。由于 SQL Server 2000 Reporting Services 总是以默认 SQL Server 实例运行，所以必须将安装的新 SQL Server 2005 实例配置为命名实例。

  • 将 SQL Server 2000 安装中的报表服务器数据库复制到新的 SQL Server 2005 安装中。

  • 确认新实例完全正常运行后，卸载 SQL Server 2000 Reporting Services。

请注意，如果您要重新使用在以前的安装中创建的现有报表服务器数据库，用于承载报表服务器数据库的 SQL Server 是有版本限制的。有关详细信息，请参阅创建报表服务器数据库。

备份文件和数据

在安装新的 Reporting Services 实例之前，请确定备份了当前安装中的所有文件。

  1. 备份报表服务器数据库的对称密钥。使用 rskeymgmt 实用工具来执行此操作。

  2. 使用任一支持备份 SQL Server 数据库的方法来备份报表服务器数据库。

  3. 备份报表服务器配置文件。要备份的文件包括：

    1. Rsreportserver.config

    2. Rswebapplication.config

    3. Rssvrpolicy.config

    4. Rsmgrpolicy.config

    5. Reportingservicesservice.exe.config

    6. 报表服务器和报表管理器 ASP.NET 应用程序的 Web.config 文件。

    7. ASP.NET. 的 Machine.config

  4. 备份报表服务器的虚拟目录设置。使用 Internet 服务信息管理器备份该设置。

  5. 为了提高报表服务器的可用性，将报表服务器数据库设置为只读，并对 SQL Server 数据库引擎修改 RSExec 角色以停止报表服务器数据库中的事务。

安装 SQL Server 2005 Reporting Services

  1. 运行 SQL Server 2005 安装程序安装新的 Reporting Services 实例。

  2. 在“要安装的组件”页上，选择“Reporting Services”。如果希望在同一台计算机上安装新的数据库引擎实例和报表设计器，则还可以选择“SQL Server Database Services”以及“工作站组件、联机丛书和开发工具”。

  3. 在“实例名”中，为要安装的 SQL Server 2005 实例键入一个新名称。不要指定默认实例。如果指定默认实例，则将对现有安装执行就地升级，而不是创建一个新的报告服务器实例。

  4. 在“服务帐户”中，为报表服务器 Windows 服务指定一个服务帐户。有关服务帐户的详细信息，请参阅Setting Up Windows Service Accounts

    或者，在安装结束后启动服务时，选择“SQL Server Agent”（必须运行 SQL Server Agent 以支持计划操作）。

  5. 在“报表服务器安装选项”中，选择“安装但不配置服务器”选项。通过选择该选项，可以在完成安装后再配置报表服务器。

  6. 完成安装。

  7. 如果应用的是 Service Pack 1，请停止所有 SQL Server 2005 服务（包括报表服务器 Windows 服务、SQL Server Agent、SQL Server Browser 和 SQL Server Fulltext Search）。

  8. 应用 Service Pack 1，然后重新启动各项服务。

  9. 将从 SQL Server 2000 安装下备份的报表服务器数据库复制、附加或还原到新实例上。必须同时提供报表服务器数据库和临时数据库。

    如果使用的是新的 SQL Server 2005 数据库引擎实例，则可用 SQL Server Management Studio 来完成此操作。如果是使用 SQL Server 2000 承载报表服务器数据库，则可为新安装创建一个数据库副本。

  10. 将 SQL Server 2000 安装所用的 rsreportserver.config 中的设置复制到新的 SQL Server 2005 安装的 rsreportserver.config 文件中：

    1. 复制 InstallationID 条目。如果要避免在报表服务器数据库的键表中出现两个未用的条目，则必须复制安装 ID。这两个未用行都是 SQL Server 2000 实例的安装标识符。未用行是不完整的，每一行缺少的是机器名和实例名。机器名和实例名对于 SQL Server 2000 实例来说都是未定义的，因此报表服务器数据库升级后，键表中的这些栏没有值。请注意，如果一个条目缺少机器名或实例名，就无法在 Reporting Services 配置工具中将其删除。但是，您可以编辑键表以删除这些行，或添加缺少的机器名和实例名。也可将未用的条目留在表中，这些未用的条目对报表服务器操作没有任何影响。

    2. 复制要在新安装中使用的其他任何自定义设置。如果要在安装中使用自定义扩展插件，那么，在使用这些插件之前，可能需要将其重新编译。有关详细信息，请参阅升级顾问产品文档。

    如果有自定义跟踪设置，请将这些条目复制到新安装的 Web.config 或 Machine.config 文件中。

配置报表服务器

  1. 启动 Reporting Services 配置工具，然后连接到刚安装的 SQL Server 2005 报表服务器实例。

  2. 创建报表服务器和报表管理器的虚拟目录。虚拟目录名称必须是唯一的，因此，如果在 SQL Server 2000 Reporting Services 安装中使用了默认名称，则必须为 SQL Server 2005 安装选择非默认名称。

    创建报表服务器虚拟目录时，应该会自动配置 Web 服务标识。如果配置不正确，则可创建一个新的应用程序池用于运行服务。

    报表服务器 Windows 服务应该会在安装过程中自动配置。如果要用其他帐户运行该服务，则可现在就修改其配置。有关服务帐户的详细信息，请参阅 SQL Server 联机丛书中的Setting Up Windows Service AccountsReporting Services 部署中的帐户。

  3. 在“服务器状态”页上，单击“停止”以停止报表服务器 Windows 服务。此步骤非常重要。如果不停止该服务，数据库升级操作就可能会在完全更新架构之前超时，从而将数据库停留在中间状态。

  4. 在“数据库安装”页的“服务器名称”中，选择用于承载要升级的报表服务器数据库的 SQL Server 实例，然后单击 “连接”。

  5. 选择要在 SQL Server 2005 安装中使用的报表服务器数据库。

  6. 单击“升级”。报表服务器数据库和临时数据库都将升级为新架构。

  7. 指定将报表服务器连接到报表服务器数据库的帐户。

  8. 在“加密密钥”页中，还原在报表服务器数据库中对内容进行加密和解密时所用的密钥。这是本主题“备份文件和数据”部分步骤 1 中备份的加密密钥。

  9. 打开浏览器，并在 URL 地址中键入报表服务器虚拟目录和报表管理虚拟目录，对它们进行测试。为该实例指定的 URL 和数据库连接信息必须包括实例名。

  10. 测试报表，并验证它们是否包含所需的数据。检查数据源信息，查看是否仍指定了数据源连接信息。

  11. 卸载 SQL Server 2000 Reporting Services。

  12. 将虚拟目录重命名为早期安装的版本中使用的名称。如果使用了自定义虚拟目录设置，请更新创建的虚拟目录，以便使用新值。

请参阅

概念

升级 Reporting Services

其他资源

报表服务器数据库
Reporting Services 的向后兼容性
Reporting Services 配置工具


如何将 SQL Server Express Report Server 升级到其他版本的 SQL Server

如何将 SQL Server Express Report Server 升级到其他版本的 SQL Server |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 Reporting Services >

具有高级服务的 SQL Server 2005 Express Edition (SQL Server Express) 包含 Reporting Services 功能的一个子集。若要使用更多功能，必须升级到其他版本。可以将 SQL Server Express 升级到 SQL Server 2005 Reporting Services 的 Standard Edition、Developer Edition、Enterprise Edition 或 Workgroup Edition。并非每个版本都提供所有 Reporting Services 功能。如果是因为要使用某个特定功能而升级 SQL Server Express，请验证该版本是否支持此功能。有关详细信息，请参阅 SQL Server 2005 的各种版本所支持的功能。

Reporting Services 的 Express Edition 基于 SQL Server 2005 Service Pack 1，因此 Express Edition 的版本比其他 SQL Server 2005 版本中提供的 Reporting Services 版本要新。Express Edition 包含 Service Pack 1 中的增强性能，并使用 Service Pack 1 版本的报表服务器数据库架构。从 Express Edition 升级到 SQL Server 其他版本时，报表服务器数据库架构将保留 Service Pack 1 格式，不会在升级过程中进行修改。若要在升级后的安装中使用 SQL Server Express 的报表服务器数据库，必须应用 Service Pack 1 以避免报表服务器和报表服务器数据库之间出现兼容性问题。

Reporting Services 对承载报表服务器数据库的 SQL Server 数据库引擎有版本要求。报表服务器升级后，可能无法再使用 SQL Server Express 来承载报表服务器数据库。此时，可以转而选择其他 SQL Server 数据库引擎实例，也可以将 SQL Server Express 的数据库引擎实例升级到兼容的版本。只能使用对正在使用的服务器版本有效的本地或远程的 SQL Server 2000 或 SQL Server 2005 数据库引擎实例。有关报表服务器数据库版本要求的详细信息，请参阅创建报表服务器数据库。

若要升级安装，必须使用 SKUUPGRADE=1 参数。可以在启动 SQL Server 安装向导时指定此参数。或者，也可以从命令提示符运行安装程序，并在命令行中包括 SKUUPGRADE=1 参数。

为了简化升级并尽量减少安装完成后的配置步骤，应该同时升级 Reporting Services 和数据库引擎。如果选择只升级 Reporting Services，则必须将报表服务器数据库附加到要使用的数据库引擎实例，然后配置报表服务器以使用该数据库。

以下示例说明了在同一操作中升级 Reporting Services 和数据库引擎的命令行：

复制代码
start /wait setup.exe ADDLOCAL=SQL_Engine,RS_Server PIDKEY=ABCDE12345FGHIJ67890KLMNO INSTANCENAME=SQLEXPRESS UPGRADE=SQL_Engine,RS_Server SKUUPGRADE=1 /qb

此示例假设运行安装程序的文件夹包含要升级的版本的 Setup.exe 程序文件（不运行 SQL Server Express 安装程序来升级到其他版本）。此示例中的 PIDKEY 是虚构的，实际的值必须对要升级的版本有效的值。有关如何从命令提示符运行安装程序的详细信息，请参阅如何从命令提示符安装 SQL Server 2005。

升级完成后，必须应用 Service Pack 1。否则，将会出现数据库兼容错误消息。

请注意，一旦开始升级 SQL Server Express 安装，则在所有步骤完成之前，报表服务器和内容将不再可用。

升级 SQL Server Express 安装

  1. 备份报表服务器数据库和报表服务器临时数据库。默认情况下，这两个数据库的名称分别为 reportserver$SQLExpress 和 reportserverTempDB$SQLExpress。

  2. 备份 RSReportServer.config 文件。如果修改了其他配置文件（如 Web.config 或 RSWebApplication.config），则应将这些文件备份。

  3. 使用 Reporting Services 配置工具中的“加密密钥”页备份加密密钥。有关详细信息，请参阅备份和还原加密密钥。

  4. 使用 SKUUPGRADE=1 参数运行安装程序。

    若要从命令行以无人参与模式运行安装程序，请使用类似以下示例的语法。请注意，PIDKEY 是虚构的；请确保使用对要安装的版本有效的 PIDKEY 将其替换。

    复制代码
    start /wait setup.exe ADDLOCAL=SQL_Engine,RS_Server PIDKEY=ABCDE12345FGHIJ67890KLMNO INSTANCENAME=SQLEXPRESS UPGRADE=SQL_Engine,RS_Server SKUUPGRADE=1 /qb

    运行 SQL Server 安装向导：

    1. 打开命令提示符，导航到包含安装介质的目录或驱动器，然后在命令行中指定 setup.exe SKUUPGRADE=1（例如 d:\setup.exe SKUUPGRADE=1）.

    2. 在“注册信息”页中，输入用于注册 SQL Server 副本的标识信息。

    3. 在“要安装的组件”页中，选择“Database Services”、“Reporting Services”和“工作站组件、联机丛书和开发工具”。

    4. 在“实例名称”页中，单击“命名实例”，然后选择要升级的 SQLEXPRESS 实例。

    5. 指定其余向导页中的选项，完成此向导。

  5. 安装完成后，应用 Service Pack 1。

若要验证升级是否成功，请打开“报表管理器”。此时，应该可以查看先前创建的所有报表。如果尚未更改虚拟目录，则用于访问升级后的安装中的报表管理器的 URL 与在 Express 安装中使用的 URL 相同。

除非重新命名，否则升级后的安装将继续使用原始安装中的名称。如果使用了默认的 SQL Server Express 名称，则升级后的 SQL Server 实例名称将继续使用 <servername>\SQLExpress。对于数据库，默认名称将继续使用 reportserver$sqlexpress 和 reportservertempdb$sqlexpress。对于 Reporting Services URL，默认名称仍为 http://<servername>/reports$SQLExpress 和 http://<servername>/reportserver$SQLExpress。若要避免混淆，可以注册 SQL Server 实例，并重新命名数据库和虚拟目录。有关详细信息，请参阅 SQL Server 联机丛书中的Registering Servers、配置报表服务器虚拟目录和Renaming a Report Server Database。

除查看现有报表服务器内容外，应该还可以创建订阅和计划操作，并可以使用已安装版本中可用的其他功能。OYZW有关如何创建订阅和计划的详细信息，请参阅Report Manager How-to Topics.如果报表服务器升级未成功或可能尚未完成，则可以改为迁移安装。有关详细信息，请参阅迁移 Reporting Services。

可以在命令行指定客户端组件来升级 SQL Server Management Studio 和 Business Intelligence Development Studio。可以通过以下操作来验证工具升级是否正确：

  • 连接到 SQL Server Management Studio 中的 Reporting Services 实例。

  • 在 Business Intelligence Development Studio 中创建其他项目类型（特别说明，在 Business Intelligence Development Studio 中创建新项目时，“报表模型”项目模板应可用）。

如果工具未正确进行升级，则可以使用“添加或删除程序”以卸载不再需要的工具，然后运行 SQL Server 安装程序以安装正在升级的版本中包含的工具。

如果正在迁移可能提供报告给其他数据库引擎数据的其他 SQL Server Express 数据库，则请确保在升级完成后更新已发布报表使用的数据源连接信息。例如，如果数据源指定 Data Source=localhost\sqlexpress，则应将其更新为 Data Source=localhost（如果将数据库迁移到本地默认实例）。

请参阅

任务

如何启动 Reporting Services 配置

概念

报表服务器安装的默认配置
升级 Reporting Services
配置报表服务器数据库连接

其他资源

管理加密密钥


升级或迁移 Data Transformation Services

升级或迁移 Data Transformation Services |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 >

注意：
有关 Microsoft SQL Server 2005 产品和技术的升级方案的一般信息，我们建议您查看版本升级。

如果您现在或以前是 Microsoft SQL Server 2000 Data Transformation Services (DTS) 的用户，则在安装 Microsoft SQL Server 2005 Integration Services (SSIS) 时可以进行如下选择：

  • 安装 SQL Server 2000 Data Transformation Services 包的支持组件

  • 将早期版本的 Data Transformation Services 升级为 SSIS

  • 将现有的 Data Transformation Services 包迁移到 SSIS

重要事项：
无论选择哪个安装选项，都应知道某些 SQL Server 2000 Data Transformation Services 特性和功能已停止使用、不推荐使用或已更改。有关详细信息，请参阅SQL Server 2005 Integration Services 的向后兼容性。

已知升级问题

由于 Integration Services 是一个全新的产品，而不是升级版本，所以升级到 Integration Services 时不会遇到软件冲突问题。但是，将 Data Transformation Services 升级到 SQL Server 2005 Integration Services 之前，我们建议您查看 SQL Server 2005 Integration Services 的向后兼容性。

升级前的检查表

将 Data Transformation Services 升级到 SQL Server 2005 Integration Services 之前，请先检查以下要求：

  • 安装 SQL Server 2005 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

  • 使用升级顾问来准备升级

安装 SQL Server 2000 Data Transformation Services 包的支持组件

可以在同一台计算机上运行 SQL Server 2000 Data Transformation Services (DTS) 包和 Integration Services 包。

如果选择安装“Integration Services”，则安装程序还将安装 SQL Server 2000 Data Transformation Services (DTS) 包的支持组件，包括 SQL Server Management Studio 中的 DTS 运行时和 DTS 包枚举。运行时支持已更新，允许 DTS 包访问 SQL Server 2005 数据源。如果未安装 Integration Services，但需要支持 DTS 包，则需要确保在“功能选择”页上选择了“早期组件”。

注意：
虽然选择安装 Integration Services 时会自动安装对 SQL Server 2000 Data Transformation Services (DTS) 的支持，但如果在安装期间或安装后将计算机中 SQL Server 2000 的上一实例升级为 SQL Server 2005，则将删除 DTS 所需的某些注册表和环境设置。若要还原这些设置，请在“控制面板”的“添加/删除程序”列表中找到“Microsoft SQL Server 2005 向后兼容性”，单击“更改”按钮，并在向导的“程序维护”页上选择“修复”选项。

安装的向后兼容性文件还包括 SQL Server 2000 Analysis Services 处理任务及其依赖项，即决策支持对象 (DSO)。但是它们不包括 SQL Server 2000 数据挖掘预测查询任务。

注意：
SQL Server 2005 不安装用于编辑 DTS 包的 DTS 包设计器。有关详细信息，请参阅 SQL Server 2005 Integration Services 的向后兼容性。

选择安装 Integration Services 时，还将安装包迁移向导。还可以使用包迁移向导将 SQL Server 2000 DTS 包升级为 Integration Services 格式。迁移过程中，该向导复制 DTS 包，然后以 Integration Services 格式重新创建这些包。源包将保持不变且不会被修改。有关详细信息，请参阅迁移 Data Transformation Services 包。

注意：
SQL Server 2005 的 Standard Edition、Enterprise Edition 和 Developer Edition 提供了包迁移向导。

有关详细信息，请参阅如何确保对 Data Transformation Services 包的支持。

将早期版本的 Data Transformation Services 升级为 Integration Services

将 SQL Server 2000 Data Transformation Services 升级为 SQL Server 2005 Integration Services 的过程包括安装 SQL Server 2005 Integration Services，还可以包括将现有 DTS 包迁移为 SQL Server 2005 Integration Services 包格式。在此过程中，除使用安装程序自身之外，还可以使用其他软件工具。

若要将 SQL Server 2000 Data Transformation Services 的实例升级到 SQL Server 2005 Integration Services，请执行以下步骤：

  1. 使用安装向导或其他安装方法来安装 SQL Server 2005 Integration Services。有关详细信息，请参阅使用安装程序安装 SQL Server Integration Services和从命令提示符安装 SQL Server Integration Services。

  2. 还可以使用包迁移向导将 SQL Server 2000 DTS 包迁移到 SQL Server 2005 Integration Services。此步骤以新的包格式重新创建包，同时原始包保持不变。选择安装 Integration Services 时，还将安装包迁移向导。有关详细信息，请参阅迁移 Data Transformation Services 包。

有关详细信息，请参阅 如何从 Data Transformation Services 升级到 Integration Services 和 SQL Server 2005 Integration Services 的向后兼容性。

将现有的 Data Transformation Services 包迁移到 Integration Services

可以选择使用包迁移向导将 SQL Server 2000 DTS 包升级为 SQL Server 2005 Integration Services 格式。迁移过程中，该向导复制 SQL Server 2000 DTS 包，然后以 SQL Server 2005 Integration Services 格式重新创建这些包。源包将保持不变且不会被修改。

选择安装 Integration Services 时，还将安装包迁移向导。

注意：
SQL Server 2005 的 Standard Edition、Enterprise Edition 和 Developer Edition 提供了包迁移向导。

有关详细信息，请参阅迁移 Data Transformation Services 包、如何将 Data Transformation Services 包迁移到 Integration Services和已知的包迁移问题。

请参阅

其他资源

升级 dtsrun 命令行


迁移 Data Transformation Services 包

迁移 Data Transformation Services 包 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级或迁移 Data Transformation Services >

SQL Server 2005 Integration Services (SSIS) 提供了多个选项用于保留使用 SQL Server 2000 Data Transformation Services (DTS) 工具和对象模型创建的解决方案。可将 DTS 包迁移为 SQL Server 2005 格式，使用 SQL Server 2000 DTS 运行时继续运行 DTS 包，或使用执行 DTS 2000 包任务将 DTS 包并入 SQL Server 2005 Integration Services 解决方案中。

当将 SQL Server 2000 DTS 包迁移为 SQL Server 2005 Integration Services 格式时，迁移的包的结构以及迁移是否完全取决于原始包的内容。

注意：
包迁移向导将保持 DTS 包不变。

迁移包可能会产生以下结果：

  • 有些包可成功地完全迁移，因为这些包所包含的任务和使用的功能都可映射为 SQL Server 2005 Integration Services (SSIS) 任务和功能。

  • 包中包含不能直接迁移到 SQL Server 2005 Integration Services (SSIS) 任务和功能的 SQL Server 2000 DTS 任务和功能，但是通过使用封装的 SQL Server 2000 包，包的功能保留下来。

注意：
在某些情况下，例如包名称包含无效字符 (/ \ : [ ] . =) 或包包含未注册的对象时，包迁移向导在这些问题解决前将无法执行迁移。

如果包中的所有任务都可映射为 SQL Server 2005 中的新任务，则迁移的包的结构与 SQL Server 2000 包的结构非常相似。相反，如果任务不能直接映射为 SQL Server 2005 任务，则迁移将更改包结构。每个不可迁移的任务将保留其 SQL Server 2000 格式，并封装在执行 DTS 2000 任务中。包中的自定义任务也以这种方式进行迁移。有关详细信息，请参阅迁移任务。

其他包元素（例如，优先约束、连接和变量）迁移为 SQL Server 2005 中的等效元素。有关详细信息，请参阅迁移优先约束、迁移连接和迁移变量。

包密码不随迁移为 SQL Server 2005 Integration Services (SSIS) 包的包一起迁移。但是，SQL Server 2005 支持 SQL Server 2000 包中和执行 DTS 2000 包任务中的包密码。SQL Server 2005 包内的执行 DTS 2000 包任务可将包密码传递给 SQL Server 2000 包。有关详细信息，请参阅迁移密码。

SQL Server 2005 中的 ActiveX 脚本任务通常能够不必另外修订即可运行从 SQL Server 2000 DTS 包中的 ActiveX 脚本迁移来的脚本代码。但是，不支持对 SQL Server 2000 DTS 包对象的引用。有关详细信息，请参阅迁移脚本。

在 DTS 设计器中输入的文本批注、包日志记录以及错误处理设置都不会迁移。

迁移包之后，应当打开所迁移的包检查有无问题，包括有无验证失败。例如，某些包依赖于同一包中先前完成的任务才能创建或准备数据源或数据目标，如果找不到这些对象，则验证可能会失败。通过将任务或其他容器对象的 DelayValidation 属性设置为 true，或将受影响的数据流组件的 ValidateExternalMetadata 属性设置为 false，可以解决此类验证失败问题。

本节的相关信息

主题 | 说明
使用包迁移向导 | 介绍包迁移向导提供的迁移过程。
已知的包迁移问题 | 列出了包迁移向导或升级顾问可标识的已知包迁移问题。
迁移任务 | 介绍包迁移向导如何迁移任务，以及迁移后可用于修复任务或增强任务行为的步骤。
迁移优先约束 | 介绍包迁移向导如何迁移优先约束，以及迁移后可用于增强优先约束行为的步骤。
迁移变量 | 介绍包迁移向导如何迁移变量，以及迁移后可用于修复或增强变量行为的步骤。
迁移连接 | 介绍包迁移向导如何迁移连接，以及迁移后可用于编辑连接属性的步骤。
迁移密码 | 介绍包迁移向导如何迁移密码，以及迁移后可用于提高安全性的其他步骤。
迁移脚本 | 介绍包迁移向导如何迁移 ActiveX 脚本。

请参阅

概念

SQL Server 2005 Integration Services 的向后兼容性

其他资源

SQL Server Integration Services (SSIS)


使用包迁移向导

使用包迁移向导 |
 | 请参阅
升级 SQL Server 组件 > 升级或迁移 Data Transformation Services > 迁移 Data Transformation Services 包 >

SQL Server 2005 Integration Services (SSIS) 提供了包迁移向导，可用于迁移使用 SQL Server 2000 工具创建的 Data Transformation Services (DTS) 包。

注意：
SQL Server 2005 的 Standard Edition、Enterprise Edition 和 Developer Edition 提供了包迁移向导。

注意：
对于保存在 SQL Server 7.0 实例的 msdb 数据库中的 DTS 包，升级顾问无法对其进行分析，包迁移向导无法对其进行迁移。但是，对于保存为结构化存储文件或保存在已升级到 SQL Server 2005 的 SQL Server 7.0 实例的 msdb 数据库中的 SQL Server 7.0 DTS 包，升级顾问可以对其进行分析，包迁移向导也可以对其进行迁移。

不是所有的包都可被完全迁移。例如，某些 SQL Server 2000 任务不映射到 Integration Services 任务，不能迁移自定义任务，也不能迁移 ActiveX 脚本任务中或数据转换中的某些脚本。有关详细信息，请参阅迁移任务和已知的包迁移问题。

留在 SQL Server 2000 包格式中的包可在 Integration Services 解决方案中使用，还可作为独立的 SQL Server 2000 包继续运行。

许多 SQL Server 2000 包受密码保护。如果您迁移这些包，则包迁移向导将提示您提供这些包的密码。如果不提供正确的密码，则不能迁移受密码保护的包。

SQL Server 2005 不安装 Meta Data Services 的支持组件。仅当在本地计算机上安装了 SQL Server 2000、SQL Server 2000 工具或存储库可再发行文件时，包迁移向导才支持 Meta Data Services（存储库）包。如果存在存储库文件，则包迁移向导可以迁移被保存到 Meta Data Services 的 DTS 包。当存储库文件不存在时，包迁移向导只能迁移保存到 SQL Server 或结构化存储文件中的 DTS 包。

启动包迁移向导

可以从以下三个位置启动包迁移向导。

  • SQL Server Management Studio。连接到 SQL Server 2005 数据库引擎 的实例，在对象资源管理器中，右键单击“管理\早期”下的 Data Transformation Services 节点，然后选择“迁移向导”。

  • Business Intelligence Development Studio。创建或打开一个 Integration Services 项目，在解决方案资源管理器中，右键单击“SSIS 包”节点，然后选择“迁移 DTS 2000 包”。

  • 命令提示符。启动 C:\Program Files\Microsoft SQL Server\90\DTS\Binn 文件夹中的 DTSMigrationWizard.exe。

选择包源

包迁移向导可迁移保存到 SQL Server msdb 数据库、结构化存储文件或 Meta Data Services 中的 SQL Server 2000 包。不能迁移保存到 Visual Basic 文件中的包。

重要事项：
SQL Server 2005 不安装 Meta Data Services 的支持组件。仅当计算机上安装了 SQL Server 2000、SQL Server 2000 工具或存储库可再发行文件时，包迁移向导才可访问保存到 Meta Data Services 中的 DTS 包。

如果包位于 msdb 数据库或 Meta Data Services 中，则用户需提供服务器名，然后包迁移向导会使用 Windows 身份验证或 SQL Server 身份验证来验证该用户的身份。

如果包位于结构化存储文件中，请选择要迁移的文件。结构化存储文件可包含多个包的定义，并可包含一个包的多个版本。可迁移该文件中的部分或全部包和包版本。

有关详细信息，请参阅选择源位置（包迁移向导）。

选择包目标

包迁移向导可将包迁移到 SQL Server 2005 实例中的 msdb 数据库，或者迁移到一个 .dtsx 文件。.dtsx 文件是保存到文件系统中的包定义的 XML 表示形式。

如果目标为 SQL Server 2005，则用户需提供服务器名，然后包迁移向导会使用 Windows 身份验证或 SQL Server 身份验证来验证该用户的身份。

有关详细信息，请参阅选择目标位置（包迁移向导）。

注意：
从 Management Studio 内迁移包后，连接到对象资源管理器中的 Integration Services 的本地实例，以查看迁移的包。如果选择 SQL Server 作为目标，可在 MSDB 节点下看到迁移的包。如果选择文件系统文件夹作为目标，请右键单击“文件系统”节点，并选择“导入包”以显示迁移的包。从 BI Development Studio 内迁移包后，迁移的包将保存到您指定的文件系统文件夹，并添加到“SSIS 包”节点下已打开的项目中。

选择要迁移的包

指定源和目标后，包迁移向导将列出 msdb 数据库、Meta Data Services 或指定的结构化存储文件中可用的包。可以选择要迁移的包，并可更新包迁移向导为该包提供的默认名称。迁移包后，还可以在 Business Intelligence Development Studio 或 SQL Server Management Studio 中更新包名称。

有关详细信息，请参阅列出包（包迁移向导）。

提供包密码

使用 SQL Server 工具的早期版本开发的包可能受密码保护。必须提供正确的密码，然后向导才能访问这些包的包定义并迁移它们。如果多个包共享一个密码，则只能提供一次该密码。直到您提供了所有受密码保护的包的密码之后，包迁移向导才能继续。如果没有受密码保护的包，则向导将跳过此步骤。

记录迁移错误

可以使包迁移向导记录在迁移过程中出现的错误。

有关详细信息，请参阅指定日志文件（包迁移向导）。

查看迁移进程

包迁移向导逐一迁移所选包。如果向导无法迁移某个包，它将提供选项以结束所有剩余包的迁移进程，或者跳过该包并继续迁移列表中的下一个包。每个包迁移后，其迁移状态都将更新。

有关详细信息，请参阅完成该向导（包迁移向导）和正在迁移包（包迁移向导）。

检查迁移的包

迁移包之后，应当在 Business Intelligence Development Studio 中打开所迁移的包，检查有无问题，包括有无验证失败。例如，某些包依赖于同一包中先前完成的任务才能创建或准备数据源或数据目标，如果找不到这些对象，则验证可能会失败。通过将任务或其他容器对象的 DelayValidation 属性设置为 true，或将受影响的数据流组件的 ValidateExternalMetadata 属性设置为 false，可以解决此类验证失败问题。

注意：
从 Management Studio 内迁移包后，连接到对象资源管理器中的 Integration Services 的本地实例，以查看迁移的包。如果选择 SQL Server 作为目标，可在 MSDB 节点下看到迁移的包。如果选择文件系统文件夹作为目标，请右键单击“文件系统”节点，并选择“导入包”以显示迁移的包。从 BI Development Studio 内迁移包后，迁移的包将保存到您指定的文件系统文件夹，并添加到“SSIS 包”节点下已打开的项目中。

请参阅

其他资源

迁移 Data Transformation Services 包

更改历史记录

版本 历史记录

2005 年 12 月 5 日

新增内容：
  • 添加了有关查找迁移包的位置的注释。

  • 添加了有关从 SQL Server 7.0 中进行迁移的支持信息。


已知的包迁移问题

已知的包迁移问题 |
 | 请参阅
升级 SQL Server 组件 > 升级或迁移 Data Transformation Services > 迁移 Data Transformation Services 包 >

这是对使用包迁移向导将 Microsoft SQL Server 2000 Data Transformation Services (DTS) 包迁移为 SQL Server 2005 Integration Services (SSIS) 格式时可能遇到的问题的摘要。

某些 SQL Server 2000 DTS 功能在 SQL Server 2005 Integration Services (SSIS) 中没有直接等效项，包迁移向导通过将这些功能封装在执行 DTS 2000 包任务中来迁移它们。尽管在很多情况下可以运行这些迁移包而不会出错，但封装在执行 DTS 2000 包任务中的早期功能最终必须被替换。

迁移这些包后，应打开所迁移的包以检查是否有问题，包括验证是否失败。例如，某些包依赖于同一包中先前完成的任务才能创建或准备数据源或数据目标，如果找不到这些对象，则验证可能会失败。通过将任务或其他容器对象的 DelayValidation 属性设置为 true，或将受影响的数据流组件的 ValidateExternalMetadata 属性设置为 false，可以解决此类验证失败问题。

已知问题

下表列出了出现在由 SQL Server 2005 升级顾问生成的报表中的各个迁移问题，以及对每个问题的简短说明。包迁移向导和升级顾问标识并报告相同的潜在包迁移问题。

问题标题 问题说明

包迁移之后重新配置事务设置

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的事务设置。迁移之后，必须手动编辑所产生的 SSIS 包，以还原以前的包行为。

纠正操作：迁移后，在 Business Intelligence Development Studio 中对包设置适当的与事务相关的属性及其组件，来重新对包创建所需的事务设置。

包迁移之后附加到包步骤上的 ActiveX 脚本的替换功能

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移与 SQL Server 2000 Data Transformation Services (DTS) 包中的步骤相关联的 ActiveX 脚本。迁移之后，必须手动编辑所产生的 SSIS 包，以还原以前的包行为。

纠正操作：迁移后，根据相应情况用新的脚本任务或其他 Integration Services 对象替换缺少的脚本。

包迁移之后在执行 DTS 2000 包任务中封装的 Analysis Services 任务的替换功能

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的 Analysis Services 任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，将封装 Analysis Services 任务的执行 DTS 2000 任务转换为 Integration Services Analysis Services 处理任务。

包迁移之后在执行 DTS 2000 包任务中封装的复杂数据转换任务的替换功能

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的复杂数据转换任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，使用 Integration Services 数据流源、转换以及目标来重写复杂数据转换任务。

包迁移之后在执行 DTS 2000 包任务中封装的自定义任务的替换功能

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的自定义任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，如果所需的功能不在某个内置 Integration Services 组件或组件的组合中，则使用脚本任务或脚本组件来重新创建自定义任务的逻辑。

包迁移之后在执行 DTS 2000 包任务中封装的数据驱动的查询任务的替换功能

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的数据驱动的查询任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，使用 Integration Services 数据流组件重新创建数据驱动的查询任务的功能。（替换数据驱动的查询任务的功能时，请考虑使用渐变维度转换、条件性拆分转换和 OLE DB 命令转换。）

包迁移之后在执行 DTS 2000 包任务中封装的数据挖掘预测查询任务的替换功能

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的数据挖掘预测查询任务。迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。SQL Server 2005 不安装对 SQL Server 2000 数据挖掘预测查询任务的支持；因此，在没有 SQL Server 2000 Analysis Services 的情况下，迁移的包在升级后将不运行。

纠正操作：迁移后，将封装数据挖掘预测查询任务的执行 DTS 2000 任务转换为 Integration Services 数据挖掘查询任务或数据挖掘查询转换。

包迁移之后动态属性任务的替换功能

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的动态属性任务。迁移之后，必须手动编辑所产生的 SSIS 包，以还原以前的包行为。

纠正操作：迁移后，使用 Integration Services 功能（例如变量、属性表达式和包配置）来重新创建动态属性任务的功能。

包迁移之后在执行 DTS 2000 包任务中封装的执行包任务（加载 Meta Data Services 包）的替换功能

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移将加载 Meta Data Services 包的执行包任务。迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。SQL Server 2005 不安装对 SQL Server 2000 Meta Data Services 的支持；因此，在没有 SQL Server 2000 客户端工具的情况下，迁移的包在升级后将不运行。

纠正操作：迁移后，将 Meta Data Services 包移到 SQL Server 存储区（位于 msdb 数据库中）或移到结构化存储文件，并且将封装执行包任务（该任务加载 Meta Data Services 包）的执行 DTS 2000 任务转换为从 SQL Server 或结构化存储文件加载包的执行 DTS 2000 任务。

包迁移之后在执行 DTS 2000 包任务中封装的并行数据抽取任务的替换功能

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的并行数据抽取任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，使用 Integration Services 数据流组件重新创建并行数据抽取任务的功能。

包迁移之后在执行 DTS 2000 包任务中封装的 UDL 连接的替换功能

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移从 Microsoft 数据链接 (.udl) 文件获得连接信息的任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，将封装 UDL 文件连接的执行 DTS 2000 任务转换为使用 Integration Services 连接管理器的等效 Integration Services 任务。

迁移包后重写访问 DTS 对象模型的 ActiveX 脚本代码

SQL Server 2005 Integration Services (SSIS) 包迁移向导不迁移通过 SQL Server 2000 Data Transformation Services (DTS) 包中 GlobalVariables 集合的 Parent 属性访问 DTS 对象模型的 ActiveX 脚本代码。迁移之后，必须手动编辑所产生的 SSIS 包，以还原以前的包行为。

纠正操作：迁移后，修改脚本代码或重写 ActiveX 脚本任务以通过其他方式从包中获取所需的信息：例如，通过使用变量。

请参阅

概念

SQL Server 2005 Integration Services 的向后兼容性


迁移任务

迁移任务 |
 | 请参阅
升级 SQL Server 组件 > 升级或迁移 Data Transformation Services > 迁移 Data Transformation Services 包 >

许多 SQL Server 2000 Data Transformation Services (DTS) 任务直接映射为 SQL Server 2005 Integration Services (SSIS) 任务，将包迁移到 SQL Server 2005 Integration Services (SSIS) 可以将 SQL Server 2000 版本的任务替换为该任务的 SQL Server 2005 Integration Services (SSIS) 等效任务。

下表列出这两种任务版本间的直接映射。

SQL Server 2000 任务 | SQL Server 2005 任务
ActiveX 脚本任务 | ActiveX 脚本任务
大容量插入任务 | 大容量插入任务
复制 SQL Server 对象任务 | 传输 SQL Server 对象任务
数据挖掘预测任务 | 数据挖掘查询任务
执行包任务 | 执行 DTS 2000 包任务
执行进程任务 | 执行进程任务
执行 SQL 任务 | 执行 SQL 任务
文件传输协议任务 | FTP 任务
消息队列任务 | 消息队列任务
发送邮件任务 | 发送邮件任务
传输数据库任务、传输错误消息任务、传输作业任务、传输登录名任务和传输主存储过程任务 | 传输 SQL Server 对象任务、传输数据库任务、传输错误消息任务、传输作业任务、传输登录名任务和传输主存储过程任务。
注意：
完成包迁移之后，尝试通过使用 GlobalVariables 集合的 Parent 属性来访问包对象模型的 ActiveX 脚本任务将失败。

某些 SQL Server 2000 任务不直接映射为 SQL Server 2005 Integration Services (SSIS) 任务：

  • Analysis Services 任务（因为 SQL Server 2005 Integration Services (SSIS) Analysis Services 任务不能与 Analysis Services 的 SQL Server 2000 实例一起运行）

  • 数据驱动的查询任务

  • 动态属性任务

  • 转换数据任务

在 SQL Server 2005 中，这些任务中的有些任务被替换为非任务功能。下表列出 SQL Server 2000 任务与等效的 SQL Server 2005 非任务功能之间的映射。

SQL Server 2000 任务 | SQL Server 2005 功能
动态属性 | 配置和属性表达式。有关详细信息，请参阅创建包配置。
转换数据 | 数据流任务和数据流元素。
数据驱动的查询 | 替换数据驱动的查询任务的功能时，请考虑使用渐变维度转换、条件性拆分转换和 OLE DB 命令转换。

自定义任务

包含自定义任务的包将以特殊方式被迁移到 SQL Server 2005。对于每个自定义任务，都创建一个 SQL Server 2000 包，然后将调用该 SQL Server 2000 包的执行 DTS 2000 包任务添加到所迁移的包中。新的 SQL Server 2000 包（称为中间包）被嵌入到进行迁移的包内，并且不单独保存。例如，具有三项自定义任务的 SQL Server 2000 包将转换成包含三项执行 DTS 2000 包任务的 SQL Server 2005 包，其中每项执行 DTS 2000 包任务指向一个封装一项自定义任务的嵌入的 SQL Server 2000 包。

数据抽取任务

有三项 SQL Server 2000 任务基于 SQL Server 2000 DTS 数据抽取，这三项任务是数据驱动的查询任务、转换数据任务和 ParallelDataPump 任务。除了简单的数据转换任务之外，这些任务都以与自定义任务相同的方式进行迁移。包迁移向导为每项任务创建新的 SQL Server 2000 包，然后将与每项数据抽取任务对应的执行 DTS 2000 包任务添加到新的包。

动态属性任务

动态属性任务不能迁移到 SQL Server 2005。如果尝试迁移具有动态属性任务的包，包迁移向导将发出警告。如果选择迁移这样的包，则在迁移后的包中将由占位符任务替换动态属性任务。占位符任务是一种脚本任务，该脚本任务列出可能要在脚本任务中转换为脚本的动态属性任务中的“属性-值”对。此信息以脚本注释的形式写入脚本任务中。

在 SQL Server 2005 中，配置可以替换和增强动态属性任务中可用的功能。有关详细信息，请参阅创建包配置。

请参阅

其他资源

迁移 Data Transformation Services 包


迁移优先约束

迁移优先约束 |
 | 请参阅
升级 SQL Server 组件 > 升级或迁移 Data Transformation Services > 迁移 Data Transformation Services 包 >

将 SQL Server 2000 Data Transformation Services (DTS) 包中的优先约束迁移到新包的 PrecedenceConstraints 集合中。

优先约束的扩展功能

迁移包后，可通过以下方法扩展优先约束：

  • 将表达式与前面可执行文件的执行结果共同使用或替换该执行结果，以指定运行受约束任务的条件。有关详细信息，请参阅将表达式添加到优先约束。

  • 结合多个优先约束以指定运行受约束任务的条件。有关详细信息，请参阅应用多个优先约束。

请参阅

其他资源

迁移 Data Transformation Services 包
优先约束


迁移变量

迁移变量 |
 | 请参阅
升级 SQL Server 组件 > 升级或迁移 Data Transformation Services > 迁移 Data Transformation Services 包 >

在 SQL Server 2005 Integration Services (SSIS) 中，所有容器都可使用 Variables 集合，这些容器包括：包、循环结构（例如 Foreach 容器）以及封装每个任务的 TaskHost 容器。迁移包时，全局变量以及来自 SQL Server 2000 DTS 任务的变量都被迁移到该包的 Variables 集合中。例如，SQL Server 2000 执行 SQL 任务使用的变量被添加到已迁移包的 Variables 集合中。

SQL Server 2005 Integration Services (SSIS) 使用命名空间来组织变量。所有 DTS 变量都迁移到 User 命名空间中。

扩展变量的功能

迁移包后，可使用以下方法向变量添加功能：

  • 创建其他命名空间，并按命名空间组织变量。

  • 使用表达式来设置变量值。

  • 指定更新变量值时是否引发事件。

有关详细信息，请参阅 Integration Services 变量和在包中使用变量。

请参阅

其他资源

迁移 Data Transformation Services 包


迁移连接

迁移连接 |
 | 请参阅
升级 SQL Server 组件 > 升级或迁移 Data Transformation Services > 迁移 Data Transformation Services 包 >

将 SQL Server 2000 Data Transformation Services (DTS) 包中的连接迁移到 SQL Server 2005，并且转换为适当连接类型的连接管理器。

连接管理器是与数据源所进行的连接的逻辑表示形式。连接管理器指定物理连接的属性，该物理连接在运行包时由运行时引擎所创建。一个迁移的包可有多个连接管理器，这些连接管理器具有相同的连接类型，但各自配置不同。有关详细信息，请参阅连接管理器。

使用连接并可毫无问题地迁移到 SQL Server 2005 的 SQL Server 2000 任务只有执行 SQL 任务。该任务的连接将作为 OLE DB 或 ODBC 连接管理器来迁移。现有连接管理器中以前未设置的所有属性在新连接管理器中被设置为默认值。有关详细信息，请参阅 OLE DB 连接管理器和 ODBC 连接管理器。

注意：
在某些情况下，SQL Server 2000 数据转换任务可与其连接一起成功地进行迁移。数据驱动的查询任务和并行数据抽取任务都被迁移到执行 DTS 2000 包任务中。有关详细信息，请参阅迁移任务和已知的包迁移问题。

在 SQL Server 2000 任务中使用但无法迁移到 SQL Server 2005 的所有连接将留在 SQL Server 2000 中间包中，该中间包是作为迁移的组成部分而创建的。例如，SQL Server 2000 转换数据任务中的连接留在封装转换数据任务的 SQL Server 2000 中间包中。

更新连接管理器的属性

连接管理器中包括设置为默认值的属性。

下表列出了这些属性。

属性 | 说明
DelayValidation | 用于指定是否将连接验证延迟到包运行时为止的值。包迁移向导将此属性设置为 False。
Description | 连接管理器的说明。包迁移向导将此属性留空。

请参阅

其他资源

迁移 Data Transformation Services 包


迁移密码

迁移密码 |
 | 请参阅
升级 SQL Server 组件 > 升级或迁移 Data Transformation Services > 迁移 Data Transformation Services 包 >

SQL Server 2005 只对与某些包保护级别选项有关的包使用密码。因此，受密码保护的包在从 SQL Server 2000 完全迁移到 SQL Server 2005 后不保留密码，尽管在迁移过程中必须提供密码。有关 SQL Server 2005 中的包保护级别的信息，请参阅设置包的保护级别。

注意：
迁移受密码保护的包时，必须提供这些包的密码，否则无法迁移。

如果安装了 SQL Server 2000 的 DTS 运行时引擎，则可以继续运行 SQL Server 2000 包。还可以将这些包包含在 SQL Server 2005 数据转换解决方案中。在这种情况下，SQL Server 2005 将继续支持包密码。例如，执行 DTS 2000 包任务包含一个密码属性，该属性用于将密码传递给 SQL Server 2000 包。

向包中添加安全功能

迁移包后，可以添加以下安全功能：

  • 对包设置保护级别，即保存包时，是加密所有属性值还是只加密敏感属性值。有关详细信息，请参阅 Integration Services 包。

  • 对包进行数字签名，并设置属性以确保加载包时检查该签名。有关详细信息，请参阅如何使用数字签名对包进行签名。

  • 对使用检查点的包加密检查点。有关详细信息，请参阅在包中使用检查点。

有关保护 Integration Services 服务和 Integration Services 包的详细信息，请参阅 Integration Services 的安全注意事项。

请参阅

其他资源

迁移 Data Transformation Services 包


迁移脚本

迁移脚本 |
 | 请参阅
升级 SQL Server 组件 > 升级或迁移 Data Transformation Services > 迁移 Data Transformation Services 包 >

SQL Server 2000 版本的 ActiveX 脚本任务可迁移到 SQL Server 2005 ActiveX 脚本任务。

完成包迁移之后，尝试通过使用 GlobalVariables 集合的 Parent 属性来访问包对象模型的 ActiveX 脚本任务将失败。必须使用不同的脚本代码或新的 SQL Server 2005 功能取代原来的功能。

请参阅

其他资源

迁移 Data Transformation Services 包


升级 dtsrun 命令行

升级 dtsrun 命令行 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级或迁移 Data Transformation Services >

在 SQL Server 2005 中，已使用 dtexec.exe 替换了 SQL Server 2000 dtsrun.exe 命令提示实用工具。

同样，在 SQL Server 2005 中已使用 dtexecui.exe 替换了有助于直观构建命令行的 SQL Server 2000 dtsrunui.exe 实用工具。

升级命令行

如果要通过将每个命令提示选项映射到相应的 dtexec 选项来转换 dtsrun 命令行，请参阅 dtsrun 到 dtexec 的命令选项映射。

  • 某些 dtsrun 命令行选项具有直接的 dtexec 等效项，如提供服务器名称或包名称的选项，或设置变量值的选项。

  • 某些 dtsrun 命令行选项没有直接的 dtexec 等效项，如指定可信连接的选项（现为隐式默认），以及从存储库加载的选项（现已不再支持）。

  • 有些新的 dtexec 命令行选项支持 SQL Server 2005 Integration Services (SSIS) 中的新功能，如传入连接字符串的选项和管理检查点的选项。

若要借助用户界面的帮助直观地创建新的命令行，可使用 dtexecui 工具，它显示了所有可用选项，并可确保使用正确的语法。

请参阅

其他资源

dtexec 实用工具
如何使用 DTExec 实用工具运行包
如何使用 DTExecUI 实用工具运行包


迁移 Notification Services 实例

迁移 Notification Services 实例 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 >

Microsoft SQL Server 安装程序不会自动升级 Notification Services 2.0 的实例，而是应该自行升级数据库引擎 并安装 Microsoft SQL Server 2005 Notification Services，然后迁移 Notification Services 实例。当升级到 SQL Server 2005 的更高版本时，安装程序也不会自动更新实例元数据，而是必须使用 Notification Services 工具“升级”元数据。

此主题说明迁移选项，并根据迁移情况提供对其他信息的链接。

重要事项：
强烈建议在迁移 Notification Services 的生产实例之前，在测试服务器上测试迁移步骤，然后备份生产数据库。

已知的迁移问题

在将 Notification Services 2.0 实例迁移到 SQL Server 2005 Notification Services 之前，请查看任何有关升级和迁移的问题。有关详细信息，请参阅 Notification Services 向后兼容性。

准备迁移到 SQL Server 2005

在升级数据库引擎 和迁移 Notification Services 实例之前，请查看下列主题：

  • 安装 SQL Server 2005 的硬件和软件要求

  • 使用升级顾问来准备升级

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

迁移 Notification Services 实例

Notification Services 将实例、应用程序元数据和操作数据存储在数据库中。Notification Services 实例版本必须与数据库引擎 实例版本相匹配：

  • 如果已有 Notification Services 2.0 实例，并且要升级到 SQL Server 2005，则必须升级 数据库引擎，安装 SQL Server 2005 Notification Services，然后迁移 Notification Services 实例。有关详细信息，请参阅将 Notification Services 2.0 实例迁移到 SQL Server 2005。

  • 如果已有 SQL Server 2005 Notification Services 实例，并且要升级到 SQL Server 2005 的更高版本，则必须“升级”实例元数据。有关详细信息，请参阅将 Notification Services 实例迁移到 SQL Server 2005 的更高版本。

并行安装

Notification Services 2.0 和 SQL Server 2005 Notification Services 可以并行安装。但是，在 Notification Services 实例中，数据库引擎 版本和 Notification Services 版本必须匹配。而且，在生成自定义组件时，必须引用同一个版本的 Notification Services 和相关的 Microsoft .NET Framework 版本。

如果 Microsoft Windows 注册表中的版本信息和数据库不匹配，Notification Services 实例就不会启动。因此迁移 Notification Services 实例后应当验证版本信息。可以在 SQL Server Management Studio 中显示版本信息，也可以使用命令提示实用工具显示版本信息。

  • 如何查看 Notification Services 版本信息

  • nscontrol listversions 命令

降级 Notification Services 实例

迁移 Notification Services 实例后，如果需要恢复到早期版本，则必须从备份还原早期的数据库，然后使用 Notification Services 实用工具的匹配版本，重新注册 Notification Services 实例。

请参阅

概念

安装 SQL Server 2005
安装 SQL Server Notification Services


将 Notification Services 2.0 实例迁移到 SQL Server 2005

将 Notification Services 2.0 实例迁移到 SQL Server 2005 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 迁移 Notification Services 实例 >

Notification Services 实例的版本必须与其数据库匹配。Notification Services 2.0 的实例必须使用 Microsoft SQL Server 2000 数据库。Microsoft SQL Server 2005 Notification Services 的实例必须使用 SQL Server 2005 数据库。

通过升级数据库引擎 或通过将数据库移动到 SQL Server 2005 数据库服务器来升级 SQL Server 2000 数据库。SQL Server 2005 Notification Services 与 Notification Services 2.0 同时安装。运行安装程序时，Notification Services 实例并不自动升级。相反，必须执行下列步骤将 Notification Services 实例迁移到 SQL Server 2005：

  • 升级数据库引擎。

  • 安装 SQL Server 2005 Notification Services。

  • 升级 Notification Services 实例元数据。

  • 升级 Notification Services 实例。

迁移矩阵

下表显示从 Notification Services 2.0 迁移到 SQL Server 2005 Notification Services 的可能路径。“是”表示可以从左侧列中的版本迁移到该列顶部的版本。“否”表示迁移将失败。

当前版本 | SQL Server 2005 Evaluation Edition | SQL Server 2005 Developer Edition | SQL Server 2005 Workgroup Edition | SQL Server 2005 Standard Edition | SQL Server 2005 Enterprise Edition
Notification Services 2.0 Standard Edition | 是1 | 是2 |  | 是 | 是
Notification Services 2.0 Enterprise Edition | 是1 | 是2 |  | 否 | 是

1SQL Server 2005 Evaluation Edition 有时间限制。超过时间限制后，Notification Services 的实例将不会启动。

2注意 SQL Server 2005 Developer Edition 的许可限制。

注意 Notification Services 不支持 SQL Server 2005 Express Edition 和 SQL Server Workgroup Edition。

准备迁移实例

将现有 Notification Services 的实例升级到 SQL Server 2005 之前，请执行下列任务：

  • 使用 SQL Server 2005 Notification Services 程序集和 Microsoft .NET Framework 2.0 重新编译自定义事件提供程序、内容格式化程序和传递协议。用 Notification Services 2.0 程序集和 .NET Framework 1.1 编译的自定义组件与 SQL Server 2005 Notification Services 不兼容。

    Notification Services 的 SQL Server 2005 程序集位于 %ProgramFiles%\Microsoft SQL Server\90\NotificationServices\n.n.nnn\bin 文件夹中，其中 n.n.nnn 是内部版本号。

  • 卸载 Notification Services 2.0 示例应用程序。

    未修改的 Notification Services 2.0 示例并不在 SQL Server 2005 上运行。规则语法已更改，SQL Server 2005 不支持使用 Notify() 函数的规则。

    另外，某些示例应用程序在 Notification Services 2.0 和 SQL Server 2005 中使用相同的名称。因此，使用同名的 SQL Server 2005 示例前必须删除 Notification Services 2.0 示例。

    运行 RemoveSamplesDB.cmd 实用工具，删除 2.0 示例应用程序，此实用工具位于 v2.0.NNNN.0\Samples 文件夹中。

  • 确保该应用程序在同一台服务器上没有多个分发服务器。这在 SQL Server 2005 中是不允许的。必要时，可以在迁移到 SQL Server 2005 之前，先更新 ADF 以移动其中一个分发服务器，然后再更新应用程序。

  • 确定执行升级的最佳时间。

    请在活动不频繁的时侯升级实例，以便尽量减少对收集事件、生成和分发通知以及管理订阅的影响。还应该尽量避免在计划的删除间隔期间升级，删除间隔通常出现在活动不频繁的时侯。删除计划在每个应用程序定义文件 (ADF) 中以通用协调时间 (UTC) 定义。

  • 为实例数据库和应用程序数据库准备备份设备。

    升级过程中将指导您对实例和应用程序数据库进行备份。对备份设备事先进行定义将减少执行升级所需的时间。

如何迁移实例

可以使用 SQL Server Management Studio 或命令提示实用工具，将 Notification Services 实例迁移到 SQL Server 2005：

  • 如何将 Notification Services 2.0 实例迁移到 SQL Server 2005 (SQL Server Management Studio)

  • 如何将 Notification Services 2.0 实例迁移到 SQL Server 2005（命令提示符）

请参阅

概念

迁移 Notification Services 实例
安装 SQL Server Notification Services
如何查看 Notification Services 版本信息


将 Notification Services 实例迁移到 SQL Server 2005 的更高版本

将 Notification Services 实例迁移到 SQL Server 2005 的更高版本 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 迁移 Notification Services 实例 >

如果正在 Microsoft SQL Server 2005 上运行 Notification Services，可以将 Notification Services 实例迁移到 SQL Server 2005 的更高版本。以下列表按从低版本到高版本的顺序显示了 Notification Services 支持的 SQL Server 2005 版本。

  • SQL Server 2005 Evaluation Edition

  • SQL Server 2005 Developer Edition

  • SQL Server 2005 Standard Edition

  • SQL Server 2005 Enterprise Edition

可以将 SQL Server 2005 Standard Edition 实例迁移到 Evaluation Edition 或 Developer Edition，尽管这两个版本在列表中处于更低版本的位置。Evaluation Edition 和 Developer Edition 具有与 Enterprise Edition 相同的 Notification Services 功能；允许从 Standard Edition 迁移到这些版本，使得您可以评估 Enterprise Edition 的功能。

通过运行 SQL Server 2005 安装程序，可将 SQL Server 2005 Notification Services 二进制文件升级到 SQL Server 2005 的更高版本。但是，运行安装程序时，Notification Services 实例不会自动迁移。必须在运行安装程序后，使用下列过程将实例迁移到更高版本：

  • 安装 SQL Server 2005 Notification Services 的更高版本。

  • 升级 Notification Services 实例元数据。

迁移矩阵

下表显示了可能的迁移路径。“是”表示可以从左侧列中的版本迁移到该列顶部的版本。“否”表示迁移将失败。

 | Evaluation Edition | Developer Edition | Standard Edition | Enterprise Edition
Evaluation Edition | --4 | 是2 | 是3 | 是
Developer Edition | 否 | --4 | 是3 | 是
Standard Edition | 是1 | 是2 | --4 | 是
Enterprise Edition | 否 | 否 | 否 | --4

1SQL Server 2005 Evaluation Edition 有时间限制。超过时间限制后，Notification Services 的实例将不会启动。

2注意 SQL Server 2005 Developer Edition 的许可限制。

3注意 SQL Server 2005 Standard Edition 并不支持所有功能。在迁移过程中最后执行的实例更新会将应用程序中 Standard Edition 不支持的所有功能标记出来。

4迁移成功，但没有任何更改，因为源版本和目标版本及其对应的版本类别是相同的。

准备迁移

在将 Notification Services 实例从 SQL Server 2005 的较低版本迁移到较高版本之前，请执行下列任务：

  • 确定执行迁移的最佳时间。

    请在低活动期间迁移实例，以尽量减少对事件收集、通知生成与分发以及订阅管理的影响。还应尽量避免在计划的数据清除时段进行迁移，此时段往往是在低活动期间。数据清除计划是在应用程序定义文件 (ADF) 中以协调世界时 (UTC) 格式定义。

  • 为实例数据库和应用程序数据库准备备份设备。

    在迁移过程中，会指示您备份实例数据库和应用程序数据库。事先定义好备份设备可减少迁移实例所需的时间。

如何迁移

可以使用 SQL Server Management Studio 或命令提示实用工具将 Notification Services 实例迁移到另一版本的 SQL Server 2005：

  • 如何将 Notification Services 实例迁移到更高版本 (SQL Server Management Studio)

  • 如何将 Notification Services 实例迁移到更高版本（命令提示符）

请参阅

概念

如何查看 Notification Services 版本信息
迁移 Notification Services 实例
安装 SQL Server Notification Services


升级复制数据库

升级复制数据库 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 >

Microsoft SQL Server 2005 支持从 SQL Server 的早期版本升级复制数据库；在升级某一节点时，不需要停止其他节点的活动。请务必遵守有关拓扑中支持哪些版本的规则：

  • Microsoft SQL Server 7.0 Service Pack 4 (SP4) 是参与 SQL Server 2005 的复制拓扑所需的最低版本。如果使用的是 SQL Server 2000，则需要使用 Service Pack 3 (SP3) 或更高版本。

  • 分发服务器的版本可以是高于或等于发布服务器版本的任何版本（在许多情况下，分发服务器与发布服务器是同一个实例）。

  • 发布服务器的版本可以是低于或等于分发服务器版本的任何版本。

  • 订阅服务器版本取决于发布的类型：

    • 事务性发布的只读订阅服务器版本可以是两个发布服务器版本中的任何一个版本。例如，运行的 SQL Server 7.0 版发布服务器可以对应 SQL Server 2005 订阅服务器，而 SQL Server 2005 发布服务器可以对应 SQL Server 7.0 版订阅服务器。

    • SQL Server 2005 事务性发布的可更新订阅服务器版本可以是等于或高于 Microsoft SQL Server 2000 SP3 的任何版本。

    • 合并发布的订阅服务器版本可以是低于或等于发布服务器版本的任何版本。

注意：
在“安装帮助”文档和 SQL Server 2005 联机丛书中可以查看此主题。对于“安装帮助”文档中显示为粗体文本的主题链接来说，所指向的主题仅在联机丛书中提供。

升级至 Standard Edition、Workgroup Edition 或 Express Edition

在从 SQL Server 2005 的某一版本升级到另一版本之前，请验证要升级到的版本是否支持当前使用的功能。有关详细信息，请参阅主题 SQL Server 2005 的各种版本所支持的功能中的“SQL Server 2005 复制功能”部分。

新的复制代理安全模式

在 SQL Server 的早期版本中，默认情况下，代理在 SQL Server 代理服务帐户的上下文中运行。SQL Server 2005 可以细粒度控制复制代理在其中运行并建立对数据库和其他资源的 Windows 集成连接的每一个帐户；对每个代理，可指定一个不同的帐户。有关详细信息，请参阅复制的安全注意事项和复制代理安全性模式。

新的安全模式对于在拓扑中升级和运行 SQL Server 的多个版本具有下列含义：

  • 用 SQL Server 2000 或 SQL Server 7.0 创建的复制脚本在用于 SQL Server 2005 时应进行升级，以便利用安全增强功能。有关详细信息，请参阅How to: Upgrade Replication Scripts (Replication Transact-SQL Programming)。

  • 从 SQL Server 的早期版本升级到 SQL Server 2005 的分发服务器或订阅服务器在 SQL Server 代理帐户下可继续运行，并且所拥有的权限很可能比需要的多。建议您在升级后，为具有相应最低权限的代理指定单独的帐户。指定单独的帐户：

    1. 编写发布和订阅脚本。

    2. 对脚本进行更改。有关详细信息，请参阅How to: Upgrade Replication Scripts (Replication Transact-SQL Programming)。

    3. 删除发布和订阅。有关详细信息，请参阅发布数据和数据库对象和订阅发布。

    4. 使用修改后的脚本重新创建发布和订阅。

    有关代理所需权限的信息，请参阅复制代理安全性模式；有关管理登录名和密码的信息，请参阅管理复制中的登录名和密码。升级后创建的新复制配置要求每一个复制代理具有特定的帐户配置。

    注意：
    任何配置为使用 SQL Server 身份验证进行本地数据库连接的代理都改用 Windows 身份验证。本地连接是指代理与它所在的同一台计算机上运行的 SQL Server 实例之间建立的连接。例如，请求订阅的合并代理运行在订阅服务器上，因此它与订阅服务器建立的连接是本地连接。

  • 对于运行 SQL Server 早期版本的复制拓扑的参与者，原复制安全模式保持不变。例如：

    • 对运行 SQL Server 2000 或 SQL Server 7.0 的订阅服务器的请求订阅不使用新的安全模式，因为合并代理或分发是在订阅服务器上创建的。

    • 从运行 SQL Server 2005 的分发服务器到运行 SQL Server 2000 或 SQL Server 7.0 的订阅服务器的推送订阅使用新的安全模式，因为合并代理或分发是在分发服务器上创建的。

    • 运行 SQL Server 2000 或 SQL Server 7.0 的发布服务器与运行 SQL Server 2005 的分发服务器一起工作，不使用新安全模式（对于快照代理、日志读取器代理或队列读取器代理），因为代理是在发布数据库的上下文中创建的。

升级合并复制后运行代理

升级后，请为每一个合并发布运行快照代理，并为每一个订阅运行合并代理，以更新复制元数据。因为不必重新初始化订阅，所以不需要应用新快照。升级后首次运行合并代理时，将更新订阅元数据。

合并复制将发布和订阅元数据存储在发布和订阅数据库中的若干系统表中。运行快照代理将更新发布元数据，而运行合并代理将更新订阅元数据。只需生成发布快照。如果合并发布使用参数化筛选器，则每一个分区也都有快照。不必更新这些分区快照。（在 SQL Server 2000 中，“参数化筛选器”称为“动态筛选器”，“分区快照”称为“动态快照”）。

从 Microsoft SQL Server Management Studio、复制监视器或命令行运行代理。有关运行快照代理的详细信息，请参阅下列主题：

  • 如何创建和应用初始快照 (SQL Server Management Studio)

  • 如何启动和停止复制代理 (SQL Server Management Studio)

  • How to: Create the Initial Snapshot (Replication Transact-SQL Programming)

  • Programming Replication Agent Executables

有关运行合并代理的详细信息，请参阅下列主题：

  • 如何同步请求订阅 (SQL Server Management Studio)

  • 如何同步推送订阅 (SQL Server Management Studio)

  • 如何同步请求订阅（复制编程）

  • 如何同步推送订阅（复制编程）

在使用合并复制的拓扑中升级 SQL Server 之后，如果要使用新功能，请更改所有发布的发布兼容级别。有关详细信息，请参阅在复制拓扑中使用 SQL Server 的多个版本。

合并复制的 Web 同步

合并复制的 Web 同步选项要求将 SQL Server 复制侦听器 (replisapi.dll) 复制到用于同步的 Internet 信息服务 (IIS) 服务器上的虚拟目录中。配置 Web 同步时，该文件被配置 Web 同步向导复制到虚拟目录中。若要升级安装在 IIS 服务器上的 SQL Server 组件，则必须将 replisapi.dll 从 COM 目录手动复制到 IIS 服务器上的虚拟目录。有关配置 Web 同步的详细信息，请参阅配置 Web 同步。

从早期版本还原复制的数据库

在从早期版本还原复制数据库的备份时，若要确保保留复制设置：请还原到与创建备份的服务器和数据库同名的服务器和数据库。

请参阅

参考

版本升级

概念

复制的向后兼容性
在复制拓扑中使用 SQL Server 的多个版本

其他资源

管理复制
复制增强


升级 SQL Server 组件帮助主题

升级 SQL Server 组件帮助主题 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 >

此部分中的主题提供关于将现有的 Microsoft SQL Server 组件升级或迁移到 Microsoft SQL Server 2005 的信息。

本节的相关信息

  • 升级数据库引擎帮助主题

  • 升级或迁移 Analysis Services 的帮助主题

  • 迁移 Notification Services 帮助主题

  • 升级或迁移 Data Transformation Services 帮助主题

请参阅

任务

如何从命令提示符安装 SQL Server 2005

概念

准备安装 SQL Server 2005
SQL Server 外围应用配置器

其他资源

安装 SQL Server 组件帮助主题


升级数据库引擎帮助主题

升级数据库引擎帮助主题 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 >

此部分中的主题说明如何将 Microsoft SQL Server 独立实例或群集实例升级到 SQL Server 2005。

本节的相关信息

  • 如何升级到 SQL Server 2005（安装程序）

  • 如何从命令提示符安装 SQL Server 2005

  • 如何升级到 SQL Server 2005 故障转移群集（安装程序）

请参阅

参考

版本升级

其他资源

升级 SQL Server 组件
向后兼容性
安装 SQL Server 2005 组件


如何升级到 SQL Server 2005（安装程序）

如何升级到 SQL Server 2005（安装程序） |
 | 请参阅
升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 > 升级数据库引擎帮助主题 >

Microsoft SQL Server 2005 安装向导基于 Windows 安装程序，并提供一个功能树用于升级 SQL Server 组件。也可以将 SQL Server 2005 与 SQL Server 2000 或 SQL Server 7.0 并行安装，或从 SQL Server 的早期版本中迁移已有的数据库和配置设置，然后将它们应用于 SQL Server 2005 的实例。

有关升级和迁移选项的详细信息，请参阅升级 SQL Server 组件。有关支持并行配置的详细信息，请参阅使用 SQL Server 的多个版本。

数据库引擎

若要升级 SQL Server 2000 或 SQL Server 7.0 数据库引擎 的实例，请参阅以下过程。

若要升级故障转移群集，请参阅如何升级到 SQL Server 2005 故障转移群集（安装程序）。

若要将用户数据库迁移到 SQL Server 2005，请参阅：

  • 使用复制数据库向导

  • 如何使用复制数据库向导升级至 SQL Server 2005

Analysis Services

有关升级 Analysis Services 的信息，请参阅升级或迁移 Analysis Services。

Reporting Services

使用 SQL Server 安装程序（安装向导）和 Reporting Services 配置工具，可以升级 Reporting Services。有关详细信息，请参阅升级 Reporting Services。

Notification Services

若要升级 Notification Services，请升级数据库引擎并安装 SQL Server 2005 Notification Services，然后迁移 Notification Services 的实例。有关详细信息，请参阅迁移 Notification Services 实例。

Data Transformation Services

有关在 SQL Server 2005 中使用 DTS 的信息，请参阅升级或迁移 Data Transformation Services。

复制

SQL Server 2005 支持从早期版本的 SQL Server 升级复制的数据库。有关详细信息，请参阅升级复制数据库。

必备项

对于本地安装，必须以管理员身份运行安装程序。如果通过远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

将数据库引擎 升级到 SQL Server 2005 之前，请先查看以下主题：

  • 安装 SQL Server 2005 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

  • SQL Server 2005 数据库引擎的向后兼容性

  • 升级数据库引擎

过程

将 SQL Server 数据库引擎升级到 SQL Server 2005

  1. 将 SQL Server 2005 产品 CD 或 DVD 插入计算机的 CD 或 DVD 驱动器中。SQL Server 安装向导将会自动启动。如果 SQL Server 安装向导无法自动启动，请双击 CD 或 DVD 根文件夹中的 Splash.hta。

    注意：
    若要从网络驱动器运行安装程序，请导航到共享驱动器上的安装位置，然后双击 Splash.hta。

  2. 若要开始安装过程，请单击“安装 SQL Server”。

  3. 在“最终用户许可协议”页上，阅读许可协议，再选中相应的复选框以接受许可条款和条件。接受许可协议后即可激活“下一步”按钮。若要继续，请单击“下一步”。若要结束安装程序，请单击“取消”。

  4. 在“SQL Server 组件更新”页上，安装程序将安装 SQL Server 2005 的必需软件。有关组件要求的详细信息，请单击该页底部的“帮助”按钮。若要开始执行组件更新，请单击“安装”。更新完成之后若要继续，请单击“完成”。有关详细信息，请参阅 安装必备组件。

  5. 在 SQL Server 安装向导的“欢迎”页上，单击“下一步”以继续安装。

  6. 在“系统配置检查”(SCC) 页上，将扫描安装计算机，看看是否存在可能阻止安装程序运行的情况。有关配置检查项的信息，请单击该页底部的“帮助”或参阅系统配置检查器的检查参数。若要中断扫描，请单击“停止”。若要显示按结果进行分组的检查项列表，请单击“筛选器”，然后从下拉列表中选择类别。若要查看 SCC 结果的报表，请单击“报表”，然后从下拉列表中选择选项。选项包括查看报表、将报表保存到文件、将报表复制到剪贴板和以电子邮件形式发送报表。完成 SCC 扫描之后，若要继续执行安装程序，请单击“继续”。

  7. 在“注册信息”页上的“姓名”和“公司”文本框中，输入相应的信息。在此版本中，产品密钥是自动输入的。若要继续，请单击“下一步”。有关详细信息，请参阅注册信息。

  8. 在“要安装的组件”页上，请选择要安装的组件。选择各个组件组时，“要安装的组件”窗格中会显示相应的说明。您可以选中任意一些复选框。当您选择 SQL Server 或 Analysis Services 时，如果安装程序检测到您正将组件安装到虚拟服务器，则将启用“作为故障转移群集安装”复选框。必须选择此选项才可以安装故障转移群集。有关详细信息，请参阅要安装的组件。

    若要安装单个组件，请单击“高级”。否则，请单击“下一步”继续。

  9. 如果在上一页中单击了“高级”，此时将显示“功能选择”页。在“功能选择”页上，使用下拉框选择要安装的程序功能。若要将组件安装到自定义的目录下，请选择相应的功能，再单击“浏览”。有关此页功能的详细信息，请参阅功能选择。若要继续安装，请在完成功能选择后单击“下一步”。

  10. 在“实例名”页上，请选择要升级的默认实例或命名实例。如果已经安装了默认实例或命名实例，并且为安装的软件选择了现有实例，则安装程序将升级所选的实例并提供安装其他组件的选项。

    若要升级计算机上已安装的 SQL Server 默认实例，请单击“默认实例”，然后单击“下一步”继续。

    若要升级计算机上已安装的 SQL Server 命名实例，请单击“命名实例”，然后在提供的空白处键入实例名，也可以在“实例名”页上单击“已安装的实例”，从“已安装的实例”列表中选择一个实例，然后单击“确定”以填充实例名字段。选择要升级的实例之后，请单击“下一步”继续。

    注意：
    若要升级默认实例，计算机上必须已经有默认实例。若要升级命名实例，计算机上必须已经有命名实例。

    有关实例命名规则的详细信息，请参阅实例名称。

  11. 在“现有组件”页上，安装程序列出计算机上已安装的 SQL Server 组件。能够升级到 SQL Server 2005 的组件的复选框是启用了的。如果某个组件的复选框不可用，则该组件不能升级到 SQL Server 2005。若要查看可用选项和替代项的报告，请单击“详细信息”。若要升级“现有组件”页上列出的组件，请选中其复选框，然后单击“下一步”。有关详细信息，请参阅现有组件。

  12. 如果要添加新的组件，请在“服务帐户”页上，为非 SQL Server 帐户指定用户名、密码和域名。对于此版本，SQL Server 2005 安装程序将使用正在升级的现有 SQL Server 服务的服务帐户信息。您可以将同一个帐户用于所有服务。

    也可以为各个服务指定单独的帐户。选中“为每个服务帐户进行自定义”复选框，从列表框中选择服务名，然后为列表中的每个服务提供登录凭据。若要继续安装，请单击“下一步”。有关详细信息，请参阅服务帐户。

    注意：
    域名不能为完整的域名服务 (DNS) 名称。例如，如果 DNS 名称为 my-domain-name.com，请在“域”文本框中输入“my-domain-name”。在 SQL Server 安装程序中，“域”文本框不接受“my-domain-name.com”。

  13. 如果要升级的 SQL Server 实例配置为使用混合模式（Windows 身份验证或 SQL Server 身份验证），则将显示“升级登录信息”页。在此页提供的凭据用于连接到现有的 SQL Server 实例，以便可以运行升级脚本。如果现有的 SQL Server 实例配置为使用 Windows 身份验证，则不显示此页。若要继续安装，请单击“下一步”。有关详细信息，请参阅升级登录信息。

    安全说明：
    如果可能，请使用 Windows 身份验证。

    安全说明：
    对于此版本，SQL Server 安装程序可能不会对其所在计算机不是域成员的 Microsoft Windows Server 2003 的某些默认配置强制强密码要求。设置强密码对于确保系统的安全至关重要。始终使用强密码。有关强密码的指南，请参阅 SQL Server 2005 联机丛书中的身份验证模式。

  14. 如果选择 Analysis Services 作为要安装的功能，请在“排序规则设置”页上指定默认排序规则。您可以将同一个排序规则用于 SQL Server 和 Analysis Services，也可以为各个组件分别指定排序规则。

    若要为 SQL Server 和 Analysis Services 设置单独的排序规则设置，请选中“为每个服务帐户进行自定义”复选框。选中复选框之后，将出现下拉选择框。从下拉选择框中选择一个服务，然后分配其排序规则。对每个服务重复。若要继续安装，请单击“下一步”。有关详细信息，请参阅排序规则设置。

  15. 如果选择 Reporting Services 作为要安装的功能，将显示“报表服务器虚拟目录”页。接受默认目录名称，或为目录指定位置。有关此页的详细信息，请单击该页底部的“帮助”。若要继续安装，请单击“下一步”。有关详细信息，请参阅报表服务器安装选项。

  16. 如果选择 Reporting Services 作为要安装的功能，将显示“报表服务器数据库安装程序”页。指定报表服务器数据库的宿主。如果选择使现有 SQL Server 实例驻留报表服务器数据库，请从下拉列表中选择一个实例，再选择用于访问该实例的身份验证模式。有关详细信息，请参阅报表服务器安装详细信息。

    如果选择“SQL Server 身份验证”，请提供对该实例具有管理权限的用户名和密码。然后确认报表服务器数据库名称是否正确。若要继续，请单击“下一步”。

  17. 如果选择 Reporting Services 作为要安装的功能，将显示“报表服务器传递设置”页。指定 SMTP 服务器地址和电子邮件地址（用作从报表服务器发出的电子邮件的发件人）。若要继续，请单击“下一步”。

  18. 在“错误和使用情况报告设置”页上，可以清除复选框以禁用错误报告。若要继续安装，请单击“下一步”。有关详细信息，请参阅错误和使用情况报告设置。

  19. 在“准备安装”页上，查看要安装的 SQL Server 功能和组件的摘要。对于升级方案，现有实例的所有组件和功能均选中进行升级。若要继续安装，请单击“安装”。有关详细信息，请参阅准备安装。

  20. 在“安装进度”页上，可以在安装过程中监视安装进度。若要在安装期间查看组件的日志文件，请在“安装进度”页上单击产品或状态名称。

  21. 在“完成 Microsoft SQL Server 安装向导”页上，可以通过单击此页上提供的链接查看安装摘要日志。若要退出 SQL Server 安装向导，请单击“完成”。

  22. 如果得到重新启动计算机的指示，请立即进行此操作。完成安装后，阅读来自安装程序的消息是很重要的。如果未能重新启动计算机，可能会导致以后运行安装程序失败。

后续步骤

将数据库引擎 升级到 SQL Server 2005 之后，请完成以下任务：

  • 注册服务器 - 升级会删除早期的 SQL Server 实例的注册表设置。升级之后，必须重新注册服务器。

  • 重新填充全文目录 - 在升级过程中数据库被标记为禁用全文。目录必须重新填充，但是因为此操作耗费时间很长，所以安装程序不会自动运行此操作。由于此操作可增强 SQL Server 2005 安装的性能，因此管理员应计划在方便的时候重新填充全文目录。

  • 更新统计信息 - 建议您在升级之后对所有数据库更新统计信息，以便优化查询性能。使用 sp_updatestats 存储过程更新 SQL Server 2005 数据库用户定义表中的统计信息。

  • 更新使用计数器 - 在 SQL Server 的早期版本中，表和索引的行计数以及页计数的值可能会不正确。若要更正任何无效的行或页计数，建议在升级完成后对所有数据库运行 DBCC UPDATEUSAGE。

  • 配置新的 SQL Server 安装 -- 为了减小系统易受攻击的外围应用，SQL Server 2005 有选择地安装和激活关键服务和功能。有关如何激活 SQL Server 2005 功能的详细信息，请参阅 SQL Server 外围应用配置器。

请参阅

任务

如何在 SQL Server 2005 的现有实例中更改组件（安装程序）

概念

如何查看 SQL Server 2005 安装日志文件

其他资源

升级到 SQL Server 2005
向后兼容性


升级或迁移 Analysis Services 的帮助主题

升级或迁移 Analysis Services 的帮助主题 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 >

本部分包含以下用于将数据库升级和迁移到 Microsoft SQL Server 2005 Analysis Services (SSAS) 的通用步骤。

有关安装 Analysis Services 的通用步骤的信息，请参阅 Analysis Services 安装帮助主题。

重要事项：
本部分中的升级和迁移 Analysis Services 的帮助主题只将重点放在特定于 Analysis Services 的升级和迁移选项上。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

本节内容

  • 如何升级 Analysis Services 实例

  • 如何迁移 Analysis Services 数据库

请参阅

概念

升级或迁移 Analysis Services


如何升级 Analysis Services 实例

如何升级 Analysis Services 实例 |
 | 请参阅
升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 > 升级或迁移 Analysis Services 的帮助主题 >

可以将 Microsoft SQL Server 2000 Analysis Services 的现有实例升级为 Microsoft SQL Server 2005 Analysis Services (SSAS)，并且作为升级过程的一部分，还可以将现有数据库从旧实例迁移到新实例。若要升级 SQL Server 2000 Analysis Services 的现有实例，请运行安装程序并将现有实例的名称指定为新实例的名称。

重要事项：
本主题和同时提供的 Analysis Services 升级和迁移帮助主题仅重点介绍 Analysis Services 特有的升级和迁移选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

升级 Analysis Services 的实例

  1. 使用 SQL Server 安装向导或从命令提示符运行安装程序。有关如何使用 SQL Server 安装向导运行安装程序的详细信息，请参阅如何使用安装程序安装 Analysis Services。有关如何从命令提示符运行安装程序的详细信息，请参阅如何从命令提示符安装 Analysis Services。

    重要事项：
    从 64 位版本的 Microsoft SQL Server 2000 升级到 64 位版本的 Microsoft SQL Server 2005 时，必须在升级数据库引擎 之前先升级 Analysis Services。

  2. 使用 SQL Server 安装向导时，请在“实例名”页上选择“默认实例”。若要确认是否存在 SQL Server 2000 Analysis Services 实例，可以单击“已安装的实例”按钮。从命令提示符运行安装程序时，使用 instancename 选项来指定 SQL Server 2000 Analysis Services 现有实例的名称。由于 SQL Server 2000 Analysis Services 不支持命名实例，因此现有实例的名称通常为服务器名。

请参阅

任务

如何迁移 Analysis Services 数据库

概念

升级或迁移 Analysis Services


如何迁移 Analysis Services 数据库

如何迁移 Analysis Services 数据库 |
 | 请参阅
升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 > 升级或迁移 Analysis Services 的帮助主题 >

您可以将现有的 Analysis Services 数据库从 Microsoft SQL Server 2000 Analysis Services 实例迁移到 Microsoft SQL Server 2005 Analysis Services (SSAS) 实例，方法是在安装期间升级现有的 Analysis Services 实例或在安装完成后运行迁移向导。

本主题描述使用迁移向导来迁移现有 Analysis Services 数据库的过程。在安装期间，使用 SQL Server 安装向导升级 SQL Server 2000 Analysis Services 实例时，不必指定任何与数据库迁移相关的其他选项。

重要事项：
本主题和同时提供的 Analysis Services 升级和迁移帮助主题仅重点介绍 Analysis Services 特有的升级和迁移选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

通过使用迁移向导来迁移现有的 Analysis Services 数据库

  1. 从 SQL Server Management Studio 的对象浏览器中的 Analysis Services 服务器节点启动迁移向导。也可以通过在命令提示符处运行程序 MigrationWizard.exe 来启动该向导。

  2. 向导启动并显示“欢迎使用 Analysis Services 迁移向导”页。阅读介绍性消息，然后单击“下一步”继续。

  3. 在“指定源和目标”页上，标识源 SQL Server 2000 Analysis Services 服务器和实例名，然后标识目标 SQL Server 2005 Analysis Services 服务器和实例名。也可以不指定目标服务器，而选择将数据库架构保存到脚本文件，以后再完成迁移。例如，通过在 SQL Server 2005 Integration Services (SSIS) 包中使用 Analysis Services 执行 DDL 任务来完成迁移。有关 Analysis Services 执行 DDL 任务的详细信息，请参阅 Analysis Services 执行 DDL 任务。

  4. 在“选择要迁移的数据库”页上，选中要迁移的数据库旁边的复选框。如果愿意，可为目标数据库指定与源数据库不同的名称。

  5. 在“验证数据库”页上，向导分析要迁移的数据库并报告所发现的任何问题。

  6. 在“迁移数据库”页上，向导在执行数据库迁移时报告执行的进度。

  7. 在“完成向导”页上，向导报告迁移的结果。单击“完成”即可完成向导。

  8. 迁移数据库之后，必须从原始数据源处理数据库，然后才能查询数据库。有关详细信息，请参阅处理 Analysis Services 对象。

  9. 迁移之后，您可能需要查看 Analysis Services 数据库迁移注意事项，以了解 Analysis Services 数据库不同版本间的差异。

请参阅

概念

迁移现有 Analysis Services 数据库
Analysis Services 数据库迁移注意事项
升级或迁移 Analysis Services


升级或迁移 Data Transformation Services 帮助主题

升级或迁移 Data Transformation Services 帮助主题 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 >

本部分包含以下用于将包升级和迁移到 Microsoft SQL Server 2005 Integration Services (SSIS) 的通用步骤。

有关安装 Integration Services 的通用步骤的信息，请参阅Integration Services 安装帮助主题。

本节内容

  • 如何从 Data Transformation Services 升级到 Integration Services

  • 如何将 Data Transformation Services 包迁移到 Integration Services

请参阅

概念

升级或迁移 Data Transformation Services
SQL Server 2005 Integration Services 的向后兼容性


如何从 Data Transformation Services 升级到 Integration Services

如何从 Data Transformation Services 升级到 Integration Services |
 | 请参阅
升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 > 升级或迁移 Data Transformation Services 帮助主题 >

SQL Server 2000 Data Transformation Services (DTS) 包可以继续与 SQL Server 2005 Integration Services (SSIS) 包一起运行。

有关升级和迁移 Data Transformation Services 用户可用的选项的详细信息，请参阅升级或迁移 Data Transformation Services。

从 Data Transformation Services 升级到 Integration Services

  1. 使用首选方法安装 SQL Server 2005，包括 Integration Services。有关详细信息，请参阅如何使用安装程序安装 Integration Services 或如何从命令提示符安装 Integration Services。

  2. Integration Services 还安装 SQL Server 2000 Data Transformation Services (DTS) 的支持组件，包括枚举和运行 DTS 包的功能。有关详细信息，请参阅如何确保对 Data Transformation Services 包的支持。

    注意：
    虽然选择安装 Integration Services 时会自动安装对 SQL Server 2000 Data Transformation Services (DTS) 的支持，但如果在安装期间或安装后将计算机中 SQL Server 2000 的上一实例升级为 SQL Server 2005，则将删除 DTS 所需的某些注册表和环境设置。若要还原这些设置，请在“控制面板”的“添加/删除程序”列表中找到“Microsoft SQL Server 2005 向后兼容性”，单击“更改”按钮，并在向导的“程序维护”页上选择“修复”选项。

  3. 还可以将 DTS 包迁移为 Integration Services 格式，同时原始包保持不变。有关详细信息，请参阅迁移 Data Transformation Services 包。安装 Integration Services 时，将安装包迁移向导。

请参阅

任务

如何确保对 Data Transformation Services 包的支持

概念

SQL Server 2005 Integration Services 的向后兼容性


如何将 Data Transformation Services 包迁移到 Integration Services

如何将 Data Transformation Services 包迁移到 Integration Services |
 | 请参阅
升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 > 升级或迁移 Data Transformation Services 帮助主题 >

您不是必须将 SQL Server 2000 Data Transformation Services (DTS) 包迁移为 SQL Server 2005 Integration Services (SSIS) 包格式。DTS 包可继续与 Integration Services 包一起运行。

有关升级和迁移 Data Transformation Services 用户可用的选项的详细信息，请参阅升级或迁移 Data Transformation Services。

如果要迁移 DTS 包，SQL Server 2005 提供了包迁移向导来帮助完成此过程。由于该向导不改变原始包，因此如果迁移有困难，您始终可以继续使用原始包。

安装 Integration Services 时，将安装包迁移向导。有关详细信息，请参阅如何确保对 Data Transformation Services 包的支持。

注意：
SQL Server 2005 的 Standard Edition、Enterprise Edition 和 Developer Edition 提供了包迁移向导。

有关迁移 DTS 包的详细信息，请参阅迁移 Data Transformation Services 包。

将 Data Transformation Services 包迁移到 Integration Services

  1. 根据需要，可以运行升级顾问来分析现有的包并获取潜在迁移问题的报表。有关详细信息，请参阅已知的包迁移问题。

  2. 运行包迁移向导来迁移包。

  3. 请重新配置升级顾问或向导所报告的必须手动重新配置的包项。

  4. 根据需要对迁移的包进行测试并排除故障。

请参阅

任务

如何确保对 Data Transformation Services 包的支持

概念

SQL Server 2005 Integration Services 的向后兼容性


迁移 Notification Services 帮助主题

迁移 Notification Services 帮助主题 |
 | 请参阅
升级到 SQL Server 2005 > 升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 >

此部分中的主题提供将 Notification Services 实例升级并迁移到 Microsoft SQL Server 2005 的说明。

本节的相关信息

  • 如何将 Notification Services 2.0 实例迁移到 SQL Server 2005（命令提示符）

  • 如何将 Notification Services 2.0 实例迁移到 SQL Server 2005 (SQL Server Management Studio)

  • 如何将 Notification Services 实例迁移到更高版本（命令提示符）

  • 如何将 Notification Services 实例迁移到更高版本 (SQL Server Management Studio)

  • 如何查看 Notification Services 版本信息

请参阅

任务

如何为 COM Interop 注册核心 Notification Services 程序集

概念

迁移 Notification Services 实例
安装 SQL Server Notification Services


如何将 Notification Services 2.0 实例迁移到 SQL Server 2005 (SQL Server Management Studio)

如何将 Notification Services 2.0 实例迁移到 SQL Server 2005 (SQL Server Management Studio) |
 | 请参阅
升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 > 迁移 Notification Services 帮助主题 >

如果现有的 Notification Services 2.0 实例在 Microsoft SQL Server 2000 上运行，则可以升级数据库和 Notification Services，然后将 Notification Services 实例迁移到 Microsoft SQL Server 2005。

下列过程显示如何使用 SQL Server Management Studio 升级实例。

重要事项：
Notification Services 实例可以在许多不同配置下部署。请使用下列过程作为开发和测试您自己的迁移过程的指南。

升级服务器之前的准备工作

  1. 使用 Notification Services 2.0 版的 nscontrol 命令提示实用工具禁用 Notification Services 实例：

    1. 在“开始”菜单上，指向“程序”\“Microsoft SQL Server Notification Services”，再单击“Notification Services 命令提示”。

    2. 键入以下命令，禁用实例：

      nscontrol disable -name instance_name

  2. 在每个运行 NS$instanceName Windows 服务的服务器上，停止该服务：

    1. 在“开始”菜单上，指向“程序”\“Microsoft SQL Server Notification Services”，再单击“Notification Services 命令提示”。

    2. 键入以下命令，停止实例：

      net stop NS$ instanceName

  3. 在每个具有事件提供程序、生成器、分发服务器或订阅管理界面的服务器上，撤消注册该实例。

    1. 在打开的 Notification Services 命令提示窗口中键入以下内容：

      nscontrol unregister -name instance_name

    2. 关闭命令提示窗口。

升级数据库引擎并安装 Notification Services

  1. 使用 SQL Server 2005 安装程序，将数据库引擎 从 SQL Server 2000 升级到 SQL Server 2005。有关详细信息，请参阅升级数据库引擎。

  2. 在每个运行事件提供程序、生成器、分发服务器或订阅管理界面的服务器上，安装 SQL Server 2005 Notification Services。

    如果 Notification Services 和数据库位于同一台服务器上，则可以同时升级数据库并安装 Notification Services。

迁移 Notification Services 实例

  1. 打开 SQL Server 2005 Notification Services 命令提示符窗口，将实例信息添加到系统数据库：

    1. 在“开始”菜单上，指向“所有程序”\“Microsoft SQL Server 2005”\“配置工具”，再单击“Notification Services 命令提示”。

    2. 键入以下命令修复实例元数据：

      nscontrol repair -name instance_name -database instanceDatabaseName -schema instanceDatabaseSchema -server databaseServer

  2. 使用 SQL Server Management Studio 升级实例和应用程序数据库数据：

    1. 在“开始”菜单上，指向 “程序”\“Microsoft SQL Server”，然后单击 SQL Server Management Studio。

    2. 连接到承载实例和应用程序数据库的 SQL Server 实例。

    3. 在对象资源管理器中，展开 Notification Services。

    4. 右键单击实例，指向“任务”，然后选择“升级”。

      这样便可升级数据库架构、存储过程以及在实例和应用程序数据库中的版本号。

  3. 为实例承载的每个应用程序修改应用程序定义文件 (ADF) 中的通知生成规则。

    • 修改所有使用 Notify() 函数的通知生成规则，以使用 INSERT INTO 语法。例如，更改下面的 Notification Services 2.0 规则：

      复制代码
      SELECT dbo.FlightNotificationsNotify(S.SubscriberId,
S.DeviceName, S.SubscriberLocale, E.Carrier, E.LeavingFrom,
E.GoingTo, E.Price, E.Conditions)
    FROM FlightEvents E, FlightSubscriptions S
    WHERE E.LeavingFrom = S.LeavingFrom
    AND E.GoingTo = S.GoingTo
    AND ( (E.Carrier = S.Carrier) OR (S.Carrier = '*') )
    AND E.Price &lt; S.Price
      将其更改为下面的语法，该语法不再使用 Notify() 函数，而是选择数据，将其插入到与通知类同名的视图 (FlightNotifications)：

      复制代码
      INSERT INTO FlightNotifications(SubscriberId, DeviceName,
SubscriberLocale, Carrier, LeavingFrom, GoingTo, Price,
Conditions)
SELECT S.SubscriberId, S.DeviceName, S.SubscriberLocale,
E.Carrier, E.LeavingFrom, E.GoingTo, E.Price, E.Conditions
    FROM FlightEvents E, FlightSubscriptions S
    WHERE E.LeavingFrom = S.LeavingFrom
    AND E.GoingTo = S.GoingTo
    AND ( (E.Carrier = S.Carrier) OR (S.Carrier = '*') )
    AND E.Price &lt; S.Price
    • 修改 ADF 和 ICF 中的版本号。（可选）

    • 如果移动了该实例，请更新 ADF 中的 SystemName 值和 ICF 中的 SqlServerSystem 值。这些值可能为参数，这意味着这些值位于 ParameterDefaults 节点中，或者在创建实例时提供。

  4. 在对象资源管理器中，右键单击 Notification Services 实例，指向“任务”，然后选择“更新”。

    在“更新”对话框中提供请求的信息。更新实例及其应用程序的过程将 ADF 和 ICF 更改应用到数据库。

    确保选中“更新实例后启用它”。

  5. 在以前注册实例的每个服务器上，注册实例。

    SQL Server Management Studio 只在本地计算机上注册实例。若要使用 SQL Server Management Studio 注册实例，请右键单击实例，指向“任务”，再选择“注册”。

    如果必须在未安装 SQL Server Management Studio 的服务器上注册实例，请使用 SQL Server 2005 nscontrol register 命令行实用工具来注册实例。

  6. 将任何自定义组件替换为使用 SQL Server 2005 程序集和 Microsoft .NET Framework 2.0 编译的新组件。

  7. 如果使用的是 COM interop，请重新注册核心 Notification Services 程序集。有关详细信息，请参阅如何为 COM Interop 注册核心 Notification Services 程序集。

  8. 在对象资源管理器中，右键单击实例，然后选择“启动”。

请参阅

任务

将 Notification Services 2.0 实例迁移到 SQL Server 2005
如何将 Notification Services 2.0 实例迁移到 SQL Server 2005（命令提示符）

其他资源

管理实例和应用程序帮助主题 (Notification Services)
nscontrol register 命令


如何将 Notification Services 2.0 实例迁移到 SQL Server 2005（命令提示符）

如何将 Notification Services 2.0 实例迁移到 SQL Server 2005（命令提示符） |
 | 请参阅
升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 > 迁移 Notification Services 帮助主题 >

如果现有的 Notification Services 2.0 实例在 Microsoft SQL Server 2000 上运行，则可以将此实例升级到 Microsoft SQL Server 2005。若要执行升级，必须升级数据库和 Notification Services 实例。以下过程显示如何使用命令提示实用工具升级实例。

重要事项：
Notification Services 实例可以在许多不同配置下部署。请使用下列过程作为开发和测试您自己的迁移过程的指南。

升级服务器之前的准备工作

  1. 在注册实例的一个服务器上，使用 nscontrol 命令提示实用工具的 Notification Services 2.0 版本禁用 Notification Services 实例：

    1. 在“开始”菜单上，依次指向“所有程序”、Microsoft SQL Server 2005 和“配置工具”，再单击“Notification Services 命令提示”。

    2. 键入以下命令，禁用实例：

      nscontrol disable -name instance_name

  2. 在每个运行 NS$instanceName Windows 服务的服务器上，停止该服务：

    1. 打开 Notification Services 2.0 命令提示符窗口，键入以下命令以停止实例：

      net stop NS$ instanceName

  3. 在每个具有事件提供程序、生成器、分发服务器或订阅管理界面的服务器上，撤消注册该实例。

    1. 在打开的 Notification Services 命令提示窗口中键入以下内容：

      nscontrol unregister -name instance_name

    2. 关闭命令提示窗口。

升级数据库引擎并安装 Notification Services

  1. 使用 SQL Server 2005 安装程序，将数据库引擎 从 SQL Server 2000 升级到 SQL Server 2005。有关详细信息，请参阅升级数据库引擎。

  2. 在每个运行事件提供程序、生成器、分发服务器或订阅管理界面的服务器上，安装 SQL Server 2005 Notification Services。

    如果 Notification Services 和数据库位于同一台服务器上，则可以同时升级数据库并安装 Notification Services。

    在升级过程中 Notification Services 2.0 的安装不更改。

迁移 Notification Services 实例

  1. 在每个以前注册过此实例的服务器上注册此实例：

    1. 在“开始”菜单上，依次指向“所有程序”、Microsoft SQL Server 2005 和“配置工具”，再单击“Notification Services 命令提示”。

    2. 使用 nscontrol register 命令注册此实例。以下命令显示如何注册此实例并创建使用 Windows 身份验证连接到数据库服务器的 Windows 服务：

      nscontrol register -name instanceName -server databaseServer -service -serviceusername username -servicepassword password

      有关详细信息，请键入 nscontrol register -? 或参阅 nscontrol register 命令。

  2. 在服务器上键入以下命令，修复实例元数据：

    nscontrol repair -name instance_name -database instanceDatabaseName -schema instanceDatabaseSchema

  3. 键入以下命令，升级实例和应用程序数据：

    nscontrol upgrade -name instanceName

  4. 为实例承载的每个应用程序修改应用程序定义文件 (ADF) 中的通知生成规则。

    • 修改所有使用 Notify() 函数的通知生成规则，以使用 INSERT INTO 语法。例如，更改下面的 Notification Services 2.0 规则：

      复制代码
      SELECT dbo.FlightNotificationsNotify(S.SubscriberId,
S.DeviceName, S.SubscriberLocale, E.Carrier, E.LeavingFrom,
E.GoingTo, E.Price, E.Conditions)
    FROM FlightEvents E, FlightSubscriptions S
    WHERE E.LeavingFrom = S.LeavingFrom
    AND E.GoingTo = S.GoingTo
    AND ( (E.Carrier = S.Carrier) OR (S.Carrier = '*') )
    AND E.Price &lt; S.Price
      将其更改为下面的语法，该语法不再使用 Notify() 函数，而是选择数据，将其插入到与通知类同名的视图 (FlightNotifications)：

      复制代码
      INSERT INTO FlightNotifications(SubscriberId, DeviceName,
SubscriberLocale, Carrier, LeavingFrom, GoingTo, Price,
Conditions)
SELECT S.SubscriberId, S.DeviceName, S.SubscriberLocale,
E.Carrier, E.LeavingFrom, E.GoingTo, E.Price, E.Conditions
    FROM FlightEvents E, FlightSubscriptions S
    WHERE E.LeavingFrom = S.LeavingFrom
    AND E.GoingTo = S.GoingTo
    AND ( (E.Carrier = S.Carrier) OR (S.Carrier = '*') )
    AND E.Price &lt; S.Price
    • 修改 ADF 和 ICF 中的版本号。（可选）

    • 如果移动了该实例，请更新 ADF 中的 SystemName 值和 ICF 中的 SqlServerSystem 值。这些值可能为参数，这意味着这些值位于 ParameterDefaults 节点中，或者在创建实例时提供。

  5. 键入以下命令，更新 Notification Services 的实例：

    nscontrol update -in ICFPath\ICFName.xml

    具体的参数因身份验证模式的不同而异。

  6. 键入以下命令，启用 Notification Services 的实例：

    nscontrol enable -name instanceName

    具体的参数因身份验证模式的不同而异。

  7. 将任何自定义组件替换为使用 SQL Server 2005 程序集和 Microsoft .NET Framework 2.0 编译的新组件。

  8. 如果使用的是 COM interop，请重新注册核心 Notification Services 程序集。有关详细信息，请参阅如何为 COM Interop 注册核心 Notification Services 程序集。

  9. 准备好启动实例时，在每个运行 Notification Services 引擎组件的服务器上键入以下命令：

    net start NS$ instanceName

请参阅

任务

将 Notification Services 2.0 实例迁移到 SQL Server 2005
如何将 Notification Services 2.0 实例迁移到 SQL Server 2005 (SQL Server Management Studio)

其他资源

nscontrol 实用工具


如何将 Notification Services 实例迁移到更高版本 (SQL Server Management Studio)

如何将 Notification Services 实例迁移到更高版本 (SQL Server Management Studio) |
 | 请参阅
升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 > 迁移 Notification Services 帮助主题 >

如果您使用 Microsoft SQL Server 2005 的较低版本（如 Standard Edition）创建一个 Notification Services 实例，之后要升级到 SQL Server 的更高版本（如 Enterprise Edition），则必须将此 Notification Services 实例升级到更高版本。下列过程显示如何使用 SQL Server Management Studio 将 Notification Services 实例迁移到更高版本。

重要事项：
Notification Services 实例可以在许多不同配置下部署。请将下面的过程用作开发和测试您自己的迁移过程的指南。

升级到 Notification Services 的更高版本

  1. 在 SQL Server Management Studio 对象资源管理器中，展开 Notification Services。

  2. 右键单击该实例并选择“禁用”。

  3. 右键单击要迁移的实例并选择“停止”。

  4. 关闭 SQL Server Management Studio 和其他任何已打开的应用程序。

  5. 在每个安装了 Notification Services 实例的服务器上，使用安装程序将 Notification Services 升级到更高版本。

  6. 在 SQL Server Management Studio 对象资源管理器中，展开 Notification Services。

  7. 在对象资源管理器中，右键单击该实例，指向“任务”，然后选择“升级”。这样便将实例和应用程序数据库中的版本号和版本类别号升级。

  8. 右键单击该实例并选择“更新”。

    在“更新”对话框中提供请求的信息。

    确保选中“更新实例后启用它”。

  9. 右键单击该实例并选择“启动”。

请参阅

任务

将 Notification Services 实例迁移到 SQL Server 2005 的更高版本
如何将 Notification Services 实例迁移到更高版本（命令提示符）

其他资源

nscontrol 实用工具


如何将 Notification Services 实例迁移到更高版本（命令提示符）

如何将 Notification Services 实例迁移到更高版本（命令提示符） |
 | 请参阅
升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 > 迁移 Notification Services 帮助主题 >

如果使用 Microsoft SQL Server 2005 的低版本（如 Standard Edition）创建 Notification Services 的实例，并且以后要升级到 SQL Server 的更高版本（如 Enterprise Edition），则必须迁移 Notification Services 的实例以匹配数据库服务器。下列过程显示如何使用命令提示实用工具将 Notification Services 实例迁移到更高版本。

重要事项：
Notification Services 实例可以在许多不同配置下部署。请将下面的过程用作开发和测试您自己的迁移过程的指南。

升级到 Notification Services 的更高版本

  1. 在注册实例的一台服务器上禁用该实例：

    1. 在“开始”菜单上，指向“所有程序”\“Microsoft SQL Server 2005”\“配置工具”，然后单击“Notification Services 命令提示”。

    2. 键入以下命令以禁用该实例：

      nscontrol disable -name instanceName

  2. 在运行实例的每一个服务器上，键入以下命令以停止该实例：

    net stop NS$ instanceName

    如果要在自己的应用程序中承载引擎组件，请确保该实例没有运行。

  3. 在安装 Notification Services 实例的每一个服务器上，将 Notification Services 升级到更高版本。

  4. 在一台服务器上，键入以下命令以升级数据库中的元数据：

    nscontrol upgrade -name instanceName -server databaseServer

    具体参数因安全配置的不同而异。

  5. 在一台服务器上，键入以下命令以更新数据库中的元数据：

    nscontrol update -in ICFPath\ICFName.xml

    具体参数因安全配置的不同而异。

  6. 在运行 NS$instanceName Windows 服务的每一个服务器上，键入以下命令以启动该服务：

    net start NS$ instanceName

    如果要在自己的应用程序中承载引擎组件，请启动该实例。

  7. 在一台服务器上，键入以下命令以启用该实例：

    nscontrol enable -name instanceName

请参阅

任务

将 Notification Services 实例迁移到 SQL Server 2005 的更高版本
如何将 Notification Services 实例迁移到更高版本 (SQL Server Management Studio)

其他资源

nscontrol 实用工具


如何查看 Notification Services 版本信息

如何查看 Notification Services 版本信息 |
 | 请参阅
升级 SQL Server 组件 > 升级 SQL Server 组件帮助主题 > 迁移 Notification Services 帮助主题 >

Notification Services 在实例数据库中存储用于创建、更新或升级实例的 Notification Services 版本和版本类别，并在 Microsoft Windows 注册表中存储用于注册实例的版本。迁移 Notification Services 实例时，此信息将更新。

如果 Windows 注册表和实例数据库中的版本不匹配，那么 Notification Services 实例不启动。如果迁移后启动实例遇到问题，请按照下列过程验证版本和版本类别信息。

过程

查看产品和注册表版本

  • 在对象资源管理器中，右键单击 Notification Services 并选择“列出版本”。

    “列出版本”对话框只显示本地注册的实例。实例版本号为实例注册表项中的版本。
注意：
在没有安装 Microsoft SQL Server Management Studio 的服务器上，从 Notification Services 命令提示符运行 nscontrol listversions。

 查看数据库版本

  1. 在 SQL Server Management Studio 中，单击“新建查询”按钮，选择“数据库引擎查询”。

  2. 在“数据库引擎查询”窗口中运行以下查询，将 instanceDatabase 替换为实例数据库名称，将 instanceSchema 替换为实例架构名称。

    复制代码
    USE [instanceDatabase];
SELECT Top(1) *
FROM [instanceDatabase].[instanceSchema].[NSVersionInfo]
ORDER BY [VersionId] DESC;

请参阅

其他资源

nscontrol listversions 命令
查看实例、应用程序和组件的状态
@@VERSION (Transact-SQL)


向后兼容性

向后兼容性 |
 | 请参阅
升级到 SQL Server 2005 >

下列部分包含 Microsoft SQL Server 组件的向后兼容性信息。此内容包括有关不推荐使用的功能、停止使用的功能、重大更改和行为更改的信息。

本节的相关信息

主题 | 说明
SQL Server 2005 数据库引擎的向后兼容性 | 包含说明 Microsoft SQL Server 2005 中的数据库引擎 更改的一些主题，这些更改可能要求更改应用程序。
SQL Server 2005 Analysis Services 的向后兼容性 | 包含说明 SQL Server 2005 中的 SSAS 更改的一些主题，这些更改可能要求更改应用程序。
SQL Server 2005 Integration Services 的向后兼容性 | 说明 SQL Server 2005 中的 SSIS 更改，这些更改可能要求更改现有 Data Transformation Services 应用程序。
Notification Services 向后兼容性 | 说明 SQL Server 2005 中的 Notification Services 更改，这些更改可能要求更改现有 Notification Services 2.0 应用程序。
Reporting Services 的向后兼容性 | 包含说明 SQL Server 2005 中的SSRS 更改的一些主题，这些更改可能要求更改现有 Reporting Services 解决方案。
复制的向后兼容性 | 包含说明 SQL Server 2005 中的数据库引擎 更改的一些主题，这些更改可能要求更改现有复制解决方案。

请参阅

其他资源

升级 SQL Server 组件
安装 SQL Server 2005 组件


SQL Server 2005 数据库引擎的向后兼容性

SQL Server 2005 数据库引擎的向后兼容性 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 >

向后兼容性部分中的主题说明 Microsoft SQL Server 各版本之间的行为更改。

请参阅... | 有关...的主题
SQL Server 2005 中废弃的数据库引擎功能 | 此版本废止的数据库引擎 功能。
SQL Server 2005 中不推荐使用的数据库引擎功能 | 此版本不推荐使用的数据库引擎 功能。
SQL Server 2005 中数据库引擎功能的重大更改 | 可能需要更改应用程序的数据库引擎 功能更改。
SQL Server 2005 中数据库引擎功能的行为更改 | 此版本中对数据库功能的其他行为更改。

请参阅

参考

版本升级
SQL Server 2005 的各种版本所支持的功能

其他资源

sp_dbcmptlevel (Transact-SQL)


SQL Server 2005 中不推荐使用的数据库引擎功能

SQL Server 2005 中不推荐使用的数据库引擎功能
升级到 SQL Server 2005 > 向后兼容性 > SQL Server 2005 数据库引擎的向后兼容性 >

不推荐使用的功能包括在 SQL Server 的下一个版本中不再支持的功能以及在 SQL Server 的未来版本中不再受支持的功能。

在 SQL Server 的下一个版本中不再受支持的功能

在 SQL Server 的下一个版本中，将不再支持下列数据库引擎 功能。如果时间允许，建议在可能的情况下用替换项替换这些功能。

类别 | 不推荐使用的功能 | 替代功能
备份和还原 | DUMP 语句 | BACKUP
备份和还原 | LOAD 语句 | RESTORE
备份和还原 | BACKUP LOG WITH NO_LOG | 无。 如果数据库使用的是简单恢复模式，事务日志将被自动截断。如果需要从数据库删除日志备份链，请切换到简单恢复模式。
备份和还原 | BACKUP LOG WITH TRUNCATE_ONLY | 无。 如果数据库使用的是简单恢复模式，事务日志将被自动截断。如果需要从数据库删除日志备份链，请切换到简单恢复模式。
备份和还原 | BACKUP TRANSACTION | BACKUP LOG
备份和还原 | BACKUP { DATABASE | LOG } WITH PASSWORD | 无。
备份和还原 | BACKUP { DATABASE | LOG } WITH MEDIAPASSWORD | 无。
备份和还原 | RESTORE { DATABASE | LOG } … WITH DBO_ONLY | RESTORE { DATABASE | LOG } … … WITH RESTRICTED_USER
备份和还原 | RESTORE { DATABASE | LOG } WITH PASSWORD | 无。
备份和还原 | RESTORE { DATABASE | LOG } WITH MEDIAPASSWORD | 无。
兼容级别 | 60 和 65 兼容级别 | 无。
兼容级别 | 70 兼容级别 | 无。
DBCC | DBCC CONCURRENCYVIOLATION | 无。
扩展存储过程编程 | srv_getuserdata srv_setuserdata | 改用 CLR 集成。
全文搜索 | sp_fulltext_service 操作值 clean_up、connect_timeout 和 data_timeout 返回零。 | 无。
实例选项 | SET REMOTE_PROC_TRANSACTIONS sp_configure 'remote proc trans' | 使用链接服务器和分布式查询。 sp_addlinkedserver
远程服务器 | 使用远程服务器 用 sp_addserver 来创建远程服务器 | 使用链接服务器。 用 sp_addlinkedserver 来创建链接服务器
安全性 | sp_addalias sp_dropalias sp_addgroup sp_changegroup sp_dropgroup sp_helpgroup | 由角色取代
安全性 | SETUSER | EXECUTE AS

在 SQL Server 的未来版本中不再受支持的功能

在 SQL Server 的下一个版本中，这些数据库引擎 功能仍受支持，但是在未来的版本中这些功能将被删除。具体的 SQL Server 版本尚未确定。

类别 不推荐使用的功能 替代功能

备份和还原

sp_helpdevice

sys.backup_devices

排序规则

印地语

Lithuanian_Classic

SQL_AltDiction_CP1253_CS_AS

无。

Microsoft SQL Server 2005 中存在这些排序规则，但是对 fn_helpcollations 是不可见的。

兼容级别

80 兼容级别

无。

数据类型

sp_addtype

CREATE TYPE

数据类型

rowversion 数据类型的 timestamp 语法

rowversion 数据类型语法。

数据库管理

sp_attach_db

sp_attach_single_file_db

带 FOR ATTACH 选项的 CREATE DATABASE 语句；若要重新生成多个日志文件，其中的一个或多个日志文件具有新位置时，请使用 FOR ATTACH_REBUILD_LOG 选项。

数据库对象

CREATE DEFAULT

DROP DEFAULT

sp_bindefault

sp_unbindefault

CREATE/ALTER TABLE 中的 DEFAULT 关键字。

数据库对象

CREATE RULE

DROP RULE

sp_bindrule

sp_unbindrule

CREATE/ALTER TABLE 中的 CHECK 关键字。

数据库对象

sp_renamedb

ALTER DATABASE 中的 MODIFY NAME。

数据库对象

从触发器返回结果集的功能

无。

数据库选项

sp_dboption 的 'concat null yields null'

无。

数据库选项

sp_dboption

sp_resetstatus

ALTER DATABASE SET { ONLINE | EMERGENCY }

数据库选项

ALTER DATABASE 的 TORN_PAGE_DETECTION 选项

ALTER DATABASE 的 PAGE_VERIFY TORN_PAGE DETECTION 选项

DBCC

DBCC DBREINDEX

ALTER INDEX 的 REBUILD 选项。

DBCC

DBCC INDEXDEFRAG

ALTER INDEX 的 REORGANIZE 选项

DBCC

DBCC SHOWCONTIG

sys.dm_db_index_physical_stats

扩展属性

Level-0 TYPE

Level-1 TYPE

扩展属性

用 Level0type = 'USER' 向 1 级或 2 级类型的对象添加扩展属性。

用 Level0type = 'USER' 只可直接向用户或角色添加扩展属性。

用 Level0type = 'SCHEMA' 可向 1 级类型（如 TABLE 或 VIEW）或 2 级类型（如 COLUMN 或 TRIGGER）添加扩展属性。

扩展存储过程编程

srv_alloc

srv_convert

srv_describe

srv_getbindtoken

srv_got_attention

srv_message_handler

srv_paramdata

srv_paraminfo

srv_paramlen

srv_parammaxlen

srv_paramname

srv_paramnumber

srv_paramset

srv_paramsetoutput

srv_paramtype

srv_pfield

srv_pfieldex

srv_rpcdb

srv_rpcname

srv_rpcnumber

srv_rpcoptions

srv_rpcowner

srv_rpcparams

srv_senddone

srv_sendmsg

srv_sendrow

srv_setcoldata

srv_setcollen

srv_setutype

srv_willconvert

srv_wsendmsg

改用 CLR 集成。

扩展存储过程编程

sp_addextendedproc

sp_dropextendedproc

sp_helpextendedproc

改用 CLR 集成。

扩展存储过程

xp_LoginConfig

SERVERPROPERTY 的 IsIntegratedSecurityOnly 参数

全文搜索

sp_fulltext_catalog

CREATE/ALTER/DROP FULLTEXT CATALOG

全文搜索

sp_fulltext_table

sp_fulltext_column

sp_fulltext_database

CREATE/ALTER/DROP FULLTEXT INDEX

ALTER FULLTEXT INDEX

全文搜索

sp_help_fulltext_tables[_cursor]

sp_help_fulltext_columns[_cursor]

sp_help_fulltext_catalogs[_cursor]

sys.fulltext_indexes

sys.fulltext_index_columns

sys.fulltext_catalogs

函数

fn_get_sql

sys.dm_exec_sql_text

索引选项

sp_indexoption

fillfactor = 0

ALTER INDEX

fillfactor = 100

索引选项

CREATE INDEX <index_option>::= syntax

CREATE INDEX <relational_index_option>::= syntax

实例选项

disallow results from triggers 选项的默认设置 = 0

disallow results from triggers 选项的默认设置 = 1

锁定

sp_lock

sys.syslock_information

锁定

syslockinfo

sys.syslock_information

元数据

DATABASEPROPERTY

FILE_ID

INDEXKEY_PROPERTY

DATABASEPROPERTYEX

FILE_IDEX

sys.index_columns

其他

DB-Library

用于 C 语言的嵌入式 SQL

尽管 SQL Server 2005 数据库引擎 仍然支持来自使用 DB-Library 和嵌入式 SQL API 的现有应用程序的连接，但是它不包含对使用这些 API 的应用程序进行编程工作所需的文件或文档。SQL Server 数据库引擎 的未来版本将不再支持来自 DB-Library 或嵌入式 SQL 应用程序的连接。请不要使用 DB-Library 或嵌入式 SQL 来开发新的应用程序。修改现有的应用程序时，请删除 DB-Library 或嵌入式 SQL 的任何依赖项。请使用 SQLClient 命名空间或诸如 OLE DB 或 ODBC 的 API 来代替这些 API。SQL Server 2005 不包含运行这些应用程序所需的 DB-Library DLL。若要运行 DB-Library 或嵌入式 SQL 应用程序，必须有适用于 SQL Server 6.5 版、SQL Server 7.0 版或 SQL Server 2000 版的 DB-Library DLL。

查询提示

FASTFIRSTROW 提示

OPTION (FAST n)。

可删除数据库

sp_certify_removable

sp_create_removable

CREATE DATABASE

可删除数据库

sp_dbremove

DROP DATABASE

安全性

sp_addapprole

sp_dropapprole

CREATE APPLICATION ROLE

DROP APPLICATION ROLE

安全性

sp_addlogin

sp_droplogin

CREATE LOGIN

DROP LOGIN

安全性

sp_adduser

sp_dropuser

CREATE USER

DROP USER

安全性

sp_grantdbaccess

sp_revokedbaccess

CREATE USER

DROP USER

安全性

sp_addrole

sp_droprole

CREATE ROLE

DROP ROLE

安全性

sp_approlepassword

sp_password

无。

安全性

sp_changeobjectowner

ALTER SCHEMA 或 ALTER AUTHORIZATION

安全性

sp_defaultdb

sp_defaultlanguage

无。

无。

安全性

sp_denylogin

sp_grantlogin

sp_revokelogin

无。

无。

DROP LOGIN

安全性

USER_ID

FILE_ID

DATABASE_PRINCIPAL_ID

FILE_IDEX

安全性

sp_srvrolepermission

sp_dbfixedrolepermission

这些存储过程返回在 SQL Server 2000 中是正确的信息。该输出不反映在 SQL Server 2005 中实现的对权限层次结构所作的更改。有关详细信息，请参阅 SQL Server 2005 联机丛书中的“固定角色的权限”。

SET 选项

SET ANSI_NULLS

SET ANSI_PADDING

SET CONCAT_NULL_YIELDS_NULL

无。

SET 选项

SET OFFSETS

无。

SET 选项

INSERT、UPDATE 和 DELETE 语句的 SET ROWCOUNT

TOP 关键字。

系统表

sysaltfiles

syscacheobjects

syscharsets

syscolumns

syscomments

sysconfigures

sysconstraints

syscurconfigs

sysdatabases

sysdepends

sysdevices

sysfilegroups

sysfiles

sysforeignkeys

sysfulltextcatalogs

sysindexes

sysindexkeys

syslanguages

syslockinfo

syslogins

sysmembers

sysmessages

sysobjects

sysoledbusers

sysopentapes

sysperfinfo

syspermissions

sysprocesses

sysprotects

sysreferences

sysremotelogins

sysservers

systypes

sysusers

兼容性视图。有关详细信息，请参阅兼容性视图 (Transact-SQL)。

重要事项：
兼容性视图不显示 SQL Server 2005 中所引入功能的元数据。建议将应用程序升级为使用目录视图。有关详细信息，请参阅目录视图 (Transact-SQL)。

表提示

应用于 UPDATE 或 DELETE 语句的目标表时，在该语句的 FROM 子句中指定 NOLOCK 或 READUNCOMMITTED。

从 FROM 子句中删除 NOLOCK 或 READUNCOMMITTED 表提示。

Textpointers

READTEXT、WRITETEXT、UPDATETEXT

无。

Textpointers

'text in row' 表选项

使用 varchar(max)、nvarchar(max) 和 varbinary(max) 数据类型。

Textpointers

TEXT、NTEXT 和 IMAGE 数据类型

使用 varchar(max)、nvarchar(max) 和 varbinary(max) 数据类型。

Textpointers

TEXTPTR()、TEXTVALID()

无。

Transact-SQL

:: 函数调用顺序

替换为 SELECT column_list FROM sys.fn_function_name()

Transact-SQL

SELECT 列表中由 3 部分和 4 部分组成的列引用

由两部分组成的名称是符合标准的行为。

Transact-SQL

在 SELECT 列表中用作列别名的表达式字符串：

'string_alias' = expression

expression [AS] column_alias

expression [AS] [column_alias]

expression [AS] "column_alias"

expression [AS] 'column_alias'

column_alias = expression

Transact-SQL

存储过程号

sys.numbered_procedures

sys.numbered_procedure_parameters

无。

Transact-SQL

DROP INDEX 中的 table_name.index_name 语法

DROP INDEX 中的 index_name ON table_name 语法

Transact-SQL

UPDATE table1, table2, ...SET 语法

在 UPDATE 目标中指定多个表是不标准的，也是不明确的。


SQL Server 2005 中废弃的数据库引擎功能

SQL Server 2005 中废弃的数据库引擎功能
升级到 SQL Server 2005 > 向后兼容性 > SQL Server 2005 数据库引擎的向后兼容性 >

SQL Server 2005 中不支持 SQL Server 早期版本的这些数据库引擎 功能。

类别 废止的功能 替代功能

备份和还原

命名管道备份设备。

磁盘或磁带设备。

出于安全原因，SQL Server 不支持对命名管道的备份。

命令提示实用工具

isql 实用工具

使用 sqlcmd 实用工具。

注意：
sqlcmd 和 osql 实用工具不支持将存储过程返回值传递给退出值。

有关详细信息，请参阅 sqlcmd 实用工具。

配置选项

sp_configure 的 'allow updates' 选项。

存在该选项但不支持对系统表直接更新

配置选项

sp_configure 的 'open objects' 选项。

存在该选项，但其功能已停用。在 SQL Server 2005 中，打开的数据库对象的数量是动态管理的，该数量只受可用内存的限制。sp_configure 中保留了 'open objects' 选项，以确保向后兼容现有脚本。

配置选项

sp_configure 的 'set working set size' 选项

存在该选项，但其功能已停用。

数据库创建

DISK INIT

DISK RESIZE

来自 SQL Server 6.x 的早期行为

数据库创建

CREATE DATABASE 的 FOR LOAD 选项

RESTORE 操作可创建数据库

DBCC

DBCC DBREPAIR

使用 DROP DATABASE 可以删除已损坏的数据库。

有关详细信息，请参阅 DROP DATABASE (Transact-SQL)。

DBCC

DBCC NEWALLOC

DBCC CHECKALLOC

有关详细信息，请参阅 DBCC (Transact-SQL)。

DBCC

DBCC PINTABLE，DBCC UNPINTABLE

无。

DBCC

DBCC ROWLOCK

行级锁定为自动。

DBCC

DBCC TEXTALL

DBCC TEXTALLOC

DBCC CHECKDB

DBCC CHECKTABLE

扩展存储过程编程

当存在来自原始登录的模拟上下文切换时，请使用 SRV_PFIELD 结构中的 SRV_PWD 字段。

无。

网络协议

以下协议：NWLink IPX/SPX、AppleTalk、Banyan Vines 和多协议。

将您的应用程序和数据库引擎的实例配置为使用以下受支持的协议之一：TCP/IP 套接字、named pipes、VIA 或 shared memory。

有关详细信息，请参阅选择网络协议。

重新生成 master

Rebuildm.exe

在 Setup.exe 中使用 REBUILDDATABASE 选项。

有关详细信息，请参阅如何从命令提示符安装 SQL Server 2005。

示例数据库

Northwind 和 pubs

使用 AdventureWorks；但是，可通过下载或从 SQL Server 的早期版本中复制而得到 Northwind 和 pubs。

有关详细信息，请参阅示例和示例数据库。

Setup.exe

远程安装 - 不支持 TARGETCOMPUTER 参数。

使用远程连接以用户界面模式或从命令行提示符运行 SQL Server 安装程序。

API

基于 SQL-DMO 的 WMI 提供程序

托管代码：Microsoft.SqlServer.Management.Smo.Wmi

非托管代码：WMI Provider for Configuration Management

API

SQL 命名空间 API (SQL-NS)

无

Transact-SQL

*= 和 =* 外部联接运算符

使用 FROM 子句的 JOIN 语法。

有关详细信息，请参阅 FROM (Transact-SQL)。

虚拟表

syslocks

sys.dm_tran_locks

有关详细信息，请参阅 sys.dm_tran_locks。


SQL Server 2005 中数据库引擎功能的重大更改

SQL Server 2005 中数据库引擎功能的重大更改 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > SQL Server 2005 数据库引擎的向后兼容性 >

本主题介绍对 Microsoft SQL Server 2005 中的数据库引擎 所做的一些更改，这些更改可导致基于早期版本的 SQL Server 的应用程序无法继续使用。

客户端/服务器连接

功能 说明

Banyan VINES 顺序包协议 (SPP)、多协议、AppleTalk 或 NWLink IPX/SPX 网络协议

SQL Server 2005 不支持 Banyan VINES 顺序包协议 (SPP)、多协议、AppleTalk 或 NWLink IPX/SPX 网络协议。客户端应用程序必须使用受支持的协议才能连接到 SQL Server 2005 。如果设置的某个别名使用了不受支持的协议，则必须修改该别名，使其使用受支持的协议。

如果应用程序连接字符串通过以下方法之一明确地使用或加载其中一个不受支持的协议，则必须对应用程序进行修改，使其使用受支持的协议：对 RPC 指定 NETWORK=DBMSRPCN，对 Appletalk 指定 NETWORK=DBMSADSN，对 Banyan VINES 属性指定 NETWORK=DBMSVINN，或者使用显式前缀，例如：对 SPX 使用 spx:server\实例名，对 Banyan VINES 使用 bv:服务器名，对 AppleTalk 使用 adsp:服务器名，以及对多协议使用 rpc:服务器名。

有关详细信息，请参阅选择网络协议。

MDAC

MDAC 2.6 之前的 MDAC 版本不支持命名实例。若要使应用程序能够连接到命名实例，应升级到 MDAC 的当前版本。

Winsock 代理

Winsock 代理不能使用 SQL Server 工具来配置。有关如何配置 Winsock 代理的信息，请参阅代理服务器文档。

配置选项

功能 说明

AUTO_UPDATE_STATISTICS

升级任何数据库之前，请先将 AUTO_UPDATE_STATISTICS 设置为 ON。否则，升级到 SQL Server 2005 时，数据库统计信息不会随之更新。如果所依赖的统计信息来自 SQL Server 的早期版本，查询计划有可能不是最佳的。通过将 AUTO_UPDATE_STATISTICS 设置为 ON，所有统计信息都会在第一次引用时得以更新。更新统计信息会增大执行查询时选择更多最佳查询计划的可能性。

注意：
在某些情况下，将 AUTO_UPDATE_STATISTICS 设置为 ON 后，第一次引用统计信息时，更新统计信息的过程可能会影响查询的服务器性能。

若要将 AUTO_UPDATE_STATISTICS 数据库 SET 选项设置为 ON，请使用 ALTER DATABASE 语句；若要更新数据库中的统计信息，请运行 sp_updatestats。

max server memory 选项

在 SQL Server 2000 中，如果有足够的系统物理内存，SQL Server 缓冲池可以超过 max server memory 选项所指定的限制。在 SQL Server 2005 中，缓冲池无法超出 max server memory 的值。达到此限制时，查询将失败，并显示“系统内存不足”错误。

如果出现此错误，并且 max server memory 选项已设置，请增大该选项的值或将该值重置为默认值 2147483647。有关详细信息，请参阅服务器内存选项。

query governor cost limit 选项

应用 SET GOVERNOR_QUERY_COST_LIMIT 或 sp_configure 的 query governor cost limit 选项可导致在 SQL Server 的早期版本中能够正常运行的查询无法在 SQL Server 2005 中运行。出现此行为的原因是查询开销建模已更改。

请将连接或服务器实例的查询调控器开销限制设置更新为适当的值，或者将该值设置为 0，以此对查询可运行的时间段不进行任何限制。

数据库、数据和日志文件

功能 说明

压缩驱动器

SQL Server 2005 不能在压缩驱动器上创建或升级数据库。在安装 SQL Server 2005 时，请为系统数据库选择非压缩驱动器，并验证要升级的数据库不在压缩驱动器上。但是，请注意，在数据库升级之后，可以将只读数据库和只读辅助文件组放在 NTFS 压缩文件系统中。

数据文件

数据文件需要额外的磁盘空间才能处理以下更改：

  • 在每个用户数据库的 PRIMARY 文件组中，将针对数据库对象和用户权限创建和维护附加的系统元数据。例如，在早期版本的 SQL Server 中，与授权者或被授权者相关联的权限作为位图存储在单独一行中。而在 SQL Server 2005 中，位图已扩展为多行。

  • 定义为 text、ntext 或 image 数据类型的大型对象 (LOB) 列要求为每列额外增加 40 字节的磁盘空间。在每个 LOB 列的第一次更新过程中会出现这种一次性空间增长。

  • 全文文档 ID (DOCID) 映射存储在数据文件中，而不是全文目录中。

为了确保在升级和后续生产操作期间，资源能够处理大小增长的情况，我们建议您在升级到 SQL Server 2005 之前，将所有用户数据文件的自动增长设置为 ON。升级并测试工作负荷后，可能需要将自动增长设置为 OFF，或者相应地调整 FILEGROWTH 增量。有关详细信息，请参阅ALTER DATABASE (Transact-SQL)。

数据库兼容模式

在将数据库从 SQL Server 的任何早期版本升级到 SQL Server 2005 之后，该数据库将保留其现有的兼容级别。如果升级后将兼容模式改为 90，则兼容模式上的差异可能会影响应用程序。有关这些差异的详细信息，请参阅 sp_dbcmptlevel (Transact-SQL)。

数据库 ID 32767

在 SQL Server 2005 中，此数据库 ID 是保留的。请先分离该数据库，然后再升级。

文件组

必须先将 SQL Server 实例中的所有数据库的文件组设置为 READ_WRITE，然后才能升级到 SQL Server 2005。若要将文件组设置为 READ_WRITE，请使用 ALTER DATABASE。

日志文件

在 SQL Server 2005 中，事务日志文件需要额外的磁盘空间。在崩溃了的恢复的撤消阶段，SQL Server 2005 允许用户访问数据库。这是因为崩溃发生时未提交的事务将重新获取它们在崩溃前持有的所有锁。当事务回滚时，其锁有助于保护它们不受其他用户的干扰。必须在事务日志中维护此附加锁定信息。

为了确保在升级和后续生产操作期间，资源能够处理大小增长的情况，我们建议您在升级到 SQL Server 2005 之前，将所有用户日志文件的自动增长设置为 ON。升级并测试工作负荷后，可能需要将自动增长设置为 OFF，或者相应地调整 FILEGROWTH 增量。有关详细信息，请参阅ALTER DATABASE (Transact-SQL)。

model 数据库

在 SQL Server 2005 中，model 数据库包含下列更改：

  • 最小大小变大。

  • 兼容级别设置为 90。

  • PAGE_VERIFY 数据库选项设置为 CHECKSUM。

tempdb 数据库

SQL Server 2005 中的 tempdb 数据文件和日志文件需要额外的磁盘空间。为了确保在升级和后续生产操作期间，资源能够处理大小增长的情况，我们建议您在升级到 SQL Server 2005 之前，将所有 tempdb 数据文件和日志文件的自动增长设置为 ON。升级并测试工作负荷后，可能需要将自动增长设置为 OFF，或者相应地调整 FILEGROWTH 增量。

有关详细信息，请参阅解决 tempdb 中磁盘空间不足的问题。

功能

功能 说明

扩展存储过程

升级到 SQL Server 2005 后，先前未用 DLL 名称的完整路径注册的扩展存储过程可能无法运行。出现此情况的原因是：升级过程中旧的 BINN 目录没有添加到新的路径中。SQL Server 可能找不到扩展存储过程。

升级到 SQL Server 2005 前，请对每个未使用完整路径名注册的扩展存储过程执行以下步骤：

  1. 若要删除扩展存储过程，请运行 sp_dropextendedproc。

  2. 若要用完整路径名注册扩展存储过程，请运行 sp_addextendedproc。

日志传送

SQL Server 的早期版本中的日志传送与 SQL Server 2005 中的日志传送不兼容，因此无法直接升级。升级到 SQL Server 2005 后，请使用 SQL Server Management Studio 或存储过程重新配置日志传送。有关详细信息，请参阅升级 SQL Server 2000 日志传送配置。

osql 实用工具

osql 实用工具不支持 ED 和 !! 命令。从脚本中删除对 ED 和 !! 命令的引用。若要使用 ED 和 !! 命令，请改用 sqlcmd 实用工具。

SQL-DMO WMI 提供程序

SQL-DMO WMI 提供程序已废弃，现在已不可用。

SQL Mail

SQL Server 支持升级自 SQL Server 7.0 或 SQL Server 2000 的 SQL Mail；但是 SQL Server 2005 需要 Microsoft Outlook 2002 或更高版本作为邮件客户端。

注意：
后续版本的 Microsoft SQL Server 将删除该功能。请避免在新的开发工作中使用该功能，并着手修改当前还在使用该功能的应用程序。 若要从 SQL Server 2005 发送邮件，请使用数据库邮件。

SQL Mail

当使用 SQL Server 身份验证连接的客户端尝试发送包含附件的 SQL Mail 时，SQL Server 无法设置适当的安全上下文，因此将返回一个错误。为了避免此问题，请使用 Windows 身份验证。

SQL 命名空间 API (SQL-NS)

SQL 命名空间 API (SQL-NS) 已废弃，现在已不可用。

跟踪标志

在 SQL Server 2000 中，在会话 A 中设置的跟踪标志不会在已有的会话 B 中自动生效。仅当在会话 B 中首次设置了任何跟踪标志后，该跟踪标志才生效。此行为在 SQL Server 2000 中是不确定性的，而在 SQL Server 2005 中是确定性的。在 SQL Server 2005 中，在会话 A 中设置的全局跟踪标志会立即在其他并发会话中设置。

此外，在 SQL Server 2005 中，DBCC TRACEON 语句的一个附加参数用于指定跟踪标志是局部的还是全局的。如果未指定第二个参数，则在 SQL Server 2005 中，默认值为局部。这与在 SQL Server 2000 中不同，在此版本中，默认值为全局。

有关详细信息，请参阅跟踪标志 (Transact-SQL)。

跟踪标志

有些 SQL Server 2000 跟踪标志在 SQL Server 2005 中不存在。此外，一些跟踪标志在 SQL Server 2005 中的功能有所改变。升级到 SQL Server 2005 之前，应先禁用所有跟踪标志。升级之后，验证跟踪标志的功能是否保持不变。在重新启用任何跟踪标志之前，还要先验证是否仍需要该跟踪标志。

触发器

在 SQL Server 2005 中，无法对 DML 触发器中所插入和删除的表执行数据定义语言 (DDL) 语句，如 CREATE INDEX。在 SQL Server 的早期版本中，可对 inserted 和 deleted 表执行某些 DDL 语句。有关详细信息，请参阅使用插入的和删除的表。

重复的索引名称

在 SQL Server 2005 中，不允许表索引名称或视图索引名称重复。请先对重复的索引重命名，没有重复后再升级。

  1. 执行以下查询可以找到重复的索引：

    复制代码
    SELECT DISTINCT OBJECT_NAME(o.id), name
FROM sysindexes as o
WHERE EXISTS
    (SELECT name FROM sysindexes  as i
      WHERE i.id = o.id
      AND i.name = o.name and i.indid < o.indid);
  2. 使用 sp_rename 更改其中一个索引名称。由于索引名称相同，因此无法确定哪个索引将被重命名。此步骤使您可以区分这些索引。

    复制代码
    EXEC sp_rename N'table_name.index_name', N'new_index_name, N'INDEX'
  3. 通过执行以下查询来验证哪个索引被重命名了。以下查询返回所有索引，其中包括指定表或视图上的键列名：

    复制代码
    SELECT i.name AS IndexName, c.name AS ColumnName, ik.colid, ik.keyno
FROM sysindexes i
JOIN sysindexkeys ik ON i.id = ik.id and i.indid = ik.indid
JOIN syscolumns c ON c.id = ik.id and ik.colid = c.colid
WHERE i.id = OBJECT_ID('table_or_view_name')
  4. 如有必要，再次使用 sp_rename 更正索引名称。

对象名

在 SQL Server 2005 中，不能在对象名中使用 0xFFFF 字符。当数据库的数据库兼容级别为 90 时，包含此 Unicode 字符的对象名无法被访问。请重命名包含此字符的对象。

索引视图

功能 说明

函数确定性

下面的函数表达式在 SQL Server 2005 中被视为具有不确定性，因而可能会防碍索引视图的创建：

  • 对隐式转换为 datetime 和 smalldatetime 的字符串的引用。

  • 排序规则之间非 Unicode 字符数据的隐式转换。

除非兼容级别设置为 80 或更低，否则涉及将字符串隐式转换为 datetime 或 smalldatetime 的表达式在 SQL Server 2005 中被认为是不确定性的。这是因为结果取决于服务器会话的 LANGUAGE 和 DATEFORMAT 设置。例如，表达式 CONVERT (datetime, '30 listopad 1996', 113) 的结果取决于 LANGUAGE 设置，因为字符串“listopad”在不同的语句中表示不同的月份。同样地，在表达式 DATEADD(mm,3,'2000-12-01') 中，SQL Server 根据 DATEFORMAT 设置来解释字符串 '2000-12-01'。

非 Unicode 字符数据在排序规则间的隐式转换也被视为是不确定的，除非兼容级别设置为 80 或更低。

数据库兼容级别为 90 时，不允许对包含这些表达式的视图创建索引。尽管已升级的数据库中包含这些表达式的现有视图是可维护的，但是当兼容级别为 80 或 90 时，查询优化器不会在查询计划中考虑这些视图。有关设置兼容级别的信息，请参阅 sp_dbcmptlevel (Transact-SQL)。

在 SQL Server 2005 的索引视图定义中，应使用确定性的日期格式样式显式地将文字转换为首选日期类型。有关确定性的日期格式样式的列表，请参阅 CAST 和 CONVERT (Transact-SQL)。

如果在已经升级到 SQL Server 2005 的现有索引视图中使用字符串到日期的隐式转换，则应确定数据库与应用程序中的 LANGUAGE 和 DATEFORMAT 设置是一致的，以免损坏索引视图。

IGNORE_DUP_KEY

在 SQL Server 2005，对视图创建唯一聚集索引时，必须将 IGNORE_DUP_KEY 选项设置为 OFF。这是默认设置。将 IGNORE_DUP_KEY 设置为 ON 可导致索引视图损坏。

删除视图的聚集索引，然后在不指定 IGNORE_DUP_KEY 选项的情况下重新创建它。

查询提示

兼容级别为 80 时，索引视图定义中的查询提示被忽略。这会导致一些应用程序在兼容级别为 80 和 90 时的行为不同。有关详细信息，请参阅设计索引视图、创建索引视图和查询提示 (Transact-SQL)。

安全性

功能 说明

登录名

以下固定服务器角色名称在 SQL Server 2005 中是保留名称，因此不能用作用户定义的登录名：

  • sysadmin

  • serveradmin

  • setupadmin

  • securityadmin

  • processadmin

  • dbcreator

  • diskadmin

  • bulkadmin

升级到 SQL Server 2005 之前，请先执行以下步骤：

  1. 执行以下语句记录登录名的安全标识符 (SID)：

    复制代码
    SELECT name, sid
FROM master.dbo.syslogins
WHERE name IN('sysadmin', 'serveradmin','setupadmin',
 'securityadmin','processadmin', 'dbcreator','diskadmin',
 'bulkadmin')
  2. 删除登录名。

  3. 若要创建新的登录名，请使用 sp_addlogin 系统过程。在每个相应登录名的 @sid 参数中，指定步骤 1 中返回的 SID。

登录安全标识符 (SID)

在 SQL Server 2005 中，不允许安全标识符 (SID) 重复。删除重复登录名中的一个以及相关联的用户后再升级。

远程登录映射

在早期版本的 SQL Server 中，使用 sp_remoteoption 系统存储过程可以将来自 SQL Server 远程实例的登录标记为可信。但 SQL Server 2005 不支持这种标记远程登录的方法。升级到 SQL Server 2005 后，远程登录将不再被标记为可信。

请使用链接服务器和链接服务器存储过程来设置和管理远程登录。有关详细信息，请参阅链接服务器。

SQL Server 6.5 登录名

SQL Server 6.5 保存密码哈希的格式不再受支持。无法直接将旧密码升级到 SQL Server 2005。

若要启用此登录名，必须重置其密码。使用 ALTER LOGIN 可以重置密码：

复制代码
ALTER LOGIN <login name> WITH PASSWORD = '<new password>' MUST_CHANGE

除非禁用策略检查，否则将根据系统的密码复杂性策略来验证新密码。建议使用复杂的密码且不要禁用策略检查。MUST_CHANGE 选项将强制用户选择新密码。这不是必需的，但建议这样做。

使用以下查询可以标识休眠的 SQL Server 6.5 登录名：

复制代码
SELECT * FROM sysxlogins WHERE (xstatus & 2048) = 2048;
GO

sys 用户名

名称 sys 在 SQL Server 2005 中是保留名称，不能用作用户名。请换一个用户名，然后再升级到 SQL Server 2005。如果未重命名用户，则数据库在升级过程结束之后将处于可疑状态，并在使其在线之前不可用。

升级前的步骤

升级到 SQL Server 2005 之前，在包含用户 sys 的每个数据库中，执行下列操作：

  1. 创建一个新用户。

  2. 使用下列语句显示用户 sys 授予的和授予给用户 sys 的所有权限。

    复制代码
    -- Return permissions granted by user sys.
SELECT * FROM sysprotects WHERE grantor = USER_ID('sys')
-- Return permissions granted to user sys.
SELECT * FROM sysprotects WHERE uid = USER_ID('sys')
  3. 若要将 sys 拥有的所有对象的所有权转给新用户，请使用 sp_changeobjectowner。

  4. 删除用户 sys。

  5. 若要还原在步骤 2 中捕获的原始权限，请使用 GRANT 语句的 AS new_user 子句。

  6. 修改脚本以引用新用户。

升级后的步骤

如果没有在升级前重命名用户 sys，请执行以下操作：

  1. 执行 ALTER DATABASE db_name SET ONLINE 语句。数据库将处于 SINGLE_USER 模式。

  2. 执行“升级前的步骤”部分中的所有步骤。

  3. 执行 ALTER DATABASE db_name SET MULTI_USER 语句。

系统对象和元数据

功能 说明

INFORMATION_SCHEMA.COLUMNS

在 SQL Server 2005 中，INFORMATION_SCHEMA.COLUMNS 视图的 ORDINAL_POSITION 列与 COLUMNS_UPDATED 函数返回的位模式不兼容。

若要获取与 COLUMNS_UPDATED 兼容的位模式，请在查询 INFORMATION_SCHEMA.COLUMNS 视图时引用 COLUMNPROPERTY 系统函数的 ColumnID 属性，如下面的示例所示：

复制代码
SELECT TABLE_NAME, COLUMN_NAME,
    COLUMNPROPERTY(OBJECT_ID(TABLE_SCHEMA + '.' + TABLE_NAME),
    COLUMN_NAME, 'ColumnID') AS COLUMN_ID
FROM AdventureWorks.INFORMATION_SCHEMA.COLUMNS
WHERE TABLE_NAME = 'Contact';

INFORMATION_SCHEMA.SCHEMATA

在 SQL Server 的早期版本中，INFORMATION_SCHEMA.SCHEMATA 视图返回 SQL Server 实例中的所有数据库。在 SQL Server 2005 中，此视图返回数据库中的所有架构。此行为符合 SQL 标准。有关详细信息，请参阅 SCHEMATA (Transact-SQL)。

与值“%SCHEMA”匹配的 INFORMATION_SCHEMA 列名

在 SQL Server 的早期版本中，与值“%SCHEMA”匹配的 INFORMATION_SCHEMA 列名返回用户的名称。在 SQL Server 2005 中，这些列返回架构名称。数据库升级到 SQL Server 2005 后，架构名称会始终与用户名相同，因此引用这些列的任何应用程序都不会失败。但是，在数据库中实现 SQL Server 2005 用户-架构分离功能的用户应意识到，如果需要的数据是用户名而不是架构名称，其应用程序可能会失败。

有关详细信息，请参阅用户架构分离。

sp_helptrigger

SQL Server 2005 将 trigger_schema 作为最后一列添加在 sp_helptrigger 系统存储过程所返回的结果集中。检查应用程序中是否使用了 sp_helptrigger。可能需要修改应用程序以处理该附加列。另外，也可以使用 sys.triggers 目录视图。

syslockinfo 和 sp_lock

在 SQL Server 2000 中，syslockinfo 中的 rsc_objid 和 rsc_indid 列与 sp_lock 中的 objid 和 indid 列将返回一致的对象 ID 和索引 ID。而在 SQL Server 2005 中，可能会返回值 0。

在 SQL Server 2000 中，对于单个事务中的任何一个特定锁资源，syslockinfo 和 sp_lock 最多返回两行。而在 SQL Server 2005 中，如果启用了锁分区，就可以针对在一个事务中运行的同一资源返回多行。最多可返回 N + 1 行，其中，N 是 CPU 的数目。此外，在 SQL Server 2005 中，可对同一资源显示 GRANTED 和 WAITING 请求；而在 SQL Server 2000 中，不能对同一资源显示这些请求。有关详细信息，请参阅 sp_lock (Transact-SQL) 和 sys.syslockinfo (Transact-SQL)。

系统对象名与系统类型名按排序规则进行的匹配

在 SQL Server 的早期版中，系统对象名与系统类型名是按照 master 数据库的排序规则进行匹配的。在 SQL Server 2005 中，系统对象名和系统类型名自动转换为与当前数据库的排序规则相应。如果脚本或应用程序中对这些对象的引用与这些对象在目录中的出现方式不匹配，并且当前数据库的排序规则导致不匹配，则该脚本或应用程序将失败。例如，如果当前数据库的排序规则区分大小写，则语句 EXEC SP_heLP 将失败。

对系统对象的修改

SQL Server 2005 中不允许进行直接系统目录更新。尝试执行此操作将生成以下错误：

“服务器: 消息 259，级别 16，状态 1，第 1 行”

“不允许对系统目录进行即席更新。”

修改 SQL 脚本，以使用正式且有记录的 API。例如，使用 ALTER DATABASE database_name SET EMERGENCY，而不是对 sysdatabases 系统表运行 UPDATE 语句。

系统对象的删除

DROP TABLE、DROP PROCEDURE 等语句和 sp_dropextendedproc 不能用于删除系统对象，因为这些对象是部署在只读的资源数据库中的。

删除所有试图从应用程序中删除系统对象的语句。修改应用程序，使其撤消或拒绝对系统对象的 EXECUTE 权限。另外，可以使用 SQL Server 2005 中的一个外围应用配置器工具来禁用一些系统对象。例如，可使用其中一个外围应用配置器工具禁用或启用 xp_cmdshell 扩展存储过程。

sysperfinfo

在 SQL Server 2005 中，sysperfinfo 对 cntr_value 列返回一个 bigint 值。请修改使用 sysperfinfo 的应用程序，以确保其可以处理 cntr_value 列的 bigint 值。

在 SQL Server 2005 中，sysperfinfo 是一个兼容性视图。应改用 sys.dm_os_performance_counters 动态管理视图。

在搜索条件中用 'dbo' 进行查询的系统表

在 SQL Server 的早期版本中，系统对象属于 dbo，并驻留在 master 数据库中。在 SQL Server 2005 中，系统对象由 sys 拥有，并在逻辑上显示在每个数据库中。查询系统表的语句以及具有指定了用户 dbo 的搜索条件的语句都将失败。

Transact-SQL

功能 说明

@@VERSION

SQL Server 2005 比 SQL Server 2000 返回的信息更详细，其格式为：主版本号.次版本号.内部版本号.增量内部版本号。

CREATE STATISTICS

在 SQL Server 2005 中，不支持在 CREATE STATISTICS 语句中指定 WITH ROWS。请通过以下方式修改包含 WITH ROWS 的 CREATE STATISTICS 语句：在 WITH 和 ROWS 间指定 SAMPLE number，或者指定符合已公布的语法的其他选项。

DISK INIT

SQL Server 的早期版本中使用 DISK INIT 语句来创建数据库或事务日志设备，而 SQL Server 2005 中已经删除了该语句。请用等效的 CREATE DATABASE 或 ALTER DATABASE 语句替换所有出现此语句的地方。

INSERT INTO...SELECT 语句中的 UNION

当 UNION 运算符用在 INSERT 语句中时，SQL Server 2005 根据数据类型转换规则独立地转换每个 UNION 运算的数据类型。这样，UNION 操作的最后结果的数据类型将转换为 INSERT 操作的目标表中的相应列。此行为更改可能导致在您的应用程序中出现数据类型转换错误。

下面的示例演示数据类型转换错误。兼容级别为 80 以及更低时，第一个 SELECT 语句中的整数常量 1 直接转换为目标列 ReturnedValue 的数据类型，即 varchar(255)。兼容级别为 90 时，UNION 结果集的数据类型在转换为目标列之前确定。对于第一个 SELECT 语句中的第二列，数据类型被确定为 int。对于第二个 SELECT 语句中的第二列，数据类型被确定为 varchar(4)。由于 int 数据类型的优先级高于 varchar(4) 数据类型，因此当确定 UNION 结果集的数据类型时，值 test 将转换为 int 数据类型，这就会导致数据类型转换错误。

复制代码
CREATE TABLE #test(ReturnedName varchar(255) NOT NULL,
  ReturnedValue varchar(255) NULL)
INSERT INTO #test
SELECT 'col1', 1
UNION ALL
SELECT 'test', 'test'
DROP TABLE #test

UPDATETEXT

SQL Server 2005 不支持在使用同一文本指针对同一二进制大型对象 (BLOB) 进行读取和写入的 UPDATETEXT 语句中使用文本指针。请将 BLOB 复制到一个临时表或表变量，然后将值重新赋给原始列。

使用表提示时的 WITH 关键字

在 SQL Server 2005 中，除了一些例外情况之外，仅当使用 WITH 关键字指定了表提示时，查询的 FROM 子句中才支持这些提示。

有关详细信息，请参阅 FROM (Transact-SQL) 和 表提示 (Transact-SQL)。

视图定义中的 ORDER BY

在 SQL Server 2005 中，视图定义中的 ORDER BY 子句仅用于确定 TOP 子句返回的行。ORDER BY 不保证在查询视图时得到有序结果，除非在查询本身中也指定了 ORDER BY。

XML

功能 说明

OPENXML

由于 MSXML 已更改，OPENXML 不再支持非整数的位置谓词。在 SQL Server 2005 中，MSXML 3.0 是用于处理 OPENXML 查询中使用的 XPath 表达式的基础引擎。MSXML 3.0 的引擎更符合 XPath 1.0，在该引擎中，非整数值在位置谓词中的语义已更改。

例如，XPath 表达式 a[5.1] 现在将不返回任何元素，而不是返回第五个 <a> 元素。若要更正此问题，请直接使用舍入值。例如，将上面的示例改为 a[5]。

OPENXML XPath 表达式

MSXML 3.0 具有更严格的 XPath 1.0 引擎，此引擎中已删除了对下列函数的支持：

  • format-number()

  • formatNumber()

  • current()

  • element-available()

  • function-available()

  • system-property()

对于 format-number() 和 formatNumber()，可以使用 Transact-SQL。对于其他不受支持的函数，没有直接的解决方法。

用户定义类型“xml”

在 SQL Server 2005 中，xml 是保留的系统类型。请在升级前或升级后使用 sp_rename 重命名该类型，并修改应用程序，使其使用新的类型名称。

请参阅

参考

SQL Server 2005 中数据库引擎功能的行为更改
SQL Server 2005 中不推荐使用的数据库引擎功能
SQL Server 2005 中废弃的数据库引擎功能

其他资源

SQL Server 2005 数据库引擎的向后兼容性
sp_dbcmptlevel (Transact-SQL)

更改历史记录

版本 历史记录

2006 年 4 月 14 日

新增内容：
  • 在 Transact-SQL 部分中添加了有关在视图定义中使用 ORDER BY 的内容。


SQL Server 2005 中数据库引擎功能的行为更改

SQL Server 2005 中数据库引擎功能的行为更改 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > SQL Server 2005 数据库引擎的向后兼容性 >

本主题介绍某些数据库引擎 功能在 Microsoft SQL Server 2005 中与在 SQL Server 的早期版本中不同的行为更改。

备份和恢复

还原现有数据库时，SQL Server 2005 要求您在完整恢复或大容量恢复模式下还原数据库之前备份日志的尾部。除非 RESTORE 语句包含 WITH REPLACE 或 WITH STOPAT 子句，否则，在备份日志尾部前尝试还原数据库将导致错误。有关详细信息，请参阅尾日志备份。

游标

下表列出了 SQL Server 2000 中会发生而 SQL Server 2005 中不会发生的隐式游标转换。解决方法是请求特定类型的游标，而不是依赖于隐式转换。

条件 | SQL Server 2000 中转换前的游标 | 转换后的游标
查询包含内联表值函数。 | 动态/键集 | 静态
查询引用远程对象。 | 快进 | 键集
查询不包含表。 | 快进 | 静态
查询包含表函数。 | 快进 | 静态
查询包含派生表。 | 快进 | 静态
查询包含多语句表函数。 | 动态 键集 | 键集到静态 静态
查询包含虚拟表。 | 动态/键集 | 静态
查询包含带有 TOP 的视图。 | 快进 | 静态
查询包含可更新的分区视图。 | 快进 | 静态
API 游标查询包含具有唯一访问路径但不处于基表级别的索引视图。 | Keyset | 静态
API 游标查询包含没有聚集索引或唯一键的表。 | Keyset | 静态
API 游标结果集包含 text、ntext 或 image 列。 | 快进 | 动态

SQL Server 2005 不支持异步生成键集驱动的或静态的 Transact-SQL 游标。Transact-SQL 游标操作（如 OPEN 或 FETCH）通常是成批执行的，因此不需要异步生成 Transact-SQL 游标。SQL Server 2005 继续支持异步键集驱动的或静态的 API 服务器游标，但由于每个游标操作的客户端往返，因此需要注意其中的低滞后时间 OPEN。

在 SQL Server 2005 中，如果对没有唯一索引的表声明动态游标并在游标外删除行，则随后对游标的刷新会检索包含 NULL 数据的行的占位符。在 SQL Server 的早期版本中，游标不返回受影响的行。

在 SQL Server 2005 中，如果通过批处理或存储过程中的条件逻辑可以声明不同的游标，则通过游标执行的 INSERT、UPDATE 和 DELETE 语句会导致重新编译。在 SQL Server 2000 中，这些语句不会导致重新编译。

在下面的示例中，UPDATE 语句将导致模块的重新编译。

复制代码
IF(@some_condition=1)
   DECLARE c CURSOR FOR
      SELECT region FROM db.dbo.mytable ORDER BY lastname
ELSE
   DECLARE c CURSOR FOR
      SELECT postalcode FROM db.dbo.mytable ORDER BY firstname
...
FETCH NEXT FROM c
...
UPDATE db.dbo.mytable
   SET  firstname='a' WHERE CURRENT OF c

若要避免重新编译，请按以下方法重新编写该代码：

复制代码
IF (@some_condition=1)
BEGIN
   DECLARE c CURSOR FOR
     SELECT region FROM db.dbo.mytable ORDER BY lastname
   FETCH NEXT FROM c
   UPDATE db.dbo.mytable
     SET  firstname='a' WHERE CURRENT OF c
END
ELSE
BEGIN
  DECLARE c CURSOR FOR
    SELECT postalcode FROM db.dbo.mytable ORDER BY firstname
  FETCH NEXT FROM c
  UPDATE db.dbo.mytable
    SET  firstname='a' WHERE CURRENT OF c
END

在 SQL Server 2005 中，除非查询中指定了更高的锁提示，否则游标滚动锁定将获取从 S（共享）到 U（更新）的锁升级。SQL Server 2000 为滚动锁定游标透明地添加 U 锁提示。SQL Server 2005 行为可以提高并发性能，但也可能使并发游标出现死锁。使用 UPDLOCK 提示可以获得您想要的行为。有关详细信息，请参阅表提示 (Transact-SQL)。

在 SQL Server 2000 中，当游标提取缓冲区中多次出现对一个列或行值进行更新时，由于提取缓冲区大小或行在缓冲区中所处位置的原因，某个更新之外出现该值时可能不会反映这一更新。在 SQL Server 2005 中，提取缓冲区中的行更新后，无论提取缓冲区的大小或行的位置如何，这些值始终保持一致。

在 SQL Server 2000 中，涉及 UNION ALL 语句的游标会根据 UNION 中的第一个集错误地返回可更新性信息。因此，某些游标在不可更新的情况下会被报告为可更新。SQL Server 2005 将 UNION ALL 结果报告为计算结果，因此是不可更新的。如果所有游标行都来自一个表或视图，则您可以通过将使用 UNION 的查询改为使用 IN 或 OR 子句来定义可更新的游标。

在 SQL Server 2000 中，如果 CURSOR_CLOSE_ON_COMMIT 选项设为 ON，则提交事务时，连接中的所有游标都将关闭。在 SQL Server 2005 中，只有在当前事务中打开的游标才会在提交事务时关闭。在事务开始前打开的游标仍处于打开状态。

SQL Server 2000 允许使用某些无效的游标声明，并可将其转换为其他类型的游标。SQL Server 2005 不允许使用无效的声明。例如，同时请求可更新性和不区分性的游标在 SQL Server 2005 中无效，并将因出现错误而失败。

数据库、数据和日志文件

SQL Server 2000 行为 SQL Server 2005 行为

AUTO_CLOSE 数据库选项是一个同步进程，当与数据库引擎 重复建立和中断连接的应用程序访问数据库时，该选项可能会降低性能。

AUTO_CLOSE 进程是异步进程。重复打开和关闭数据库不会再降低性能。

原始分区上的文件不会自动增长；因此，os_file_name 指定原始分区时，不需要指定 MAXSIZE 和 FILEGROWTH 参数。

原始分区上的文件可以自动增长。可以指定 MAXSIZE 和 FILEGROWTH 参数。

不对每个数据库的数据文件和日志文件设置权限。

只要下列操作应用于数据库，就会对数据文件和日志文件设置权限：

创建 | 修改以添加新文件
附加 | 备份
分离 | 还原

当文件位于具有开放权限的目录中时，上述权限可以防止文件被意外篡改。有关详细信息，请参阅保护数据和日志文件的安全。

注意：
Microsoft SQL Server 2005 Express Edition 不设置数据文件和日志文件权限。

链接服务器和分布式查询

使用“SQLOLEDB”作为访问接口名称定义的链接服务器将在升级时被修改为“SQLNCLI”（SQL Native Client OLE DB 访问接口）。sys.sysservers 兼容性视图显示将“SQLNCLI”用作“SQLOLEDB”的链接服务器。SQL Server 2005 的目录视图 sys.servers 显示将“SQLNCLI”用作“SQLNCLI”的链接服务器。

当在纤程模式下运行 SQL Server 时，不支持异类查询和 OLE DB 访问接口的使用。当轻型池高级配置选项设为 1 时启用纤程模式。

SQL Native Client OLE DB 访问接口不能在进程外进行实例化。

在 SQL Server 2005 中，来自链接服务器的警告消息不会传播给客户端。下面是这些警告中最重要的一些类别：

  • 已在聚合计算中消除 NULL 值的符合 ANSI 的警告

  • 算术溢出警告

例如，如果 col1 中有 NULL 值，则下列 Transact-SQL 语句可能生成一个警告消息：

复制代码
SELECT SUM(col1)
FROM <Table>
GROUP BY col2

在 SQL Server 2000 和更早的版本中，链接服务器将警告消息传播给客户端。在 SQL Server 2005 中，链接服务器已不这样做。

在 SQL Server 2000 中，当远程存储过程由于编译时错误（如参数绑定不正确）而不能成功运行时，返回值/状态会设为 0。而当 SQL Server 2005 中出现这种情况时，返回值/状态将设为 NULL。

查询处理器体系结构

对于以下列形式提交的批处理，SQL Server 2000 与 SQL Server 2005 在重新编译期间使用参数值的方式有所不同：

  • 存储过程

  • 使用 sp_executesql

  • 预定义语句

当 SQL Server 2000 重新编译这些批处理时，它使用作为重新编译的一部分被调用的批处理所带有的参数值。当 SQL Server 2005 重新编译这些查询时，它使用恰好在导致重新编译的语句之前参数所具有的值。这些值可能不同于最初传递给该批处理的那些值。有关详细信息，请参阅重用参数和执行计划。

安全性

功能 SQL Server 2000 行为 SQL Server 2005 行为

GRANT ALL

授予所有适用的权限。

不推荐授予对象和语句的 ALL 权限。执行 GRANT ALL 后，将发生以下情况：

  • 该命令成功，但只授予用户 SQL Server 2000 中可授予的权限。

  • 收到以下消息：“ALL 权限已不再推荐使用，并且只保留用于兼容性目的。它并不表示对实体定义了 ALL 权限。”

SQL Server 2005 在各作用域内提供可用于管理用户权限的附加权限。例如，CONTROL 权限可用于为对象授予类似所有权的权限。

密码比较

SQL Server 2000 维护每个 登录密码的两种版本。一个是由用户提供的实际密码，另一个是由 将其转换为全大写字母的密码。这样可以验证不区分大小写的密码。尽管此行为方便了很多用户，但由于它减少了可能的密码数，因此使得猜密码攻击变简单了。

只存储实际密码。用户输入的密码必须与服务器中存储的密码相符。如果密码与 SQL Server 中存储的密码不符，则登录失败。如果忘记了密码字符确切的大小写，则必须重新设置密码。

更改 sa 帐户的默认语言

SQL Server sa 帐户的默认语言是在安装和升级过程中选择的语言。

在 Microsoft SQL Server 的早期版本中，通过运行 sp_configure 更改服务器的默认语言时还会更新 sa 帐户的默认语言。

若要在 SQL Server 2005 中更改 sa 帐户的默认语言，必须运行 sp_defaultlanguage 存储过程，执行 DBCC FREESYSTEMCACHE 命令，然后启动新会话。通过运行 sp_configure 更改服务器的默认语言时不会更新 sa 帐户的默认语言。

系统存储过程

下表列出了对数据库引擎 系统存储过程中的参数的更改。

存储过程 | 参数 | 更改说明
sp_bindefault | @objname | 大小从 nvarchar(517) 改为 nvarchar(776)。
sp_bindrule | @objname | 大小从 nvarchar(517) 改为 nvarchar(776)。
sp_changeobjectowner | @objname | 大小从 nvarchar(517) 改为 nvarchar(776)。
sp_detach_db | @keepfulltextindexfile | 大小从 nvarchar(517) 改为 nvarchar(776)。
sp_fulltext_service | @action | 大小从 varchar(20) 改为 nvarchar(100)。
sp_fulltext_service | @value | 数据类型从 int 改为 sql_variant。
sp_getapplock | @DbPrincipal | 添加的参数。
sp_releaseapplock | @DbPrincipal | 添加的参数。
sp_setapprole | @fCreateCookie | 添加的参数。
sp_setapprole | @cookie | 添加的参数。
sp_settriggerorder | @stmttype | 大小从 varchar(10) 改为 varchar(50)。
sp_settriggerorder | @namespace | 添加的参数。
sp_sproc_columns | @fUsePattern | 添加的参数。
sp_stored_procedures | @fUsePattern | 添加的参数。
sp_table_privileges | @fUsePattern | 添加的参数。
sp_table_privileges_ex | @fUsePattern | 添加的参数。
sp_tables | @fUsePattern | 添加的参数。
sp_tables_ex | @fUsePattern | 添加的参数。

系统表和系统视图

下表列出了对系统表和系统视图中的列的更改。

系统表或系统视图 | 列 | 更改说明
COLUMNS | ORDINAL_POSITION | 数据类型从 smallint 改为 int。
PARAMETERS | ORDINAL_POSITION | 数据类型从 smallint 改为 int。
REFERENTIAL_CONSTRAINTS | MATCH_OPTION | 大小从 varchar(4) 改为 varchar(7)。 默认值从“NONE”改为“SIMPLE”。
REFERENTIAL_CONSTRAINTS | UPDATE_RULE | 大小从 varchar(9) 改为 varchar(11)。
REFERENTIAL_CONSTRAINTS | DELETE_RULE | 大小从 varchar(9) 改为 varchar(11)。
ROUTINE_COLUMNS | ORDINAL_POSITION | 数据类型从 smallint 改为 int。
sysaltfiles | name | 数据类型从 nchar(128) 改为 sysname。
sysaltfiles | filename | 数据类型从 nchar(260) 改为 nvarchar(260)。
sysconfigures | config | 数据类型从 smallint 改为 int。
syscursorcolumns | data_type_sql | 数据类型从 smallint 改为 int。
sysfiles | name | 数据类型从 nchar(128) 改为 sysname。
sysfiles | filename | 数据类型从 nchar(260) 改为 nvarchar(260)。
sysmessages | severity | 数据类型从 smallint 改为 tinyint。
sysperfinfo | cntr_value | 数据类型从 int 改为 bigint。
sysprocesses | waittime | 数据类型从 int 改为 bigint。
sysprocesses | hostprocess | 大小从 nchar(8) 改为 nchar(10)。
sysprocesses | request_id | 添加的列。
sysprotects | columns | 大小从 varbinary(4000) 改为 varbinary(8000)。
sysservers | srvcollation | 数据类型从 int 改为 sysname。
sysservers | nonsqlsub | 添加的列。
sysoledbusers | rmtpassword | 仅返回 NULL。
sysindexes | keys | 仅返回 NULL。
sysindexes | statblob | 仅返回 NULL。
syscomments | compressed | 仅返回 0。
sysdevices | size | 仅返回 0。
sysobjects | schema_ver | 仅返回 0。
sysremotelogins | status | 仅返回 0。
sysservers | topologyx | 仅返回 0。
sysservers | topologyy | 仅返回 0。

Transact-SQL

功能 SQL Server 2000 行为 SQL Server 2005 行为

bcp 实用工具

对表具有 INSERT 和 SELECT 权限的用户可以使用 bcp 实用工具通过以下命令向该表大容量加载数据：

复制代码
bcp <target table> in
<datafile> -c -T

默认情况下，此命令对目标表禁用 CHECK 约束和触发器。

若要运行 bcp 实用工具，如果在大容量复制过程中禁用 CHECK 约束和触发器，则用户必须具有目标表的 ALTER 权限以及 INSERT 和 SELECT 权限。升级到 SQL Server 2005 后，应用程序中的 bcp 命令可能会因权限不足而失败。可以使用下列方法之一解决此问题：

  • 将受 bcp 进程影响的所有表的 ALTER TABLE 权限授予用户。

  • 修改 bcp 命令以显式强制使用 CHECK 约束和触发器，如以下命令所示：

    复制代码
    bcp <target table>
in <datafile> -c -T -h
"CHECK_CONSTRAINTS,
FIRE_TRIGGERS"

内置系统函数

每次对内置函数的引用（如 NEWID 和 RAND）都会生成不同的结果，这是因为它对每次外部查询引用都会计算一次。

外部查询可以多次引用视图或派生表的列。但是，如果这些列是通过调用函数（如 NEWID 和 RAND）定义的，则这样的多次调用会使该函数对视图或派生表内的每个实际调用只计算一次。

在子查询中对这些列的多次引用不会使这些函数被计算多次。这使您可以在子查询中重用这些函数所生成的值。

例如，在 SQL Server 2000 中，下面的查询将返回两个不同的值。在 SQL Server 2005 中，此查询返回一个值。

复制代码
SELECT Column1, Column1
      FROM (
            SELECT RAND() Column1
            FROM (
            SELECT 1 c
            UNION
            SELECT 2 c
                  ) s
            ) t

BULK INSERT

BULK INSERT 支持将使用科学计数法表示数值的字符串从字符串类型转换为十进制类型。

BULK INSERT 中使用的从字符串到十进制类型的转换所遵从的规则与 Transact-SQL CONVERT 函数遵从的规则相同。此函数拒绝使用了科学计数法表示数值的字符串。因此，BULK INSERT 将这些字符串视为无效的值并报告转换错误。有关详细信息，请参阅 BULK INSERT (Transact-SQL)。

datetime 转换

从字符串到 datetime 的转换标记为确定性转换。但是，这对于下表中列出的样式却不成立。对于这些样式，该转换取决于语言设置。

下表列出了从字符串到 datetime 的转换为不确定性转换的样式。

低于 1001的所有样式 | 106
107 | 109
113 | 130

1 样式 20 和 21 除外

SQL Server 2005 将从字符串到 datetime 的转换标记为不确定性转换。

DBCC CHECKFILEGROUP

如果指定文件组中的一个非聚集索引与另一文件组中的表相关联，则将检查该索引和另一文件组中的基表。

如果指定文件组中的一个非聚集索引与另一文件组中的表相关联，则不会检查该索引，因为基表不可用于验证。

DBCC SHOW_STATISTICS

DBCC SHOW_STATISTICS 返回的行集不包含 Name 列。

DBCC SHOW_STATISTICS 返回的第一个行集包含一个附加列，该列的标题为 Name。此列在结果集中显示为第一列。如果您的应用程序是按序号位置访问 DBCC SHOW_STATISTICS 返回的列的，请将它们改为按名称访问列。

DROP LOGIN

执行 DROP LOGIN 时，如果数据库用户映射到该登录名，则该登录名不会被删除。

执行 DROP LOGIN 时，即使数据库用户映射到该登录名，该登录名仍会被删除。

查询中的表达式

查询中不安全的表达式并不总是生成运行时异常。

查询中的表达式在 SQL Server 2005 中的计算时间有时短于它们在 SQL Server 2000 中的计算时间。此行为具有以下非常有用的优点：

  • 能够将计算列的索引和查询中与计算列表达式相同的表达式相匹配。

  • 防止出现多余的表达式计算结果。

但是，根据查询的性质和数据库中的数据，如果查询包含的现有表达式不安全，则 SQL Server 2005 中可能会出现运行时异常。这些运行时异常包括：

  • 算术异常：被零除、溢出和下溢。

  • 转换失败，如丢失精度和尝试将非数值字符串转换为数值。

  • 对一组不保证全为非空的值进行聚合。

在 SQL Server 2000 中，这些异常可能不会在使用特定数据的特定应用程序中发生。但是，由于更改统计信息而更改的查询计划可能会导致 SQL Server 2000 中出现异常。通过将查询修改为包含条件表达式（如 NULLIF 或 CASE），可以防止出现这些运行时异常。有关详细信息，请参阅故障排除查询表达式中的错误和警告。

fn_servershareddrives

public 角色的成员可以查看系统函数 fn_servershareddrives 返回的数据。

权限更改：fn_servershareddrives 要求用户对服务器具有 VIEW SERVER STATE 权限。

重要事项：
保留此 SQL Server 2000 系统函数是为了向后兼容。建议改用 sys.dm_io_cluster_shared_drives。

fn_virtualfilestats

public 角色的成员可以查看系统函数 fn_virtualfilestats 返回的数据。

权限更改：fn_virtualfilestats 要求用户对服务器具有 VIEW SERVER STATE 权限。

fn_virtualservernodes

public 角色的成员可以查看系统函数 fn_virtualservernodes 返回的数据。

权限更改：fn_virtualservernodes 要求用户对服务器具有 VIEW SERVER STATE 权限。

重要事项：
保留此 SQL Server 2000 系统函数是为了向后兼容。建议改用 sys.dm_os_cluster_nodes。

HOST_ID

HOST_ID 返回 char(8) 值。

HOST_ID 返回 char(10) 值。

索引

允许使用“SQL Server 2005 行为”列中介绍的索引。

由于 SQL Server 2005 中引入的更改，下列索引在升级过程中可能会被禁用或需要重新生成：

  • 使用 CHECKSUM(some_timestamp_column) 的计算列的索引将被禁用，因为当 Transact-SQL CHECKSUM 函数将 timestamp 列作为参数时，它的行为发生了更改。

  • 可能需要重新生成 nvarchar 或 nchar 列（使用基于土耳其语的排序规则）中包含字符值 0x3390、0x33ca 或 0x33cb 的索引，因为这些排序规则的排序行为已更改。

  • 如果视图或计算列表达式包含从字符串到 datetime 或 smalldatetime 的隐式转换，或者包含从字符串到 datetime 或 smalldatetime 的显式不确定性转换，则对这种计算列或视图的索引将被禁用。

对于因上述前两项更改而需要重新生成的索引，请使用下列操作步骤。

  1. 检查 SQL Server 错误日志中的警告消息 3801、3803 或 3804。

  2. 对基础表运行 DBCC CHECKTABLE 以验证是否存在问题。

  3. 如果 DBCC 语句的结果指示有问题存在，请使用下列方法之一重新生成该索引：

    • 带有 REBUILD 子句的 ALTER INDEX 语句

    • 带有 DROP_EXISTING 子句的 CREATE INDEX

    • DBCC DBREINDEX

  4. 使用下面的语句标识禁用的 FOREIGN KEY 约束：

    复制代码
    SELECT * FROM sys.foreign_keys
WHERE is_disabled=1;
  5. 使用 ALTER TABLE CHECK CONSTRAINT 语句启用任何 FOREIGN KEY 约束。

    重新生成关联的索引时将启用 PRIMARY KEY 和 UNIQUE 约束。必须重新生成此索引，才能启用引用 PRIMARY KEY 或 UNIQUE 约束的 FOREIGN KEY 约束。

对于因上述第三项更改而禁用的索引，请使用下列操作步骤。

  1. 使用下面的语句来标识已禁用的计算列索引：

    复制代码
    SELECT object_name(i.object_id) AS
 object_name, i.*
FROM sys.indexes AS i
JOIN sys.index_columns AS ic
ON i.index_id = ic.index_id
  AND i.object_id = ic.object_id
JOIN sys.computed_columns AS
 cc
ON ic.object_id = cc.object_id
  AND ic.column_id = cc.column_id
WHERE i.is_disabled = 1
  2. 对于计算列索引，请删除该索引，然后将计算列定义改为使用带有确定性日期格式的显式 CONVERT 函数。

  3. 对于索引视图，请删除该视图，然后使用带有确定性日期格式的显式 CONVERT 函数重新定义该视图。

  4. 重新创建已修改的计算列或视图的索引。

索引

SQL Server 2000 Developer Edition、SQL Server 2000 Standard Edition 和 SQL Server 2000 Enterprise Edition 中都支持并行索引操作。

创建、删除或重新生成索引的并行索引操作只可用在 SQL Server 2005 Developer Edition 和 SQL Server 2005 Enterprise Edition 中。

要从 SQL Server 2000 Standard Edition 升级到 SQL Server 2005 Standard Edition 的用户应了解创建、删除或重新生成索引的操作在 SQL Server 2005 Standard Edition 中是依次执行的，因此完成时间可能会稍长一些。

SELECT、INSERT、UPDATE 和 DELETE 语句不受影响。在 SQL Server 2005 Standard Edition 中，它们将并行操作。

升级到 SQL Server 2005 Standard Edition 后，请监视创建、删除或重新生成索引的操作。您可能需要调整维护脚本或计划的维护活动，以便有额外时间用于这些操作。

若要执行并行索引操作，请安装 SQL Server 2005 Enterprise Edition。

ORDER BY 子句

无论 ORDER BY 子句中的列名是否有限定，它们都将解析为选择列表中的列。

例如，以下查询执行时不会出现错误：

复制代码
USE pubs
SELECT au_fname AS 'FName',
  au_lname AS 'LName'
FROM authors a
ORDER BY a.LName

SQL Server 忽略 ORDER BY 子句中的限定符 a 并将列名 LName 解析为选择列表中的列。

限定的列名和别名解析为 FROM 子句中所列表中的列。如果 order_by_expression 未限定，则它必须在 SELECT 语句中列出的所有列中是唯一的。

例如，下面的等效查询将返回错误：

复制代码
USE AdventureWorks
SELECT FirstName AS 'FName',
 LastName AS 'LName'
FROM Person.Contact p
ORDER BY p.LName

SQL Server 不忽略 ORDER BY 子句中的限定符 p，并将列名 LName 解析为 FROM 子句中列出的表中的列。但是 FROM 子句不认为列 LName 是表 p 的列别名。

SERVERPROPERTY 函数

SERVERPROPERTY 函数中的 ProductVersion 属性的返回类型是 varchar。

SERVERPROPERTY 函数中的 ProductVersion 属性的返回类型是 nvarchar。

sp_addtype

任何用户都可以执行 sp_addtype。

用户必须是 db_ddladmin 或 db_owner 数据库角色的成员才能执行 sp_addtype。

若要使用户可以创建别名数据类型，必须进行下列更改之一：

  • 若要使用 sp_addtype，请将用户添加到 db_ddladmin 或 db_owner 数据库角色。

  • 若要使用 CREATE TYPE 创建别名数据类型，请将 CREATE TYPE 权限授予用户并将 ALTER 权限授予目标架构上的用户。

sp_altermessage

sp_altermessage 可用于指定是否要将系统消息（消息 ID < 50000 的消息）写入 Windows 应用程序日志。

sp_altermessage 不能用于更改系统消息（消息 ID < 50000 的消息）的日志记录行为。若要审核系统消息，请使用 SQL 跟踪和 User Error Message 事件类。有关详细信息，请参阅SQL 跟踪简介。

sp_changedbowner

只有 sysadmin 固定服务器角色、db_owner 固定服务器角色的成员，或者同时为 db_ddladmin 和 db_securityadmin 固定数据库角色的成员才可以执行 sp_changeobjectowner。

由于具有 db_ddladmin 和 db_securityadmin 固定数据库角色的成员资格而可以执行此存储过程的用户还必须被授予安全对象的 CONTROL 权限。在不具有目标对象的 CONTROL 权限的情况下执行 sp_changeobjectowner 将导致执行失败并引发以下错误消息：

“消息 15247，级别 16，状态 1，过程 sp_changeobjectowner，第 17 行

用户没有执行此操作的权限。”

sp_help

sp_help 返回函数的一个结果集。

sp_help 返回函数的两个结果集。附加结果集是针对函数参数的。

sysindexes

保留 sys.sysindexes 是为了向后兼容。但是，SQL Server 2005 中的更改使视图不能完全向后兼容 SQL Server 的早期版本。

系统元数据

public 角色的成员可以查询系统表并显示目录中的元数据。

查询目录的用户只能查看某些对象的元数据行，这些对象或者是用户所拥有的，或者用户对其具有某种权限，这些对象还包括因用户具有某个角色的成员资格而有权查看的对象。有关详细信息和建议的纠正操作，请参阅元数据可见性配置和元数据可见性故障排除。

系统表

系统表的类型为“S”。

系统表已成为兼容性视图，其类型为“V”。查询系统表并包含搜索条件 type = 'S' 的语句将失败。

请将语句搜索条件改为 type = 'V'。

或

迁移到新的目录视图或动态管理视图。有关详细信息，请参阅将 SQL Server 2000 系统表映射到 SQL Server 2005 系统视图。

使用 bcp、BULK INSERT 或 OPENROWSET(BULK...) 大容量导入时的 TABLOCK

大容量导入到带有非空聚集索引的表中时，将忽略 TABLOCK 提示。

大容量导入到带有非空聚集索引的表中时，TABLOCK 提示可获取表的 X 锁。该行为阻止以并行方式大容量导入数据。如果要在此情况下执行大容量并行导入，请不要使用 TABLOCK。有关以并行方式大容量加载的详细信息，请参阅优化大容量导入指南。

触发器

仅当触发器触发并执行可再次触发同一触发器的操作时，才会发生直接触发器递归。

在下列任一情况下，都会发生直接触发器递归：

  • 触发器触发并执行可再次触发同一触发器的操作。

  • 再次调用同一触发器，但在调用另一类型的触发器（AFTER 或 INSTEAD OF）之后。

当触发器触发并执行可以触发相同类型的另一触发器（AFTER 或 INSTEAD OF）的操作时，会发生间接递归。第二个触发器执行再次触发原始触发器的操作。

有关详细信息，请参阅使用嵌套触发器下的“递归触发器”部分。

触发器

在针对本地或分布式分区视图发出 UPDATE 或 DELETE 语句时，将触发在该视图的基表中定义的任何 UPDATE 或 DELETE 触发器。其中包括不受更新或删除操作影响的表中的触发器。

当针对分区视图发出 UPDATE 或 DELETE 语句时，仅当定义触发器的基表受更新或删除操作影响时才会触发 UPDATE 或 DELETE 触发器。有关详细信息，请参阅 DML 触发器执行。

UPDATE() 函数

UPDATE() 函数不检测对 timestamp 列的更改。对于这些列，触发器正文中的 IF UPDATE() 子句将返回 FALSE，而不考虑是否已更新列。

UPDATE() 函数检测对 timestamp 列的更改。对于这些列，如果它们已更新，则 DML 触发器正文中的 IF UPDATE() 子句将返回 TRUE。

用户定义函数

用户定义函数不能包含不确定性内置系统函数。

Transact-SQL 用户定义函数可包含大多数不确定性内置系统函数。有关允许的内置函数的完整列表，请参阅创建用户定义函数（数据库引擎）。

varchar、nvarchar 和 varbinary 数据类型

用作计算表列定义的零长度字符串或二进制值可创建类型为 varchar(0)、nvarchar(0) 或 varbinary(0) 的列。

用作计算表列定义的零长度字符串或二进制值可创建类型为 varchar(1)、nvarchar(2) 或 varbinary(1) 的列。这一行为更改只影响计算列的数据类型，而不影响计算值。

修改可对计算列数据类型的长度进行检查的应用程序，使 varchar 和 varbinary 列的最小长度为 1 个字节，nvarchar 列的最小长度为 2 个字节。

虚拟表访问

来宾或 public 角色的成员可以访问虚拟表。

访问虚拟表（如 sysprocesses）需要 VIEW SERVER STATE 权限和 SELECT 权限。

对视图的 WITH CHECK OPTION

允许对指定了 WITH CHECK OPTION 子句并且是对远程表创建的视图执行插入和更新操作，即使这些操作超出了视图的 SELECT 语句的范围。

对在远程数据源的表上创建的视图执行插入和更新操作时，SQL Server 2005 将确认 WITH CHECK OPTION 子句。

如果由于 WITH CHECK OPTION 子句而无法对在远程表上创建的视图执行插入和更新操作，而您不希望发生此行为，则应通过取消指定 WITH CHECK OPTION 子句来修改视图。

有关详细信息，请参阅 CREATE VIEW (Transact-SQL)、ALTER VIEW (Transact-SQL) 和通过视图修改数据。

xp_cmdshell

当 xp_cmdshell 的执行过程中出现错误时，将引发一个错误消息，但执行不会终止。

当 xp_cmdshell 的执行过程中出现错误时，将引发一个错误消息，而且执行会终止。

请参阅

参考

SQL Server 2005 中数据库引擎功能的重大更改
SQL Server 2005 中不推荐使用的数据库引擎功能
SQL Server 2005 中废弃的数据库引擎功能

其他资源

SQL Server 2005 数据库引擎的向后兼容性
sp_dbcmptlevel (Transact-SQL)

更改历史记录

版本 历史记录

2005 年 12 月 5 日

新增内容：
  • 添加了有关无效游标声明的信息。

  • 添加了“更改 sa 帐户的默认语言”内容。

  • 添加了“DBCC CHECKFILEGROUP”内容。

  • 添加了“大容量导入时的 TABLOCK”内容。

  • 添加了“触发器”内容。

已更改的内容：
  • 更正了“varchar、nvarchar 和 varbinary 数据类型”中的内容。


SQL Server 2005 和 SQL Server 2000

SQL Server 2005 和 SQL Server 2000
升级到 SQL Server 2005 > 向后兼容性 > SQL Server 2005 数据库引擎的向后兼容性 >

本部分中的主题介绍 SQL Server 2005 对下列早期组件和功能的支持：

请参阅... | 相关信息...
分布式管理对象 | 此 SQL Server 版本中对分布式管理对象的支持。
英文查询 | 此 SQL Server 版本中对英文查询的支持。
Meta Data Services | 此 SQL Server 版本中对 Meta Data Services 的支持。


分布式管理对象

分布式管理对象 |
 | 请参阅
向后兼容性 > SQL Server 2005 数据库引擎的向后兼容性 > SQL Server 2005 和 SQL Server 2000 >

Microsoft SQL Server 2005 将分布式管理对象功能作为早期组件安装。若要安装“早期组件”功能，请在 SQL Server 安装过程中，在“要安装的组件”页上单击“高级”。展开“客户端组件”功能，然后选择“早期组件”。

请参阅

参考

SQL Server 2005 的版本和组件
SQL Server 2005 的各种版本所支持的功能


英文查询

英文查询 |
 | 请参阅
向后兼容性 > SQL Server 2005 数据库引擎的向后兼容性 > SQL Server 2005 和 SQL Server 2000 >

此版本已停止使用英文查询。无法安装或升级英文查询。如果您对包含英文查询的 Microsoft SQL Server 2000 安装进行升级，则英文查询不会受影响。

请参阅

概念

SQL Server 2005 和 SQL Server 2000


Meta Data Services

Meta Data Services |
 | 请参阅
向后兼容性 > SQL Server 2005 数据库引擎的向后兼容性 > SQL Server 2005 和 SQL Server 2000 >

Meta Data Services 3.0 是 Microsoft SQL Server 2000 的组件，在 Microsoft SQL Server 2005 中已不使用。升级过程不会删除 msdb 数据库中现有的存储库表。但是，读取和更新这些表的存储库引擎在升级后已不可用，而存储库表也不再可访问。若要删除不使用的表，可手动将其删除。存储库表可由 Rtbl 前缀标识。

注意：
在删除这些表之前，请确保其中不包含要保留的 DTS 包或 SSAS 元数据。

请参阅

概念

SQL Server 2005 和 SQL Server 2000

其他资源

删除表


SQL Server 2005 Analysis Services 的向后兼容性

SQL Server 2005 Analysis Services 的向后兼容性 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 >

本部分中的各主题介绍 Microsoft SQL Server Analysis Services 的不同版本之间在行为上的更改。这些更改包括：

  • 在 Microsoft SQL Server 2000 Analysis Services 中有，但在 Microsoft SQL Server 2005 Analysis Services (SSAS) 中已删除的功能。

  • 在 SQL Server 2005 Analysis Services 中出于向后兼容的目的而保留，但在将来版本的 SQL Server 中将会删除的功能。

  • 在 SQL Server 2005 Analysis Services 中已更改的功能。

本节的相关信息

主题 | 说明
SQL Server 2005 中已废弃的 Analysis Services 功能 | 介绍在 SQL Server 2000 Analysis Services 中有，但在 SQL Server 2005 Analysis Services 中已删除的功能。
SQL Server 2005 中不推荐使用的 Analysis Services 功能 | 介绍在 SQL Server 2005 Analysis Services 中出于向后兼容的目的而保留，但在将来版本的 SQL Server 中将会删除的功能。
SQL Server 2005 中 Analysis Services 功能的行为更改 | 介绍在 SQL Server 2005 Analysis Services 中已更改的功能。
SQL Server 2005 Analysis Services 的已知升级问题 | 介绍从 SQL Server 2000 Analysis Services 升级到 SQL Server 2005 Analysis Services 时可能遇到的问题。

请参阅

概念

迁移现有 Analysis Services 数据库

其他资源

SQL Server 2005 Analysis Services 的向后兼容性


SQL Server 2005 中不推荐使用的 Analysis Services 功能

SQL Server 2005 中不推荐使用的 Analysis Services 功能 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > SQL Server 2005 Analysis Services 的向后兼容性 >

下列 Analysis Services 功能在 Microsoft SQL Server 2005 Analysis Services (SSAS) 中出于向后兼容的目的而保留，但在将来版本的 SQL Server 中会被删除。在新的应用程序中不应使用这些不推荐使用的功能。

不推荐使用的功能

类别 | 不推荐使用的功能 | 注释
连接字符串属性 | InsertInto | 用于填充本地多维数据集的原始连接字符串语法。
连接字符串属性 | CreateCube | 用于填充本地多维数据集的原始连接字符串语法。 在 ADOMD.NET 中不支持。
功能 | SQL Server 2000 PMML | 此功能已由标准预测模型标记语言 (PMML) 替换。
多维表达式 (MDX) | Create Action | 支持扩展语法，但英文语句无法创建新类型的操作。应改用 DDL。
MDX | CalculationPassValue |
MDX | CalculationCurrentPass |
数据挖掘算法 | 决策树：参数 Score_Method |
其他 | CELL_EVALUATION_LIST 内部单元属性 | SQL Server 2005 Analysis Services 中此属性为空白。

请参阅

概念

迁移现有 Analysis Services 数据库

其他资源

SQL Server 2005 Analysis Services 的向后兼容性


SQL Server 2005 中已废弃的 Analysis Services 功能

SQL Server 2005 中已废弃的 Analysis Services 功能 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > SQL Server 2005 Analysis Services 的向后兼容性 >

Microsoft SQL Server 2000 Analysis Services 中的下列功能已经从 Microsoft SQL Server 2005 Analysis Services (SSAS) 中删除。

废止的功能

类别 | 废止的功能 | 注释
连接字符串属性 | Mining Execution Location | 为实现向后兼容性，可接受此属性，但已忽略。始终在服务器上执行。
连接字符串属性 | Mining Location |
连接字符串属性 | Log File | Log File 功能已由 Trace 功能替换。
连接字符串属性 | Execution Location |
连接字符串属性 | Distinct Measures by Key |
连接字符串属性 | Large Level Threshold |
功能 | 聚合提供程序 | 此功能已由插件算法替换。
功能 | 链接多维数据集 | 此功能已由链接度量值组替换。
功能 | 自定义级别公式 | 此功能已由多维表达式 (MDX) 脚本替换。
功能 | 多维数据集和数据库角色命令 | 不再支持。
MDX | CreateVirtualDimension | 不再支持此 MDX 函数。
MDX | CreatePropertySet | 不再支持此 MDX 函数。
MDX | Ignore | 在 SQL Server 2000 Analysis Services 中，此函数保留供将来使用。
MDX | With Cache Create Cache | 接受但并不支持。
其他 | Active Directory 注册 |
其他 | 父子层次结构中的已跳过级别 | SkippedLevelsColumn 属性指示在父子层次结构中的父级下创建成员时要跳过的级别数，该属性不再受支持。

请参阅

概念

迁移现有 Analysis Services 数据库

其他资源

SQL Server 2005 Analysis Services 的向后兼容性


SQL Server 2005 Analysis Services 的已知升级问题

SQL Server 2005 Analysis Services 的已知升级问题 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > SQL Server 2005 Analysis Services 的向后兼容性 >

下表列出了将 SQL Server 2000 Analysis Services 数据库升级到 SQL Server 2005 Analysis Services (SSAS) 时可能遇到的问题。下表列出的各个升级问题以及对每个问题的简短说明与 SQL Server 2005 升级顾问生成的报表中显示的完全相同。

问题类型 | 问题说明
不迁移依赖于链接对象的对象 | 在 Microsoft SQL Server 2005 Analysis Services 中，升级顾问不迁移链接多维数据集和链接维度。因此，无法迁移引用链接多维数据集或链接维度的对象，因为无法迁移对象所基于的链接对象。
如果将多个层次结构迁移到同一个维度中，则 Autoexist 可以产生不同的查询结果 | 将多个层次结构或虚拟维度迁移到 Microsoft SQL Server 2005 Analysis Services 的同一维度内时，查询维度中包含的已迁移层次结构与查询迁移前在 SQL Server 2000 Analysis Services 中的该层次结构所产生的结果可能不同。
使用禁用的级别时，浏览体验会不同 | Microsoft SQL Server 2005 Analysis Services 不再支持层次结构中包含隐藏的或禁用的级别。隐藏的或禁用的级别迁移为可见的和启用的级别。计算时如果涉及包含此类级别的层次结构，可能会返回意外结果。
存储桶存储对于分组级别而言可能不同 | Microsoft SQL Server 2005 Analysis Services 中的自动分组可能会返回一组不同的成员组。依赖这些成员组的计算可能会返回意外的结果。
从非特定语言到特定语言的转换可能会产生意外的结果 | Analysis Services 的早期版本中使用的非特定语言的标识符在 Microsoft SQL Server 2005 Analysis Services 中被迁移为特定语言的标识符。从非特定语言迁移到特定语言的标识符会更改预期的翻译和排序规则行为，从而导致意外的结果。
不支持多维数据集角色命令 | Microsoft SQL Server 2005 Analysis Services 不支持针对多维数据集角色的命令对象，因而不会从早期版本迁移命令。
自定义级别公式以不同方式聚合 | 如果多维数据集包含带有自定义级别公式的维度，并且还包含前后都带有自定义成员公式和/或一元运算符的维度，那么该多维数据集可能会返回与早期版本的 Analysis Services 不同的结果。这是因为计算优先规则已更改。
自定义成员公式和自定义汇总公式会被迁移到 MDX 脚本中 | 在 Microsoft SQL Server 2005 Analysis Services 中，自定义汇总公式、自定义成员公式、所有成员公式和自定义级别公式不再作为维度或级别的属性得到支持。
不迁移自定义聚合 | 在 Analysis Services 的早期版本中手动生成的聚合，在 Microsoft SQL Server 2005 Analysis Services 中不会迁移。仅迁移由存储设计向导生成的聚合。
数据成员始终存在于父子维度中 | Analysis Services 的早期版本提供了不在父子维度中包括数据成员的选项。现在不再可以从父子维度中排除数据成员。
不支持数据库角色命令 | Microsoft SQL Server 2005 Analysis Services 不支持数据库角色的命令对象，因而不会从 Analysis Services 的早期版本迁移命令。
DefaultMember 已迁移到 MDX 脚本中 | 在 Analysis Services 的早期版本中，维度的默认成员由多维表达式 (MDX) 表达式（包含在该维度的 DefaultMember 属性中）指定。在 Microsoft SQL Server 2005 Analysis Services 中，此属性已由 MDX 脚本中支持的功能所取代，因而在迁移期间该属性会升级到 MDX 脚本。
迁移时对维度和层次结构的重命名可能会导致不同的查询结果 | Analysis Services 的早期版本中的维度层次结构在内部表示为单独的维度，并使用命名约定标识。迁移到 Microsoft SQL Server 2005 Analysis Services 可能会为每个维度层次结构创建一个单独的维度，并用新名称命名，而不是将父维度下的维度层次结构组合在一起，因为 auto-exist 会导致安全规则不同于 Analysis Services 的早期版本中应用的安全规则。
不迁移钻取设置 | 尽管 Microsoft SQL Server 2005 Analysis Services 中存在钻取，但不会迁移 Analysis Services 的早期版本中的钻取设置。
迁移后隐藏的级别是可见的 | Microsoft SQL Server 2005 Analysis Services 不再支持层次结构中包含隐藏的或禁用的级别。隐藏的或禁用的级别迁移为可见的和启用的级别。计算时如果涉及包含此类级别的层次结构，可能会返回意外结果。
无效对象导致迁移失败 | 数据库包含无效对象。如果数据库包含无效对象，则迁移无法完成。
不迁移链接多维数据集 | Analysis Services 的早期版本支持链接多维数据集。在 Microsoft SQL Server 2005 Analysis Services 中，此功能已由链接维度和链接度量值组所取代。
在迁移期间可能会更改成员的唯一名称 | Microsoft SQL Server 2005 Analysis Services 在迁移期间会尝试保留成员的唯一名称，但是在某些情况下会更改成员的唯一名称。如果更改了成员的唯一名称，则客户端应用程序、多维表达式 (MDX) 表达式和其他依赖于成员唯一名称的属性可能会产生意外的结果。
不支持 ODBC 数据源 | 尽管 Analysis Services 的早期版本允许使用 ODBC 数据源，但 Microsoft SQL Server 2005 Analysis Services 中不再支持此功能。
不迁移远程分区 | 在 Microsoft SQL Server 2005 Analysis Services 中支持远程分区，但是在将远程服务器升级到 SQL Server 2005 之前，不能自动迁移它们。
不支持某些挖掘模型算法参数 | 在 Microsoft SQL Server 2005 Analysis Services 中，不再支持 Analysis Services 的早期版本中的某些挖掘模型算法参数。
某些 MDX 函数的表现有所不同 | 由于 Microsoft SQL Server 2005 Analysis Services 中对多维表达式 (MDX) 语言进行了增强和更改，不再支持某些 MDX 函数或者这些函数的使用与 Analysis Services 的早期版本不同。
不支持维度安全性的顶级 | 在 Analysis Services 的早期版本中，您可以指定维度安全性，使用户看到的顶级与层次结构的顶级不同。迁移后，使用顶级设置保护的成员将可见。
不迁移也不注册 UDF 源 .dll | 不迁移在 Analysis Services 的早期版本中注册的用户定义函数 (UDF)。
对非父子层次结构上的一元运算符的支持是有限的 | 除非层次结构中以级别为源的属性之间存在属性关系，否则在 Microsoft SQL Server 2005 Analysis Services 中不支持父子层次结构之外的层次结构上的一元运算符。
不支持虚拟多维数据集 | Analysis Services 的早期版本支持虚拟多维数据集，即一个或多个常规或链接多维数据集中的度量值和维度子集的组合视图。在 Microsoft SQL Server 2005 Analysis Services 中，此功能已由链接度量值组所取代。在升级过程中，虚拟多维数据集将作为链接度量值组进行迁移。
不迁移写回表内容 | 在 Microsoft SQL Server 2005 Analysis Services 中，已经更新了由 Analysis Services 的早期版本生成的写回表的结构。由 Analysis Services 的早期版本生成的写回表中的数据无法迁移到新的写回表结构中。

请参阅

其他资源

SQL Server 2005 Analysis Services 的向后兼容性


SQL Server 2005 中 Analysis Services 功能的行为更改

SQL Server 2005 中 Analysis Services 功能的行为更改 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > SQL Server 2005 Analysis Services 的向后兼容性 >

与 Analysis Services 的早期版本相比，Microsoft SQL Server 2005 Analysis Services (SSAS) 中的某些功能的行为已发生更改。下表列出了这些更改。

行为更改

功能 | SQL Server 2000 行为 | SQL Server 2005 行为
浏览 | 支持层次结构中的隐藏或禁用级别。 | 隐藏或禁用级别迁移为可见和启用级别。计算时如果涉及包含此类级别的层次结构，则可能会返回意外结果。
维度 | 支持在父子维度中不包含数据成员的选项。 | 数据成员始终存在于父子维度中；不能再从父子维度中排除数据成员。
多维表达式 (MDX) | 函数：CreateVirtualDimension | 表达式将返回错误。
MDX | 函数：CreatePropertySet | 表达式将返回错误。
MDX | 语句：With Cache | 接受该语法，但不执行任何操作。
MDX | 语句：Create Cache | 接受该语法，但不执行任何操作。
MDX | 计算优先规则。 | 计算优先规则已更改，与 Analysis Services 的早期版本不同。 由于自定义汇总的优先级提前，表达式返回的结果可能与 Analysis Services 的早期版本返回的不同。
安全性 | 支持通过指定维度安全性使用户看到的顶级不同于层次结构的顶级。 | 不支持维度安全性的顶级。在迁移后，使用顶级设置保护的成员将可见。
其他 | 更新中自动提交和自动回滚。 | 尝试提交不存在的事务会失败。在 SQL Server 2000 Analysis Services 中，Update 语句创建它自己的事务。但在 SQL Server 2005 Analysis Services 中不会创建。

请参阅

概念

迁移现有 Analysis Services 数据库

其他资源

SQL Server 2005 Analysis Services 的向后兼容性


Reporting Services 的向后兼容性

Reporting Services 的向后兼容性 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 >

本部分介绍 SQL Server Reporting Services 各版本之间在行为方面的更改。它包括不再可用或计划在将来的版本中删除的功能。还介绍了对产品的基本更改，已知这些更改会使包含 Reporting Services 功能的自定义应用程序不能正常工作。

本节的相关信息

  • SQL Server 2005 Reporting Services 中不推荐使用的功能

  • SQL Server 2005 Reporting Services 中废弃的功能

  • SQL Server 2005 Reporting Services 中的重大更改

  • SQL Server 2005 Reporting Services 中的行为更改

请参阅

概念

升级 Reporting Services

其他资源

向后兼容性
升级 SQL Server 组件
Reporting Services 增强功能


SQL Server 2005 Reporting Services 中不推荐使用的功能

SQL Server 2005 Reporting Services 中不推荐使用的功能 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > Reporting Services 的向后兼容性 >

本主题介绍计划在下一个版本中删除的 SQL Server Reporting Services 功能。以下功能在 SQL Server 2005 中仍然可用。

SQL Server 2000 报表服务器 Web 服务端点

在此版本中，不推荐使用 SQL Server 2000 报表服务器 Web 服务端点。以前的端点被以下两个新端点所替换：ReportingService2005 和 ReportExecutionService。

这两个新端点包括以前的端点所具备的所有功能以及 SQL Server 2005 引入的新功能。有关详细信息，请参阅 SQL Server 联机丛书中的 Reporting Services 可编程性的增强功能和Report Server Web Service Endpoints。

HTML OWC 呈现扩展插件

在此版本中不推荐使用具有 Office Web 组件 (OWC) 的 HTML 呈现扩展插件。如果您使用的版本是从早期版本升级的，则该扩展插件仍然可用。新安装的版本不将 HTML OWC 呈现扩展插件作为导出选项。如果想在新安装的版本中使用不推荐使用的扩展插件，则可在 RSReportServer.config 和 RSReportDesigner.config 文件中添加条目以使该扩展插件可用。以下示例说明了必须添加的条目：

复制代码
<Extension Name="HTMLOWC" Type="Microsoft.ReportingServices.Rendering.HtmlRenderer.HtmlOWCRenderingExtension,Microsoft.ReportingServices.HtmlRendering" Visible="false"/>

HTML 3.2 呈现扩展插件

此版本中不推荐使用 HTML 呈现扩展插件中的 HTML 3.2 格式。在报表工具栏中，不能将 HTML 3.2 选作导出选项。若要以 HTML 3.2 格式呈现报表，则必须使用 Format 参数在报表 URL 上指定该格式。有关如何指定呈现扩展插件的详细信息，请参阅 SQL Server 联机丛书中的Specifying a Rendering Format in a URL。

SQL Server 2000 报表服务器 Web 服务端点的 RS 实用工具支持

在此版本的 Reporting Services 中，报表服务器脚本宿主命令行实用工具 (rs.exe) 支持早期版本的 SOAP 端点。在后续版本的产品中，将删除对该端点的支持。请尽可能在所有新的和修订的脚本中使用新 SOAP 端点。有关详细信息，请参阅 SQL Server 联机丛书中的Report Server Web Service Endpoints和 rs 实用工具。

请参阅

概念

升级 Reporting Services

其他资源

升级 SQL Server 组件
Reporting Services 的向后兼容性
向后兼容性

更改历史记录

版本 历史记录

2005 年 12 月 5 日

新增内容：
  • 不推荐使用 SQL Server 2000 报表服务器 Web 服务端点的声明。


SQL Server 2005 Reporting Services 中废弃的功能

SQL Server 2005 Reporting Services 中废弃的功能 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > Reporting Services 的向后兼容性 >

本主题介绍 SQL Server 2005 中不再可用的 SQL Server Reporting Services 功能。

Rsactivate.exe

Rsactivate.exe 是一个命令行实用工具，它用于初始化单个报表服务器实例和组成单个 Web 场的多个报表服务器实例。由于现在执行初始化和配置的方式发生了更改，所以此实用工具已过时，不再提供此功能。若要在 SQL Server 2005 中创建扩展部署，请使用 Reporting Services 配置工具。有关初始化更改的详细信息，请参阅 SQL Server 2005 Reporting Services 中的行为更改。有关将多个报表服务器配置为使用单个报表服务器数据库的详细信息，请参阅配置报表服务器扩展部署。

请参阅

概念

升级 Reporting Services

其他资源

升级 SQL Server 组件
Reporting Services 的向后兼容性
向后兼容性


SQL Server 2005 Reporting Services 中的重大更改

SQL Server 2005 Reporting Services 中的重大更改 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > Reporting Services 的向后兼容性 >

本主题介绍将破坏自定义应用程序、脚本或报表的 Reporting Services 功能的变化。

不支持 SQL Server 2000 中的报表服务器 Windows Management Instrumentation (WMI) 提供程序

Reporting Services 包括一个 WMI 提供程序，用于以编程的方式配置报表服务器的运行环境。Reporting Services 的 SQL Server 2005 版本包括一个完全替代前一版本的全新版的 WMI 提供程序。此 SQL Server 版本不支持 SQL Server 2000 中的原始版本。

对数据处理扩展插件的新身份验证限制

此 Reporting Services 版本对于如何为某些数据处理扩展插件处理凭据有新的限制：

  • 不能将 Analysis Services 数据源连接配置为使用数据库凭据。如果使用 ADOMD 包装，连接将失败。

  • 不能将 XML 数据源连接配置为使用数据库凭据。如果未指定凭据，并且未定义无人参与的执行帐户，则将通过匿名访问发出请求。

  • 如果用连接字符串传递数据库凭据，并且未配置无人参与的执行帐户，则第三方 .NET 数据处理扩展插件（例如，DB2.NET、Oracle ODP.NET 和 Teradata）在进行数据处理时将显式失败。

  • 除非配置了无人参与的执行帐户，否则在所有情况下，实现 IDBConnection（但不实现 IDBConnectionExtension）的自定义数据处理扩展插件进行数据处理时将显式失败。

  • 在由服务帐户发起连接请求的所有情况下（即，服务帐户的安全上下文用于与数据源建立网络连接），Reporting Services 都将在发送请求之前从服务帐户删除管理员特权。

若要配置无人参与的执行帐户，请使用 Reporting Services 配置工具或 rsconfig 实用工具。有关详细信息，请参阅配置用于无人参与的报表处理的帐户。

如果表达式包含对象引用，将会导致报表编译错误

如果表达式包括 Me.Value 引用，则对于使用表达式来设置项的 Action 属性的报表，将不再进行编译。升级在 Action 属性表达式中包括 Me.Value 的报表将导致编译器错误，错误的内容类似于“文本框‘textbox1’的 Value 表达式包含错误: [BC30456] 'Value' 不是 'ReportExprHostImpl.textbox1_TextBoxExprHost.DataValue1_DataValueExprHost' 的成员。(rsCompilerErrorInExpression)”。

若要避免这些错误并升级报表，必须重写 Action 表达式，用实际值表达式替换 Me.Value。下面的示例演示了如何用实际值表达式替换文本框样式的表达式中的 Me.Value：=iif(Fields!Name.Value = 0, "Solid", "None")。

对多值参数的支持可能破坏报表中的单值参数

多值参数支持是此版本中引入的新功能。如果使用的是旧的 SOAP 端点，并且您的代码获得或设置多值参数，那么，现在您将重新获得多值参数。在早期版本中，如果指定了多个参数，只会返回第一个参数。升级之后，对于您认为是单值的参数，可能会为其返回其他参数。请务必检查现有的 Render 方法调用，以确定它们使用单值还是多值参数。还应当测试所有具有参数的报表，以验证单值参数是否可以按预期的那样工作。

通过 SetReportParameters 更新参数

在早期版本中，如果要更新参数属性，必须重新指定其所有设置。如果报表包括基于查询或基于表达式的参数，则更新单个参数属性通常意味着必须重新发布该报表，否则，将导致报表在参数属性更改之后丢失基于查询的默认值。

在此版本中，可以更新参数的特定属性，而不必重置其所有属性。如果未指定 DefaultValues 属性，则默认值不再设置为空。注意，如果使用旧 SOAP 端点的应用程序代码或脚本正在处理空引用，则此更改可能会破坏这些代码或脚本。

引用 Microsoft SQL Server Analysis Services 数据处理扩展的扩展属性

在 SQL Server 2005 Reporting Services 报表中，如果需要引用 Analysis Services 数据源中某个字段的扩展键属性，则需要使用自定义字段语法 Fields!FieldName("MEMBER_KEY")。如果升级到 SQL Server 2005 Service Pack 1 (SP1)，则此语法将不再返回键值，因此也就不再需要或支持此解决方法，而是需要将对键属性的扩展字段语法的引用更改为 Fields!FieldName.Key 或 Fields!FieldName("Key")。

请参阅

概念

升级 Reporting Services

其他资源

升级 SQL Server 组件
Reporting Services 的向后兼容性
向后兼容性


SQL Server 2005 Reporting Services 中的行为更改

SQL Server 2005 Reporting Services 中的行为更改 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > Reporting Services 的向后兼容性 >

本主题描述对 SQL Server Reporting Services 功能所作的基本更改，这些更改可能会影响您的工作方式。

初始化和加密方面的更改

报表服务器 Web 服务不再用于初始化 Reporting Services 的安装。在此版本中，只有报表服务器 Windows 服务执行初始化。如果报表服务器 Web 服务需要加密或解密，它将调用报表服务器 Windows 服务来获取密钥并执行该操作。Web 服务在发出该请求之前，先执行检查以查看它本身是否作为 RSReportServer.config 文件中 WebServiceAccount 设置指定的帐户运行。如果运行 Web 服务的帐户与指定的值不匹配，则 Web 服务返回错误，指示帐户不匹配。

此初始化行为方面的更改，使报表服务器 Web 服务与报表服务器 Windows 服务之间的依赖关系更强。现在，运行报表服务器 Windows 服务是执行大多数 Web 服务操作的前提条件。有关详细信息，请参阅初始化报表服务器。

安装程序命令

在此版本中，能够通过命令行安装程序执行的操作的作用域已经缩小。命令行安装程序不能再用于同时安装和部署包含远程计算机的安装。安装程序不再部署报表服务器 Web 场安装。如果以前使用安装程序来部署 Reporting Services 安装，现在则必须使用其他工具和方法来部署该软件。如果以前创建了批处理文件和安装脚本来部署 Reporting Services 组件，则在升级后这些批处理文件和安装脚本将不能再运行。

DefaultValueQueryBased 属性现在是读写属性

DefaultValueQueryBased 属性是布尔值属性，该属性指示参数的默认值是否基于查询。在前一个版本中，此属性是只读的。此属性已被修改为接受写操作，从而可以用编程方式更新发布报表的此属性值。如果在代码中使用此属性，请一定要测试该应用程序，以验证该应用程序是否具有预期的行为。

Excel 呈现扩展插件支持二进制交换文件格式

Excel 呈现扩展插件以 Microsoft Excel 使用的本机文件格式呈现报表，从而消除了前一个版本中存在的大多数限制。

标题行高度方面的更改

在前一个版本中，多行标题中的第一行决定了该标题中所有行的行高（即：行高是固定的，其值取决于第一行的高度)。现在，行高可以是可变的。如果报表包含多行标题，升级后应检查报表以验证行高是否正确。

角色定义名称中的前导空格字符

在前一个版本中，角色定义名称中允许使用前导空格。此版本不再支持在创建的新的角色名称中使用前导空格。但是如果已经有以前导空格字符开头的角色定义，则这些角色定义将继续起作用。更改此功能是为了适应 DeleteRole 方法的行为。如果 DeleteRole 检测到角色定义名称的开头有空格，则将删除该角色。

请参阅

概念

升级 Reporting Services

其他资源

升级 SQL Server 组件
Reporting Services 的向后兼容性
向后兼容性


SQL Server 2005 Integration Services 的向后兼容性

SQL Server 2005 Integration Services 的向后兼容性 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 >

SQL Server 2005 Integration Services (SSIS) 为 Data Transformation Services (DTS) 包提供管理支持、运行时支持和设计时支持。DTS 包是使用 SQL Server 2000 工具和对象模型创建的。

  • Managing DTS packages

  • DTS 包的运行时支持

    • Installing run-time support for DTS packages

    • Running DTS packages from the command prompt

    • Running DTS packages from Integration Services packages

  • Design-time support for DTS packages

  • 迁移

    • Migrating dtsrun commands to dtexec commands

    • Migrating DTS packages to Integration Services packages

  • 有限支持

    • Support for Integration Services in SQL Server 2005 Express Edition

    • Support for Repository packages

管理 DTS 包

可以在 SQL Server Management Studio 中管理 DTS 包，而不考虑这些 DTS 包是存储在 SQL Server 2000 实例中，还是已导入到 SQL Server 2005 实例中。若要在 Management Studio 中查看 DTS 包，请连接到 SQL Server 实例，然后在 Management\Legacy\Data Transformation Services 节点下的对象浏览器中查看。

如果在 Management Studio 中选择了单个 DTS 包，则可打开该包进行编辑、迁移，也可将其导出到结构化存储文件或将其删除。

如果在 Management Studio 中选择了“Data Transformation Services”节点后，则可打开包，将其从结构化存储文件导入到 SQL Server，或者启动包迁移向导。

注意：
若要编辑 DTS 包，必需单独下载 DTS 设计器组件。请参阅Installing Design-time Support for SQL Server 2000 DTS Packages。

安装对 SQL Server 2000 DTS 包的运行时支持

可以在同一台计算机上运行 DTS 包和 SSIS 包。

如果选择安装“Integration Services”，则安装程序还将安装 DTS 包的支持组件，包括 SQL Server Management Studio 中的 DTS 运行时和 DTS 包枚举。运行时中的支持功能已增强，使 DTS 包可以访问 SQL Server 2005 数据源。

有关详细信息，请参阅如何确保对 Data Transformation Services 包的支持。

注意：
虽然选择安装 Integration Services 时会自动安装对 SQL Server 2000 Data Transformation Services (DTS) 的支持，但如果在安装期间或安装后将计算机中 SQL Server 2000 的上一实例升级为 SQL Server 2005，则将删除 DTS 所需的某些注册表和环境设置。若要还原这些设置，请在“控制面板”的“添加/删除程序”列表中找到“Microsoft SQL Server 2005 向后兼容性”，单击“更改”按钮，并在向导的“程序维护”页上选择“修复”选项。

安装的向后兼容性文件还包括 SQL Server 2000 Analysis Services 处理任务及其依赖项，即决策支持对象 (DSO)。但是，这些文件不包括 SQL Server 2000 数据挖掘预测查询任务。

从命令提示符运行 DTS 包

可以从命令提示符运行 SQL Server 2000 DTS 包。安装 DTS 运行时支持时，SQL Server 2005 Integration Services (SSIS) 会安装 SQL Server 2000 dtsrun.exe 实用工具。

从 Integration Services 包运行 DTS 包

在执行 SQL Server 2005 数据转换解决方案时，也可以运行由 SQL Server 2000 工具创建的包。Integration Services 提供执行 DTS 2000 包任务，用于从 SQL Server 2005 Integration Services 包中运行 DTS 包。

有关详细信息，请参阅执行 DTS 2000 包任务。

安装对 SQL Server 2000 DTS 包的设计时支持

SQL Server 2005 Integration Services (SSIS) 不安装 DTS 设计器。可以在 Web 下载中单独下载 DTS 包设计器的更新版本。下载 Microsoft SQL Server 2000 DTS 设计器组件。

有关管理影响 DTS 设计环境的某些 DTS 应用程序属性的信息，请参阅设置 DTS 应用程序属性。

为执行包迁移命令行

若要了解用于 SQL Server 2000 dtsrun 实用工具的命令提示符选项如何映射到用于 SQL Server 2005 dtexec 实用工具的命令提示符选项，请参阅 dtsrun 到 dtexec 的命令选项映射。

迁移 DTS 包

SQL Server 2005 提供包迁移向导，用于将 SQL Server 2000 DTS 包迁移为 Integration Services 包格式。许多包可以完全迁移到 SQL Server 2005，特别是使用任务和连接的包以及使用在 SQL Server 2005 中具有等效项的其他对象的包。通过封装无法在执行 DTS 2000 包任务内迁移的某些任务或功能，其他包也可以成功迁移。在运行包迁移向导之前，可能需要安装和运行升级顾问，以便分析现有的包是否存在预期的迁移问题。

有关升级顾问的详细信息，请参阅使用升级顾问来准备升级。

注意：
SQL Server 2005 的 Standard Edition、Enterprise Edition 和 Developer Edition 提供了包迁移向导。

注意：
对于保存在 SQL Server 7.0 实例的 msdb 数据库中的 DTS 包，升级顾问无法对其进行分析，包迁移向导无法对其进行迁移。但是，对于保存为结构化存储文件或保存在已升级到 SQL Server 2005 的 SQL Server 7.0 实例的 msdb 数据库中的 SQL Server 7.0 DTS 包，升级顾问可以对其进行分析，包迁移向导也可以对其进行迁移。

有关详细信息，请参阅迁移 Data Transformation Services 包。

SQL Server 2005 Express Edition 中对 SQL Server 2000 DTS 包的支持

SQL Server 2005 Express Edition 不包括 Integration Services，也不支持 SQL Server 2000 DTS 包。

  • 若要在 SQL Server 2005 Express Edition 服务器上运行现有 DTS 包，必须在该服务器上保留 SQL Server 2000 客户端工具或 DTS 可再分发文件，或重新安装它们。SQL Server 2005 Express Edition 不包括 DTS 运行时。

  • 若要在 SQL Server 2005 Express Edition 服务器中编辑现有 DTS 包，必须使用 SQL Server 2000，或从运行 SQL Server 2005 Workgroup Edition、Standard Edition、Enterprise Edition 或 Developer Edition 的服务器中远程编辑这些包。SQL Server 2005 Express Edition 不包括 SQL Server Management Studio 或 BI Development Studio。

  • 若要将现有 DTS 包迁移到 SQL Server 2005 Integration Services，必须使用 SQL Server 2005 Standard Edition、Enterprise Edition 或 Developer Edition。其他 SQL Server 2005 版本不包括 Integration Services 包迁移向导。

SQL Server 2005 Express Edition 附带的导入和导出实用工具不是 SQL Server 导入和导出向导，它不使用 Integration Services。

对 Meta Data Services（存储库）包的支持

SQL Server 2000 Meta Data Services（通常称为存储库）是一个不推荐使用的组件。SQL Server 2005 不安装也不使用存储库。

SQL Server 2000 Data Transformation Services (DTS) 设计器和 dtsrun.exe 实用工具继续支持保存到 Meta Data Services 中的 DTS 包。

SQL Server 2005 Integration Services 只在升级顾问和包迁移向导中支持存储库，且仅限于本地计算机上安装了 SQL Server 2000、SQL Server 2000 工具或存储库可再发行文件的情况。存储库文件存在时，升级顾问可以扫描保存到 Meta Data Services 的 DTS 包，包迁移向导也可以迁移这些 DTS 包。存储库文件不存在时，升级顾问只能扫描保存到 SQL Server 或结构化存储文件中的 DTS 包，包迁移向导也只能迁移这些 DTS 包。

Integration Services 执行 DTS 2000 包任务无法执行保存到存储库中的 DTS 包。但是，SQL Server 2000 DTS 运行时可以执行存储库包。为了解决 Integration Services 中的这一限制，可在存储库文件存在时创建新的 SQL Server 2000 DTS 包作为包装，并将此新包保存到 SQL Server 中或将其保存为结构化存储文件。使用新 DTS 包中的执行包任务可执行存储库包，使用 Integration Services 包中的执行 DTS 2000 包任务可执行新的包装包。

请参阅

概念

已知的包迁移问题

其他资源

dtsrun 到 dtexec 的命令选项映射

更改历史记录

版本 历史记录

2006 年 4 月 14 日

新增内容：
  • 添加了可以使用 SQL Server 2005 工具对 DTS 包执行的所有操作的列表

  • 添加了管理 DTS 包部分。

  • 添加了有关从命令提示符运行 DTS 包部分

  • 在迁移部分添加了有关升级顾问的注意事项。

已更改的内容
  • 提供了下载 DTS 设计器组件的链接。

2005 年 12 月 5 日

新增内容：
  • 添加了有关下载 DTS 设计器和配置其选项的信息。

  • 添加了有关迁移 dtsrun.exe 命令行的注释和链接。

  • 添加了有关从 SQL Server 7.0 中进行迁移的支持信息。


设置 DTS 应用程序属性

设置 DTS 应用程序属性 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > SQL Server 2005 Integration Services 的向后兼容性 >

对于仍需运行 SQL Server 2000 Data Transformation Services (DTS) 包的 SQL Server 2005 Integration Services (SSIS) 用户，Microsoft 提供 DTS 运行时引擎的更新版本作为 SQL Server 2005 Integration Services (SSIS) 安装程序的一部分，并提供 DTS 设计器的更新版本作为 Web 下载的一部分。SQL Server 2005 工具通过熟悉的设计器和运行时引擎提供对几乎所有 DTS 功能的访问。

但是，SQL Server 2005 工具不再提供对 DTS“包属性”对话框中应用程序范围内设置的访问，该对话框可通过在 SQL Server 2000 企业管理器中选择 Data Transformation Services 节点的弹出菜单上的“属性”来访问。本主题对这些设置以及如何以手动方式（通过编辑适用的注册表项）或编程方式（通过在可修改注册表项的 DTS 对象模型中调用相应的方法）来配置设置进行了说明。

DTS 应用程序属性

本主题中讨论了以下 DTS 应用程序属性：

高速缓存：启用高速缓存（复选框）

缓存可用任务、转换、脚本语言以及 OLE DB 访问接口的列表，以提高性能。

高速缓存：刷新高速缓存（按钮）

刷新上述缓存列表。

设计器：在 DTS 设计器中显示多阶段抽取

启用高级选项的显示，这些选项允许单独配置数据转换的特定阶段（如“源数据前”或“转换失败时”）的高级选项的显示。

调试：启用实时调试

为自定义任务的开发人员启用调试。

元数据服务：允许保存到元数据服务

允许将包保存到元数据服务（存储库）。

注意：
SQL Server 2005 中限制对存储库的支持。有关详细信息，请参阅 SQL Server 2005 Integration Services 的向后兼容性中的“元数据服务（存储库）包”。

在注册表中设置 DTS 应用程序属性

若要通过直接修改注册表来手动启用或禁用以下 DTS 应用程序属性，请在父键 HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\80\DTS\Settings 下将以下 REG_DWORD 值设置为 0（启用）或 1（禁用）：

启用高速缓存

TasksCache

TransformationsCache

ScriptingLanguagesCache

OLEDBProvidersCache

在 DTS 设计器中显示多阶段抽取

DesignerSettings

启用实时调试

JITDebug

注意：
不能通过编辑注册表值来刷新高速缓存。只能以编程方式来刷新高速缓存。

若要通过直接修改注册表来手动启用或禁用以下 DTS 应用程序属性，请在父键 HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\80\DTS\Settings 下将以下 REG_DWORD 值设置为 0（启用）或 1（禁用）：

允许保存到元数据服务

EnableSaveToRepository

注意：
当启用“允许保存到元数据服务”属性时，“包属性”对话框将显示以下警告：“警告: 保存到元数据服务的包应视为不安全。确实要允许将包保存到元数据服务吗?”

示例注册表脚本

将以下注册表脚本保存到扩展名为 .reg 的文本文件中并运行时，该脚本可启用此主题中讨论的所有 DTS 应用程序属性。若要禁用这些属性，请将新值从 00000001 更改为 00000000。

复制代码
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\80\DTS\Settings]
"TasksCache"=dword:00000001
"TransformationsCache"=dword:00000001
"ScriptingLanguagesCache"=dword:00000001
"OLEDBProvidersCache"=dword:00000001
"DesignerSettings"=dword:00000001
"JITDebug"=dword:00000001

[HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\80\DTS\Settings]
"EnableSaveToRepository"=dword:00000001

在 DTS 对象模型中设置 DTS 应用程序属性

若要以编程方式启用或禁用以下 DTS 应用程序属性，请将 DTS Application 对象的下列值设置为 True（启用）或 False（禁用）。

启用高速缓存

.TaskInfos.UseCache

.TransformationInfos.UseCache

.ScriptingLanguageInfos.UseCache

.OLEDBProviderInfos.UseCache

启用实时调试

.JITDebug

若要以编程方式启用或禁用以下 DTS 应用程序选项，请将 DTS Application 对象的下列值设置为 DTSDesignerSettings 枚举中的相应值：

  • 启用 - DTSDesignerSettings.DTSDesigner_ShowMultiPhaseTransforms

  • 禁用 - DTSDesignerSettings.DTSDesigner_Default

在 DTS 设计器中显示多阶段抽取

.DesignerSettings

使用 DTS 对象模型无法设置“允许保存到元数据服务”属性的值。可以使用 .NET Framework 类库的 Microsoft.Win32 命名空间中的 Registry 类来设置该属性，如以下示例所示。

示例代码

当编译并运行以下用于控制台应用程序的示例代码时，可启用此主题中讨论的所有 DTS 应用程序属性。若要禁用这些选项，请将新值从 True 更改为 False，并将 DesignerSettings 属性的值更改为 DTSDesignerSettings.DTSDesigner_Default。

该应用程序要求引用 Microsoft DTSPackage Object Library (COM)。

只能通过直接修改注册表来设置“允许保存到元数据服务”选项的值。

复制代码
Imports Microsoft.Win32
Imports DTS

Module SetDTSProperties

  Sub Main()

    Const SETTINGS_ROOT_KEY As String = "Software\Microsoft\Microsoft SQL Server\80\DTS\Settings"
    Const METADATASERVICES_VALUE As String = "EnableSaveToRepository"

    Dim dtsApp As New DTS.Application
    Dim keySettingsRoot As RegistryKey

    With dtsApp
      .TaskInfos.UseCache = True
      .TransformationInfos.UseCache = True
      .ScriptingLanguageInfos.UseCache = True
      .OLEDBProviderInfos.UseCache = True
      .DesignerSettings = DTSDesignerSettings.DTSDesigner_ShowMultiPhaseTransforms
      .JITDebug = True
    End With

    keySettingsRoot = Registry.LocalMachine.OpenSubKey(SETTINGS_ROOT_KEY, True)
    If keySettingsRoot Is Nothing Then
      keySettingsRoot = Registry.LocalMachine.CreateSubKey(SETTINGS_ROOT_KEY)
    End If
    With keySettingsRoot
      .SetValue(METADATASERVICES_VALUE, Math.Abs(CType(True, Integer)))
      .Close()
    End With

  End Sub

End Module
复制代码
using Microsoft.Win32;
using DTS;

class SetDTSProperties
{

  public static void Main()
  {

    const string SETTINGS_ROOT_KEY = "Software\\Microsoft\\Microsoft SQL Server\\80\\DTS\\Settings";
    const string METADATASERVICES_VALUE = "EnableSaveToRepository";

    DTS.Application dtsApp = new DTS.Application();
    RegistryKey keySettingsRoot;

    {
      dtsApp.TaskInfos.UseCache = true;
      dtsApp.TransformationInfos.UseCache = true;
      dtsApp.ScriptingLanguageInfos.UseCache = true;
      dtsApp.OLEDBProviderInfos.UseCache = true;
      dtsApp.DesignerSettings = DTSDesignerSettings.DTSDesigner_ShowMultiPhaseTransforms;
      dtsApp.JITDebug = true;
    }

    keySettingsRoot = Registry.LocalMachine.OpenSubKey(SETTINGS_ROOT_KEY, true);
    if (keySettingsRoot==null)
    {
      keySettingsRoot = Registry.LocalMachine.CreateSubKey(SETTINGS_ROOT_KEY);
    }
    {
      keySettingsRoot.SetValue(METADATASERVICES_VALUE, Math.Abs((int) true));
      keySettingsRoot.Close();
    }

  }

}

可将以下子例程添加到应用程序，以在适当的时候刷新高速缓存。缓存的值存储在注册表中的 HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\80\DTS\Enumeration 下。

复制代码
  Private Sub RefreshCache()

    Me.Cursor = Cursors.WaitCursor
    With dtsApp
      .TaskInfos.Refresh()
      .TransformationInfos.Refresh()
      .ScriptingLanguageInfos.Refresh()
      .OLEDBProviderInfos.Refresh()
    End With
    Me.Cursor = Cursors.Default

  End Sub
复制代码
  private void RefreshCache()
  {

    this.Cursor = Cursors.WaitCursor;
    {
      dtsApp.TaskInfos.Refresh();
      dtsApp.TransformationInfos.Refresh();
      dtsApp.ScriptingLanguageInfos.Refresh();
      dtsApp.OLEDBProviderInfos.Refresh();
    }
    this.Cursor = Cursors.Default;

  }

请参阅

概念

SQL Server 2005 Integration Services 的向后兼容性
升级或迁移 Data Transformation Services


Notification Services 向后兼容性

Notification Services 向后兼容性 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 >

下列各部分列出了在 SQL Server 2005 Notification Services 中可能影响现有 Notification Services 应用程序的更改。

不推荐使用的功能

下列 Notification Services API 中的类及与其关联的显式接口定义已不推荐使用，并已被 Notification Services 管理对象 (NMO) 类替换。

不推荐使用的类 | 替换 NMO 类
ApplicationEnumeration | ApplicationCollection
DeliveryChannel | DeliveryChannel
DeliveryChannelEnumeration | DeliveryChannelCollection
EventClass | EventClass
EventClassEnumeration | EventClassCollection
InstanceEnumeration | InstanceCollection
NotificationClass | NotificationClass
NotificationClassEnumeration | NotificationClassCollection
NSInstanceDescription | Instance
Protocol | NotificationClassProtocol
ProtocolEnumeration | NotificationClassProtocolCollection
SubscriptionClass | SubscriptionClass
SubscriptionClassEnumeration | SubscriptionClassCollection

已停止使用的功能

在 SQL Server 2005 中未停止使用 Notification Services 2.0 的任何功能

重大更改

SQL Server 2005 Notification Services 包含某些更改，在升级到 SQL Server 2005 时这些更改将导致现有 Notification Services 2.0 应用程序停止工作。下表包含已知重大更改的列表。

重大更改 | 说明
已删除 Notify() 函数。 | 在 Notification Services 2.0 中，必须在生成通知的订阅规则中使用 Notify() 函数。由于安全和性能的原因，已删除 Notify()。有关详细信息，请参阅将 Notification Services 2.0 实例迁移到 SQL Server 2005。
必须重新编译自定义组件。 | 在 SQL Server 2005 中，Notification Services 程序集的强名称已更改。其结果是，必须重新编译所有自定义事件提供程序、内容格式化程序、传递协议以及用 Notification Services API 生成的自定义应用程序。重新编译这些组件或应用程序时，请使用 SQL Server 2005 程序集和 .NET Framework 2.0。
Notification Services 实例必须使用数据库引擎 的同一版本。 | Notification Services 2.0 实例必须使用 SQL Server 2000 数据库引擎。SQL Server 2005 Notification Services 实例必须使用 SQL Server 2005 数据库引擎。将数据库引擎 升级到 SQL Server 2005 后，必须将 Notification Services 的实例迁移到 SQL Server 2005。有关详细信息，请参阅将 Notification Services 2.0 实例迁移到 SQL Server 2005。

行为更改

对 SQL Server 2005 Notification Services 没有重大的行为更改。

请参阅

概念

迁移 Notification Services 实例
安装 SQL Server Notification Services


复制的向后兼容性

复制的向后兼容性 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 >

向后兼容性部分中的主题说明 Microsoft SQL Server 复制各版本之间的行为更改。如果要升级或者在复制拓扑中有 SQL Server 的多个版本，那么了解向后兼容性是十分重要的。

主题 | 说明
SQL Server 2005 复制中不推荐使用的功能 | Microsoft SQL Server 2005 中为实现向后兼容而保留、但在 SQL Server 未来版本中将删除的复制功能。
SQL Server 2005 复制中已废弃的功能 | Microsoft SQL Server 2000 中存在、但在 SQL Server 2005 中已删除的复制功能。
SQL Server 2005 复制中的行为更改 | SQL Server 2005 中已更改的复制功能。
SQL Server 2005 复制中的重大更改 | 可能需要更改应用程序的复制功能更改。
在复制拓扑中使用 SQL Server 的多个版本 | 在复制拓扑中使用 SQL Server 多个版本时的注意事项。

请参阅

概念

升级复制数据库


SQL Server 2005 复制中不推荐使用的功能

SQL Server 2005 复制中不推荐使用的功能 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > 复制的向后兼容性 >

本主题介绍在将来的版本中将被删除的复制功能。这些功能在 Microsoft SQL Server 2005 中可用，但建议尽可能使用其他功能。

注意：
在“安装帮助”文档和 SQL Server 2005 联机丛书中可以查看本主题。对于“安装帮助”文档中显示为粗体文本的主题链接来说，所指向的主题仅在联机丛书中提供。

影响所有复制类型的不推荐使用的功能

在 SQL Server 2005 中不推荐使用以下功能（这些功能应用于所有复制类型）。

功能 说明

可附加订阅

此功能可在部署大量请求订阅（这在合并复制中很常见）时使用。在 SQL Server 2005 中，建议使用以下方法而不是可附加订阅：

  • 对于使用参数化筛选器分区的合并复制，建议使用分区快照的新功能，这些功能可简化大量订阅的初始化。有关详细信息，请参阅带有参数化筛选器的合并发布的快照。

  • 对于未分区的发布，可以使用备份来初始化订阅。有关详细信息，请参阅初始化合并订阅（不使用快照）和初始化事务订阅（不使用快照）。

在上述两种情况下，您可以通过编写脚本来自动创建大量的订阅：创建一个订阅；将其编写为脚本；对每个订阅服务器修改该脚本；然后在每个订阅服务器上应用该脚本以创建订阅。有关详细信息，请参阅编写复制脚本。

有关可附加订阅的详细信息，请参阅可附加的订阅。

匿名订阅

不推荐为 sp_addmergepullsubscription (Transact-SQL) 的 @subscriber_type 参数或为 sp_addpullsubscription (Transact-SQL) 的 @subscription_type 参数指定 anonymous 值。

在 SQL Server 2005 中，如果您要创建订阅而不在发布服务器上注册该订阅，则需要值 anonymous。如果在订阅配置期间无法建立到发布服务器的 SQL Server 连接，则需要匿名订阅。在 SQL Server 的未来版本中，这种情况将不再需要 anonymous 设置。

订阅服务器注册

不推荐使用存储过程 sp_addsubscriber (Transact-SQL)。不再要求在发布服务器上显式注册订阅服务器。

SQL 分布式管理对象 (SQL-DMO)

现有代码将继续起作用，但 SQL-DMO 不支持 SQL Server 2005 中的新功能。请改用复制管理对象 (RMO)。有关详细信息，请参阅Programming with Replication Management Objects。

使用 sp_repladdcolumn 和 sp_repldropcolumn 的架构更改

不推荐使用存储过程 sp_repladdcolumn (Transact-SQL) 和 sp_repldropcolumn (Transact-SQL)。请改用架构更改复制。有关详细信息，请参阅对发布数据库进行架构更改。

存储过程不能用于添加或删除数据类型为 SQL Server 2005 中所引入的数据类型的列：XML、varchar(max)、nvarchar(max)、varbinary(max) 或用户定义类型 (UDT)。

校验和验证

校验和验证应仅用于运行 Microsoft SQL Server 7.0 版的订阅服务器。对于运行较新版本的 SQL Server 订阅服务器，使用二进制校验和验证。也可以对所有 SQL Server 订阅服务器（包括版本 7.0 的订阅服务器以及从 Oracle 发布服务器订阅发布的订阅服务器）使用行计数验证。有关详细信息，请参阅验证已复制的数据。

添加发布到 Active Directory

不推荐使用 sp_addpublication (Transact-SQL) 或 sp_addmergepublication (Transact-SQL) 的 @add_to_active_directory 参数向 Active Directory 中添加发布。已不再允许通过在 Active Directory 中查找发布来订阅发布。

-UseInprocLoader 参数

不推荐使用分发代理和合并代理的这一参数，因为它与 XML 数据类型不兼容。如果不复制 XML 数据，则可以使用此参数。有关详细信息，请参阅Replication Distribution Agent和Replication Merge Agent。

不推荐使用的事务复制功能

SQL Server 2005 中不推荐使用以下事务复制功能。

功能 | 说明
事务复制的订阅过期 | 不推荐使用 sp_addpublication (Transact-SQL) 的 @retention 属性。订阅如果在最大分发保持期（sp_adddistributiondb (Transact-SQL) 的 @max_distretention 属性）内未同步，则仍会标记为不活动，必须重新初始化。有关保持期的详细信息，请参阅订阅过期和停用。
对事务发布的“no sync”订阅 | 如果 sp_addsubscription (Transact-SQL) 参数的 @sync_type 参数指定为 none 值，则订阅是“no sync”订阅。如果要指定订阅数据库中已存在必要的架构和数据，则请为此参数指定值 replication support only。有关详细信息，请参阅初始化事务订阅（不使用快照）。
ODBC 订阅服务器 | 对于非 SQL Server 订阅服务器，请改用 OLE-DB。有关所支持的订阅服务器的信息，请参阅非 SQL Server 订阅服务器。
可转换的订阅 | 此功能可通过存储过程接口使用，但此功能的支持已从用户界面中删除。使用此功能要求安装 Microsoft SQL Server 2000 Data Transformation Services (DTS)。有关详细信息，请参阅SQL Server 2005 Integration Services 的向后兼容性。有关可转换订阅的详细信息，请参阅转换已发布数据。
包含快照发布的可更新订阅 | 仍支持包含事务发布的可更新订阅。有关详细信息，请参阅事务复制的可更新订阅。
分发 ActiveX 控件 | 此控件使您可以在应用程序中嵌入分发代理。改用 RMO。有关详细信息，请参阅Synchronizing Subscriptions (RMO Programming)。
复制分发服务器接口 | 在 SQL Server 2000 中，复制分发服务器接口提供在分发服务器上的分发数据库中存储复制事务的接口。可用此接口启用从非 SQL Server 数据库发布（需要增加自定义编程以跟踪发布服务器上的更改）。不推荐使用此功能支持，但现有代码在从 SQL Server 2000 升级的服务器上仍可以使用。有关详细信息，请参阅 SQL Server 2000 联机丛书中的“复制分发服务器接口引用”。 SQL Server 2005 支持从 Oracle 数据库发布，无须自定义编程。有关详细信息，请参阅 Oracle 发布概述。

不推荐使用的合并复制功能

SQL Server 2005 不推荐使用以下合并复制功能。

功能 说明

可选同步伙伴

备用同步伙伴功能使您可以指定订阅服务器可与之同步的备用发布服务器。有关详细信息，请参阅备用同步伙伴。

在 SQL Server 2005 中，建议将合并复制与数据库镜像一起使用，而不是与备用同步伙伴一起使用。有关详细信息，请参阅复制和数据库镜像。

合并 ActiveX 控件

此控件使您可以在应用程序中嵌入合并代理。改用 RMO。有关详细信息，请参阅Synchronizing Subscriptions (RMO Programming)。

多列 UPDATE 选项

当合并复制执行更新时，它会更新一个 UPDATE 语句中所有更改的列，并将未更改的列重置为其原始值。另外，它还可以发出多条 UPDATE 语句，每个已更改的列一条。多列 UPDATE 语句的效率通常更高。

在早期版本的 SQL Server 中，建议为 fast_multicol_updateproc 项目选项指定 false 值以处理多列更新（一条 UPDATE 语句）可能效率较低的情况：

  • 大部分更新涉及少量的列。

  • 未更改列的索引维护量很大，因为这些列在更新发生时被重置。

由于 SQL Server 中的性能改进，这些情况不再需要此选项。

请参阅

概念

复制的向后兼容性

其他资源

复制增强


SQL Server 2005 复制中已废弃的功能

SQL Server 2005 复制中已废弃的功能 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > 复制的向后兼容性 >

本主题说明已在 Microsoft SQL Server 2005 中停止使用的复制功能。

注意：
在“安装帮助”文档和 SQL Server 2005 联机丛书中可以查看本主题。对于“安装帮助”文档中显示为粗体文本的主题链接来说，所指向的主题仅在联机丛书中提供。

影响所有复制类型的停止使用的功能

以下复制功能已在 SQL Server 2005 中停止使用。

功能 | 说明
在“新建订阅向导”中创建推送订阅而不连接到订阅服务器 | 现在，在“新建订阅向导”中创建推送订阅需要在配置过程中指向订阅服务器的活动连接。有关使用此向导的详细信息，请参阅如何创建推送订阅 (SQL Server Management Studio)。
使用文件传输协议 (FTP) 初始化运行 SQL Server 7.0 版的订阅服务器 | 此功能对运行 SQL Server 2000 或更高版本的订阅服务器可用。有关详细信息，请参阅通过 FTP 传输快照。
在 Windows 同步管理器中创建订阅 | 无法再在同步管理器中创建订阅，但仍然可以同步订阅。有关详细信息，请参阅 Windows 同步管理器。
通过在 Active Directory 中定位发布，来对其订阅 | 不推荐使用 sp_addpublication (Transact-SQL) 或 sp_addmergepublication (Transact-SQL) 的 @add_to_active_directory 参数向 Active Directory 中添加发布。已不再允许通过在 Active Directory 中查找发布来订阅发布。
快照 ActiveX 控件 | 利用该控件，可以将快照代理嵌入到应用程序中。请改用新的托管快照代理。有关详细信息，请参阅 SnapshotGenerationAgent 和How to: Create the Initial Snapshot (RMO Programming)。
远程代理激活 | SQL Server 2000 支持在另一台计算机上运行分发代理或合并代理，然后使用 DCOM 远程激活该代理。对于运行 SQL Server 2005 及更高版本的分发服务器，已停止使用此支持；对于运行更早 SQL Server 版本的分发服务器，不推荐使用此支持。有关详细信息，请参阅 SQL Server 2000 联机丛书中的“远程代理激活”。
Microsoft Access (Jet 4.0) 订阅服务器 | Jet 是 Access 使用的基础数据库，在 SQL Server 2000 中，复制支持对 Jet 数据库的订阅。未来版本将不支持这些订阅。 我们推荐改用 Microsoft SQL Server 2005 Express Edition。Access 可以将 SQL Server 数据库用作后端，SQL Server 数据库不受此问题的影响。有关详细信息，请参阅将数据复制到 SQL Server Express。

已停止使用的事务性复制功能

以下事务性复制功能已在 SQL Server 2005 中停止使用。

功能 | 说明
排队更新订阅的 Microsoft 消息队列 (MSMQ) 选项 | 利用排队更新订阅，将订阅服务器中的更改写入队列；然后，队列读取器代理从该队列中读取更改并将其传递到发布服务器。在 SQL Server 2000 中，订阅可以使用 SQL Server 队列或 MSMQ 对更改进行排队。队列的类型是由 sp_addpublication (Transact-SQL) 的 @queue_type 参数指定的，允许的值为 sql 和 msmq。在 SQL Server 2005 中，只允许使用 sql 值。在升级期间，使用 MSMQ 的现有发布将被改为使用 SQL Server 队列。如果某些应用程序依赖于使用 MSMQ 的排队更新，那么需要重写这些应用程序以适应 SQL Server 队列。有关排队更新订阅的详细信息，请参阅事务复制的可更新订阅。

已停止使用的合并复制功能

以下合并复制功能已在 SQL Server 2005 中停止使用。

功能 | 说明
从 SQL Server 2005 Express Edition 发布 | SQL Server MSDE 可以用作合并发布的发布服务器。SQL Server Express 可替换 MSDE，但不能用作发布服务器。它可以订阅合并发布、事务性发布和快照发布。具有更新订阅的合并复制和事务复制均允许将更改从订阅服务器传播回发布服务器。有关复制到 SQL Server Express 的详细信息，请参阅将数据复制到 SQL Server Express。
IVBCustomResolver 接口 | 该接口允许使用 Visual Basic 编写基于 COM 的自定义冲突解决程序。在 SQL Server 2005 中，建议使用业务逻辑处理程序，而不使用基于 COM 的冲突解决程序。有关详细信息，请参阅在合并同步期间执行业务逻辑。 还可以使用 C++ 编写基于 COM 的冲突解决程序。有关详细信息，请参阅基于 COM 的自定义冲突解决程序。

请参阅

概念

复制的向后兼容性

其他资源

复制增强


SQL Server 2005 复制中的重大更改

SQL Server 2005 复制中的重大更改 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > 复制的向后兼容性 >

本主题介绍可能需要更改应用程序的复制功能更改。

注意：
在“安装帮助”文档和 SQL Server 2005 联机丛书中可以查看本主题。对于“安装帮助”文档中显示为粗体文本的主题链接来说，所指向的主题仅在联机丛书中提供。

影响所有复制类型的重大更改

下列重大更改适用于 Microsoft SQL Server 2005 中的所有复制类型。

功能 说明

复制脚本所需的更改

复制代理安全模型相对 Microsoft SQL Server 2000 已更改。有关安全模式的详细信息，请参阅复制代理安全性模式。如果您是 SQL Server 2005 中的 sysadmin 固定服务器角色的成员，当运行用 SQL Server 2000 或 SQL Server 7.0 创建的复制脚本时，脚本可以正确执行。如果您是 dbo 固定数据库角色或其他角色的成员，则脚本会失败，必须升级。有关升级脚本的信息，请参阅How to: Upgrade Replication Scripts (Replication Transact-SQL Programming)。虽然不需要升级由 sysadmin 角色的成员执行的脚本，但为了利用安全性增强功能，建议对其进行升级。

复制代理的本地连接

升级到 SQL Server 2005 时，所有使用 SQL Server 身份验证的本地连接都改为使用 Windows 身份验证。本地连接是指某代理与和它运行在同一计算机上的 SQL Server 实例建立的连接。例如，请求订阅的合并代理运行在订阅服务器上，因此它与订阅服务器建立的连接为本地连接。

在早期版本的 SQL Server 中，默认情况下，代理在 SQL Server 代理服务帐户的上下文中运行。升级后，在此帐户的上下文中建立本地连接。SQL Server 2005 可以细粒度控制复制代理运行并与数据库及其他资源建立 Windows 集成连接所用的每个帐户；可为每个代理指定不同的帐户。升级后，建议为每个代理指定不同的帐户。有关详细信息，请参阅升级复制数据库和复制代理安全性模式。

ActiveX 控件

所有 ActiveX 控件对于编写脚本和初始化都标记为是不安全的。

SQL Server 2005 中没有快照代理 ActiveX 控件。请改用新的托管快照代理。有关详细信息，请参阅 SnapshotGenerationAgent 和How to: Create the Initial Snapshot (RMO Programming)。

distributor_admin 帐户的密码

不再支持发布服务器和远程分发服务器之间的可信连接，因为这些连接不要求密码（在 SQL Server 2000 Service Pack 3 之前的版本中，默认情况下使用可信连接）。如果使用远程分发服务器，则在升级到 SQL Server 2005 之前，将可信连接转换为不可信连接（此问题不会影响使用本地分发服务器的发布服务器）。有关 distributor_admin 帐户的详细信息，请参阅保护分发服务器的安全。

确定要使用的连接的类型

  • 在分发服务器上执行 sp_helpdistpublisher (Transact-SQL)。如果 trusted 列中的值为 1，则必须更改为不可信连接。

更改为不可信连接

  1. 在分发服务器上执行 sp_changedistpublisher (Transact-SQL)，将参数 @property 的值指定为“trusted”，将参数 @value 的值指定为“False”。

    注意：
    某些版本的 SQL Server 2000 联机丛书中未列出“trusted”作为 @property 的有效值。它对于所有的 SQL Server 2000 版本都有效。

  2. 在发布服务器和分发服务器上都执行 sp_changedistributor_password (Transact-SQL)，为参数 @password 指定强密码。

SQL Server Express 不包含 SQL Server 代理

如果升级到 SQL Server Express Edition (SQL Server Express)，必须重新配置复制同步，因为 SQL Server Express 不包含 SQL Server 代理。

如果要使用请求订阅，则必须使用复制管理对象 (RMO)、Windows 同步管理器，或在命令行上运行复制代理，以此来同步这些订阅。有关详细信息，请参阅将数据复制到 SQL Server Express。

如果要继续使用 SQL Server 代理来运行复制代理作业，则必须使用推送订阅或者升级到其他版本的 SQL Server（除 SQL Server Express 和 Microsoft SQL Server Mobile 以外的所有包括 SQL Server 代理的版本）。在使用推送订阅的情况下，分发代理或合并代理将在分发服务器中运行，因此 SQL Server 代理是可用的（SQL Server Express 不能作为分发服务器）。

Microsoft Access (Jet 4.0) 订阅服务器

Jet 是 Access 使用的基础数据库，在 SQL Server 2000 中，复制支持对 Jet 数据库的订阅。未来版本将不支持这些订阅。

建议改用 Microsoft SQL Server 2005 Express Edition。Access 可以将 SQL Server 数据库用作后端，SQL Server 数据库不受此问题的影响。有关详细信息，请参阅将数据复制到 SQL Server Express。

事务复制的重大更改

以下重大更改适用于 SQL Server 2005 中的事务复制。

功能 说明

排队更新订阅的 Microsoft 消息队列 (MSMQ) 选项

利用排队更新订阅，将订阅服务器中的更改写入队列；然后，队列读取器代理从该队列中读取更改并将其传递到发布服务器。在 SQL Server 2000 中，订阅可以使用 SQL Server 队列或 MSMQ 对更改进行排队。队列的类型是由 sp_addpublication (Transact-SQL) 的 @queue_type 参数指定的，允许的值为 sql 和 msmq。在 SQL Server 2005 中，只允许使用 sql 值。在升级期间，使用 MSMQ 的现有发布将被改为使用 SQL Server 队列。如果某些应用程序依赖于使用 MSMQ 的排队更新，那么需要重写这些应用程序以适应 SQL Server 队列。有关排队更新订阅的详细信息，请参阅事务复制的可更新订阅。

如果在升级 SQL Server 时正在运行 MSMQ 服务，则升级操作将会删除现有的 MSMQ 订阅队列。

重要事项：
在 Windows 2000 和 Windows XP 中，还必须正在运行 Microsoft 分布式事务处理协调器 (MSDTC) 服务，因为在这些平台上 MSMQ 需要 MSDTC。

如果未运行 MSMQ 服务，则在升级完成之后应手动删除队列。有关删除队列的详细信息，请参阅 Windows 文档。

合并复制的重大更改

以下重大更改适用于 SQL Server 2005 中的合并复制。

功能 | 说明
从 SQL Server 2005 Express Edition 发布 | SQL Server MSDE 可以用作合并发布的发布服务器。SQL Server Express 可替换 MSDE，但不能用作发布服务器。它可以订阅合并发布、事务性发布和快照发布。具有更新订阅的合并复制和事务复制均允许将更改从订阅服务器传播回发布服务器。有关复制到 SQL Server Express 的详细信息，请参阅将数据复制到 SQL Server Express。
批处理更改 | 在早期版本的 SQL Server 中，合并代理所做的更改是逐行执行的。在 SQL Server 2005 中，为提高性能，更改是成批执行的；因此，可以在一个语句内插入、更新或删除多行。如果发布数据库或订阅数据库中任何已发布的表都有触发器，请确保这些触发器可以处理插入、更新和删除多行的操作。有关详细信息，请参阅DML 触发器的多行注意事项。
冲突表的重新创建 | 升级到 SQL Server 2005 时重新创建冲突表，将 DBO 作为表的所有者。如果 SQL Server 2000 中的其他用户拥有某些表，则可能需要修改应用程序。 合并复制会以 conflict_PublicationName_ArticleName 命令格式为发布中的每个项目创建一个冲突表。升级时会重新创建所有元数据表，而且在 DBO 架构中创建所有冲突表。
分配的新标识范围 | 对于使用自动标识范围管理的表，复制可能在升级过程中分配新标识范围。如果某些表分配给订阅服务器的标识范围大于分配给发布服务器的标识范围，则复制会给发布服务器分配与订阅服务器的相等的范围。 若要确定用于每个项目的范围，请在发布数据库中执行 sp_helpmergearticle (Transact-SQL)，并检查 pub_identity_range 列和 identity_range 列。

请参阅

概念

复制的向后兼容性

其他资源

复制增强


SQL Server 2005 复制中的行为更改

SQL Server 2005 复制中的行为更改 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > 复制的向后兼容性 >

此主题说明 Microsoft SQL Server 2000 中存在的复制功能中的行为更改。有关复制功能增强的信息，请参阅复制增强。

注意：
在“安装帮助”文档和 SQL Server 2005 联机丛书中可以查看此主题。对于“安装帮助”文档中显示为粗体文本的主题链接来说，所指向的主题仅在联机丛书中提供。

影响所有复制类型的行为更改

下列更改影响所有复制类型。

功能 | 说明
复制代理安全模式 | 在 SQL Server 的早期版本中，默认情况下，代理在 SQL Server 代理服务帐户的上下文中运行。Microsoft SQL Server 2005 可以精细地控制每一个帐户，在其中复制代理运行并建立对数据库和其他资源的 Microsoft Windows 集成连接；对每一个代理，可以指定一个不同的帐户。有关详细信息，请参阅复制的安全注意事项和复制代理安全性模式。有关此更改如何影响升级的信息，请参阅升级复制数据库的“新复制代理安全模式”部分和 SQL Server 2005 复制中的重大更改。
Windows 同步管理器 | 在 SQL Server 的早期版本中，默认情况下启用以同步管理器同步订阅的功能。在 SQL Server 2005 中，如果要使用同步管理器，必须显式启用此选项。有关详细信息，请参阅如何使用 Windows 同步管理器同步订阅（Windows 同步管理器）。
复制冲突查看器 | 在 SQL Server 2000 中，复制冲突查看器被打包，以用于重新分发。在 SQL Server 2005 中，不对该查看器进行单独打包。若要在应用程序中包含复制冲突查看器，必须在部署了该应用程序的计算机中安装 Microsoft .NET Framework 2.0，还必须将若干文件复制到该计算机。有关详细信息，请参阅升级顾问帮助中的“其他复制升级问题”。有关升级顾问的详细信息，请参阅使用升级顾问来准备升级。

事务复制的行为更改

下列更改会影响事务复制。

功能 说明

订阅服务器对象所有权

使用 SQL Server 2005 新建发布向导创建发布时，订阅服务器上创建的对象的所有者默认为发布服务器上相应对象的所有者的值。在早期版本中，在订阅服务器上创建对象的过程中不指定所有者；它默认为与用以连接到订阅服务器的分发代理帐户相关联的所有者。该行为对存储过程 sp_addarticle (Transact-SQL) 保持不变。

可更新订阅安全模式

sp_link_publication (Transact-SQL) 的 @security_mode 参数控制即时更新订阅的触发器如何在发布服务器上执行调用。在 SQL Server 2005 中，此参数的选项有：

  • 0：使用 SQL Server 身份验证，以存储过程中指定的登录名作为登录名和密码。

  • 1：使用在订阅服务器上进行更改的用户的安全上下文（SQL Server 身份验证或 Windows 集成身份验证）。

  • 2：使用现有的、用户定义的链接服务器登录名。

在 SQL Server 的早期版本中，选项 0 用于指定从订阅服务器到发布服务器的动态远程过程调用 (RPC)，而不是链接服务器。

合并复制的行为更改

下列更改影响合并复制。

功能 说明

发布兼容级别

在 SQL Server 的早期版本中，如果启用了需要更高兼容级别的功能，则兼容级别会自动增加。在 SQL Server 2005 中，必须先将兼容级别手动设置为 90RTM，然后才能启用要求该兼容级别的功能。For more information, see the "Compatibility Level for Merge Publications" section of 在复制拓扑中使用 SQL Server 的多个版本.

补偿操作

在 SQL Server 的早期版本中，在同步期间遇到错误（如违反约束）时采取补偿操作。此行为在某些情况下很合适，但在某些情况下可能会带来问题；例如，一个未正确配置的订阅服务器发生错误时，可导致撤消对发布服务器和所有其他订阅服务器的更改。

在 SQL Server 2005 中，sp_addmergearticle (Transact-SQL) 的 @compensate_for_errors 参数控制是否采取补偿操作。当设置为 False（默认值）时，禁用补偿操作；但是，仍将错误记录到日志中，且后续合并将继续尝试应用更改。虽然受影响的行中的数据可能表面上不收敛，但只要解决了错误，更改就可以应用，数据亦将收敛。当设置为 True 时，同步期间无法在节点上应用的更改会导致补偿操作，而这些补偿操作会撤消所有其他节点上的更改。

注意：
如果项目的源表已在另一个发布中发布，则两个项目的 @compensate_for_errors 值必须相同。对于运行 SQL Server 2000 8.00.858 版本和更早版本（包括 Service Pack 3）的订阅服务器上的请求订阅，即使将 @compensate_for_errors 设置为 False，仍会发生补偿操作。

冲突表

在 SQL Server 的早期版本中，合并复制为发布中的每一个表项目创建单个冲突表，其名称形式为 conflict_<项目名称>。在 SQL Server 2005 中，该信息包含在两个表中：MSmerge_conflicts_info 和一个名称形式为 MSmerge_conflict_<发布名称>_<项目名称> 的表。

基于保持期的元数据清除

SQL Server 2005 使用基于保持期的元数据清除，这是在 SQL Server 2000 Service Pack 1 中引入的。元数据定期从下列系统表中删除掉：

  • MSmerge_contents

  • MSmerge_tombstone

  • MSmerge_genhistory

  • 任何前映像表（如果存在）。如果发布上启用了 @keep_partition_changes 同步优化选项（有关此选项的详细信息，请参阅下一节），则存在前象表。

@keep_partition_changes 参数

在 SQL Server 的早期版本中，@keep_partition_changes 参数默认情况下设置为 False，因为它导致在发布服务器上存储更多数据。现在，如果发布兼容级别为 90RTM 或更高，且 @use_partition_groups 参数设置为 False，则将它设置为 True。有关这些选项的详细信息，请参阅参数化行筛选器。

请参阅

概念

复制的向后兼容性

其他资源

复制增强


在复制拓扑中使用 SQL Server 的多个版本

在复制拓扑中使用 SQL Server 的多个版本 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > 复制的向后兼容性 >

复制支持将数据复制到 Microsoft SQL Server 的不同版本。此主题包括：

  • 支持的 SQL Server 版本

  • 为早期版本映射 Microsoft SQL Server 2005 数据类型

  • 从早期版本还原复制的数据库

  • 合并发布的兼容级别

有关将数据复制到 Microsoft SQL Server 2005 Express Edition 和 Microsoft SQL Server 2005 Mobile Edition 的信息，请参阅将数据复制到 SQL Server Express 和将数据复制到 SQL Server Mobile。有关 SQL Server 各版本所支持功能的信息，请参阅 SQL Server 2005 的各种版本所支持的功能。

注意：
在“安装帮助”文档和 SQL Server 2005 联机丛书中可以查看本主题。对于“安装帮助”文档中显示为粗体文本的主题链接来说，所指向的主题仅在联机丛书中提供。

支持的 SQL Server 版本

Microsoft 使用 SQL Server 2005 时，SQL Server 7.0 版 Service Pack 4 (SP4) 是参与使用复制拓扑所需的最低版本。如果使用的是 SQL Server 2000，则需要使用 Service Pack 3 (SP3) 或更高版本。如果复制拓扑中有 SQL Server 的多个版本：

  • 分发服务器的版本可以是高于或等于发布服务器版本的任何版本（在许多情况下，分发服务器与发布服务器是同一个实例）。

  • 发布服务器的版本可以是低于或等于分发服务器版本的任何版本。

  • 订阅服务器版本取决于发布的类型：

    • 事务性发布的只读订阅服务器版本可以是两个发布服务器版本中的任何一个版本。例如，SQL Server 7.0 版发布服务器可以对应 SQL Server 2005 订阅服务器，而 SQL Server 2005 发布服务器可以对应 SQL Server 7.0 版订阅服务器。

    • SQL Server 2005 事务性发布的可更新订阅服务器版本可以是等于或高于 Microsoft SQL Server 2000 SP3 的任何版本。

    • 合并发布的订阅服务器版本可以是低于或等于发布服务器版本的任何版本。

在不同版本的 SQL Server 之间复制时，常常受限于所用的最早版本的功能。例如，如果将分发服务器升级到 SQL Server 2005 实例，但有运行 SQL Server 2000 实例的发布服务器和运行 SQL Server 7.0 实例的订阅服务器，那么就要受限于 SQL Server 7.0 的常规功能和复制功能。

SQL Server 7.0 和 SQL Server Management Studio

SQL Server Management Studio 包含复制向导和对话框，可以连接到运行 SQL Server 2000 或更高版本的实例。对于运行 SQL Server 7.0 的订阅服务器：

  • 可以用 SQL Server 7.0 工具、SQL Server 2000 工具、SQL 分布式管理对象 (SQL-DMO) 或存储过程创建订阅和发布。

  • 无法从 Management Studio 或复制监视器启动请求订阅代理。可以在创建订阅时指定代理按计划运行，也可以按需从命令提示符运行代理。

运行 SQL Server 7.0 的订阅服务器的订阅在创建后确实会出现在 Management Studio 和复制监视器中。有关创建订阅和发布以及运行代理的信息，请参阅 SQL Server 7.0 联机丛书。

与运行早期版本的发布服务器一起使用 SQL Server 2005 分发服务器

SQL Server 2005 支持对运行 SQL Server 2000 和 SQL Server 7.0 的发布服务器使用远程分发服务器。若要更改此方案中的代理属性，请在分发服务器上执行以下存储过程。用这些过程可以更改 SQL Server 2005 中的新增属性：

  • sp_MSchange_snapshot_agent_properties (Transact-SQL)

  • sp_MSchange_logreader_agent_properties (Transact-SQL)

  • sp_MSchange_distribution_agent_properties (Transact-SQL)

  • sp_MSchange_merge_agent_properties (Transact-SQL)

如果您有运行 SQL Server 2000 的发布服务器和分发服务器，则可使用 sp_changedistpublisher (Transact-SQL) 和 sp_changesubscriber (Transact-SQL) 更改代理建立连接所使用的凭据。但是，如果将分发服务器升级到 SQL Server 2005，则不能使用这些过程更改现有代理作业中使用的凭据（这些过程确实影响调用过程后创建的代理作业）。为了更改现有代理作业的凭据，请调用上面列出的四个过程之一。

为早期版本映射 SQL Server 2005 数据类型

SQL Server 2005 引入了一些新数据类型。如果使用来自 SQL Server 2005 分发服务器的推送订阅，则将这些新数据类型映射到订阅服务器上的兼容数据类型。

SQL Server 2005 数据类型 | SQL Server 2000 或 SQL Server 7.0 数据类型
XML | NTEXT
CLR User Defined Types (UDT) | IMAGE
VARCHAR(max) | TEXT
NVARCHAR(max) | NTEXT
VARBINARY(max) | IMAGE

如果将 VARCHAR(max)、NVARCHAR(max)、VARBINARY(max)、XML 和 CLR UDT 类型复制到运行 SQL Server 较早版本的订阅服务器（这对于合并发布中的项目是默认操作），则必须确保这些类型被正确映射。这些类型的映射行为由 sp_addarticle (Transact-SQL) 和 sp_addmergearticle (Transact-SQL) 的架构选项 0x20、0x10000000 和 0x20000000 控制。有关设置架构选项的详细信息，请参阅：如何指定架构选项 (SQL Server Management Studio) 和How to: Specify Schema Options (Replication Transact-SQL Programming)。

SQL Server 2000 引入了两个映射到 SQL Server 7.0 兼容数据类型的数据类型。如果使用来自 SQL Server 2005 或 SQL Server 2000 分发服务器的推送订阅，则将这些新数据类型映射到订阅服务器上的兼容数据类型。

SQL Server 2005 或 SQL Server 2000 数据类型 | SQL Server 7.0 数据类型
SQL_VARIANT | IMAGE
BIGINT | DECIMAL

从早期版本还原复制的数据库

从早期版本还原复制数据库的备份时，可以保留复制设置。若要确保保留复制设置：请还原到与创建备份的服务器和数据库同名的服务器和数据库，并指定 KEEP_REPLICATION 选项。有关详细信息，请参阅 RESTORE (Transact-SQL)。

合并发布的兼容级别

合并复制使用发布兼容级别来确定给定数据库中的发布可以使用哪些功能。值的范围是从 70RTM（未安装 service pack 的 SQL Server 7.0）到 90RTM。通过以下方式指定兼容级别：

  • 使用 sp_addmergepublication (Transact-SQL) 的 @publication_compatibility_level 参数指定。有关详细信息，请参阅How to: Set the Publication Compatibility Level (Replication Transact-SQL Programming)。

  • 在新建发布向导的“订阅服务器类型”页上指定。有关运行此向导的详细信息，请参阅如何创建发布和定义项目 (SQL Server Management Studio)。

  • 在“发布属性 - <发布>”对话框的“常规”页上指定。有关详细信息，请参阅如何设置合并发布的兼容级别 (SQL Server Management Studio)。

下列功能要求 90RTM 或更高的兼容级别：

  • 逻辑记录。有关详细信息，请参阅通过逻辑记录对相关行的更改进行分组。

  • 订阅服务器上载选项。有关详细信息，请参阅使用仅下载项目优化合并复制的性能。

  • 不重叠的分区。有关详细信息，请参阅参数化行筛选器。

  • 业务逻辑处理程序。有关详细信息，请参阅在合并同步期间执行业务逻辑。

  • 使用 ALTER <OBJECT> 语句的架构更改。有关详细信息，请参阅对发布数据库进行架构更改。

以下功能不依赖兼容级别，但的确需要随 SQL Server 2005 一起提供的合并代理；运行 SQL Server 早期版本的订阅服务器可以像未启用该功能一样工作：

  • 预计算分区。有关详细信息，请参阅使用预计算分区优化参数化筛选器的性能。

  • Web 同步。有关详细信息，请参阅合并复制的 Web 同步。

  • 并行阶段代理（为合并代理指定 -ParallelUploadDownload）。有关详细信息，请参阅Replication Merge Agent。

  • 使用参数化筛选器的发布的新快照功能，包括以下能力：

    • 如果订阅服务器没有分区快照，可以请求快照。

    • 管理员可以预生成快照和计划快照的生成。

    • 使用 FTP 传递参数化快照。

    有关详细信息，请参阅带有参数化筛选器的合并发布的快照和通过 FTP 传输快照。

  • 改进了复制监视器中的历史日志和项目级统计信息。有关详细信息，请参阅如何查看订阅信息和执行其任务（复制监视器）。

SQL Server 2005 中的发布兼容级别行为

了解发布兼容级别的行为十分重要：

  • 该兼容级别与数据库兼容级别无关。

  • 如果用 sp_addmergepublication (Transact-SQL) 或通过复制管理对象 (RMO) 创建发布，则在默认情况下将兼容级别设置为 80RTM。如果在新建发布向导中创建发布，则根据在向导的“订阅服务器类型”页上选择的选项来确定该兼容级别。

  • 在 SQL Server 的早期版本中，如果启用了需要更高兼容级别的功能，则兼容级别会自动增加。在 SQL Server 2005 中，必须先将兼容级别手动设置为 90RTM，然后才能启用要求该兼容级别的功能。

    如果从 SQL Server 7.0 升级发布服务器，然后选择一个或多个要求 80RTM 兼容级别的功能，则兼容级别自动提高。

  • 仅当快照代理尚未启动且不存在对发布的订阅时，才能降低兼容级别。

  • 同一数据库中的所有发布必须具有相同的兼容级别。这样做有下列优点：

    • 如果数据库所含发布的兼容级别较低（如 80RTM），而且要在同一数据库中添加级别为 90RTM 的另一发布，则必须在添加新发布之前手动提高第一个发布的级别。

    • 如果数据库包含两个或多个兼容级别较低的发布，并且要在同一数据库中添加另一个级别为 90RTM 的发布，则必须执行以下操作：只保留一个现有发布，其余全部删除；将保留发布的级别提高到 90RTM，将已删除的发布重新创建为级别为 90RTM 的发布；创建级别为 90RTM 的新发布。

请参阅

概念

复制的向后兼容性
升级复制数据库

其他资源

复制增强

更改历史记录

版本 历史记录

2006 年 4 月 14 日

已更改的内容：
  • 添加了有关用于映射数据类型架构选项的相关信息。


全文搜索向后兼容性

全文搜索向后兼容性
升级到 SQL Server 2005 > 向后兼容性 >

向后兼容性部分的主题介绍 Microsoft SQL Server 2005 中的全文搜索与其他版本的全文搜索之间在行为上的更改。

请参阅… | 有关下面的主题
SQL Server 2005 中全文搜索的重大更改 | 可能需要更改应用程序的全文搜索更改。
SQL Server 2005 中全文搜索的行为更改 | 此版本的全文搜索在行为上的其他更改。


SQL Server 2005 中全文搜索的重大更改

SQL Server 2005 中全文搜索的重大更改 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > 全文搜索向后兼容性 >

本主题介绍可能需要更改应用程序的全文搜索更改。

影响应用程序的重大更改

下面是 Microsoft SQL Server 2005 中全文搜索的重大更改。

功能 说明

断字符和筛选器

SQL Server 全文搜索使用的断字符和筛选器经过重大修改，功能和可靠性都得到了提高。在某些特定情况下，对断字符所做的更改可能会影响对某些数据进行标记化的方式。?a?é?üμ????ú SQL Server 2005 中创建的标记不同于在 SQL Server 2000 中创建的标记。例如，在 SQL Server 2005 中，德语的复合字标记化功能已得到提高，现在组成成分超过两个字的复合字也可以标记化了。这会影响查询结果。

FULLTEXTCATALOG 属性

在 SQL Server 2000 中，对于全文目录中的每个全文索引表，Itemcount 返回表中索引行数的聚合加 1。在 SQL Server 2005 中，此属性已改为准确反映全文目录中每个全文索引表内索引行数的聚合。

全文目录名称的长度

在 SQL Server 2005 中，全文目录名称的长度不能超过 120 个字符，比 SQL Server 早期版本中的 128 个字符有所减少。

Microsoft SQL Server 全文引擎服务和第三方筛选器

默认情况下，Microsoft SQL Server 全文引擎 (MSFTESQL) 服务不加载未经 Microsoft 签署的组件。

默认情况下，升级后，MSFTESQL 服务不加载服务器上当前已安装的第三方筛选器，如 PDF 筛选器。

废弃的全文搜索属性

下列全文搜索相关的属性和设置已从 SQL Server 2005 中删除。

  • DataTimeout

  • ConnectTimeout

  • clean_up

  • LogSize

多个 SQL Server 2005 实例不能共享 Microsoft Full-Text Search Engine for SQL Server (MSFTESQL) 服务。

升级到 SQL Server 2005 时，每个 SQL Server 实例都有一个专用的 Microsoft Full-Text Search Engine for SQL Server (MSFTESQL) 服务实例。

全文搜索目录的路径

在 SQL Server 2005 中，位于 sysfulltextcatalogs 视图中的该路径以及 sp_help_fulltext_catalogs 和 sp_help_fulltext_catalogs_cursor 系统存储过程返回的该路径已更改。在 SQL Server 2000 中，全文目录位于根目录中。在 SQL Server 2005 中，全文目录位于 FTData 目录中。

全文索引和具有不确定性且包含计算不精确的列

SQL Server 2005 不允许创建具有不确定性且包含计算不精确的列的全文索引。这些列无法用作类型列或全文键列。

sysfulltextnotify

sysfulltextnotify 视图未在 SQL Server 2000 中记录，但仍可查询它。此视图在 SQL Server 2005 中已删除。

全文索引和系统数据库

在 SQL Server 2000 中，master、tempdb 和 model 数据库支持全文索引。而在 SQL Server 2005 中不支持对这些数据库进行全文索引。这些数据库中的所有全文目录在升级到 SQL Server 2005 后被删除。

全局断字符和筛选器

在 SQL Server 2000 中，新断字符和筛选器只能作为全局操作系统级组件添加。SQL Server 2005 允许新断字符和筛选器的实例级注册。这在实例间提供了功能隔离和安全隔离。

全文搜索的额外空间要求

由于 SQL Server 2005 中的文档标识符 (DOCID) 映射存储在数据库中，因此对数据库的大小要求提高了。但对全文目录的大小要求降低了。

请参阅

其他资源

全文搜索向后兼容性
SQL Server 2005 中全文搜索的行为更改
全文搜索


SQL Server 2005 中全文搜索的行为更改

SQL Server 2005 中全文搜索的行为更改 |
 | 请参阅
升级到 SQL Server 2005 > 向后兼容性 > 全文搜索向后兼容性 >

本主题介绍与 Microsoft SQL Server 的早期版本相比，全文搜索功能在行为上的更改。

行为更改

下表列出了这些行为更改。

行为更改 说明

主合并

在 SQL Server 2000 中，主合并在午夜启动，或者在对 500,000 个文档执行全文索引后启动。

在 SQL Server 2005 中，主合并既在完全填充结束时启动，也在达到全文索引文件数的内部阈值时启动。

主合并还会在对 500,000 个文档执行全文索引后启动，这与 SQL Server 2000 是相同的。

SQL Server 2005 还允许用户使用数据定义语言启动主合并。

MSSearch 服务

在 SQL Server 2000 中，全文搜索使用 MSSearch 服务作为全文索引和搜索引擎。而在 SQL Server 2005 中，此服务已重命名为 MSFTESQL 服务。MSFTESQL 引擎是基于 MSSearch 技术建立的。

与全文搜索相关的存储过程

由于与全文搜索相关的存储过程在 SQL Server 2005 中已重写，以使用新的全文数据定义语言 (DDL)，因此，有些错误会导致语句级错误。

下列错误会导致语句级错误。其他失败为批处理级失败。

  • 权限检查失败。

  • 显式事务检查失败。（在显式用户事务内不能调用全文存储过程）。

  • 在 master、temp 或 model 数据库中执行与全文相关的操作。

  • 数据库非只读检查失败。

  • 数据库未启用全文模式。

  • 参数验证：

    • 找不到目录名。

    • 表名不存在，或者表不可进行全文索引。

    • 列名在表中无效。

    • 数据库名和表名等参数为空。

全文目录清除功能

无法在 SQL Server 2005 中运行 sp_fulltext_service 清除功能。

干扰词

在 SQL Server 2005 中，如果使用全文搜索谓词或函数的查询包含干扰词且 transform noise words 配置选项未选中，则会发出一个警告，并且不返回任何行。有关此选项的详细信息，请参阅transform noise words 选项。

返回排名为 0 的行

在 SQL Server 2000 中，不返回排名为 0 的行。但在 SQL Server 2005 中，这些行包括在结果集中。这可能会影响存储过程和其他查询的结果。

运行 sp_fulltext_database

在 SQL Server 2005 中，对已启用全文索引的用户数据库运行 sp_fulltext_database 'enable' 不会执行任何操作。

注意：
默认情况下，用户数据库是启用全文索引的。

请参阅

其他资源

全文搜索向后兼容性
SQL Server 2005 中全文搜索的重大更改
全文搜索


安装 SQL Server 2005 组件

安装 SQL Server 2005 组件 |
 | 请参阅

Microsoft 可以使用安装向导安装 SQL Server 2005，也可以从命令提示符安装。安装向导提供图形用户界面引导您做出每个安装时决定，是大部分用户的首选方法。安装向导提供初次安装 SQL Server 2005 的指南，包括功能选择、实例命名规则、服务帐户配置、强密码指南以及设置排序规则的方案。

命令提示符安装适用于高级方案（例如无提示安装）；它们可以从命令提示符直接运行，也可以从引用安装文件以指定安装选项的命令提示符语法运行。

为确保安装成功，请在安装 SQL Server 2005 之前查看下列要求：
  • 安装 SQL Server 2005 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

若要使用 SQL Server 2005 安装向导安装 SQL Server 2005 组件，请参阅：
  • 如何安装 SQL Server 2005（安装程序）

  • 如何创建新的 SQL Server 2005 故障转移群集（安装）

若要从命令提示符安装 SQL Server 2005 组件，请参阅：
  • 如何从命令提示符安装 SQL Server 2005

  • SQL Server 2005 远程安装信息

若要从早期 SQL Server 版本升级，请参阅：
  • 版本升级

  • 升级到 SQL Server 2005

若要使用 SQL Server 2005 安装向导添加或删除 SQL Server 2005 组件，请参阅：
  • 如何在 SQL Server 2005 的现有实例中更改组件（安装程序）

请参阅

概念

准备安装 SQL Server 2005

其他资源

数据库引擎安装帮助主题


安装 SQL Server 数据库引擎

安装 SQL Server 数据库引擎 |
 | 请参阅
安装 SQL Server 2005 组件 >

Microsoft SQL Server 2005 的SQL Server 数据库引擎 组件是存储、处理数据和保证数据安全的核心服务。数据库引擎 提供受控的访问和快速事务处理，以满足企业中要求极高、大量使用数据的应用程序的要求。

数据库引擎 支持单一计算机上的一个或多个服务器实例。有关选择要安装的功能和组件的详细信息，请参阅 SQL Server 2005 的版本和组件。

若要创建典型的 SQL Server 安装，请参阅如何安装 SQL Server 2005（安装程序）。

重要事项：
对于本地安装，必须以管理员身份运行安装程序。如果通过远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

步骤 1：准备安装数据库引擎

在安装 SQL Server 2005 数据库引擎 之前，请查看下列要求：

  • 安装 SQL Server 2005 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

  • SQL Server 数据库引擎组件

步骤 2：安装数据库引擎

在查看了 SQL Server 2005 的安装要求并确保计算机符合要求后，即可着手安装数据库引擎了。根据您的环境，按下列方式之一安装数据库引擎：

  • 使用“安装向导”，在干净的计算机上安装数据库引擎。有关详细信息，请参阅如何安装 SQL Server 2005（安装程序）或安装故障转移群集前的准备工作。

  • 从命令提示符下，在干净的计算机上安装数据库引擎。有关详细信息，请参阅 SQL Server 2005 远程安装信息。有关命令提示符语法的示例，请参阅如何从命令提示符安装 SQL Server 2005。

  • 将早期 SQL Server 版本迁移或升级到 SQL Server 2005。有关详细信息，请参阅升级到 SQL Server 2005 和使用 SQL Server 的多个版本。

步骤 3：检查安装的数据库引擎

安装完成后，请验证 SQL Server 2005 服务是否运行。有关详细信息，请参阅如何验证 SQL Server 2005 服务的安装成功。

步骤 4：配置安装的数据库引擎

默认情况下，SQL Server 2005 的某些功能被关闭。若要查看配置选项，请参阅配置 SQL Server 安装和 SQL Server 外围应用配置器。

请参阅

参考

SQL Server 2005 的版本和组件
排序规则选项与国际支持

概念

SQL Server 数据库引擎组件

其他资源

数据库引擎安装帮助主题
配置高可用性


SQL Server 数据库引擎组件

SQL Server 数据库引擎组件 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 数据库引擎 >

Microsoft SQL Server 2005 在单台计算机上支持多达 50 个数据库引擎 实例。在 SQL Server 2005 安装向导的“要安装的组件”页上选择 SQL Server 数据库引擎 时，可安装下列功能：

  • 数据库引擎

  • 复制

  • 全文搜索

下列附加功能是许多典型用户应用场景的可选项：

  • Integration Services

  • 连接组件

  • 编程模型

  • 管理工具

  • SQL Server Management Studio

  • AdventureWorks 示例数据库和示例

  • 联机丛书

请参阅

参考

SQL Server 2005 的版本和组件
SQL Server 2005 的各种版本所支持的功能


SQL Server 2005 远程安装信息

SQL Server 2005 远程安装信息 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 数据库引擎 >

有两种方法可用于从命令行提示符安装 Microsoft SQL Server，以下主题将介绍这两种方法。

注意：
此版本不支持将 SQL Server 2005 安装到远程计算机中。若要将 SQL Server 2005 安装到远程计算机中，请使用远程连接以用户界面模式或从命令行提示符运行 SQL Server 2005 安装程序。

本节的相关信息

主题 | 说明
从命令提示符运行安装程序 | 列出从命令提示符安装 SQL Server 的属性和选项，包括无人参与安装和静默安装。也提供示例脚本。
用 .ini 文件指定安装属性 | 提供使用 SQL Server DVD 上的模板 .ini 文件安装 SQL Server 2005 的信息。

请参阅

任务

如何从命令提示符安装 SQL Server 2005


从命令提示符运行安装程序

从命令提示符运行安装程序 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 数据库引擎 > SQL Server 2005 远程安装信息 >

SQL Server 2005 安装程序除提供图形用户界面外，还提供一个命令提示符界面。使用命令提示语法可以自定义安装程序安装 SQL Server 2005 的方式。可以在命令提示符下或 .ini 文件中指定命令提示安装。

注意：
此版本不支持远程安装。若要将 SQL Server 2005 安装到远程计算机中，请使用远程连接以用户界面模式或从命令提示符运行 SQL Server 安装程序。此版本不支持记录无人参与的 (.iss) 安装。

有关安装或删除 SQL Server 2005 实例的语法示例，请参阅如何从命令提示符安装 SQL Server 2005。

请参阅

概念

如何为 SQL Server 2005 重新生成注册表
如何重新生成 SQL Server 2005 的 Master 数据库


用 .ini 文件指定安装属性

用 .ini 文件指定安装属性 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 数据库引擎 > SQL Server 2005 远程安装信息 >

SQL Server 2005 安装程序除提供图形用户界面外，还提供一个命令提示符界面。使用命令提示语法可以自定义安装程序安装 SQL Server 2005 的方式。可以在命令提示符下或 .ini 文件中指定命令提示安装。

注意：
此版本不支持远程安装。若要将 SQL Server 2005 安装到远程计算机中，请使用远程连接以用户界面模式或从命令提示符运行 SQL Server 安装程序。此版本不支持记录无人参与的 (.iss) 安装。

有关安装或删除 SQL Server 2005 实例的语法示例，请参阅如何从命令提示符安装 SQL Server 2005。

请参阅

概念

如何为 SQL Server 2005 重新生成注册表
如何重新生成 SQL Server 2005 的 Master 数据库


SQL Server 数据库引擎的安装故障排除

SQL Server 数据库引擎的安装故障排除 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 数据库引擎 >

以下是与安装数据库引擎 有关的一些常见问题和建议的解决方法。

问题：应用程序无法在分布式事务处理中登记 SQL Server 2005 资源

具体问题：因为在 Microsoft Windows 中未完全配置 Microsoft 分布式事务处理协调器 (MS DTC)，应用程序可能无法在分布式事务中登记 SQL Server 2005 资源。此问题会影响使用分布式事务的链接服务器、分布式查询和远程存储过程。

解决方法：要避免这些问题，必须在安装 SQL Server 2005 的服务器上完全启用 MS DTC 服务。

若要完全启用 MS DTC，请使用以下步骤：

  1. 在控制面板中，打开“管理工具”，然后打开“计算机管理”。

  2. 在“计算机管理”的左窗格中，展开“服务和应用程序”，再单击“服务”。

  3. 在“计算机管理”的右窗格中，右键单击“分布式事务协调器”并选择“属性”。

  4. 在“分布式事务协调器”窗口中，单击“常规” 选项卡，再单击“停止”停止该服务。

  5. 在“分布式事务协调器”窗口中，单击“登录”选项卡，并将登录帐户设置为 NT AUTHORITY\NetworkService。

  6. 单击“应用”和“确定”以关闭分布式事务协调器的窗口。关闭“计算机管理”。关闭“管理工具”。

注意：
对于参与故障转移群集的计算机上的 SQL Server 2005 安装，在运行安装程序前必须完全启用和聚集 MS DTC。如果未聚集 MS DTC，安装将失败。运行安装程序前，请使用 Microsoft Cluster Administrator 确保 MS DTC 已聚集。

问题：升级到 SQL Server 2005 失败，出现“SQL Server 安装程序无法连接到数据库服务进行服务器配置”的错误消息。

具体问题：如果升级到 SQL Server 2005 期间，端口 1433 不可用，SQL Server 安装程序可能返回以下错误：

SQL Server 安装程序无法连接到数据库服务进行服务器配置。–

解决方法：若要继续，请终止使用端口 1433 的进程并继续进行 SQL Server 2005 安装：

  1. 从命令提示符运行 netstat -o。

  2. 找出使用端口 1433 的应用程序或进程。

  3. 使用任务管理器关闭应用程序或终止进程以释放端口 1433。

  4. 继续 SQL Server 2005 安装。

如果使用以上步骤无法释放端口 1433，请使用以下附加的步骤：

  1. 打开控制面板中的“添加或删除程序”。

  2. 选择 Microsoft SQL Server 2005，然后单击“更改”。

  3. 在“组件选择”页上单击要升级的 SQL Server 实例的单选按钮，再单击“下一步”。

  4. 在“功能维护”页上单击“数据库引擎”，再单击“下一步”。

  5. 单击“继续”继续升级到 SQL Server 2005 的操作。

问题：如果有本地应用程序连接到正在升级的实例，则升级可能会失败。

具体问题：SQL Server 安装程序需要在单用户模式下完成到 SQL Server 2005 的升级。如果升级操作过程中有本地应用程序连接到 SQL Server 实例，安装将失败，并出现以下错误：

SQL Server 安装程序无法连接到数据库服务进行服务器配置。错误为：[Microsoft][SQL Native Client][SQL Server] 用户 <DomainName\AdminAccount> 登录失败。原因：服务器处于单用户模式。目前只有一位管理员能够连接。有关详细信息，请参阅服务器错误日志。有关如何查看安装日志的详细信息，请参阅 SQL Server 联机丛书中的“如何查看安装日志文件”。

解决方法：在 SQL Server 升级过程中，Reporting Services 处于运行状态时通常会出现此失败。若要解决此问题，请停止所有连接到此 SQL Server 实例的应用程序，然后在该安装错误消息上选择“重试”以使升级继续。

具体问题：由于现有 SQL Server 组件的配置，SQL Server 2005 安装程序失败。

问题：如果现有的 SQL Server 客户端安装程序配置中启用了“强制加密”选项，则可能出现此问题。此情况的错误消息为：

SQL Server 安装程序无法连接到数据库服务进行服务器配置。错误为：[Microsoft]<组件名称> SSL 提供程序：证书的 CN 名与传递的值不匹配。有关详细信息，请参阅服务器错误日志和安装日志。有关如何查看安装日志的详细信息，请参阅 SQL Server 联机丛书中的“如何查看安装日志文件”。

解决方法：使用 SQL Server 2000 客户端网络实用工具（对于 SQL Server 2000 中的 MDAC 客户端）或 SQL 配置管理器（对于 SQL Server 2005 中的 SQL Native 客户端）禁用原先存在的 SQL Server 客户端上的“强制加密”选项，然后再次运行 SQL Server 2005 安装程序。

请参阅

任务

如何验证 SQL Server 2005 服务的安装成功
如何阅读 SQL Server 2005 安装日志文件

概念

故障转移群集故障排除
如何查看 SQL Server 2005 安装日志文件
如何为 SQL Server 2005 重新生成注册表
如何重新生成 SQL Server 2005 的 Master 数据库


安装 SQL Server Analysis Services

安装 SQL Server Analysis Services |
 | 请参阅
安装 SQL Server 2005 组件 >

步骤 1：准备安装 SQL Server 2005 Analysis Services

在安装 Microsoft SQL Server 2005 Analysis Services (SSAS) 之前，请检查以下要求：

  • 安装 SQL Server 2005 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

步骤 2：安装 SQL Server 2005 Analysis Services

在检查了 SQL Server 2005 的安装要求并确保计算机满足这些要求后，就可以安装 SQL Server 2005 Analysis Services 了。根据环境的不同，可以以下列方式之一安装 Analysis Services：

  • 在干净的计算机上安装 SQL Server 2005 Analysis Services

  • 并行安装 SQL Server 2005 Analysis Services 和 SQL Server 2000 Analysis Services

  • 升级到 SQL Server 2005 Analysis Services

在干净的计算机上安装 SQL Server 2005 Analysis Services

与 SQL Server 2005 中的任何组件一样，Analysis Services 既可以通过 SQL Server 安装向导运行 SQL Server 安装程序来安装，也可以通过在命令提示符下运行安装程序来安装。

选项 1：使用 SQL Server 安装向导

您可以通过使用 SQL Server 安装向导，在本地计算机或故障转移群集上安装 Analysis Services。

主题 | 说明
使用安装程序安装 SQL Server Analysis Services | 特定于 SQL Server 2005 Analysis Services 的安装信息。
如何安装 SQL Server 2005（安装程序） | 描述 SQL Server 安装向导中的每个步骤的安装信息，该信息适用于 SQL Server 2005 的所有组件，包括 Analysis Services。

选项 2：从命令提示符运行安装程序

您可以在命令提示符处运行 SQL Server 安装程序。在远程计算机上安装 Analysis Services 时，必须从命令提示符运行安装程序。

主题 | 说明
从命令提示符安装 SQL Server Analysis Services | 特定于 Analysis Services 的命令提示符安装信息。
如何从命令提示符安装 SQL Server 2005 | 描述命令提示符安装过程的每个步骤和选项的命令提示符安装信息，该信息适用于 SQL Server 2005 的所有组件，包括 Analysis Services。

返回页首

并行安装 SQL Server 2005 Analysis Services 和 SQL Server 2000 Analysis Services

您可以将 SQL Server 2005 Analysis Services 作为命名实例与 Microsoft SQL Server 2000 Analysis Services 的默认实例并行安装。因为 SQL Server 2000 Analysis Services 不支持命名实例，所以在并行安装中 SQL Server 2000 Analysis Services 实例必须始终是默认实例。

您还可以将现有的 SQL Server 2000 Analysis Services 数据库迁移为 SQL Server 2005 Analysis Services 数据库格式，而保持现有的数据库内容不变。

主题 | 说明
升级或迁移 Analysis Services | 有关并行安装和数据库迁移的常规信息。
迁移现有 Analysis Services 数据库 | 有关 Analysis Services 迁移向导以及 SQL Server 2000 Analysis Services 和 SQL Server 2005 Analysis Services 数据库对象之间的差异的信息。
SQL Server 2005 Analysis Services 的向后兼容性 | 有关废止和不推荐使用的功能以及从 SQL Server 2000 Analysis Services 到 SQL Server 2005 Analysis Services 行为更改的信息。

返回页首

升级到 SQL Server 2005 Analysis Services

您可以通过使用安装程序或使用除 SQL Server 安装程序之外的几个实用工具程序从较早版本的 Analysis Services 升级到 SQL Server 2005 Analysis Services。

若要在安装期间升级，请输入 SQL Server 2000 Analysis Services 现有实例的实例名。若要在安装完 SQL Server 2005 Analysis Services 的命名实例后升级，可使用 Analysis Services 迁移向导将现有的 Analysis Services 数据库移到新的服务器实例。然后可以选择卸载 SQL Server 2000 Analysis Services，并使用 Analysis Services 实例重命名工具将 SQL Server 2005 Analysis Services 实例重命名为默认实例。

主题 | 说明
升级或迁移 Analysis Services | 有关并行安装和数据库迁移的常规信息。
迁移现有 Analysis Services 数据库 | 有关 Analysis Services 迁移向导以及 SQL Server 2000 Analysis Services 和 SQL Server 2005 Analysis Services 数据库对象之间的差异的信息。
SQL Server 2005 Analysis Services 的向后兼容性 | 有关废止和不推荐使用的功能以及从 SQL Server 2000 Analysis Services 到 SQL Server 2005 Analysis Services 行为更改的信息。

返回页首

请参阅

其他资源

安装 SQL Server 2005 组件


使用安装程序安装 SQL Server Analysis Services

使用安装程序安装 SQL Server Analysis Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server Analysis Services >

注意：
有关使用 Microsoft SQL Server 安装向导安装 SQL Server 2005 产品组件的详细信息，建议您查看如何安装 SQL Server 2005（安装程序）。

本主题只包含使用 SQL Server 安装向导安装 Microsoft SQL Server 2005 Analysis Services (SSAS) 时特有的信息。

  • 选择要安装的组件

  • 指定 Analysis Services 文件位置

  • 指定 Analysis Services 实例

  • 指定 Analysis Services 服务帐户

  • 指定 Analysis Services 身份验证模式

  • 指定 Analysis Services 排序规则

选择要安装的组件

虽然可单独安装 Analysis Services，但请注意，许多数据仓库解决方案需要安装其他 SQL Server 2005 组件才能开发、部署和管理 Analysis Services 数据库。下表描述这些附加或可选的 SQL Server 2005 组件。

组件 | 适用于管理员 | 适用于开发人员 | 可选组件
连接组件 用于客户端与服务器之间通信的组件，包括用于 DB-Library、ODBC 和 OLE DB 的网络库。 | X | X |
管理工具 用于管理 SQL Server 2005 的交互工具，包括 SQL Server 配置管理器、SQL Server Management Studio、SQL Server 事件探查器 和复制监视器。 | X |  |
Business Intelligence Development Studio 商业智能项目的集成开发环境。 |  | X |
软件开发包 可帮助开发人员为 SQL Server 2005 创建自定义解决方案的软件。 |  | X |
SQL Server Database Services SQL Server 数据库引擎 和用于管理关系数据和 XML 数据、复制以及全文搜索的工具。 |  |  | X
Reporting Services 报表服务器和报表管理器，前者用于管理、执行、呈现和分发报表，后者是用于访问 SQL Server 2005 Reporting Services (SSRS) 组件的基于 Web 的用户界面，包括管理工具和查看报表的用户界面。 |  |  | X
Integration Services SQL Server 2005 Integration Services (SSIS)，即一组用于移动、复制和转换数据的图形化和可编程的对象。 |  |  | X
文档和示例 SQL Server 联机丛书文档、编程参考材料和所有 SQL Server 2005 组件的示例。 | X | X | X

安装所选组件

Integration Services 可以单独安装，也可以与其他 SQL Server 2005 组件一起安装，如以下过程所述。

单独安装 Analysis Services

  • 在 SQL Server 安装向导的“要安装的组件”页上，只选择 Analysis Services。

    注意：
    如果选择只安装 Analysis Services，则默认情况下不安装 SQL Server 2005 客户端组件，这些组件包括命令行工具、连接组件、编程模型、管理和开发工具以及文档和示例。
使用“要安装的组件”页添加或删除安装组件

  • 在安装向导的“要安装的组件”页上，选中或清除要添加或删除的组件的复选框。

    注意：
    默认情况下，如果在“要安装的组件”页上选择“工作站组件、联机丛书和开发工具”安装选项，将不会选择示例数据库和编程示例。必须在“功能选择”页上手动选中这些选项。
使用“功能选择”页添加或删除安装组件

  1. 在“要安装的组件”页中，单击“高级”。

  2. 在“功能选择”页上，选中要添加的组件的复选框，并清除要删除的组件的复选框。

    注意：
    “功能选择”页是在 SQL Server 安装向导中查看安装选项的详细列表（包括本主题先前列出的组件）的好方法。

指定 Analysis Services 文件位置

SQL Server 2005 安装程序将 Analysis Services 程序文件、数据文件和共享文件分多处存放。每个 Analysis Services 实例各自有一组文件夹，这些文件夹中存有该实例的程序文件和数据文件。下表列出了 Analysis Services 文件的默认文件夹位置：

Analysis Services 文件 | 默认位置
SQL Server 2005 和 Analysis Services 的实例 | C:\Program Files\Microsoft SQL Server\MSSQL.n 其中数字 n 表示多个实例的安装顺序，从 1 开始。此位置可以在安装过程中更改。
Analysis Services 实例的数据文件和共享文件 | C:\Program Files\Microsoft SQL Server\MSSQL.n\OLAP\Data C:\Program Files\Microsoft SQL Server\MSSQL.n\OLAP\bin
由 SQL Server 2005 组件的所有实例共享的组件 | C:\Program Files\Microsoft SQL Server\90\Shared 安装期间无法更改此文件夹。
工具、文档和示例 | C:\Program Files\Microsoft SQL Server\90\Tools 为所有 Analysis Services 实例和其他 SQL Server 组件安装一组工具和文档。
在安装过程中更改 Analysis Services 文件的默认位置

  1. 在安装向导的“要安装的组件”页上，单击“高级”。

  2. 在“功能选择”页上，单击支持非默认安装路径的功能，再单击“浏览”。

  3. 在“更改文件夹”页的“安装路径”框中，输入新的文件位置。
重要事项：
现在可以使用安装向导的“功能选择”页，将某些 SQL Server 2005 组件安装到默认位置 %ProgramFiles%\Microsoft SQL Server\90 以外的其他位置。此选项对于 SQL Server 2005 Integration Services (SSIS)、SQL Server 2005 Notification Services 和工作站组件（即客户端工具、文档和示例）是可用的。在命令提示符下进行安装时，所用的相应开关是 installsqlshareddir。

指定 Analysis Services 实例

在 SQL Server 安装向导的“实例名”页上，可以指定是安装 SQL Server 2005 Analysis Services 的默认实例，还是命名实例。只能安装一个 SQL Server 2005 Analysis Services 默认实例。默认实例不是必需的。

在“实例名”页上，只能为所有选定要安装的 SQL Server 2005 组件指定一个实例名。因此，不能同时安装 SQL Server 数据库引擎 的默认实例和 Analysis Services 的命名实例。在多个实例的情况下，必须对要使用的每个实例名分别运行安装程序。

如果服务器上已经安装了 SQL Server 2000 Analysis Services 的实例，则只能安装 SQL Server 2005 Analysis Services 的命名实例，除非将现有的默认实例升级到 SQL Server 2005 Analysis Services。在 SQL Server 安装向导的“实例名”页上输入现有实例的名称时，“要升级的组件”页将要求确认是否要升级现有实例。

并行安装 SQL Server 2005 Analysis Services 和 SQL Server 2000 Analysis Services 时，必须将 SQL Server 2005 Analysis Services 安装为命名实例。

如果在单个服务器上安装多个 SQL Server 2005 Analysis Services 实例，可能希望只使用命名实例，以便可以提供有意义的名称来区分各实例。

注意：
一份 Microsoft SQL Server 2005 Enterprise Edition 许可证允许在单个计算机上安装多个 SQL Server 2005 Analysis Services 实例。其他版本的 SQL Server 2005 则对每个实例各要求一份许可证。有关的完整详细信息，请参阅您的产品附带的许可协议。

有关 SQL Server 2000 Analysis Services 和 SQL Server 2005 Analysis Services 并行安装方案的详细信息，请参阅升级或迁移 Analysis Services。

使用 Analysis Services 实例重命名工具，可以重命名已安装的 SQL Server 2005 Analysis Services 实例，也可以在默认实例不存在的情况下，使命名实例成为默认实例。

有关详细信息，请参阅如何重命名 Analysis Services 实例。

指定 Analysis Services 服务帐户

Analysis Services 作为 Microsoft Windows 服务启动和运行。此服务出现在 SQL Server 配置管理器中已安装服务的列表中，也列入对 Windows 服务提供管理支持的 Microsoft 管理控制台 (MMC) 管理单元“服务”中。

每个 Analysis Services 实例由自己的服务支持，且每个实例的排序规则和其他服务器选项可以使用不同的设置。每个实例的服务名反映了安装过程中指定的实例名。默认实例的服务名是 MSSQLServerOLAPService。命名实例的服务名是 MSOLAP$instancename，其中 instancename 是在安装过程中为该实例指定的名称。

用于运行 Analysis Services 服务的帐户必须是本地 Administrators 组的成员。

在“服务”管理单元中查看 Analysis Services 服务

  1. 单击“开始”，指向“所有程序”、再指向“管理工具”，然后单击“服务”。

  2. 在服务列表中查找以下项之一：

    • 对于 Analysis Services 的默认实例，查找 MSSQLServerOLAPService。

    • 对于 Analysis Services 的命名实例，查找 MSOLAP$instancename。

有关 SQL Server 2005 服务帐户的详细信息，请参阅设置 Windows 服务帐户。

指定 Analysis Services 身份验证模式

SQL Server 2005 Analysis Services 只支持 Windows 身份验证。

指定 Analysis Services 排序规则

Analysis Services 使用的排序规则指示符和排序顺序设置与 SQL Server 数据库引擎 相同。如果在同一个实例名下安装 Analysis Services 和 SQL Server 数据库引擎，则可以选择这两个服务器是使用相同的设置还是使用不同的设置。如果选择使用不同的设置，则必须分别配置 Analysis Services 和 SQL Server 数据库引擎，具体过程如下所述。

在 Analysis Services 和 SQL Server 数据库引擎中使用不同的排序规则设置

  1. 在安装向导的“排序规则设置”页上，选中“为每个服务帐户进行自定义”复选框。

  2. 在“服务”旁边，选择 Analysis Services，然后配置 Analysis Services 的排序规则选项。

    注意：
    “SQL 排序规则”选项不适用于 Analysis Services，且在配置 Analysis Services 排序规则选项时，该选项不可用。

  3. 在“服务”旁边，选择“数据库引擎”，然后配置 SQL Server 数据库引擎 的排序规则选项。

有关 SQL Server 2005 排序规则选项的详细信息，请参阅排序规则选项与国际支持。

请参阅

概念

安装 SQL Server Analysis Services


从命令提示符安装 SQL Server Analysis Services

从命令提示符安装 SQL Server Analysis Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server Analysis Services >

注意：
有关从命令提示符安装 Microsoft SQL Server 2005 产品和技术的详细信息，我们建议您查看如何从命令提示符安装 SQL Server 2005。

本主题包含的信息仅限于从命令提示符安装 Microsoft SQL Server 2005 Analysis Services (SSAS)，并不涉及其他安装方法或其他 SQL Server 2005 组件安装的相关信息。

Analysis Services 命令提示符安装参数

在本地或远程服务器上，或者故障转移群集上，可以从命令提示符安装 Analysis Services。如果从命令提示符安装，则可以在命令提示符下指定安装参数，也可以使用 /settings 开关从 .ini 文件加载安装参数。您必须使用安装命令行参数或 .ini 文件，但不能两者同时使用。

从命令提示符进行安装时，必须使用 addlocal="feature1,feature2,..." 开关来指定要安装的 SQL Server 2005 功能。下表显示了安装 Analysis Services 的实例所需的参数。

值 | 指定
Analysis_Server | Analysis Services 的实例
AnalysisDataFiles | Analysis Services 的数据文件

例如，若要安装 Analysis Services 的实例及产品文档，可按以下示例所示设置参数 addlocal：

复制代码
   setup addlocal="Analysis_Server,AnalysisDataFiles,SQL_BooksOnline"

有关可以在 addlocal 参数中指定的 SQL Server 2005 功能的详细信息，请参阅 SQL Server 2005 安装媒体的根文件夹中的 template.ini 文件或参阅如何从命令提示符安装 SQL Server 2005。

重要事项：
现在可以将某些 SQL Server 2005 组件安装到默认位置 %ProgramFiles%\Microsoft SQL Server\90 以外的其他位置。此选项对于 SQL Server 2005 Integration Services (SSIS)、SQL Server 2005 Notification Services 和工作站组件（即客户端工具、文档和示例）是可用的。从命令提示符进行安装时，用于此选项的开关是 installsqlshareddir。

其他必需的命令提示符安装参数

一些其他参数，如 PIDKEY，是使用 setup 命令在命令提示符下执行的任何 SQL Server 安装都需要的。对于 Analysis Services 和其他 SQL Server 2005 组件的特定安装，可能还需要其他参数。

有关从命令提示符安装 SQL Server 2005 产品和技术的详细信息，请参阅如何从命令提示符安装 SQL Server 2005。

其他 Analysis Services 命令提示符安装参数

除 addlocal 之外，以下 /settings 命令行参数也是特定于 Analysis Services 的。

注意：
下列参数不能用于故障转移群集安装。

参数 | 说明
INSTALLOLAPDIR="OLAP_executable_folder_path" | 指定在其中安装 Analysis Services 可执行文件的文件夹。默认路径为 C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\bin。请将 Analysis Services 安装到在路径和名称中只使用单字节字符的文件夹中。
INSTALLOLAPDATADIR="OLAP_data_folder_path" | 指定在其中构建 Analysis Services 多维数据集的文件夹。默认位置为 C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Data。
OLAPACCOUNT="domain\logon_name" | 指定 MSSQLServerOLAPService 服务帐户的域和登录名。使用参数 OLAPPASSWORD 可以指定与登录名相对应的密码。如果不指定此参数，则将使用默认值。默认使用本地系统帐户。
OLAPAUTOSTART={1|0} | 指定重新启动 Microsoft Windows 操作系统时是否自动启动 MSSQLServerOLAPService 服务。指定 1 将允许该服务自动启动，指定 0 将禁止该服务自动启动。如果不指定此参数，则将使用默认值 1。
OLAPPASSWORD="password" | 指定 MSSQLServerOLAPService 服务帐户密码，该密码与由参数 OLAPACCOUNT 指定的登录名相对应。如果不指定此参数，则将使用默认值空密码。

有关从命令提示符进行安装时，可指定的 SQL Server 2005 安装参数的详细信息，请参阅 SQL Server 2005 安装媒体的根文件夹中的 template.ini 文件或参阅如何从命令提示符安装 SQL Server 2005。

通过使用 .Ini 文件来指定安装参数

您可以选择通过从 .ini 文件加载参数的方式来指定 setup 命令行参数。在 setup 命令行中，使用 /settings filename.ini 参数来指定 .ini 文件。

SQL Server 2005 安装媒体上的 template.ini 文件提供创建 .ini 文件的详细说明。请特别注意，.ini 文件中的第一个非注释行必须包含字符串 [Options]。下面的示例说明了 .ini 文件的格式：

复制代码
[Options]
USERNAME=MyName
COMPANYNAME=MyCompany
PIDKEY=ABCDE12345FGHIJ67890KLMNO
INSTALLSQLDIR="C:\Program Files\Microsoft SQL Server\"
INSTALLOLAPDATADIR="C:\Program Files\Microsoft SQL Server\MSSQL\OLAP\Data"
ADDLOCAL=Server_Components,Analysis_Server,AnalysisDataFiles,...
INSTANCENAME=MyInstance
OLAPACCOUNT=MyDomain/MyAccount
OLAPPASSWORD=MyPassword
OLAPAUTOSTART=1
...

有关通过使用 .ini 文件来指定 SQL Server 2005 安装参数的详细信息，请参阅 SQL Server 2005 安装媒体的根文件夹中的 template.ini 文件或参阅如何从命令提示符安装 SQL Server 2005。

请参阅

概念

安装 SQL Server Analysis Services


安装 SQL Server Reporting Services

安装 SQL Server Reporting Services |
 | 请参阅
安装 SQL Server 2005 组件 >

SQL Server Reporting Services (SSRS) 是基于服务器的端对端报表解决方案，它支持报表的创作、分发、管理和最终用户访问。Reporting Services 包含客户端组件和服务器组件。可以在单台计算机上安装所有组件，也可以在不同的计算机上分别安装单独的组件。涉及使用不同计算机的安装方案的示例包括：在群集节点上部署报表服务器的生产报表环境，有多个报表设计器客户端连接到单个报表服务器实例的开发机构，或使用可由机构中所有雇员组访问的远程 SQL Server 实例来存储其内部数据的工作组报表服务器。Reporting Services 可以与其他 SQL Server 组件和技术一起安装，也可以单独安装。可以在单台服务器上运行报表服务器的多个实例。有关详细信息，请参阅安装多个 Reporting Services 实例。

步骤 1：准备安装 Reporting Services

安装 Reporting Services 之前，请检查下列要求和组件说明：

  • 安装 SQL Server 2005 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

  • 设置 Windows 服务帐户

  • 选择要安装的 Reporting Services 组件

注意：
如果选择默认安装选项，则现有的报表服务器数据库文件可能会导致安装失败。当选择默认安装选项时，安装程序将尝试使用默认名称创建报表服务器数据库。如果使用该名称的数据库已经存在，安装程序将失败，您必须回滚安装。若要避免此问题，可在运行安装程序前重命名现有数据库，或选择“安装但不配置服务器”选项，以便在安装完成后指定自定义数据库设置。

步骤 2：安装 Reporting Services

查看 SQL Server 2005 的安装要求并验证计算机符合这些要求后，就可以开始安装 SQL Server 2005 Reporting Services 了。根据环境，用下列方式之一安装 Reporting Services：

  • 从命令行运行 Setup.exe 以执行静默安装或无人参与安装。有关详细信息，请参阅从命令提示符安装 Reporting Services。

  • 运行安装向导以安装默认配置或“仅文件”配置。有关详细信息，请参阅使用安装程序安装 Reporting Services。

    默认配置将所有组件本地安装在单台计算机上。此安装选项仅当同时安装数据库引擎和 Reporting Services 才可用。

    “仅文件”安装复制文件并最低限度地配置报表服务器。安装完成后，请使用 Reporting Services 配置工具使报表服务器联机。使用此方法可以指定远程计算机（例如选择要承载报表服务器数据库的远程数据库引擎实例），或者在分布式服务器、扩展部署或面向 Internet 的 Web 服务器上部署 Reporting Services。

步骤 3：配置 Reporting Services

安装 Reporting Services 后，可以修改安装以匹配正实现的部署模型。可以在完成安装后实现的部署模型的示例包括：

  • 在面向 Internet 的 Web 服务器上部署报表服务器。

  • 在承载其他 Web 应用程序的服务器上部署报表服务器。

  • 在分布式多服务器安装中部署一个或多个报表服务器。

若要了解如何在这些配置中部署报表服务器，请在安装完成后参阅 SQL Server 联机丛书中的部署 Reporting Services。

如果执行了“仅文件”安装，则必须使用 Reporting Services 配置工具来配置报表服务器，以使其就绪待用。有关详细信息，请参阅 SQL Server 联机丛书中的配置 Reporting Services 组件。

重要事项：
与早期版本的 Reporting Services 安装不同，现在使用 Reporting Services 配置来安装报表服务器扩展部署（以前称为“Web 场”）。有关如何更改安装和扩展部署的详细信息，请参阅 SQL Server 联机丛书中的 Reporting Services 可管理性和部署的增强功能和配置报表服务器扩展部署。

步骤 4：验证 Reporting Services 安装

安装和配置后，请验证 Reporting Services 组件是否运行。有关详细信息，请参阅如何验证 Reporting Services 安装。

请参阅

任务

如何并行安装 Reporting Services 及其早期版本

概念

升级 Reporting Services

其他资源

安装多个 Reporting Services 实例
在 64 位计算机上安装 Reporting Services
Reporting Services 安装帮助主题
Reporting Services 增强功能
Reporting Services 组件概述
安装 SQL Server 2005 组件


选择要安装的 Reporting Services 组件

选择要安装的 Reporting Services 组件 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server Reporting Services >

SQL Server 2005 Reporting Services (SSRS) 由服务器端组件和客户端组件构成，这两种组件既可以安装在一起，也可以分开安装。了解要使用的组件后，可以运行安装程序安装这些组件。有关如何安装特定组件的详细信息，请参阅使用安装程序安装 Reporting Services。

可以在单台计算机上多次运行安装程序以安装报表服务器的多个实例。客户端组件可以安装在使用 Reporting Services 的任何版本的计算机上。服务器组件要求 SQL Server 许可证。对于安装 Reporting Services 服务器组件的任何计算机，都必须具备有效的 SQL Server 许可证。

注意：
安装的版本决定了某些功能的可用性。有关详细信息，请参阅 SQL Server 联机丛书中的 SQL Server 2005 的各种版本所支持的功能。

服务器组件

Reporting Services 提供以下服务器组件。

报表服务器

报表服务器为交互式报表和计划报表提供报表处理、呈现和传递功能。报表服务器实现为 Microsoft Windows 服务和运行在 Microsoft Internet 信息服务 (IIS) 上的 ASP.NET Web 服务。这是一个无状态服务器，它将元数据和对象定义存储在报表服务器数据库中。安装报表服务器组件时，Windows 服务和 Web 服务也随之安装在主机上。

Microsoft 建议将报表服务器安装在运行 Windows Server 2003 或 Windows XP 的计算机上。虽然可以在 Windows 2000 Server 上安装和运行报表服务器组件，但存在一些已知的模拟和网络访问的限制，限制使用报表服务器的某些功能。

重要事项：
当选择报表服务器驻留的计算机时，不要使用其名称中带下划线的计算机。报表服务器不会保留名称中包含下划线字符的计算机以及已使用 Internet Explorer Security Patch MS01-055 进行修补的计算机中的会话状态信息。该安全修补程序会禁止在名称中包含下划线的客户端计算机中设置 cookie，从而中断 Reporting Services 的会话管理功能。Microsoft 知识库文章 316112 中介绍了建议的解决方案。

报表服务器数据库

Reporting Services 使用两个 SQL Server 数据库来为报表服务器实例提供内部存储：一个用来存储动态使用的数据，一个用于临时存储。这两个数据库一起创建，并按名称绑定。默认情况下，数据库名称分别为 reportserver 和 reportservertempdb。Reporting Services 要求有一个本地或远程 SQL Server 实例来承载这两个报表服务器数据库。可以使用 SQL Server 2000 或 SQL Server 2005 实例。有关报表服务器数据库版本要求的详细信息，请参阅创建报表服务器数据库。

报表服务器数据库可在安装期间或安装后创建。如果在同一台计算机中同时安装 SQL Server 2005 数据库引擎实例和 Reporting Services，则安装程序可以创建报表服务器数据库。但是，如果要使用 SQL Server 2000 来承载报表服务器数据库或者要使用任何远程 SQL Server 实例，您必须选择“安装但不配置服务器”安装选项，并在安装完成后使用 Reporting Services 配置工具来创建和配置报表服务器数据库。有关详细信息，请参阅如何安装本地报表服务器和远程报表服务器数据库。

报表管理器

报表管理器是基于 Web 的管理工具，用于管理单个报表服务器实例。默认情况下，它与报表服务器一起安装。如果使用其他工具管理报表服务器（如 SQL Server Management Studio 或自定义应用程序），则可通过从功能选择树中删除该组件来将其省略。

报表生成器

报表生成器是 ClickOnce 应用程序，它为用户提供创建即席报表的方法，即席报表由在模型设计器中创建和发布的数据模型生成。报表生成器与报表服务器组件一起安装。用户可通过报表管理器或 URL 来访问报表生成器。可通过配置角色分配或设置报表服务器系统属性来限制或阻止对报表生成器的访问。有关详细信息，请参阅 SQL Server 联机丛书中的保护报表生成器。

Reporting Services 配置

Reporting Services 配置工具与报表服务器实例一起安装。可以使用它自定义或部署报表服务器安装。在报表服务器安装中，该工具是必备的组件。

客户端组件

以下客户端组件与 Reporting Services 一起使用。这些组件可以安装在客户端计算机上，不需要 SQL Server 许可证。

报表设计器

Reporting Services 包括名为报表设计器的报表制作工具。可以使用报表设计器创建、编辑和预览报表，然后将其部署到报表服务器中。报表设计器在 Visual Studio 2005 中运行。

模型设计器

模型设计器是用于在报表生成器中为即席业务报表创建模型的工具。它用于指定最终用于支持即席报表的数据关系。模型设计器在 Visual Studio 2005 中运行。

命令提示实用工具

Reporting Services 中包含几种命令提示工具，可用于管理 Reporting Services 安装。大多数情况下，可以使用 Reporting Services 配置工具来代替命令提示实用工具。但是，如果更愿意使用命令行方法，可以安装以下实用工具来执行报表服务器管理任务：

  • Rsconfig 用于在安装完毕后修改报表服务器数据库的连接设置。还可以用它来设置无人参与的报表处理所需的加密帐户信息。

  • Rs 是脚本宿主，可用于处理 Microsoft Visual Basic 脚本，以重复执行常见的任务或在不同的计算机上运行相同的任务。

  • Rskeymgmt 用于备份和还原报表服务器使用的加密密钥。

有关每种工具的详细信息，请参阅 SQL Server 联机丛书中的 rsconfig 配置工具, rs 实用工具 和 rskeymgmt 实用工具。

SQL Server Management Studio

可以使用 Management Studio 管理一个或多个报表服务器实例。Management Studio 提供全面的服务器管理工作区，可用于从一个位置管理所有的 SQL Server 组件服务器。

SQL Server 配置管理器

可以使用 SQL Server 配置管理器查看和设置报表服务器 Windows 服务的属性，该服务用于安排报表服务器的操作和报表服务器的初始化。

选择部署模型

如果想节省 SQL Server 许可证或者报表要求不是很广泛，可以在同一台计算机上安装所有的服务器组件。但是，如果要支持大量的报表用户，则在一台专用服务器上安装报表服务器数据库可以获得更好的性能。有关部署模型的详细信息，请参阅 SQL Server 联机丛书中的安排 Reporting Services 部署计划。

请参阅

概念

安装 SQL Server Reporting Services

其他资源

Reporting Services 组件概述


报表服务器安装的默认配置

报表服务器安装的默认配置 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server Reporting Services >

使用 SQL Server 安装向导安装 Reporting Services 的报表服务器组件时，安装程序提供一个按默认配置安装服务器的选项。此安装选项安装并部署报表服务器。安装程序结束后，报表服务器便进入运行状态，可供使用。若使用安装向导，此选项的名称是“安装默认配置”。若使用命令行安装，此默认配置通过 RSCONFIGURATION 属性的 DEFAULT 设置来指定。

要求

默认配置安装选项有若干要求和限制，说明如下：

  • 必须使用 SQL Server 数据库引擎的本地实例来承载报表服务器数据库。数据库引擎必须与报表服务器实例同时安装。

  • 用于运行安装程序的用户帐户必须具有使用本地数据库引擎实例来访问和创建数据库的权限。

  • 必须在 Microsoft Internet Information Services (IIS) 中启用默认的 Web 站点或应用程序池，并且必须将其 Internet 协议 (IP) 地址映射为“（全部未分配）”。报表服务器和报表管理器虚拟目录将在默认 Web 站点中创建。

  • ASP.NET 必须在默认 ASP.NET 帐户下运行。报表服务器 Web 服务使用 ASP.NET 帐户。在 Windows Server 2003 上，默认 ASP.NET 帐户为 Network Service。在 Windows 2000 server 上，默认 ASP.NET 帐户是专为 ASP.NET 辅助进程创建的最少特权帐户。如果 ASP.NET 在非默认帐户下运行，安装程序将无法安装默认配置。

  • 在运行安装程序之前必须启用 IWAM_computername 帐户。安装程序使用此帐户配置 IIS。

默认配置设置

下表比较了默认配置中使用的设置和“仅文件”安装中使用的设置。除了 Microsoft Windows 服务帐户外，安装过程中无法指定默认配置中的值。

操作 | 默认配置 | “仅文件”安装
配置实例名 | 使用 SQL Server 实例名 | 使用 SQL Server 实例名
安装文件 | 是 | 是
配置 Web 服务帐户 | 对于 Windows XP 和 Windows 2000，安装程序使用 machine.config 中的 ASP.Net 计算机帐户或 Network Service 帐户。如果值不是二者之一，则不能使用默认安装。 在 Windows Server 2003 上，安装程序使用与默认 Web 站点所使用的应用程序池关联的帐户。 | 否
配置 Windows 服务 | 使用在安装向导的“服务帐户”页中指定的值。对于 Windows XP 和 Windows 2000，默认为本地系统。对于 Windows Server 2003，默认为 Network Service。 | 使用在安装向导的“服务帐户”页中指定的值。
设置文件夹权限 | 授予 Web 服务帐户和 Windows 服务帐户权限。 | 授予 Windows 服务帐户权限。
创建报表服务器数据库 | 是。创建 reportserver 和 reportservertempdb 数据库。 | 否
配置数据库连接 | 是。Web 服务帐户和 Windows 服务帐户被授予通过 rsexecrole 访问数据库的权利。 | 否
创建虚拟目录 | 是。在默认 Web 站点上用实例名确定的默认名称创建虚拟目录。 | 否
配置电子邮件传递 | 否 | 否
注册报表服务器 WMI 提供程序 | 是 | 是
启动报表服务器 Windows 服务 | 如果指定自动启动服务且没有发生安装错误，是。 | 否
初始化报表服务器 | 是 | 否

请参阅

参考

报表服务器安装选项

概念

安装 SQL Server Reporting Services
使用安装程序安装 Reporting Services


使用安装程序安装 Reporting Services

使用安装程序安装 Reporting Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server Reporting Services >

可以使用 SQL Server 安装向导安装 Reporting Services 组件。可以使用该向导安装部分或全部组件。

选择安装选项

在安装服务器组件时，安装向导提供了一些选项以确定如何安装报表服务器：

  • “安装默认配置”指示安装程序在安装报表服务器时使用默认值。此选项的结果是完全部署的报表服务器，该报表服务器一旦安装完毕即可使用。安装程序不会提示您提供虚拟目录名，选择 SQL 服务器数据库引擎实例，或者指定其他信息以完成安装。相反，安装程序将使用报表服务器安装的默认配置中说明的默认值。仅当同时安装本地数据库引擎实例和 Reporting Services 实例时，该默认安装选项才可用。如果有任何默认值不可用，则无法选择此安装选项。

  • “安装但不配置服务器”用于将程序文件复制到磁盘，配置报表服务器 Windows 服务帐户，以及注册报表服务器 Windows Management Instrumentation (WMI) 提供程序。此安装选项称为“仅文件”安装。需要进一步配置才能使用报表服务器。提供了 Reporting Services 配置工具，以便能够进行进一步配置。

    若要运行 Reporting Services 配置工具，请单击“开始”，依次指向“所有程序”、Microsoft SQL Server 2005 和“配置工具”，然后单击“Reporting Services 配置”。

如果指定“要安装的组件”页上的 Reporting Services，或者指定“功能选择”页上的“报表服务器”，便可以使用报表服务器安装选项。请注意，这些选项仅适用于服务器组件的安装。如果要安装客户端组件（如报表设计器、模型设计器或管理工具），则这些选项无效。

选择要安装的组件

可以通过选择“要安装的组件”页上的 Reporting Services 来安装服务器组件。可以通过选择“要安装的组件”页上的“工作站组件、联机丛书和开发工具”来安装客户端组件。

若要选择特定组件或安装 Reporting Services 产品文档或示例，请单击“高级”。单击“高级”将打开“功能选择”页，该页提供了可以单独安装的组件的完整列表。

如何安装特定组件

Reporting Services 包括用于创作报表和模型以及管理报表服务器的服务器组件和客户端组件。可以安装有助于管理服务器安装的 SQL Server 客户端组件。有关组件说明的详细信息，请参阅选择要安装的 Reporting Services 组件。

安装该组件 操作

报表服务器、Reporting Services 配置工具、SQL Server 外围应用配置器工具、SQL Server 配置管理器、报表生成器

报表服务器总是与用于启用服务器功能的工具一同安装。没有选项可从安装中排除这些工具。但如果在“功能组件”页中选择“共享工具”，则可指定这些工具在文件系统中的安装位置。

  1. 在“要安装的组件”页中选择 Reporting Services。

  2. 单击“高级”。

  3. 展开 Reporting Services。

  4. （可选）如果不想安装报表管理器，可将其删除。

  5. （可选）选择“共享工具”，然后单击“浏览”可选择共享实用工具的特定文件夹位置。

不能从服务器组件安装中删除报表生成器。但可在安装完成后将其禁用，这样该工具便无法运行。有关如何禁用报表生成器的详细信息，请参阅保护报表生成器。

报表管理器

选择“要安装的组件”页中的 Reporting Services 时，将默认选择“报表管理器”。

从“功能组件”页中删除报表管理器，便可安装 Reporting Services 而不安装报表管理器。也可以在单独的计算机中部署报表管理器和报表服务器。有关如何在单独的计算机中安装报表管理器和报表服务器的详细信息，请参阅配置用于 Internet 访问的报表服务器。

报表设计器和模型设计器

安装 Business Intelligence Development Studio 时，报表设计器和模型设计器可用。

  1. 在“要安装的组件”页中选择“工作站组件、联机丛书和开发工具”。

  2. 单击“高级”可验证是否选择了 Business Intelligence Development Studio 或修改要安装的组件列表。

示例报表和应用程序
  1. 在“要安装的组件”页中选择“工作站组件、联机丛书和开发工具”。

  2. 单击“高级”。

  3. 展开“文档、示例和示例数据库”。

  4. 选择“示例数据库以及示例代码和应用程序”。

请参阅

任务

如何安装本地报表服务器和远程报表服务器数据库
如何在单台计算机上安装 Reporting Services
如何验证 Reporting Services 安装
如何排除 Reporting Services 安装故障

概念

安装 SQL Server Reporting Services
选择要安装的 Reporting Services 组件
报表服务器安装的默认配置
从命令提示符安装 Reporting Services


从命令提示符安装 Reporting Services

从命令提示符安装 Reporting Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server Reporting Services >

Setup.exe 程序除提供图形界面的安装程序外，还提供命令提示符界面。可以在命令行下或 .ini 文件中指定安装属性，以自定义 Setup.exe 安装 Reporting Services 组件的方式，或取消用户界面。若要从命令行运行安装程序，您必须是系统中的本地管理员。

此主题说明用于在命令行安装中安装 Reporting Services 组件的属性。它还提供常见安装方案的示例。有关在命令行安装中使用的语法和参数的详细信息，请参阅从命令提示符运行安装程序和用 .ini 文件指定安装属性。

Reporting Services 的命令行示例

下面的示例说明常见 Reporting Services 安装方案的命令行语法和设置。为使这些示例正常工作，必须首先定位到包含 Setup.exe 程序的文件夹。示例设置说明了指定 .ini 安装文件以实现特定结果的不同方式。

静默命令行安装的基本语法

复制代码
Setup /settings c:\mysetup.ini /qn

在本地计算机上安装 Reporting Services 组件的设置

复制代码
[Options]
INSTANCENAME=MSSQLSERVER
ADDLOCAL=SQL_Engine,SQL_Data_Files,RS_Server,RS_Web_Interface,SQL_WarehouseDevWorkbench,SQL_ComputerManagement,SQL_Workbench,RS_tools
SQLAUTOSTART=1
AGAUTOSTART=1
RSAUTOSTART=1
SECURITYMODE=SQL
SAPWD=<password>
PERPROCESSOR=2
RSCONFIGURATION=Default
RSSQLLOCAL=1

安装文档和示例的设置

复制代码
[Options]
ADDLOCAL=SQL_Documentation,SQL_BooksOnline,SQL_SQLServerBooksOnline,SQL_Samples,SQL_AdventureWorksSamples,SQL_AdventureWorksDWSamples,SQL_ReportingServicesSamples

Reporting Services 组件的属性

从命令行安装 Reporting Service 时，可以指定以下属性。可以在命令行或 .ini 文件中指定属性，但不能同时在两者中指定属性。如果两者的输入发生冲突，则以命令行中的输入为准。

RSACCOUNT="domain\logon_name"

可选。默认值是当前操作系统的默认内置帐户。此属性应用于 RS_Server 功能选择。指定运行 Report Server Windows 服务的帐户。域名限制为 254 个字符，而帐户名限制为 20 个字符。下表显示了在没有提供 RSACCOUNT 值的情况下所选的默认内置帐户。

操作系统 帐户

Windows 2000

Local System

Windows XP

Local System

Windows Server 2003

域用户
RSPASSWORD="password"

可选。默认值为空密码。此属性应用于 RS_Server 功能选择。指定对应于为 RSACCOUNT 属性指定的用户名的密码。密码限制为 255 个字符。

RSUPGRADEDATABASEACCOUNT="username"

可选。指定用于连接到 SQL Server 实例（该实例在升级期间承载报表服务器数据库）的 SQL Server 数据库登录名。数据库用户必须有权修改架构。如果升级的是在远程 SQL Server 实例上运行的报表服务器，则设置此属性非常有用。数据库用户名限制在 20 个字符之内。

RSUPGRADEPASSWORD="password"

指定了 RSUPGRADEDATABASEACCOUNT 时为必需。指定用户帐户的密码。空字符串为无效值。密码未存储或保存。最大长度为 255 个字符。

RSCONFIGURATION={ default | filesonly }

可选。指定如何安装报表服务器实例。default 安装需要本地数据库引擎实例和使用默认值的系统配置。数据库引擎实例不能作为虚拟服务器安装。

filesonly 安装安装程序文件，并且对报表服务器安装进行最小配置。需要进一步配置以使报表服务器正常运行。如果未指定此属性，则使用 filesonly。有关详细信息，请参阅报表服务器安装的默认配置和报表服务器安装选项。

RSAUTOSTART={ 1 | 0 }

可选。默认值为 true (1)。此属性应用于 RS_Server 功能选择。指定当重新启动 Windows 时，Report Server Windows 服务是否自动启动。在操作系统中注册 Report Server Windows 服务时，服务启动类型根据此值进行设置。指定 true (1) 以自动启动服务，或指定 false (0) 将启动类型设置为手动。

ADDLOCAL = "feature_selection"

指定全新安装或现有安装中要安装的功能。指定的功能将列入逗号分隔的列表。安装特定功能时，还必须指定确保成功安装所必需的某些属性。下表列出了所需的每个功能和所有属性。

下表列出了可用于每个组件的属性。功能选择栏是通过命令提示符添加或删除组件时用于 ADDLOCAL 或 REMOVE 属性的 feature_selection 参数。

组件 | 功能选择值 | 可用属性
报表服务器 Web 服务和 Windows 服务，以及 Reporting Services 配置工具 | RS_Server | RSACCOUNT、RSPASSWORD、RSAUTOSTART、RSCONFIGURATION
报表管理器 | RS_Web_Interface | 无
报表设计器和模型设计器 | SQL_WarehouseDevWorkbench | 无
Reporting Services 命令行实用工具 | RS_Tools | 无
重要事项：
缺少系统必备项时，无法安装关联组件。如果受影响的组件是在 ADDLOCAL 属性的命令行中指定的，安装程序将终止运行并显示错误。

请参阅

概念

升级 Reporting Services
选择要安装的 Reporting Services 组件
安装 SQL Server Reporting Services

其他资源

Reporting Services 的向后兼容性


在 64 位计算机上安装 Reporting Services

在 64 位计算机上安装 Reporting Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server Reporting Services >

64 位版本的 Microsoft SQL Server 2005 中包括 Reporting Services。下表汇总了不同类型的 64 位体系结构的特别注意事项。

体系结构 | 特别注意事项
x64 | x64 操作系统完全支持 SQL Server 2005 Reporting Services。 可以对带 Service Pack 1 的 Microsoft Windows Server 2003 安装和运行 Reporting Services 的所有服务器和客户端组件。 安装的操作系统、Service Pack 以及 SQL Server 的版本必须是 64 位版本。
IA64 | 该平台专门用于生产服务器。不支持 Business Intelligence Development Studio 中的集成报表设计器或模型设计器。在此体系结构中无法安装上述设计工具。
Microsoft Windows-32-on-Windows-64 (WOW64) 子系统 | 可以在 WOW64 中运行 32 位版本的 Reporting Services ASP.NET 应用程序。必须指定 IIS 中的设置，才能启用该配置。有关详细信息，请参阅如何将 IIS 配置为在 WOW64 模式下运行 32 位 Reporting Services。
注意：
任何 64 位平台都不支持 SQL Server 2000 Reporting Services。虽然 SQL Server 2000 Service Pack 4 引入了对 Microsoft Windows-32-on-Windows-64 (WOW64) 子系统的支持，但对 WOW64 的支持并不扩展到 SQL Server 2000 Reporting Services。

请参阅

参考

SQL Server 2005 的各种版本所支持的功能

概念

安装 SQL Server Reporting Services

其他资源

64 位计算机上的 Integration Services 注意事项


安装多个 Reporting Services 实例

安装多个 Reporting Services 实例 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server Reporting Services >

可以在同一台计算机上安装多个 Reporting Services 实例。如果要承载特定站点的不同内容，安装多个实例会很有用。每个实例将拥有自己的报表服务器数据库、配置文件和虚拟目录。如果要在多个实例间共享单个报表服务器数据库，则可配置一个扩展部署。有关此部署方案的详细信息，请参阅配置报表服务器扩展部署。

对于多实例安装，可以使用以下配置：

  • 单服务器部署中的多实例，其中每个报表服务器实例都使用自己的本地报表服务器数据库。

  • 多报表服务器实例，其中每个实例都连接到自己的远程报表服务器数据库。

每个 SQL Server 实例都独立于同一台计算机上运行的其他实例。可以在同一台计算机上，将不同的版本和版本类别安装成为单独实例，例如，将 SQL Server 2000 Enterprise Edition 和 SQL Server 2005 Developer Edition 作为单独的实例运行。

可以配置每个实例，使其使用特定的 Internet 协议 (IP) 地址。如果执行以此操作，则还必须执行其他步骤，使用户可以使用服务器。本主题将进一步介绍这些步骤。

安装报表服务器实例

若要安装多个 Reporting Services 实例，必须为每个要安装的报表服务器实例运行一次安装程序。不能一次安装多个实例。第一次运行安装程序时，只要满足该安装类型的要求，就可以选择执行默认安装。附加的实例必须作为命名实例安装。在文件系统中，每个报表服务器实例的程序文件保存在单独的实例文件夹中（例如 MSSQL.2、MSSQL.3 等等）。安装程序按照实例的安装顺序创建文件夹。有关安装多个实例的详细信息，请参阅如何安装 SQL Server 2005（安装程序）。

配置报表服务器实例

若要在同一台计算机上配置不同的报表服务器实例，可以使用 Reporting Services 配置工具选择要配置的实例。Reporting Services 使用 SQL Server 实例命名约定来标识每个实例：

  • 默认实例使用默认实例名 MSSQLServer。

  • SQL Server Express 的默认实例为 SQLExpress。请注意，SQL Server Express 始终作为命名实例安装）。

  • 其他命名实例都按照安装时提供的名称进行标识。

有关如何连接到特定报表服务器实例的详细信息，请参阅如何启动 Reporting Services 配置。

访问多实例部署中的报表服务器实例

若要访问报表服务器或报表管理器的一个特定实例，或者要将报表发布到某个特定实例，可键入要使用的实例的 URL。

每个实例的虚拟目录必须是唯一的。如果是为命名实例或默认 SQL Server Express 实例创建虚拟目录，则 Reporting Services 配置工具会自动合并实例信息，以便创建唯一的虚拟目录名称。例如，假设在名为 SERVER01 的服务器上安装了一个默认报表服务器实例，那么命名报表实例（标识为 TestServer）、SQL Server Express 实例以及这些实例的默认 URL 将如下所示：

  • http://server01/reportserver

  • http://server01/reportserver

  • http://server01/reportserver

配置报表服务器实例以使用唯一的 IP 地址

默认情况下，报表服务器实例被配置为默认网站，其中的 IP 地址被映射为（全部未分配）。可以将默认网站及其现有配置用于承载同一台计算机上安装的所有报表服务器实例，也可以在单独的网站上运行各个报表服务器实例。如果要为每个报表服务器实例映射一个特定的 IP 地址，则必须使用单独的网站。

若要将每个报表服务器实例都配置为使用特定 IP 地址，请按以下步骤操作：

  1. 运行安装程序安装各个报表服务器实例。如果满足了默认安装的所有条件，则可在一个安装中使用默认 SQL Server 实例。否则，必须将 Reporting Services 安装为命名实例。安装命名实例时，可在“报表服务器安装选项”页中选择“安装但不配置服务器”选项。

  2. 在 Internet 信息服务管理器中，配置网站（每个实例一个）以使用特定的 IP 地址。IP 地址是在“网站属性”对话框的“网站”选项卡中指定的。

  3. 运行 Reporting Services 配置工具配置各个实例：

    1. 连接到要配置的实例。

    2. 在“报表服务器虚拟目录”页上，单击“新建”。指定网站，然后键入一个虚拟目录名。

    3. 在“报表管理器虚拟目录”页上，单击“新建”。指定与报表服务器所用网站相同的网站，然后键入一个虚拟目录名。

    4. （可选）。在“Web 服务标识”中，单击“新建”，为报表服务器实例创建一个唯一应用程序域。为报表管理器重复此步骤。可以为每个实例以及同一实例中的每个应用程序创建唯一应用程序域。在多数情况下，在实例级别创建唯一应用程序域就可以提供足够的隔离。

    完成报表服务器的配置还必须执行其他步骤（特别是在创建和配置报表服务器数据库时）。此处不再重复这些步骤。有关创建和配置数据库的详细信息，请参阅创建报表服务器数据库。

  4. 编辑 RSWebApplication.config 文件，指定 ReportServerUrl 配置设置。

    1. 删除 ReportServerVirtualDirectory 中的条目。只删除值，不要删除标记。

    2. 在 ReportServerUrl 中，键入报表服务器实例的完全限定名称。完全限定报表服务器 URL 由前缀、服务器名称和虚拟目录组成。无需指定网站。以下示例展示了应使用的语法： https://salesreports/reportserver

    通过编辑 RSWebApplication.config 文件，为计算机上的每个 Reporting Services 实例重复此步骤。有关此配置文件的详细信息，请参阅 SQL Server 联机丛书中的 RSWebApplication 配置文件。

  5. 如果打算使用报表服务器电子邮件传递，请编辑 RSReportServer.config 文件，将 UrlRoot 设置为报表服务器的完全限定名称。

    通过编辑 RSReportServer.config 文件，为计算机上的每个 Reporting Services 实例重复此步骤。请确保对报表服务器电子邮件订阅进行测试，以验证链接是否被正确解析。有关此配置文件的详细信息，请参阅 SQL Server 联机丛书中的 RSReportServer 配置文件。

请参阅

任务

如何启动 Reporting Services 配置

参考

实例名称

概念

安装 SQL Server Reporting Services
配置报表服务器虚拟目录


安装 SQL Server Integration Services

安装 SQL Server Integration Services
安装 SQL Server 2005 组件 >

步骤 1：准备安装 Integration Services

在安装 Microsoft SQL Server 2005 Integration Services (SSIS) 之前，请检查以下要求：

  • 安装 SQL Server 2005 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

注意：
SQL Server 2005 Integration Services 不为故障转移群集提供特殊安装选项。但分别在群集的每个节点中安装 Integration Services 之后，可对其进行手动配置，以使其作为群集服务运行。有关详细信息，请参阅如何在群集中配置 Integration Services。

步骤 2：安装 Integration Services

在检查了 SQL Server 2005 的安装要求并确保计算机满足这些要求之后，就可以安装 Integration Services 了。根据环境的不同，将以下列方式之一安装 Integration Services：

  • 在干净的计算机上安装 Integration Services

  • 并行安装 Integration Services 和 SQL Server 2000 Data Transformation Services

  • 升级到 Integration Services

注意：
如果在 SQL Server 安装向导的“要安装的组件”页或“功能选择”页上选择安装某些 SQL Server 2005 组件，将同时安装 Integration Services 组件的部分子集。这些组件对特定任务是有用的，但 Integration Services 功能将受到限制。例如，数据库引擎 选项将安装 SQL Server 导入和导出向导所需的 Integration Services 组件。Business Intelligence Development Studio 选项将安装在设计包时所需的 Integration Services 组件，但不会安装 Integration Services 服务，并且消息队列任务无法正常运行，您无法在 BI Development Studio 之外运行包。为了确保完整安装 Integration Services，必须在“要安装的组件”页上选择 Integration Services。

注意：
有关安装在 64 位计算机上的 SQL Server 2005 功能的信息，请参阅 64 位计算机上的 Integration Services 注意事项。

在干净的计算机上安装 Integration Services

与 SQL Server 2005 的任何组件一样，可以通过 SQL Server 安装向导运行 SQL Server 安装程序来安装 Integration Services，也可以通过从命令提示符运行安装程序来安装它。

选项 1：使用 SQL Server 安装向导

使用 SQL Server 安装向导可以在本地计算机上安装 Integration Services。

主题 说明

使用安装程序安装 SQL Server Integration Services

特定于 Integration Services 的安装信息。

如何安装 SQL Server 2005（安装程序）

描述 SQL Server 安装向导的每个步骤的安装信息，该信息适用于 SQL Server 2005 的所有组件，包括 Integration Services。
选项 2：从命令提示符运行安装程序

您可以从命令提示符运行 SQL Server 安装程序。在远程计算机上安装 Integration Services 时，必须从命令提示符运行安装程序。

主题 说明

从命令提示符安装 SQL Server Integration Services

特定于 Integration Services 的命令提示符安装信息。

如何从命令提示符安装 SQL Server 2005

描述命令提示符安装过程的每个步骤和选项的命令提示符安装信息，该信息适用于 SQL Server 2005 的所有组件，包括 Integration Services。

并行安装 Integration Services 和 SQL Server 2000 Data Transformation Services

可以并行安装 Integration Services 和 Microsoft SQL Server 2000 Data Transformation Services (DTS)。以后还可以将现有的 DTS 包迁移为 Integration Services 包格式，同时现有的包保持不变。

主题 | 说明
升级或迁移 Data Transformation Services | 有关并行安装和包迁移的常规信息。
迁移 Data Transformation Services 包 | 有关包迁移向导以及 SQL Server 2000 Data Transformation Services 和 Integration Services 包之间的差异的信息。
SQL Server 2005 Integration Services 的向后兼容性 | 有关在 Integration Services 中对 SQL Server 2000 Data Transformation Services 的支持的信息。

升级到 Integration Services

使用 SQL Server 安装程序安装 Integration Services，可以从 Data Transformation Services 升级到 Integration Services，然后可以选择使用包迁移向导将现有的 DTS 包迁移为新的 Integration Services 包格式，同时现有的包保持不变。

主题 | 说明
升级或迁移 Data Transformation Services | 有关并行安装和包迁移的常规信息。
迁移 Data Transformation Services 包 | 有关包迁移向导以及 SQL Server 2000 Data Transformation Services 和 Integration Services 包之间的差异的信息。
SQL Server 2005 Integration Services 的向后兼容性 | 有关在 Integration Services 中对 SQL Server 2000 Data Transformation Services 的支持的信息。

更改历史记录

版本 历史记录

2005 年 12 月 5 日

新增内容：
  • 添加了注释，这些注释可将用户引向 Integration Services 群集配置和 64 位功能主题，以了解详细信息。


使用安装程序安装 SQL Server Integration Services

使用安装程序安装 SQL Server Integration Services
安装 SQL Server 2005 组件 > 安装 SQL Server Integration Services >

注意：
有关使用 SQL Server 安装向导来安装 Microsoft SQL Server 2005 组件的详细信息，建议您查看如何安装 SQL Server 2005（安装程序）。

本主题只包含使用 SQL Server 安装向导安装 Microsoft SQL Server 2005 Integration Services (SSIS) 时特有的信息。

  • 选择要安装的组件

  • 指定 Integration Services 文件位置

  • 安装 Integration Services 服务

  • 安装 SQL Server 2000 Data Transformation Services 包的支持组件

注意：
如果在 SQL Server 安装向导的“要安装的组件”页或“功能选择”页上选择安装某些 SQL Server 2005 组件，将同时安装 Integration Services 组件的部分子集。这些组件对特定任务是有用的，但 Integration Services 功能将受到限制。例如，数据库引擎 选项将安装 SQL Server 导入和导出向导所需的 Integration Services 组件。Business Intelligence Development Studio 选项将安装在设计包时所需的 Integration Services 组件，但不会安装 Integration Services 服务，并且消息队列任务无法正常运行，您无法在 BI Development Studio 之外运行包。为了确保完整安装 Integration Services，必须在“要安装的组件”页上选择 Integration Services。

注意：
有关安装在 64 位计算机上的 SQL Server 2005 功能的信息，请参阅 64 位计算机上的 Integration Services 注意事项。

选择要安装的组件

虽然可单独安装 Integration Services，但许多数据仓库解决方案需要安装其他 SQL Server 2005 组件才能开发、部署和管理 Integration Services 包。下表描述这些附加或可选的 SQL Server 2005 组件。

组件 | 适用于管理员 | 适用于开发人员 | 可选组件
连接组件 用于客户端与服务器之间通信的组件，包括用于 DB-Library、ODBC 和 OLE DB 的网络库。 | X | X |
管理工具 用于管理 SQL Server 2005 的交互工具，包括 SQL Server 配置管理器、SQL Server Management Studio、SQL Server 事件探查器 和复制监视器。 | X |  |
Business Intelligence Development Studio 商业智能项目的集成开发环境。 |  | X |
软件开发包 可帮助开发人员为 SQL Server 2005 创建自定义解决方案的软件。 |  | X |
SQL Server Database Services SQL Server 数据库引擎 和用于管理关系数据和 XML 数据、复制以及全文搜索的工具。 |  |  | X
SQL Server Analysis Services SQL Server 2005 Analysis Services (SSAS) 和用于支持联机分析处理 (OLAP) 和数据挖掘的工具。 |  |  | X
SQL Server Reporting Services 报表服务器和报表管理器，前者用于管理、执行、呈现和分发报表，后者是用于访问 SQL Server 2005 Reporting Services (SSRS) 组件的基于 Web 的用户界面，包括管理工具和查看报表的用户界面。 |  |  | X
文档和示例 SQL Server 联机丛书文档、编程参考材料和所有 SQL Server 2005 组件的示例。 | X | X | X

安装所选组件

Integration Services 可以单独安装，也可以与其他 SQL Server 2005 组件一起安装，如以下过程所述。

只安装 Integration Services

  • 在 SQL Server 安装向导的“要安装的组件”页上，只选择 Integration Services。

    注意：
    如果选择只安装 Integration Services，则默认情况下不安装 SQL Server 2005 客户端组件，这些组件包括命令行工具、连接组件、编程模型、管理和开发工具、文档以及示例。

使用“要安装的组件”页添加或删除安装组件

  • 在“要安装的组件”页上，选中要添加的组件的复选框，清除要删除的组件的复选框。

    注意：
    默认情况下，如果在“要安装的组件”页上选择“工作站组件、联机丛书和开发工具”安装选项，将不会选择示例数据库和编程示例。若要安装示例数据库和编程示例，必须在“功能选择”页上手动选择这些选项。

使用“功能选择”页添加或删除安装组件

  1. 在“要安装的组件”页中，单击“高级”。

  2. 在“功能选择”页上，选中要添加的组件的复选框，清除要删除的组件的复选框。

    注意：
    “功能选择”页是在 SQL Server 安装向导中查看安装选项的详细列表（包括本主题先前列出的组件）的好方法。

指定 Integration Services 文件位置

SQL Server 2005 安装程序将 Integration Services 程序文件和共享文件分多处存放。下表列出了 Integration Services 文件的默认文件夹位置：

Integration Services 文件 | 默认位置
Integration Services 核心组件和 dtexec 命令提示实用工具 | C:\Program Files\Microsoft SQL Server\90\DTS\Binn
Integration Services 连接管理器 | C:\Program Files\Microsoft SQL Server\90\DTS\Connections
Integration Services 枚举器 | C:\Program Files\Microsoft SQL Server\90\DTS\ForEachEnumerators
将数据类型从一个数据库版本或系统映射到另一个数据库版本或系统（例如，从 SQL Server 2000 映射到 SQL Server 2005，或从 SQL Server 2005 映射到 Oracle）的 XML 格式文件。SQL Server 导入和导出向导将使用这些映射文件。 | C:\Program Files\Microsoft SQL Server\90\DTS\MappingFiles
Integration Services 数据流组件，由源、转换和目标组成 | C:\Program Files\Microsoft SQL Server\90\DTS\PipelineComponents
Integration Services 运行时任务 | C:\Program Files\Microsoft SQL Server\90\DTS\Tasks
由 SQL Server 2005 组件的所有实例共享的组件 | C:\Program Files\Microsoft SQL Server\90\Shared 安装期间无法更改此文件夹。
工具、文档和示例 | C:\Program Files\Microsoft SQL Server\90\Tools 为所有 Analysis Services 实例和其他 SQL Server 组件安装一组工具和文档。

在安装过程中更改 Integration Services 文件的默认位置

  1. 在“要安装的组件”页中，单击“高级”。

  2. 在“功能选择”页上，单击支持非默认安装路径的功能，再单击“浏览”。

  3. 在“更改文件夹”页的“安装路径”框中，输入新的文件位置。
重要事项：
在“功能选择”页上可以将某些 SQL Server 2005 组件安装到默认位置 %ProgramFiles%\Microsoft SQL Server\90 之外的位置上。此选项可用于 SQL Server 2005 Integration Services、SQL Server 2005 Notification Services 和工作站组件（客户端工具、文档和示例）。从命令提示符进行安装时，此选项所用的相应开关是 installsqlshareddir。

安装 Integration Services 服务

Integration Services 将安装 Integration Services 服务，该服务是一个新的功能部件，在 SQL Server 2000 Data Transformation Services 中没有等效项，它可提供多项增强功能。Integration Services 服务允许您在 SQL Server Management Studio 中执行以下操作：

  • 监视正在计算机上运行的所有 Integration Services 包的执行情况。

  • 显示存储在不同物理位置中的 Integration Services 包和文件夹的层次结构视图。

注意：
创建、存储和执行 SSIS 包时不需要此服务。

如果在“要安装的组件”页上选择了 SQL Server Integration Services 组件，则默认安装并启用 Integration Services 服务。

该服务被注册为在网络服务帐户下运行。此设置不能通过 SQL Server 安装向导修改，也不受在该向导的“服务帐户”页上所做的任何选择的影响。

此服务在它自己的进程中运行，不依赖于 SQL Server 代理进程。

若要管理此服务，请使用 SQL Server 配置管理器，或打开“控制面板”中的“管理工具”，使用 Microsoft 管理控制台 (MMC) 的“服务”管理单元。有关详细信息，请参阅管理 Integration Services 服务。

安装 SQL Server 2000 Data Transformation Services 包的支持组件

如果选择安装“Integration Services”，则安装程序还将安装 SQL Server 2000 Data Transformation Services (DTS) 包的支持组件，包括 SQL Server Management Studio 中的 DTS 运行时和 DTS 包枚举。运行时支持已更新，允许 DTS 包访问 SQL Server 2005 数据源。如果未安装 Integration Services，但需要支持 DTS 包，则需要确保在“功能选择”页上选择了“早期组件”。

安装的向后兼容性文件还包括 SQL Server 2000 Analysis Services 处理任务及其依赖项，即决策支持对象 (DSO)。但是它们不包括 SQL Server 2000 数据挖掘预测查询任务。

注意：
SQL Server 2005 不安装用于编辑 DTS 包的 DTS 包设计器。有关详细信息，请参阅 SQL Server 2005 Integration Services 的向后兼容性。

选择安装 Integration Services 时，还将安装包迁移向导。还可以使用包迁移向导将 SQL Server 2000 DTS 包升级为 Integration Services 格式。迁移过程中，该向导复制 DTS 包，然后以 Integration Services 格式重新创建这些包。源包将保持不变且不会被修改。有关详细信息，请参阅迁移 Data Transformation Services 包。

注意：
SQL Server 2005 的 Standard Edition、Enterprise Edition 和 Developer Edition 提供了包迁移向导。

更改历史记录

版本 历史记录

2005 年 12 月 5 日

新增内容：
  • 添加了注释，这些注释可将用户引向 Integration Services 64 位功能主题，以了解详细信息。

已更改的内容
  • 改进了早期组件的安装选项说明。


从命令提示符安装 SQL Server Integration Services

从命令提示符安装 SQL Server Integration Services
安装 SQL Server 2005 组件 > 安装 SQL Server Integration Services >

注意：
有关从命令提示符安装 Microsoft SQL Server 2005 组件的详细信息，我们建议您参阅如何从命令提示符安装 SQL Server 2005。

本主题只包含有关从命令提示符安装 Microsoft SQL Server 2005 Integration Services (SSIS) 的特定信息。

注意：
您选择安装的某些 SQL Server 2005 组件可能会安装 Integration Services 组件的一部分子集。这些组件对特定任务是有用的，但 Integration Services 功能将受到限制。例如，数据库引擎 选项将安装 SQL Server 导入和导出向导所需的 Integration Services 组件。Business Intelligence Development Studio 选项将安装在设计包时所需的 Integration Services 组件，但不会安装 Integration Services 服务，并且消息队列任务无法正常运行，您无法在 BI Development Studio 之外运行包。为了确保完整安装 Integration Services，必须选择安装 Integration Services。

注意：
有关安装在 64 位计算机上的 SQL Server 2005 功能的信息，请参阅 64 位计算机上的 Integration Services 注意事项。

Integration Services 命令提示符安装参数

可以从本地或远程服务器上的命令提示符安装 Microsoft SQL Server 2005 Integration Services (SSIS)。如果从命令提示符安装，则可以在命令提示符下指定安装参数，也可以使用 /settings 开关从 .ini 文件加载安装参数。您必须使用安装命令行参数或 .ini 文件，但不能两者同时使用。

从命令提示符进行安装时，必须使用 addlocal="feature1,feature2,..." 开关来指定要安装的 SQL Server 2005 功能。下表显示安装 Integration Services 时可以指定的参数，该安装包括 Integration Services 组件、管理和开发工具、SQL Server 数据库引擎 和 SQL Server 联机丛书。

值 | 指定
SQL_DTS | Integration Services 组件。还安装 Microsoft SQL Server 2000 Data Transformation Services (DTS) 包的支持组件，包括 SQL Server Management Studio 中的 DTS 运行时和 DTS 包枚举。
SQL_WarehouseDevWorkbench | Business Intelligence Development Studio.
SQL_Workbench | SQL Server Management Studio.
SQL_Engine | SQL Server 数据库引擎。
SQL_Data_Files | SQL Server 数据库引擎 的数据文件。指定 SQL_Engine 选项时，需要此选项。
SQL_BooksOnline | SQL Server 联机丛书。如果不指定此选项，则在设计器、编辑器和向导中将不没有上下文相关的帮助。

例如，若要安装 Integration Services 实例及产品文档，可按以下示例所示设置 addlocal 参数：

复制代码
   setup addlocal="SQL_DTS,SQL_BooksOnline"

有关可以在 addlocal 参数中指定的 SQL Server 2005 功能的详细信息，请参阅 SQL Server 2005 安装媒体的根文件夹中的 template.ini 文件或参阅如何从命令提示符安装 SQL Server 2005。

重要事项：
现在可以选择将某些 SQL Server 2005 组件安装到默认位置 (%ProgramFiles%\Microsoft SQL Server\90) 以外的其他位置。此选项对于 Integration Services、SQL Server 2005 Notification Services 和工作站组件（客户端工具、文档和示例）是可用的。从命令提示符进行安装时，用于此选项的开关是 installsqlshareddir。

其他必需的命令提示符安装参数

一些其他参数，如 PIDKEY，是使用 setup 命令从命令提示符执行的任何安装都需要的。对于 Integration Services 和其他 SQL Server 2005 组件的特定安装，可能还需要其他参数。

有关从命令提示符安装 SQL Server 2005 产品和技术的详细信息，请参阅如何从命令提示符安装 SQL Server 2005。

通过使用 .Ini 文件来指定安装参数

您可以选择通过从 .ini 文件加载参数的方式来指定 setup 命令提示参数。在 setup 命令行上，使用 /settings filename.ini 参数来指定 .ini 文件。

SQL Server 2005 安装媒体上的 template.ini 文件提供创建 .ini 文件的详细说明。请特别注意，.ini 文件中的第一个非注释行必须包含字符串：[Options]。下面的示例说明了 .ini 文件的格式：

复制代码
[Options]
USERNAME=MyName
COMPANYNAME=MyCompany
PIDKEY=ABCDE12345FGHIJ67890KLMNO
ADDLOCAL=SQL_DTS, SQL_BooksOnline,...
...

有关如何通过使用 .ini 文件来指定 SQL Server 2005 安装参数的详细信息，请参阅 SQL Server 2005 安装媒体的根文件夹中的 template.ini 文件或参阅如何从命令提示符安装 SQL Server 2005。

更改历史记录

版本 历史记录

2005 年 12 月 5 日

新增内容：
  • 添加了注释，这些注释可将用户引向 Integration Services 64 位主题，以了解详细信息。

已更改的内容：
  • 阐明不完整的 Integration Services 安装的限制。


安装 SQL Server Notification Services

安装 SQL Server Notification Services |
 | 请参阅
安装 SQL Server 2005 组件 >

Microsoft SQL Server Notification Services 是用于开发和部署生成并发送通知的应用程序的平台。可以使用 Notification Services 将及时的个性化消息发送到成千上万的订阅方，还可以将消息传递到各种各样的设备。

此部分提供有关安装 Notification Services 的信息。

步骤 1：验证必备组件

安装 Notification Services 之前，请查看下列要求：

  • 安装 SQL Server 2005 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

步骤 2：确定要安装的组件

Notification Services 有两组可安装组件：引擎和客户端。根据部署，可以安装全部组件或只安装其中一组。

  • 引擎组件运行 Notification Services 实例和应用程序。

  • 客户端组件用于与其他服务器的实例和应用程序数据进行交互。

根据使用 Notification Services 的方式，在一个或多个服务器上安装其组件。必须将组件安装在任何承载下列 Notification Services 功能的服务器上：

  • 任何运行宿主事件提供程序、生成器或分发服务器的服务器都需要引擎组件。

  • 任何运行非宿主事件提供程序或订阅管理界面的服务器都需要客户端组件。注册实例和使用 Notification Services API 都需要客户端组件。

  • 任何用于管理 Notification Services 实例的服务器都需要客户端组件。注册实例以及与实例交互都需要客户端组件。客户端组件包含在 SQL Server Management Studio 中。

步骤 3：安装 Notification Services

准备安装 Notification Services 时，请使用下列方法之一执行安装：

  • 使用安装程序安装 Notification Services

  • 从命令提示符安装 Notification Services

步骤 4：配置 Notification Services

安装 Notification Services 后，可以创建 Notification Services 应用程序、配置 Notification Services 实例以承载这些应用程序并部署 Notification Services 实例。有关详细信息，请参阅 SQL Server 联机丛书的下列部分：

  • 生成通知解决方案

  • 部署 Notification Services

部署 Notification Services 实例后，可以使用 SQL Server Management Studio 或 nscontrol 命令提示实用工具配置这些实例。有关详细信息，请参阅管理 Notification Services。

卸载 Notification Services

如果要永久删除 Notification Services，应该在卸载产品前先删除 Notification Services 实例。如果要将 Notification Services 实例升级到 SQL Server 的新版本，请将实例保留在原位并按照 Notification Services 迁移说明操作。For more information, see the following topics:

  • 删除 Notification Services 实例

  • 迁移 Notification Services 实例

  • 如何卸载 Notification Services

请参阅

其他资源

安装 SQL Server 2005 组件


使用安装程序安装 Notification Services

使用安装程序安装 Notification Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server Notification Services >

安装 Notification Services 时，不是安装 Notification Services 的实例，而是安装 Notification Services 二进制文件。然后，配置和部署 Notification Services 的实例，这些实例承载通知应用程序。

Notification Services 的实例可运行于多种系统配置中。例如，Notification Services 引擎和数据库可在一个服务器上，或者引擎和数据库可在不同的服务器上。此外，可以有位于远程服务器上的订阅管理界面或非宿主事件提供程序。

凡是要运行 Notification Services 引擎（该引擎运行宿主事件提供程序、生成器和分发服务器）的地方，都必须安装 Notification Services；凡是要运行非宿主事件提供程序、订阅管理界面或管理控制台的地方，都必须安装 Notification Services 客户端组件。

单服务器安装

在单服务器安装中，Notification Services 和 Microsoft SQL Server 数据库引擎运行在同一个服务器上。这种情况常见于开发系统和中小型部署系统。

运行安装程序时，安装 SQL Server 数据库引擎和 Notification Services 的实例。可能还需要安装工作站组件，以便用 SQL Server Management Studio 创建和管理使用 SQL Server Management Studio 的 Notification Services 实例。
安装 Notification Services 和数据库引擎
  • 如何安装 Notification Services 和数据库引擎

远程 Notification Services 引擎

Notification Services 引擎组件（用来运行宿主事件提供程序、生成器和分发服务器）可以在与数据库引擎不同的服务器上。

定义 Notification Services 应用程序时，指定每个宿主事件提供程序、生成器和分发服务器运行时所在的服务器。在每个指定的服务器上，需要安装 Notification Services 引擎组件。通过安装 Notification Services 来安装这些组件。

注意：
通过 SQL Server 安装程序中的“功能选择”对话，可以安装引擎组件和客户端组件。安装引擎组件相当于安装所有 Notification Services。
安装 Notification Services
  • 如何安装 Notification Services 引擎组件

远程通知服务客户端

大多数 Notification Services 应用程序都要求一个或多个客户端应用程序。运行客户端应用程序但不运行引擎组件的服务器要求 Notification Services 客户端组件。

以下类型的应用程序使用客户端组件：

  • 订阅管理界面

  • 非宿主事件提供程序

  • 管理控制台

安装 Notification Services 客户端组件时安装除运行 Notification Services 引擎所需的文件以外的所有 Notification Services 文件。

注意：
安装 SQL Server Management Studio 时，会安装 Notification Services 客户端组件。
安装客户端组件
  • 如何安装 Notification Services 客户端组件

请参阅

概念

安装 SQL Server Notification Services
从命令提示符安装 Notification Services
迁移 Notification Services 实例


从命令提示符安装 Notification Services

从命令提示符安装 Notification Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server Notification Services >

除了图形用户界面，Microsoft SQL Server 2005 安装程序还提供命令提示符界面。请使用本主题中的信息从命令提示符安装 Notification Services。有关从命令提示符安装 SQL Server 2005 的其他信息（包括完整的语法和参数列表），请参阅如何从命令提示符安装 SQL Server 2005。

Notification Services ADDLOCAL 值

可以使用 Microsoft Windows Installer 的 ADDLOCAL 参数，从命令提示符安装每个 Notification Services 组件。要从命令行安装组件，用户必须使用正确的命令行名称。各组件的组件名称和命令行名称如下表所示。

组件名称 | 命令行名
所有 Notification Services 组件 | Notification_Services
Engine components | NS_Engine
Client components | NS_Client

示例

以下示例说明如何从命令提示符安装 Notification Services。

安装所有 Notification Services 组件

下面的示例说明如何安装 Notification Services 的所有组件，同时显示进度对话框：

start /wait setup.exe /qb ADDLOCAL=Notification_Services

安装 Notification Services 客户端组件

下面的示例说明如何执行 Notification Services 客户端组件的新安装。不显示任何对话框，但命令提示符要等到安装完成才返回：

start /wait setup.exe /qn ADDLOCAL=NS_Client

删除 Notification Services 客户端组件

下面的示例说明如何删除 Notification Services 客户端组件，同时显示进度对话框：

start /wait setup.exe REMOVE=NS_Client

请参阅

概念

安装 SQL Server Notification Services
使用安装程序安装 Notification Services


安装 SQL Server 复制

安装 SQL Server 复制 |
 | 请参阅
安装 SQL Server 2005 组件 >

可以使用 Microsoft SQL Server 2005 安装向导、从命令提示符或通过使用 .ini 文件安装复制组件。请在安装 SQL Server 实例或修改现有实例时安装复制。

安装复制组件后，必须配置服务器才可以使用复制。有关详细信息，请参阅 SQL Server 2005 联机丛书中的配置和维护复制。

重要事项：
如果在修改 SQL Server 现有实例的时候安装复制组件，则必须在安装完成后停止并重新启动 SQL Server 代理。此操作可确保 SQL Server 代理识别复制代理子系统，并可从作业步骤中调用复制代理。

使用安装程序安装复制

在安装 SQL Server 的新实例时安装复制

  • 若要安装包括复制管理对象 (RMO) 在内的复制组件，请在安装向导的“要安装的组件”页上选择 SQL Server Database Services。

在修改 SQL Server 的现有实例时安装复制

  • 若要安装复制组件，请执行以下操作：

    1. 在 SQL Server 安装向导的“要安装的组件”页上单击“高级”。

    2. 在“功能选择”页上展开“数据库服务”。

    3. 单击“复制”，然后单击“整个功能将安装到本地硬盘上”。

  • 若要安装复制管理对象 (RMO)，请执行以下操作：

    1. 在 SQL Server 安装向导的“要安装的组件”页上单击“高级”。

    2. 在“功能选择”页上，展开“客户端组件”。

    3. 单击“软件开发包”，然后单击“整个功能将安装到本地硬盘上”。

从命令提示符安装复制

在安装 SQL Server 的新实例时安装复制

  • 若要安装复制组件，请执行以下操作：

    • 在命令提示符下或 .ini 文件中为 ADDLOCAL 参数指定 SQL_Engine 值。例如，命令提示符可能为：

      复制代码
      start /wait setup.exe /qb ADDLOCAL=SQL_Engine SQLACCOUNT=domain\user SQLPASSWORD=$tr0ngP@ssw0rd
  • 若要安装复制管理对象 (RMO)，请执行以下操作：

    • 在命令提示符下或 .ini 文件中为 ADDLOCAL 参数指定 SDK 值。例如，命令提示符可能为：

      复制代码
      start /wait setup.exe /qb ADDLOCAL=SQL_Engine,SDK SQLACCOUNT=domain\user SQLPASSWORD=thepassword

在修改 SQL Server 的现有实例时安装复制

  • 若要安装复制组件，请执行以下操作：

    • 在命令提示符下或 .ini 文件中为 ADDLOCAL 参数指定 SQL_Replication 值。例如，命令提示符可能为：

      复制代码
      start /wait setup.exe /i <installation package> /qb ADDLOCAL=SQL_Replication
  • 若要安装复制管理对象 (RMO)，请执行以下操作：

    • 在命令提示符下或 .ini 文件中为 ADDLOCAL 参数指定 SDK 值。例如，命令提示符可能为：

      复制代码
      start /wait setup.exe /i <installation package> /qb ADDLOCAL=SDK

请参阅

概念

安装 SQL Server 2005
从命令提示符运行安装程序
用 .ini 文件指定安装属性

其他资源

安装 SQL Server 2005 组件

更改历史记录

版本 历史记录

2006 年 4 月 14 日

新增内容：
  • 添加了在修改 SQL Server 现有实例时，安装复制组件时要求停止并重新启动 SQL Server 代理的相关信息。


安装 AdventureWorks 示例数据库和示例

安装 AdventureWorks 示例数据库和示例 |
 | 请参阅
安装 SQL Server 2005 组件 >

Microsoft SQL Server 2005 中提供了新的联机事务处理 (OLTP)、联机分析处理 (OLAP) 和数据仓库示例数据库。这些数据库用于 SQL Server 2005 联机丛书中所包含的示例和代码示例中。可以下载 SQL Server 早期版本中使用的示例数据库。

本节的相关信息

主题 | 说明
运行安装程序安装 AdventureWorks 示例数据库和示例 | 说明如何使用安装程序安装 AdventureWorks、AdventureWorksDW 和 Adventure Works DW 示例数据库及示例。
从脚本重新安装示例数据库 | 说明如何通过运行安装脚本重新安装 AdventureWorks 或 AdventureWorksDW 示例数据库。
下载 Northwind 和 pubs 示例数据库 | 说明如何从 Microsoft 下载中心下载 Northwind 和 pubs 示例数据库。

请参阅

其他资源

示例和示例数据库
安装 SQL Server 2005 组件


运行安装程序安装 AdventureWorks 示例数据库和示例

运行安装程序安装 AdventureWorks 示例数据库和示例 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 AdventureWorks 示例数据库和示例 >

默认情况下，SQL Server 2005 中不安装 AdventureWorks (OLTP)、AdventureWorksDW（数据仓库）、Adventure Works DW (Analysis Services) 示例数据库和附带示例。以下过程说明如何在安装过程中和安装后进行示例数据库和示例的安装。还提供了部署 Adventure Works DW Analysis Services 项目的其他说明。

注意：
以下过程不适用于 SQL Server 2005 Express Edition 或 SQL Server 2005 Mobile Edition。若要下载这些版本的 AdventureWorks ，请参阅安装示例数据库。

重要事项：
安装 AdventureWorks 和 AdventureWorksDW 示例数据库后，使用的排序规则是 SQL_Latin1_General_CP1_CI_AS，而不是为 SQL Server 的实例选定的排序规则。若要更改示例数据库的排序规则以匹配服务器排序规则，请删除数据库并从安装脚本重新创建。有关详细信息，请参阅从脚本重新安装示例数据库。

在安装过程中安装示例数据库和示例

若要在安装过程中安装示例数据库和附带示例，请按以下说明操作。

  1. 在“要安装的组件”页上选择“工作站组件、联机丛书和开发工具”。

  2. 单击“高级”，然后展开“文档、示例和示例数据库”。

  3. 选择“示例代码和应用程序”。

  4. 展开“示例数据库”，然后选择要安装的示例数据库。

    注意：
    只有为安装选定了数据仓库 (AdventureWorksDW) 数据库之后，方可安装 OLAP 数据库 (Adventure Works DW)。必须先部署 Analysis Services 项目 Adventure Works DW，才能访问 Adventure Works DW Analysis Services 数据库。

  5. 若要完成示例的安装，在安装完成后，请执行下列步骤之一：

    1. 从“开始”菜单中单击“所有程序”，单击 Microsoft SQL Server 2005，单击“文档和教程”，然后单击“示例”，再单击“Microsoft SQL Server 2005 示例”。

    2. 或者使用 Windows 资源管理器，定位到 <drive>:\Program Files\Microsoft SQL Server\90\Tools\Samples\，然后双击 SqlServerSamples.msi 启动安装程序。

    重要事项：
    示例被安装到 <drive>:\Program Files\Microsoft SQL Server\90\Samples。请务必阅读并遵照您希望使用的示例所附带的自述文件中的安装说明。有关示例的列表，请参阅示例。

在安装完成后安装示例数据库和示例

如果在初始安装 SQL Server 2005 过程中没有安装示例数据库或示例，可以在以后安装。

重要事项：
不能用以下过程重新创建已删除的示例数据库。若要重新创建已删除的示例数据库，请从安装脚本重新安装该数据库。有关详细信息，请参阅从脚本重新安装示例数据库。

  1. 从“添加或删除程序”中选择 Microsoft SQL Server 2005，然后单击“更改”。按照“Microsoft SQL Server 2005 维护”向导中的步骤操作。

  2. 从“选择组件”中选择“工作站组件”，然后单击“下一步”。

  3. 在“欢迎使用 SQL Server 安装向导”中单击“下一步”。

  4. 在“系统配置检查”中单击“下一步”。

  5. 从“更改或删除实例”中单击“更改已安装的组件”。

  6. 在“功能选择”中，展开“文档、示例和示例数据库”节点。

  7. 选择“示例代码和应用程序”。

  8. 展开“示例数据库”，然后选择要安装的示例数据库。单击“下一步”。

  9. 若要安装并附加示例数据库，请从“安装示例数据库”中选择“安装并附加示例数据库”，然后单击“下一步”。

    数据库文件创建并存储在文件夹 <drive>:\Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Data 中。数据库已附加并可以使用。

  10. 若要安装示例数据库文件但不附加它们，请在“安装示例数据库”中选择“安装但不附加示例数据库”，然后单击“下一步”。

    AdventureWorks 数据库文件在文件夹 <drive>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks OLTP 中创建。AdventureWorksDW 文件在 <drive>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Data Warehouse 文件夹中创建。必须先附加数据库，然后才能使用它。有关详细信息，请参阅分离和附加数据库。

  11. 选择要安装示例数据库和示例的 SQL Server 实例。

  12. 完成向导中的步骤。

  13. 若要完成示例的安装，在安装完成后，请执行下列步骤之一：

    1. 从“开始”菜单中单击“所有程序”，单击 Microsoft SQL Server 2005，单击“文档和教程”，然后单击“示例”，再单击“Microsoft SQL Server 2005 示例”。

    2. 或者使用 Windows 资源管理器，定位到 <drive>:\Program Files\Microsoft SQL Server\90\Tools\Samples\，然后双击 SqlServerSamples.msi 启动安装程序。

    重要事项：
    示例被安装到 <drive>:\Program Files\Microsoft SQL Server\90\Samples。请务必阅读并遵照您希望使用的示例所附带的自述文件中的安装说明。有关示例的列表，请参阅示例。

部署 Adventure Works DW Analysis Services 项目

  1. 请确保已经安装了 AdventureWorksDW 和 Adventure Works DW 数据库。

  2. 请确保已经安装了 Analysis Services。

  3. 在 SQL Server Business Intelligence Development Studio 工具栏中单击“文件”，指向“打开”，然后单击“项目/解决方案”。

  4. 浏览到 <drive>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Analysis Services Project，选择文件 Adventure Works.sln，然后单击“打开”。

  5. 从解决方案资源管理器中，右键单击 Adventure Works DW 并选择“部署”或“处理”。

请参阅

任务

从脚本重新安装示例数据库

概念

下载 Northwind 和 pubs 示例数据库

其他资源

安装 AdventureWorks 示例数据库和示例

更改历史记录

版本 历史记录

2005 年 12 月 5 日

新增内容：
  • 添加了 SQL Server 2005 Express Edition 和 SQL Server 2005 Mobile Edition 注释。

已更改的内容：
  • 更正了用户界面引用。


从脚本重新安装示例数据库

从脚本重新安装示例数据库 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 AdventureWorks 示例数据库和示例 >

如果更改示例数据库后想返回到原始架构，可以运行 Microsoft SQL Server Management Studio 查询编辑器中相应的安装脚本，重新安装数据库。安装脚本将删除现有示例数据库、重新创建数据库对象并填充表。

注意：
这些过程不再适用于 SQL Server 2005 Express Edition 或 SQL Server 2005 Mobile Edition。若要下载这些版本的 AdventureWorks，请参阅安装示例数据库。

下列过程说明如何重新安装 AdventureWorks 数据库和 AdventureWorksDW 数据仓库。

从脚本重新安装 AdventureWorks

  1. 在 Management Studio 工具栏上，单击“文件”，指向“打开”，然后单击“文件”。

  2. 浏览到文件 instawdb.sql，并单击“打开”。该文件的默认位置为 C:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks OLTP。

  3. 运行脚本之前，在脚本中找到语句 SET @data_path = @sql_path + 'AWDB\';，并更改该语句使其指向 instawdb.sql 脚本的位置。例如，SET @data_path = 'C:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks OLTP\';。

  4. 执行脚本。

从脚本重新安装 AdventureWorksDW

  1. 在 Management Studio 工具栏上，单击“文件”，指向“打开”，然后单击“文件”。

  2. 浏览到文件 instawdwdb.sql，并单击“打开”。该文件的默认位置为 C:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Data Warehouse。

  3. 运行脚本之前，在脚本中找到语句 SET @data_path = @sql_path + 'awdwdb\';，并更改该语句使其指向 instawdwdb.sql 脚本的位置。例如，SET @data_path = 'C:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Data Warehouse\';。

  4. 执行脚本。

请参阅

概念

运行安装程序安装 AdventureWorks 示例数据库和示例


下载 Northwind 和 pubs 示例数据库

下载 Northwind 和 pubs 示例数据库 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 AdventureWorks 示例数据库和示例 >

默认情况下，Microsoft SQL Server 2005 中不安装 Northwind 和 pubs 示例数据库。这些数据库可以从 Microsoft 下载中心下载。有关详细信息，请参阅此 Microsoft 网站。

下载 SQL2000SampleDb.msi 后，双击 SQL2000SampleDb.msi 解压缩示例数据库脚本。SQL2000SampleDb.msi 将数据库脚本和自述文件解压缩到此默认文件夹中：C:\SQL Server 2000 Sample Databases。请按照自述文件中的说明运行安装脚本。

注意：
创建这些数据库的脚本已更新，删除了 guest 帐户以提高安全性。pubs 安装脚本已更新，以便包含数据库的所有数据，从而不需要在创建 pubs 之后单独运行相应的作业来添加数据。

请参阅

任务

从脚本重新安装示例数据库

概念

运行安装程序安装 AdventureWorks 示例数据库和示例

其他资源

AdventureWorks 表与 Northwind 表的比较
AdventureWorks 表与 pubs 表的比较


安装 SQL Server 组件帮助主题

安装 SQL Server 组件帮助主题 |
 | 请参阅
安装 SQL Server 2005 组件 >

下列部分的主题说明如何安装 Microsoft SQL Server 2005 组件。

本节的相关信息

  • 数据库引擎安装帮助主题

  • Analysis Services 安装帮助主题

  • Reporting Services 安装帮助主题

  • Notification Services 安装帮助主题

  • Integration Services 安装帮助主题

  • 安装 SQL Server 复制

请参阅

任务

如何从命令提示符安装 SQL Server 2005

参考

版本升级

概念

准备安装 SQL Server 2005
SQL Server 外围应用配置器

其他资源

安装 SQL Server 组件帮助主题
升级到 SQL Server 2005


数据库引擎安装帮助主题

数据库引擎安装帮助主题 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 >

此部分包含下列用于安装、维护 Microsoft SQL Server 2005 以及对其进行故障排除的过程。

本节的相关信息

安装主题

  • 如何安装 SQL Server 2005（安装程序）

  • 如何从命令提示符安装 SQL Server 2005

  • 如何升级到 SQL Server 2005（安装程序）

  • 如何安装 Microsoft Internet 信息服务

  • 如何验证 SQL Server 2005 服务的安装成功

维护主题

  • 如何在 SQL Server 2005 的现有实例中更改组件（安装程序）

  • 如何重新生成 SQL Server 2005 的 Master 数据库

  • 如何为 SQL Server 2005 重新生成注册表

  • 如何卸载 SQL Server 2005 的现有实例（安装程序）

故障排除主题

  • SQL Server 数据库引擎的安装故障排除

  • 故障转移群集故障排除

  • 如何解决 SQL Server 安装程序中的 COM+ 系统配置检查失败问题

  • 如何在 SQL Server 2005 中为安装程序增加计数器注册表项值

  • 如何查看 SQL Server 2005 安装日志文件

请参阅

任务

如何访问 SQL Server 2005 联机丛书


如何安装 SQL Server 2005（安装程序）

如何安装 SQL Server 2005（安装程序） |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

Microsoft SQL Server 2005 安装向导基于 Windows 安装程序，并提供一个功能树用于安装所有 SQL Server 2005 组件：

  • 数据库引擎

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • 复制

  • 管理工具

  • 连接组件

  • 示例数据库、示例和 SQL Server 2005 文档

不必分别安装每个组件。

必备项

注意：
如果您正在安装故障转移群集，请不要按照此过程操作。请参阅如何创建新的 SQL Server 2005 故障转移群集（安装）。

如果您正在将早期版本的 SQL Server 升级到 SQL Server 2005，请不要按照此过程操作。请参阅升级到 SQL Server 2005。

安装 SQL Server 2005 前，请查看准备安装 SQL Server 2005 中的主题。

注意：
对于本地安装，必须以管理员身份运行安装程序。如果通过远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

安装 SQL Server 2005

  1. 若要开始安装过程，请将 SQL Server 2005 DVD 插入 DVD 驱动器。如果 DVD 驱动器的自动运行功能无法启动安装程序，请导航到 DVD 的根目录，然后启动 splash.hta。如果通过网络共享进行安装，请导航到网络文件夹，然后启动 splash.hta。

  2. 在自动运行的对话框中，单击“运行 SQL Server 安装向导”。

  3. 在“最终用户许可协议”页上，阅读许可协议，再选中相应的复选框以接受许可条款和条件。接受许可协议后即可激活“下一步”按钮。若要继续，请单击“下一步”。若要结束安装程序，请单击“取消”。

  4. 在“SQL Server 组件更新”页上，安装程序将安装 SQL Server 2005 的必需软件。有关组件要求的详细信息，请单击该页底部的“帮助”按钮。若要开始执行组件更新，请单击“安装”。更新完成之后若要继续，请单击“完成”。

  5. 在 SQL Server 安装向导的“欢迎”页上，单击“下一步”以继续安装。

  6. 在“系统配置检查 (SCC)”页上，将扫描安装计算机，以检查是否存在可能妨碍安装程序的条件。有关配置检查项的信息，请单击该页底部的“帮助”或参阅系统配置检查器的检查参数。若要中断扫描，请单击“停止”。若要显示按结果进行分组的检查项列表，请单击“筛选器”按钮，然后从下拉列表中选择类别。若要查看 SCC 结果的报表，请单击“报表”按钮，然后从下拉列表中选择选项。选项包括查看报表、将报表保存到文件、将报表复制到剪贴板和以电子邮件形式发送报表。完成 SCC 扫描之后，若要继续执行安装程序，请单击“继续”。

  7. 在“注册信息”页上的“姓名”和“公司”文本框中，输入相应的信息。若要继续，请单击“下一步”。

  8. 在“要安装的组件”页上，请选择要安装的组件。选择各个组件组时，“要安装的组件”窗格中会显示相应的说明。您可以选中任意一些复选框。当您选择 SQL Server 或 Analysis Services 时，如果安装程序检测到您正将组件安装到虚拟服务器，则将启用“作为虚拟服务器进行安装”复选框。必须选择此选项才可以安装故障转移群集。

    重要事项：
    由于安装故障转移群集的步骤有所不同，因此若要安装故障转移群集，请参阅如何创建新的 SQL Server 2005 故障转移群集（安装）。

    若要安装单个组件，请单击“高级”。否则，请单击“下一步”继续。

  9. 如果在上一页中单击了“高级”，此时将显示“功能选择”页。在“功能选择”页上，使用下拉框选择要安装的程序功能。若要将组件安装到自定义的目录下，请选择相应的功能，再单击“浏览”。有关此页功能的详细信息，请单击“帮助”。若要在完成功能选择后继续安装，请单击“下一步”。

  10. 在“实例名”页上，请为安装的软件选择默认实例或已命名的实例。如果已经安装了默认实例或已命名实例，并且为安装的软件选择了现有实例，安装程序将升级所选的实例，并提供安装其他组件的选项。计算机上必须没有默认实例，才可以安装新的默认实例。若要安装新的命名实例，请单击“命名实例”，然后在提供的空白处键入一个唯一的实例名。有关实例命名规则的详细信息，请单击该页底部的“帮助”，或查看 SQL Server 2005 联机丛书中的实例名称主题。

  11. 在“服务帐户”页上，为 SQL Server 服务帐户指定用户名、密码和域名。您可以对所有服务使用一个帐户。

    根据需要，可以为各个服务指定单独的帐户。若要为各个服务指定单独的帐户，请选中“为每个服务帐户进行自定义”，从下拉框中选择服务名称，然后为该服务提供登录凭据。若要继续安装，请单击“下一步”。

    注意：
    域名不能为完整的域名系统 (DNS) 名称。例如，如果 DNS 名称为 my-domain-name.com，请在“域”字段中使用 my-domain-name。在 SQL Server 中，“域”字段不接受 my-domain-name.com。

  12. 在“身份验证模式”页上，选择要用于 SQL Server 安装的身份验证模式。

    如果选择 Windows 身份验证，安装程序会创建一个 sa 帐户，该帐户在默认情况下是被禁用的。选择“混合模式身份验证”时，请输入并确认系统管理员 (sa) 登录名。密码是抵御入侵者的第一道防线，因此设置强密码对于系统安全是绝对必要的。切勿设置空密码或弱 sa 密码。若要使用混合模式身份验证，并在安装完成后激活 sa 帐户，请参阅 SQL Server 联机丛书中的“如何更改服务器身份验证模式”。若要继续安装，请单击“下一步”。

    注意：
    请尽可能使用 Windows 身份验证。 不要使用空密码。请使用强密码。 有关强密码的指南，请参阅身份验证模式。

    注意：
    对于此版本，SQL Server 安装程序可能不会对其所在计算机不是域成员的 Microsoft Windows Server 2003 的默认配置强制强密码要求。在“排序规则设置”页上，指定 SQL Server 实例的排序规则。您可以将一个帐户用于 SQL Server 和 Analysis Services，也可以为各个组件分别指定排序规则。

    若要为 SQL Server 和 Analysis Services 设置单独的排序规则设置，请选中“为每个服务帐户进行自定义”复选框。选中该复选框后，将显示一个下拉框。从下拉选择框中选择一个服务，然后分配其排序规则。对每个服务重复以上操作。若要继续安装，请单击“下一步”。

  13. 如果选择 Reporting Services 作为要安装的功能，将显示“报表服务器虚拟目录”页。接受默认目录名称，或为目录指定位置。有关此页的详细信息，请单击该页底部的“帮助”。若要继续安装，请单击“下一步”。

  14. 如果选择 Reporting Services 作为要安装的功能，将显示“报表服务器数据库安装程序”页。指定报表服务器数据库的宿主。如果选择使现有 SQL Server 实例驻留报表服务器数据库，请从下拉列表中选择一个实例，再选择用于访问该实例的身份验证模式。

    如果选择“SQL Server 身份验证”，请提供对该实例具有管理权限的用户名和密码。然后确认报表服务器数据库名称是否正确。若要继续，请单击“下一步”。

  15. 如果选择 Reporting Services 作为要安装的功能，将显示“报表服务器传递设置”页。指定 SMTP 服务器地址和电子邮件地址（用作从报表服务器发出的电子邮件的发件人）。若要继续，请单击“下一步”。

  16. 在“错误报告”页上，可以清除复选框以禁用错误报告。有关错误报告功能的详细信息，请单击该页底部的“帮助”。若要继续安装，请单击“下一步”。

  17. 在“准备安装”页上，查看要安装的 SQL Server 功能和组件的摘要。若要继续安装，请单击“安装”。

  18. 在“安装进度”页上，可以在安装过程中监视安装进度。若要在安装期间查看某个组件的日志文件，请单击“安装进度”页上的产品或状态名称。

  19. 在“完成 Microsoft SQL Server 安装向导”页上，可以通过单击此页上提供的链接查看安装摘要日志。若要退出 SQL Server 安装向导，请单击“完成”。

  20. 如果提示您重新启动计算机，请立即重新启动。完成安装后，阅读来自安装程序的消息是很重要的。如果未能重新启动计算机，可能会导致以后运行安装程序失败。

后续步骤

安装程序完成 SQL Server 2005 的安装后，可使用图形工具和命令提示实用工具进一步配置 SQL Server。有关详细信息，请参阅配置 SQL Server 安装。

为了减少系统的可攻击外围应用，SQL Server 2005 有选择地安装并激活密钥服务和功能。在新安装软件的默认配置中，许多功能被禁用。有关详细信息，请参阅 SQL Server 外围应用配置器。

请参阅

任务

如何升级到 SQL Server 2005（安装程序）
如何使用复制数据库向导升级至 SQL Server 2005
如何创建新的 SQL Server 2005 故障转移群集（安装）
如何升级到 SQL Server 2005 故障转移群集（安装程序）

概念

准备安装 SQL Server 2005
故障转移群集故障排除
如何查看 SQL Server 2005 安装日志文件


如何解决 SQL Server 安装程序中的 COM+ 系统配置检查失败问题

如何解决 SQL Server 安装程序中的 COM+ 系统配置检查失败问题 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

Microsoft SQL Server 2005 安装程序检查 COM+ 是否已正确配置。如果发现配置错误，安装程序仍将继续，但是在系统配置检查 (SCC) 报告中显示以下警告：

“如果 SQL Server 安装程序失败，安装程序将回滚所进行的安装，但可能不会删除所有的 .manifest 文件。解决方法是重命名这些文件，然后重新运行安装程序。”

如果未运行 Microsoft 分布式事务处理协调器 (MS DTC)，或者，在使用 Microsoft 群集服务器的情况下，如果 MS DTC 不是群集资源，则可能会发生 COM+ 错误。COM+ 依赖于 MS DTC，而 Integration Services 中的消息队列任务依赖于 COM +。如果出现 COM+ 错误，则只有将 COM+ 系统正确配置后，Integration Services 中的消息队列任务才可用。

若要使用消息队列（亦称 MSMQ），请确保 MS DTC 正在运行并且已正确配置。如果 SQL Server 安装在群集上，则 MS DTC 必须是群集资源。

按照下列过程重新安装 COM+。

安装组件服务管理单元

  1. 在 Windows 桌面上，单击“开始”，然后单击“运行”。

  2. 在“打开”框中，键入 MMC，然后单击“确定”。

  3. 在“控制台”窗口中，单击菜单栏上的“文件”，然后单击“添加/删除管理单元”。

  4. 在“添加/删除管理单元”窗口，单击“添加”。

  5. 在“添加独立管理单元”窗口，从管理单元列表中选择“组件服务”，然后单击“添加”。

  6. 单击“关闭”以关闭“添加独立管理单元”窗口，然后单击“确定”以关闭“添加/删除管理单元”窗口。

  7. 在“控制台根节点\组件服务”窗口，展开“组件服务”树。这就是当 COM+ 出现问题时，错误消息可能发生的地方。

  8. 再次运行 SQL Server 2005 安装程序。如果收到错误消息，请重新安装 COM+。

重新安装 COM+

  1. 从控制面板的“添加或删除程序”中，单击“添加/删除 Windows 组件”。

  2. 在“Windows 组件向导”中，不对选择做任何更改，单击“下一步”。

  3. 一直单击以完成向导，然后再次运行 SQL Server 2005 安装程序。

请参阅

任务

如何阅读 SQL Server 2005 安装日志文件

概念

SQL Server 数据库引擎的安装故障排除
如何查看 SQL Server 2005 安装日志文件


如何在 SQL Server 2005 中为安装程序增加计数器注册表项值

如何在 SQL Server 2005 中为安装程序增加计数器注册表项值 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

在 SQL Server 安装开始前，Microsoft SQL Server 安装程序中的安装配置检查器 (SCC) 会验证计数器注册表项的值。如果 SCC 无法验证现有的注册表项，或 SCC 无法运行 lodctr.exe 系统程序，则 SCC 检查会失败，致使安装受阻。

错误编辑注册表会严重损坏您的系统。更改注册表项之前，建议您备份计算机中的所有重要数据。

手动设置计数器注册表项的增量

  1. 在 Microsoft Windows 2003 或 Windows XP 桌面上，依次单击“开始”、“运行”，然后在“打开”中键入 regedit.exe，再单击“确定”。在 Windows 2000 中，使用 regedt32.exe 启动注册表编辑器。

  2. 定位到以下注册表项：

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib]

    "Last Counter"=dword:00000ed4 (5276)

    "LastHelp"=dword:00000ed5 (5277)

  3. 上一步的“Last Counter”值 (5276) 必须与以下注册表项中“Perflib\009”的“Counter”项的最大值匹配，并且上一步的“Last Help”值 (5277) 必须与以下注册表项中“Perflib\009”的“Help”项的最大值匹配。

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\009]

    注意 009 是英文中的一个示例。“Last Counter”和“Last Help”值是由 Windows 动态分配的；这两个值会因计算机的不同而不同。

  4. 如有必要，可修改“\Perflib”项中的“Last Counter”和“Last Help”值的值：在右侧窗格中，右键单击“Last Counter”或“Last Help”，单击“修改”，再单击“Base = "Decimal"”，在“值数据”中设置值，再单击“确定”。如有必要，对另一个项重复以上过程，然后关闭注册表编辑器。

  5. 再次运行 SQL Server 安装程序。

请参阅

概念

准备安装 SQL Server 2005
如何查看 SQL Server 2005 安装日志文件


如何从命令提示符安装 SQL Server 2005

如何从命令提示符安装 SQL Server 2005 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

运行 SQL Server 2005 的安装程序之前，请先查看准备安装 SQL Server 2005。如果要安装故障转移群集，还请查看安装故障转移群集前的准备工作。

注意：
对于本地安装，必须以管理员身份运行安装程序。如果通过远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。对于故障转移群集安装，您必须是本地管理员，且具有以服务的身份登录并在虚拟服务器的所有节点上充当操作系统组成部分的权限。

可以使用以下示例脚本从命令提示符安装、更新或删除 SQL Server 2005 组件。这些脚本提供典型用户方案中安装 SQL Server 2005 的命令提示符语法。请根据您单位的需要测试和修改这些示例。

示例脚本分为以下几个类别：

  • 安装脚本

  • 维护脚本

  • 卸载脚本

有关从命令提示符进行安装时所用特定参数的详细信息，请参阅参数。

安装脚本

请根据您单位的需要测试和修改以下安装脚本。

从命令提示符安装 SQL Server 2005 的独立新实例

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 对于识别实例的组件（数据库引擎、SQL Server 代理、Analysis Services 和 Reporting Services），可使用以下语法：

    复制代码
    Start /wait <CD or DVD Drive>\setup.exe /qb INSTANCENAME=<InstanceName> ADDLOCAL=SQL_Engine,SQL_Replication PIDKEY=<pidkey value with no "-"> SAPWD=<StrongPassword> SQLACCOUNT=<DomainName\UserName> SQLPASSWORD=<DomainUserPassword> AGTACCOUNT=<DomainName\UserName> AGTPASSWORD=<DomainUserPassword> SQLBROWSERACCOUNT=<DomainName\UserName> SQLBROWSERPASSWORD=<DomainUserPassword>
重要事项：
不要使用空密码。请使用强密码。

注意：
对于默认实例，请将 <InstanceName> 指定为“MSSQLSERVER”。如果是命名实例，请指定实例名。有关实例命名的指南，请参阅实例名称。

  1. 对于不识别实例的共享组件（Notification Services、Integration Services、全文搜索、SQLXML 和复制），请使用以下语法：

    复制代码
    Start /wait <CD or DVD Drive>\setup.exe /qb ADDLOCAL=Client_components,Connectivity,SQLXML PIDKEY=<pidkey value with no "-">
  2. 若要安装所有 SQL Server 2005 组件，请使用以下语法：

    复制代码
    Start /wait <CD or DVD Drive>\setup.exe /qb INSTANCENAME=<InstanceName> ADDLOCAL=All PIDKEY=<pidkey value with no "-"> SAPWD=<StrongPassword>

从命令提示符安装 SQL Server 2005 的新群集实例

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 对于新的故障转移群集，请使用以下语法来安装 SQL Server Database Services 和管理工具：

    复制代码
    Start /wait <CD or DVD Drive>\setup.exe /qn VS=<VSName> INSTALLVS=SQL_Engine INSTANCENAME=<InstanceName> ADDLOCAL=SQL_Engine,Client_Components PIDKEY=<pidkey value with no "-"> ADDNODE=<NodeName1,NodeName2> GROUP=<Diskgroup> IP=<IP,Networkname> ADMINPASSWORD=<StrongPassword> SAPWD=<StrongPassord> INSTALLSQLDIR=<InstallationPath> INSTALLSQLDATADIR=<ShareDrivePath> SQLACCOUNT=<domain\user> SQLPASSWORD=<DomainUserPassword> AGTACCOUNT=<domain\user> AGTPASSWORD=<DomainUserPassword> SQLBROWSERACCOUNT=<domain\user> SQLBROWSERPASSWORD=<DomainUserPassword> SQLCLUSTERGROUP="MyDomain\MySQLDomainGroup" AGTCLUSTERGROUP="MyDomain\MyAGTDomainGroup"
    重要事项：
    不要使用空密码。请使用强密码。

    /qn 开关用于取消所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。

    指定 /qb 开关将显示基本的安装程序对话框。还会显示错误消息。

返回页首。

维护脚本

请根据您单位的需要测试和修改以下维护脚本。

从命令提示符向 SQL Server 2005 的现有独立实例添加组件

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 若要添加全文搜索并删除复制，可使用以下语法：

    复制代码
    Start /wait <CD or DVD Drive>setup.exe /qb INSTANCENAME=<InstanceName> ADDLOCAL=SQL_FullText REMOVE=SQL_Replication

    对于默认实例，请将 <InstanceName> 指定为“MSSQLSERVER”。有关参数的完整列表，请参阅下面的参数。

从命令提示符向现有 SQL Server 2005 群集添加组件

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 若要将 Analysis Services 添加到现有群集，可使用以下语法：

    复制代码
    start /wait <CD or DVD Drive>\setup.exe /qn VS=<VSName> INSTALLVS=Analysis_Server INSTANCENAME=<InstanceName> ADDLOCAL=Analysis_Server ADDNODE=n GROUP=<NotSQLDiskGroup> IP=<IP,Networkname> ADMINPASSWORD=<StrongPassword> SAPWD=<StrongPassword> INSTALLSQLDIR=<InstallationPath> INSTALLSQLDATADIR=<ShareDrivePath> ASACCOUNT=<domain\user> ASPASSWORD=<DomainUserPassword> SQLBROWSERACCOUNT=<domain\user> SQLBROWSERPASSWORD=<DomainUserPassword> SQLREPORTING=1
注意：
不能将 Analysis Services 安装到与数据库引擎 相同的群集组。必须先将 Analysis Services 安装到自己的组，安装完成后才可将 Analysis Services 移到与 SQL Server 相同的组。

有关参数的完整列表，请参阅下面的参数。

从命令提示符向现有 SQL Server 2005 群集添加节点

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 使用以下语法：

    复制代码
    start /wait <CD or DVD Drive>\setup.exe /qn VS=<VSName> INSTALLVS=SQL_Engine INSTANCENAME=<InstanceName> ADMINPASSWORD=<StrongPassword> ADDNODE=<NodeName>
    重要事项：
    不要使用空密码。请使用强密码。

    对于默认实例，请将 <InstanceName> 指定为“MSSQLSERVER”。

    /qn 开关用于取消所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。指定 /qb 开关将显示基本的安装程序对话框。还会显示错误消息。

从命令提示符删除现有的 SQL Server 2005 群集中的节点

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 使用以下语法：

    复制代码
    start /wait <CD or DVD Drive>\setup.exe /qn VS=<VSName> INSTALLVS=SQL_Engine INSTANCENAME=<InstanceName> ADMINPASSWORD=<StrongPassword> REMOVENODE=<NodeName>
    重要事项：
    不要使用空密码。请使用强密码。

    对于默认实例，请将 <InstanceName> 指定为“MSSQLSERVER”。

    /qn 开关用于取消所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。指定 /qb 开关将显示基本的安装程序对话框。还会显示错误消息。

    注意：
    如果在群集环境中并行安装了 SQL Server 2000 和 SQL Server 2005，则卸载 SQL Server 2005 时不应卸载 Microsoft SQL Native Client。SQL Server 2005 的 SQL Server 资源 DLL 始终使用 SQL Native Client 与 SQL Server 进行连接。安装 SQL Server 2005 时，SQL Server 群集资源 DLL 会升级。卸载 SQL Server 2005 时，SQL Server 资源 DLL 不会替换为 SQL Server 2000 所需的版本。在群集节点上保留 SQL Native Client 使得 SQL Server 资源 DLL 可以继续连接到 SQL Server 2000 的实例。

重新生成系统数据库、重新生成注册表

REINSTALLMODE 用于修复已安装的 SQL Server 2005 组件。有关使用 REINSTALLMODE 的其他信息，请参阅下面的 [REINSTALLMODE] 和 [REBUILDDATABASE] 部分。

从命令提示符重新生成 SQL Server 2005 默认实例的系统数据库

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 使用以下语法：

    复制代码
    start /wait <CD or DVD Drive>\setup.exe /qn INSTANCENAME=<InstanceName> REINSTALL=SQL_Engine REBUILDDATABASE=1 SAPWD=<NewStrongPassword>
    重要事项：
    不要使用空密码。请使用强密码。

    对于默认实例，请将 <InstanceName> 指定为“MSSQLSERVER”。

    重要提示 资源数据库 (mssqlsystemresource) 是从 SQL Server 2005 分发介质还原的。从分发介质重新生成资源数据库时，所有的 Service Pack 和 QFE 更新都将丢失，因此必须重新应用。继续操作之前，请先参阅 [REBUILDDATABASE] 以获取详细信息。

    /qn 开关用于取消所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。指定 /qb 开关将显示基本的安装程序对话框。还会显示错误消息。

    重新生成 master 数据库时，会将所有系统数据库安装到其初始位置。如果将一个或多个系统数据库移动到其他位置，则必须重新移动这些数据库。有关移动系统数据库的详细信息，请参阅移动系统数据库。

从命令提示符重新生成 SQL Server 2005 群集实例的系统数据库

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 使用以下语法：

    复制代码
    start /wait <CD or DVD Drive>\setup.exe /qn VS=<VSName> INSTANCENAME=<InstanceName> REINSTALL=SQL_Engine REBUILDDATABASE=1 ADMINPASSWORD=<StrongPassword> SAPWD=<NewStrongPassword> SQLCOLLATION=<NewSystemCollation> SQLACCOUNT=<domain\user> SQLPASSWORD=<DomainUserPassword> AGTACCOUNT=<domain\user> AGTPASSWORD=<DomainUserPassword>
    重要事项：
    不要使用空密码。请使用强密码。

    对于默认实例，请将 <InstanceName> 指定为“MSSQLSERVER”。

    重要提示 资源数据库 (mssqlsystemresource) 是从 SQL Server 2005 分发介质还原的。从分发介质重新生成资源数据库时，所有的 Service Pack 和 QFE 更新都将丢失，因此必须重新应用。继续操作之前，请先参阅 [REBUILDDATABASE] 以获取详细信息。

    /qn 开关用于取消所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。指定 /qb 开关将显示基本的安装程序对话框。还会显示错误消息。

    重新生成 master 数据库时，会将所有系统数据库安装到其初始位置。如果将一个或多个系统数据库移动到其他位置，则必须重新移动这些数据库。有关移动系统数据库的详细信息，请参阅移动系统数据库。

指定新的系统排序规则

排序规则设置（包括字符集、排序顺序和其他特定于区域的设置）是所有 SQL Server 数据库的结构和功能的基础。应对您的单位制定这些选项的标准，并在安装时应用。如果服务器之间的排序规则设置不一致，服务器之间的活动可能失败。

安装 SQL Server 2005 时，请使用正确的排序规则设置。安装程序运行完后可以更改排序规则设置，但是更改时必须重新生成系统数据库和用户数据库并重新加载用户数据。

若要更改 SQL Server 2005 的现有实例的排序规则设置，必须使用无人参与的安装程序重新生成系统数据库。可以使用形式为 REBUILDDATABASE=1 的特殊开关启用此功能。重新生成系统数据库时，master、model 和 msdb 系统数据库中的所有数据库对象和数据都会被删除。重新生成 master 数据库时，会将所有系统数据库安装到其初始位置。如果将一个或多个系统数据库移动到其他位置，则必须重新移动这些数据库。有关移动系统数据库的详细信息，请参阅移动系统数据库。

语法中必须指定 /qb 或 /qn 选项。指定 /qb 选项将显示基本的安装程序用户界面和错误消息对话框。如果指定 /qn 选项，所有安装程序对话框（包括错误消息）都将写入安装程序日志文件。

重要事项：
为了重新生成系统数据库，必须指定新的系统管理员 (sa) 密码。 不要使用空密码。请使用强密码。

重新生成系统数据库并指定新的系统排序规则

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 从命令提示符运行以下命令：

    复制代码
    start /wait <CD or DVD Drive>\setup.exe /qn INSTANCENAME=MSSQLSERVER REINSTALL=SQL_Engine REBUILDDATABASE=1 SAPWD=<NewStrongPassword> SQLCOLLATION=<NewSystemCollation>

    对于 INSTANCENAME，如果是默认实例，请使用 MSSQLSERVER。如果是命名实例，请指定实例名。

    重要事项：
    资源数据库 (mssqlsystemresource) 是从 SQL Server 2005 分发介质还原的。从分发介质重新生成资源数据库时，所有的 Service Pack 和修补程序更新都将丢失，因此必须重新应用。继续操作之前，请参阅 [REBUILDDATABASE] 部分以获取详细信息。

    /qn 开关用于取消所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。指定 /qb 开关将显示基本的安装程序对话框。还会显示错误消息。

    重新生成 master 数据库时，会将所有系统数据库安装到其初始位置。如果将一个或多个系统数据库移动到其他位置，则必须重新移动这些数据库。有关移动系统数据库的详细信息，请参阅移动系统数据库。

重新生成注册表

若要重新生成 SQL Server 2005 注册表，必须使用带有 REINSTALL=ALL 参数和 REINSTALLMODE=omus 参数的安装程序命令。运行带有这些参数设置的 Setup.exe 将重新生成、验证和修复 SQL Server 实例并重新生成注册表。此步骤最常用于重新生成已损坏的所安装 SQL Server 软件的注册表。

注意：
若要重新生成注册表，使用的包文件和选项必须与初始安装过程中所指定的相同。如果不知道此信息，请卸载并重新安装 SQL Server，而不要重新生成注册表。

语法中必须指定 /qb 或 /qn 选项。指定 /qb 选项将显示基本的安装程序用户界面和错误消息对话框。如果指定 /qn 选项，所有安装程序对话框（包括错误消息）都将写入安装程序日志文件。

重要事项：
为了重新生成系统数据库，必须指定新的 sa 密码。 不要使用空密码。请使用强密码。

从命令提示符修复所有文件、重新生成注册表并替换所有 SQL Server 快捷方式

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 从命令提示符运行以下命令：

    复制代码
    start /wait <CD or DVD Drive>\setup.exe /qb INSTANCENAME=MSSQLSERVER REINSTALL=ALL REBUILDDATABASE=1 REINSTALLMODE=omus SAPWD=<NewStrongPassword>

    对于 INSTANCENAME，如果是默认实例，请使用 MSSQLSERVER。如果是命名实例，请指定实例名。

    重要事项：
    资源数据库 (mssqlsystemresource) 是从 SQL Server 2005 分发介质还原的。从分发介质重新生成资源数据库时，所有的 Service Pack 和 QFE 更新都将丢失，因此必须重新应用。继续操作之前，请参阅 [REBUILDDATABASE] 部分以获取详细信息。

从命令提示符修复 SQL Server Management Studio 快捷方式

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 从命令提示符运行以下命令：

    复制代码
    start /wait <CD or DVD Drive>\setup.exe /qb REINSTALL=SQL_Tools90 REINSTALLMODE=S

    对于 INSTANCENAME，如果是默认实例，请使用 MSSQLSERVER。如果是命名实例，请指定实例名。

从命令提示符修复全文搜索引擎注册表项

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 从命令提示符运行以下命令：

    复制代码
    start /wait <CD or DVD Drive>\setup.exe /qb REINSTALL=SQL_FullText INSTANCENAME=MSSQLSERVER REINSTALLMODE=M

    对于 INSTANCENAME，如果是默认实例，请使用 MSSQLSERVER。如果是命名实例，请指定实例名。

返回页首。

卸载脚本

请根据您单位的需要测试和修改以下删除脚本。

在 SQL Server 2005 与早期 SQL Server 版本同时运行的计算机上，企业管理器和依赖 SQL-DMO 的其他程序可能被禁用。这可能出现在以下情况中：

  • 并行安装了 SQL Server 2005、SQL Server 2000 和/或 SQL Server 7.0，但又卸载了其中任一版本。

  • 并行安装了 SQL Server 2000 和 SQL Server 2005，且是在安装 SQL Server 2005 后安装 SQL Server 2000。

这个问题是由于删除了 SQL Server 2005 SQL-DMO COM 库的注册造成的。若要重新启用企业管理器和对 SQL-DMO 有依赖关系的其他程序，请从命令提示符运行 regsvr32.exe sqldmo.dll 以注册 SQL-DMO。有关详细信息，请参阅SQL Server 数据库引擎的安装故障排除。

从命令提示符删除 SQL Server 2005 的默认独立安装

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 使用以下语法卸载 SQL Server：

    复制代码
    Start /wait <CD or DVD Drive>\setup.exe /qb REMOVE=SQL_Engine,Client_Components INSTANCENAME=<InstanceName>

    对于默认实例，请将 <InstanceName> 指定为“MSSQLSERVER”。使用 REMOVE=ALL 删除实例组件时还会删除共享组件：SQL Server 工具、Integration Services 和 Notification Services。

  3. 使用以下语法卸载 Microsoft SQL Native Client：

    复制代码
    Start /wait C:\Windows\System32\msiexec /qb /X <CD or DVD Drive>\setup\sqlncli.msi

  4. 使用以下语法卸载 Microsoft .NET Framework：

    复制代码
    Start /wait <CD or DVD Drive>\redist\2.0\dotnetfix.exe /q:a /c:"install /qu"
    注意：
    由于 Visual Studio 依赖 Microsoft .NET Framework，因此卸载 .NET Framework 1.1 或 2.0 会影响现有的 Microsoft Visual Studio 安装。如果安装了 Visual Studio，请不要卸载 .NET Framework。

从命令提示符删除 SQL Server 2005 的默认群集实例

  1. 将 SQL Server 2005 安装介质插入磁盘驱动器。

  2. 使用以下语法卸载 SQL Server：

    复制代码
    start /wait <CD or DVD Drive>\setup.exe /qn VS=<VSName> INSTANCENAME=<InstanceName> REMOVE=SQL_Engine ADMINPASSWORD=<StrongPassword>

    对于默认实例，请将 <InstanceName> 指定为“MSSQLSERVER”。

    /qn 开关用于取消所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。指定 /qb 开关将显示基本的安装程序对话框。还会显示错误消息。

  3. 使用以下语法卸载 SQL Native Client：

    复制代码
    Start /wait <CD or DVD Drive>\msiexec /qb /X <CD or DVD Drive>\setup\sqlncli.msi

    如果 SQL Server 安装程序无法卸载群集节点，请使用以下步骤：

  4. 使用注册表编辑器实用工具 regedit.exe，找到注册表项 HLKM\Software\Microsoft\Microsoft SQL Server\<instid>\Setup，其中 <instid> 是要卸载的特定 SQL Server 实例；例如，MSSQL.1 代表第一个实例，MSSQL.2 代表第二个实例。

    注意：
    如果注册表编辑不当，可能会导致严重问题并需要重新安装操作系统。Microsoft 不能保证因注册表编辑不当而导致的问题会得到解决。编辑注册表之前，请备份所有重要数据。有关如何备份、还原和编辑注册表的信息，请参阅此 Microsoft 知识库文章。

  5. 在此项中，设置 SqlCluster=2。

  6. 重复上两个步骤，对群集中所有节点更新 SqlCluster 项。

  7. 将共享磁盘移到当前正卸载的计算机上，在该节点上使用添加或删除程序来删除 SQL Server 2005。

  8. 将共享磁盘移到下一个节点，然后使用添加或删除程序删除 SQL Server 2005。

  9. 对其余每个节点，重复此移动和卸载过程。

    如果 SQL Server 2005 和早期版本的 SQL Server、企业管理器或其他依赖于 SQL-DMO 的程序同时运行，则早期版本可能被禁用。这可能出现在以下情况中：

    • 并行安装了 SQL Server 2005、SQL Server 2000 和/或 SQL Server 7.0，但又卸载了其中任一版本。

    • 并行安装了 SQL Server 2000 和 SQL Server 2005，且是在安装 SQL Server 2005 后安装 SQL Server 2000。

    这个问题是由于删除了 SQL Server 2005 SQL-DMO COM 库的注册造成的。若要重新启用企业管理器和对 SQL-DMO 有依赖关系的其他程序，请从命令提示符运行 regsvr32.exe sqldmo.dll 以注册 SQL-DMO。有关详细信息，请参阅SQL Server 数据库引擎的安装故障排除。

    如果在群集环境中并行安装了 Microsoft SQL Server 2000 和 SQL Server 2005，则卸载 SQL Server 2005 时不应卸载 SQL Native Client。SQL Server 2005 的 SQL Server 资源 DLL 始终使用 SQL Native Client 与 SQL Server 进行连接。安装 SQL Server 2005 时，SQL Server 群集资源 DLL 会升级。卸载 SQL Server 2005 时，SQL Server 资源 DLL 不会替换为 SQL Server 2000 所需的版本。在群集节点上保留 SQL Native Client 使得 SQL Server 资源 DLL 可以继续连接到 SQL Server 2000 的实例。

使用 .ini 文件运行 SQL Server 2005 的命令提示符安装

  1. 从命令提示符运行 Setup.exe：

    引用 .ini 文件的安装的示例命令如下：

    复制代码
                          <CD or DVD Drive>\Setup.exe /settings C:/set.ini /qn

    其中 Setup.exe 命令后面是 /settings 开关，该开关指定包含安装参数的 .ini 文件名，再后面是 /qn 开关，用于取消安装程序用户界面。在此示例中，“C:\set.ini”文件是包含安装参数的文本文件。

    如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关 .ini 文件各参数的详细信息，请参阅本部分后面的内容。有关安装程序日志文件位置的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。

返回页首。

参数

可以使用下表中列出的参数开发命令提示符安装脚本。

[Options] | [PIDKEY] | [INSTALLSQLDIR]
[INSTALLSQLSHAREDDIR] | [INSTALLDATADIR] | [INSTALLASDATADIR]
[ADDLOCAL] | [REMOVE] | [INSTANCENAME]
[UPGRADE] | [SAVESYSDB] | [USESYSDB]
[SQLACCOUNT]、[SQLPASSWORD]、[AGTACCOUNT]、[AGTPASSWORD]、[ASACCOUNT]、[ASPASSWORD]、[RSACCOUNT] 和 [RSPASSWORD] | [AUTOSTART] | [SECURITYMODE] 和 [SAPWD]
[SQLCOLLATION] 和 [ASCOLLATION] | [REBUILDDATABASE] | [REINSTALLMODE]
[RSCONFIGURATION] | [SAMPLEDATABASESERVER] | [DISABLENETWORKPROTOCOLS]
[ERRORREPORTING] | [SKUUPGRADE] |

有关每个参数的详细信息，请参阅下面的参数说明。

若要在群集上从命令提示符安装，请参阅群集安装所需的参数。

返回页首。

[Options]

使用设置 (.ini) 文件时，必须指定 [Options] 行。此信息用于“注册信息”对话框。

默认值：如果未指定这些参数，则使用服务器的默认用户名值和公司名称值。

注意：
如果名称中包含空格，请用引号将名称括起来。

复制代码
USERNAME=
COMPANYNAME=

[PIDKEY]

对于 SQL Server 2005 的重要中间版本，不需要 PIDKEY 属性，因为 MSI 文件的参数是预设的。但是，SQL Server 2005 的最终发行版需要 PIDKEY 属性。

用法：PIDKEY=ABCDE12345FGHIJ67890KLMNO。

注意：
这不是实际的项值。

注意

  • PIDKEY 不能用于 SQL Server Express 安装。

  • 不要在 PIDKEY 中包含“-”。

复制代码
PIDKEY=

[INSTALLSQLDIR]

此信息用于“功能选择”对话框。若要使用默认路径，请不要指定此参数。

注意：
如果指定的路径中有空格，请用引号将路径括起来，且每个路径的结尾以反斜杠 (\) 结束。

用法：INSTALLSQLDIR 指定特定于实例的二进制文件的位置。默认位置为：\Program Files\Microsoft SQL Server\。

重要事项：
群集安装必须指定 INSTALLSQLDIR，且 INSTALLSQLDIR 必须指向一个本地驱动器，其驱动器号在群集定义中的所有节点上都存在。

复制代码
INSTALLSQLDIR=

有关安装目录的详细信息，请参阅 SQL Server 2005 的默认实例和命名实例的文件位置。

[INSTALLSQLSHAREDDIR]

INSTALLSQLSHAREDDIR 参数指定 Integration Services、Notification Services 和工作站组件的自定义位置。在示例：Setup.exe <options> INSTALLSQLSHAREDDIR="<InstallDir>" 中，安装路径为：

  • <InstallDir>\90\DTS\

  • <InstallDir>\90\Notification\

  • <InstallDir>\90\Tools\

复制代码
INSTALLSQLSHAREDDIR=

有关安装目录的详细信息，请参阅 SQL Server 2005 的默认实例和命名实例的文件位置。

[INSTALLSQLDATADIR]

INSTALLSQLDATADIR 指定 SQL Server 数据文件的位置。默认位置是在 INSTALLSQLDIR 位置下。

重要事项：
群集安装必须指定 INSTALLSQLDATADIR，且 INSTALLSQLDATADIR 必须指向一个共享驱动器，该共享驱动器是为安装指定的群集组的成员。

复制代码
INSTALLSQLDATADIR=

有关安装目录的详细信息，请参阅 SQL Server 2005 的默认实例和命名实例的文件位置。

[INSTALLASDATADIR]

用法：INSTALLASDATADIR 指定 Analysis Services 数据文件的位置。默认位置为：INSTALLSQLDIR\Data\。

注意：
不要将此参数用于 SQL Server Express 安装。

如果计算机上已安装 Analysis Services，将忽略此参数。

复制代码
INSTALLASDATADIR=

有关安装目录的详细信息，请参阅 SQL Server 2005 的默认实例和命名实例的文件位置。

[ADDLOCAL]

用法：ADDLOCAL 指定要安装的组件。如果未指定 ADDLOCAL，安装程序将失败。

若要安装所有组件，请从命令提示符指定“ADDLOCAL=All”。

ADDLOCAL 规则：

  • 功能名称区分大小写。

  • 若要使用 ADDLOCAL，请提供以逗号分隔且不含空格的要安装的功能的列表。例如，若要安装除 Analysis Services 和 Reporting Services 组件之外的所有组件，该列表将如下所示：

    • ADDLOCAL=SQL_Engine,SQL_Data_Files,SQL_FullText,Notification_Services,NS_Engine,NS_Client,SQL_DTS,Client_Components,Connectivity,SQL_Tools90,SDK,SQL_Documentation,SQL_BooksOnline,SQL_SQLServerBooksOnline,SQL_SQLServerMobileBooksOnline,SQL_Samples,SQL_AdventureWorksSamples,SQL_AdventureWorksDWSamples,SQL_AnalysisServiceSamples,SQL_Samples

  • 选择父功能将只安装父功能，而不会同时安装父功能和子功能。安装子功能将自动安装父功能和子功能。删除父功能将同时删除父功能和子功能。

  • 还可以使用 ADDLOCAL 以维护模式添加组件。例如，执行上述安装后，指定以下内容可以添加 Analysis Services：

    • ADDLOCAL=Analysis_Server,AnalysisDataFiles,AnalysisSharedTools,Client_Components,Connectivity

下表显示父/子功能关系及其对安装在 X86、IA64 和 AMD64 中的 SQL Server 2005 Enterprise Edition、Developer Edition、Evaluation Edition 和 Standard Edition 的 ADDLOCAL 要求。

SQL Server 2005 功能 | 父功能名 | 子功能名
SQL Server Database Services | SQL_Engine |
SQL Server 数据文件 |  | SQL_Data_Files
复制 |  | SQL_Replication
全文搜索引擎 |  | SQL_FullText
Analysis Services | Analysis_Server |
Analysis Services 数据文件 |  | AnalysisDataFiles
Reporting Services | RS_Server |
报表管理器 |  | RS_Web_Interface
Notification Services | Notification_Services |
Notification Services 引擎组件 |  | NS_Engine
Notification Services 客户端组件 |  | NS_Client
Notification Services 规则组件 |  | NS_Rules
Integration Services |  | SQL_DTS
客户端组件 | Client_Components |
连接组件 |  | Connectivity
管理工具 |  | SQL_Tools90
Business Intelligence Development Studio |  | SQL_WarehouseDevWorkbench
软件开发包 |  | SDK
SQLXML 客户端功能 |  | SQLXML
早期组件：Data Transformation Services 2000 运行库和 DMO |  | Tools_Legacy
文档和示例 |  | SQL_Documentation
文档 |  | SQL_BooksOnline
SQL Server 联机丛书 |  | SQL_SQLServerBooksOnline
SQL Server 2005 Mobile Edition 联机丛书 |  | SQL_SQLServerMobileBooksOnline
示例数据库 |  | SQL_DatabaseSamples
AdventureWorks 示例 OLTP |  | SQL_AdventureWorksSamples
AdventureWorks 示例数据仓库 |  | SQL_AdventureWorksDWSamples
AdventureWorks 示例 OLAP |  | SQL_AdventureWorksASSamples
示例 |  | SQL_Samples
复制代码
ADDLOCAL=

下表显示父/子功能关系及其对安装在 X86、IA64 和 AMD64 中的 SQL Server 2005 Workgroup Edition 的 ADDLOCAL 要求。

SQL Server 2005 Workgroup 功能 | 父功能名 | 子功能名
SQL Server Database Services | SQL_Engine |
SQL Server 数据文件 |  | SQL_Data_Files
复制 |  | SQL_Replication
全文搜索引擎 |  | SQL_FullText
Integration Services |  | SQL_DTS
客户端组件 | Client_Components |
连接组件 |  | Connectivity
管理工具 |  | SQL_Tools90
软件开发包 |  | SDK
SQLXML 客户端功能 |  | SQLXML
早期组件：Data Transformation Services 2000 运行库和 DMO |  | Tools_Legacy
文档和示例 |  | SQL_Documentation
文档 |  | SQL_BooksOnline
SQL Server 联机丛书 |  | SQL_SQLServerBooksOnline
SQL Server 2005 Mobile Edition 联机丛书 |  | SQL_SQLServerMobileBooksOnline
示例数据库 |  | SQL_DatabaseSamples
AdventureWorks 示例 OLTP |  | SQL_AdventureWorksSamples
AdventureWorks 示例数据仓库 |  | SQL_AdventureWorksDWSamples
AdventureWorks 示例 OLAP |  | SQL_AdventureWorksASSamples
示例 |  | SQL_Samples
复制代码
ADDLOCAL=

下表显示父/子功能关系及其对安装在 X86、IA64 和 AMD64 中的 SQL Server 2005 Express Edition 的 ADDLOCAL 要求。

SQL Server 2005 Express 功能 | 父功能名 | 子功能名
SQL Server Database Services | SQL_Engine |
SQL Server 数据文件 |  | SQL_Data_Files
复制 |  | SQL_Replication
客户端组件 | Client_Components |
连接组件 |  | Connectivity
软件开发包 |  | SDK
复制代码
ADDLOCAL=

[REMOVE]

REMOVE 参数指定要卸载的组件，如 SQL Server、Reporting Services 或 Analysis Services。此命令必须与 INSTANCENAME 参数一起使用。例如，若要删除识别实例的组件与任何不识别实例的组件（如 Client_Components），则指定以下内容：

  • REMOVE=All INSTANCENAME=MSSQLSERVER

    重要事项：
    如果已安装多个实例，且仍想使用客户端工具，请不要使用此参数。

    若要删除所有不识别实例的组件（如 Client_Components 和 SQL_DTS），请指定 REMOVE=ALL 且不引用实例名。

    如果为新安装指定 REMOVE，则不安装“REMOVE=”后列出的组件。例如，若要在新安装中安装除 Reporting Services 组件之外的所有组件，请指定以下内容：

    • ADDLOCAL=All REMOVE=RS_Server,RS_Web_Interface

还可以在维护期间使用 REMOVE 从现有安装中删除组件。例如，若要删除全文搜索，请指定以下内容：

  • REMOVE=SQL_FullText

    重要事项：
    删除父功能将同时删除父功能和子功能。

    复制代码
    REMOVE=

[INSTANCENAME]

此信息用于“实例名”对话框。对于识别实例的组件，必须指定 INSTANCENAME 参数。对于默认实例，请使用 MSSQLSERVER。对于不识别实例的共享组件（Notification Services、Integration Services 和客户端组件），可以省略此参数。

复制代码
INSTANCENAME=

[UPGRADE]

UPGRADE 参数指定要升级的产品。允许的值为 SQL_Engine 以升级 SQL Server。如果指定了 UPGRADE 选项，必须指定 INSTANCENAME 参数才能定义要升级的实例。例如，若要升级 SQL Server 的默认实例，请使用以下命令行：

  • UPGRADE=SQL_Engine INSTANCENAME=MSSQLSERVER

若要升级以域帐户运行 SQL Server 的 SQL Server 命名实例，且要添加客户端组件和工具，请运行以下命令：

  • UPGRADE=SQL_Engine INSTANCENAME=<实例名> SQLACCOUNT=<域名>\<帐户名> SQLPASSWORD=<强密码> ADDLOCAL=Client_Components

    复制代码
    UPGRADE=

[SAVESYSDB]

在卸载时使用 SAVESYSDB 参数可以指定不删除系统数据库。如果 SAVESYSDB 设为 1，则系统数据库留在 SQL 数据目录中。此选项通常用在计划将来要升级的情况下。

复制代码
SAVESYSDB=

[USESYSDB]

USESYSDB 参数指定升级时系统数据库的数据目录的根路径。例如，如果数据库安装在 D:\Microsoft SQL Server\MSSQL.1\MSSQL\DATA 下，usesysdb 参数应为 USESYSDB="D:\Microsoft SQL Server\MSSQL.1\MSSQL"。

如果设置了数据库引擎功能的安装路径，则 SQL Server 安装程序将使用该路径作为该安装的所有特定于实例的文件夹的根目录，包括 SQL Server 数据文件。在这种情况下，如果将根目录设为“C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\”，则特定于实例的目录将附加到该路径后。

如果选择使用 USESYSDB 升级功能，客户就能够轻松地将产品安装到递归文件夹结构（如 <SQL 程序文件夹>\MSSQL.1\MSSQL\MSSQL.1\MSSQL\Data\）中。若要使用 USESYSDB 功能，请设置 SQL Server 数据文件的安装路径，而不是数据库引擎功能的安装路径。

注意：
数据文件始终应位于名为“Data”的子目录中。例如，当数据文件位于“C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data”下时，应指定“C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL”以指定升级过程中系统数据库的数据目录的根路径。

重要事项：
使用 USESYSDB 安装 SQL Server 2005 与一组来自以前安装的版本的数据文件时，请确保系统数据库的 .MDF 文件和 .LDF 文件位于同一目录中。

复制代码
USESYSDB=

[SQLACCOUNT]、[SQLPASSWORD]、[AGTACCOUNT]、[AGTPASSWORD]、[ASACCOUNT]、[ASPASSWORD]、[RSACCOUNT] 和 [RSPASSWORD]

此信息用于“服务帐户”对话框。如果未指定这些参数，默认情况下安装程序使用 LocalSystem 帐户。

注意：
默认情况下，SQL Server 和 Analysis Services 的服务设为自动启动。

若要使用 *ACCOUNT 设置，请确保指定 DOMAIN，例如 SQLACCOUNT=DOMAINNAME\ACCOUNT。

重要事项：
虚拟服务器安装必须指定 SQLACCOUNT、SQLPASSWORD、AGTACCOUNT 和 AGTPASSWORD。ASACCOUNT 和 ASPASSWORD 不能用于虚拟服务器安装。

复制代码
SQLACCOUNT=
SQLPASSWORD=
AGTACCOUNT=
AGTPASSWORD=
ASACCOUNT=
ASPASSWORD=
RSACCOUNT=
RSPASSWORD=

[AUTOSTART]

若要使用 *AUTOSTART 参数，则指定 1 将自动启动，指定 0 将手动启动。如果决定自动启动 SQL Server 代理，则 SQL 也将自动启动。这些参数的默认值指定如下。

复制代码
SQLAUTOSTART=1
AGTAUTOSTART=0
ASAUTOSTART=1
RSAUTOSTART=1

[SECURITYMODE] 和 [SAPWD]

此信息用于“身份验证模式”对话框。若要使用混合模式身份验证，请使用 SECURITYMODE=SQL。如果未指定 SECURITYMODE=SQL，则只使用 Windows 身份验证。

重要事项：
如果可能，请使用 Windows 身份验证。

若要设置 sa 密码，请指定 SAPWD。SQL Server 安装程序要求指定强 sa 密码。

重要事项：
不要使用空密码。请使用强密码。

SECURITYMODE=SQL

复制代码
SAPWD=

有关强密码指南的详细信息，请参阅身份验证模式。

[SQLCOLLATION] 和 [ASCOLLATION]

此信息用于“排序规则设置”对话框。SQLCOLLATION 参数设置 SQL Server 排序规则，ASCOLLATION 参数设置 Analysis Services 排序规则。

复制代码
SQLCOLLATION=
ASCOLLATION=

有关排序规则设置的详细信息，请参阅安装程序中的排序规则设置、Windows 排序规则排序样式和使用二进制排序规则。

[REBUILDDATABASE]

此信息用于重新生成系统数据库。当系统数据库损坏或要重置系统排序规则时，必须将系统数据库还原为原始安装时的状态。可以使用 REBUILDDATABASE 参数启用此功能，即指定 REBUILDDATABASE=1。使用 REBUILDDATABASE 时需要的其他参数包括：

  • SQLACCOUNT、SQLPASSWORD

  • SQLAGTACCOUNT、SQLAGTPASSWORD

  • SQLBROWSERACCOUNT、SQLBROWSERPASSWORD

重新生成 master 数据库的问题

重新生成 master 数据库会将所有系统数据库恢复为其原始内容和属性。

重新生成 master 数据库之后的工作

重新生成 master 后，必须执行以下操作：

  1. 还原 master、model 和 msdb 数据库的最新完整备份。如果没有可用的备份，请转到步骤 2。

  2. 如果要还原的数据库备份不够新，请重新创建缺少的所有项。例如，在 master 数据库中，重新创建用户数据库、备份设备、SQL Server 登录名、端点等缺少的所有项。如果有创建这些项时所使用的原始脚本，则重新创建这些项的最佳方法是运行这些原始脚本。

    安全说明：
    建议您保护好脚本，以防未经授权的人员更改脚本的内容。

    还要建议您在更新完数据库后，备份该数据库。有关详细信息，请参阅 SQL Server 2005 联机丛书中备份 master 数据库和备份 model 和 msdb 数据库的主题。

  3. 如果服务器实例配置为复制分发服务器，必须还原分发数据库。有关详细信息，请参阅 SQL Server 2005 联机丛书中的备份和还原复制的数据库的主题。

  4. 在 SQL Server 2005 中，系统对象存储在资源数据库中。每当将 SQL Server 更新（QFE 或 service pack）应用于 SQL Server 可执行文件 sqlservr.exe 时，就会更新此数据库。重新生成 master 数据库后，必须重新应用以前已应用于该服务器实例的任何 SQL Server 更新。有关详细信息，请参阅 SQL Server 2005 联机丛书中资源数据库的主题。

    重要事项：
    不要在常规数据库备份和还原过程中包含 mssqlsystemresource.mdf 文件（即资源数据库）。该文件既不包含数据也不包含元数据，它包含的是代码。默认情况下，SQL Server 备份和还原组件自动省略资源数据库。

  5. 重新生成 master 数据库时，会将所有系统数据库安装到其初始位置。如果将一个或多个系统数据库移动到其他位置，则必须重新移动这些数据库。有关移动系统数据库的详细信息，请参阅移动系统数据库。

注意：
REBUILDDATABASE 选项只在无人参与的安装中可用。必须使用 /qn 或 /qb 选项。/qn 开关用于取消所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。

指定 /qb 开关将显示基本的安装程序对话框。还会显示错误消息。

重要事项：
为了重新生成系统数据库，必须指定新的 sa 密码。

复制代码
REBUILDDATABASE=

[REINSTALLMODE]

此信息用于修复已安装的组件。使用 REINSTALLMODE 时，必须指定 REINSTALL 参数。REINSTALL 参数使用与 ADDLOCAL 参数相同的值。

注意：
REINSTALLMODE 选项只在无人参与的安装程序中可用，且必须使用 /qn 或 /qb 选项。/qn 开关用于取消所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。

指定 /qb 开关将显示基本的安装程序对话框。还会显示错误消息。

REINSTALLMODE 所支持的值为：

  • O - 如果缺少文件或版本较旧，则重新安装

  • M - 重写 HKLM 下特定于计算机的注册表项

  • U - 重写 HKCU 下特定于用户的注册表项

  • S - 重新安装所有快捷方式

复制代码
REINSTALLMODE=

[RSCONFIGURATION]

此信息用于“Reporting Services 配置”对话框。安装 Reporting Services 或报表管理器功能时，应指定此参数，此参数值可为 FilesOnly 或 Default。指定 FilesOnly 选项将只安装文件，并不实际配置报告服务。指定“Default”选项将使用默认选项安装 Reporting Services。

复制代码
RSCONFIGURATION=

有关详细信息，请参阅 报表服务器安装选项。

[SAMPLEDATABASESERVER]

此信息用于“示例数据库”对话框。安装 AdventureWorks 示例或 AdventureWorksDW 示例功能时，应使用此参数。

示例数据库可以附加到与示例数据库版本相同的任何现有的本地 SQL Server 实例中。此参数指定要将示例附加到的计算机和实例的名称，如下所示：

  • SAMPLEDATABASESERVER - MachineName\InstanceName

复制代码
SAMPLEDATABASESERVER=

[DISABLENETWORKPROTOCOLS]

此参数用于设置网络协议的启动类型。它有以下三个选项：

  • 0 - Shared memory = On、Named Pipes = On、TCP/IP = On

  • 1 - Shared memory = On、Named Pipes = Off（仅限本地使用）、TCP/IP = Off

  • 2 - Shared memory = On、Named Pipes = Off（仅限本地使用）、TCP/IP = On

复制代码
DISABLENETWORKPROTOCOLS=

[ERRORREPORTING]

此信息用于“错误报告”对话框。如果启用此功能，则 SQL Server 及其组件以及 Analysis Services 配置为当 SQL Server 数据库引擎、SQL Server 代理或 Analysis Services 中出现致命错误时，将会自动向 Microsoft 发送报告。Microsoft 利用错误报告来改进 SQL Server 的功能，并且对所有信息保密。

若要启用错误报告，请指定 ERRORREPORTING=1。如果未指定 ERRORREPORTING=1，则会禁用错误报告功能。

复制代码
ERRORREPORTING=

[SKUUPGRADE]

从 SQL Server 2005 的一个版本升级到 SQL Server 2005 的另一个版本时，使用 SKUUPGRADE 参数。

重要事项：
如果使用 SKUUPGRADE 参数，则安装程序将删除要升级的 SQL Server 实例的所有修补程序和 Service Pack 更新。版本升级完成后，必须重新应用所有修补程序和 Service Pack 更新。

若要通过无人参与的安装程序执行 SQL Server 2005（仅 SQL 引擎）的默认实例的版本升级，请使用 /qb 或 /qn 运行下列命令：

start /wait setup.exe ADDLOCAL=SQL_Engine INSTANCENAME=MSSQLSERVER UPGRADE=SQL_Engine SKUUPGRADE=1 /qb

复制代码
SKUUPGRADE=

群集安装所需的参数

注意：
若要运行群集安装，必须在群集上进行，且必须在命令行中指定 /qn 或 /qb。/qn 开关用于取消所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。

指定 /qb 开关将显示基本的安装程序对话框。还会显示错误消息。有关故障转移群集的详细信息，请参阅配置高可用性和安装故障转移群集前的准备工作。

从命令提示符进行群集安装需要以下参数。

[INSTALLSQLDIR] | [INSTALLSQLDATADIR] | [SQLACCOUNT]、[SQLPASSWORD]、[AGTACCOUNT] 和 [AGTPASSWORD]
[INSTANCENAME] | [SAPWD] | [VS]
[INSTALLVS] | [IP] | [GROUP]
[ADDNODE] | [REMOVENODE] | [SQLCLUSTERGROUP] 和 [AGTCLUSTERGROUP]
[ADMINPASSWORD] | [SKUUPGRADE] |

[INSTALLSQLDIR]

故障转移群集安装必须指定此参数。其中的驱动器号必须在两台计算机上都存在。

复制代码
INSTALLSQLDIR=

[INSTALLSQLDATADIR]

故障转移群集安装必须指定此参数。其中的共享驱动器号必须在 GROUP 参数中使用的磁盘组中存在。

复制代码
INSTALLSQLDATADIR

[SQLACCOUNT]、[SQLPASSWORD]、[AGTACCOUNT] 和 [AGTPASSWORD]

故障转移群集安装必须指定这些参数。

复制代码
SQLACCOUNT=
SQLPASSWORD=
AGTACCOUNT=
AGTPASSWORD=

[INSTANCENAME]

故障转移群集安装必须指定此参数。对于默认实例，请使用 MSSQLSERVER。有关实例命名规则的详细信息，请参阅实例名称。

复制代码
INSTANCENAME=

[SAPWD]

故障转移群集安装必须指定此参数。

重要事项：
不要使用空密码。请使用强密码。

复制代码
SAPWD=

有关强密码指南的详细信息，请参阅身份验证模式。

[VS]

故障转移群集安装必须指定此参数。此参数用于指定虚拟服务器的名称。该名称不能超过 15 个字符，它遵循与计算机名称相同的规则。

复制代码
VS=

[INSTALLVS]

故障转移群集安装必须指定此参数。它指定要作为群集安装的服务器。对于 SQL Server 请使用“SQL_Engine”，对于 Analysis Services 请使用“Analysis_Server”。

复制代码
INSTALLVS=

[IP]

故障转移群集安装必须指定此参数。它用于指定 IP 地址，请为每个网络适配器提供一项。

  • 格式："IP 地址,网络"

  • 示例：IP="xxx.xxx.xxx.xxx,Local Area Connection"

复制代码
IP=

[GROUP]

故障转移群集安装必须指定此参数。它指定包含 SQL Server 资源的群集组，该群集组包含要写入共享数据文件的磁盘。

  • 示例：GROUP="Group 2"

复制代码
GROUP=

[ADDNODE]

故障转移群集安装必须指定此参数。它指定虚拟服务器的节点。群集中必须存在这些节点。还可以使用此参数向现有群集添加节点。

复制代码
ADDNODE=

[REMOVENODE]

此参数只用于群集维护。使用此选项可以从现有群集中删除节点。

复制代码
REMOVENODE=

[SQLCLUSTERGROUP] 和 [AGTCLUSTERGROUP]

故障转移群集安装必须指定这些参数。若要安装故障转移群集，以 <DomainName>\<GroupName> 格式指定在安装程序运行时就已存在的域名和组名。SQL Server 安装程序不会在安装过程中为您创建组。有关详细信息，请参阅群集服务的域组。

复制代码
SQLCLUSTERGROUP=
AGTCLUSTERGROUP=

[ADMINPASSWORD]

故障转移群集安装必须指定此参数。指定登录用户帐户的密码。指定的帐户必须是所有远程群集节点的管理员。

复制代码
ADMINPASSWORD=

请参阅

任务

如何安装 SQL Server 2005（安装程序）

概念

如何查看 SQL Server 2005 安装日志文件


如何安装 Microsoft Internet 信息服务

如何安装 Microsoft Internet 信息服务 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

Microsoft Internet 信息服务 (IIS) 是某些 Microsoft SQL Server 2005 组件的必备软件。有关详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。

安装 Internet 信息服务

  1. 关闭计算机上所有当前正在运行的应用程序。

  2. 在控制面板中，双击“添加或删除程序”。

  3. 在左窗格中，单击“添加/删除 Windows 组件”。Windows 组件向导将启动。

  4. 选择“Internet 信息服务”，然后单击“下一步”。如果复选框已经选中，说明计算机上已经安装了 IIS。

    注意：
    对于某些服务器操作系统，IIS 可能是应用程序服务器选择的一个组件。如果您的操作系统属于这种情况，那么请选择“应用程序服务器”，然后单击“下一步”。

    将在您的计算机上安装和配置 IIS。

请参阅

概念

如何查看 SQL Server 2005 安装日志文件

其他资源

数据库引擎安装帮助主题


如何验证 SQL Server 2005 服务的安装成功

如何验证 SQL Server 2005 服务的安装成功 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

若要验证 Microsoft SQL Server 2005 安装成功，请确保安装的服务正运行于计算机上。

验证 SQL Server 2005 服务的安装成功

  1. 检查 SQL Server 服务是否正在运行：在“控制面板”中，双击“管理工具”，双击“服务”，然后查找相应的服务显示名称。

    下表列出服务显示名称及其提供的服务。

    注意：
    实际服务名称与其显示名称略有不同。通过右键单击服务并选择“属性”可以查看服务名称。

Name | 服务
SQL Server (MSSQLSERVER) | SQL Server 数据库引擎的默认实例。
SQL Server (instancename) | SQL Server 数据库引擎的命名实例，其中 instancename 是实例的名称。
SQL Server 代理 (MSSQLSERVER) | SQL Server 代理的默认实例。SQL Server 代理可以运行作业，监视 SQL Server，激发警报，以及允许自动执行某些管理任务。
SQL Server 代理 (instancename) | SQL Server 代理的命名实例，其中 instancename 是实例的名称。SQL Server 代理可以运行作业，监视 SQL Server，激发警报，以及允许自动执行某些管理任务。
Analysis Services (MSSQLSERVER) | Analysis Services 的默认实例。
分析服务器 (instancename) | Analysis Services 的命名实例，其中 instancename 是实例的名称。
Reporting Services | Microsoft Reporting Services 的默认实例。
Reporting Services (instancename) | Reporting Services 的命名实例，其中 instancename 是实例的名称。
  1. 如果服务没有运行，通过右键单击服务再单击“启动”启动服务。如果服务无法启动，则请检查服务属性中的 .exe 路径。确保指定的路径中存在 .exe。

请参阅

任务

如何阅读 SQL Server 2005 安装日志文件

概念

如何查看 SQL Server 2005 安装日志文件
SQL Server 数据库引擎的安装故障排除
SQL Server 外围应用配置器


如何在 SQL Server 2005 的现有实例中更改组件（安装程序）

如何在 SQL Server 2005 的现有实例中更改组件（安装程序） |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

在此 Microsoft SQL Server 版本中，只有通过 Microsoft Windows 中“控制面板”的“添加或删除程序”才能支持功能维护。

在 SQL Server?2005 的现有实例中更改组件

  1. 在“控制面板”中，双击“添加或删除程序”。

  2. 在“目前安装的程序”下，单击要配置的 SQL Server 实例，然后单击“更改”。

  3. 在“选择组件 - 维护”页上，选择要更新的实例或共享组件。

    单击“报告”按钮以查看计算机上安装的 SQL Server 2005 各组件和功能的列表。该报告包含安装的每个组件和功能的版本、版本类别、更新级别和语言信息。

    若要继续，请单击“下一步”。

  4. 在“功能维护”页上，选择要更新的服务器组件。如果在前一页上选择了共享组件，则不会显示此页。

    单击“报告”按钮以查看计算机上安装的 SQL Server 2005 各组件和功能的列表。该报告包含安装的每个组件和功能的版本、版本类别、更新级别和语言信息。

    若要继续，请单击“下一步”。

  5. 在“更改/删除”页上，单击“更改”。

  6. 在“功能选择”页上，使用功能树更改对 SQL Server 2005 实例所做的选择。若要继续，请单击“下一步”。

  7. 在“准备更新”页上，检查 SQL Server 2005 安装程序要进行的更改。若要继续，请单击“下一步”。

  8. 在“安装进度”页上，安装程序显示安装状态。

  9. 在“完成安装”页上，单击“完成”退出安装向导。

请参阅

任务

如何安装 SQL Server 2005（安装程序）
如何卸载 SQL Server 2005 的现有实例（安装程序）
如何阅读 SQL Server 2005 安装日志文件

概念

如何查看 SQL Server 2005 安装日志文件


如何重命名 SQL Server 2005 的独立实例

如何重命名 SQL Server 2005 的独立实例 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

如果更改运行 Microsoft SQL Server 2005 的计算机名称，则 SQL Server 启动时将识别出新名称。不必再次运行安装程序以重置计算机名称。以下步骤不能用于重命名实例，只能用于重命名与计算机名称相对应的实例名部分。例如，将名为 MB1\instance1 的服务器改为其他名称，如 MB2\instance1，但该名称的实例部分 instance1 将保持不变。

开始之前

开始重命名进程之前，请阅读下列各项：

  • 当 SQL Server 实例是 SQL Server 故障转移群集的组成部分时，虚拟服务器与独立实例的重命名过程会有所不同。有关重命名虚拟服务器的信息，请参阅如何重命名 SQL Server 2005 虚拟服务器。

  • 除了在复制时使用日志传送的情况之外，SQL Server 不支持对复制所涉及的服务器进行重命名。如果主服务器永久丢失连接，则可以重命名日志传送中的辅助服务器。有关详细信息，请参阅复制和日志传送。

  • 重命名配置为使用数据库镜像的 SQL Server 实例时，必须在重命名操作前关闭数据库镜像，然后使用新实例名重新建立数据库镜像。数据库镜像的元数据不会自动更新以反映新的 SQL Server 实例名。

重新启动服务器后，可以使用新的计算机名称连接到 SQL Server。但是，若要确保 @@servername 返回本地服务器实例的更新后名称，应手动运行以下过程之一，具体取决于是更新默认实例还是更新命名实例。

重命名 SQL Server 2005 的实例

  • 对于重命名的默认实例，请运行以下过程：

    复制代码
    sp_dropserver <old_name>
GO
sp_addserver <new_name>, local
GO

    重新启动 SQL Server 实例。

  • 对于重命名的命名实例，请运行以下过程：

    复制代码
    sp_dropserver <old_name\instancename>
GO
sp_addserver <new_name\instancename>, local
GO

    重新启动 SQL Server 实例。

验证重命名操作

重命名 SQL Server 实例后，所有使用旧名称的连接必须使用新名称进行连接。

验证是否已成功完成重命名操作

  • 从 @@servername 或 sys.servers 中选择信息。@@servername 函数将返回新名称，而 sys.servers 表将显示新名称。

远程登录的相关问题

如果计算机存在远程登录，运行 sp_dropserver 可能会产生与下述错误类似的错误：

复制代码
Server: Msg 15190, Level 16, State 1, Procedure sp_dropserver, Line 44
There are still remote logins for the server 'SERVER1'.

若要解决此错误，必须删除此服务器的远程登录。

删除远程登录

  • 对于默认实例，请运行以下过程：

    复制代码
    sp_dropremotelogin old_name
GO

  • 对于命名实例，请运行以下过程：

    复制代码
    sp_dropremotelogin old_name\instancename
GO

请参阅

任务

如何重命名 SQL Server 2005 虚拟服务器


如何卸载 SQL Server 2005 的现有实例（安装程序）

如何卸载 SQL Server 2005 的现有实例（安装程序） |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

使用以下过程可以卸载 Microsoft SQL Server 2005 的实例。

注意：
必须严格按照给定的顺序执行此处列出的卸载步骤。

重要事项：
若要维护或更新 SQL Server 实例，您必须是具有“作为服务登录”权限的本地管理员。

开始卸载 SQL Server 2005 前，请考虑以下重要信息：

在同时运行 SQL Server 2005 和 SQL Server 早期版本的计算机上，企业管理器和其他依赖于 SQL-DMO 的程序可能被禁用。这可能出现在以下情况中：

  • 并行安装了 SQL Server 2005、SQL Server 2000 和/或 SQL Server 7.0，但又卸载了其中任一版本。

  • 并行安装了 SQL Server 2000 和 SQL Server 2005，且是在安装 SQL Server 2005 后安装 SQL Server 2000。

这个问题是由于删除了 SQL Server 2005 SQL-DMO COM 库的注册造成的。若要重新启用具有 SQL-DMO 依赖项的企业管理器和其他程序，请从命令提示符运行“regsvr32.exe sqldmo.dll”来注册 SQL-DMO。有关详细信息，请参阅“SQL Server 2005 安装故障排除”。

注意：
从内存大小为最小必需物理内存量的计算机中删除 SQL Server 2005 组件前，必须确保页文件大小等于物理内存量的两倍。在某些情况下，虚拟内存不足可能会导致不能彻底删除 SQL Server 2005。

有关命令提示符语法的信息，请参阅如何从命令提示符安装 SQL Server 2005。

有关删除故障转移群集的信息，请参阅如何删除 SQL Server 2005 故障转移群集实例（安装程序）。

删除 SQL Server?2005 实例

  1. 若要开始卸载过程，请在 Microsoft Windows 桌面上，单击“开始”，再单击“控制面板”，然后双击“添加或删除程序”。

  2. 选择要卸载的 SQL Server 2005 组件，再单击“删除”。此时将启动 SQL Server 2005 安装向导。

  3. 在“选择组件 - 卸载”页上，选择任何要删除的服务器和/或共享组件。

    单击“报告”按钮以查看计算机上安装的 SQL Server 2005 各组件和功能的列表。该报告包含安装的每个组件和功能的版本、版本类别、更新级别和语言信息。

    若要继续，请单击“下一步”。

  4. 在“确认 - 卸载”页上，检查要删除的组件和功能的列表。若要继续，请单击“下一步”。

  5. “安装进度”页将显示安装状态。

  6. 在“完成安装”页上，单击“完成”退出安装向导。

请参阅

任务

如何阅读 SQL Server 2005 安装日志文件

概念

如何查看 SQL Server 2005 安装日志文件


如何卸载现有的 SQL Server 2000 或 7.0 实例

如何卸载现有的 SQL Server 2000 或 7.0 实例 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

请使用以下过程删除现有的 Microsoft SQL Server 2000 或 SQL Server 7.0 实例。

着手卸载 SQL Server 之前，请考虑以下重要信息：

在 SQL Server 2005 与早期 SQL Server 版本同时运行的计算机上，企业管理器和依赖 SQL-DMO 的其他程序可能被禁用。这可能出现在以下情况中：

  • 并行安装了 SQL Server 2005、SQL Server 2000 和/或 SQL Server 7.0，但又卸载了其中任一版本。

  • 并行安装了 SQL Server 2000 和 SQL Server 2005，且是在安装 SQL Server 2005 后安装 SQL Server 2000。

这个问题是由于删除了 SQL Server 2005 SQL-DMO COM 库的注册造成的。若要重新启用企业管理器和对 SQL-DMO 有依赖关系的其他程序，请从命令提示符运行“regsvr32.exe sqldmo.dll”以注册 SQL-DMO。有关详细信息，请参阅“SQL Server 2005 安装故障排除”。

卸载现有 SQL Server 实例

  1. 将 SQL Server 2000 CD 插入 CD-ROM 驱动器。如果光盘未自动运行，请双击光盘根目录中的“Autorun.exe”文件。

  2. 单击“SQL Server 2000 组件”，再单击“安装数据库服务器”。安装程序随即启动 SQL Server 安装向导。在“欢迎”屏幕中单击“下一步”。

  3. 在“计算机名称”对话框中，单击“本地计算机”或“远程计算机”。

  4. 在“安装选择”对话框中，单击“对现有 SQL Server 实例进行升级、删除或添加组件”，再单击“下一步”。

  5. 在“实例名”对话框中，如果安装了默认实例，则“默认”复选框被选中。如果要卸载命名实例，请从“实例名”列表框中选择该实例，再单击“下一步”。

  6. 在“现有安装”对话框中，单击“卸载现有安装”，再单击“下一步”。

  7. 安装程序于是删除选定的安装。在“卸载”对话框中，单击“下一步”，然后在“安装完成”对话框中单击“完成”。

请参阅

任务

如何升级到 SQL Server 2005（安装程序）


如何查看 SQL Server 2005 安装日志文件

如何查看 SQL Server 2005 安装日志文件 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

Microsoft SQL Server 安装日志在此版本中有所更改。应查看的主日志位于

%ProgramFiles%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Summary.txt

此文件包含如下内容：

--------------------------------------------------------------------------------

Machine : MYSERVER

Product : Microsoft XML Parser

Product Version : 8.60.1639.0

Installation : Successful

--------------------------------------------------------------------------------

Machine : MYSERVER

Product : MSXML 6.0 Parser and SDK

Product Version : 6.00.3562.0

Installation : Successful

--------------------------------------------------------------------------------

Machine : MYSERVER

Product : Microsoft SQL Server 2005 Analysis Services

Product Version : 9.00.787

Installation : Successful

--------------------------------------------------------------------------------

Machine : MYSERVER

Product : Microsoft SQL Native Client

Product Version : 9.00.121

Installation : Successful

--------------------------------------------------------------------------------

如果日志文件显示某个“产品”失败，可以通过查看此产品日志（搜索“return value 3”）调查失败的根源。产品日志可位于：

%ProgramFiles%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Files

该日志的命名约定如下：

SQLSetup[XXXX][s]_[COMPUTERNAME]_[PRODUCTNAME]_[Y].log，其中

  • XXXXX = 该安装的枚举数（最后执行的安装具有最大的枚举数）

  • COMPUTERNAME= 正在运行安装程序的计算机

  • PRODUCTNAME= 产品名称（.msi 文件的名称），例如：Reporting Services 的 SQLSetup0001_MachineName_RS.log、Notification Services 的 SQLSetup0001_MachineName_NS.log

  • Y= 如果在一次安装运行中多次安装了 Microsoft Windows Installer 文件（.msi），则将该数字添加到日志名称上并递增。?这主要发生在 Microsoft XML Core Services (MSXML) 上。

下表包含安装每一个 SQL Server 组件的示例日志文件名称和日志文件说明。

日志文件 | 说明
SQLSetup0001_MachineName_Core.log | 主 SQL Server 安装日志文件，包含所有 .msi 安装成功或失败的信息。
SQLSetup0001_MachineName_SCC.log | SQL Server 2005 系统配置检查器的详细信息，该检查器在 SQL Server 安装过程中运行系统检查。
SQLSetup0001_MachineName_SQL.log | 数据库引擎安装日志文件。
SQLSetup0001_MachineName_AS.log | Analysis Services 安装日志文件。
SQLSetup0001_MachineName_RS.log | Reporting Services 安装日志文件。
SQLSetup0001_MachineName_NS.log | SQL Server 2005 Notification Services 安装日志文件。
SQLSetup0001_MachineName_DTS.log | Integration Services 安装日志文件。
SQLSetup0001_MachineName_Tools.log | 客户端组件、SQL Server Management Studio 和联机丛书安装日志文件。
SQLSetup0001_MachineName_WI.log | 安装用户界面 (UI) 安装日志文件。
SQLSetup0001_MachineName_SNAC.log | SQL Server 本机客户端安装日志文件。
SQLSetup0001_MachineName_.NET Framework 2.0.log | .NET Framework 2.0 安装日志文件。
SQLSetup0001_MachineName_MSXML.log | MSXML 安装日志文件。
SQLSetup0001_MachineName_SQLXML.log | SQLXML 安装日志文件。
SQLSetup0001_MachineName_Logs.cab | 对于故障转移群集安装，此文件将包含来自所有群集节点的日志。
SQLSetup0001_MachineName_Datastore.xml | 对在安装期间缓存的所有属性的转储。产品支持服务部门可能需要此信息以排除故障与调试错误。

请参阅

任务

如何阅读 SQL Server 2005 安装日志文件

概念

SQL Server 数据库引擎的安装故障排除


如何阅读 SQL Server 2005 安装日志文件

如何阅读 SQL Server 2005 安装日志文件 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

SQL Server 2005 安装程序在安装过程中为每个 SQL Server 组件创建日志文件；Setup.exe 启动后日志记录立即开始。

阅读 SQL Server 安装日志文件

  1. 打开 Windows 资源管理器并导航到：

    %ProgramFiles%\Microsoft SQL Server\90\Setup Bootstrap\LOG

  2. 打开 Summary.txt 文件。通查该文件看有无错误消息。

  3. 如果在 Summary.txt 文件中找不到有关失败事项的信息，请打开同一根目录中的 SQLSetup[xxxx].cab 文件。

  4. 如果该 .cab 文件不存在，请在下列路径中打开 CORE 日志文件：

    %ProgramFiles%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Files

    查看最新修改的核心日志：SQLSetup[xxxx]_[ComputerName]_Core.log。

  5. 如果安装过程中在用户界面中显示了错误，请查找此日志：SQLSetup[xxxx][s]_[ComputerName]_WI.log。

  6. 分析 SQLSetup_[xxxx] 日志文件时，在该文件中搜索“UE 3”。这是“Return Value 3”的缩写。

  7. 如果在安装进度对话期间组件失败，请打开日志文件 SQLSetup[xxxx]_[ComputerName]_SQL.log，然后执行“UE 3”搜索以扫描错误。

请参阅

概念

如何查看 SQL Server 2005 安装日志文件


如何重新生成 SQL Server 2005 的 Master 数据库

如何重新生成 SQL Server 2005 的 Master 数据库 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

此 Microsoft SQL Server 版本中更改了使用 Setup 命令重新生成 master 数据库的用法。运行 Setup.exe 重新生成、验证和修复 SQL Server 实例，并重新生成系统数据库。此过程通常用于为损坏的 SQL Server 安装重新生成 master 数据库。

注意：
如果可能，请使用 Windows 身份验证。

有关详细信息和示例命令提示符语法，请参阅如何从命令提示符安装 SQL Server 2005。

请参阅

任务

如何阅读 SQL Server 2005 安装日志文件

概念

如何查看 SQL Server 2005 安装日志文件


如何为 SQL Server 2005 重新生成注册表

如何为 SQL Server 2005 重新生成注册表 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

若要重新生成注册表，请从命令提示符运行 Setup 命令（属性设置为：REINSTALL=ALL，REINSTALDATABASE=1，REINSTALLMODE=omus）。这将重新生成、验证和修复 Microsoft SQL Server 实例。此过程通常用于为已损坏的 SQL Server 安装重新生成注册表。

注意：
若要重新生成注册表，必须使用与初始安装过程中所指定的相同的包文件和选项。如果不知道此信息，请卸载然后重新安装 SQL Server，而不要重新生成注册表。

重要事项：
如果可能，请使用 Windows 身份验证。请不要将 sa 密码保留为空；应始终使用强密码。

有关详细信息和示例命令提示符语法，请参阅如何从命令提示符安装 SQL Server 2005。

请参阅

任务

如何阅读 SQL Server 2005 安装日志文件

概念

如何查看 SQL Server 2005 安装日志文件


如何访问 SQL Server 2005 联机丛书

如何访问 SQL Server 2005 联机丛书 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

使用下列步骤在 Microsoft Windows 桌面的“开始”菜单中启动 Microsoft SQL Server 2005 联机丛书，或找到 SQL Server 2005 联机丛书的默认安装目录。

从“开始”菜单访问 SQL Server 2005 联机丛书

  1. 指向“所有程序”，指向 Microsoft SQL Server 2005，再单击“SQL Server 联机丛书”。

  2. SQL Server 2005 联机丛书将启动。

从 Windows 资源管理器访问 SQL Server 2005 联机丛书

  1. 在 Windows 桌面上右键单击“开始”，再单击资源管理器。

  2. 定位到 %ProgramFiles%\Microsoft SQL Server\90\Tools\Books\1033。这是英文 SQL Server 联机丛书的默认安装目录。
注意：
如果安装了英文以外语言的 SQL Server 联机丛书，则 SQL Server 联机丛书安装目录将为 ...\Tools\Books\ 目录中语言特定的文件夹。

请参阅

任务

如何在 SQL Server 2005 的现有实例中更改组件（安装程序）


如何访问 SQL Server 2000 联机丛书

如何访问 SQL Server 2000 联机丛书
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

使用以下信息查找 Microsoft SQL Server 2000 联机丛书。

从“开始”菜单查找 SQL Server 2000 联机丛书

  1. 指向“所有程序”，指向 Microsoft SQL Server，再单击“联机丛书”。

  2. SQL Server 2000 联机丛书将启动。

从 Windows 资源管理器查找 SQL Server 2000 联机丛书

  1. 在 Microsoft Windows 桌面上，右键单击“开始”，再单击“资源管理器”。

  2. 导航到 %ProgramFiles%\Microsoft SQL Server\80\Tools\Books\。这是英文版 SQL Server 联机丛书的默认安装目录。


如何访问 SQL Server 7.0 联机丛书

如何访问 SQL Server 7.0 联机丛书
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > 数据库引擎安装帮助主题 >

请使用下列过程从“开始”菜单启动 Microsoft SQL Server 7.0 联机丛书，并查找 SQL Server 7.0 联机丛书默认安装目录。

从“开始”菜单访问 SQL Server 7.0 联机丛书

  1. 单击“开始”，指向“所有程序”，指向 Microsoft SQL Server，然后单击“联机丛书”。

  2. SQL Server 7.0 联机丛书将启动。

从 Windows 资源管理器访问 SQL Server 7.0 联机丛书

  1. 在 Microsoft Windows 桌面上，右键单击“开始”，再单击“资源管理器”。

  2. 定位到 %ProgramFiles%\MSSQL7\Books。这是英文版 SQL Server 联机丛书的默认安装目录。


Analysis Services 安装帮助主题

Analysis Services 安装帮助主题 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 >

本部分包含安装 Microsoft SQL Server 2005 Analysis Services (SSAS) 所用的以下通用步骤。

有关从 Analysis Services 的早期版本进行升级以及迁移 Analysis Services 包的通用步骤，请参阅升级或迁移 Analysis Services 的帮助主题。

重要事项：
本部分中的 Analysis Services 安装帮助主题只将重点放在特定于 Analysis Services 的安装选项上。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

本节的相关信息

  • 如何使用安装程序安装 Analysis Services

  • 如何从命令提示符安装 Analysis Services

  • 如何在故障转移群集上安装 Analysis Services

  • 如何安装 Analysis Services 的多个实例

  • 如何将 Analysis Services 与早期版本并行安装

  • 如何重命名 Analysis Services 实例

  • 如何添加或删除 Analysis Services 实例的功能

  • 如何卸载 Analysis Services 实例

请参阅

概念

安装 SQL Server Analysis Services


如何使用安装程序安装 Analysis Services

如何使用安装程序安装 Analysis Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Analysis Services 安装帮助主题 >

安装 Microsoft SQL Server 2005 Analysis Services (SSAS) 既可使用 SQL Server 安装向导，也可使用命令提示符。此安装向导提供了图形用户界面，该界面可以引导您确定每个安装选项，这是推荐大多数用户使用的方法。安装向导为 SQL Server 2005 的初始安装提供指导，包括功能选择、实例命名规则、服务帐户配置、强密码指南和排序规则选择。

重要事项：
此主题和此部分中 Analysis Services 安装的其他帮助主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

使用安装程序安装 Analysis Services

  1. 启动 SQL Server 安装向导。

  2. 可以根据需要查看如何安装 SQL Server 2005（安装程序），以查看安装向导的逐页说明（特别是当正在安装除 Analysis Services 以外的其他 SQL Server 组件时）。

  3. 在安装向导的“要安装的组件”页上，选择 Analysis Services。有关要在安装的软件中包括的其他 SQL Server 功能（例如，文档、示例和开发工具）的详细信息，请查看使用安装程序安装 SQL Server Analysis Services。

  4. 在“实例名”页上，为安装的软件选择默认实例或命名实例。如果默认的实例已存在，或者如果不希望升级的 SQL Server 2000 Analysis Services 实例已存在于该计算机上，则只能选择命名实例。

  5. 在“服务帐户”页上，为 Analysis Services 服务帐户以及其他 SQL Server 服务帐户指定用户名、密码和域名。您可以将一个帐户用于所有服务。

  6. 在“排序规则设置”页上，指定默认的排序规则。可对 Analysis Services 使用一个排序规则，对 SQL Server 2005 数据库引擎 使用另一个排序规则，或者也可以将一个排序规则指定给所有服务。

  7. 完成安装向导。其余向导页不包含与 Analysis Services 有关的选项设置。

请参阅

其他资源

Analysis Services 安装帮助主题


如何从命令提示符安装 Analysis Services

如何从命令提示符安装 Analysis Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Analysis Services 安装帮助主题 >

安装 Microsoft SQL Server 2005 Analysis Services (SSAS) 既可使用 SQL Server 安装向导，也可使用命令提示符。此安装向导提供了图形用户界面，该界面可以引导您确定每个安装选项，这是推荐大多数用户使用的方法。从命令提示符进行安装适用于高级方案，例如无提示安装和远程安装。可以在命令提示符下直接运行安装，或者在命令提示符语法中引用 .ini 文件来指定安装选项。

重要事项：
此主题和此部分中 Analysis Services 安装的其他帮助主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

从命令提示符安装 Analysis Services

  1. 决定是在命令提示符下还是在 .ini 文件中指定安装选项。有关如何使用 .ini 文件来指定这些选项的详细信息，请参阅如何从命令提示符安装 SQL Server 2005。

  2. 按照如何从命令提示符安装 SQL Server 2005 中的说明，在命令提示符下启动 Setup.exe，然后在命令提示符下或 .ini 文件中提供所需的信息。有关特定于 Analysis Services 的安装选项的详细信息，请查看从命令提示符安装 SQL Server Analysis Services。

请参阅

其他资源

Analysis Services 安装帮助主题


如何在故障转移群集上安装 Analysis Services

如何在故障转移群集上安装 Analysis Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Analysis Services 安装帮助主题 >

在支持 Microsoft 群集服务 (MSCS) 的故障转移群集上安装 Microsoft SQL Server 2005 Analysis Services (SSAS) 可以提供较高的可靠性。

重要事项：
本主题和此部分中 Analysis Services 安装的其他帮助主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

注意：
群集环境中不支持 SQL Server 2005 Analysis Services (SSAS) 实例重命名工具。

在故障转移群集上安装 Analysis Services

  1. 开始安装之前，请查看使用安装程序安装 SQL Server Analysis Services 以了解特定于 Analysis Services 的、在安装过程中必须选择的选项。

  2. 查看信息并达到特定于群集安装的必备条件，详细信息请参阅如何创建新的 SQL Server 2005 故障转移群集（安装）。请准备为 Analysis Services 的群集安装提供虚拟服务器实例名和 IP 地址，该虚拟服务器实例名和 IP 地址应是唯一的，与该群集自身的以及该群集中各节点的虚拟服务器实例名和 IP 地址都不同。

  3. 对于在故障转移群集上安装 SQL Server 2005 Analysis Services 的步骤以及特定于群集安装的 SQL Server 安装向导的各页，Analysis Services 与 SQL Server 2005 数据库引擎 是相同的。请按照如何创建新的 SQL Server 2005 故障转移群集（安装）中说明的步骤来运行安装向导。按使用安装程序安装 SQL Server Analysis Services 中的说明，在“要安装的组件”页、“实例名”页、“服务帐户”页以及“排序规则设置”页上，为 Analysis Services 选择适当的选项。

请参阅

任务

如何创建新的 SQL Server 2005 故障转移群集（安装）

概念

安装故障转移群集前的准备工作
使用安装程序安装 SQL Server Analysis Services
从命令提示符安装 SQL Server Analysis Services


如何安装 Analysis Services 的多个实例

如何安装 Analysis Services 的多个实例 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Analysis Services 安装帮助主题 >

可以在同一台计算机上运行 Microsoft SQL Server 2005 Analysis Services (SSAS) 的多个实例。若要再安装一个实例，请再次运行安装程序并为新实例指定一个唯一的名称。

重要事项：
此主题和此部分中 Analysis Services 安装的其他帮助主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

安装 Analysis Services 的另一个实例

  1. 使用 SQL Server 安装向导或从命令提示符运行安装程序。有关如何使用 SQL Server 安装向导运行安装程序的详细信息，请参阅如何使用安装程序安装 Analysis Services。有关如何从命令提示符运行安装程序的详细信息，请参阅如何从命令提示符安装 Analysis Services。

  2. 使用 SQL Server 安装向导时，请在“实例名”页上指定唯一的实例名称。从命令提示符运行安装程序时，请使用 instancename 选项指定唯一的实例名。

请参阅

其他资源

Analysis Services 安装帮助主题


如何将 Analysis Services 与早期版本并行安装

如何将 Analysis Services 与早期版本并行安装 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Analysis Services 安装帮助主题 >

可以将 Microsoft SQL Server 2005 Analysis Services (SSAS) 与 SQL Server 2000 Analysis Services 的实例并行安装。但是，SQL Server 2000 Analysis Services 的实例必须始终是默认实例，而 SQL Server 2005 Analysis Services 的实例必须始终为命名实例，因为 SQL Server 2000 Analysis Services 不支持命名实例。

如果您稍后删除 SQL Server 2000 Analysis Services 的默认实例，则可使用 Analysis Services 实例重命名工具使 SQL Server 2005 Analysis Services 的实例成为默认实例。有关详细信息，请参阅如何重命名 Analysis Services 实例。

重要事项：
此主题和此部分中 Analysis Services 安装的其他帮助主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

将 Analysis Services 与早期版本并行安装

  1. 使用 SQL Server 安装向导或从命令提示符运行安装程序。有关如何使用 SQL Server 安装向导运行安装程序的详细信息，请参阅如何使用安装程序安装 Analysis Services。有关如何从命令提示符运行安装程序的详细信息，请参阅如何从命令提示符安装 Analysis Services。

  2. 使用 SQL Server 安装向导时，请在“实例名”页上指定唯一的实例名称。从命令提示符运行安装程序时，请使用 instancename 选项指定唯一的实例名。

请参阅

其他资源

Analysis Services 安装帮助主题


如何重命名 Analysis Services 实例

如何重命名 Analysis Services 实例 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Analysis Services 安装帮助主题 >

通过使用“重命名实例”对话框，可以重命名现有的 Microsoft SQL Server 2005 Analysis Services (SSAS) 实例。

重要事项：
本主题和此部分中 Analysis Services 安装的其他帮助主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

注意：
在 64 位计算机中，必须使用 64 位版本的实例重命名工具。

注意：
群集环境中不支持 SQL Server 2005 Analysis Services (SSAS) 实例重命名工具。

重命名 Analysis Services 的实例

  1. 运行 C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE 下的 asinstancerename.exe，启动“实例重命名”工具。

  2. 在“重命名实例”对话框中，从“要重命名的实例”列表中选择要重命名的实例。

  3. 在“新实例名”框中，输入实例的新名称。

  4. 验证用户名和密码是否正确，然后单击“重命名”。

请参阅

其他资源

“重命名实例”对话框 (SSAS)
Analysis Services 安装帮助主题
管理和维护 Analysis Services
Analysis Services 安装帮助主题


如何添加或删除 Analysis Services 实例的功能

如何添加或删除 Analysis Services 实例的功能 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Analysis Services 安装帮助主题 >

在 Microsoft SQL Server 2005 中，只有通过 Microsoft Windows 中“控制面板”的“添加或删除程序”才能支持功能维护。

重要事项：
此主题和此部分中 Analysis Services 安装的其他帮助主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

在 SQL Server 2005 Analysis Services 的现有实例中更改组件

  1. 在 Microsoft Windows 桌面上单击“开始”，单击“控制面板”，再双击“添加或删除程序”。

  2. 在“当前安装的程序”中，选择 Microsoft SQL Server 2005，再单击“更改”。这将启动 Microsoft SQL Server 2005 维护向导。

  3. 在“选择组件”页上的 SQL Server 2005 实例下，选择包含要修改的 Analysis Services 实例的实例。

  4. 在“功能维护”页上，选择 Analysis Services。然后 Microsoft SQL Server 2005 维护向导将启动 Microsoft SQL Server 2005 安装向导。

  5. 在“更改或删除实例”页上，单击“更改已安装的组件”。

  6. 单击“下一步”，然后按照后续向导页中的说明执行操作。

请参阅

其他资源

Analysis Services 安装帮助主题


如何卸载 Analysis Services 实例

如何卸载 Analysis Services 实例 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Analysis Services 安装帮助主题 >

使用以下步骤可以卸载 Microsoft SQL Server 2005 Analysis Services (SSAS) 的实例。

重要事项：
此主题和此部分中 Analysis Services 安装的其他帮助主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

删除 SQL Server 2005 Analysis Services 的实例

  1. 在 Microsoft Windows 桌面上单击“开始”，单击“控制面板”，再双击“添加或删除程序”。

  2. 在“当前安装的程序”中，选择 Microsoft SQL Server 2005，再单击“更改”。这将启动 Microsoft SQL Server 2005 维护向导。
注意：
如果单击“删除”，而不是单击“更改”，则在卸载 Analysis Services 的实例的同时，也将卸载同名实例下安装的 SQL Server 数据库引擎 和 Reporting Services。

  1. 在“选择组件”页上的 SQL Server 2005 实例下，选择包含要删除的 Analysis Services 实例的实例。

  2. 在“功能维护”页上，选择 Analysis Services。然后 Microsoft SQL Server 2005 维护向导将启动 Microsoft SQL Server 2005 安装向导。

  3. 在“更改或删除实例”页上，单击“删除 Microsoft SQL Server”。

  4. 单击“下一步”，然后按照后续向导页中的说明执行操作。

请参阅

其他资源

Analysis Services 安装帮助主题


Reporting Services 安装帮助主题

Reporting Services 安装帮助主题 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 >

此部分包括安装 Reporting Services 的过程。

本节的相关信息

  • 如何在单台计算机上安装 Reporting Services

  • 如何安装本地报表服务器和远程报表服务器数据库

  • 如何并行安装 Reporting Services 及其早期版本

  • 如何卸载 Reporting Services 的实例

  • 如何验证 Reporting Services 安装

  • 如何排除 Reporting Services 安装故障

  • 如何排除 SQL Server 2000 和 SQL Server 2005 Reporting Services 的并行安装故障

  • 如何将 IIS 配置为在 WOW64 模式下运行 32 位 Reporting Services

请参阅

概念

升级 Reporting Services
安装 SQL Server Reporting Services

其他资源

安装 SQL Server 组件帮助主题
SQL Server 2005 远程安装信息


如何在单台计算机上安装 Reporting Services

如何在单台计算机上安装 Reporting Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Reporting Services 安装帮助主题 >

使用下列过程在单台计算机上安装整套客户端和服务器组件。除客户端和服务器组件外，这些说明还包括安装以下组件的步骤：

  • 数据库引擎，用于承载报表服务器数据库，如果以默认配置模式安装报表服务器，此引擎为必需的。

  • Reporting Services 示例，用于测试 Reporting Services 的功能。请注意 SQL Server 2005 安装程序只是将示例安装程序复制到硬盘驱动器。安装完成后，必须运行示例安装程序来安装文件，然后将示例上载到报表服务器。

这些说明假定您是首次安装 Reporting Services。如果是升级或重新安装，可能无法使用默认配置安装选项。在这种情况下，应该在安装完成后运行 Reporting Services 配置工具和外围应用配置器工具，以完成报表服务器的配置。有关详细信息，请参阅升级 Reporting Services。

在单台计算机上安装客户端和服务器组件

  1. 运行安装程序。

  2. 在“要安装的组件”页上，选择 SQL Server Database Services、Reporting Services 和“工作站组件、联机丛书和开发工具”。

  3. 单击“高级”。

  4. 在“客户端组件”中，打开“文档、示例和示例数据库”。

  5. 单击“示例数据库”。如果要运行所有示例报表，两个 AdventureWorks 数据库都应选择。选择“整个功能将安装到本地硬盘上”。

  6. 单击“示例代码和应用程序”。选择“整个功能将安装到本地硬盘上”。单击“下一步”。

  7. 在“实例名”页中，选择“默认实例”。单击“下一步”。

  8. 在“服务帐户”页中指定域用户帐户。在“在安装程序结束时启动服务”中，选择“SQL Server 代理”。单击“下一步”。

  9. 在“身份验证模式”页中，指定“Windows 身份验证”。单击“下一步”。

  10. 在“排序规则设置”页中，接受默认值。单击“下一步”。

  11. 在“报表服务器安装选项”页中，选择“安装默认配置”。单击“下一步”。

  12. 在“错误和使用情况报告设置”页中，单击“下一步”。

  13. 单击“安装”开始安装。

配置报表服务器并安装示例

  1. 单击“开始”，依次指向“所有程序”、Microsoft SQL Server 2005、“配置工具”，再单击“SQL Server 外围应用配置器”。

  2. 在服务和连接的外围应用配置器中，验证报表服务器 Windows 服务是否正在运行。在功能的外围应用配置器中，验证“预定的事件和报表传递”已启用。验证“HTTP 和 Web 服务请求”已启用。验证“Windows 集成安全性”是否已启用。

  3. 通过启动报表管理器验证安装成功。在 URL 地址中，键入 https://localhost/reports 或 http://localhost/reports。应查看报表管理器主页。

  4. 若要安装示例，请单击“开始”，依次指向“所有程序”、Microsoft SQL Server 2005、“文档和教程”和“示例”，然后单击“Microsoft SQL Server 2005 示例”。使用安装向导来安装示例。

  5. 若要发布报表，请使用 Business Intelligence Development Studio。单击“开始”，依次指向“所有程序”、Microsoft SQL Server 2005，然后单击 Business Intelligence Development Studio。

  6. 从“文件”菜单中，单击“打开项目/解决方案”。

  7. 从 C:\Program Files\Microsoft SQL Server\90\Samples\Reporting Services\Report Samples\AdventureWorks Sample Reports 中，选择 AdventureWorks Sample Reports.sln。单击“打开”。

  8. 从“生成”菜单中，选择“部署解决方案”。如果解决方案未部署，请打开每个报表，然后重试部署。输出窗口中指示成功部署的状态。在输出窗口中应该看到“部署到 http://localhost/reportserver”、每个报表的状态以及上载到服务器的数据源。

  9. 打开报表管理器。如果已经打开，请单击浏览器的“刷新”按钮以显示已发布的项目。

  10. 打开 AdventureWorks 示例文件夹。单击一个报表进行查看。
注意：
Sales Reason Comparison 示例报表使用 Analysis Services 数据库。在运行报表前，必须满足该报表的其他要求。有关详细信息，请参阅 AdventureWorks 报表示例。

请参阅

任务

如何安装 SQL Server 2005（安装程序）
如何验证 Reporting Services 安装

概念

安装 SQL Server Reporting Services

其他资源

Reporting Services 教程
SQL Server Reporting Services 示例
Reporting Services 安装帮助主题
如何上载报表实例（报表管理器）
Reporting Services 配置工具


如何安装本地报表服务器和远程报表服务器数据库

如何安装本地报表服务器和远程报表服务器数据库 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Reporting Services 安装帮助主题 >

在远程 SQL Server 数据库引擎实例上承载报表服务器数据库，需要在安装完成后执行额外的配置步骤。在本地计算机和远程计算机上都必须具有管理员权限。本地计算机和远程计算机必须在同一域或在可信域中。

注意：
以下过程适用于 Windows Server 2003 操作系统。如果您使用的不是此操作系统，步骤可能不同。

安装本地报表服务器和远程报表服务器数据库

  1. 运行安装程序。

  2. 在“功能选择”页中选择 Reporting Services。单击“下一步”。

  3. 在“实例名”页中，选择“默认实例”。单击“下一步”。

  4. 在“服务帐户”页中指定域用户帐户。若要支持计划操作，请确保 SQL Server 代理服务可自动启动。在“在安装程序结束时启动服务”中，选择“SQL Server 代理”。单击“下一步”。

  5. 在“身份验证模式”页中，指定“Windows 身份验证”。单击“下一步”。

  6. 在“报表服务器安装选项”页中选择“安装但不配置服务器”。单击“下一步”。

  7. 在“错误和使用情况报告设置”页中，单击“下一步”。

  8. 单击“安装”开始安装。

配置报表服务器和创建远程数据库

  1. 单击“开始”，依次指向“所有程序”、Microsoft SQL Server 2005、“配置工具”，再单击“SQL Server 外围应用配置器”。

  2. 在服务和连接的外围应用配置器中，验证报表服务器 Windows 服务是否正在运行。

  3. 在功能的外围应用配置器中，验证“预定的事件和报表传递”已启用。验证“HTTP 和 Web 服务请求”已启用。验证“Windows 集成安全性”是否已启用。

  4. 打开“Reporting Services 配置”。单击“开始”，指向“所有程序”，指向 Microsoft SQL Server 2005，再指向“配置工具”，单击“Reporting Services 配置”。

  5. 选择刚才安装的本地报表服务器实例。单击“连接”。

  6. 配置 Web 服务帐户和虚拟目录。如果使用的是 Windows XP 或 Windows 2000 服务器，则必须使用默认 ASP.NET 帐户。使用 Windows Server 2003 时可以指定自定义帐户。

  7. 配置数据库。

    1. 打开“数据库安装”页。

    2. 在“服务器名称”中选择远程 SQL Server 数据库引擎实例，然后单击“连接”。必须在该服务器上具有创建数据库和配置角色的权限。Reporting Services 配置工具将用凭据创建数据库。

    3. 单击“新建”创建新的报表服务器数据库。此时将打开“SQL Server 连接”对话框。键入新数据库的名称以及用于创建该数据库的凭据，然后单击“确定”。

      如果已经存在要使用的报表服务器数据库，则可选择该数据库，而无需创建新数据库。如果要将 SQL Server 2000 报表服务器数据库升级到新架构，可单击“升级”。如果要将数据库用于 SQL Server 2005 版本的 Reporting Services，则需要对该数据库进行升级（请注意，一旦对数据库进行了升级，将无法还原此操作；请确保在继续操作前，备份该数据库）。

    4. 在“凭据类型”中选择用于将报表服务器连接到报表服务器数据库的帐户类型。可以使用服务帐户凭据、特定的 Windows 域帐户或 SQL Server 登录名。

    5. 如果选择 Windows 凭据或 SQL Server 凭据，请键入该报表服务器用于连接到报表服务器数据库的用户名和密码。有关详细信息，请参阅配置报表服务器数据库连接。

    6. 单击“应用”可以保存更改。

  8. 根据需要配置其他设置，然后验证安装。有关详细信息，请参阅如何验证 Reporting Services 安装。

请参阅

任务

如何安装 SQL Server 2005（安装程序）

参考

设置 Windows 服务帐户

概念

安装 SQL Server Reporting Services

其他资源

Reporting Services 安装帮助主题
Reporting Services 配置工具


如何并行安装 Reporting Services 及其早期版本

如何并行安装 Reporting Services 及其早期版本 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Reporting Services 安装帮助主题 >

可以安装多个版本的 Reporting Services，SQL Server 2000 Reporting Services 实例可以与 SQL Server 2005 Reporting Services 实例并行运行。

注意：
如果在运行 Internet 信息服务 (IIS) 5.0 的服务器上或在以 IIS 5.0 兼容模式运行的服务器上安装 .NET Framework 2.0 或注册 ASP.NET 2.0，SQL Server 2000 Reporting Services 的安装可能停止运行。有关如何恢复服务器操作的详细信息，请参阅如何排除 SQL Server 2000 和 SQL Server 2005 Reporting Services 的并行安装故障。

若要并行运行两个版本，必须将 SQL Server 2005 版本作为命名实例安装，并继续将 SQL Server 2000 版本作为默认实例运行。SQL Server 2000 版本不支持命名实例，因此不能配置为作为命名实例运行。

如果要在同一计算机上运行多个版本的 Reporting Services，请牢记以下要点：

  • 可以使用 SQL Server 2000 数据库引擎承载用于 SQL Server 2000 Reporting Services 安装的报表服务器数据库。

  • 每个版本的报表命名空间和 SOAP 端点各不相同。有关详细信息，请参阅 SQL Server 联机丛书中的Reporting Services 可编程性的增强功能。

  • 在 SQL Server 2005 报表设计器中创建的报表定义 (.rdl) 文件只能发布到 SQL Server 2005 报表服务器。

  • 在 SQL Server 2000 报表设计器中创建的报表定义 (.rdl) 文件既可以发布到 SQL Server 2000 报表服务器，也可以发布到 SQL Server 2005 报表服务器。如果将 SQL Server 2000 .rdl 文件发布到 SQL Server 2005 报表服务器，则该文件将被转换为 SQL Server 2005 格式，并存储在报表服务器上。如果在 SQL Server 2005 报表设计器中打开 SQL Server 2000 Reporting Services 报表，则系统将提示您升级该报表。有关详细信息，请参阅升级报表。

  • 不能使用 Reporting Services 配置工具配置 SQL Server 2000 报表服务器。但是，可以使用 Management Studio 连接到 SQL Server 2000 报表服务器。请注意，安装不同版本的 Reporting Services 时，各个报表服务器安装都有对应的专用报表管理器实例。您可能会发现不同版本的报表服务器之间存在细微差别。

可以并行运行报表设计器的新版本或较早版本。如果这样做，请注意，必须对每个实例使用（或安装）不同版本的 Visual Studio：

  • SQL Server 2000 报表设计器需要 Visual Studio 2003，无法在 Visual Studio 2005 中运行。

  • SQL Server 2005 使用 Visual Studio 2005。如果尚未安装 Visual Studio 2005，则安装程序将安装运行报表设计器所需的该版本的 Visual Studio 外壳程序。不能使用 SQL Server 2005 报表设计器将报表发布到 SQL Server 2000 报表服务器。

并行安装 Reporting Services 及其早期版本

  1. 运行 SQL Server 2005 安装程序。运行安装程序时，务必执行以下操作：

    1. 如果运行的是命令行安装，请在“实例名”页或通过 instancename 选项，指定一个唯一实例名。

    2. 为报表服务器指定“仅文件”安装。若要执行此操作，请在 SQL Server 安装向导的“报表服务器安装选项”页中选择“安装但不配置”选项，或在命令行安装中选择 RSCONFIGURATION=filesonly。

  2. 安装完成后，运行 Reporting Services 配置工具以部署新的 SQL Server 2005 实例。

  3. 连接到刚安装的报表服务器实例。为完成此操作，请指定服务器名称和 SQL Server 命名实例，然后单击“连接”。

  4. 在“报表服务器虚拟目录”和“报表管理器虚拟目录”页上，为报表服务器和报表管理器指定一个唯一虚拟目录。实例名称不能与 SQL Server 2000 实例所使用的名称相同。

    指定上述虚拟目录时，应该会自动配置 Windows 服务帐户和 Web 服务帐户。在有些情况下，自动配置 Web 服务帐户可能会失败。如果使用的是 Microsoft Internet 信息服务 (IIS) 6.0，则可通过指定其他应用程序池来解决此错误。

  5. 在“数据库安装”页上，连接到要用于承载报表服务器数据库的 SQL Server 实例。默认情况下，指定为本地数据库引擎实例。如果要使用其他服务器，则必须键入该服务器的名称。单击“连接”连接到服务器。

  6. 单击“新建”创建报表服务器数据库。在“SQL Server 连接”对话框中，键入数据库名称。如果连接到的是远程 SQL Server，请指定具有创建数据库权限的凭据。单击“确定”。

  7. 或者，也可以指定报表服务器用于连接到数据库的凭据。默认情况下，将使用服务帐户凭据。单击“应用”保存数据库配置更改。

  8. 在“加密密钥”页上，创建一份密钥备份副本。

  9. 若要验证新建实例是否可正常运行，可以发布一些示例报表，然后使用报表管理器查看这些报表。请记住，必须指定为新建实例定义的报表管理器虚拟目录。有关如何发布示例报表的分步指导，请参阅 SQL Server 联机丛书如何发布报表示例（报表设计器）主题中的“配置报表服务器并安装示例”部分。

请参阅

任务

如何启动 Reporting Services 配置

参考

实例名称

概念

使用安装程序安装 Reporting Services
配置报表服务器虚拟目录
安装 SQL Server Reporting Services

其他资源

Reporting Services 安装帮助主题
Reporting Services 配置工具


如何卸载 Reporting Services 的实例

如何卸载 Reporting Services 的实例 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Reporting Services 安装帮助主题 >

可以使用安装程序卸载 SQL Server Reporting Services 或删除特定的组件。安装向导和命令行安装程序都可以用于删除或修改现有安装。如果选择删除整个安装，在安装程序运行完成后会有某些文件和帐户保留下来。必须手动删除等待处理的数据库、日志文件、报表定义文件、模型文件、项目文件、解决方案和作业。本主题中的步骤提供关于如何删除卸载软件时未删除的项的说明。若要删除当前队列中的计划报表进程，请参阅查看和修改作业。

注意：
如果在同一台计算机上安装了 32 位版本和 64 位版本的 Reporting Services，请确保使用 64 位版本的安装程序卸载 64 位版本的 Reporting Services。不能使用 32 位版本的安装程序卸载 64 位版本的 Reporting Services。

删除报表服务器数据库

  1. 请用 Management Studio 或企业管理器（如果正在使用 SQL Server 2000 承载数据库）连接到承载数据库的 SQL Server 数据库引擎实例。

  2. 删除数据库 (.mdb) 文件和日志 (.ldb) 文件。

  3. 请从 Master 数据库和 MSDB 数据库中手动删除数据库角色 RSExecRole。

删除数据文件

  1. 在硬盘上搜索以下文件类型：

    报表定义 (.rdl) 文件、语义模型 (.smdl) 文件、共享数据源 (.rds) 文件、报表项目 (.rptproj) 文件、解决方案 (.sln) 文件。

  2. 删除这些文件。

删除示例

  • 使用“添加或删除程序”卸载 Reporting Services 示例报表和应用程序。安装程序仅卸载它添加的文件。如果创建其他用户选项文件，或向此文件夹添加新文件，则这些文件会在卸载操作完成后保留下来。示例文件位于 Tools\Samples\<lang>\ReportingServices。

删除日志文件

  1. 请导航到日志文件文件夹。日志文件位于 Reporting Services\Log Files。

  2. 删除这些文件。

请参阅

其他资源

Reporting Services 安装帮助主题


如何验证 Reporting Services 安装

如何验证 Reporting Services 安装 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Reporting Services 安装帮助主题 >

如果使用默认配置安装报表服务器，安装程序将安装并部署该服务器。可以执行几个简单的测试来验证安装程序是否部署了报表服务器。只有本地管理员才能执行这些步骤。若要让其他用户执行测试，必须为这些用户配置报表服务器访问权限。有关详细信息，请参阅 SQL Server 联机丛书中的服务器部署检查表。

验证报表服务器已安装并正常运行

  1. 运行 Reporting Services 配置工具，连接到刚刚安装的报表服务器实例，并检查每个设置的状态指示器以验证该设置是否已配置。

  2. 打开“服务”窗口，验证报表服务器 Windows 服务正在运行。若要查看报表服务器 Windows 服务的状态，请单击“开始”，指向“控制面板”，双击“管理工具”，再双击“服务”。出现服务列表后，滚动到“报表服务器 (MSSQLSERVER)”。该服务的状态应为“已启动”。

  3. 打开浏览器，在地址栏中键入报表服务器的 URL。该地址由安装过程中为报表服务器指定的服务器名称和虚拟目录名组成。默认情况下，报表服务器虚拟目录的名称为 ReportServer。可以使用以下 URL 验证报表服务器的安装情况：http://<计算机名称>/ReportServer<实例名>。

  4. 运行报表以测试报表服务器的操作。对于此步骤，如果没有任何可用的报表，可以安装和发布示例报表。有关详细信息，请参阅 SQL Server 联机丛书中的 AdventureWorks 报表示例。

验证报表管理器已安装并正常运行

  1. 打开浏览器，在地址栏中键入报表服务器的 URL。该地址由您在安装过程中为报表管理器指定的服务器名称和虚拟目录名组成。默认情况下，报表管理器虚拟目录的名称为 Reports。可以使用以下 URL 验证报表管理器的安装情况：http://<计算机名称>/Reports<实例名>。

  2. 使用报表管理器创建新文件夹或上载文件，以测试定义是否传回报表服务器数据库。如果上述操作成功，则表明连接正常。

验证报表设计器已安装并正常运行

  1. 打开 Business Intelligence Development Studio，创建基于报表服务器项目类型的新项目。有关使用报表服务器项目向导的详细信息，请参阅 SQL Server 联机丛书中的如何创建报表服务器项目（报表设计器）。

  2. 如果安装了报表示例，请打开示例报表项目文件并将报表发布到报表服务器。有关详细信息，请参阅 SQL Server 联机丛书中的 调试和发布报表。

  3. 在脚本环境下运行一个脚本文件 (.rss)，以测试指定报表服务器上的 Web Service 操作。有关运行示例脚本的详细信息，请参阅 SQL Server 联机丛书中的脚本示例 (Reporting Services)。

请参阅

其他资源

Reporting Services 安装帮助主题


如何排除 Reporting Services 安装故障

如何排除 Reporting Services 安装故障 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Reporting Services 安装帮助主题 >

SQL Server 2005 Reporting Services 的安装过程支持两种模式的安装：按默认配置安装 Reporting Services 实例，或者安装将程序文件复制到磁盘的“仅文件”安装。如果遇到安装问题，请考虑使用“仅文件”安装。之后，当为操作而配置报表服务器时，可以调整计算机设置或运行时环境以支持报表服务器操作。如果在“仅文件”安装中遇到安装问题，请使用此主题中的信息加以解决。

验证必备组件

  1. 必须已经安装 Internet 信息服务 (IIS) 5.0 或更高版本。

  2. 在 Windows Server 2003 上，不能将 IIS 配置为 IIS 5.0 隔离模式。

  3. 不能将 IWAM_computername 帐户配置为漫游配置文件。

  4. 必须已经安装 MDAC 2.6 或更高版本。

  5. 必须已经启动分布式事务处理协调器 (DTC)。

ASP.NET 必须已经向 Internet 信息服务注册。

  1. 从 %windir%\Microsoft.Net\Framework\v2.0.50110 文件夹运行 aspnet_regiis -i。

  2. 运行 iisrest 以重新启动 IIS。

检查安装日志文件

  • 查看由安装程序创建的日志文件。有关详细信息，请参阅如何查看 SQL Server 2005 安装日志文件。

请参阅

概念

安装 SQL Server Reporting Services

其他资源

如何排除 SQL Server 2000 和 SQL Server 2005 Reporting Services 的并行安装故障
Reporting Services 故障排除


如何排除 SQL Server 2000 和 SQL Server 2005 Reporting Services 的并行安装故障

如何排除 SQL Server 2000 和 SQL Server 2005 Reporting Services 的并行安装故障 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Reporting Services 安装帮助主题 >

如果执行 SQL Server 2005 Reporting Services 的并行安装（或在主机上安装 Microsoft .NET Framework 2.0 版或注册 ASP.NET 2.0），在 Internet 信息服务 (IIS) 5.0 中或在 IIS 5.0 的隔离模式下运行的 SQL Server 2000 Reporting Services 安装可能停止运行。根据所用的操作系统，会出现不同错误。

操作系统 | 错误消息
Microsoft Windows XP | 报表服务器无法对访问报表服务器数据库中的敏感数据或加密数据时所用的对称密钥进行解密。必须还原备份密钥，或删除所有加密内容，然后重新启动该服务。
其他 Windows 服务器 | 在指定的状态中使用该密钥时无效。

安装 SQL Server 2005 Reporting Services 后，请执行以下步骤，以更新 SQL Server 2000 版本的 Reporting Services 安装。

更新 SQL Server 2000 Reporting Services 安装

  1. 在 <drive>:\Documents and Settings\<machine_name>\ASPNET\Application Data\Microsoft\Crypto\RSA\ 下，搜索名为“1aedd7b5699f3d6a88e354100b596aae*”的文件。

  2. 删除该文件。

  3. 运行 RSActivate –r –c <rsreportserver.config 文件>，指定 SQL Server 2000 Reporting Services 安装的 RSReportServer.config 文件。

请参阅

任务

如何并行安装 Reporting Services 及其早期版本
如何排除 Reporting Services 安装故障

其他资源

Reporting Services 安装帮助主题


如何将 IIS 配置为在 WOW64 模式下运行 32 位 Reporting Services

如何将 IIS 配置为在 WOW64 模式下运行 32 位 Reporting Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Reporting Services 安装帮助主题 >

当以 Windows-on-Windows 64 (WOW64) x86 模拟模式运行 Reporting Services 时，Internet 信息服务 (IIS) 6.0 将返回“服务不可用”的错误消息。若要避免此错误，必须将 IIS 配置为允许运行 32 位 ASP.NET 应用程序。

重要事项：
必须先配置 IIS，再安装 Reporting Services。

将 IIS 配置为运行 32 位 Reporting Services

  1. 卸载 64 位版本的 Reporting Services。不支持并行部署 64 位和 32 位的版本。

  2. 运行 dotnetfx64.exe 以手动安装 .NET Framework。可在 SQL Server 2005 安装程序媒体上的“Redist”文件夹中找到此文件。

  3. 在 IIS 管理器中，单击 Web Server Extensions 文件夹。

  4. 在“详细信息”窗格中，右键单击 ASP.NET V2.0.50727，然后单击“允许”。

  5. 右键单击 Web Sites 文件夹，然后选择“属性”。

  6. 单击“ISAPI 筛选器”。

  7. 在“筛选器名称”中，选择 ASP.NET_2.0.50727，然后单击“编辑”。

  8. 将“C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\aspnet_filter.dll”替换为位于“Framework”文件夹中的 32 位版本：C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_filter.dll。

  9. 单击“确定”。保存您的更改，然后关闭 IIS 管理器。

  10. 打开命令提示符窗口，然后运行以下命令：

    复制代码
    cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 1

  11. 安装 32 位版本的 Reporting Services。

  12. 安装完成后，打开 IIS 管理器，单击 Web Server Extensions 文件夹。

  13. 在“详细信息”窗格中，右键单击“ASP.NET V2.0.50727（32 位）”，然后单击“允许”。

请参阅

其他资源

Reporting Services 安装帮助主题


Integration Services 安装帮助主题

Integration Services 安装帮助主题 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 >

本部分包含安装 Microsoft SQL Server 2005 Integration Services 所用的以下通用步骤。

有关从 Data Transformation Services (DTS) 升级以及迁移 DTS 包的通用步骤，请参阅升级或迁移 Data Transformation Services 帮助主题。

重要事项：
本部分中的 Integration Services 安装帮助主题只将重点放在特定于 Integration Services 的安装选项上，但提供了指向其他主题的链接，这些主题涉及 SQL Server 安装的其他信息。

本节的相关信息

  • 如何使用安装程序安装 Integration Services

  • 如何从命令提示符安装 Integration Services

  • 如何确保对 Data Transformation Services 包的支持

  • 如何在群集中配置 Integration Services

请参阅

概念

安装 SQL Server Integration Services


如何使用安装程序安装 Integration Services

如何使用安装程序安装 Integration Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Integration Services 安装帮助主题 >

安装 SQL Server 2005 Integration Services (SSIS) 既可使用 SQL Server 安装向导，也可使用命令提示符。此安装向导提供了图形用户界面，该界面可以引导您确定每个安装选项，这是大多数用户的首选方法。安装向导为 SQL Server 2005 的初始安装提供指导，包括功能选择、实例命名规则、服务帐户配置、强密码指南和排序规则选择。

重要事项：
此主题和此部分中 Integration Services 安装的其他帮助主题仅重点介绍 Integration Services 特有的安装选项，但同时提供了指向其他主题的链接来介绍 SQL Server 安装的其他方面。

使用安装程序安装 Integration Services

  1. 按照如何安装 SQL Server 2005（安装程序）中的说明，启动 SQL Server 安装向导。

  2. 可以根据需要查看如何安装 SQL Server 2005（安装程序），以查看安装向导的逐页说明（特别是当正在安装除 Integration Services 以外的其他 SQL Server 组件时）。

  3. 在安装向导的“要安装的组件”页上，选择 Integration Services。有关其他 SQL Server 功能（例如，文档、示例和开发工具）的信息，请查看使用安装程序安装 SQL Server Integration Services。

  4. 选择“Integration Services”还将安装 SQL Server 2000 Data Transformation Services (DTS) 的支持组件，包括枚举和运行 DTS 包的功能。有关详细信息，请参阅如何确保对 Data Transformation Services 包的支持。

  5. 完成安装向导。“要安装的组件”页后面的其余向导页都是关于除 Integration Services 之外的其他 SQL Server 2005 组件的。

请参阅

任务

使用安装程序安装 SQL Server Integration Services


如何从命令提示符安装 Integration Services

如何从命令提示符安装 Integration Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Integration Services 安装帮助主题 >

安装 SQL Server 2005 Integration Services (SSIS) 既可使用 SQL Server 安装向导，也可使用命令提示符。此安装向导提供了图形用户界面，该界面可以引导您确定每个安装选项，这是大多数用户的首选方法。命令提示符安装适用于高级方案，例如远程安装和无提示安装；可以在命令提示符下直接运行安装，也可以在命令提示符语法中引用 .ini 文件来指定安装选项。

重要事项：
此主题和此部分中 Integration Services 安装的其他帮助主题仅重点介绍 Integration Services 特有的安装选项，但同时提供了指向其他主题的链接来介绍 SQL Server 安装的其他方面。

从命令提示符安装 Integration Services

  1. 选择是在命令提示符下还是在 .ini 文件中指定安装选项。有关如何使用 .ini 文件来指定这些选项的详细信息，请参阅如何从命令提示符安装 SQL Server 2005。

  2. 按照如何从命令提示符安装 SQL Server 2005 中的说明，在命令提示符下启动 Setup.exe，然后在命令提示符下或 .ini 文件中提供所需的选项。有关特定于 Integration Services 的安装选项的信息，请查看从命令提示符安装 SQL Server Integration Services。

请参阅

概念

从命令提示符安装 SQL Server Integration Services


如何确保对 Data Transformation Services 包的支持

如何确保对 Data Transformation Services 包的支持 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Integration Services 安装帮助主题 >

SQL Server 2000 Data Transformation Services (DTS) 包可以继续与 SQL Server 2005 Integration Services (SSIS) 包一起运行。

可以在同一台计算机上运行 SQL Server 2000 Data Transformation Services (DTS) 包和 Integration Services 包。

如果选择安装“Integration Services”，则安装程序还将安装 SQL Server 2000 Data Transformation Services (DTS) 包的支持组件，包括 SQL Server Management Studio 中的 DTS 运行时和 DTS 包枚举。运行时支持已更新，允许 DTS 包访问 SQL Server 2005 数据源。如果未安装 Integration Services，但需要支持 DTS 包，则需要确保在“功能选择”页上选择了“早期组件”。

安装的向后兼容性文件还包括 SQL Server 2000 Analysis Services 处理任务及其依赖项，即决策支持对象 (DSO)。但是它们不包括 SQL Server 2000 数据挖掘预测查询任务。

注意：
SQL Server 2005 不安装用于编辑 DTS 包的 DTS 包设计器。有关详细信息，请参阅 SQL Server 2005 Integration Services 的向后兼容性。

选择安装 Integration Services 时，还将安装包迁移向导。还可以使用包迁移向导将 SQL Server 2000 DTS 包升级为 Integration Services 格式。迁移过程中，该向导复制 DTS 包，然后以 Integration Services 格式重新创建这些包。源包将保持不变且不会被修改。有关详细信息，请参阅迁移 Data Transformation Services 包。

注意：
SQL Server 2005 的 Standard Edition、Enterprise Edition 和 Developer Edition 提供了包迁移向导。

SQL Server 2005 Express Edition 不包括 Integration Services，也不支持 SQL Server 2000 DTS 包。

  • 若要在 SQL Server 2005 Express Edition 服务器上运行现有 DTS 包，必须在该服务器上保留 SQL Server 2000 客户端工具或 DTS 可再分发文件，或重新安装它们。SQL Server 2005 Express Edition 不包括 DTS 运行时。

  • 若要在 SQL Server 2005 Express Edition 服务器上编辑现有 DTS 包，必须使用 SQL Server 2000，或从运行 SQL Server 2005 Workgroup Edition、Standard Edition、Enterprise Edition 或 Developer Edition 的服务器远程编辑它们。SQL Server 2005 Express Edition 不包括 SQL Server Management Studio 或 Business Intelligence Development Studio。

  • 若要将现有 DTS 包迁移到 SQL Server 2005 Integration Services，必须使用 SQL Server 2005 Standard Edition、Enterprise Edition 或 Developer Edition。SQL Server 2005 的其他版本类别不包括 Integration Services 包迁移向导。

SQL Server 2005 Express Edition 附带的导入和导出实用工具不是 SQL Server 导入和导出向导，它不使用 Integration Services。

确保对 Data Transformation Services 包的支持

  1. 使用首选方法安装 SQL Server 2005，包括 Integration Services。如果选择安装 Integration Services，安装程序还将安装 SQL Server 2000 Data Transformation Services (DTS) 包的支持组件。

请参阅

任务

如何使用安装程序安装 Integration Services
如何从命令提示符安装 Integration Services


如何在群集中配置 Integration Services

如何在群集中配置 Integration Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Integration Services 安装帮助主题 >

SQL Server 2005 Integration Services 不为故障转移群集提供特殊安装选项。但分别在群集的每个节点中安装 Integration Services 之后，可对其进行手动配置，以使其作为群集服务运行。

在群集中安装 Integration Services 之前的准备工作

  1. 安装并配置具有一个或更多节点的群集。

  2. 也可以安装群集服务，如 SQL Server 2005 SQL Server 数据库引擎。

  3. 分别在群集的每个节点中安装 Integration Services。

  4. 确定是否将 Integration Services 配置为群集服务：

    1. 与 SQL Server 2005 SQL Server 数据库引擎 在相同的组中。

    2. 与 SQL Server 数据库引擎 在不同的组中。

在与 SQL Server 相同的组中配置 Integration Services

在此配置中：

  • 可以更加快速地向 MSDB 数据库中加载和保存包。

  • MSDB 节点在 Management Studio 中可用。

在与 SQL Server 相同的组中将 Integration Services 配置为群集服务

  1. 打开“群集管理器”。

  2. 在控制台树中选择 Groups 文件夹。

  3. 在详细信息窗格中，选择计划添加 Integration Services 的组。

  4. 在“文件”菜单上，指向“新建”，再单击“资源”。

  5. 在“资源向导”的“新资源”页上，键入名称并选择“一般服务”作为服务类型。不要更改“组”的值。单击“下一步”。

  6. 在“可能的所有者”页上，将群集的节点作为可能的资源所有者来添加或删除。单击“下一步”。

  7. 若要在“依赖关系”页中添加依赖关系，请选择“可用资源”下的资源，然后单击“添加”。对于故障转移的情况，SQL Server 和存储 Integration Services 包的共享磁盘应在 Integration Services 联机前重新联机。在选择依赖关系之后，单击“下一步”。

  8. 在“一般服务参数”页上，输入 MsDtsServer 作为服务名。单击“下一步”。

  9. 在“注册表复制”页上单击“添加”，以添加可为 Integration Services 服务标识配置文件的注册表项。该文件应位于 Integration Services 服务的同组共享磁盘中，且故障转移到用于 Integration Services 服务的下一个节点。在“注册表项”对话框中，键入 SOFTWARE\Microsoft\MSDTS\ServiceConfigFile。单击“确定”，然后单击“完成”。Integration Services 服务现已添加为群集服务。

  10. 必须立即修改该服务配置文件的位置和内容，这样，在故障转移的情况下，配置文件和包存储区才可用于所有节点。在 %ProgramFiles%\Microsoft SQL Server\90\DTS\Binn\MsDtsSrvr.ini.xml 找到该配置文件。将其复制到共享磁盘。

  11. 在共享磁盘上新建一个名为 Packages 的文件夹。为内置用户组授予此新文件夹的查看文件夹权限和写入权限。

  12. 在文本编辑器或 XML 编辑器中打开共享磁盘中的配置文件。将 ServerName 元素的值更改为同组中的虚拟 SQL Server 的名称。

  13. 将 StorePath 元素的值更改为上一步骤中在共享磁盘上所创建的 Packages 文件夹的完全限定路径。

  14. 将注册表中 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTS\ServiceConfigFile 的值更新为共享磁盘上的服务配置文件的完全限定路径和文件名。

  15. 现在使群集 Integration Services 服务联机。在“群集管理器”中选择 Integration Services 服务，单击右键，然后在弹出菜单中选择“联机”。Integration Services 服务现已作为群集服务联机。

在与 SQL Server 不同的组中配置 Integration Services

在此配置中：

  • 当 SQL Server 2005 SQL Server 数据库引擎 脱机并且其 msdb 数据库中存储的包不可用时，Integration Services 服务可能处于联机状态。

  • 如果需要，可将 Integration Services 服务更快速地移至另一节点。

  • 当其他 SQL Server 服务未安装于同一计算机上时，Integration Services 服务不与其他 SQL Server 服务争用 CPU 资源。

在与 SQL Server 不同的组中将 Integration Services 配置为群集服务

  1. 在“群集管理器”中，选择 SQL Server 所在组之外的一个组。

  2. 为 Integration Services 服务添加并配置 IP 地址、网络名称以及一般服务资源。对于一般服务，请按照前面过程中的步骤 1 到 9 进行操作。

  3. 将服务配置文件和 Packages 文件夹放置在该组的共享磁盘上。按照前面过程中的步骤 10 到 14 来更新该配置文件的位置和内容。

  4. 使该组联机。

请参阅

任务

如何使用安装程序安装 Integration Services
如何从命令提示符安装 Integration Services


Notification Services 安装帮助主题

Notification Services 安装帮助主题 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 >

此部分包含安装 Notification Services 的过程。

本节的相关信息

  • 如何安装 Notification Services 和数据库引擎

  • 如何安装 Notification Services 引擎组件

  • 如何安装 Notification Services 客户端组件

  • 如何为 COM Interop 注册核心 Notification Services 程序集

  • 如何卸载 Notification Services

请参阅

概念

安装 SQL Server Notification Services
迁移 Notification Services 实例
安装 SQL Server 2005


如何安装 Notification Services 和数据库引擎

如何安装 Notification Services 和数据库引擎 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Notification Services 安装帮助主题 >

如果要在承载 Notification Services 数据库的同一台服务器上运行其实例，则必须在此服务器上安装 Notification Services 和数据库引擎。通常在开发应用程序或部署中小型应用程序时使用单服务器配置。

安装 Notification Services 和数据库引擎

  1. 在“开始”页上，单击“运行 SQL Server 安装向导”。

  2. 按照安装说明执行操作，直到出现“要安装的组件”页。

  3. 选择 SQL Server Database Services 和 Notification Services。

    您可以根据需要选择其他组件，如工作站组件、联机丛书和开发工具。

  4. 继续按照安装页中的说明执行操作。

  5. 在“准备安装”页中，单击“安装”。

请参阅

概念

安装 SQL Server Notification Services
迁移 Notification Services 实例

其他资源

Notification Services 安装帮助主题


如何安装 Notification Services 引擎组件

如何安装 Notification Services 引擎组件 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Notification Services 安装帮助主题 >

Notification Services 的实例和它的数据库可以位于不同的服务器上。在运行 Notification Services 实例的服务器上，必须安装 Notification Services。安装全部 Notification Services 相当于安装 Notification Services 引擎组件。

安装 Notification Services

  1. 在“开始”页上，单击“运行 SQL Server 安装向导”。

  2. 按照安装说明执行操作，直到出现“要安装的组件”页。

  3. 选择“Notification Services”。

    您可以根据需要选择其他组件，如工作站组件、联机丛书和开发工具。

  4. 继续按照安装页中的说明执行操作。

  5. 在“准备安装”页中，单击“安装”。

请参阅

概念

安装 SQL Server Notification Services
迁移 Notification Services 实例

其他资源

Notification Services 安装帮助主题


如何安装 Notification Services 客户端组件

如何安装 Notification Services 客户端组件 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Notification Services 安装帮助主题 >

与 Notification Services 实例进行交互的客户端应用程序需要 Notification Services 客户端组件。最常见的远程应用程序如下所示：

  • 订阅管理界面。

  • 非宿主事件提供程序。

  • 远程管理控制台。

注意：
安装 Notification Services、SQL Server 引擎组件或 Microsoft SQL Server Management Studio 时已包含 Notification Services 客户端组件。

安装规则组件

  1. 在“开始”页上，单击“运行 SQL Server 安装向导”。

  2. 按照安装说明执行操作，直到出现“要安装的组件”页。

  3. 在“要安装的组件”页上单击“高级”按钮。

  4. 在“功能选择”页上展开 Notification Services。

  5. 在 Notification Services 下单击“客户端组件”，并选择“将安装到本地硬盘上”。

    也可以选择其他 SQL Server 组件。

  6. 继续按照安装页中的说明执行操作。

  7. 在“准备安装”页中，单击“安装”。

请参阅

概念

安装 SQL Server Notification Services
迁移 Notification Services 实例

其他资源

Notification Services 安装帮助主题


如何卸载 Notification Services

如何卸载 Notification Services |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Notification Services 安装帮助主题 >

要永久删除 Notification Services，必须删除 Notification Services 实例。如果要将 Notification Services 实例升级到新版本的 Microsoft SQL Server，请在原位保留实例，并按照 Notification Services 升级说明操作。迁移到 SQL Server 2005 不需要卸载 Notification Services 2.0。

卸载 Notification Services

  1. 停止使用要删除版本的 Notification Services 的所有实例。

  2. （可选）删除 Notification Services 实例。

    如果要将实例升级到更新版本的 SQL Server，则不要删除实例。有关删除实例的详细信息，请参阅删除 Notification Services 实例。

  3. 在“开始”菜单，选择“控制面板”，然后选择“添加或删除程序”。

  4. 选择 Microsoft SQL Server 2005，然后单击“更改”。

  5. 在“组件选择”页，选择 Notification Services。

  6. 单击“下一步”，然后按照后续向导页中的说明进行操作。

  7. 出现“更改或删除实例”页时，选择“更改已安装的组件”。

  8. 单击 Notification Services，然后选择“整个功能将不可用”。

  9. 单击“下一步”，然后按照后续向导页中的说明进行操作。

请参阅

概念

安装 SQL Server Notification Services
迁移 Notification Services 实例


如何为 COM Interop 注册核心 Notification Services 程序集

如何为 COM Interop 注册核心 Notification Services 程序集 |
 | 请参阅
安装 SQL Server 2005 组件 > 安装 SQL Server 组件帮助主题 > Notification Services 安装帮助主题 >

Notification Services API 是在托管代码中开发的。不过，Microsoft.SqlServer.NotificationServices.dll 程序集中的许多类都可以通过 COM interop 在非托管代码中使用。安装程序为 COM interop 注册此程序集。如果必须重新注册此程序集，请按照下面部分中的说明进行操作。

其他 Notification Services 程序集不支持 COM interop。

为 COM interop 注册核心程序集

  1. 打开“命令提示符”窗口。

  2. 将当前目录更改为 Microsoft .NET Framework 2.0 版目录。在下面的命令中，用完整的 .NET Framework 版本号替换 N.N.N。

    CD %WINDIR%\Microsoft.NET\Framework\v N.N.N

  3. 用下面的命令注册程序集：

    regasm /codebase /tlb "%ProgramFiles%\Microsoft SQL Server\90\NotificationServices\9.0.242\bin\microsoft.sqlserver.notificationservices.dll"

请参阅

概念

安装 SQL Server Notification Services

其他资源

带有 Notification Services 的 COM Interop
Notification Services 安装帮助主题


安装 SQL Server Express

安装 SQL Server Express |
 | 请参阅

安装 Microsoft SQL Server 2005 Express Edition (SQL Server Express) 时，您必须做出决策以选择最适合您环境的选项。本部分的主题有助于您做出这些决策。

本节的相关信息

主题 | 说明
硬件和软件要求 (SQL Server Express) | 列出安装 SQL Server Express 的硬件和软件要求。
安装 SQL Server Express 准备 | 提供安装 Microsoft .NET Framework（它是安装 SQL Server Express 的必备条件）的指南。
使用命令提示符选项安装 SQL Server Express | 说明如何使用命令行修改 SQL Server Express 安装程序。指向列出安装 SQL Server 的所有命令行选项的 SQL Server 2005 联机丛书主题。
安装示例数据库 | 提供用于安装 Adventureworks、Northwind 以及 pubs 示例数据库的下载位置。
将 MSDE 升级到 SQL Server Express | 说明在哪些情况下可以将 MSDE 升级到 SQL Server Express。
安装用户界面参考 (SQL Server Express) | 提供安装 SQL Server Express 的说明。
SQL Server 外围应用配置器 | 记录外围应用配置器用户界面并提供每个对话框的默认设置。

请参阅

其他资源

SQL Server 2005 Books Online Download Center


硬件和软件要求 (SQL Server Express)

硬件和软件要求 (SQL Server Express) |
 | 请参阅
安装 SQL Server Express >

以下各表列出了运行 Microsoft SQL Server 2005 Express Edition (SQL Server Express)、具有高级服务的 Microsoft SQL Server 2005 Express Edition (SQL Server Express) 以及 Microsoft SQL Server 2005 Express Edition 工具包 (SQL Server Express Toolkit) 的必备软件以及最低软硬件要求。

注意：
若要确定计算机是否符合系统要求，请在“开始”菜单中右键单击“我的电脑”，然后单击“属性”。“常规”选项卡显示了 CPU 类型和速度，以及安装的内存 (RAM) 大小。

SQL Server Express 的系统要求（32 位）

必备软件 | Microsoft .NET Framework Microsoft Internet Explorer 6.0 SP1 或更高版本（安装 .NET Framework 的前提条件）
RAM | 最小：192 MB 建议：512 MB 或更高
硬盘空间 | 600 MB 可用空间
处理器 | Pentium III 兼容处理器或更高速度的处理器 最低：500 MHz 建议：1 GHz 或更高
操作系统 | Windows Server 2003 SP1 Windows Server 2003 Enterprise Edition SP1 Windows Server 2003 Datacenter Edition SP1 Windows Small Business Server 2003 Standard Edition SP1 Windows Small Business Server 2003 Premium Edition SP1 Windows XP Professional SP2 Windows XP Home Edition SP2 Windows XP Tablet Edition SP2 Windows XP Media Edition SP2 Windows 2000 Professional Edition SP4 Windows 2000 Server Edition SP4 Windows 2000 Advanced Edition SP4 Windows 2000 Datacenter Server Edition SP4 虚拟 PC 虚拟服务器 注意 此版本不支持 Windows XP Embedded Edition。

具有高级服务的 SQL Server Express 的系统要求

下表列出了运行 Microsoft SQL Server 2005 Express Edition (SQL Server Express) 的必备软件以及最低软硬件要求。

必备软件

Microsoft .NET Framework 2.0

Internet 要求

  • Microsoft Internet Explorer 6.0 SP1 或更高版本（安装 .NET Framework 的前提条件）

  • Microsoft SQL Server 2005 Reporting Services (SSRS) 安装要求 Internet Information Services (IIS) 5.0 或更高版本。

    有关如何安装 IIS 的详细信息，请参阅 SQL Server 2005 联机丛书中的如何安装 Microsoft Internet 信息服务。

RAM

最小：512 MB

建议：1GB 或更高

硬盘空间

600 MB 可用空间

处理器

Pentium III 兼容处理器或更高速度的处理器

最低：600 MHz

建议：1 GHz 或更高

操作系统

Windows Server 2003 SP1

Windows Server 2003 Enterprise Edition SP1

Windows Server 2003 Datacenter Edition SP1

Windows Server 2003 Web Edition SP1

Windows Small Business Server 2003 Standard Edition SP1

Windows Small Business Server 2003 Premium Edition SP1

Windows XP Professional SP2

Windows XP Tablet Edition SP2

Windows XP Home Edition SP21

Windows XP Media Edition SP21

Windows 2000 Professional Edition SP4

Windows 2000 Server Edition SP4

Windows 2000 Advanced Edition SP4

Windows 2000 Datacenter Server Edition SP4

虚拟 PC

虚拟服务器

注意：
此版本不支持 Windows XP Embedded Edition。

1如果在安装具有高级服务的 SQL Server Express 时安装 Reporting Services，则不会在不含 Internet 信息服务 (IIS) 的操作系统上安装 Reporting Services。

SQL Server 2005 Express Edition 工具包的系统要求

必备软件

Microsoft .NET Framework 2.0

Internet 要求

  • Microsoft Internet Explorer 6.0 SP1 或更高版本（安装 .NET Framework 的前提条件）

  • Microsoft SQL Server 2005 Reporting Services (SSRS) 安装要求 Internet Information Services (IIS) 5.0 或更高版本。

    有关如何安装 IIS 的详细信息，请参阅 SQL Server 2005 联机丛书中的如何安装 Microsoft Internet 信息服务。

RAM

最小：512 MB

建议：1GB 或更高

硬盘空间

600 MB 可用空间

处理器

Pentium III 兼容处理器或更高速度的处理器

最低：600 MHz

建议：1 GHz 或更高

操作系统

Windows Server 2003 SP1

Windows Server 2003 Enterprise Edition SP1

Windows Server 2003 Datacenter Edition SP1

Windows Server 2003 Web Edition SP1

Windows Small Business Server 2003 Standard Edition SP1

Windows Small Business Server 2003 Premium Edition SP1

Windows XP Professional SP2

Windows XP Tablet Edition SP2

Windows XP Home Edition SP2

Windows XP Media Edition SP2

Windows 2000 Professional Edition SP4

Windows 2000 Server Edition SP4

Windows 2000 Advanced Edition SP4

Windows 2000 Datacenter Server Edition SP4

虚拟 PC

虚拟服务器

注意：
此版本不支持 Windows XP Embedded Edition。

1如果在安装具有高级服务的 SQL Server Express 时安装 Reporting Services，则不会在不含 Internet 信息服务 (IIS) 的操作系统上安装 Reporting Services。

SQL Server Express 安装包

存在以下两个用于安装 SQL Server Express 的可执行文件：

  • SQLEXPR.EXE。安装在基于 x86 的计算机上并支持 x64 而非 IA64 上的 WoW64。

  • SQLEXPR32.EXE。只安装在基于 x86 的计算机上。此程序不会在任何 64 位平台（即使是 WoW64）上运行。

请参阅

任务

如何安装 SQL Server Express

概念

安装 SQL Server Express 准备

其他资源

SQL Server 2005 联机丛书下载中心

更改历史记录

版本 历史记录

2005 年 12 月 5 日

已更改的内容：
  • 更新了操作系统列表

  • 更新了安装包的说明。

2006 年 4 月 14 日

已更改的内容：
  • 添加了选用于 SQL Server Express 新版本的操作系统列表


安装 SQL Server Express 准备

安装 SQL Server Express 准备 |
 | 请参阅
安装 SQL Server Express >

在安装 Microsoft SQL Server 2005 Express Edition (SQL Server Express) 之前，请确保已安装与 SQL Server Express 关联的正确版本的 .NET Framework。

SQL Server Express 版本 .NET Framework 版本

SQL Server 2005 Express Edition - RTM

如果要安装 SQL Server 2005 Express Edition，则按顺序执行下列步骤：

  1. 从计算机中卸载 .NET Framework 1.2 及更高版本（不必卸载版本 1.0 和 1.1）。然后，从 .NET Framework 2.0 下载中心安装 .NET Framework 2.0。

  2. 从 SQL Server Express 网站安装 SQL Server 2005 Express Edition。

如何标识计算机上的 .NET Framework 版本

您可以通过下列两种方法之一标识计算机上的 .NET Framework 版本：

  • 如果版本为 2.0，则若要标识确切的版本，请转到 %WINDIR%\Microsoft.NET\Framework\version，右键单击 mscorlib.dll，再依次单击“属性”和“版本”。

  • 或者，在“开始”菜单中，单击“控制面板”，打开“管理工具”，再打开“.NET Framework 2.0 配置”。在右窗格顶部，将显示 .NET Framework 版本。

请参阅

任务

如何安装 SQL Server Express
如何卸载 SQL Server Express

其他资源

安装 SQL Server Express
SQL Server 2005 联机丛书下载中心


使用命令提示符选项安装 SQL Server Express

使用命令提示符选项安装 SQL Server Express |
 | 请参阅
安装 SQL Server Express >

SQL Server 2005 Express Edition (SQL Server Express) 安装程序除了提供图形用户界面之外，还提供一个命令提示符界面。请参阅 SQL Server 2005 联机丛书中的从命令提示符运行安装程序和如何从命令提示符安装 SQL Server 2005，以自定义安装程序安装 SQL Server Express 的方式。

注意：
SQL Server Express 是受限版本的 SQL Server 2005。使用命令提示符安装 SQL Server Express 的体验类似于安装 SQL Server 2005 的体验。

修改 SQL Server Express 的已安装组件

如果您通过 SQL Server Express 网站上的下载中心安装 SQL Server Express，则将使用 sqlexpr.exe 运行安装程序。如果 sqlexpr.exe 直接运行而未保存到文件夹中，则在安装完成后会删除提取二进制文件的临时目录。如果您尝试使用“控制面板”中的“添加或删除程序”来修改 SQL Server Express 组件，则“更改”按钮便会查找安装目录，但是找不到。

当 SQL Server Express 作为 Visual Studio 2005 Express 的一部分进行安装时，不能使用此方案。有关 Visual Studio Express 的详细信息，请参阅 Visual Studio 2005 Express 产品。

若要修改已安装的 SQL Server Express 组件，必须再次从网站下载 sqlexpr.exe 并将该 .exe 保存到文件夹中。在命令提示符下，将路径更改为存储 .exe 的文件夹，然后使用 sqlexpr.exe –x 参数运行安装程序。系统将会提示您选择一个提取/安装目录。

通过在提示时指定提取目录，便可在提取安装程序文件之后，使用“更改”按钮来修改 SQL Server Express 安装。

在单用户模式下运行 SQL Server Express

在以下方案中，SQL Server Express 将不会在单用户模式下启动：

安装 SQL Server Express 之后，您可以使用 SQL Server 配置管理器来启动服务，验证连接以及停止服务。然后转到命令提示符下并使用以下命令在单用户模式下启动 SQL Server Express：

Sqlservr.exe -s SQLEXPRESS -m

服务将会启动。但是，如果关闭服务并尝试再次启动，则服务不会启动。

请参阅

任务

如何安装 SQL Server Express
如何卸载 SQL Server Express

其他资源

SQL Server 2005 联机丛书下载中心


安装示例数据库

安装示例数据库 |
 | 请参阅
安装 SQL Server Express >

Microsoft SQL Server 2005 Express Edition (SQL Server Express) 支持的示例数据库包括 Adventureworks、Northwind 和 Pubs。默认情况下，这些示例数据库没有与 SQL Server Express 一起安装。相反，您可以从 Microsoft 下载中心下载这些示例数据库。

AdventureWorks

Adventureworks 可以通过此 Microsoft Web site 进行安装。下载 SQLServerExpressSamplesOverview.htm 并按照它提供的说明进行操作。双击 AdventureworksDB.msi 以安装示例数据库。

Northwind 和 pubs

Northwind 和 pubs 可以通过此 Microsoft Web site 进行安装。

下载 SQL2000SampleDb.msi 之后，请双击 SQL2000SampleDb.msi 以提取示例数据库脚本。SQL2000SampleDb.msi 将数据库脚本和自述文件提取到文件夹 C:\Program Files\SQL Server 2000 Sample Databases 中。请按照自述文件中的说明运行安装脚本。

注意：
有关详细信息，请参阅 SQL Server 2005 联机丛书中的示例和示例数据库。

请参阅

其他资源

SQL Server 2005 Books Online Download Center


将 MSDE 升级到 SQL Server Express

将 MSDE 升级到 SQL Server Express |
 | 请参阅
安装 SQL Server Express >

如果 MDSE 使用 MSI 安装程序进行安装，则当您使用与现有 MSDE 实例相同的实例名安装 Microsoft SQL Server 2005 Express Edition (SQL Server Express) 时，会升级现有的 MSDE 实例。当您运行 SQL Server Express 安装程序时，请使用“默认实例”选项。例外的情况是：要安装的 SQL Server Express 版本不是英语版。然后，要升级的 MSDE 安装必须与 SQL Server Express 版本具有相同的语言，或者必须为英语版。

如果 MSDE 作为另一个使用自带安装程序的应用程序的一部分进行安装，则 SQL Server Express 安装程序便无法识别 MSDE.在这种情况下，升级 SQL Server Express 的唯一方法是使用另一个实例名安装 SQL Server Express。当您运行 SQL Server Express 安装程序时，请使用“命名实例”选项指定新的实例名，然后将数据库从 MSDE 中分离开并附加到 SQL Server Express 上。

若要了解 MSDE 是否作为另一个应用程序的一部分进行安装，请转到“控制面板”中的“添加或删除程序”。如果“添加或删除程序”中没有显示 MSDE，则说明它作为另一个应用程序的一部分进行安装。在这种情况下，删除 MSDE 的唯一方法是卸载安装有 MSDE 的应用程序。在多数情况下，应用程序用户需要请求应用程序供应商来帮助升级。

请参阅

其他资源

SQL Server 2005 Books Online Download Center


如何在安装过程中启用网络访问 (SQL Server Express)

如何在安装过程中启用网络访问 (SQL Server Express)
安装 SQL Server Express >

当您安装 Microsoft SQL Server 2005 Express Edition (SQL Server Express) 时，网络协议默认处于禁用状态。可以在安装过程中或安装产品之后启用这些协议。您还可能需要启用防火墙设置。

启用网络协议

  • 在命令提示符下运行 setup.exe 时，请指定 DisableNetworkProtocols = 0，如以下示例所示：

    复制代码
    setup.exe /qn addlocal=all InstanceName=SQLEXPRESS  DisableNetworkProtocols=0

启用防火墙设置

  1. 单击“开始”和“控制面板”，再单击“网络连接”。

  2. 在左侧的导航栏中，单击“更改 Windows 防火墙的设置”。

  3. 在“异常”选项卡上的“程序和服务”框中，您可能看到已列出 SQL Server，但是未将它选择为异常。如果您选中该复选框，则 Windows 将打开端口 1433 来放入 TCP 请求。或者，如果您未看到列出 SQL Server，则请执行下列操作：

    1. 单击“添加程序”。

    2. 单击“浏览”。

    3. 导航到 drive:/Program Files/Microsoft SQL Server/MSSQL.1\MSSQL\BINN

    4. 将文件 sqlservr.exe 添加到异常列表中。


如何安装 SQL Server Express

如何安装 SQL Server Express |
 | 请参阅
安装 SQL Server Express >

本主题说明如何安装 Microsoft SQL Server 2005 Express Edition (SQL Server Express)，同时还介绍了不同于 Microsoft SQL Server 2005 的设置选项。

对于本地安装，必须以管理员身份运行安装程序。如果通过远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

安装 SQL Server Express

  1. 若要开始安装，请双击 sqlexpr.exe。

    注意：
    SQL Server Express 可作为自解压可执行文件 (sqlexpr.exe)，从 Visual Studio 2005 CD 和 SQL Server Express 网站 上获取。SQLEXPR.EXE 安装在基于 x86 的计算机和 32 位子系统 (WOW64) 上。有关详细信息，请参阅硬件和软件要求 (SQL Server Express)。

  2. 在“最终用户许可协议”页上，阅读许可协议，然后选中“我接收许可条款和条件”复选框。单击“下一步”。

  3. 此时，将运行“SQL Server 组件更新”，以便在安装 SQL Server Express 前安装必需的软件。有关组件要求的详细信息，请单击该页底部的“帮助”按钮。单击“下一步”。

    重要事项：
    运行“SQL Server 组件更新”时尚未安装 .NET Framework2.0，但 SQL Server Express 安装程序要求在运行 sqlexpr.exe 之前安装 .NET Framework 2.0。如果 .NET Framework 2.0 不存在，则将发生错误。请确保卸载了 .NET Framework 的所有以前版本，并在启动 SQL Server Express 安装程序前从 .NET Framework 2.0 下载中心安装 .NET Framework 2.0。

  4. 此时将显示“欢迎使用 Microsoft SQL Server 安装向导”页面。单击“下一步”。

  5. 在“系统配置检查”页上，将扫描计算机以检查是否存在潜在的安装问题。若要中断扫描，请单击“停止”。若要在扫描完成后继续进行安装，请单击“继续”。

  6. 在“注册信息”页上的“姓名”和“公司”文本框中，输入相应的信息。单击“下一步”。

    1. 由于 SQL Server Express 是免费的，因此该页没有“产品密钥”文本框。

    2. 如果选中“隐藏高级配置选项”复选框，则安装过程中不会出现“服务帐户”、“排序规则设置”、“实例名”和“用户实例”页面。

  7. 在“功能选择”页上，选择要安装的程序功能，然后单击“下一步”。

    注意：
    SQL Server Express 安装程序没有“自定义功能选择”页面，而是通过“功能选择”页面选择要安装的功能。单击“+”符号展开功能，可以查看其子功能。

  8. 在“实例名”页上，请为安装的软件选择“默认实例”或“命名实例”。如果选择“默认实例”，将升级现有的默认实例。如果选择“命名实例”，请指定实例名称，或者使用 SQLExpress 的默认命名实例。单击“下一步”。

    单击“已安装的实例”可以查看正在运行 SQL Server Express 安装程序的计算机中安装的 SQL Server Express 实例和组件的列表。安装实例的详细信息窗格将显示已安装实例的升级选项。

    SQL Server Express 安装程序检查在启动时是否存在实例名 SQLExpress。

    1. 如果存在 SQLExpress 实例，则默认情况下将显示实例名页面。

    2. 如果不存在 SQLExpress 实例，则默认情况下将隐藏实例名页面。但是，如果清除“注册信息”页上的“隐藏高级配置选项”复选框，则将始终显示“实例名”复选框。

  9. 通过“服务帐户”页面，可以将本地系统帐户或域用户帐户分配到 SQL Server 服务。如果选中“隐藏高级配置选项”复选框，则不会出现此页面。

    1. 选择“使用本地系统帐户”（不要求提供密码），连接到同一计算机上的 SQL Server，然后单击“下一步”。

    2. 选择“使用域用户”帐户，输入“用户名”、“密码”和“域”名，然后单击“下一步”。

      注意：
      对于 SQL Server Express，默认情况下“SQL 安装结束时启动服务”复选框处于选中状态。启动操作系统，将自动启动 SQL Server 服务。

  10. 在“身份验证模式”页上，指定连接到 SQL Server 实例所用的安全模式。如果选择 Windows 身份验证，安装程序会创建一个在默认情况下禁用的 sa 帐户。若要在安装程序完成后激活 sa 帐户，请参阅 SQL Server 2005 联机丛书中的 如何更改服务器身份验证模式 和 ALTER LOGIN (Transact-SQL) 主题。如果选择“混合模式身份验证”，则必须对所有 SQL Server 登录名设置强密码。输入并确认 sa 强登录密码。单击“下一步”。

    重要事项：
    出于安全原因，SQL Server Express 不会自动启动 SQL Browser 服务。如果应用程序必须使用 SQL Browser，则必须手动启动该服务，或更改其启动选项。有关详细信息，请参阅 SQL Server 2005 联机丛书中的 SQL Server Browser 服务如何启动和停止 SQL Server Browser 服务。

  11. 在“排序规则设置”页中，仅在必须匹配 SQL Server 的另一实例或另一计算机中的排序规则设置时，才更改默认的“排序规则指示符和排序顺序”。选择“SQL 排序规则”以匹配 SQL Server 较早版本中的排序顺序设置。单击“下一步”。如果选中“隐藏高级配置选项”复选框，则不会出现此页面。

    注意：
    已删除“为每个服务帐户进行自定义”下拉框，因为在 SQL Server Express 中，服务应始终指向 SQL Server。

  12. 在“错误和使用情况报告设置”页中，选择是否为 SQL Server 及其组件打开错误报告和使用情况报告。默认情况下，错误报告处于打开状态。若要关闭错误报告，请清除相应的复选框。单击“下一步”。

  13. 在“准备安装”页中，单击“安装”以完成安装 SQL Server。

除了使用图形用户界面外，还可以使用与安装 SQL Server 2005 相同的命令行参数来安装 SQL Server Express。有关命令行参数的详细信息，请参阅 SQL Server 2005 联机丛书中的“从命令提示符运行安装程序”。

SQL Server Express 还支持 DISABLENETWORKPROTOCOLS 属性，从而可在安装过程中进行网络访问。有关详细信息，请参阅如何在安装过程中启用网络访问 (SQL Server Express)。

请参阅

任务

如何卸载 SQL Server Express

概念

安装 SQL Server Express 准备

其他资源

SQL Server 2005 联机丛书下载中心


如何卸载 SQL Server Express

如何卸载 SQL Server Express |
 | 请参阅
安装 SQL Server Express >

在本主题中，您将了解如何完全卸载 Microsoft SQL Server 2005 Express Edition (SQL Server Express)。

卸载 SQL Server Express

  1. 单击“开始”，再单击“控制面板”。

  2. 打开“添加或删除程序”。

  3. 选择 Microsoft SQL Server 2005，再单击“删除”。

  4. 将出现“选择组件”页。默认情况下，选中“删除 SQL Server 2005 实例组件”复选框。选择要删除的实例。

  5. 若要删除工作站组件，请选中“工作站组件”复选框。

  6. 将出现“确认”页，其中列出要删除的组件。单击“完成”以完成 SQL Server Express 的卸载进程。

    当卸载进程完成后，您将看到“系统配置检查”页和“安装进度”页。

  7. 若要删除 SQL 本机客户端，请依次单击“开始”和“控制面板”，再单击“添加或删除程序”。

  8. 选择“Microsoft SQL 本机客户端”，再单击“删除”。

  9. 您将看到一个对话框，确认是否要删除 SQL 本机客户端。单击“是”。

    如此便可从“添加或删除程序”的列表中删除 SQL 本机客户端。

请参阅

其他资源

SQL Server 2005 Books Online Download Center


配置 SQL Server 安装

配置 SQL Server 安装 |
 | 请参阅

安装程序完成 Microsoft SQL Server 2005 的安装后，可以使用图形化工具和命令提示实用工具进一步配置 SQL Server。下表说明了对用来管理 SQL Server 2005 实例的工具的支持。

工具或实用工具 | 说明
SQL Server Management Studio | SQL Server Management Studio 用于编辑和执行查询，并用于启动标准向导任务。有关详细信息，请参阅SQL Server Management Studio 简介。
SQL Server 事件探查器 | SQL Server 事件探查器 提供了图形用户界面，用于监视 SQL Server 数据库引擎 实例或 Analysis Services 实例。有关详细信息，请参阅SQL Server Profiler 简介。
数据库引擎 优化顾问 | 数据库引擎 优化顾问可以协助创建索引、索引视图和分区的最佳组合。有关详细信息，请参阅使用数据库引擎优化顾问。
Business Intelligence Development Studio | Business Intelligence Development Studio 是用于 Analysis Services 和 Integration Services 解决方案的集成开发环境。有关详细信息，请参阅介绍 Business Intelligence Development Studio。
命令提示实用工具 | 从命令提示符管理 SQL Server 对象。有关详细信息，请参阅命令提示实用工具。
SQL Server 配置管理器 | 管理服务器和客户端网络配置设置。有关详细信息，请参阅 SQL Server 配置管理器。
Import and Export Data | Integration Services 提供了一套用于移动、复制及转换数据的图形化工具和可编程对象。有关详细信息，请参阅 Integration Services 概述。
SQL Server 安装程序 | 安装、升级到或更改 SQL Server 2005 实例中的组件。有关详细信息，请参阅数据库引擎安装帮助主题。

默认配置

SQL Server 2005 新实例的默认配置禁用某些功能和组件，以减少此产品易受攻击的外围应用。

默认情况下，禁用下列组件和功能：

  • Integration Services

  • SQL Server 代理

  • SQL Server 浏览器

  • 全文搜索

有关详细信息，请参阅 SQL Server 外围应用配置器。

请参阅

参考

SQL Server 2005 的各种版本所支持的功能

其他资源

管理数据库引擎
关于 SQL Server 代理


SQL Server 外围应用配置器

SQL Server 外围应用配置器 |
 | 请参阅
配置 SQL Server 安装 >

外围应用减少操作将涉及停止或禁用未使用的组件以增加系统的安全性。对新的 Microsoft SQL Server 2005 安装，一些功能、服务和连接将被禁用或停止，以减少 SQL Server 外围应用。对于升级的安装，所有功能、服务和连接将保持其升级前的状态。

使用 SQL Server 外围应用配置器，可以启用、禁用、开始或停止 SQL Server 2005 安装的一些功能、服务和远程连接。可以在本地和远程服务器中使用 SQL Server 外围应用配置器。

SQL Server 外围应用配置器使用 Window Management Instrumentation (WMI) 查看和更改服务器设置。WMI 提供了一种统一的方式，用于与管理配置 SQL Server 的注册表操作的 API 调用进行连接。有关与 WMI 相关的配置权限的信息，请参阅主题如何在 SQL Server 工具中将 WMI 配置为显示服务器状态。

启动外围应用配置器工具

可通过 SQL Server 开始菜单使用 SQL Server 外围应用配置器：

  • 在“开始”菜单中，依次指向“所有程序”、Microsoft SQL Server 2005 和“配置工具”，再单击“SQL Server 外围应用配置器”。

显示的第一个页面为 SQL Server 外围应用配置器的起始页。在该起始页中，可指定要配置的服务器：

  1. 单击“配置外围应用”旁边的链接。默认值为 localhost。如果您以前选择的是一个命名服务器，则将会看到该服务器名称。

  2. 在“选择计算机”对话框中，执行下列操作之一：

    • 若要在本地计算机中配置 SQL Server 2005，请单击“本地计算机”。

    • 若要在另一台计算机中配置 SQL Server 2005，请单击“远程计算机”，然后在文本框中输入计算机名称。

    • 若要配置故障转移群集，请单击“远程计算机”，然后在文本框中输入虚拟服务器名称。

  3. 单击“确定”。

选择了要配置的计算机后，可以启动以下两个工具：

  • 使用“功能的外围应用置器”来启用或禁用数据库引擎、Analysis Services 和 Reporting Services 的功能。有关默认功能设置，请参阅功能的外围应用配置器。

  • 使用“服务和连接的外围应用配置器”来启用或禁用 Windows 服务和远程连接。有关默认服务和连接设置，请参阅服务和连接的外围应用配置器。

sac 命令行实用工具

若要导入或导出外围应用设置，请使用 sac 命令提示实用工具。使用此实用工具，您可以在一台计算机中配置外围应用，然后再将这些相同的设置应用于其他计算机。

使用 sac 实用工具最简单的方法是：使用 SQL Server 外围应用配置器配置一台计算机，然后再使用 sac 实用工具将该计算机的设置导出到一个文件中。您可以使用该文件将相同的设置应用于其他计算机的 SQL Server 2005 组件。

有关详细信息，请参阅 sac 实用工具。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器

其他资源

外围应用配置器的 F1 帮助


功能的外围应用配置器

功能的外围应用配置器 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 >

功能的外围应用配置器工具提供一个单一界面，用于启用或禁用多个数据库引擎、Analysis Services 和 Reporting Services 功能。禁用未使用的功能可减少 SQL Server 外围应用，有助于保护 Microsoft SQL Server 安装。

下表列出了每个设置的默认值，并提供指向 F1 帮助主题的链接。

数据库引擎功能默认值

设置 | 默认值 | F1 帮助主题
即席分布式查询 | 在新安装中禁用。 | 功能的外围应用配置器（即席远程查询）- 数据库引擎
公共语言运行时 (CLR) 集成 | 在新安装中禁用。 | 功能的外围应用配置器（CLR 集成）- 数据库引擎
专用管理员连接 (DAC) | 在新安装中禁用。 | 功能的外围应用配置器 (DAC) - 数据库引擎
数据库邮件 | 在新安装中禁用。 | 功能的外围应用配置器（数据库邮件）- 数据库引擎
本机 XML Web 服务 | 默认情况下，未配置端点。 | 功能的外围应用配置器（本机 XML Web 服务）- 数据库引擎
OLE 自动化存储过程 | 在新安装中禁用。 | 功能的外围应用配置器（OLE 自动化）- 数据库引擎
Service Broker | 默认情况下，未配置端点。 | 功能的外围应用配置器 (Service Broker) - 数据库引擎
SQL 邮件 | 在新安装中禁用。 | 功能的外围应用配置器 (SQL Mail) - 数据库引擎
Web 助手存储过程 | 在新安装中禁用。 | 功能的外围应用配置器（Web 助手）- 数据库引擎
xp_cmdshell | 在新安装中禁用。 | 功能的外围应用配置器 (xp_cmdshell) - 数据库引擎

Analysis Services 功能默认值

设置 | 默认值 | F1 帮助主题
即席数据挖掘查询 | 在新安装中禁用。 | 功能的外围应用配置器（即席数据挖掘查询）- Analysis Services
匿名连接 | 在新安装中禁用。 | 功能的外围应用配置器（匿名连接）- Analysis Services
链接对象 | 在新安装中禁用。 | 功能的外围应用配置器（链接对象）- Analysis Services
用户定义函数 | 在新安装中禁用。 | 功能的外围应用配置器（用户定义函数）- Analysis Services

Reporting Services 功能默认值

功能 | 默认设置 | F1 帮助主题
Web 服务请求和 HTTP 访问 | 在新安装中启用。 | 功能的外围应用配置器（Web 服务和 HTTP 访问）- Reporting Services
预定的事件和报表传递 | 在新安装中启用。 | 功能的外围应用配置器（预定的事件和报表传递）- Reporting Services
Windows 集成安全性 | 在新安装中启用 | 功能的外围应用配置器（Windows 集成安全性）- Reporting Services

请参阅

概念

SQL Server 外围应用配置器
配置 SQL Server 安装


功能的外围应用配置器（即席远程查询）- 数据库引擎

功能的外围应用配置器（即席远程查询）- 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

即席分布式查询可使用 OPENROWSET 和 OPENDATASOURCE 函数连接到使用 OLE DB 的远程数据源。使用此对话框可配置对即席远程查询的支持。

选项

启用 OPENROWSET 和 OPENDATASOURCE 支持

如果选中此项，数据库引擎 实例将支持使用 OPENROWSET 和 OPENDATASOURCE 函数来运行远程查询，而无需先定义链接服务器。OPENROWSET 和 OPENDATASOURCE 专门用于不常见的查询。如果您的应用程序不使用这些函数，则不应启用这些函数。

有关即席查询的详细信息，请参阅 SQL Server 联机丛书中的使用临时名称标识数据源。

有关配置服务器选项的详细信息，请参阅 SQL Server 联机丛书中的 sp_configure (Transact-SQL)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器（CLR 集成）- 数据库引擎

功能的外围应用配置器（CLR 集成）- 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

默认情况下，将禁用 Microsoft SQL Server 2005 中用户程序集的执行。使用此对话框可以配置对公共语言运行时 (CLR) 的支持。

选项

启用 CLR 集成

如果选中此选项，您可以使用数据库引擎中基于 CLR 的用户定义函数、过程、触发器和类型。

即使禁用此选项，您也可以运行数据定义语言 (DDL) 语句来创建、更改或删除用户程序集和 CLR 模块，但不能执行 CLR 代码。

有关 CLR 集成的详细信息，请参阅 SQL Server 联机丛书中的Building Database Objects with Common Language Runtime (CLR) Integration。

有关配置服务器选项的详细信息，请参阅 SQL Server 联机丛书中的 sp_configure (Transact-SQL)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器 (DAC) - 数据库引擎

功能的外围应用配置器 (DAC) - 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

通过专用管理员连接 (DAC)，管理员可以连接到服务器以执行诊断功能或 Transact-SQL 语句。在数据库引擎 不响应常规连接的情况下，可使用 DAC。默认情况下，仅对本地连接启用此功能。启用此选项可通过远程计算机使用 DAC。在群集配置中，必须启用此选项才能使用 DAC 连接。

选项

启用远程 DAC

如果选中此项，则可通过远程计算机启用 DAC。

有关 DAC 的详细信息，请参阅 SQL Server 联机丛书中的使用专用管理员连接。

有关配置服务器选项的详细信息，请参阅 SQL Server 联机丛书中的 sp_configure (Transact-SQL)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器

更改历史记录

版本 历史记录

2005 年 12 月 5 日

新增内容：
  • 添加了有关将此选项用于群集配置的说明。


功能的外围应用配置器（数据库邮件）- 数据库引擎

功能的外围应用配置器（数据库邮件）- 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

数据库邮件是使用 SMTP 从数据库引擎发送电子邮件的新组件。只有在计划配置和使用数据库邮件时才需要启用数据库邮件存储过程。

禁用数据库邮件将阻止启动数据库邮件程序，但是如果在更改该选项时数据库邮件正在运行，数据库邮件将继续运行并处理邮件（没有查询或附件），直到数据库邮件完成邮件发送并在 DatabaseMailExeMinimumLifeTime 选项所配置的时间内处于空闲状态。

选项

启用数据库邮件存储过程

如果选中此选项，将启用支持数据库邮件的扩展存储过程。若要使用数据库邮件，必须对数据库邮件进行配置。有关详细信息，请参阅 Microsoft SQL Server 联机丛书中的数据库邮件。

有关配置 SQL Server 选项的详细信息，请参阅 SQL Server 联机丛书中的 sp_configure (Transact-SQL)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器（本机 XML Web 服务）- 数据库引擎

功能的外围应用配置器（本机 XML Web 服务）- 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

本机 XML Web 服务提供了使用 SOAP 消息通过 HTTP 对数据库的访问。若要使用此功能，必须创建并启动 HTTP 端点。有关详细信息，请参阅 Microsoft SQL Server 2005 联机丛书中的 CREATE ENDPOINT (Transact-SQL) 和在 SQL Server 2005 中使用本机 XML Web 服务。

注意：
HTTP SOAP 端点支持在 Microsoft Windows XP SP2 和 Microsoft Windows Server 2003 操作系统上启动。

选项

端点名称

HTTP 端点的名称。

状态

显示端点的当前状态。当前状态可以为“已启动”、“已停止”或“已禁用”。

若要更改状态，请从“状态”框中选择状态，再单击“应用”。

  • 如果状态为“已启动”，则可以将该状态更改为“已停止”。停止端点会停止并禁用端点。

  • 如果状态为“已停止”或“已禁用”，则可以将该状态更改为“已启动”。启动端点会启用并启动端点。

如果只想禁用端点，请使用 ALTER ENDPOINT (Transact-SQL)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器（OLE 自动化）- 数据库引擎

功能的外围应用配置器（OLE 自动化）- 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

OLE 自动化扩展存储过程允许 Transact-SQL 批处理、存储过程和触发器引用自定义 OLE 自动化对象。使用此对话框可以控制是否执行下列任何 OLE 自动化过程：

  • sp_OACreate

  • sp_OADestroy

  • sp_OAGetErrorInfo

  • sp_OAGetProperty

  • sp_OAMethod

  • sp_OASetProperty

  • sp_OAStop

默认情况下，在 Microsoft SQL Server 的新安装中禁用这些存储过程。

选项

启用 OLE 自动化

如果选中此选项，将启用 OLE 自动化存储过程。

有关 OLE 自动化的详细信息，请参阅 SQL Server 联机丛书中的 Transact-SQL 中的 OLE 自动化对象。

有关配置 SQL Server 选项的详细信息，请参阅 SQL Server 联机丛书中的 sp_configure (Transact-SQL)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器 (Service Broker) - 数据库引擎

功能的外围应用配置器 (Service Broker) - 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

Microsoft SQL Server 为 SQL Server 实例外部的 Service Broker 通信使用 Service Broker 端点。

端点是表示 SQL Server 的网络通信能力的 SQL Server 对象。每个端点支持一种特定的通信类型。例如，使用 HTTP 端点，SQL Server 可以处理特定的 SOAP 请求。Service Broker 端点可以将 SQL Server 配置为通过网络来发送和接收 Service Broker 消息。

可以启动、停止或禁用 Service Broker 端点。您可以使用此对话框为实例启动/停止和禁用 Service Broker 端点。

选项

Service Broker 端点

显示 Service Broker 端点的名称。

状态

显示 Service Broker 端点的当前状态。

若要更改状态，请从“状态”框中选择状态，再单击“应用”。

  • 如果状态为“已启动”，则可以将该状态更改为“已停止”。停止端点会停止并禁用端点。

  • 如果状态为“已停止”或“已禁用”，则可以将该状态更改为“已启动”。启动端点会启用并启动端点。

如果只想禁用端点，请使用 ALTER ENDPOINT (Transact-SQL)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器 (SQL Mail) - 数据库引擎

功能的外围应用配置器 (SQL Mail) - 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

默认情况下，SQL Mail 为禁用状态。因为提供了数据库邮件，所以不推荐使用 SQL Mail。使用此对话框，您可以启用 SQL Mail 以便向后兼容。

选项

启用 SQL Mail 存储过程

如果选中此选项，将启用支持 SQL Mail 的扩展存储过程。

有关 SQL Mail 的详细信息，请参阅 Microsoft SQL Server 联机丛书中的 SQL Mail。

有关配置服务器选项的详细信息，请参阅 SQL Server 联机丛书中的 sp_configure (Transact-SQL)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器（Web 助手）- 数据库引擎

功能的外围应用配置器（Web 助手）- 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

Web 助手存储过程可以使用 Microsoft SQL Server 数据生成 HTML 文件。在 Microsoft SQL Server 2005 中，已不推荐使用这些存储过程。使用此对话框可以启用 Web 助手所使用的过程。

Reporting Services 提供了多个使用 SQL Server 数据生成基于 Web 的报表的高级选项。有关详细信息，请参阅 SQL Server 联机丛书中的 SQL Server Reporting Services。

选项

启用 Web 助手

如果选中此选项，则将启用 Web 助手存储过程。

有关配置服务器选项的详细信息，请参阅 SQL Server 联机丛书中的 sp_configure (Transact-SQL)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器 (xp_cmdshell) - 数据库引擎

功能的外围应用配置器 (xp_cmdshell) - 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

xp_cmdshell 扩展存储过程将命令字符串作为操作系统命令 shell 执行，并以文本行的形式返回所有输出。使用外围应用配置器中的 xp_cmdshell 对话框可以配置 xp_cmdshell 支持。

选项

启用 xp_cmdshell

如果选中此选项，将会启用 xp_cmdshell 扩展存储过程。如果取消选中此选项，将无法使用 xp_cmdshell 扩展存储过程。

有关 xp_cmdshell 的详细信息，请参阅 Microsoft SQL Server 联机丛书中的 xp_cmdshell (Transact-SQL)。

有关配置服务器选项的详细信息，请参阅 SQL Server 联机丛书中的设置服务器配置选项。

请参阅

概念

SQL Server 外围应用配置器
功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器（即席数据挖掘查询）- Analysis Services

功能的外围应用配置器（即席数据挖掘查询）- Analysis Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

数据挖掘扩展插件 (DMX) OPENROWSET 函数支持使用外部访问接口的即席查询。如果您的应用程序和脚本不使用此函数，请禁用即席数据挖掘查询。

如果启用即席数据挖掘查询，在使用 OPENROWSET 时，可以启用或禁用 OLEDB 访问接口名称和连接字符串的传递。

选项

启用即席数据挖掘查询

如果选中此选项，则将启用 DMX OPENROWSET 函数。

有关详细信息，请参阅 Microsoft SQL Server 联机丛书中的 OPENROWSET (DMX)。

有关配置服务器选项的详细信息，请参阅 SQL Server 联机丛书中的 sp_configure (Transact-SQL)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器（匿名连接）- Analysis Services

功能的外围应用配置器（匿名连接）- Analysis Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

匿名连接允许未经身份验证的用户与 Microsoft SQL Server 2005 Analysis Services 建立连接。除非您的应用程序需要未经身份验证的用户连接到该实例，否则请禁用匿名连接。

默认情况下，Analysis Services 不允许未经身份验证的用户与实例建立连接。极力建议不启用对实例的匿名连接，但是通过使用 SQL Server Management Studio 将 RequireClientAuthentication 服务器配置属性的值更改为 0，或通过使用此对话框，可以启用匿名连接。

选项

启用匿名连接

如果选中此选项，则未经身份验证的用户可以连接到 Analysis Services。

有关保护与 Analysis Services 实例的连接的详细信息，请参阅 SQL Server 联机丛书中的保护客户端与 Analysis Services 实例的通信。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器（链接对象）- Analysis Services

功能的外围应用配置器（链接对象）- Analysis Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

默认情况下，Microsoft SQL Server 2005 Analysis Services 不允许创建链接对象，例如链接维度和链接度量值组。为了启用这些对象的链接，两个实例都需要启用此功能。通过使用 SQL Server Management Studio 更改 Link\ToOtherInstanceEnabled 和 Link\FromOtherInstanceEnabled 服务器配置属性的值或使用此对话框，可以对此进行控制。

选项

启用到其他实例的链接

如果选中此选项，则此 Analysis Services 实例可以链接到其他 Analysis Services 实例上的对象。

有关链接对象的详细信息，请参阅 SQL Server 联机丛书中的链接维度 (SSAS) 和链接度量值组 (SSAS)。

启用来自其他实例的链接

如果选中此选项，则其他 Analysis Services 实例可以链接到此实例上的对象。

有关链接对象的详细信息，请参阅 SQL Server 联机丛书中的链接维度 (SSAS) 和链接度量值组 (SSAS)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器（用户定义函数）- Analysis Services

功能的外围应用配置器（用户定义函数）- Analysis Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

使用 Analysis Services 可以加载包含用户定义函数的程序集。这些函数可以基于公共语言运行时 (CLR)，也可以是组件对象模型 (COM) 对象。使用 CLR 开发的对象可以使用 CLR 安全模式进行保护。COM 对象则不支持此安全模式。除非您的应用程序要求使用用户定义的 COM 对象，否则请禁用加载这些对象的功能。

选项

启用用户定义的 COM 函数的加载

如果选中此选项，Analysis Services 将可以加载用户定义的 COM 函数。

有关配置服务器选项的详细信息，请参阅 Microsoft SQL Server 联机丛书中的 sp_configure (Transact-SQL)。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器（预定的事件和报表传递）- Reporting Services

功能的外围应用配置器（预定的事件和报表传递）- Reporting Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

在 Reporting Services 中，可以安排报表传递、报表快照和报表缓存过期时间。如果不需要订阅功能或按特定日期和时间运行计划报表的功能，可以禁用计划和传递处理。请注意，如果禁用此功能，则报表只能按需运行，将无法使用电子邮件和共享文件夹传递。

选项

启用预定的事件和报表传递

如果选中此选项，则将启用预定的事件和报表传递。

有关详细信息，请参阅 Microsoft SQL Server 联机丛书中的计划和传递处理器。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器（Web 服务和 HTTP 访问）- Reporting Services

功能的外围应用配置器（Web 服务和 HTTP 访问）- Reporting Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

您可以配置报表服务器 Web 服务以忽略所有简单对象访问协议 (SOAP) 请求和 URL 访问请求。如果没有使用 Web 服务的客户端应用程序，并且此 Reporting Services 安装不需要报表管理器、报表生成器或 Microsoft SQL Server Management Studio，请禁用 HTTP 和 Web 服务请求。

选项

启用 Web 服务和 URL 访问

如果选中此选项，Reporting Services 将允许使用 SOAP 和 URL 访问的连接。

有关详细信息，请参阅 SQL Server 联机丛书中的Report Server Web Service和 URL Access。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


功能的外围应用配置器（Windows 集成安全性）- Reporting Services

功能的外围应用配置器（Windows 集成安全性）- Reporting Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 功能的外围应用配置器 >

在 Reporting Services 中，报表数据源可以使用 Windows 集成安全性来连接到外部数据源。不过，使用 Windows 集成安全性可能允许他人在用户不知情的情况下以该用户的身份访问数据。若要确保所有的报表数据源连接均使用显式指定的凭据集，请对报表数据源禁用 Windows 集成安全性。有关集成安全性可能给敏感数据带来危险的原因的详细信息，请参阅集成安全性和提升权限。

如果禁用 Windows 集成安全性，用于配置报表数据源凭据的选项将会减少。在报表管理器、Management Studio 和用于定义报表数据源连接的任何第三方工具中，都将应用缩减后的选项集来定义数据源。在禁用 Windows 集成安全性之后，仅能通过以下方式获取凭据：

  • 提示凭据。系统将提示用户键入用户名和密码来运行报表。凭据可以是 Windows 域凭据或数据库凭据。

  • 存储的凭据。用于运行报表的凭据安全地存储在报表服务器数据库中。凭据可以是 Windows 域凭据或数据库凭据。对于每个数据源，只能存储一组凭据。所有用户都将使用相同的凭据访问该报表数据源。

  • 无凭据。如果数据源不需要凭据或允许通过连接字符串传递凭据，则可使用此选项。由于凭据将在数据源属性页上以纯文本形式显示，因此不建议使用此选项。若要使用此选项，则必须配置用于无人参与报表执行的专用帐户。有关详细信息，请参阅配置用于无人参与的报表处理的帐户。

注意：
禁用 Windows 集成安全性后，报表管理器、Management Studio 和报表设计工具中的“使用 Windows 集成安全性”选项并不会删除。如果用户在不支持 Windows 集成安全性的报表服务器上选择了该项，则在执行报表时将发生错误。

选项

对报表数据源连接启用 Windows 集成安全性

对报表数据源使用 Windows 集成安全性。

有关详细信息，请参阅集成安全性和提升权限和指定凭据和连接信息。

请参阅

概念

功能的外围应用配置器
服务和连接的外围应用配置器


服务和连接的外围应用配置器

服务和连接的外围应用配置器 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 >

功能的外围应用配置器工具提供了一个单一界面，在其中可以启用或禁用 Microsoft SQL Server 2005 服务以及用于远程连接的网络协议。禁用未使用的服务和连接类型可减少 SQL Server 外围应用，有助于保护 SQL Server 安装。

下表列出了每个设置的默认值，并提供指向 F1 帮助主题的链接。

Windows 服务和网络协议默认值

服务或协议 默认设置 F1 帮助主题

数据库引擎 服务

在安装过程中，可以将启动设置为“自动”或“手动”。

服务和连接的外围应用配置器（服务）- 数据库引擎

数据库引擎 远程连接

在 SQL Server 2005 Express Edition、Evaluation Edition 和 Developer Edition 中禁用了远程连接，而在其他版本中启用了远程连接。

服务和连接的外围应用配置器（远程连接）- 数据库引擎

Analysis Services 服务

在安装过程中，可以将启动设置为“自动”或“手动”。

服务和连接的外围应用配置器（服务）- Analysis Services

Analysis Services 远程连接

在 SQL Server 2005 Express Edition、Evaluation Edition 和 Developer Edition 中禁用了远程连接，而在其他版本中启用了远程连接。

服务和连接的外围应用配置器（远程连接）- Analysis Services

Reporting Services 服务

在安装过程中，可以将启动设置为“自动”或“手动”。

服务和连接的外围应用配置器（服务）- Reporting Services

SQL Server Agent 服务

如果安装此项，启动类型将设置为“手动”并停止该服务。

服务和连接的外围应用配置器（服务）- SQL Server Agent

Full-text Search 服务

如果安装此项，启动类型将设置为“手动”并停止该服务。

服务和连接的外围应用配置器（服务）- Full-Text Search

Notification Services 实例服务

安装过程中不安装这些服务。

服务和连接的外围应用配置器（服务）- Notification Services

Integration Services 服务

如果安装此项，该服务将设置为“自动”启动模式。

服务和连接的外围应用配置器（服务）- Integration Services

SQL Server Browser 服务

在以下情况时启动将设置为“自动”：

  • 服务器上已有数据库引擎或 Analysis Services 的命名实例

  • 安装在群集上

  • 与 SQL Server 2000 并行安装

服务和连接的外围应用配置器（服务）- SQL Server Browser

请参阅

概念

SQL Server 外围应用配置器
功能的外围应用配置器


服务和连接的外围应用配置器（服务）- 数据库引擎

服务和连接的外围应用配置器（服务）- 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 服务和连接的外围应用配置器 >

只有在安装了数据库引擎的实例之后才会安装数据库引擎 Windows 服务。使用此对话框可更改该实例的服务设置。

选项

服务名称

服务的名称。

显示名称

在 Microsoft Windows 服务面板的“名称”列中显示的名称。

说明

服务说明，该说明还会显示在 Windows 服务面板的“说明”列中。

启动类型

用于配置服务的启动方式。

选择“自动”将指定服务在系统启动时启动。

选择“手动”将指定特定的用户或依赖的服务可启动该服务，并且服务在系统启动时不启动。

选择“禁用”将禁止系统、用户或任何依赖的服务启动该服务。

服务状态

显示服务的状态。

“启动”按钮

启动服务。

“停止”按钮

停止服务。

“暂停”按钮

暂停服务。

“恢复”按钮

恢复暂停的服务。

请参阅

概念

服务和连接的外围应用配置器
功能的外围应用配置器


服务和连接的外围应用配置器（远程连接）- 数据库引擎

服务和连接的外围应用配置器（远程连接）- 数据库引擎 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 服务和连接的外围应用配置器 >

默认情况下，SQL Server 2005 Express Edition、Evaluation Edition 和 Developer Edition 只允许本地客户端连接。Enterprise Edition、Standard Edition 和 Workgroup Edition 还可侦听 TCP/IP 上的远程客户端连接。使用“远程连接”页可以更改 SQL Server 侦听传入客户端连接时使用的协议。TCP/IP 优先于 named pipes，因为前者通过防火墙时要求开放的端口较少。

“远程连接”页上的这些设置只影响传入连接，而不影响服务器传出连接（例如用于分布式查询的连接）。

注意：
您必须重新启动数据库引擎实例的服务，才可以应用更改。

选项

仅限本地连接

如果选择此选项，数据库引擎实例将只侦听本地计算机上的 shared memory 连接。来自远程计算机的连接将失败。

注意：
专用管理员连接端口是单独配置的。请参阅功能的外围应用配置器 (DAC) - 数据库引擎。

本地连接和远程连接

如果选择此选项，数据库引擎实例将侦听来自本地计算机以及来自远程计算机的使用所选协议的连接。

仅使用 TCP/IP 协议

如果选择此选项，数据库引擎实例将侦听使用 TCP/IP 而不是 Named Pipes 的远程连接。

仅使用 Named Pipes 协议

如果选择此选项，数据库引擎实例将侦听使用 Named Pipes 而不是 TCP/IP 的远程连接。

同时使用 TCP/IP 和 Named Pipes 协议

如果选择此选项，数据库引擎实例将侦听同时使用 TCP/IP 和 Named Pipes 的远程连接。

请参阅

概念

服务和连接的外围应用配置器
功能的外围应用配置器


服务和连接的外围应用配置器（服务）- Analysis Services

服务和连接的外围应用配置器（服务）- Analysis Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 服务和连接的外围应用配置器 >

Analysis Services Windows 服务随 Analysis Services 一起安装。使用此对话框可更改服务设置。

选项

服务名称

服务的名称。

显示名称

在 Microsoft Windows 服务面板的“名称”列中显示的名称。

说明

服务说明，该说明还会显示在 Windows 服务面板的“说明”列中。

启动类型

用于配置服务的启动方式。

选择“自动”将指定服务在系统启动时启动。

选择“手动”将指定特定的用户或依赖的服务可启动该服务，并且服务在系统启动时不启动。

选择“禁用”将禁止系统、用户或任何依赖的服务启动该服务。

服务状态

显示服务的状态。

“启动”按钮

启动服务。

“停止”按钮

停止服务。

“暂停”按钮

暂停服务。

“恢复”按钮

恢复暂停的服务。

请参阅

概念

SQL Server 外围应用配置器
服务和连接的外围应用配置器


服务和连接的外围应用配置器（远程连接）- Analysis Services

服务和连接的外围应用配置器（远程连接）- Analysis Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 服务和连接的外围应用配置器 >

在 Microsoft SQL Server 2005 Express Edition、Developer Edition 和 Evaluation Edition 中，默认情况下将禁用远程连接。在其他版本中，默认情况下将禁用远程连接。

为 Analysis Services 启用远程连接会打开服务器上的 TCP/IP 端口。只有在希望允许来自远程计算机的连接时，才应启用远程连接。

注意：
必须重新启动 Analysis Services 服务，才可应用协议更改。

选项

仅限本地连接

Analysis Services 实例仅侦听本地计算机上的连接。来自远程计算机的连接将失败。

本地连接和远程连接

Analysis Services 实例使用 TCP/IP 侦听来自本地计算机和远程计算机的连接。

请参阅

概念

服务和连接的外围应用配置器
功能的外围应用配置器


服务和连接的外围应用配置器（服务）- Reporting Services

服务和连接的外围应用配置器（服务）- Reporting Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 服务和连接的外围应用配置器 >

只有在安装了 Reporting Services 之后才会安装 Reporting Services Windows 服务。使用此对话框可更改服务设置。

选项

服务名称

服务的名称。

显示名称

显示在 Microsoft Windows 服务面板的“名称”列中的名称。

说明

服务说明，该说明还会显示在 Windows 服务面板的“说明”列中。

启动类型

配置服务的启动方式。

选择“自动”将指定服务在系统启动时启动。

选择“手动”将指定特定的用户或依赖的服务可启动该服务，并且服务在系统启动时不启动。

选择“禁用”将禁止系统、用户或任何依赖的服务启动该服务。

服务状态

显示服务的状态。

“启动”按钮

启动服务。

“停止”按钮

停止服务。

“暂停”按钮

暂停服务。

“恢复”按钮

恢复暂停的服务。

请参阅

概念

服务和连接的外围应用配置器
功能的外围应用配置器


服务和连接的外围应用配置器（服务）- SQL Server Agent

服务和连接的外围应用配置器（服务）- SQL Server Agent |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 服务和连接的外围应用配置器 >

Microsoft SQL Server Agent Windows 服务随数据库引擎实例一起安装。默认情况下，将禁用并停止此服务。若要使用自动管理，则必须启用此服务。使用此对话框可更改服务设置。有关配置 SQL Server Agent 服务帐户的详细信息，请参阅 Microsoft SQL Server 2005 联机丛书中的为 SQL Server 代理服务选择帐户。

选项

服务名称

服务的名称。

显示名称

显示在 Windows 服务面板的“名称”列中的名称。

说明

服务的说明（也会显示在 Microsoft Windows 服务面板的“说明”列中）。

启动类型

用于配置服务的启动方式。

选择“自动”将指定服务在系统启动时启动。

选择“手动”将指定特定的用户或依赖的服务可启动该服务，并且服务在系统启动时不启动。

选择“禁用”将禁止系统、用户或任何依赖的服务启动该服务。

服务状态

显示服务的状态。

“启动”按钮

启动服务。

“停止”按钮

停止服务。

“暂停”按钮

暂停服务。

“恢复”按钮

恢复暂停的服务。

请参阅

概念

服务和连接的外围应用配置器
功能的外围应用配置器


服务和连接的外围应用配置器（服务）- Full-Text Search

服务和连接的外围应用配置器（服务）- Full-Text Search |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 服务和连接的外围应用配置器 >

只有在安装了数据库引擎时，才会安装 Microsoft Full-Text Engine for Microsoft SQL Server service (MSFTE) 服务。使用此对话框可更改服务设置。

选项

服务名称

服务的名称。

显示名称

在 Microsoft Windows 服务面板的“名称”列中显示的名称。

说明

服务说明，该说明还会显示在 Windows 服务面板的“说明”列中。

启动类型

用于配置服务的启动方式。

选择“自动”将指定服务在系统启动时启动。

选择“手动”将指定特定的用户或依赖的服务可启动该服务，并且服务在系统启动时不启动。

选择“禁用”将禁止系统、用户或任何依赖的服务启动该服务。

服务状态

显示服务的状态。

“启动”按钮

启动服务。

“停止”按钮

停止服务。

“暂停”按钮

暂停服务。

“恢复”按钮

恢复暂停的服务。

请参阅

概念

服务和连接的外围应用配置器
功能的外围应用配置器


服务和连接的外围应用配置器（服务）- Notification Services

服务和连接的外围应用配置器（服务）- Notification Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 服务和连接的外围应用配置器 >

可以在部署 Notification Services 的实例时安装 Notification Services Windows 服务。在安装 Notification Services 时不会安装 Microsoft Windows 服务。如果已在服务器上安装了一个或多个 Notification Services Windows 服务，使用此对话框可以更改服务设置。

选项

服务名称

服务的名称。

显示名称

显示在 Windows 服务面板的“名称”列中的名称。

说明

服务说明，该说明还会显示在 Windows 服务面板的“说明”列中。

启动类型

用于配置服务的启动方式。

选择“自动”将指定服务在系统启动时启动。

选择“手动”将指定特定的用户或依赖的服务可启动该服务，并且服务在系统启动时不启动。

选择“禁用”将禁止系统、用户或任何依赖的服务启动该服务。

服务状态

显示服务的状态。

“启动”按钮

启动服务。

“停止”按钮

停止服务。

“暂停”按钮

暂停服务。

“恢复”按钮

恢复暂停的服务。

请参阅

概念

服务和连接的外围应用配置器
功能的外围应用配置器


服务和连接的外围应用配置器（服务）- Integration Services

服务和连接的外围应用配置器（服务）- Integration Services |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 服务和连接的外围应用配置器 >

只有在安装了 Integration Services 的情况下，才能安装 Integration Services Windows 服务。使用此对话框可更改服务设置。

选项

服务名称

服务的名称。

显示名称

在 Microsoft Windows 服务面板的“名称”列中显示的名称。

说明

服务说明，该说明还会显示在 Windows 服务面板的“说明”列中。

启动类型

用于配置服务的启动方式。

选择“自动”将指定服务在系统启动时启动。

选择“手动”将指定特定的用户或依赖的服务可启动该服务，并且服务在系统启动时不启动。

选择“禁用”将禁止系统、用户或任何依赖的服务启动该服务。

服务状态

显示服务的状态。

“启动”按钮

启动服务。

“停止”按钮

停止服务。

“暂停”按钮

暂停服务。

“恢复”按钮

恢复暂停的服务。

请参阅

概念

SQL Server 外围应用配置器
服务和连接的外围应用配置器


服务和连接的外围应用配置器（服务）- SQL Server Browser

服务和连接的外围应用配置器（服务）- SQL Server Browser |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 > 服务和连接的外围应用配置器 >

SQL Server Browser 服务可将命名管道和 TCP 端口信息返回到客户端应用程序。如果某命名实例的管道名称或端口号对于客户端应用程序是未知的，则启用此服务十分有用。如果禁用此服务，则可以为数据库引擎命名实例选择静态端口，然后在客户端连接中指定端口号。对于 Analysis Services 命名实例，最好启用 SQL Server Browser 服务。

选项

服务名称

服务的名称。

显示名称

显示在 Windows 服务面板的“名称”列中的名称。

说明

服务的说明（也会显示在 Microsoft Windows 服务面板的“说明”列中）。

启动类型

用于配置服务的启动方式。

选择“自动”将指定服务在系统启动时启动。

选择“手动”将指定特定的用户或依赖的服务可启动该服务，并且服务在系统启动时不启动。

选择“禁用”将禁止系统、用户或任何依赖的服务启动该服务。

服务状态

显示服务的状态。

“启动”按钮

启动服务。

“停止”按钮

停止服务。

“暂停”按钮

暂停服务。

“恢复”按钮

恢复暂停的服务。

请参阅

概念

服务和连接的外围应用配置器
功能的外围应用配置器


sac 实用工具

sac 实用工具 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 外围应用配置器 >

sac 实用工具可以导入和导出 Microsoft SQL Server 2005 外围应用设置。使用此实用工具，您可以在一台计算机上配置外围应用，然后将相同的设置应用于其他计算机。

使用 sac 实用工具最简单的方法是使用 SQL Server 外围应用配置器图形用户界面先配置一台计算机，然后使用 sac 将该计算机的设置导出到一个文件。接着，可使用 sac 将所有 SQL Server 2005 组件的设置应用到本地计算机或远程计算机的其他 SQL Server 2005 实例中。

此实用工具位于 x:\Program Files\Microsoft SQL Server\90\Shared 中。

语法

sac {in | out} filename [-S computer_name]
    [-U SQL_login [–P SQL_ password]]
    [-I instance_name ]
    [-DE] [-AS] [-RS] [-IS] [-NS] [-AG] [-BS] [-FT] [-AD]
    [-F] [-N] [-T] [-O]
    [-H | -?]

参数

in

从一个文件导入外围应用设置，并使用这些设置配置由 instance_name 指定的实例。

out

将外围应用配置器设置从一个实例导出到在 filename 中指定的文件。

filename

导入或导出外围应用设置时所用文件的完整路径。

-S computer_name

指定远程计算机的名称。如果未指定该参数，则 sac 将连接到本地计算机。

-U SQL_login

指定用于连接到数据库引擎的 SQL Server 身份验证登录名。如果未指定，则 sac 将使用 Windows 身份验证连接到数据库引擎。

-P SQL_password

指定 SQL_login 的密码。如果未指定该参数，则 sac 将提示输入密码。如果在命令的末尾指定 -P 但未赋值，则 sac 将使用空密码。

-I instance_name

指定要对其运行 sac 的 SQL Server 实例。如果未指定该选项，则 sac 将连接到所有 SQL Server 实例。对于默认实例，该实例的名称为 MSSQLServer。

-DE

导入或导出数据库引擎 设置。

-AS

导入或导出 Analysis Services 设置。

-RS

导入或导出 Reporting Services 设置。

-IS

导入或导出 Integration Services 设置。

-NS

导入或导出 Notification Services 设置。

-AG

导入或导出 SQL Server 代理设置。

-BS

导入或导出 SQL Server Browser 服务设置。

-FT

导入或导出全文搜索服务设置。

-F

导入或导出指定组件的以下功能的状态：

组件 功能

数据库引擎

即席远程查询

CLR 集成

DAC

数据库邮件

本机 XML Web 服务

OLE 自动化

SQL Server Service Broker

SQL Mail

Web 助手

xp_cmdshell

Analysis Services

即席数据挖掘查询

匿名连接

链接对象

用户定义函数

Reporting Services

预定的事件和报表传递

Web 服务和 HTTP 访问

Windows 集成安全性
-N

导入或导出指定组件的远程连接网络协议的状态。只有数据库引擎 和 Analysis Services 提供了配置远程连接的选项。

-T

导入或导出指定组件的 Windows 服务的状态。

-O

指定接收来自 sac 的命令行输出的文件的名称。

-H | -?

显示命令语法。其他参数将被忽略。

备注

sac 适用下列规则：

  • 参数不区分大小写。

  • 命令参数前有一个连字符 (-) 或正斜杠 (/)。这两种符号等价。

  • 在参数及其值之间有一个空格。

  • 将包含特殊字符的值用英文引号括起来。

示例

以下示例显示了 sac 实用工具的常见使用情况：

A. 导出所有默认实例设置

以下示例显示了如何将默认 SQL Server 实例的所有功能、连接和服务设置导出到文件 server1.out。因为该示例指定了用户名但未指定密码，所以 sac 将提示输入密码。

复制代码
sac out server1.out –S server1 –U admin –I MSSQLSERVER

B. 将功能设置导入到其他服务器

以下示例只导入 server1.out 文件的功能设置，并将其应用于服务器 2 中的默认 SQL Server 实例。因为此示例未提供用户名称，所以 sac 将使用 Windows 身份验证。

复制代码
sac in server1.out –S server2 –F

C. 导入所有本地功能和网络设置

以下示例将本地服务器的所有 SQL Server 实例和组件的所有功能和连接设置导出到文件 server1.out，但不导出服务设置。

复制代码
sac out server1.out –F –N

D. 导入所有设置

以下示例将文件 server1.out 中的所有可用设置导入到 server2。

复制代码
sac in server1.out –S server2

E. 导出所有数据库引擎设置

以下示例将本地服务器的所有数据库引擎实例的所有设置导出到文件 server1.out。

复制代码
sac out server1.out –DE

F. 导入服务状态设置

以下示例只导入 server1.out 的服务状态设置，并将服务设置应用于 server2。

复制代码
sac in server1.out –S server2 -T

请参阅

概念

SQL Server 外围应用配置器

其他资源

命令提示实用工具


Reporting Services 配置

Reporting Services 配置 |
 | 请参阅
配置 SQL Server 安装 >

使用 Reporting Services 配置工具可以配置 SQL Server 2005 Reporting Services 的安装。如果使用仅安装文件选项安装报表服务器，必须使用此工具来配置服务器，否则服务器将不可用。如果以前安装报表服务器时使用的是默认配置安装选项，则可以使用此工具来验证或修改在安装过程中指定的设置。如果从以前的版本升级，可以使用此工具将报表服务器数据库升级为新格式。

Reporting Services 配置可以用来配置本地或远程报表服务器实例。您必须对承载要配置的报表服务器的计算机具有本地系统管理员权限。

注意：
Reporting Services 配置工具使用图标来指示是否已配置设置。配置的设置可能无效。应始终测试 Reporting Services 安装以确保其工作正常。表示配置状态的可视指示符不能代替用于验证部署是否成功的测试。有关如何验证部署的详细信息，请参阅如何验证 Reporting Services 安装。

本节内容

主题 | 说明
启动和停止报表服务器 Windows 服务 | 介绍如何启动和停止报表服务器 Windows 服务。
更改服务帐户和密码 | 为如何修改服务帐户和密码提供建议和步骤。
Renaming a Report Server Computer | 介绍在重命名服务器运行的计算机时，如何更新 Reporting Services 安装。
将报表服务器数据库移至另一台计算机 | 说明如何将报表服务器数据库移到另一台计算机。
创建报表服务器数据库 | 介绍如何创建存储服务器元数据和对象所必需的报表服务器数据库。
配置报表服务器数据库连接 | 介绍如何修改报表服务器用来连接报表服务器数据库的连接字符串。
配置报表服务器虚拟目录 | 介绍如何创建用来访问报表服务器和报表管理器的虚拟目录。
配置报表服务器以进行电子邮件传递 | 介绍如何配置报表服务器，以便通过电子邮件来分发报表。
配置用于无人参与的报表处理的帐户 | 介绍如何配置用户帐户以便以无人参与的方式处理报表。
配置用于 Internet 访问的报表服务器 | 介绍多种将报表部署到面向 Internet 的 Web 服务器上的方法。
配置报表服务器扩展部署 | 介绍如何配置多个报表服务器实例以使用共享报表服务器数据库。
管理加密密钥 | 介绍如何使用和管理存储敏感数据时使用的加密密钥。
Reporting Services 配置“如何”主题 | 提供常见任务的分步说明。
Reporting Services 配置的 F1 帮助 | 提供 Reporting Services 配置工具页面的帮助主题。

在 SQL Server 2005 联机丛书中

Reporting Services 配置工具的联机帮助是 SQL Server 2005 Reporting Services 产品文档的子集。可在 SQL Server 2005 联机丛书中找到完整的产品文档。

当使用 SQL Server 联机丛书时，您可以访问此联机帮助系统提供的所有主题，以及关于部署、管理和保护 Reporting Services 安装的其他内容。有关详细信息，请参阅 如何访问 SQL Server 2005 联机丛书。

请参阅

概念

安装 SQL Server Reporting Services
升级 Reporting Services
配置 SQL Server 安装

其他资源

Reporting Services 安装帮助主题


配置报表服务器虚拟目录

配置报表服务器虚拟目录 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

在 SQL Server 2005 Reporting Services 中，通过包含专为每个组件配置的专用虚拟目录的 URL 来访问报表服务器和报表管理器。

  • 报表管理器虚拟目录用于访问报表管理器。默认情况下，报表管理器的虚拟目录名称为 reports。

  • 报表服务器虚拟目录允许以编程方式访问报表服务器 Web 服务 SOAP 端点。该目录还是为报表服务器中存储的报表、资源、模型、共享数据源和文件夹提供 URL 寻址服务的报表服务器文件夹命名空间的根节点。默认情况下，报表服务器的虚拟目录名称为 reportserver。

虚拟目录是完整 URL 的一部分，用于访问报表管理器和报表服务器。URL 的其他部分包括一个前缀（如 http:// 或 https://）和一个服务器名（如 localhost 或 sales01）。如果使用默认配置安装 Reporting Services 作为命名实例，则安装程序将使用实例名来创建一个唯一的报表服务器虚拟目录。例如，如果按默认配置安装具有高级服务的 SQL Server 2005 Express Edition，则安装程序将使用 reportserver$SQLEXPRESS 作为虚拟目录名。以下是一些报表服务器 URL 的示例：

  • http://localhost/reportserver

  • http://localhost/reportserver$SQLEXPRESS

  • http://localhost/reportserver

  • http://adventure-works.com/results.aspx

  • https://www.adventure-works.com:8080/reportserver01

虚拟目录配置

报表服务器和报表管理器虚拟目录都必须在现有 Web 站点中创建。可以使用默认网站，也可以使用自定义网站。您可以为这两个虚拟目录使用同一个网站。对于网站没有特殊要求。所有安全性、ASP.NET、路径、权限和其他设置都要在虚拟目录中配置。

使用 Reporting Services 配置工具创建虚拟目录时，会自动配置报表服务器 Web 服务标识。所使用的 Internet 信息服务 (IIS) 的版本决定 Web 服务标识：

  • 在 IIS 6.0 中，包含网站的应用程序池决定 Web 服务标识。

  • 在 IIS 5.0 中，Web 服务标识始终为 ASP.NET 进程标识。

Reporting Services 虚拟目录配置为使用 ASP.NET 2.0（这是随 SQL Server 安装的版本）。如果您的 Web 服务器正在运行早期版本的 ASP.NET，请确保不同版本的 ASP.NET 彼此互不冲突。两个主要版本的 ASP.NET 不能在同一进程中运行。在 IIS 6.0 中，如果为每个版本使用单独的应用程序池，则可以并行运行不同版本的 ASP.NET。在 IIS 5.0 中，每个版本的 ASP.NET 自动作为一个单独的进程运行。

报表服务器虚拟目录配置为用于 Intranet 访问。默认情况下禁用匿名访问。在大多数情况下，报表服务器 URL 使用网络计算机名称。若要为 Internet 连接配置 Reporting Services，您可能需要修改报表服务器配置文件。有关详细信息，请参阅本主题中的“Reporting Services 中使用的 URL”部分以及配置用于 Internet 访问的报表服务器。

若要创建和配置虚拟目录，请使用 Reporting Services 配置工具。

若要为报表服务器 Web 服务指定应用程序池，请使用 Reporting Services 配置工具中的“Web 服务标识”页。

若要将报表服务器或报表管理器配置为使用端口号为非 80 的端口，请将要使用的端口号追加到 rsreportserver.config 文件中的 UrlRoot 设置。下面的示例说明了要使用的语法：

IIS 中的报表服务器虚拟目录配置

与所有虚拟目录一样，可以通过 Microsoft Internet 信息服务 (IIS) 进一步自定义报表服务器和报表管理器虚拟目录。只有在部署自定义安全扩展插件时，才需要进一步自定义。如果在自定义设置后导致部署被破坏，可以使用 Reporting Services 配置工具将虚拟目录重置为使用默认配置。

重定向到报表管理器虚拟目录

通过 IIS，可以将报表管理器用作 Web 服务器的默认主页。若要配置重定向，请使用以下设置：

  1. 右键单击承载报表管理器的网站，并选择“属性”。

  2. 单击“主目录”选项卡。

  3. 单击“重定向到 URL”。

  4. 在“重定向到:”中，键入 /reports。如果文本框中包含“http://”，请将其删除。

  5. 如果使用的是 IIS 6.0，请选择“输入的 URL 下的目录”。如果使用的是 IIS 5.0，请选择“此位置下的目录”选项。

  6. 单击“确定”。

Reporting Services 中使用的 URL

Reporting Services 配置文件支持各种包含所配置的虚拟目录的 URL 设置。下表简要介绍了可以在 Reporting Services 安装中指定的所有 URL。您可以使用说明来查看 URL 之间的比较。该表并未说明用来访问报表服务器数据库中存储的报表或其他项的 URL 地址。有关通过 URL 地址访问报表项的详细信息，请参阅 SQL Server 联机丛书中的Using a URL to Access Report Server Items。

设置 说明

ReportServerVirtualDirectory

指定报表管理器使用的报表服务器的 SOAP 端点。有效值包括报表服务器虚拟目录的名称。例如，如果报表服务器的 URL 为 http://adventure-works.com/reportserver，则 ReportServerVirtualDirectory 设置的值为 reportserver。报表管理器使用 localhost 连接报表服务器。如果未启用 localhost，则可使用 ReportServerUrl 代替。

此设置在 RSWebApplication.config 文件中定义。此值是在安装过程中或在配置报表管理器虚拟目录时通过 Reporting Services 配置工具创建的。您也可以编辑配置文件以修改该值。

此设置需要将报表管理器和报表服务器配置为使用同一个网站。如果它们使用不同的网站，请删除 ReportServerVirtualDirectory 的值并改用 ReportServerUrl。

ReportServerUrl

提供另一种指定报表管理器所用报表服务器的 SOAP 端点的方法。当报表管理器和报表服务器虚拟目录承载于不同的服务器或网站上时，可以用此设置替代 ReportServerVirtualDirectory。

若要指定此设置，必须手动编辑 RSWebApplication.config 文件。有效值包括 http://<服务器>/<报表服务器> 或者 https://<服务器>/<报表服务器>（如果使用证书）。如果在面向 Internet 的 Web 服务器上单独安装报表管理器，此值必须为可用来访问位于防火墙后面的报表服务器实例的完全限定域名。绝对不能将此值设置为 localhost。

如果安装了安全套接字层 (SSL) 证书，则此值必须是为该证书注册的服务器的名称。如果您得到错误消息“基础连接已经关闭: 未能为 SSL/TLS 安全通道建立信任关系”，请将 ReportServerUrl 设置为颁发证书所针对的服务器的完全限定域名。例如，如果该证书注册到 https://adventure-works.com.onlinesales，则报表服务器 URL 应为 https://adventure-works.com.onlinesales/reportserver。

ReportServerUrl 和 ReportServerVirtualDirectory 是互斥的。如果指定了 ReportServerUrl，则必须删除 ReportServerVirtualDirectory 项。

ReportServerExternalUrl

这是一个特殊用途的 URL，报表生成器客户端组件使用该 URL 来通过 Internet 连接向报表服务器发出 SOAP 请求。此设置与 ReportServerUrl 一起使用。当 SOAP 请求因未包含足够的信息而无法将请求路由至报表服务器实例时，则可以在部署中使用此设置。若要使用此设置，必须手动将其添加到 RSWebApplication.config 文件中。有效值包括此值的完全限定域名。

UrlRoot

传递扩展插件使用此值来编写在访问存储于报表服务器中的项时所使用的 URL。例如，如果使用的是 Report Server 电子邮件传递扩展插件，则可使用 UrlRoot 值来创建指向正在被分配的报表的超链接。

可以在安装过程中或通过 Reporting Services 配置工具（如果以“仅文件”安装模式安装报表服务器）指定此值。该值必须为报表服务器的有效 URL 地址。此设置在 RSReportServer.config 文件中指定。

请参阅

任务

如何配置 Reporting Services 以使用非默认网站（Reporting Services 配置）

概念

报表服务器虚拟目录（Reporting Services 配置）

其他资源

配置 Reporting Services 组件

更改历史记录

版本 历史记录

2006 年 4 月 14 日

新增内容：
  • 指定默认虚拟目录名称。


管理报表服务器数据库

管理报表服务器数据库 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

报表服务器数据库为报表服务器提供了内部存储位置。您可以在安装期间或在配置报表服务器时创建该数据库。同时会创建用于存储会话和缓存信息的临时数据库。

在 Reporting Services 中，数据库管理任务包括备份和还原报表服务器数据库，以及管理用于加密和解密敏感数据的加密密钥。

SQL Server 提供了许多工具用于管理报表服务器数据库。

  • 若要备份、复制或还原报表服务器数据库，可以使用 SQL Server Management Studio、Transact-SQL 命令或数据库命令提示实用工具。

  • 若要将现有数据库内容复制到另一个报表服务器数据库中，可以使用 rs 实用工具运行脚本。

  • 若要管理报表服务器与报表服务器数据库间的连接，以及查找用于特定报表服务器实例的数据库，可以使用 Reporting Services 配置工具中的“数据库安装”页。若要了解有关报表服务器与报表服务器数据库的连接的详细信息，请参阅配置报表服务器数据库连接。

  • 若要重命名或移动报表服务器数据库，请参阅 SQL Server 联机丛书中的Renaming a Report Server Database和将报表服务器数据库移至另一台计算机。

若要收集有关报表服务器性能和活动的度量信息，请参阅 SQL Server 联机丛书中的查询和报告报表执行日志数据。

关于数据库版本

在 Reporting Services 中，未提供有关数据库版本的显式信息。但是，由于数据库版本始终与产品版本同步，可以使用产品版本信息来了解数据库版本的更改时间。Reporting Services 的产品版本信息是通过出现在日志文件、所有 SOAP 调用的标题中的文件版本信息指示的；连接到报表服务器 URL（例如，打开浏览器浏览 http://localhost/reportserver）时也会指示 Reporting Services 的产品版本信息。

请参阅

概念

创建报表服务器数据库

其他资源

Reporting Services 安装的备份和还原操作
报表服务器数据库
部署 Reporting Services
管理 Reporting Services
报表服务器数据库要求
存储临时报表服务器数据
存储加密的报表服务器数据
管理加密密钥


创建报表服务器数据库

创建报表服务器数据库 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

Reporting Services 使用两个 SQL Server 关系数据库存储报表服务器元数据和对象。一个数据库用于主存储，另一个数据库用于存储临时数据。这两个数据库一起创建，并按名称绑定。两个数据库的默认名称分别为 reportserver 和 reportservertempdb。这两个数据库统称为“报表服务器数据库”或“报表服务器目录”。可以使用 SQL Server 2000 或 SQL Server 2005 承载数据库。

重要事项：
请不要编写对报表服务器数据库运行查询的应用程序。报表服务器数据库不是公用架构。从一个版本升级到下一个版本时可能会更改表结构。如果编写需要具有报表服务器数据库访问权限的应用程序，则应始终使用 Reporting Services API 来访问报表服务器数据库。

创建报表服务器数据库的方式

您可以通过以下方式创建报表服务器数据库：

  • 如果选择默认配置安装选项，则可通过安装程序自动创建。在 SQL Server 安装向导中，这是“报表服务器安装选项”页中的“安装默认配置”选项。如果选择“安装但不配置”选项，则必须使用 Reporting Services 配置工具来创建数据库。

  • 通过 Reporting Services 配置工具手动创建。有关说明，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

您可以在本地或远程 SQL Server 数据库引擎实例上创建报表服务器数据库。若要在远程计算机上创建报表服务器数据库，则需要将连接配置为使用域用户帐户或具有网络访问权限的服务帐户。如果决定使用远程 SQL Server 实例，请仔细考虑报表服务器应使用哪些凭据来连接 SQL Server 实例。有关详细信息，请参阅配置报表服务器数据库连接。

重要事项：
报表服务器和承载报表服务器数据库的 SQL Server 实例可以位于不同的域中。对于 Internet 部署，通常的做法是使用防火墙后的服务器。如果配置的报表服务器将供 Internet 访问，请使用 SQL Server 凭据连接防火墙后的 SQL Server 实例并使用 IPSEC 来保护连接。

创建不同版本的 SQL Server 中的报表服务器数据库

请注意，创建报表服务器数据库时，并非所有版本的 SQL Server 2005 都可用于承载数据库。下表显示了可用于特定版本的 Reporting Services 的数据库引擎版本。

SQL Server 2005 Reporting Services 版本 | 可用于承载数据库的数据库引擎实例版本
具有高级服务的 SQL Server 2005 Express Edition | 具有高级服务的 SQL Server 2005 Express Edition（仅本地）。
Workgroup Edition | Workgroup Edition（仅本地）
Evaluation Edition | Standard Edition、Evaluation Edition、Enterprise Edition（本地或远程）
Developer Edition | Standard Edition、Developer Edition、Enterprise Edition（本地或远程）
Standard Edition | Standard Edition、Enterprise Edition（本地或远程）
Enterprise Edition | Standard Edition、Enterprise Edition（本地或远程）

在升级的服务器上创建报表服务器数据库

在某些情况下，如果尝试在已从版本 7.0 升级的 SQL Server 实例上创建报表服务器数据库，可能会遇到异常。升级并不会设置 master 数据库的数据库兼容级别。因此，在设置该数据库时，Reporting Services 配置工具中将发生异常。有关如何在升级的服务器上创建数据库的详细信息，请参阅如何在从 SQL Server 7.0 升级的数据库引擎上配置报表服务器数据库（Reporting Services 配置）。

请参阅

任务

如何创建报表服务器数据库（Reporting Services 配置）

其他资源

报表服务器数据库
管理报表服务器数据库
Introducing Reporting Services Programming

更改历史记录

版本 历史记录

新增内容：
  • 创建不同版本中的报表服务器数据库


配置报表服务器数据库连接

配置报表服务器数据库连接 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

每个报表服务器实例都需要连接到存储由服务器管理的报表、报表模型、共享数据源、资源和元数据的报表服务器数据库。如果要安装默认配置，则可以在报表服务器安装过程中创建初始连接。多数情况下，可以在安装程序完成之后使用 Reporting Services 配置工具配置连接。您可以随时修改连接，以更改帐户类型或重置凭据。有关如何创建数据库并配置连接的分步说明，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

如果出现下列情况，则必须配置报表服务器数据库连接：

  • 为首次使用配置报表服务器。

  • 配置报表服务器以使用不同的报表服务器数据库。

  • 更改数据库连接所使用的用户帐户或密码。当帐户信息存储在 RSReportServer.config 文件中时，您只需要更新数据库连接。如果使用服务帐户进行连接（该帐户使用 Windows 集成安全性作为凭据类型），则不会存储密码，因此不需要更新连接信息。有关更改帐户的详细信息，请参阅更改服务帐户和密码。

  • 配置报表服务器扩展部署。配置扩展部署时，您需要创建多个到报表服务器数据库的连接。有关如何执行此多步操作的详细信息，请参阅如何配置报表服务器扩展部署（Reporting Services 配置）。

报表服务器根据凭据和连接信息以及对使用该数据库的报表服务器实例有效的加密密钥来访问报表服务器数据库。拥有有效的加密密钥对于存储和检索敏感数据是必要的。首次配置数据库时，会自动创建加密密钥。创建密钥之后，如果更改报表服务器 Windows 服务标识，则必须更新这些密钥。有关使用加密密钥的详细信息，请参阅管理加密密钥。

定义报表服务器数据库连接

若要配置连接，必须使用 Reporting Services 配置工具或 rsconfig 命令行配置工具。报表服务器需要以下连接信息：

  • 承载报表服务器数据库的 SQL Server 实例的名称。可以使用本地或远程的 SQL Server 2000 或 SQL Server 2005 数据库引擎实例。如果使用的是具有高级服务的 SQL Server 2005 Express Edition，则必须选择本地数据库引擎实例。

  • 报表服务器数据库的名称。首次创建连接时，可以创建新的报表服务器数据库，也可以选择现有的数据库。有关详细信息，请参阅创建报表服务器数据库。

  • 凭据类型。可以使用服务帐户、Windows 域帐户或 SQL Server 数据库登录名。

  • 用户名和密码（仅在使用 Windows 域帐户或 SQL Server 登录名时需要）。

必须为所提供的凭据授予访问报表服务器数据库的权限。如果使用 Reporting Services 配置工具，则自动执行此步骤。有关访问数据库所需权限的详细信息，请参阅本主题中的“数据库权限”一节。

存储数据库连接信息

Reporting Services 在下列 RSreportserver.config 设置中存储和加密连接信息。必须使用 Reporting Services 配置工具或 rsconfig 配置工具为这些设置创建加密值。

并非所有的值都针对每一种连接类型进行了设置。如果使用默认值配置连接（即使用服务帐户建立连接），则 <LogonUser>、<LogonDomain> 和 <LogonCred> 将为空，如下所示：

复制代码
<Dsn></Dsn>
<ConnectionType></ConnectionType>
<LogonUser></LogonUser>
<LogonDomain></LogonDomain>
<LogonCred></LogonCred>

如果将连接配置为使用特定的 Windows 帐户或数据库登录名，则在随后更改帐户或登录名时必须更新已存储的值。

选择凭据类型

可以在报表服务器数据库连接中使用三种类型的凭据：

  • 使用报表服务器 Web 服务和 Windows 服务帐户的 Windows 集成安全性。

  • Windows 用户帐户。如果报表服务器和报表服务器数据库安装在同一台计算机上，则可以使用本地帐户。否则，必须使用域帐户。

  • SQL Server 登录名。

注意：
不能使用自定义身份验证扩展插件来连接到报表服务器数据库。自定义身份验证扩展插件只能用来对报表服务器的主体进行身份验证。它们不会对与报表服务器数据库或为报表提供内容的外部数据源之间的连接产生任何影响。
使用服务帐户和集成安全性

可以使用 Windows 集成安全性通过报表服务器 Web 服务和 Windows 服务帐户进行连接。这两个服务帐户都被授予了登录报表服务器数据库的权限。如果按默认配置安装 Reporting Services，这将是安装程序选择的默认凭据类型。

服务帐户是可信帐户，这种帐户提供了一种只需较少维护即可管理报表服务器数据库连接的方法。由于服务帐户使用 Windows 集成安全性来建立连接，因此不需要存储凭据。如果后来更改了服务帐户密码，报表服务器可以在不中断连接的情况下自动使用更新后的凭据。如果更改了服务帐户标识（例如从内置帐户切换到域帐户），则必须在承载报表服务器数据库的 SQL Server 实例上更新该帐户的访问权限。

使用域用户帐户

可以指定使用单个帐户来连接到报表服务器数据库。报表服务器 Web 服务和 Windows 服务都将使用此帐户进行连接。如果使用本地帐户或域帐户，则每次更改密码或帐户时，必须更新报表服务器数据库连接。请始终使用 Reporting Services 配置工具来更新连接。

使用 SQL Server 登录名

可以指定使用单个 SQL Server 登录名连接到报表服务器数据库。如果使用 SQL Server 身份验证并且报表服务器数据库位于远程计算机上，则可以使用 IPSEC 来确保服务器之间数据传输的安全性。如果使用 SQL Server 登录名，报表服务器 Web 服务和 Windows 服务都将使用此帐户进行连接。如果使用数据库登录名，则每次更改密码或帐户时，必须更新报表服务器数据库连接。

数据库权限

用来连接到报表服务器数据库的帐户被授予了以下角色：

  • ReportServer 数据库的 public 和 RSExecRole 角色。

  • master、msdb 和 ReportServerTempDB 数据库的 RSExecRole 角色。

使用 Reporting Services 配置工具创建或修改连接时，将自动授予这些权限。如果使用 rsconfig 配置工具并且为该连接指定了不同的帐户，则必须为这一新帐户更新 SQL Server 登录名。可以在 Reporting Services 配置工具中创建用来更新报表服务器的 SQL Server 登录名的脚本文件。

验证数据库名称

使用 Reporting Services 配置工具可以查看特定报表服务器实例所使用的报表服务器数据库。若要查找该名称，请连接到该报表服务器实例并打开“数据库安装”页。

使用不同的报表服务器数据库或移动报表服务器数据库

可以通过更改连接信息将报表服务器实例配置为使用不同的报表服务器数据库。切换数据库的一个常见示例是部署生产报表服务器。通常，生产服务器是通过从测试报表服务器数据库切换到生产报表服务器数据库来实现的。您还可以将报表服务器数据库移动到另一台计算机上。有关详细信息，请参阅将报表服务器数据库移至另一台计算机和迁移 Reporting Services。

将多个报表服务器配置为使用同一个报表服务器数据库

可以将多个报表服务器配置为使用同一个报表服务器数据库。当希望在服务器群集中运行多个报表服务器时，通常可以考虑采用此部署配置作为扩展部署模型。不过，您也可以使用此配置来测试新的报表服务器实例的安装和设置，以便将其与按设计方式运行的现有报表服务器进行比较。有关详细信息，请参阅配置报表服务器扩展部署。

请参阅

概念

创建报表服务器数据库
Reporting Services 配置“如何”主题

其他资源

更改服务帐户和密码
连接数据源
配置 Reporting Services 组件
RSReportServer 配置文件
rsconfig 配置工具


配置用于 Internet 访问的报表服务器

配置用于 Internet 访问的报表服务器 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

尽管 SQL Server Reporting Services 并非专门设计用于 Internet 报表部署方案，但是您可以成功地将 Reporting Services 放置于面向 Internet 的 Web 服务器上，以将常规信息向广大公众传播，或者将公司保密数据向经过授权和身份验证的用户传播。根据应用程序和用户需求，您可以选择下列任何一种方法：

  • 在您创建和部署的自定义 Internet 应用程序中，使嵌入报表驻留在 ReportViewer Web 服务器控件中。

  • 使用 Windows 身份验证，在 Extranet 上部署报表服务器。

  • 使用自定义身份验证，在 Extranet 上部署报表服务器。

  • 针对匿名访问配置公共报表服务器。

注意：
尽管您可以在面向 Internet 的 Web 服务器上只安装报表管理器，然后在防火墙后安装报表服务器和报表服务器数据库，但建议不要执行此操作。该方法需要两个许可证。其中一个安装必须包括报表管理器。安装完成后，您可以使用 SQL Server 外围应用配置器工具禁用与报表管理器一起安装的报表服务器。然后可以将报表管理器配置为使用防火墙之后的第二个报表服务器实例。您需要在 RSWebApplication.config 文件中修改 <ReportServerVirtualDirectory> 和 <ReportServerUrl> 设置，以使报表管理器指向报表服务器实例。

使用 ReportViewer Web 服务器控件在 Internet 应用程序中承载报表

若要在 Internet 应用程序中部署报表，可以在所创建和部署的面向 Internet 的自定义应用程序中嵌入 ReportViewer Web 服务器控件。ReportViewer 控件包含在 Visual Studio 2005 中，并且随应用程序一起免费提供。其中一种使用控件的方法是承载在报表服务器中运行的报表。应用程序与报表服务器之间的连接由控件通过 Web 服务编程接口进行处理。在此部署配置中，所有的身份验证和授权都是由您的应用程序处理的，该应用程序是通过单一的用户可信连接来连接到服务器。

注意：
可以独立于 Reporting Services 使用 ReportViewer 控件，用于承载应用程序中提供的客户端报表定义 (.rdlc) 文件。有关详细信息，请参阅 SQL Server 联机丛书中的比较 Reporting Services 和 ReportViewer 控件。

在 Extranet 中部署报表服务器和报表管理器

若要在 Extranet 方案中部署报表服务器，而该方案支持通过预定义的 Microsoft Active Directory 帐户进行连接，则您可以使用默认的 Windows 身份验证安全扩展插件。请对将服务器配置为在 Internet 信息服务 (IIS) 中使用安全套接字层 (SSL) 连接和基本身份验证进行规划。

若要在 Extranet 方案中部署报表服务器，而该方案支持通过单一登录技术或基于窗体的身份验证模型（数据库中存储用户标识信息）连接时，您必须创建一个自定义身份验证扩展插件，来替换默认的 Windows 身份验证安全扩展插件。当向公共开放报表服务器，但是只希望通过身份验证的用户查看内容时，通常使用基于窗体的身份验证。默认情况下，SQL Server Reporting Services 不提供基于窗体的身份验证模块。有关如何创建一个身份验证模块的详细信息，请参阅 SQL Server 联机丛书中的Implementing a Security Extension。

按照下列原则在同一计算机上部署报表服务器和报表管理器：

  1. 使用“仅文件”安装模式在面向 Internet 的 Web 服务器上安装 Reporting Services。在 SQL Server 安装向导中，此选项为“安装但不配置”选项。

  2. 保护 Web 服务器和计划用于承载报表服务器数据库的 SQL Server 数据库引擎实例间连接的安全。您可以使用 IPSec 来保护连接。

  3. 安装结束后，运行 Reporting Services 配置工具以配置报表服务器：

    1. 指定服务帐户并创建报表服务器数据库。

    2. 如果 SQL Server 实例在不同的域中，并且未启用 Kerberos 5.0 时，请使用 SQL Server 身份验证连接报表服务器数据库。

  4. 通过选择您已为 Internet 访问配置的网站，来配置报表服务器和报表管理器虚拟目录。

注意：
在早期版本中，当在面向 Internet 的 Web 服务器上部署报表服务器实例时，您需要修改配置设置。只要报表管理器和报表服务器安装在一起，就不再需要此步骤。

在 Web.config 文件中配置代理设置

在 SQL Server 2005 中，Reporting Services 包括一个 Web.config 设置，允许报表管理器在向同一台计算机中安装的本地报表服务器发送请求时跳过代理服务器。

该 Web.config 设置是 System.NET defaultProxy 网络设置。默认情况下，对于报表管理器 defaultProxy 在 Web.config 文件中是禁用的。如果报表管理器和报表服务器部署于同一台计算机中，以上是建议的配置。

如果您是从 SQL Server 2000 Reporting Services 升级，则报表管理器 Web.config 文件不包括 defaultProxy 配置设置。对于报表管理器和报表服务器运行于同一台计算机的安装系统，您可以添加并设置 defaultProxy 设置，以跳过代理服务器。请将以下配置设置复制到报表管理器 Web.config 文件：

复制代码
<configuration>
...
<system.net>
  <defaultProxy enabled="false" />
</system.net>
</configuration>

有关这些设置的详细信息，请参阅 Microsoft .NET Framework 开发人员指南中的“配置 Internet 应用程序”和“defaultProxy 元素（网络设置）”。

公共报表服务器

若要将报表服务器部署为可以匿名访问，您可以将该报表服务器放置于防火墙之外，并将该报表服务器虚拟目录配置为可以匿名访问。您随后定义的角色分配不会因用户的不同而有所不同；对于同样的内容，所有用户均具有相同的访问权限，需要用户相关数据的报表将不会工作。

验证 Internet 部署

若要验证报表服务器连接是否可访问，键入 http: (or https:)//<your-web-server-fully-qualified-domain-name>/reportserver 后，通过 Internet 连接您应该可以查看报表服务器文件夹命名空间，其中 /reportserver 是报表服务器虚拟目录的默认名称。

注意：
在面向 Internet 的 Web 服务器上部署 Reporting Services，您需要仔细地对自己的网络环境进行评估。网络和安全软件、网络拓扑和域配置可以引入变量，这些变量会导致很难为报表服务器部署规定明确的步骤。为 Internet 访问评估报表服务器时，请确保您的测试方案包括所有您希望使用的功能，并且始终使用安全连接进行测试。

请参阅

概念

配置报表服务器虚拟目录

其他资源

RSWebApplication 配置文件
部署 Reporting Services
集成安全性和提升权限
配置报表服务器安全性


配置用于无人参与的报表处理的帐户

配置用于无人参与的报表处理的帐户 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

SQL Server 2005 Reporting Services 需要一个特殊帐户用于无人参与的报表处理。可以通过下列方式使用该帐户：

  • 连接到不需要或不使用身份验证的外部报表数据源。

  • 通过网络发送对使用数据库身份验证的报表的连接请求。有关详细信息，请参阅 SQL Server 联机丛书中的指定凭据和连接信息。

  • 检索在报表中使用的外部图像文件。有关如何使用无人参与的执行帐户检索图像的详细信息，请参阅 SQL Server 联机丛书中的向报表中添加图像。

无人参与的报表处理是指任何由事件（计划驱动事件或数据刷新事件）而不是用户请求触发的报表执行过程。只有外部报表数据源不需要或不使用凭据，或报表数据源连接需要在连接字符串中指定凭据（不建议）时，才必须为无人参与的报表处理配置特殊帐户。

报表服务器使用无人参与的报表处理帐户来登录承载外部数据源的计算机。由于 Report Server 的 Microsoft Windows 服务帐户或 Web 服务帐户的凭据不能用于连接其他计算机，因此必需配置此帐户。

对于在“数据源”属性页上指定了“不需要凭据”选项的报表来说，不使用凭据就可以访问外部数据源。对于 RSreportserver.config 文件中的以下设置，可以运行 Reporting Services 配置工具或 rsconfig -e，在本地或远程报表服务器实例上为其设置值：

复制代码
<UnattendedExecutionAccount>
<UserName></UserName>
<Password></Password>
<Domain></Domain>
</UnattendedExecutionAccount>

这些值将进行加密。设置值后，将无法通过解密以纯文本的形式查看这些值。如果输错了值或忘记了指定的值，则必须使用 Reporting Services 配置工具或运行 rsconfig -e 重新设置。

如何配置帐户

该帐户必须是域用户帐户。它不能是报表服务器服务帐户。请确保使用只对那些向报表服务器提供数据源和资源的计算机具有最小权限（只读访问权限便足够）和受限访问权限的帐户。

若要创建帐户，可以使用 Reporting Services 配置工具或 rsconfig 配置工具。配置无人参与的执行帐户的最简便方法是运行 Reporting Services 配置工具，然后在“执行帐户”页中指定凭据。

使用 Reporting Services 配置工具

  1. 启动 Reporting Services 配置工具，并连接到要配置的报表服务器实例。有关详细信息，请参阅如何启动 Reporting Services 配置。

  2. 在“执行帐户”页上，选择“指定执行帐户”。

  3. 键入帐户和密码，再重复键入密码，然后单击“应用”。

使用 RSConfig 配置工具

您也可以使用 rsconfig 实用工具。若要指定该帐户，请使用 rsconfig 的 -e 参数。为 rsconfig 指定 -e 参数可强制该实用工具将帐户信息写入到配置文件中。您无需指定 RSreportserver.config 的路径。请按照以下步骤来配置该帐户。

  1. 创建或选择一个有权访问为报表服务器提供数据或服务的计算机和服务器的域帐户。您应使用权限受到限制（如只读权限）的帐户。

  2. 打开命令提示符窗口：在“开始”菜单上，单击“运行”，键入 cmd，再单击“确定”。

  3. 键入以下命令，为本地报表服务器实例配置该帐户：

    rsconfig -e -u<域/用户名> -p<密码>

rsconfig -e 支持其他参数。有关语法和查看命令示例的详细信息，请参阅 SQL Server 联机丛书中的 rsconfig 配置工具。

请参阅

其他资源

Reporting Services 部署中的帐户
配置 Reporting Services 组件
“数据源”属性页（报表管理器）
RSReportServer 配置文件
rsconfig 配置工具
指定凭据和连接信息


配置报表服务器以进行电子邮件传递

配置报表服务器以进行电子邮件传递 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

SQL Server 2005 Reporting Services 包括电子邮件传递扩展插件，以便通过电子邮件分发报表。报表服务器电子邮件传递要在协作数据对象 (CDO) 上实现，且需要本地或远程的简单邮件传输协议 (SMTP) 服务器或 SMTP 转发器。

报表服务器电子邮件传递扩展插件在电子邮件附件中使用 UTF-8 编码。您无法修改此编码；HTML 呈现扩展插件仅支持 UTF-8。

注意：
默认电子邮件传递扩展插件不支持给待发邮件进行数字签名或加密。

为本地或远程的 SMTP 服务配置报表服务器

可以使用本地 SMTP 服务或远程 SMTP 服务器或转发器来支持电子邮件传递。如果具有现有远程 SMTP 服务器的访问权限，则应该考虑使用该服务器。若没有可用的 SMTP 服务器或随后由于计算机连接失败而遇到报表传递错误，则应该进行切换以使用本地 SMTP 服务。有关如何为本地或远程服务配置报表服务器的详细信息，将稍后在本主题中进一步说明。

为电子邮件传递设置配置选项

必须先设置确定使用哪一个 SMTP 服务器的配置值，才能使用报表服务器电子邮件传递。

若要针对电子邮件传递配置报表服务器，请执行下列操作：

  • 如果要仅指定一个 SMTP 服务器和一个具有发送电子邮件权限的用户帐户，则使用 Reporting Services 配置工具。以下是配置报表服务器电子邮件传递扩展插件所需的最低设置。

  • （可选）使用文本编辑器在 RSreportserver.config 和 RSwebapplication.config 文件中指定其他设置。同时，这两个配置文件具有用于报表服务器电子邮件传递的所有配置设置。如果要使用本地 SMTP 服务器或将电子邮件限定传递到特定主机，则需要在这些文件中指定其他设置。有关查找和修改配置文件的详细信息，请参阅 SQL Server 联机丛书中的 Reporting Services 配置文件。

下表说明了每个文件中的电子邮件传递设置：

文件 | 说明
RSwebapplication.config | 针对通过报表管理器创建和管理的所有订阅指定默认的传递扩展插件。RSwebapplication.config 中的 DefaultDeliveryExtension 设置将报表服务器电子邮件指定为默认的传递扩展插件。
RSreportserver.config | 存储与 SMTP 服务相关的所有设置。
注意：
报表服务器电子邮件设置都是基于 CDO。若要了解有关特定设置的更多详细信息，可以参考 CDO 产品文档。

报表服务器电子邮件配置示例

下面的示例说明了远程 SMTP 服务器的 RSreportserver.config 文件中的设置：若要了解设置说明及有效值，请参阅 RSReportServer 配置文件或 CDO 产品文档。

复制代码
<RSEmailDPConfiguration>
<SMTPServer>mySMTPServer.Adventure-Works.com</SMTPServer>
<SMTPServerPort></SMTPServerPort>
<SMTPAccountName></SMTPAccountName>
<SMTPConnectionTimeout></SMTPConnectionTimeout>
<SMTPServerPickupDirectory></SMTPServerPickupDirectory>
<SMTPUseSSL></SMTPUseSSL>
<SendUsing>2</SendUsing>
<SMTPAuthenticate></SMTPAuthenticate>
<From>my-rs-email-account@Adventure-Works.com</From>
<EmbeddedRenderFormats>
<RenderingExtension>MHTML</RenderingExtension>
</EmbeddedRenderFormats>
<PrivilegedUserRenderFormats></PrivilegedUserRenderFormats>
<ExcludedRenderFormats>
<RenderingExtension>HTMLOWC</RenderingExtension>
<RenderingExtension>NULL</RenderingExtension>
</ExcludedRenderFormats>
<SendEmailToUserAlias>True</SendEmailToUserAlias>
<DefaultHostName></DefaultHostName>
<PermittedHosts>
<HostName>Adventure-Works.com</HostName>
<HostName>hotmail.com</HostName>
</PermittedHosts>
</RSEmailDPConfiguration>

远程 SMTP 服务的配置选项

报表服务器与 SMTP 服务器或转发器之间的连接是由下列配置设置决定的：

  • SendUsing 指定发送邮件的方法。您可以选择网络 SMTP 服务或本地 SMTP 服务拾取目录。若要使用远程 SMTP 服务，在 RSReportServer.config 文件中必须将此值设置为 2。

  • SMTPServer 指定远程 SMTP 服务器或转发器。如果使用远程 SMTP 服务器或转发器，则必须指定此值。

  • “发件人”用于设置显示在电子邮件的“发件人:”行中的值。如果使用远程 SMTP 服务器或转发器，则必须指定此值。

其他用于远程 SMTP 服务的值包括下列值（请注意，除非您要覆盖默认值，否则无需指定这些值）：

  • SMTPServerPort 配置为端口 25。

  • SMTPAuthenticate 指定如何将报表服务器连接到远程 SMTP 服务器。默认值为 0（或不进行身份验证）。这种情况下，将通过匿名访问创建连接。报表服务器和 SMTP 服务器可能需要成为同一域的成员，这取决于域配置。

    若要向受限制的通讯组列表发送电子邮件（例如，只接受经过身份验证的帐户发来的邮件的通讯组列表），则将 SMTPAuthenticate 设置为 2。

本地 SMTP 服务的配置选项

若要测试报表服务器电子邮件传递或解决所遇到的疑难问题，则配置本地 SMTP 服务会很有用。报表服务器与本地 SMTP 服务器或转发器之间的连接是由下列配置设置决定的：

  • 将 SendUsing 设置为 1。

  • 将 SMTPServerPickupDirectory 设置为本地驱动器中的文件夹。

    注意：
    如果正在使用本地 SMTP 服务器，请确保不要设置 SMTPServer。

  • “发件人”用于设置显示在电子邮件的“发件人:”行中的值。此值是必需的。

请参阅

任务

如何启动 Reporting Services 配置

其他资源

如何配置报表服务器以进行电子邮件传递（Reporting Services 配置）
通过订阅分发报表
Reporting Services 中的电子邮件传递
Reporting Services 配置文件


启动和停止报表服务器 Windows 服务

启动和停止报表服务器 Windows 服务 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

可以通过停止报表服务器 Windows 服务来停止许多报表服务器操作。停止报表服务器 Windows 服务对报表服务器部署有以下影响：

  • 停止从计划事件（例如，订阅、报表快照刷新和缓存过期）触发的所有报表处理。

  • 禁止加密和解密操作。这些操作包括服务器初始化以及访问加密的凭据和连接字符串。

  • 禁止访问 Reporting Services 配置工具、rskeymgmt 实用工具和报表服务器 Windows Management Instrumentation (WMI) 提供程序所使用的远程过程调用 (RPC) 端点。

  • 停止报表服务器数据库维护和清除操作。

可以使用多种工具来启动或停止报表服务器 Windows 服务，包括 Reporting Services 配置工具、SQL Server 配置管理器、SQL Server 外围应用配置器工具和 Microsoft Windows 提供的服务工具。

如果要执行的操作不只是启动或停止服务（例如，更改服务帐户），则必须使用 Reporting Services 配置工具。如果使用其他工具更改服务帐户，可能会破坏 Reporting Services 安装。有关详细信息，请参阅更改服务帐户和密码。

不能暂停和恢复服务。没有启动参数。虽然没有显式依赖关系，但如果在服务器上支持任何计划操作，则必须运行 SQL Server 代理。

使用 Reporting Services 配置工具

  • 若要停止或启动服务，请运行 Reporting Services 配置工具，并连接到报表服务器。在“报表服务器状态”页上，单击“停止”或“启动”。

使用 SQL Server 配置管理器

  • 若要停止或启动服务，请运行 SQL Server 配置管理器，选择 SQL Server 2005 服务，右键单击“报表服务器”，再单击“停止”或“重新启动”。

使用 SQL Server 外围应用配置器工具

在 SQL Server 外围应用配置器工具中提供了启动和停止服务功能以方便您的使用，这样您可以在 Reporting Services 安装中停止服务之前停止该服务。

您还可以使用此工具来禁用特定功能。可以禁用计划和传递处理器和 Web 服务请求。启用和禁用功能会影响 RSReportServer.config 文件中的配置设置。具体来说，如果您选择 IsWindowsServiceEnabled 选项，则会将 RSReportServer.config 中的以下值设置为 True：IsSchedulingService、IsNotificationService 和 IsEventService。SQL Server 外围应用配置器工具中的 IsWindowsServiceEnabled 选项相当于所有三个配置选项的组合。在配置文件中手动编辑这些值会破坏或撤消您在该工具中所做的选择。

  • 若要停止或启动该服务，请运行 SQL Server 外围应用配置器工具，单击“服务和连接的外围应用配置器”，展开 Reporting Services，再单击“停止”或“启动”。

关于报表服务器 Web 服务

一般来说，启动、暂停、恢复和停止服务并不属于 Web 服务管理的范畴。但 ASP.NET 将启动和停止 Web 服务作为管理服务的一部分。在大多数情况下，您无须亲自启动或停止 Web 服务。若要重新启动报表服务器 Web 服务，必须重新启动 Microsoft Internet 信息服务 (IIS)。如果正在运行 IIS 6.0，可以重新启动应用程序域。

若要验证 Web 服务是否正在运行，可以在浏览器 URL 地址中键入 http://localhost/reportserver 来 ping 该服务。

请参阅

其他资源

计划和传递处理器
启动和停止报表服务器 Windows 服务
部署 Reporting Services
管理报表服务器 Web 服务和 Windows 服务


更改服务帐户和密码

更改服务帐户和密码 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

Reporting Services 使用 Windows 服务和 Web 服务来支持服务器操作。经过一段时间后，您可能需要更新密码或帐户，或者同时更新这两者。

  • 若要更改服务帐户密码，请使用操作系统的密码更新功能。报表服务器将自动使用新密码。

  • 若要更改用于运行这些服务的服务帐户，请使用 Reporting Services 配置工具。

请始终使用 Reporting Services 配置工具来更改服务帐户。更改服务帐户时，Reporting Services 配置工具将执行一些附加步骤以确保报表服务器仍然可用：

  • 当更新 Windows 服务帐户时，会自动更新对称密钥和加密数据以包含新帐户的配置文件信息。由于仅由报表服务器 Windows 服务执行加密，因此只需在重置该 Windows 服务时更新这些密钥即可。

    注意：
    如果报表服务器是扩展部署的一部分，则只有正在更新的报表服务器会受到影响。扩展部署中的其他报表服务器的加密密钥不会受到服务帐户更改的影响。

  • 它会更新用于承载报表服务器数据库的 SQL Server 数据库引擎的登录权限。如果您使用服务帐户连接该数据库，则在您最初配置连接时，Reporting Services 会为这些服务帐户授予 SQL Server 登录权限。如果您重置了 Web 服务或 Windows 服务帐户，则必须更新连接信息。

  • 它会将新帐户添加到本地计算机上创建的报表服务器组中。此组是在保护 Reporting Services 文件的访问控制列表 (ACL) 中指定的。

如何更改服务帐户

通过下列步骤可以重新配置服务帐户：

  1. 启动 Reporting Services 配置工具，再连接到报表服务器。

  2. 在“Windows 服务标识”页或“Web 服务标识”页上，指定新帐户和新密码。单击“应用”。

  3. 如果您要重置的是 Windows 服务标识，系统将提示您备份对称密钥。请为对称密钥备份文件键入密码和文件名，再单击“确定”。

服务帐户更新中的每个步骤都会记录到页面底部的任务面板中。在帐户更新过程中，报表服务器 Windows 服务将停止并重新启动。有可能发生的错误包括登录失败（例如，如果键入了错误的帐户或密码）。如果对称密钥没有还原，您可以通过单击“加密密钥”页中的“还原”来执行此步骤，但这种情况极少出现。若要验证帐户是否已正确重置，请打开一个使用存储的凭据的报表。如果无法还原密钥的备份副本，则必须删除加密的内容。有关详细信息，请参阅删除和重新创建加密密钥和备份和还原加密密钥。

关于报表服务器 Windows 服务帐户配置

报表服务器 Windows 服务是在安装过程中进行配置的。安装向导提供的选项并不能指定所有可能的服务帐户选择。例如，无法通过该向导指定网络服务（仅限 Windows Server 2003）。如果希望使用网络服务，您可以在安装结束后修改服务帐户属性。请务必使用 Reporting Services 配置工具来修改服务帐户。

关于报表服务器 Web 服务帐户配置

在安装过程中，您不能选用 Web 服务帐户。对于 Web 服务，如果安装程序以默认配置安装报表服务器，则会始终使用默认的 ASP.NET 安全标识。如果 ASP.NET 没有在默认帐户下运行，安装程序将不会提供用于安装默认配置的选项。如果执行了“仅文件”安装，则必须将报表服务器 Web 服务帐户配置为服务器部署的一部分。在该过程中，您可以将 Web 服务帐户配置为使用非默认的 ASP.NET 帐户。

报表服务器 Web 服务帐户是在您配置报表服务器虚拟目录时建立的。Internet 信息服务 (IIS) 的版本将确定所使用 Web 服务帐户：

  • 如果运行的是 IIS 5.0 或 5.01，报表服务器 Web 服务帐户将作为 ASP.NET 进程标识运行。您不能将报表服务器 Web 服务配置为在其他帐户下运行。

  • 如果您运行的是 IIS 6.0，您可以选择要运行该 Web 服务的应用程序域。该 Web 服务将使用此应用程序域运行时所基于的安全标识；但是该标识并不一定是 ASP.NET 进程标识。

请参阅

任务

如何启动 Reporting Services 配置

参考

设置 Windows 服务帐户

其他资源

部署 Reporting Services
管理报表服务器 Web 服务和 Windows 服务
Reporting Services 部署中的帐户
启动和停止报表服务器 Windows 服务


配置报表服务器扩展部署

配置报表服务器扩展部署 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

扩展部署是指多个报表服务器实例共享单个报表服务器数据库的安装配置。当需要在服务器群集中运行 Reporting Services 时，将使用此部署模型。若要在群集中运行报表服务器，必须首先将报表服务器节点配置为使用共享数据库。

扩展部署包括以下要求：

  • Reporting Services 的版本必须为 Enterprise、Developer 或 Evaluation 版本。Standard Edition 不支持扩展部署。创建扩展部署时，您可以组合使用不同的版本，只要这些版本支持扩展功能。

  • 所有报表服务器必须位于同一个域中或位于可信域中。

  • 所有报表服务器的版本必须相同（SQL Server 2005 或 Service Pack 1）。

重要事项：
若要对服务器群集运行服务器扩展部署，还必须有可用于创建和管理服务器群集的软件和工具。Reporting Services 不提供此功能。有关在服务器群集中运行 Reporting Services 的详细信息，请参阅 SQL Server 联机丛书中的安排 Reporting Services 部署计划。

报表服务器扩展的部署步骤

部署步骤包括安装、通过 Reporting Services 配置工具进行配置以及手动编辑报表服务器配置文件。如果使用 Microsoft Application Center，则必须从复制操作中排除配置文件。

Application Center 部署的预安装步骤

如果使用 Application Center 来管理服务器群集，则必须定义筛选器以便从复制操作中排除报表服务器配置文件 (RSReportServer.config)。使用“仅文件”安装选项安装要使用的报表服务器实例。此安装选项允许您在配置要包含在群集中的报表服务器实例之前设置筛选器。

  1. 若要设置筛选器，请打开 Application Center 2000 控制台，右键单击“同步”，再选择“属性”。

  2. 定义一个排除 RSReportServer.config 的筛选器。默认路径为 c:\Program Files\Microsoft SQL Server\MSSQLn\Reporting Services\ReportServer\RSReportServer.config。

创建和配置报表服务器实例

您可以在已包含在服务器群集中的节点上安装 Reporting Services。按照以下步骤安装并启用 Reporting Services 功能：

  1. 安装和配置报表服务器扩展部署。有关详细信息，请参阅如何配置报表服务器扩展部署（Reporting Services 配置）。

  2. 运行 SQL Server 外围应用配置器工具验证是否启用了 Reporting Services。报表服务器 Windows 服务必须已启用且正在运行。如果在安装程序中选择“自动启动”选项，则该服务将已启用且正在运行。有关详细信息，请参阅SQL Server 外围应用配置器。

  3. 通过编辑部署中每个报表服务器实例的报表管理器的 Web.config 文件，配置视图状态验证。在安装和初始化了扩展中的所有节点后，并在编辑 Reporting Services 配置文件之前，进行此步骤。一旦传入请求在各节点间达到负载平衡，就必须正确配置视图状态验证。否则，将会因状态验证失败而出现许多意外情况。有关详细信息，请参阅本主题中的“配置视图状态验证”部分。

  4. 如果使用的是安全套接字层 (SSL)，请验证是否在当前使用的 IIS 应用程序池中安装了 SSL 证书，并且配置了使用 SSL 的虚拟目录。在 Reporting Services 配置工具中使用虚拟目录页，为报表管理器和报表服务器指定 SSL 连接。继续执行下一步骤前，请通过 https:// 连接打开报表管理器，验证是否正确配置了报表服务器。

  5. 备份所有的配置文件，以备今后需要回滚时使用。在接下来的步骤中，您将修改配置文件。如果您执行了错误操作，则可回滚到本步骤中创建的备份。在必须备份的配置文件中，包括报表服务器和报表管理器的 RSReportServer.config、RSWebApplication.config 和 Web.config 文件。

  6. 如果访问扩展部署时使用的是虚拟服务器，则需要额外执行以下步骤：

    1. 编辑 Reporting Services 配置文件以指定虚拟服务器名称。有关详细信息，请参阅本主题中的“在 Reporting Services 配置文件中指定虚拟服务器名称”部分。

    2. 在 IIS 中，配置到虚拟服务器 URL 的重定向。若要配置重定向，请设置网站属性上的“主目录”选项卡中的选项。

    3. 验证是否可通过虚拟服务器名称（例如，https://MyReportPortal/reportserver 和 https://MyReportPortal/reports）访问扩展部署。通过查看报表服务器日志文件或检查 RS 执行日志（该执行日志表包含的 InstanceName 列可以显示处理特定请求的实例名称），可以检查实际处理报表的节点。有关详细信息，请参阅 SQL Server 联机丛书中的Reporting Services Log Files。

配置视图状态验证

若要完成扩展部署，还必须编辑配置文件，为在报表管理器中查看的交互式 HTML 报表启用视图状态。

在 Microsoft .NET Framework 2.0 中，默认情况下将启用视图状态验证并使用 ASP.NET 进程标识信息来执行验证。在群集或扩展方案中，每个节点的进程标识各不相同，因此无法按进程标识进行验证。替代方法是，您可以生成一个验证密钥来支持视图状态验证功能，并手动将每个报表服务器节点配置为使用该密钥。

以下步骤介绍了如何为 <machineKey> 元素生成密钥。有多种生成密钥值的方法，.NET Framework 文档中对这些方法进行了说明。有关为 Web 服务网络配置视图状态验证的详细信息，请参阅 .NET Framework 参考文档中关于 <machineKey> 元素的部分。

  1. 生成验证密钥。可以使用 .NET Framework 提供的自动生成功能，也可以通过其他方式创建该密钥。在设置 validationKey 属性时，请不要使用 AutoGenerate 选项。

  2. 生成解密密钥。对于解密密钥，可以创建一个显式值，或者将 decryptionKey 设置为 AutoGenerate。

  3. 打开报表管理器的 Web.config 文件，并设置 <machineKey> 元素。必须指定验证密钥、解密密钥以及用于数据验证的加密类型。以下示例说明了您必须提供的条目（这些示例值并非有效值，请不要将这些条目复制到您的配置文件中）： <machineKey validationKey="53ab8bv3ebc93bb826a7b3v37b903a9d5d4a0" decryptionKey="26165b97a9d5d4a0" validation="SHA1"/>

  4. 为扩展部署中的每个报表服务器重复以上步骤。确保 \Reporting Services\Report Manager 文件夹中所有 Web.Config 文件的 <system.web> 部分都包含相同的 <machineKey> 元素。

在 Reporting Services 配置文件中指定虚拟服务器名称

如果将报表服务器扩展部署配置为在虚拟服务器上运行，则必须在配置文件中手动更新报表服务器 URL 设置，以便使用虚拟服务器名称。有关 Reporting Services 配置文件的详细信息，请参阅 SQL Server 联机丛书中的Reporting Services 配置文件。

  1. 使用文本编辑器打开 rswebapplication.config 文件。

将 <ReportServerUrl> 设置为虚拟服务器名称。此步骤可确保将通过报表管理器传人的所有请求，平衡负载到扩展部署中运行的报表服务器上。以下示例说明了应使用的语法，该语法指定了虚拟服务器名称和报表服务器虚拟目录。 <ReportServerUrl>https://MyReportPortal/reportserver</ReportServerUrl>

  1. 打开 rsreportserver.config 文件。

将 <UrlRoot> 设置为虚拟服务器地址。此步骤可确保报表中的所有超链接都指回扩展部署，并进行相应的负载平衡。此设置也用于完成报表传递。以下示例说明了应使用的语法： <ReportServerUrl>https://MyReportPortal/reportserver</ReportServerUrl>

  1. 对扩展部署中的每个报表服务器重复以上步骤。

如果在作出以下更改后启动 Reporting Services 配置工具，则该工具可能会将 <ReportServerUrl> 设置更改为默认值。请始终保留一份配置文件的备份副本，以备需要用包含要使用的设置的版本替换该配置文件时使用。

请参阅

概念

安装 SQL Server Reporting Services

其他资源

Reporting Services 组件概述


管理加密密钥

管理加密密钥 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

Reporting Services 使用加密密钥保护存储在报表服务器数据库中的凭据和连接信息。在 Reporting Services 中，加密密钥包括一组用来保护敏感数据的公钥、私钥和对称密钥。在安装或配置报表服务器时，在报表服务器初始化期间创建对称密钥，并由报表服务器使用对称密钥对存储在报表服务器中的敏感数据进行加密。公钥和私钥由操作系统创建，用于保护对称密钥。对于报表服务器数据库中存储敏感数据的每个报表服务器实例，都要创建一个公钥私钥对。

对加密密钥的管理包括创建备份副本，以及了解还原、删除或更改密钥的时间和方式。如果要迁移报表服务器安装或配置扩展部署，则必须拥有对称密钥的备份副本，以便可以将其应用于新安装。

若要管理对称密钥，可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具。Reporting Services 中包括的工具仅用于管理对称密钥（公钥和私钥由操作系统管理）。Reporting Services 配置工具和 rskeymgmt 实用工具支持以下任务：

  • 备份对称密钥的副本，以便可以使用该副本来恢复报表服务器安装或作为计划迁移的一部分。

  • 将以前保存的对称密钥还原到报表服务器数据库，以允许新的报表服务器实例访问最初不是由其进行加密的现有数据。

  • 在无法访问加密数据时删除报表服务器数据库中的加密数据，这种情况极少出现。

  • 当对称密钥遭到破坏时重新创建对称密钥并重新加密数据，这种情况极少出现。作为安全性方面的最佳做法，您应定期（例如，每隔几个月）重新创建对称密钥，以保护报表服务器数据库，使其能够抵御试图解开密钥的网络攻击。

  • 在报表服务器扩展部署（多个报表服务器同时共享单个报表服务器数据库以及为该数据库提供可逆加密的对称密钥）中添加或删除报表服务器实例。

本节内容

主题 | 说明
初始化报表服务器 | 介绍如何创建加密密钥。
备份和还原加密密钥 | 介绍如何备份加密密钥以及如何还原备份以恢复或迁移报表服务器安装。
删除和重新创建加密密钥 | 介绍如何用新版本替换对称密钥以及在无法验证对称密钥时如何重新开始。
添加和删除扩展部署的加密密钥 | 介绍如何添加和删除加密密钥以控制在扩展部署中包括哪些报表服务器。

请参阅

其他资源

存储加密的报表服务器数据
Reporting Services 配置工具
rskeymgmt 实用工具
管理报表服务器数据库


初始化报表服务器

初始化报表服务器 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > 管理加密密钥 >

在 Reporting Services 中，已初始化的服务器是指可以对报表服务器数据库中的数据进行加密和解密的服务器。初始化是一项必需的报表服务器操作。初始化发生在报表服务器 Windows 服务第一次启动时。在将报表服务器联接到现有部署，或在恢复进程中手动重新创建密钥时也需要进行初始化。有关如何使用加密密钥以及为什么使用加密密钥的详细信息，请参阅管理加密密钥和存储加密的报表服务器数据。

加密密钥部分基于报表服务器 Windows 服务的配置文件信息。如果更改用于运行报表服务器 Windows 服务的用户标识，则必须相应地更新密钥。如果使用 Reporting Services 配置工具更改标识，将自动处理此步骤。

如果由于某些原因导致初始化失败，则报表服务器在响应用户和服务请求时将返回 RSReportServerNotActivated 错误。这种情况下，可能需要排除系统或服务器配置故障。有关详细信息，请参阅初始化和加密密钥错误故障排除。

初始化过程概述

初始化过程将创建并存储一个用于加密的对称密钥。对称密钥由 Microsoft Windows 加密服务创建，并随后由报表服务器 Windows 服务用来加密和解密数据。对称密钥本身通过非对称密钥进行加密。

在 Reporting Services 安装中，只有报表服务器 Windows 服务可以执行加密操作。如果报表服务器 Web 服务需要加密或解密，它将调用报表服务器 Windows 服务来执行该操作。

以下步骤描述了初始化过程：

  1. 在初始启动时，报表服务器 Windows 服务将读取 RSReportServer.config 文件，以获取安装标识符和数据库连接信息。

  2. 报表服务器 Windows 服务从加密服务请求公钥。Windows 创建私钥和公钥，并将公钥发送给报表服务器 Windows 服务。

  3. 报表服务器 Windows 服务连接到报表服务器数据库，并存储安装标识符和公钥值。

  4. 报表服务器 Windows 服务再次调用加密服务，这次是请求对称密钥。Windows 创建对称密钥。

  5. 报表服务器 Windows 服务再次连接到报表服务器数据库，并将对称密钥添加到在步骤 3 中存储的公钥和安装标识符值。在存储对称密钥之前，报表服务器 Windows 服务使用其公钥对对称密钥进行加密。存储对称密钥后，即可将报表服务器视为已初始化，并且可供使用。

针对扩展部署初始化报表服务器

Reporting Services 支持在多个报表服务器实例之间共享单个报表服务器数据库的扩展部署模式。若要联接扩展部署，报表服务器必须在共享数据库中创建并存储其对称密钥副本。尽管使用该数据库的服务器都使用同一个对称密钥，但是每个报表服务器都有自己的密钥副本。每个副本各不相同，因为这些副本都使用其各自拥有的公钥进行了唯一加密。

针对扩展部署初始化报表服务器的开始步骤与描述初始化单个服务器和数据库组合的前三个步骤相同。

扩展部署初始化过程的不同之处在于报表服务器获取对称密钥的方式。在初始化第一个服务器时，它从 Windows 获取对称密钥。在配置扩展部署的过程中，在初始化第二个服务器时，它将从已初始化的报表服务器 Windows 服务获取对称密钥。第一个报表服务器实例使用第二个实例的公钥来为第二个报表服务器实例创建对称密钥的加密副本。在此过程中的任何一点，对称密钥永远不会作为纯文本公开。

如何初始化报表服务器

  • 若要初始化报表服务器，请使用 Reporting Services 配置工具。在创建和配置报表服务器数据库时，将自动进行初始化。有关详细信息，请参阅配置报表服务器数据库连接。

  • 若要针对扩展部署初始化报表服务器，可以使用 Reporting Services 配置工具中的“初始化”页或使用 RSKeymgmt 实用工具。若要按照逐步说明操作，请参阅如何配置报表服务器扩展部署（Reporting Services 配置）。

注意：
RSKeymgmt 是一种控制台应用程序，需要在已作为扩展部署的一部分的报表服务器实例所驻留的计算机上从命令行运行。运行该实用工具时，需要指定相关参数，以选择要初始化的远程报表服务器实例。

只有当安装标识符与公钥相匹配时，才会初始化报表服务器。如果匹配成功，则创建允许可逆加密的对称密钥。如果匹配失败，则将禁用报表服务器，在这种情况下，可能需要应用备份密钥；如果备份密钥不可用或无效，则可能需要删除加密数据。有关报表服务器所使用的加密密钥的详细信息，请参阅管理加密密钥。

注意：
还可以通过使用 Reporting Services Windows Management Instrumentation (WMI) 提供程序，以编程的方式初始化报表服务器。有关详细信息，请参阅 Reporting Services WMI Provider。

如何确认报表服务器初始化

若要确认报表服务器初始化，请通过在命令窗口中键入 http://<服务器名>/reportserver 来 ping 报表服务器 Web 服务。如果发生 RSReportServerNotActivated 错误，则表示初始化失败。

请参阅

其他资源

Reporting Services 安装的备份和还原操作
初始化和加密密钥错误故障排除
部署 Reporting Services
管理 Reporting Services
存储加密的报表服务器数据


备份和还原加密密钥

备份和还原加密密钥 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > 管理加密密钥 >

报表服务器配置的一个重要部分是为用于加密敏感信息的对称密钥创建备份副本。该密钥的备份副本对许多例程操作来说是必需的，通过使用备份副本，您可以在新的安装中重用现有报表服务器数据库。在发生以下任何事件时，必须还原加密密钥的备份副本：

  • 更改报表服务器 Windows 服务帐户名或重置密码。使用 Reporting Services 配置工具时，对该密钥进行备份是服务帐户名称更改操作的一部分。

    注意：
    重置密码不同于更改密码。密码重置需要相应的权限以覆盖域控制器上的帐户信息。密码重置在您忘记或不知道特定密码时由系统管理员执行。只有密码重置才需要还原对称密钥。定期更改帐户密码不需要重置对称密钥。

  • 重命名承载报表服务器的计算机或实例（报表服务器实例基于 SQL Server 实例名）。

  • 迁移报表服务器安装或配置报表服务器以使用其他报表服务器数据库。

  • 由于硬件故障而恢复报表服务器安装。

只需要备份对称密钥的一个副本。报表服务器数据库和对称密钥之间存在一对一的对应关系。尽管只需要备份一个副本，但如果在扩展部署模型中运行多个报表服务器，则可能需要多次还原密钥。每个报表服务器实例都需要具有自己的对称密钥副本，才能对报表服务器数据库中的数据进行锁定和解锁。

将加密密钥备份到磁盘

备份对称密钥是将密钥写入所指定的文件，然后使用所提供的密码对密钥进行加密的过程。对称密钥绝对不能在未加密状态下存储，所以在将它保存到磁盘时，必须提供密码对密钥进行加密。创建文件后，必须将其存储在安全的位置，并记住用于对文件进行解锁的密码。若要备份对称密钥，可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具。

如何备份加密密钥（Reporting Services 配置工具）

  1. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  2. 单击“加密密钥”，再单击“备份”。

  3. 键入强密码。

  4. 指定文件以包含所存储的密钥。Reporting Services 将向该文件追加 .snk 文件扩展名。请考虑将文件存储在软盘上，以使其与报表服务器隔开。

  5. 单击“确定”。

如何备份加密密钥 (rskeymgmt)

  1. 如果希望将密码保护的文件与报表服务器分开存储，请将软盘插入软盘驱动器中。

  2. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。必须使用 -e 提取参数复制密钥，提供文件名并指定密码。下面的示例阐释了必须指定的参数：

    复制代码
    rskeymgmt -e -f a:\rsdbkey.snk -p<password>
  3. 将软盘存放在安全的位置。

还原加密密钥

还原对称密钥将覆盖存储在报表服务器数据库中的现有对称密钥。还原加密密钥将用以前保存到磁盘上的副本来替换无法使用的密钥。还原加密密钥将导致以下操作：

  • 从密码保护的备份文件中打开对称密钥。

  • 使用报表服务器 Windows 服务的公钥加密对称密钥。

  • 将加密的对称密钥存储到报表服务器数据库中。

  • 删除以前存储的对称密钥数据（例如，在以前部署的报表服务器数据库中已存在的密钥信息）。

若要还原加密密钥，必须具有保存在文件中的加密密钥副本。还必须知道用来对存储的副本进行解锁的密码。如果有了密钥和密码，则可以运行 Reporting Services 配置工具或 rskeymgmt 实用工具来还原密钥。该对称密钥必须与用来对报表服务器数据库中当前存储的加密数据进行锁定和解锁的密钥相同。如果还原的副本无效，则报表服务器将无法访问报表服务器数据库中当前存储的加密数据。在这种情况下，如果无法恢复有效的密钥，则最好删除所有加密值。如果由于某些原因（例如，如果没有备份副本）而无法还原加密密钥，则必须删除现有密钥和加密内容。有关详细信息，请参阅删除和重新创建加密密钥。有关创建对称密钥的详细信息，请参阅初始化报表服务器。

如何还原加密密钥（Reporting Services 配置工具）

  1. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  2. 在“加密密钥”页上，单击“还原”。

  3. 选择包含备份副本的 .snk 文件。

  4. 键入用于解锁该文件的密码。

  5. 单击“确定”。

如何还原加密密钥 (rskeymgmt)

  1. 插入包含加密密钥备份副本的软盘。

  2. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。使用 -a 参数还原密钥。必须提供完全限定的文件名，并指定密码。下面的示例阐释了必须指定的参数：

    复制代码
    rskeymgmt -a -f a:\rsdbkey.snk -p<password>

请参阅

其他资源

管理加密密钥
Reporting Services 配置工具
rskeymgmt 实用工具
Reporting Services 安装的备份和还原操作


删除和重新创建加密密钥

删除和重新创建加密密钥 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > 管理加密密钥 >

删除和重新创建加密密钥不属于加密密钥例行维护活动。您可以为了响应对报表服务器的特定威胁来执行这些任务，或者当无法访问报表服务器数据库时作为最后一种解决手段来执行这些任务。

  • 当确信现有对称密钥的安全受到威胁时，应重新创建对称密钥。作为安全性方面的最佳做法，您还可以定期重新创建密钥。

  • 当无法还原对称密钥时，应删除现有加密密钥和不可用的加密内容。

重新创建加密密钥

如果确认对称密钥已泄露给未经授权的用户，或者报表服务器遭到攻击，作为一种防范措施，您想要重置对称密钥，那么可以重新创建对称密钥。当重新创建对称密钥时，将使用新值对所有加密值重新进行加密。如果在扩展部署中运行了多个报表服务器，则对称密钥的所有副本都将更新为新值。报表服务器使用可用的公钥更新部署中每一台服务器的对称密钥。

只有在报表服务器处于工作状态时，才能重新创建对称密钥。重新创建加密密钥以及重新对内容进行加密将会中断服务器的操作。在进行重新加密时，必须将服务器脱机。在重新加密过程中，不应该向报表服务器发送请求。

可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具重置对称密钥和加密的数据。有关如何创建对称密钥的详细信息，请参阅初始化报表服务器。

如何重新创建加密密钥（Reporting Services 配置工具）

  1. 使用 SQL Server 外围应用配置器工具禁用报表服务器 Web 服务。如果要为报表服务器扩展部署重新创建加密密钥，请在部署中的所有实例上禁用报表服务器 Web 服务。

    1. 启动 SQL Server 外围应用配置器工具，再单击“功能的外围应用配置器”。

    2. 选择“Reporting Services”。

    3. 对于“Web 服务和 HTTP 访问”，清除复选框“启用 Web 服务和 HTTP 访问”。

  2. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  3. 在“加密密钥”页上，单击“更改”。单击“确定”。

  4. 重新启动报表服务器 Windows 服务。如果要为扩展部署重新创建加密密钥，请在所有实例上重新启动该服务。

  5. 运行 SQL Server 外围应用配置器工具以启用报表服务器 Web 服务操作。如果使用的是扩展部署，请对所有实例执行此操作。

如何重新创建加密密钥 (rskeymgmt)

  1. 禁用 Web 服务和 HTTP 访问。使用以上过程中的说明停止 Web 服务操作。

  2. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。使用 -s 参数重置对称密钥。不需要其他参数：

    复制代码
    rskeymgmt -s
  3. 重新启动 Windows 服务，并启用 Web 服务操作。

删除无用的加密内容

如果由于某些原因无法还原加密密钥，报表服务器将永远无法解密和使用由该密钥加密的所有数据。若要将报表服务器还原到工作状态，必须删除当前存储在报表服务器数据库中的加密值，然后手动重新指定需要的值。

删除加密密钥会将所有对称密钥信息从报表服务器数据库中删除，并会删除所有加密内容。所有未加密的数据都将保持不变；只有加密内容被删除。删除加密密钥时，报表服务器通过添加新的对称密钥自动对自身进行重新初始化。删除加密内容时，会出现以下情况：

  • 共享数据源中的连接字符串被删除。运行报表的用户得到错误消息“ConnectionString 属性尚未初始化”。

  • 存储的凭据被删除。报表和共享数据源重新配置为使用所提示的凭据。

  • 基于模型（且需要共享数据源配置为使用存储的凭据或不使用凭据）的报表将不会运行。

  • 订阅被停用。

加密内容一旦被删除，便无法恢复。必须重新指定连接字符串和存储的凭据，并且必须激活订阅。

可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具删除值。

如何删除加密密钥（Reporting Services 配置工具）

  1. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  2. 单击“加密密钥”，再单击“删除”。单击“确定”。

  3. 重新启动报表服务器 Windows 服务。对于扩展部署，应对所有报表服务器实例执行此操作。

如何删除加密密钥 (rskeymmgt)

  1. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。必须使用 -d 应用参数。下面的示例说明了必须指定的参数：

    复制代码
    rskeymgmt -d
  2. 重新启动报表服务器 Windows 服务。对于扩展部署，应对所有报表服务器实例执行此操作。

如何重新指定加密值

  1. 对于每个共享数据源，必须重新键入连接字符串。

  2. 对于每个使用存储的凭据的报表和共享数据源，必须重新键入用户名和密码，然后再保存。有关详细信息，请参阅指定凭据和连接信息。

  3. 对于每个数据驱动订阅，打开每个订阅，再重新键入订阅数据库的凭据。

  4. 对于使用加密数据的订阅（其中包括文件共享传递扩展插件和使用加密的任何第三方传递扩展插件），打开每个订阅，再重新键入凭据。使用报表服务器电子邮件传递的订阅不使用加密数据，因而不受密钥更改的影响。

请参阅

其他资源

管理加密密钥
Reporting Services 配置工具
rskeymgmt 实用工具
存储加密的报表服务器数据


添加和删除扩展部署的加密密钥

添加和删除扩展部署的加密密钥 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > 管理加密密钥 >

通过将多个报表服务器配置为使用一个共享的报表服务器数据库，可以在扩展部署模型中运行 Reporting Services。扩展部署中的成员身份是基于报表服务器是否将加密密钥存储在报表服务器数据库中。通过为特定的报表服务器实例添加和删除加密密钥，可以控制扩展部署成员身份。如果要从部署中删除节点，则可以按任意顺序进行删除。如果要向部署中添加节点，则必须联接已作为部署的一部分的报表服务器中的所有新实例。

使用 Reporting Services 配置工具配置扩展部署

配置扩展部署的最简单方法是使用 Reporting Services 配置工具。有关详细信息和分步说明，请参阅配置报表服务器扩展部署和如何配置报表服务器扩展部署（Reporting Services 配置）。

使用 Rskeymgmt 配置扩展部署

使用 rskeymgmt 实用工具，可以将报表服务器实例初始化为使用共享的报表服务器数据库。要向扩展部署中添加报表服务器，需要初始化报表服务器。要进行初始化，需要有管理员权限。对于承载要加入部署的报表服务器的远程计算机，您必须拥有管理员凭据。

如何将报表服务器加入扩展部署 (rskeymgmt)

  1. 在特定计算机的本地运行 rskeymgmt.exe，该计算机承载已经是报表服务器扩展部署成员的报表服务器。

  2. 使用 -j 参数将报表服务器加入报表服务器数据库。使用 -m 和 -n 参数指定要添加到部署中的远程报表服务器实例。使用 -u 和 -v 参数指定远程计算机上的管理员帐户。如果要使用同一台计算机中的多个报表服务器实例创建扩展部署，则使用的语法会稍有不同。有关应使用的语法的详细信息，请参阅rskeymgmt 实用工具。

    下面的示例说明了将远程报表服务器加入扩展部署时必须指定的参数（如果您对远程计算机拥有管理员权限，则可以忽略凭据）：

    复制代码
    rskeymgmt -j -m <remotecomputer> -n <namedreportserverinstance> -u <administratoraccount> -v <administratorpassword>

如何从扩展部署 (rskeymgmt) 中删除报表服务器

  1. 打开要删除的报表服务器的 rsreportserver.config 文件并找到安装 ID。默认情况下，该文件位于 Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportServer 中。

    如果安装了单个实例，则计算机中只有一个 rsreportserver.config 文件。如果安装了多个 Reporting Services 实例，则请使用 Reporting Services 配置工具中的“服务器状态”页来查找要删除的报表服务器的实例标识符（例如，MSSQL.2）。为报表服务器实例存储程序文件的文件夹名称将基于实例标识符来命名（例如，Program Files\Microsoft SQL Server\MSSQL.2）。

  2. 运行 rskeymgmt.exe。可以在属于报表服务器扩展部署一部分的任何报表服务器上运行该文件。

  3. 使用 -r 参数从扩展部署中释放该报表服务器实例。下面的示例说明了必须指定的参数：

    复制代码
    rskeymgmt -r <installation ID>

请参阅

其他资源

管理加密密钥
Reporting Services 配置工具
rskeymgmt 实用工具
初始化报表服务器


Reporting Services 配置“如何”主题

Reporting Services 配置“如何”主题 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

本部分包含使用 Reporting Services 配置工具配置报表服务器实例的过程。

本节内容

主题 | 说明
如何启动 Reporting Services 配置 | 提供启动 Reporting Services 配置工具的步骤。
如何创建报表服务器数据库（Reporting Services 配置） | 提供创建报表服务器数据库的步骤。此步骤是部署 Reporting Services 安装所必需的步骤。
如何配置 Reporting Services 以使用非默认网站（Reporting Services 配置） | 提供选择非默认网站的步骤。这些说明适用于可能对网站创建不太熟悉的用户。
如何配置报表服务器扩展部署（Reporting Services 配置） | 提供配置多个报表服务器以共享报表服务器数据库的步骤。
如何在从 SQL Server 7.0 升级的数据库引擎上配置报表服务器数据库（Reporting Services 配置） | 介绍如何设置数据库兼容级别，以便在升级后的数据库引擎实例上创建报表服务器数据库时避免出现异常。
如何配置报表服务器以进行电子邮件传递（Reporting Services 配置） | 提供有关配置报表服务器以进行电子邮件分发的步骤。

请参阅

其他资源

Reporting Services 的帮助主题
配置 Reporting Services 组件
Reporting Services 配置工具


如何启动 Reporting Services 配置

如何启动 Reporting Services 配置 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置“如何”主题 >

Reporting Services 配置工具可用于部署 Reporting Services 安装。可以在装有本地报表服务器实例的计算机上运行此配置工具。也可以用它来配置远程报表服务器实例，您需要对这些实例具有管理员访问权限。

启动 Reporting Services 配置

  1. 单击“开始”，指向“程序”、Microsoft SQL Server 2005，再指向“配置工具”。

  2. 单击“Reporting Services 配置”。此时将出现“选择报表服务器安装实例”对话框，可以选择要配置的报表服务器实例。

  3. 在“计算机名称”中，指定安装报表服务器实例的计算机名称。指定的默认值是本地计算机名称，但也可以键入远程 SQL 服务器实例的名称。

    如果指定远程计算机，请单击“查找”以建立一个连接。必须事先配置报表服务器，以便进行远程管理。有关详细信息，请参阅 SQL Server 联机丛书中的Configuring a Remote Report Server Instance。

  4. 在“实例名称”中，选择要配置的 SQL Server 2005 Reporting Services 实例。在列表中只显示 SQL Server 2005 报表服务器实例。不能配置较早版本的 Reporting Services。

  5. 单击“连接”。

请参阅

概念

Reporting Services 配置“如何”主题

其他资源

配置 Reporting Services 组件
Reporting Services 配置工具


如何创建报表服务器数据库（Reporting Services 配置）

如何创建报表服务器数据库（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置“如何”主题 >

Reporting Services 使用 SQL Server 数据库以供内部存储使用。此数据库是必需的组件，用于存储报表、会话数据、资源和服务器元数据。

如果您安装 Reporting Services 时使用了默认配置，则在安装报表服务器实例时会自动创建报表服务器数据库。但是，如果执行了“仅文件”安装，则必须在安装完成后创建数据库。若要创建报表服务器数据库，可使用 Reporting Services 配置工具。

创建报表服务器数据库

  1. 启动 Reporting Services 配置工具，并连接到要为其创建数据库的报表服务器实例。有关如何连接到报表服务器实例的详细信息，请参阅如何启动 Reporting Services 配置。

  2. 在“数据库安装”页面上，键入或选择要使用的 SQL Server 数据库引擎实例。可以选择 SQL Server 2000 实例或 SQL Server 2005 实例。并非所有版本都可用于承载数据库。有关版本兼容性的详细信息，请参阅创建报表服务器数据库。

  3. 单击“连接”。此时将打开“SQL Server 连接”对话框，可在此对话框中指定有权在服务器上创建数据库的凭据。单击“确定”连接到服务器。

  4. 在“数据库安装”页上，单击“新建”。这将重新打开“SQL Server 连接”对话框。

  5. 键入报表服务器数据库的名称。创建主数据库时，会同时为其创建一个临时数据库。

  6. 选择要使用的排序规则语言，再单击“确定”。

  7. 在“数据库安装”页上的“凭据类型”中，指定报表服务器连接到报表服务器数据库所用的凭据。有关选择不同帐户的详细信息，请参阅设置 Windows 服务帐户和配置报表服务器数据库连接。

    1. 选择“服务凭据”，以使用 Windows 服务帐户和 Web 服务帐户通过集成安全性进行连接。

    2. 选择“Windows 凭据”可以指定域用户帐户。必须将域用户帐户指定为 <域>\<用户>。

    3. 选择“SQL Server 凭据”可以指定 SQL Server 登录名。

  8. 单击“应用”。

请参阅

任务

如何启动 Reporting Services 配置

参考

数据库安装（Reporting Services 配置）

概念

创建报表服务器数据库
Reporting Services 配置“如何”主题
配置报表服务器数据库连接

其他资源

管理报表服务器数据库
报表服务器数据库
配置 Reporting Services 组件
Reporting Services 配置工具


如何配置 Reporting Services 以使用非默认网站（Reporting Services 配置）

如何配置 Reporting Services 以使用非默认网站（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置“如何”主题 >

您可以在非默认网站下创建报表服务器和报表管理器的虚拟目录。可以通过多种方式创建、配置和访问网站。有关详细信息，请参阅 Internet 信息服务 (IIS) 产品文档。

在新的自定义网站中创建虚拟目录

  1. 在 Internet 信息服务 (IIS) 管理器中，右键单击网站，再选择“新建”。选择所需的选项和设置，通过向导逐步创建网站。

    如果尚未为该网站分配 IP 地址，则必须指定一个用于访问该站点的唯一端口号（例如，可以使用 8080）。以后测试报表服务器 URL 时，就可以打开浏览器窗口，键入 http://<servername>:8080/reportserver。若要测试报表管理器，请键入 http://<servername>:8080/reports。

    如果要分配 IP 地址，则必须编辑 RSWebApplication.config 文件，然后指定 ReportServerUrl 配置设置。

  2. 启动 Reporting Services 配置工具，再连接到报表服务器。

  3. 在“报表服务器虚拟目录”页中，单击“新建”。

  4. 选择您刚创建的网站。单击“确定”。

  5. 在“报表管理器虚拟目录”页中，单击“新建”。

  6. 选择您刚创建的网站。单击“确定”。

  7. 如果分配了一个 IP 地址，则可打开 RSWebApplication.config 文件，然后指定 ReportServerUrl 配置设置。

    1. 删除 ReportServerVirtualDirectory 中的条目。只删除值，不要删除标记。

    2. 在 ReportServerUrl 中，键入报表服务器实例的完全限定名称。完全限定报表服务器 URL 由前缀、服务器名称和虚拟目录组成。无需指定网站。以下示例展示了应使用的语法： https://salesreports/reportserver.

  8. 验证是否可以访问报表服务器和报表管理器。无需指定网站。以下示例展示了应使用的语法：https://salesreports/reportserver 与 https://salesreports/reports.

请参阅

概念

配置报表服务器虚拟目录
Reporting Services 配置“如何”主题


如何配置报表服务器扩展部署（Reporting Services 配置）

如何配置报表服务器扩展部署（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置“如何”主题 >

Reporting Services 支持扩展部署模式。该模式允许运行共享单个报表服务器数据库的多个报表服务器实例。若要创建扩展部署，可使用安装程序和 Reporting Services 配置工具。可以运行安装程序来安装报表服务器。可以运行 Reporting Services 配置工具，将各个报表服务器配置为使用共享数据库。您一次只能连接并配置一台报表服务器。

安装属于部署内容的 Reporting Services 实例时，可选择安装默认配置还是仅文件安装选项（在 SQL Server 安装向导中，这是指“报表服务器安装选项”页上的“安装但不配置”选项）。这些步骤都假定选择仅文件安装。

配置扩展部署时，必须指定将用于存储内部数据的报表服务器数据库。您可以创建新的数据库，也可以升级现有的报表服务器数据库，此数据库最初是为 SQL Server 2000 Reporting Services 安装而创建的。本主题说明如何创建新的报表服务器数据库。有关升级报表服务器数据库或现有扩展部署的详细信息，请参阅升级报表服务器数据库和升级报表服务器 Web 场。

注意：
必须使用其他产品以支持虚拟服务器配置和负载平衡。Reporting Services 不提供允许您通过共享的 URL 地址来访问所有报表服务器实例的负载平衡功能或虚拟服务器功能。

安装第一个报表服务器实例

  1. 安装属于部署内容的第一个报表服务器实例。如果执行仅文件安装，则在安装完成后，必须运行 Reporting Services 配置工具以配置服务器。有关详细信息，请参阅使用安装程序安装 Reporting Services。

  2. 启动 Reporting Services 配置，然后通过使用“报表服务器虚拟目录”页、“报表管理器虚拟目录”页和“报表管理器 Web 服务标识”页，配置虚拟目录和服务帐户。有关详细信息，请参阅配置报表服务器虚拟目录和如何启动 Reporting Services 配置。

  3. 在“数据库安装”页上，键入或选择将承载报表服务器数据库的 SQL Server 实例名称。可以选择本地实例，也可以选择远程实例。可以使用 SQL Server 2000 或 SQL Server 2005 实例。

  4. 单击“连接”连接到 SQL 服务器实例。

  5. 单击“新建”创建报表服务器数据库。将显示“SQL Server 连接”对话框。

    1. 指定具有数据库创建权限的帐户。

    2. 单击“确定”创建数据库。

  6. 在“数据库安装”页的“凭据类型”中，选择报表服务器用于连接到报表服务器数据库的帐户类型和凭据。

    如果选择“服务帐户”并使用远程 SQL Server 实例，请确保运行服务所使用的帐户具有网络访问权限。有关凭据的详细信息，请参阅配置报表服务器数据库连接。

  7. 单击“应用”。Reporting Services 配置工具创建数据库并配置连接。

  8. 在“加密密钥”页上，备份一份对称密钥。这是建议的最佳做法。当您首次创建数据库时，应始终备份密钥。

  9. 在“初始化”页上，确认已创建报表服务器实例的项。应选中“初始化”复选框。

  10. （可选）通过指定报表服务器的电子邮件传递设置以及无人参与的执行帐户，来完成报表服务器的配置。

  11. （可选）确认报表服务器可以操作。有关详细信息，请参阅如何验证 Reporting Services 安装。

安装并配置第二个报表服务器实例

  1. 运行安装程序，在另一台计算机上安装第二个 Reporting Services 实例，或在同一台计算机上将该实例安装为一个命名实例。

  2. 使用 Reporting Services 配置工具连接到刚安装的新实例，并配置该实例。有关详细信息，请参阅如何启动 Reporting Services 配置。

  3. 配置新服务器实例的服务帐户和虚拟目录。可以使用为第一个实例指定的帐户和虚拟目录，也可使用其他帐户和虚拟目录。

  4. 在“数据库安装”页上的“服务器名称”中，指定用于承载要使用的报表服务器数据库的 SQL Server 数据库引擎实例。该实例必须是先前介绍的步骤 4 中连接到的服务器。

  5. 单击“连接”。

  6. 在“数据库安装”页的“数据库名称”中，选择先前介绍的步骤 5 中创建的数据库。如果数据库列表为空，请重复前两个步骤以建立到服务器的连接。

  7. 在“数据库安装”页的“凭据类型”中，选择报表服务器用于连接到报表服务器数据库的帐户类型和凭据。可以使用第一个报表服务器实例的凭据，也可以使用其他凭据。

  8. 单击“应用”。将显示“SQL Server 连接”对话框。单击“确定”连接到服务器。报表服务器连接到报表服务器数据库，并添加其密钥信息。进行初始化时必须使用密钥信息。

  9. 在“初始化”页上，确认已创建第二个报表服务器实例的项。“初始化”复选框应处于未选中状态。第二个报表服务器实例尚未初始化。

  10. 重新连接至第一个报表服务器实例。由于已将该实例初始化为执行可逆加密操作，因此将使用它来初始化新报表服务器实例，从而进行扩展部署。初始化新的报表服务器实例时，只能通过已经初始化的报表服务器进行。

  11. 在“初始化”页上，选择要联接到部署的报表服务器实例，并单击“初始化”。对于同一个扩展部署中的所有报表服务器实例，都应选中“初始化”复选框。您可能需要刷新页面来查看更改情况。如果报表服务器实例未显示在“初始化”页上，则请验证是否已将该实例配置为使用共享数据库。

  12. 重复上述步骤，可在部署中添加其他报表服务器。如果计划在服务器群集中运行报表服务器，则必须进行额外配置。有关详细信息，请参阅配置报表服务器扩展部署。

请参阅

任务

如何启动 Reporting Services 配置

概念

Reporting Services 配置“如何”主题

其他资源

添加和删除扩展部署的加密密钥


如何在从 SQL Server 7.0 升级的数据库引擎上配置报表服务器数据库（Reporting Services 配置）

如何在从 SQL Server 7.0 升级的数据库引擎上配置报表服务器数据库（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置“如何”主题 >

必须先运行存储过程以设置兼容级别，才能在从 SQL Server 7.0 升级的 SQL Server 数据库引擎实例上创建报表服务器数据库。兼容性的设置是必要的，它可以避免出现以下异常情况：Incorrect syntax near 'COLLATE'. You may need to set the compatibility level of the current database to a higher value to enable this feature.

当尝试在从 7.0 版升级的 SQL Server 实例上创建报表服务器数据库时，就会出现此错误。

在已升级的数据库上设置兼容级别

  1. 在 master 数据库中运行 exec sp_dbcmptlevel。有关详细信息，请参阅 sp_dbcmptlevel (Transact-SQL)。

  2. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  3. 在数据库安装中，连接到已对其运行了存储过程的 SQL Server 数据库引擎实例。

  4. 单击“新建”创建数据库。

  5. 指定用来创建此数据库的数据库名称和帐户，再单击“确定”。

  6. 指定用于报表服务器数据库连接的凭据。有关详细信息，请参阅配置报表服务器数据库连接。

请参阅

概念

创建报表服务器数据库
Reporting Services 配置“如何”主题


Reporting Services 配置的 F1 帮助

Reporting Services 配置的 F1 帮助 |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 >

本部分介绍 Reporting Services 配置工具的 F1 帮助。

本节内容

主题 | 说明
报表服务器状态（Reporting Services 配置） | 提供有关要配置的报表服务器实例的信息。
报表服务器虚拟目录（Reporting Services 配置） | 提供有关报表服务器的虚拟目录配置的信息。
报表管理器虚拟目录（Reporting Services 配置） | 提供有关用于访问报表管理器的虚拟目录配置的信息。
Windows 服务标识（Reporting Services 配置） | 提供有关报表服务器 Windows 服务设置的信息。
Web 服务标识 - Windows Server 2003（Reporting Services 配置） | 提供有关 Internet 信息服务 6.0 的报表服务器 Web 服务设置的信息。
Web 服务标识（Reporting Services 配置） | 提供有关 Internet 信息服务 5.1 和 5.5 的报表服务器 Web 服务设置的信息。
数据库安装（Reporting Services 配置） | 提供有关存储报表、报表模型和服务器元数据的报表服务器数据库的信息。使用此页可以创建和配置数据库。
加密密钥（Reporting Services 配置） | 提供有关用于可逆加密的对称密钥的信息。
初始化（Reporting Services 配置） | 提供有关向扩展部署添加报表服务器实例以及从扩展部署删除报表服务器实例的信息。
电子邮件设置（Reporting Services 配置） | 提供有关报表服务器电子邮件传递扩展插件设置的信息。
执行帐户（Reporting Services 配置） | 提供有关无人参与的执行帐户配置的信息。

请参阅

任务

如何启动 Reporting Services 配置

其他资源

Reporting Services 配置工具
配置 Reporting Services 组件


报表服务器状态（Reporting Services 配置）

报表服务器状态（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置的 F1 帮助 >

使用此页可以查看当前连接的报表服务器实例的有关信息。此页是报表服务器配置的起始页。此外还提供了用于配置虚拟目录、服务帐户、报表服务器数据库、报表服务器电子邮件传递、扩展部署、单服务器初始化和对称密钥管理的其他页。

页面底部的图例显示了用于指示设置是否已配置的图标。指定的设置可能无法生成有效的配置。应始终测试 Reporting Services 安装以确保其工作正常。表示配置状态的可视指示符不能替代用于验证部署是否成功的测试。有关如何验证部署的详细信息，请参阅如何验证 Reporting Services 安装。

具有高级服务的 SQL Server 2005 Express Edition (SQL Server Express) 用户应注意以下方面：

  • SQL Server Express 不支持报表服务器电子邮件和扩展部署。

  • 报表服务器数据库必须由本地的 SQL Server Express 数据库引擎实例承载。不能使用远程 SQL Server 实例承载数据库。

  • 报表中使用的数据源也必须是在本地 SQL Server Express 数据库引擎实例中运行的 SQL Server 数据库。不能使用远程数据源或其他数据源类型。若要使用其他数据源类型，必须使用 Reporting Services 的其他版本。

选项

连接

打开“选择报表服务器安装实例”对话框，以便指定不同的报表服务器来进行配置。若要连接到报表服务器，您必须是运行所配置报表服务器的计算机的本地管理员。

刷新

使用最新的报表服务器状态更新当前页。

实例属性

显示当前连接的报表服务器实例的有关信息。报表服务器实例名称基于 SQL Server 命名实例。报表服务器的默认实例为 MSSQLSERVER。如果使用的是 SQL Server Express，则默认实例为 SQLExpress。

启动

启动报表服务器 Windows 服务。在更改某些配置之后（例如，在更改计算机名称之后重新配置报表服务器时），需要重新启动 Windows 服务。

停止

停止报表服务器 Windows 服务。停止服务会导致报表服务器停止工作。有关详细信息，请参阅启动和停止报表服务器 Windows 服务。

请参阅

概念

Reporting Services 配置的 F1 帮助

其他资源

配置 Reporting Services 组件


报表服务器虚拟目录（Reporting Services 配置）

报表服务器虚拟目录（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置的 F1 帮助 >

使用“报表服务器虚拟目录”页可以配置报表服务器的虚拟目录。用于访问报表服务器 Web 服务的 URL 将包含该虚拟目录名称。报表服务器 Web 服务需要仅供该报表服务器使用的专用虚拟目录。Reporting Services 所需的所有 Internet 信息服务 (IIS) 设置都将通过您所创建的虚拟目录进行配置。

可以使用此页创建或修改报表服务器虚拟目录。如果为新的 Reporting Services 安装创建虚拟目录，请单击“新建”。在创建虚拟目录时，Reporting Services 配置工具将通过 Internet 信息服务 (IIS) 创建和配置虚拟目录。Reporting Services 配置工具还将使用报表服务器 URL 更新配置文件。如果计算机具有安全套接字层 (SSL) 证书，则可以指定对报表服务器 Web 服务的所有调用都使用一个证书。

注意：
Reporting Services 需要专用的报表服务器虚拟目录。不能使用现有目录。在新部署中，必须为报表服务器访问创建新的虚拟目录。

选项

名称

指定虚拟目录名称。

网站

指定用于访问报表服务器实例的网站名称。

新建

打开“创建虚拟目录”对话框，在该对话框中可以选择一个现有网站来承载报表服务器，并键入虚拟目录名称。必须为虚拟目录指定唯一的名称。必须选择一个现有网站来承载报表服务器。

IIS 的版本将决定报表服务器 Web 服务帐户：

在 IIS 6.0 中，应用程序域池的标识将决定报表服务器 Web 服务的帐户。Reporting Services 使用它自己的应用程序池，此应用程序池继承了默认应用程序池的安全标识。在 IIS 6.0 中，默认的安全标识为网络服务。

在 IIS 5.0 或 5.1 中，使用 ASP.NET 进程标识来运行 Web 服务。默认情况下，该进程为本地 ASP.NET 工作进程。

应用默认设置

单击“应用默认设置”可以使用默认配置替换现有的虚拟目录配置。不保留任何自定义设置。

要求安全套接字层 (SSL) 连接

选中此复选框可以指定 SSL 连接级别。若要使用此选项，必须已安装证书。还必须修改 RSReportServer.config 文件中的 UrlRoot 配置设置，以便指定要为其注册证书的计算机的完全限定名称。有关详细信息，请参阅 SQL Server 联机丛书中的Configuring a Report Server for Secure Sockets Layer (SSL) Connections。

要求:

指定报表服务器属性中的 SSL 连接级别。有以下三种级别：

1 - 仅连接

2 - 报表数据

3 - 整个 Web 服务 API

级别是依次递增的。级别 3 最安全。级别 0 不是下拉列表中的值，但是用来指定无 SSL 连接。有关详细信息，请参阅 SQL Server 联机丛书中的Using Secure Web Service Methods。

证书名称

指定要为其注册证书的完全限定的计算机名称。指定的名称必须与证书注册的名称相同。

请参阅

概念

Reporting Services 配置的 F1 帮助
配置报表服务器虚拟目录


报表管理器虚拟目录（Reporting Services 配置）

报表管理器虚拟目录（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置的 F1 帮助 >

使用“报表管理器虚拟目录”页可以配置用于访问报表管理器的虚拟目录。用于访问报表管理器的 URL 将包含该虚拟目录名称。如果为新的 Reporting Services 安装创建虚拟目录，请单击“新建”以指定名称。

在指定虚拟目录时，Reporting Services 配置工具将通过 Internet 信息服务 (IIS) 创建和配置虚拟目录。还会使用报表管理器虚拟目录名称更新配置文件。

注意：
Reporting Services 需要专用的报表管理器虚拟目录。不能使用现有目录。在新部署中，必须为报表管理器访问创建新的虚拟目录。

选项

名称

指定虚拟目录名称。

网站

指定用于访问报表管理器的网站的名称。

新建

打开“创建虚拟目录”对话框，在该对话框中可以选择一个现有网站来承载报表服务器，并键入虚拟目录名称。必须为虚拟目录指定唯一的名称。必须选择一个现有网站来承载报表服务器。

应用默认设置

单击“应用默认设置”可以使用默认配置替换现有的虚拟目录配置。不保留任何自定义设置。

请参阅

概念

Reporting Services 配置的 F1 帮助
配置报表服务器虚拟目录

其他资源

报表管理器


Windows 服务标识（Reporting Services 配置）

Windows 服务标识（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置的 F1 帮助 >

使用“Windows 服务标识”页可以指定报表服务器 Windows 服务作为哪一帐户运行。此帐户最初在安装过程中进行配置。如果您已经更改了该帐户或密码，则可以对其进行修改。更新的服务标识信息将经过加密并保存到 RSReportServer.config 文件中。在更新 Windows 服务标识时，请遵循以下原则：

  • 如果选择内置帐户，请选择可建立网络连接的帐户。SQL Server 2005 使用域帐户作为默认的服务帐户。

  • 如果您使用的是 Windows Server 2003，则可以使用网络服务帐户。

  • 不建议使用本地系统帐户。因为它所具有的权限多于服务要求的权限。

  • 本地服务帐户在大多数情况下都不适用。除非所有客户端操作和服务器操作都是以独占方式在本地计算机上执行的，否则请避免使用此内置帐户。

如果您切换帐户（例如，用一个 Windows 帐户替换另一个 Windows 帐户，或用 Windows 域帐户替换内置帐户），系统将会提示您创建对称密钥的备份副本。一旦您选择该新帐户，就会自动还原相应的备份副本。

注意：
每当您修改服务帐户时，Reporting Services 配置工具都会提示您备份和还原加密密钥。必须执行这些步骤，才可以确保报表服务器仍可访问加密数据。有关这些操作的详细信息，请参阅加密密钥（Reporting Services 配置）。

选项

服务名称

指定报表服务器 Windows 服务帐户名 (ReportServer)。

服务帐户

指定 Windows 服务作为哪一帐户运行。您只能选择现有帐户，而不能在 Reporting Services 配置中创建新的帐户。

内置帐户

选择此选项可选择系统帐户。

Windows 帐户

选择此选项可选择域帐户。

用户名

用以下格式指定域帐户：<域>\<用户>。

密码

指定密码。

请参阅

概念

Reporting Services 配置的 F1 帮助

其他资源

报表服务器
启动和停止报表服务器 Windows 服务
更改服务帐户和密码


Web 服务标识 - Windows Server 2003（Reporting Services 配置）

Web 服务标识 - Windows Server 2003（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置的 F1 帮助 >

使用此页可查看或修改运行在 Internet 信息服务 (IIS) 6.0 上的报表服务器的 Web 服务使用的服务帐户。报表服务器 Web 服务帐户是在您创建报表服务器虚拟目录时配置的。但是，通过选择或创建为要使用的帐户配置的应用程序域池，也可以在其他帐户下运行 Web 服务。

建议您始终使用 Reporting Services 配置工具设置应用程序域池，以便自动更新受更改影响的设置。具体地说，如果使用的是报表服务器数据库连接的服务帐户，则配置工具将更新报表服务器数据库中的连接信息以使用新帐户。如果使用其他工具来创建或配置域池，报表服务器配置可能会不完整。

有时，在升级了 Reporting Services 后，会在导航窗格中的 Web 服务标识附近出现一个红色的 X。如果 IIS 中仍存在以前的安装的设置时，就可能出现这种情况。新建一个应用程序域池即可解决此问题。

选项

报表服务器

指定报表服务器 Web 服务的域池。

报表管理器

指定报表管理器的域池。默认情况下，报表管理器与报表服务器使用相同的应用程序域池。

请参阅

概念

配置报表服务器数据库连接
配置报表服务器虚拟目录
Reporting Services 配置的 F1 帮助

其他资源

Introducing the Report Server Web Service
管理报表服务器 Web 服务和 Windows 服务


Web 服务标识（Reporting Services 配置）

Web 服务标识（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置的 F1 帮助 >

使用此页可以查看报表服务器 Web 服务使用的服务帐户信息。报表服务器 Web 服务帐户是在您创建报表服务器虚拟目录时配置的。

在使用 Internet 信息服务 (IIS) 5.0 或 5.01 时，或以隔离模式运行 IIS 6.0 时，将显示此页。如果使用的是这些版本的 IIS，则无法配置报表服务器 Web 服务标识。该服务始终在 ASP.NET 进程标识下运行。

请参阅

概念

配置报表服务器虚拟目录
Reporting Services 配置的 F1 帮助

其他资源

Introducing the Report Server Web Service
管理报表服务器 Web 服务和 Windows 服务


数据库安装（Reporting Services 配置）

数据库安装（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置的 F1 帮助 >

使用“数据库安装”页可以创建和配置为一个或多个报表服务器实例提供内部存储位置的报表服务器数据库。有关此页的逐步说明，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

注意：
如果使用的是具有高级服务的 SQL Server 2005 Express Edition，则必须使用本地的 SQL Server Express 数据库引擎实例承载报表服务器数据库。若要在从版本 7.0 升级的 SQL Server 实例上创建报表服务器数据库，则可能需要在创建数据库之前设置数据库兼容级别。有关详细信息，请参阅Reporting Services in SQL Server 2005 Express Edition with Advanced Services 和如何在从 SQL Server 7.0 升级的数据库引擎上配置报表服务器数据库（Reporting Services 配置）。

选项

服务器名称

指定运行报表服务器数据库的 SQL Server 数据库引擎的名称。

连接

单击“连接”可以登录到 SQL Server 数据库引擎。此时将打开“SQL Server 连接”对话框，以便指定登录服务器所用的凭据。可使用自己的凭据或指定 SQL Server 登录名。

数据库名称

指定存储服务器数据的报表服务器数据库的名称。可以指定现有的数据库或创建新的数据库。

若要升级或迁移 Reporting Services 安装，请选择现有的数据库。只有具有报表服务器表的数据库可供选择。

如果选择使用 Reporting Services 的 SQL Server 2000 版本创建的报表服务器数据库，则可以将该数据库升级为新的格式。

新建

单击“新建”可以在当前连接的 SQL Server 实例上创建新的数据库。此时将打开“SQL Server 连接”对话框，以便指定在此服务器上具有创建新数据库的权限的凭据。

Reporting Services 配置工具将创建按名称绑定的两个数据库：一个具有静态数据的数据库和一个存储会话和工作数据的临时数据库。

升级

单击“升级”可以将表迁移到新的数据库架构。数据库就地进行升级。如果要将数据库用于 SQL Server 2005 Reporting Services 实例，则需要升级该数据库。有关详细信息，请参阅升级 Reporting Services 的默认安装。

凭据类型

指定报表服务器用来连接报表服务器数据库的凭据。有关选择凭据的详细信息，请参阅配置报表服务器数据库连接。

帐户名

如果使用的是 Windows 凭据，请指定域用户帐户；如果使用的是 SQL Server 凭据，请指定 SQL Server 登录名。如果使用的是 Windows 凭据，则按以下格式指定凭据：<domain>\<account>

密码

指定帐户的密码。

脚本

单击“脚本”可以创建供将来在脚本环境下使用的 SQL 脚本 (.sql) 文件。可以创建脚本来创建报表服务器数据库或将报表服务器数据库升级到当前架构。也可以创建和运行相应的脚本，为用来连接报表服务器数据库的帐户配置 SQL Server 数据库角色。

请参阅

任务

如何创建报表服务器数据库（Reporting Services 配置）

概念

Reporting Services 配置的 F1 帮助
配置报表服务器数据库连接
配置报表服务器扩展部署

其他资源

报表服务器数据库
管理报表服务器数据库


加密密钥（Reporting Services 配置）

加密密钥（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置的 F1 帮助 >

使用“加密密钥”页可以管理用于对报表服务器中数据进行加密和解密的对称密钥。管理加密密钥是报表服务器配置的一个重要方面。虽然在您创建报表服务器数据库时将自动创建并应用对称密钥，但是您必须创建对称密钥的备份副本，以便执行日常的维护操作。您需要具有对称密钥的有效副本，才可执行以下维护任务：

  • 更改报表服务器 Windows 服务的服务帐户。

  • 将 Reporting Services 安装迁移到其他计算机。

  • 配置新的报表服务器实例以共享或使用现有报表服务器数据库。

选项

备份

将对称密钥复制到您指定的文件。对称密钥决不能以纯文本形式存储。您必须键入密码来保护该文件。

还原

将以前保存的对称密钥的副本应用于报表服务器数据库。您必须提供密码对文件进行解锁。

还原后的对称密钥副本将覆盖当前连接的报表服务器实例还原前的对称密钥副本。还原对称密钥后，您必须初始化使用该报表服务器数据库的所有报表服务器。有关初始化报表服务器的详细信息，请参阅初始化报表服务器。

更改

重新创建对称密钥并对报表服务器数据库中的所有加密值重新进行加密。请确保在重新创建对称密钥前停止报表服务器 Windows 服务。

在扩展部署中，对称密钥的所有副本都将替换为新的版本。在更改对称密钥前，请务必检查加入扩展部署的服务器的列表，验证仅对有效的报表服务器实例授予了对新密钥的访问权限。“已初始化”页列出了扩展部署中包含的服务器。在重新创建密钥前，请停止部署中包含的各报表服务器上的 Windows 服务。

请注意，如果您具有许多数据源和订阅，则重新生成对称密钥的过程可能需要耗费较长的时间。

删除

删除对称密钥和所有加密内容（包括连接字符串和存储的凭据）。如果您无法还原对称密钥，则只能删除该密钥。

一旦删除了对称密钥，您必须在报表和共享数据源中重新输入缺少的连接字符串和存储的凭据，因为其中已不再具有这些值。另外，对于使用存储加密数据的传递扩展插件的所有订阅，还必须进行更新。这包括使用加密值的文件共享传递扩展插件和任何第三方传递扩展插件。

此信息无法自动更新。一次只能更新一个使用存储的凭据和连接字符串的报表、订阅和共享数据源。

请参阅

概念

Reporting Services 配置的 F1 帮助

其他资源

备份和还原加密密钥
删除和重新创建加密密钥
初始化报表服务器
存储加密的报表服务器数据


初始化（Reporting Services 配置）

初始化（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置的 F1 帮助 >

已初始化的报表服务器是指可以对报表服务器数据库中存储的敏感数据进行加密和解密的服务器（例如，存储的凭据和连接字符串）。报表服务器初始化是一项必需的报表服务器操作。

使用此页可以查看报表服务器实例的初始化状态。如果报表服务器是扩展部署的一部分，此页将显示多个报表服务器实例的初始化状态。也可以使用此页将报表服务器联接到扩展部署。有关详细信息，请参阅如何配置报表服务器扩展部署（Reporting Services 配置）。

注意：
具有高级服务的 SQL Server 2005 Express Edition、SQL Server 2005 Workgroup Edition 或 SQL Server Standard Edition 不支持此功能。有关 Express Edition 提供的功能的详细信息，请参阅 SQL Server 联机丛书中的Reporting Services in SQL Server 2005 Express Edition with Advanced Services。

选项

计算机

显示承载报表服务器实例的计算机的名称。如果升级了报表服务器但缺少此条目，则可将计算机名称添加到密钥表中。

实例

显示报表服务器实例名称。报表服务器实例基于 SQL Server 实例。

ID

显示报表服务器安装过程中创建的 GUID。您可以将此值与 rskeymgmt -n 参数配合使用，以初始化处于无法加密或解密报表服务器数据库中数据的状态的远程报表服务器实例。

已初始化

指示报表服务器是否已初始化。

初始化

单击“初始化”，可以将报表服务器配置为使用共享报表服务器数据库中的对称密钥。可以使用“初始化”将报表服务器实例添加到扩展部署中，或者排除迁移或安装故障。若要配置扩展部署，请选择要添加的报表服务器实例，然后单击“初始化”。必须事先配置好每个报表服务器实例，以便使用共享报表服务器数据库。此外，还必须从已初始化为使用报表服务器数据库的报表服务器执行初始化操作。

删除

单击“删除”可以从报表服务器数据库中删除选定报表服务器实例的加密密钥。您可以通过删除密钥将报表服务器从扩展部署中删除，或者排除迁移或安装故障。使用此选项，将仅删除指定报表服务器实例的加密密钥。报表服务器数据库中的加密数据不受影响。

请确保在删除密钥之前创建了该密钥的备份副本，作为一种防范措施。一旦删除列表中最后一个报表服务器的加密密钥，将对该数据库的任何后续报表服务器初始化提出新的要求。新的要求是初始化报表服务器之后，必须还原对称密钥的备份副本。如果希望访问报表服务器数据库中当前存在的加密数据，还原对称密钥是必需的。

如果不再需要加密数据或者没有密钥的备份副本，则必须删除该加密数据。有关详细信息，请参阅加密密钥（Reporting Services 配置）。

请参阅

任务

如何配置报表服务器扩展部署（Reporting Services 配置）

概念

配置报表服务器扩展部署
升级报表服务器 Web 场

其他资源

rskeymgmt 实用工具
初始化报表服务器
管理加密密钥


电子邮件设置（Reporting Services 配置）

电子邮件设置（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置的 F1 帮助 >

使用此页可指定启用报表服务器电子邮件传递扩展插件的简单邮件传输协议 (SMTP) 设置。使用报表服务器电子邮件传递扩展插件可以通过电子邮件订阅来分发报表或报表处理通知。报表服务器电子邮件传递扩展插件需要使用 SMTP 服务器并在“发件人:”字段中使用电子邮件地址。

其他的配置设置（包括限制邮件服务器主机和呈现扩展插件可用性的设置）可用于进一步自定义电子邮件订阅。不能在 Reporting Services 配置工具中指定这些设置。若要配置其他设置，必须手动编辑 RSReportServer.config 文件。有关详细信息，请参阅配置报表服务器以进行电子邮件传递和 Reporting Services 配置文件。

注意：
包含高级服务的 SQL Server 2005 Express Edition 不支持此功能。有关 Express Edition 提供的功能的详细信息，请参阅 SQL Server 联机丛书中的Reporting Services in SQL Server 2005 Express Edition with Advanced Services。

选项

发件人电子邮件

指定要在所生成电子邮件的“发件人:”字段中使用的电子邮件地址。您必须指定一个有权从 SMTP 服务器中发送邮件的用户帐户。

传递方法

指定报表服务器电子邮件通过 SMTP 服务器进行路由。这是可以在 Reporting Services 配置工具中指定的唯一传递方法。

另一种传递方法是使用本地 SMTP 服务拾取目录。如果网络 SMTP 服务不可用，则可以使用此传递方法。若要指定本地 SMTP 服务拾取目录，必须编辑 RSReportServer.config 文件。如果您编辑配置文件以使用本地 SMTP 服务拾取目录，Reporting Services 配置工具会将“传递方法”选项设置为“自定义”，以指示传递方法在配置文件中指定。

在配置文件中，可以通过 SendUsing 配置设置来设置传递方法。有关指定 SendUsing 设置的详细信息，请参阅配置报表服务器以进行电子邮件传递。

SMTP 服务器

选择要使用的 SMTP 服务器或网关。可以使用网络中的本地服务器或 SMTP 服务器。

请参阅

概念

配置报表服务器以进行电子邮件传递
Reporting Services 配置的 F1 帮助


执行帐户（Reporting Services 配置）

执行帐户（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 安装 > Reporting Services 配置 > Reporting Services 配置的 F1 帮助 >

使用此页可以配置用于无人参与处理的帐户。只有在其他凭据源不可用的以下特殊情况时，才使用此帐户：

  • 当报表服务器连接到不需要凭据的数据源时。

  • 当报表服务器连接到其他服务器以检索报表中所引用的外部图像文件或其他资源时。

报表服务器服务帐户凭据从不能用于连接其他计算机。为报表检索数据时，报表服务器将模拟当前用户、提示用户提供凭据或使用存储的凭据，或者，如果数据源不接受凭据，则会使用无人参与的执行帐户。此帐户为可选设置。如果配置了执行帐户，该帐户将以加密值的形式存储在 RSReportServer.config 文件中。

注意：
如果使用具有高级服务的 SQL Server 2005 Express Edition，则仅在引用报表中的外部图像并且访问图像文件需要权限时，才需要配置该帐户。有关详细信息，请参阅向报表中添加图像。

选项

指定执行帐户

单击此复选框可指定帐户。

帐户

指定 Windows 域用户帐户或本地用户帐户。请使用以下格式指定帐户：<域>\<用户帐户>。

密码

键入密码。

验证密码

重新键入密码。

请参阅

概念

Reporting Services 配置的 F1 帮助
配置用于无人参与的报表处理的帐户

其他资源

RSReportServer 配置文件
存储加密的报表服务器数据


网络协议和网络库

网络协议和网络库 |
 | 请参阅
配置 SQL Server 安装 >

服务器可以同时监听或监视多个网络协议。但必须对每个协议都进行配置。如果没有配置某个协议，则服务器将无法监听该协议。安装完成后，可以使用 SQL Server 配置管理器更改这些协议配置。

默认 SQL Server 网络配置

默认的 SQL Server 2005 实例被配置为 TCP/IP 端口 1433 以及 named pipe \\.\pipe\sql\query。SQL Server 2005 命名实例被配置为 TCP 动态端口，其端口号由操作系统分配。

如果无法使用动态端口地址（例如，当 SQL Server 连接必须通过服务器配置为要通过特定端口地址的防火墙时，或者当某些连接是使用 SQL Server 7.0 或更早版本的客户端组件建立的时），则推荐使用小于 1024 的端口地址。请在此范围内，选择一个未被操作系统或其他应用程序使用的端口。

为了增强安全性，当安装 SQL Server 2005 时不会完全启用网络连接。若要在安装完成后启用、禁用和配置网络协议，请使用 SQL Server 2005 外围应用配置器工具或 SQL Server 配置管理器的 SQL Server 2005 网络配置区域。

端点的类型

SQL Server 2005 引入了 SQL Server 连接的新概念，在服务器端用 Transact-SQL 端点来表示连接。可以对 Transact-SQL 端点授予、撤消和拒绝权限。默认情况下，所有用户都具备访问端点的权限，除非 sysadmin 组的成员或端点所有者拒绝或撤消了此权限。GRANT、REVOKE 和 DENY ENDPOINT 语法使用管理员必须从端点的目录视图中获得的端点 ID。

SQL Server 安装程序为所有支持的网络协议以及专用管理员连接创建 Transact-SQL 端点。请参阅下表了解默认网络配置设置。

由 SQL Server 安装程序所创建的 Transact-SQL 端点如下：

  • TSQL 本地计算机

  • TSQL Named Pipes

  • TSQL 默认 TCP

  • TSQL 默认 VIA

有关管理 Transact-SQL 端点的详细信息，请参阅 SQL Server 2005 联机丛书中的“网络协议和 TDS 端点”。

默认配置

下表说明了默认网络配置设置。

SQL Server 版本 | 新安装或升级 | 共享内存 | TCP/IP | Named Pipes | VIA
Enterprise | 新建 | 已启用 | 已启用 | 已禁用（仅本地） | 已禁用
Developer | 新建 | 已启用 | 已禁用 | 已禁用（仅本地） | 已禁用
Standard | 新建 | 已启用 | 已启用 | 已禁用（仅本地） | 已禁用
Workgroup | 新建 | 已启用 | 已启用 | 已禁用（仅本地） | 已禁用
Evaluation | 新建 | 已启用 | 已禁用 | 已禁用（仅本地） | 已禁用
SQL Server Express | 新建 | 已启用 | 已禁用 | 已禁用（仅本地） | 已禁用
所有版本 | 升级或并行安装 | 已启用 | 以前安装中保留下来的设置 | 以前安装中保留下来的设置 | 已禁用

对于故障转移群集安装，请注意下列补充信息：

  • 如果实例正在 SQL Server 2005 故障转移群集上运行，它将侦听 SQL Server 安装过程中所选的每一个 IP 地址上的端口。若要启用其他网络协议，请使用外围应用配置器工具或者 SQL Server 配置管理器。

从命令提示符安装 SQL Server 2005 时，可以指定 SQL Server 浏览器服务的启动类型。默认情况下，SQL Server 安装程序安装 SQL Server 浏览器后会将其禁用并停止。若要将该服务配置为自动启动，请参阅如何从命令提示符安装 SQL Server 2005 中的 DISABLENETWORKPROTOCOLS 参数。

有关管理 SQL Server 网络配置的详细信息，请参阅 SQL Server 2005 联机丛书中的下列主题：

  • “服务器网络配置”

  • “配置服务器网络协议和网络库”

  • “默认 SQL Server 网络配置”

  • “网络库和网络协议”

请参阅

概念

准备安装 SQL Server 2005


SQL Server 2005 的默认实例和命名实例的文件位置

SQL Server 2005 的默认实例和命名实例的文件位置 |
 | 请参阅
配置 SQL Server 安装 >

Microsoft SQL Server 2005 的安装包含一个或多个单独的实例。无论是默认的还是命名的实例，都有自己的一套程序文件和数据文件，以及一套在计算机上的所有实例之间共享的公共文件。

对于包含数据库引擎、Analysis Services 和 Reporting Services 的 SQL Server 实例，每个组件都有一套完整的数据文件和可执行文件，以及由所有组件共享的公共文件。

为了隔离每个组件的安装位置，在给定的 SQL Server 实例中为每个组件都生成了唯一的实例 ID。这使单个组件可以升级到将来的 SQL Server 版本，而与其他 SQL Server 组件无关。

重要事项：
请不要删除下列任何目录或其中的内容：Binn、Data、Ftdata、HTML 或 1033。如有必要，可以删除其他目录；但是，如果不卸载并重新安装 SQL Server 2005，则可能无法检索失去的功能或数据。

注意：
不要删除或修改 HTML 目录中的任何 .htm 文件。它们对于 SQL Server 工具的正常运行是必需的。

所有 SQL Server 2005 实例的共享文件

单台计算机上的所有实例使用的公共文件安装在文件夹 systemdrive:\Program Files\Microsoft SQL Server\90 中，其中 systemdrive 是安装组件的驱动器号。通常为驱动器 C。

注意：
程序文件和数据文件不能安装在可移动磁盘驱动器上，不能安装在使用压缩的文件系统上，也不能安装在故障转移群集实例的共享驱动器上。

文件位置和注册表映射

SQL Server 安装过程中，为每个服务器组件生成一个实例 ID。此 SQL Server 版本中的服务器组件是数据库引擎、Analysis Services 和 Reporting Services。实例 ID 的格式为 MSSQL.n，其中 n 是安装组件的序号。实例 ID 用在文件目录和注册表根目录中。

第一个生成的实例 ID 为 MSSQL.1，其他实例的 ID 号依次递增，如 MSSQL.2，MSSQL.3 等。如果由于卸载而使 ID 序列中断，则将生成 ID 号来填充中断。最新安装的实例可能并不总是有最高的实例 ID 号。

服务器组件以 <instanceID>\<component name> 格式安装在目录中。例如，包含数据库引擎、Analysis Services 和 Reporting Services 的默认实例或命名实例具有以下默认目录：

  • <Program Files>\Microsoft SQL Server\MSSQL.1\MSSQL\（对于数据库引擎）

  • <Program Files>\Microsoft SQL Server\MSSQL.2\OLAP\（对于 Analysis Services）

  • <Program Files>\Microsoft SQL Server\MSSQL.3\RS\（对于 Reporting Services）

如果用户选择更改默认安装目录，则不使用 <Program Files>\Microsoft SQL Server，而使用 <custom path>。

注意：
SQL Server 2005 Integration Services、Notification Services 以及客户端组件为非实例识别组件，因此不给它们分配实例 ID。默认情况下，将非实例识别组件安装到相同目录中：<system drive>:\Program Files\Microsoft SQL Server\90\。更改一个共享组件的安装路径会同时更改其他共享组件的安装路径。后续安装会将非实例识别组件安装到与原始安装相同的目录。

在 HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.n 下为实例识别组件创建了注册表配置单元。例如，

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.2

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.3

注册表还维护实例 ID 到实例名的映射。实例 ID 到实例名的映射按如下方式维护：

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL.1"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="MSSQL.2"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSSQL.3"

AdventureWorks 示例数据库（新）

AdventureWorks 示例安装在 Tools\Samples 目录中。对于无人参与安装，如果要将示例数据库附加到特定的 SQL Server 实例，请使用 SAMPLEDATABASESERVER=\<instancename> 开关。示例数据库附加到的实例必须是本地实例。

有关无人参与安装的详细信息，请参阅 SQL Server 2005 远程安装信息、如何从命令提示符安装 SQL Server 2005 或 SQL Server DVD 上的 Template.ini 文件中包含的说明。

指定文件路径

安装过程中，可以更改下列功能的安装路径：

安装程序中仅显示具有用户可配置目标文件夹的功能的安装路径：

组件 | 默认路径1, 2 | 可配置路径3或固定路径
数据库引擎服务器组件 | \Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Binn\ | 可配置
数据库引擎数据文件 | \Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Data\ | 可配置
Analysis Services 服务器 | \Program Files\Microsoft SQL Server\MSSQL.n\OLAP\Bin\ | 可配置
Analysis Services 数据文件 | \Program Files\Microsoft SQL Server\MSSQL.n\OLAP\Data\ | 可配置
Reporting Services 报表服务器 | \Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportServer\Bin\ | 可配置
Reporting Services 报表管理器 | \Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportManager\Bin\ | 固定路径
SQL Server Integration Services | <安装目录>\90\DTS\ | 可配置4
Notification Services | <安装目录>\90\Notification Services\ | 可配置4
客户端组件 | <安装目录>\90\Tools\ | 可配置4
复制和服务器端 COM 对象 | Program Files\Microsoft SQL Server\90\COM\5 | 固定路径
数据转换运行时引擎、数据转换管道引擎和 dtexec 命令提示实用工具的 SQL Server Integration Services 组件 DLL | Program Files\Microsoft SQL Server\90\DTS\Binn | 固定路径
为 SQL Server Integration Services 提供托管连接支持的 DLL | Program Files\Microsoft SQL Server\90\DTS\Connections | 固定路径
SQL Server integration Services 支持的每种枚举器类型的 DLL | Program Files\Microsoft SQL Server\90\DTS\ForEachEnumerators | 固定路径
SQL Server 浏览器服务、WMI 提供程序 | \Program Files\Microsoft SQL Server\90\Shared\ | 固定路径
在 SQL Server 2005 的所有实例之间共享的组件 | \Program Files\Microsoft SQL Server\90\Shared\ | 固定路径

1确保使用有限的权限对 \Program Files\Microsoft SQL Server\ 文件夹进行了保护。

2这些位置的默认驱动器为 systemdrive，通常为驱动器 C。

3子功能的安装路径由父功能的安装路径决定。

4SQL Server Integration Services、Notification Services 和客户端组件之间共享单个安装路径。更改一个组件的安装路径会同时更改其他组件的安装路径。后续安装将组件安装到与原始安装相同的位置。

5此目录供计算机上的所有 SQL Server 实例使用。如果对计算机上的任意实例应用更新，如 Service Pack，则对此文件夹中的文件的任何更改都将影响到计算机上的所有实例。

注意：
对于群集配置，必须选择在该群集的每个节点上都可用的本地驱动器。

注意：
向现有安装中添加功能时，不能更改以前安装的功能的位置，也不能为新功能指定该位置。必须将其他功能安装到安装程序已建立的目录，或者卸载并重新安装产品。

在安装过程中指定服务器组件或数据文件的安装路径时，安装程序除了使用程序文件和数据文件的指定位置外，还使用实例名。安装程序不会将实例名用于工具和其他共享文件。此外，安装程序也不会将任何实例名用于 Analysis Services 程序和数据文件，尽管它会将实例名用于 Analysis Services 存储库。

如果设置了数据库引擎 功能的安装路径，则 SQL Server 安装程序使用该路径作为此安装的所有实例特定文件夹的根目录，包括 SQL 数据文件。在这种情况中，如果将根目录设置为 C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\，实例特定的目录将添加到此路径的末尾。

如果在 SQL Server 安装向导（安装程序用户界面模式）中选择使用 USESYSDB 升级功能，用户就能够轻松地将产品安装到递归文件夹结构（如 <SQLProgramFiles>\MSSQL.1\MSSQL\MSSQL.1\MSSQL\Data\）中。若要使用 USESYSDB 功能，请设置 SQL 数据文件功能的安装路径，而不是数据库引擎功能的安装路径。

注意：
数据文件始终应位于名为 Data 的子目录中。例如，当数据文件位于 C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data 下时，应指定 C:\Program Files\Microsoft SQL Server\MSSQL.1\ 以指定升级过程中系统数据库的数据目录的根路径。

请参阅

参考

功能选择


更改密码和用户帐户

更改密码和用户帐户 |
 | 请参阅
配置 SQL Server 安装 >

Microsoft SQL Server 2005 服务帐户和密码链接到 Microsoft Windows 用户帐户和密码。一个位置的更改可能要求另一个位置也做出更改。

安装后更改 SQL Server 服务帐户

安装 SQL Server 2005 后，使用 SQL Server 配置管理器更改任何 SQL Server 相关服务的指定密码或其他属性。每个服务都必须单独更改。新用户帐户在服务重新启动时生效。

重要事项：
在故障转移群集节点关闭或脱机时，不应更改任何 SQL Server 服务帐户的密码。如果一定要这么做，则在所有节点恢复联机状态后，必须使用配置管理器重置密码。

给帐户授予下列权限：

  • SeServiceLogonRight，使帐户可以作为服务运行。

  • SeLockMemoryPrivilege，使帐户可以使用 SQL Server 的 AWE 内存功能。

  • SeTcbPrivilege，使帐户可以模拟其他帐户。

如果要在故障转移群集配置中运行 SQL Server，则还要为群集中的所有二进制文件和所有节点的数据安装位置设置权限。还要向聚集对象上的服务帐户授予权限。

注意：
如果要运行 Microsoft Windows 2000 并使用 Windows 2000 加密文件系统对所有 SQL Server 文件进行加密，必须首先解密这些文件，然后才能更改 SQL Server 服务帐户。如果不解密这些文件就重置 SQL Server 服务帐户，将无法解密这些文件。

SQL Server 的当前服务帐户更改为非管理员帐户将导致现有的全文目录无法访问。此时需重建并完全填充属于此 SQL Server 实例的所有目录，或切换回具有管理员权限的帐户。

可将 SQLServerAgent 服务帐户更改为非 Windows NT 4.0 管理员帐户。但是，Windows NT 4.0 帐户必须是 sysadmin 固定服务器角色的成员，才能运行 SQL Server 代理。

有关详细信息，请参阅设置 Windows 服务帐户。

Windows 密码更改

如果 Windows 密码在安装 SQL Server 2005 后更改（如密码失效），则还必须在 Windows 中修改 SQL Server 服务的用户帐户信息。

更改 SQL Server 服务登录帐户信息 (Windows 2000)

在控制面板中更改 SQL Server 服务帐户信息后，还必须在 SQL Server 配置管理器中更改 SQL Server 服务帐户。这将使 Microsoft 搜索服务的服务帐户信息也保持同步。

安全说明：
设置强密码对于确保系统的安全至关重要。始终使用强密码。

重要事项：
虽然 Microsoft 搜索服务总是指派给本地系统帐户，但是全文检索引擎却对 Windows 中的 SQL Server 服务帐户进行跟踪。如果 Windows 密码更改没有重置，则全文检索和故障转移群集将不可用。

有关创建 Windows 用户帐户、授予高级用户权限、设置密码过期和管理组成员的详细信息，请参阅 Windows 文档或“域用户管理器帮助”。Microsoft Windows 2000 用户请参阅 Windows 2000 文档中的“计算机管理”或“组策略编辑器”。

请参阅

概念

SQL Server 外围应用配置器


系统和示例数据库

系统和示例数据库 |
 | 请参阅
配置 SQL Server 安装 >

安装 SQL Server 2005 时，安装程序会创建下表中显示的数据库和日志文件。

数据库 | 数据库文件 | 日志文件
master | Master.mdf | Mastlog.ldf
model | Model.mdf | Modellog.ldf
msdb | Msdbdata.mdf | Msdblog.ldf
tempdb | Tempdb.mdf | Templog.ldf

master、model、msdb 和 tempdb 都是系统数据库。

注意：
数据库和日志文件的默认位置为 Program Files\Microsoft SQL Server\Mssql.n\MSSQL\Data，其中 n 是 SQL Server 实例的序号。如果安装 SQL Server 时更改了默认位置，此位置可能会变化。

AdventureWorks 示例数据库

示例数据库作为学习工具提供，但默认情况下在 SQL Server 2005 版本中不安装。有关 AdventureWorks 示例数据库的详细信息，请参阅运行安装程序安装 AdventureWorks 示例数据库和示例。

请参阅

其他资源

示例数据库增强功能 (Transact-SQL)


SQL Server 2005 的产品规格

SQL Server 2005 的产品规格
配置 SQL Server 安装 >

下列主题提供了此版本产品规格的详细说明。

主题 | 说明
SQL Server 2005 的版本和组件 | 选择要安装的组件和功能。
SQL Server 2005 的各种版本所支持的功能 | 每个 SQL Server 版本对组件和功能的支持。
SQL Server 2005 最大容量规范 | 各种 SQL Server 对象的最大容量。
SQL Server 2005 的各版本所支持的最大处理器数 | SQL Server 2005 的每个版本所支持的最大处理器数。


SQL Server 2005 最大容量规范

SQL Server 2005 最大容量规范 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 2005 的产品规格 >

以下各表指定 Microsoft SQL Server 2005 组件中定义的不同对象的最大大小和最大数量。

数据库引擎对象

下表指定在 SQL Server 2005 数据库中定义的或在 Transact-SQL 语句中引用的不同对象的最大大小和最大数量。该表不包含 SQL Server Windows CE Edition。

SQL Server 2005 数据库引擎对象 | 最大大小/数量 SQL Server 2005（32 位） | 最大大小/数量 SQL Server 2005（64 位）
批大小1 | 65,536 * 网络数据包大小 | 65,536 * 网络数据包大小
每个短字符串列的字节数 | 8,000 | 8,000
每个 GROUP BY、ORDER BY 的字节数 | 8,060 | 8,060
每个索引键的字节数2 | 900 | 900
每个外键的字节数 | 900 | 900
每个主键的字节数 | 900 | 900
每行的字节数8 | 8,060 | 8,060
存储过程源文本中的字节数 | 批处理大小中的较小者或 250 MB | 批处理大小中的较小者或 250 MB
每个 varchar(max)、varbinary(max)、xml、text 或 image 列的字节数 | 2^31-1 | 2^31-1
每个 ntext 或 nvarchar(max) 列的字符数 | 2^30-1 | 2^30-1
每个数据表的聚集索引数 | 1 | 1
GROUP BY、ORDER BY 中的列数 | 仅受字节数限制 | 仅受字节数限制
GROUP BY WITH CUBE 或 WITH ROLLUP 语句中的列数或表达式数目 | 10 | 10
每个索引键的列数7 | 16 | 16
每个外键的列数 | 16 | 16
每个主键的列数 | 16 | 16
每个基础数据表的列数 | 1,024 | 1,024
每个 SELECT 语句的列数 | 4,096 | 4,096
每个 INSERT 语句的列数 | 1,024 | 1,024
每个客户端的连接个数 | 已配置连接的最大值 | 已配置连接的最大值
数据库大小 | 1,048,516 千吉字节 | 1,048,516 千吉字节
每个 SQL Server 实例的数据库个数 | 32,767 | 32,767
每个数据库的文件组个数 | 32,767 | 32,767
每个数据库的文件个数 | 32,767 | 32,767
文件大小（数据） | 16 千吉字节 | 16 千吉字节
文件大小（日志） | 2 千吉字节 | 2 千吉字节
每个表的外键表引用数4 | 253 | 253
标识符长度（以字符计） | 128 | 128
每台计算机的实例数 | 16 | 16
包含 SQL 语句的字符串的长度（批大小）1 | 65,536 * 网络数据包大小 | 65,536 * 网络数据包大小
每个连接的锁数 | 每个服务器的最大锁数 | 每个服务器的最大锁数
每个 SQL Server 实例的锁数5 | 最多 2,147,483,647 | 仅受内存限制
嵌套存储过程级别数6 | 32 | 32
嵌套子查询个数 | 32 | 32
嵌套触发器层数 | 32 | 32
每个数据表的非聚集索引个数 | 249 | 249
每个存储过程的参数个数 | 2,100 | 2,100
每个用户定义函数的参数个数 | 2,100 | 2,100
每个数据表的 REFERENCE 个数 | 253 | 253
每个数据表的行数 | 受可用存储空间限制 | 受可用存储空间限制
每个数据库的表数3 | 受数据库中对象数限制 | 受数据库中对象数限制
每个分区表或索引的分区数 | 1,000 | 1,000
非索引列的统计信息条数 | 2,000 | 2,000
每个 SELECT 语句的表个数 | 256 | 256
每个表的触发器个数3 | 受数据库中对象数限制 | 受数据库中对象数限制
每个数据表的 UNIQUE 索引个数或约束个数 | 249 个非聚集索引和 1 个聚集索引 | 249 个非聚集索引和 1 个聚集索引
用户连接 | 32,767 | 32,767
XML 索引 | 249 | 249

1网络数据包大小是表格格式数据流 (TDS) 数据包的大小，该数据包用于应用程序和关系数据库引擎 之间的通信。默认的数据包大小为 4 千字节 (KB)，由“网络数据包大小”配置选项控制。

2在 SQL Server 2005 中，任何索引键的最大字节数不能超过 900。可以使用最大大小合计超过 900 的可变长度列定义键，前提是这些列中所插入行的数据都不超过 900 字节。在 SQL Server 2005 中，可将非键列包含于非聚集索引中以避免最大索引键大小 900 字节的限制。有关详细信息，请参阅具有包含性列的索引。

3数据库对象包括诸如表、视图、存储过程、用户定义函数、触发器、规则、默认和约束等对象。数据库中所有对象的数量总和不能超过 2,147,483,647。

4尽管表可以包含无限数量的外键约束，但建议最大数量取为 253。根据承载 SQL Server 的硬件配置，指定额外的外键约束对查询优化器的处理而言可能开销很大。

5此值针对静态锁分配。动态锁仅受内存限制。

6如果存储过程访问的数据库多于 8 个，或者交替访问的数据库多于 2 个，将收到错误信息。

7如果表包含一个或多个 XML 索引，由于 XML 列被添加到主 XML 索引的聚集键，用户表的聚集键被限制为 15 列。在 SQL Server 2005 中，可在非聚集索引中包括非键列以避免 16 个键列的最大限制。有关详细信息，请参阅具有包含性列的索引。

8SQL Server 2005 支持行溢出存储，行溢出存储使可变长度列可以被推送到行外。只有 24 字节的根存储在推送出行外的可变长度列的主记录中；因此，此版本中的有效行限制高于 SQL Server 早期版本中的有效行限制。有关详细信息，请参阅 SQL Server 2005 联机丛书中的“行溢出数据超过 8 KB”主题。

复制对象

下表指定 SQL Server 2005 复制中定义的各种对象的最大大小和最大数量。该表不包括 SQL Server Windows CE Edition。

SQL Server 2005 复制对象 | 最大大小/数量 SQL Server 2005（32 位） | 最大大小/数量 SQL Server 2005（64 位）
项目（合并发布） | 256 | 256
项目（快照发布或事务性发布） | 32,767 | 32,767
表中的列1（合并发布） | 246 | 246
表中的列2（SQL Server 快照发布或事务性发布） | 1000 | 1000
表中的列2（Oracle 快照发布或事务性发布） | 995 | 995
行筛选器中使用的列的字节数（合并发布） | 1024 | 1024
行筛选器中使用的列的字节数（快照发布或事务性发布） | 8000 | 8000

1如果将行跟踪用于冲突检测（默认设置），则基表最多可以包含 1,024 列，但必须从项目中对这些列进行筛选，因此最多可发布 246 列。如果使用列跟踪，则基表最多可以包含 246 列。有关跟踪级别的详细信息，请参阅合并复制如何检测和解决冲突的“跟踪级别”部分。

2基表可以包含发布数据库中允许的最大数量的列（在 SQL Server 中为 1024），但如果这些列数超过发布类型指定的最大值，则必须从项目中筛选这些列。

请参阅

参考

安装 SQL Server 2005 的硬件和软件要求
系统配置检查器的检查参数

其他资源

安装 SQL Server 2005 组件


SQL Server 2005 的各版本所支持的最大处理器数

SQL Server 2005 的各版本所支持的最大处理器数 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 2005 的产品规格 >

下表指定了 SQL Server 2005 的每个版本支持的最大处理器数。

SQL Server 2005 版本 | 支持的处理器数（32 位） | 支持的处理器数（64 位）
Enterprise Edition | 操作系统最大内存1 | 操作系统最大内存1
Developer Edition | 32 | 64
Standard Edition | 4 | 4
Workgroup Edition | 2 | 不适用2
SQL Server Express Edition | 1 | 不适用2
Evaluation Edition | 操作系统最大内存 | 操作系统最大内存

1SQL Server 2005 Enterprise Edition 支持该操作系统所支持的最大处理器数。

2此版本的 SQL Server 2005 不能用于这一版本中的 64 位平台。

请参阅

参考

SQL Server 2005 各版本支持的内存
安装 SQL Server 2005 的硬件和软件要求

其他资源

SQL Server 2005 的产品规格


SQL Server 2005 各版本支持的内存

SQL Server 2005 各版本支持的内存 |
 | 请参阅
配置 SQL Server 安装 > SQL Server 2005 的产品规格 >

下表指定了 Microsoft SQL Server 2005 的每一个版本所支持的最大内存。

SQL Server 2005 版本 | 支持的最大内存（32 位） | 支持的最大内存（64 位）
Enterprise Edition | 操作系统最大内存1 | 操作系统最大内存1
Developer Edition | 操作系统最大内存 | 32 TB
Standard Edition | 操作系统最大内存 | 32 TB
Workgroup Edition | 3 GB | 不适用2
SQL Server Express Edition | 1 GB | 不适用2
Evaluation Edition | 操作系统最大内存 | 操作系统最大内存

1SQL Server 2005 Enterprise Edition 将支持操作系统所支持的最大内存。

2此版本中的 64 位平台不能使用 SQL Server 2005 的这一版本类别。

请参阅

参考

安装 SQL Server 2005 的硬件和软件要求

其他资源

SQL Server 2005 的产品规格


安装程序用户界面参考

安装程序用户界面参考 |
 | 请参阅

此部分说明由 Microsoft SQL Server 安装向导提供的安装选项。这些选项包括安装 SQL Server 2005 组件以及将现有 SQL Server 实例升级到 SQL Server 2005。

通过控制面板中的“添加或删除程序”可以更改或删除现有 SQL Server 2005 实例。有关实例维护的详细信息，请参阅如何在 SQL Server 2005 的现有实例中更改组件（安装程序）。有关实例删除的详细信息，请参阅如何卸载 SQL Server 2005 的现有实例（安装程序）。

请参阅

任务

如何安装 SQL Server 2005（安装程序）

概念

准备安装 SQL Server 2005
保留关键字（安装程序）

其他资源

升级到 SQL Server 2005
配置高可用性


安装必备组件

安装必备组件 |
 | 请参阅
安装程序用户界面参考 >

为了成功安装 Microsoft SQL Server，在安装计算机上需要下列软件组件。将由 SQL Server 安装程序安装这些软件组件：

  • Microsoft .NET Framework 2.0

  • Microsoft SQL Server 本机客户端

  • Microsoft SQL Server 2005 安装程序支持文件

注意：
如果安装失败或取消，这些组件却不会被删除。若要删除它们，请使用“控制面板”中的“添加或删除程序”。

请参阅

任务

如何安装 SQL Server 2005（安装程序）

参考

安装 SQL Server 2005 的硬件和软件要求
系统配置检查器的检查参数

概念

安装 SQL Server 的安全注意事项


系统配置检查 (SCC)

系统配置检查 (SCC) |
 | 请参阅
安装程序用户界面参考 >

SQL Server Express 用户：单击系统配置检查 (SQL Server Express) 可以获取 SQL Server Express 安装程序的特定信息。

Microsoft SQL Server 安装向导的“系统配置检查 (SCC)”页显示系统准备工具的进度。系统配置检查 (SCC) 例程扫描目标计算机，以查找可能阻碍安装程序运行的情况。对于群集，SCC 在虚拟服务器的所有节点上运行。

用户可随时单击“停止”取消 SCC 并退出安装向导。

进度符号如下：

  • 箭头符号 = 正在检查

  • 检查符号 = 检查项成功

  • X 符号 = 检查项失败

SCC 检查完毕后，“报告”按钮变为可用。仅当所有检查结果都成功，或失败的检查项不严重时，“继续”按钮才可用。对于失败的检查项，SCC 报告结果中包含对妨碍性问题的解决方法。

使用 SCC 页底部的“报告”按钮可以查看报告、将报告保存为文件、将报告复制到剪贴板或者将报告作为电子邮件发送。报告中显示的信息包括：

  • 在目标计算机上检查的配置项的列表：当前操作系统的要求、操作系统服务包级别、SQL Server 版本与当前操作系统的兼容性以及 Internet 信息服务 (IIS)。

  • 各检查项的结果。

  • 为解决妨碍性问题而建议的用户操作。

请参阅

任务

如何安装 SQL Server 2005（安装程序）

参考

系统配置检查器的检查参数
安装 SQL Server 2005 的硬件和软件要求


注册信息

注册信息 |
 | 请参阅
安装程序用户界面参考 >

SQL Server Express 用户：单击注册信息 (SQL Server Express) 可以获取 SQL Server Express 安装程序的特定信息。

使用 Microsoft SQL Server 安装向导的“注册信息”页输入用于注册 SQL Server 副本的标识信息。这包括用户名、公司名称和产品密钥。只有在第一次安装时必须输入产品密钥，在后续的安装过程中它会自动显示。

选项

名称

键入您的姓名。在网络服务器上安装 SQL Server 时，请提供负责管理该服务器的用户的名称。必须有用户名才能继续安装。

公司

输入您的公司名称。对产品的个人用副本，可以再次提供您的姓名。此字段的信息是可选的。

产品密钥

输入 SQL Server 2005 DVD 封套上不干胶标签上的产品密钥信息。

请参阅

任务

如何安装 SQL Server 2005（安装程序）


要安装的组件

要安装的组件 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“要安装的组件”页上的复选框为 SQL Server 安装选择组件组。

选项

选择各个组件组时，“要安装的组件”窗格中会显示相应的说明。您可以选中任意一些复选框。

若要为安装选择个别功能，请单击“高级”。若要将组件安装到自定义目标文件夹或者要查看个别组件或功能的磁盘空间要求，请单击“高级”。

选择此组件组 安装这些组件和功能

SQL Server Database Services

SQL Server 数据库引擎 包含以下技术：

  • 数据库引擎 是用于存储、处理和保护数据的核心服务。

  • 复制是在数据库之间对数据和数据库对象进行复制和分发，然后在数据库之间进行同步以保持一致性的一组技术。

  • 全文搜索提供用于对 SQL Server 表中纯字符数据发出全文查询的功能。

  • 用于管理关系数据和 XML 数据的工具。

Analysis Services

Analysis Services 包括用于创建和管理联机分析处理 (OLAP) 以及数据挖掘应用程序的工具。

Reporting Services1,2,3,4

Reporting Services 包括用于创建、管理和部署表格报表、矩阵报表、图形报表以及自由格式报表的服务器和客户端组件。Reporting Services 还是一个可用于开发报表应用程序的可扩展平台。

Notification Services

Notification Services 是一个平台，用于开发和部署将个性化即时信息发送给各种设备上的用户的应用程序。

Integration Services

Integration Services 是一组图形工具和可编程对象，用于移动、复制和转换数据。

工作站组件、联机丛书和开发工具5,6

安装用于在客户端和服务器之间进行通信的组件，包括用于 DB-Library、OLEDB for OLAP、ODBC、ADODB 和 ADOMD+ 的各种网络库。

管理工具

  • SQL Server Management Studio (SSMS) 是 Microsoft SQL Server 2005 中的新组件，这是一个用于访问、配置、管理和开发 SQL Server 的所有组件的集成环境。SSMS 将 SQL Server 早期版本中包含的企业管理器、查询分析器和分析管理器的功能组合到单一环境中，为不同层次的开发人员和管理员提供 SQL Server 访问能力。

  • SQL Server 配置管理器为 SQL Server 服务、服务器协议、客户端协议和客户端别名提供基本配置管理。

  • SQL Server 事件探查器 提供了图形用户界面，用于监视数据库引擎 实例或 Analysis Services 实例。

  • 数据库引擎 优化顾问可以协助创建索引、索引视图和分区的最佳组合。

  • 使用复制监视器，可以跨复制拓扑跟踪发布和订阅的状态及性能。

  • SQLXML 客户端功能

文档

  • SQL Server 联机丛书是 SQL Server 2005 的核心文档。

  • 软件开发工具包

开发工具

  • Business Intelligence Development Studio 是用于 Analysis Services、Reporting Services 和 Integration Services 解决方案的集成开发环境。

1安装程序不为报表服务器扩展部署中的多个节点配置负载平衡和单 URL 寻址。若要完成扩展部署，必须使用 Windows Server、Microsoft Application Center 或第三方群集管理软件。有关 Web 场部署设置的详细信息，请参阅配置报表服务器扩展部署。

2如果未安装 Internet 信息服务 (IIS) 5.0 或更高版本，则 Reporting Services 不可用。Reporting Services 的报表设计器组件需要 Microsoft Internet Explorer 6.0 Service Pack (SP) 1。

3若要在 64 位服务器上安装 Reporting Services（64 位），必须安装 ASP.NET 的 64 位版本。若要在 32 位系统以及在 64 位服务器的 32 位子系统 (WOW64) 上安装 Reporting Services（32 位），必须安装 ASP.NET 的 32 位版本。

4并行配置 64 位平台和 64 位服务器的 32 位子系统 (WOW64) 时不同时支持 Reporting Services。

5安装 SQL Server Management Studio，需要 Internet Explorer 6.0 SP1。

6安装 Business Intelligence Development Studio 需要 Internet Explorer 6.0 SP1。

安装故障转移群集

在选择 SQL Server 或 Analysis Services 时，如果安装程序检测到您要安装到虚拟服务器，则会启用“创建 SQL Server 故障转移群集”或“创建 Analysis Server 故障转移群集”复选框。必须选择此选项才可以安装故障转移群集。

若要将 SQL Server 实例升级到 SQL Server 2005 故障转移群集，则要升级的实例必须是故障转移群集。若要将 SQL Server 的独立实例升级到 SQL Server 2005 故障转移群集，请安装新的 SQL Server 2005 故障转移群集，然后使用复制数据库向导迁移独立实例中的用户数据库。有关升级的详细信息，请参阅如何升级到 SQL Server 2005 故障转移群集（安装程序）。有关数据库迁移的详细信息，请参阅使用复制数据库向导。

安装 AdventureWorks 示例数据库

默认情况下，不安装 AdventureWorks、AdventureWorksDW、AdventureWorksAS 和相关示例。若要安装这些功能中的一个或多个，在 SQL Server 2005 安装过程中，从“要安装的组件”页选择“工作站组件、联机丛书和开发工具”，再单击“高级”。展开“文档和示例”，然后选择要安装的数据库和示例。

请参阅

参考

SQL Server 2005 的版本和组件
功能选择


功能选择

功能选择 |
 | 请参阅
安装程序用户界面参考 >

SQL Server Express 用户：单击功能选择 (SQL Server Express) 可以获取 Server Express 安装程序的特定信息。

使用 Microsoft SQL Server 安装向导的“功能选择”页选择安装的单个功能，并指定安装目录。对于现有安装，使用此页添加或删除功能。

选项

“功能选择”页由两个窗格组成。左窗格显示可安装的功能的树视图，展开功能可查看其子功能。右窗格显示了功能说明。当单击功能或子功能时，“功能说明”窗格显示所选功能的说明及该功能的磁盘空间要求。

若要添加或删除功能，请单击功能名称旁边的箭头，然后从下拉列表中选择下列选项之一：

将安装到本地硬盘上

将所选功能安装到“安装路径”下显示的位置。

整个功能将安装到本地硬盘上

安装所选功能及其所有子功能。展开父功能以查看其子功能。

将安装为从网络运行

从网络位置运行以下内容：

  • 复制监视器

整个功能将不可用

对于 SQL Server 的新安装，此选项忽略所选功能的安装。对于现有安装，此选项将功能从安装中删除。选择此选项后，在功能树上功能名称旁边会出现一个红色的 X，并且树视图中任一父功能上的图标都灰显。

注意：
如果某个功能的子功能中有一个被选中，则无法清除此功能。若要取消选择某个功能，请确保其所有子功能也已被取消选择。

“功能选择”页还提供下列选项：

安装路径

安装过程中，可以更改下列功能的安装路径：

只为有用户可配置目标文件夹的功能显示安装路径：

组件 默认路径1, 2 可配置路径或固定路径

数据库引擎 服务器组件

\Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Binn\

可配置

数据库引擎 数据文件

\Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Data\

可配置

Analysis Services 服务器

\Program Files\Microsoft SQL Server\MSSQL.n\OLAP\Bin\

可配置

Analysis Services 数据文件

\Program Files\Microsoft SQL Server\MSSQL.n\OLAP\Data\

可配置

Reporting Services 报表服务器

\Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportServer\Bin\

可配置

Reporting Services 报表管理器

\Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportManager\Bin\

固定路径

Integration Services

<安装目录>\90\DTS\

可配置4

Notification Services

<安装目录>\90\Notification Services\

可配置4

客户端组件

<安装目录>\90\Tools\

可配置4

复制和服务器端 COM 对象

Program Files\Microsoft SQL Server\90\COM\5

固定路径

数据转换运行时引擎、数据转换管道引擎和 dtexec 命令提示实用工具的 Integration Services 组件 DLL

Program Files\Microsoft SQL Server\90\DTS\Binn

固定路径

为 Integration Services 提供托管连接支持的 DLL

Program Files\Microsoft SQL Server\90\DTS\Connections

固定路径

Integration Services 所支持的每种枚举器类型的 DLL

Program Files\Microsoft SQL Server\90\DTS\ForEachEnumerators

固定路径

SQL Server 浏览器服务、WMI 提供程序

\Program Files\Microsoft SQL Server\90\Shared\

固定路径

在所有 SQL Server 2005 实例之间共享的组件

\Program Files\Microsoft SQL Server\90\Shared\

固定路径

1确保使用有限的权限对 \Program Files\Microsoft SQL Server\ 文件夹进行了保护。

2这些位置的默认驱动器为 systemdrive，通常为驱动器 C。

3子功能的安装路径由它们的父功能的安装路径来决定。

4Integration Services、Notification Services 和客户端组件之间共享单个安装路径。更改一个组件的安装路径会同时更改其他组件的安装路径。后续安装将组件安装到与原始安装相同的位置。

5此目录供计算机上的所有 SQL Server 实例使用。如果对计算机上的任意实例应用更新，如 Service Pack，则对此文件夹中的文件的任何更改都将影响到计算机上的所有实例。

注意：
对于群集配置，必须选择在该群集的每个节点上都可用的本地驱动器。

注意：
向现有安装中添加功能时，不能更改以前安装的功能的位置，也不能为新功能指定该位置。

当在安装过程中为服务器组件或数据文件指定安装路径时，安装程序除了使用为程序和数据文件指定的位置外，还使用实例 ID。安装程序不会将实例名用于工具和其他共享文件。此外，安装程序也不会将任何实例名用于 Analysis Services 程序和数据文件，尽管它会将实例名用于 Analysis Services 存储库。

有关安装目录的详细信息，请参阅 SQL Server 2005 的默认实例和命名实例的文件位置。

有关硬盘空间要求的详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求。

如果为“数据库引擎”功能设置了安装路径，则 SQL Server 安装程序将使用该路径作为此安装的所有特定于实例的文件夹的根目录，包括“SQL 数据文件”。在这种情况下，如果将根目录设置为“C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\”，则实例特定目录将附加到该路径上。

如果在 SQL Server 安装向导（安装程序用户界面模式）中选择使用 USESYSDB 升级功能，用户就能够轻松地将产品安装到递归文件夹结构（如 <SQLProgramFiles>\MSSQL.1\MSSQL\MSSQL.1\MSSQL\Data\）中。若要使用 USESYSDB 功能，则请为“SQL 数据文件”功能而不是“数据库引擎”功能设置安装路径。

注意：数据文件应始终位于名为“Data”的子目录中。例如，当数据文件位于“C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data”下时，应指定“C:\Program Files\Microsoft SQL Server\MSSQL.1\”以指定升级过程中系统数据库的数据目录的根路径。

注意：不能将 SQL Server Windows on Windows (WOW64) 安装到物理磁盘的根目录。必须指定根目录下节点的可配置路径。例如，不能将数据库引擎服务器组件安装到 c:\。可以将数据库引擎服务器组件安装到 c:\SQL Server\。有关 WOW64 的详细信息，请参阅安装 SQL Server 2005 的硬件和软件要求中的“扩展系统支持”。

安装 AdventureWorks 示例数据库

默认情况下，不安装 AdventureWorks 示例 OLTP、AdventureWorksDW 示例数据仓库、AdventureWorks 示例 OLAP 和相关示例。若要安装这些功能中的一个或多个，请在 SQL Server 2005 安装过程中从“要安装的组件”页选择“工作站组件、联机丛书和开发工具”，然后单击“高级”。展开“文档和示例”，然后选择要安装的数据库和示例。

浏览...

启动“更改文件夹”页，此页可以更改要安装所选功能的文件夹。此按钮仅对具有用户可配置安装路径的功能可用。子功能的安装路径由其父功能的安装路径来决定。有关安装路径的详细信息，请参阅 SQL Server 2005 的默认实例和命名实例的文件位置。

磁盘开销...

显示安装到计算机不同系统驱动器的可用空间。在“磁盘开销”对话框中检查了计算机的磁盘空间后，单击“关闭”继续安装 SQL Server。

注意：
对于故障转移群集安装，此页上的“浏览...”和“磁盘开销...”按钮被禁用，这是因为故障转移群集安装有一个单独的“安装文件夹”页。

请参阅

参考

SQL Server 2005 的版本和组件
安装 SQL Server 2005 的硬件和软件要求
要安装的组件

概念

故障转移群集


实例名称

实例名称 |
 | 请参阅
安装程序用户界面参考 >

SQL Server Express 用户：单击实例名 (SQL Server Express) 可以获取 SQL Server Express 安装程序的特定信息。

使用 SQL Server 安装向导的“实例名”页指定是创建 SQL Server 的默认实例还是命名实例。除非选择命名实例，否则使用默认实例名。

每个 SQL Server 实例由一组具有排列规则及其他选项特定设置的非重复的服务组成。目录结构、注册表结构和服务名称都反映在 SQL Server 安装过程中创建的 SQL Server 实例的特定实例 ID 中。

实例是默认实例或命名实例。默认实例名为 MSSQLSERVER；它不需要客户端指定实例名称即可建立连接。命名实例在安装过程中由用户决定。

命名实例可以随时安装。默认情况下，第一次在计算机上安装 SQL Server 2005 时，安装程序将安装指定为默认实例；但是，可以选择将 SQL Server 安装成命名实例而不必先安装默认实例。默认实例可以是 SQL Server 6.5、7.0、2000 或 2005 版本的安装。无论是哪个版本，任何时候都只能有一个 SQL Server 的安装是默认实例。

多实例

SQL Server 2005 支持单个服务器或处理器上的多个 SQL Server 实例，但只有一个实例可以是默认实例，所有其他实例都必须是命名实例。一台计算机可同时运行多个 SQL Server 实例，每个实例独立于其他实例运行。单个服务器或处理器上的所有实例必须是 SQL Server 2005 的同一本地化版本。

下表显示了在 SQL Server 2005 的不同版中对于每个实例识别组件所支持的实例数。

SQL Server 2005 版本 | 数据库引擎实例 | Analysis Services 实例 | Reporting Services 实例
Enterprise Edition Developer Edition | 50 | 50 | 50
Standard Edition Workgroup Edition Express Edition | 16 | 16 | 16

选项

如果选择“默认实例”，而计算机上已经存在默认实例，则 SQL Server 安装程序将升级该默认实例。如果输入计算机中已存在的命名实例的名称，则 SQL Server 安装程序将升级该命名实例。

给定 SQL Server 2005 实例的所有组件作为一个单元来管理；SQL Server 的所有 service pack 和升级将应用于 SQL Server 实例的每个组件。

在决定是安装 SQL Server 2005 的默认实例还是命名实例时，请考虑下列信息：

  • 如果从 SQL Server 7.0 版进行升级，则升级的实例是默认实例。

  • 如果计划在数据库服务器上安装单个 SQL Server 实例，则该实例应为默认实例。

  • 如果必须支持来自 SQL Server 7.0 版或更低版本的客户端连接，则使用默认实例更加简便。尽管更旧版本的客户端可以配置为连接到命名实例，但每个客户端都需要该命名实例的“服务器名”定义和硬编码网络地址。

  • 由于一个服务器只能承载一个默认实例，因此如果计划在同一台计算机上安装多个实例，请考虑使用命名实例。

  • 任何安装 SQL Server Express Edition 的应用程序都应将其安装为命名实例。当同一台计算机上安装了多个应用程序时，这样做可以将冲突降低到最少。

默认实例

请选择此选项来安装 SQL Server 2005 的默认实例。一台计算机只能承载一个默认实例；所有其他实例必须是命名实例。但是，如果已安装 SQL Server 的默认实例，可将 Analysis Services 的默认实例添加到同一台计算机。

若要升级早期 SQL Server 安装的默认实例，请单击“默认实例”单选按钮，然后单击“下一步”。

命名实例

请选择此选项来创建新命名实例。命名 SQL Server 的实例时，请记住下列信息：

  • 实例名不区分大小写。

  • 实例名不能包含字词“Default”、“MSSQLServer”或其他保留关键字。如果在实例名中使用了保留关键字，将发生安装错误。

  • 实例名限制为 16 个字符。

  • 实例名的首字符必须是字母或下划线 (_)。可接受的字母为 Unicode 标准 2.0 中定义的字符，包括拉丁字符 a-z 和 A-Z ，以及源于其他语言的字母字符。

  • 后续字符可以是 Unicode 标准 2.0 定义的字母、源于基本拉丁语或其他国家/地区书写符号的十进制数字、美元符号 ($) 或者下划线 (_)。

  • 实例名中不允许有其他特殊字符的嵌入空格；也不允许有反斜杠 (\)、逗号 (,)、冒号 (:)、分号 (;)、单引号 (')、“and”符 (&) 或“at”符号 (@)。

    注意：
    只有在当前 Microsoft Windows 代码页中有效的字符才能在 SQL Server 实例名中使用。如果使用了不支持的 Unicode 字符，将会发生安装错误。

已安装的实例

查看正在运行 SQL Server 安装程序的计算机中安装的 SQL Server 实例和组件的列表。安装实例的详细信息窗格将显示已安装实例的升级选项。

请参阅

其他资源

数据库引擎安装帮助主题


已安装的实例

已安装的实例 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“已安装的实例”页查看在运行 SQL Server 安装程序的计算机上已安装的 SQL Server 实例和组件列表。“已安装实例的详细信息”窗格显示已安装实例的升级选项。

选项

若要选择欲升级的组件或实例，请单击实例名，然后单击“确定”。

请参阅

其他资源

升级到 SQL Server 2005


现有组件

现有组件 |
 | 请参阅
安装程序用户界面参考 >

SQL Server Express 用户：单击现有组件 (SQL Server Express) 可查看针对 SQL Server Express 安装程序的有关信息。

使用 Microsoft SQL Server 安装向导的“现有组件”页可以查看正在运行 SQL Server 安装程序的计算机上所安装的 SQL Server 组件的列表。

选项

单击“详细信息”按钮可以查看当前安装的每个 SQL Server 组件可用的维护和升级选项的报表。

允许的操作

维护：通过“控制面板”中的“添加或删除程序”可维护组件。

升级：可将现有组件升级到 SQL Server 2005。

请参阅

其他资源

升级到 SQL Server 2005


安装选项

安装选项 |
 | 请参阅
安装程序用户界面参考 >

SQL Server Express 用户：单击安装选项 (SQL Server Express) 可以获取 SQL Server Express 安装程序的特定信息。

使用 Microsoft SQL Server 安装向导的“安装选项”页，可以查看现有的 SQL Server 实例和组件的维护和升级选项。如果为当前安装选定的组件已经是同名实例的现有安装的一部分，则会显示此页。

选项

以下各部分介绍维护和升级选项。

维护

SQL Server 2005 的实例维护和功能维护（包括故障转移群集）是通过“控制面板”中的“添加或删除程序”提供的。

升级

此 SQL Server 2005 版本支持以下升级方案：

升级前的版本 | 支持的升级路径
SQL Server 7.0 Enterprise Edition SP4 | SQL Server 2005 Enterprise Edition
SQL Server 7.0 Developer Edition SP4 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition
SQL Server 7.0 Standard Edition SP4 | SQL Server 2005 Standard Edition SQL Server 2005 Enterprise Edition
SQL Server 7.0 Desktop Edition SP4 | SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 7.0 Evaluation Edition SP4 | 不支持的升级
SQL Server Desktop Engine (MSDE) 7.0 SP4 | SQL Server 2005 Express Edition
SQL Server 2000 Enterprise Edition SP3 或更高版本1 | SQL Server 2005 Enterprise Edition
SQL Server 2000 Developer Edition SP3 或更高版本1 | SQL Server 2005 Developer Edition
SQL Server 2000 Standard Edition SP3 或更高版本1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition
SQL Server 2000 Workgroup Edition SP3 或更高版本1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 2000 Personal Edition SP3 或更高版本1 | SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition 具有高级服务的 SQL Server 2005 Express Edition
SQL Server 2000 Evaluation Edition SP3 或更高版本1 | SQL Server 2005 Evaluation Edition
SQL Server Desktop Engine (MSDE) 2000 SP3 或更高版本1 | SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition 具有高级服务的 SQL Server 2005 Express Edition
SQL Server 2000 IA64（64 位）Enterprise Edition | SQL Server 2005 IA64（64 位）Enterprise Edition
SQL Server 2000 IA64（64 位）Developer Edition | SQL Server 2005 IA64（64 位）Enterprise Edition SQL Server 2005 IA64（64 位）Developer Edition
SQL Server 2005 Developer Edition 1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 2005 Standard Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition
SQL Server 2005 Workgroup Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition
SQL Server 2005 Evaluation Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition
SQL Server 2005 Express Edition 1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition 具有高级服务的 SQL Server 2005 Express Edition
SQL Server 2005 IA64（64 位）Developer Edition | SQL Server 2005 IA64（64 位）Enterprise Edition SQL Server 2005 IA64（64 位）Standard Edition
SQL Server 2005 X64（64 位）Developer Edition | SQL Server 2005 X64（64 位）Enterprise Edition SQL Server 2005 X64（64 位）Standard Edition
SQL Server 2005 IA64（64 位）Standard Edition | SQL Server 2005 IA64（64 位）Enterprise Edition SQL Server 2005 IA64（64 位）Developer Edition
SQL Server 2005 X64（64 位）Standard Edition | SQL Server 2005 X64（64 位）Enterprise Edition SQL Server 2005 X64（64 位）Developer Edition
SQL Server 2005 IA64（64 位）Evaluation Edition | SQL Server 2005 IA64（64 位）Enterprise Edition SQL Server 2005 IA64（64 位）Developer Edition SQL Server 2005 IA64（64 位）Standard Edition
SQL Server 2005 X64（64 位）Evaluation Edition | SQL Server 2005 X64（64 位）Enterprise Edition SQL Server 2005 X64（64 位）Developer Edition SQL Server 2005 X64（64 位）Standard Edition

1可在 64 位服务器的 32 位子系统 (WOW64) 上将此版本的 SQL Server 升级到 SQL Server 2005。

升级说明

  • 从其他版本的 SQL Server 2005 升级到 SQL Server 2005 后，必须对升级后的 SQL Server 实例重新应用所有修补程序或 Service Pack 更新。

  • SQL Server 2005 不支持跨版本的实例。在 SQL Server 2005 的实例中，数据库引擎、Analysis Services 和 Reporting Services 组件的版本号必须相同。

  • 升级到 SQL Server 2005 之前，请先启用 SQL Server 代理的 Windows 身份验证，并验证 SQL Server 代理的服务帐户是否是 SQL Server sysadmin 组的成员。

  • 在从 SQL Server 2005 的某一版本升级到另一版本之前，请验证要升级到的版本是否支持当前使用的功能。有关详细信息，请参阅 SQL Server 2005 的各种版本所支持的功能中相关组件的部分。

  • 若要将 SQL Server 实例升级为 SQL Server 2005 故障转移群集，要升级的实例必须是故障转移群集。若要将独立的 SQL Server 实例升级为 SQL Server 2005 故障转移群集，请安装新的 SQL Server 2005 故障转移群集，然后使用复制数据库向导迁移独立实例中的用户数据库。有关升级的详细信息，请参阅如何升级到 SQL Server 2005 故障转移群集（安装程序）。有关数据库迁移的详细信息，请参阅使用复制数据库向导。

向 SQL Server 2005 的实例添加组件

从“控制面板”的“添加或删除程序”中，可以将组件添加到 SQL Server 2005 的现有安装中，然后选择要对其添加或删除功能的 SQL Server 实例。有关详细信息，请参阅如何在 SQL Server 2005 的现有实例中更改组件（安装程序）。

跨语言支持

对于升级：

  • SQL Server 英文版可以升级为 SQL Server 2005 的任意本地化版本。

  • SQL Server 本地化版本可以升级到相同语言的 SQL Server 2005 本地化版本。

  • SQL Server 本地化版本无法升级到 SQL Server 2005 英文版。

  • SQL Server 本地化版本无法升级到其他本地化语言的 SQL Server 2005 本地化版本。

其他跨语言支持：

  • 所有支持的操作系统的本地化版本均支持 SQL Server 2005 英文版。

  • 与 SQL Server 本地化版本使用同一语言的本地化操作系统支持 SQL Server 2005 的本地化版本。

  • 通过使用 Windows 多语言用户界面包 (MUI) 设置，支持的英语操作系统版本还支持 SQL Server 2005 的本地化版本。不过，在运行英语操作系统（具有非英语 MUI 设置）的服务器上安装 SQL Server 2005 的本地化版本之前，必须先验证某些操作系统设置。必须验证以下操作系统设置是否与要安装的 SQL Server 本地化版本的语言相匹配：

    • 操作系统用户界面设置

    • 操作系统用户区域设置

    • 系统区域设置

    如果这些操作系统设置与 SQL Server 本地化版本的语言不匹配，则必须按照如何更改操作系统设置以支持本地化版本中的说明，正确设置这些操作系统设置。

请参阅

其他资源

升级到 SQL Server 2005


服务帐户

服务帐户 |
 | 请参阅
安装程序用户界面参考 >

SQL Server Express 用户：单击服务帐户 (SQL Server Express) 可以获取 Server Express 安装程序的特定信息。

使用 Microsoft SQL Server 安装向导的“服务帐户”页为 SQL Server 服务分配登录帐户。此页上配置的实际服务取决于已选择要安装的功能。

选项

可以为所有的 SQL Server 服务分配相同的登录帐户，也可以分别配置各个服务帐户。还可以指定服务是否自动启动。

安全说明：
设置强密码对于确保系统的安全至关重要。始终使用强密码。

为每个服务帐户自定义登录名

选中“为每个服务帐户进行自定义”复选框可以自定义各服务的设置。

此选项为各个服务分配特定的登录帐户。单击此复选框将实现最小特权原则，即 SQL Server 服务被授予完成其任务所需的最低权限。有关详细信息，请参阅设置 Windows 服务帐户。

如果未选中此复选框，将对所有 SQL Server 服务使用相同的帐户和设置。

选择下列任一服务以自定义其设置。

选择此服务 为其配置身份验证设置的主体

SQL Server

SQL Server 数据库引擎

SQL Server 代理

执行作业、监视 SQL Server 并允许管理任务自动完成的服务。

Analysis Services

Analysis Services

Reporting Services

Reporting Services。服务帐户用于配置报表服务器数据库连接。如果要连接到远程 SQL Server 实例上的报表服务器数据库，请选择域用户帐户。如果您使用的是本地报表服务器数据库，则可以使用域用户帐户或本地系统帐户来运行该服务。

SQL Server 浏览器

SQL Server 浏览器是向客户机提供 SQL Server 连接信息的名称解析服务。多个 SQL Server 和 Integration Services 实例共享此服务。
使用内置系统帐户

可以为可配置的 SQL Server 服务的登录分配本地系统帐户、网络服务帐户或本地服务帐户。

“本地系统”选项指定一个不需要密码的本地系统帐户，以连接到同一台计算机上的 SQL Server。不过，本地系统帐户可能会限制 SQL Server 安装与其他服务器进行交互，具体取决于该帐户所拥有的特权。

重要事项：
本地系统是一个功能强大的帐户；但它可能不适用于所有服务设置。有关详细信息，请参阅 安装 SQL Server 的安全注意事项。

网络服务帐户是一个特殊的内置帐户，它与通过身份验证的用户帐户类似。网络服务帐户与 Users 组的成员具有相同级别的资源和对象访问权限。以网络服务帐户身份运行的服务将使用计算机帐户的凭据访问网络资源。

重要事项：
建议不要将网络服务帐户用于 SQL Server 或 SQL Server 代理服务。本地用户帐户或域用户帐户更适用于这些 SQL Server 服务。

本地服务帐户是一个特殊的内置帐户，它与通过身份验证的用户帐户类似。本地服务帐户与 Users 组的成员具有相同级别的资源和对象访问权限。如果有个别服务或进程的安全受到威胁，则此有限访问权限有助于保护系统的安全。以本地服务帐户身份运行的服务将以一个没有凭据的空会话形式访问网络资源。

有关服务帐户的详细信息，请参阅设置 Windows 服务帐户。

使用域用户帐户

指定一个使用 Windows 身份验证的域用户帐户，以设置并连接到 SQL Server。Microsoft 建议对 SQL Server 服务使用具有最低权限的域用户帐户，因为 SQL Server 服务不需要管理员帐户特权。

如果创建属于非 SQL Server 管理员的 CmdExec 和 ActiveScript 作业，或者使用 AutoRestart 功能，则 SQL Server 代理帐户必须具有管理员特权。如果环境中需要上述功能，请考虑为 SQL Server 和 SQL Server 代理服务使用不同的服务帐户。

有关强密码准则，请参阅身份验证模式。

注意：
域名不能为完整的 DNS 名称。例如，如果 DNS 名称为 my-domain-name.com，将在域字段中使用 my-domain-name。SQL Server 安装程序不接受域字段中的 my-domain-name.com。

SQL Server 安装结束时启动服务

当操作系统启动时自动启动服务。对于 SQL Server 2005，默认情况下会为 SQL Server、Analysis Services 和 Reporting Services 选中服务“自动启动”选项。

注意：
SQL Server 代理服务依赖于 SQL Server 服务。如果选中 SQL Server 代理的“自动启动”复选框，则自动选中 SQL Server 服务的“自动启动”，此后只有取消选中 SQL Server 代理的此选项时才能将它取消选中。

重要事项：
默认关闭 - 为了提高 SQL Server 2005 的安全性，一些服务和功能默认情况下不激活。必须在安装程序完成后配置和启用这些服务和功能。有关详细信息，请参阅 SQL Server 外围应用配置器和 安装 SQL Server 的安全注意事项。

请参阅

参考

设置 Windows 服务帐户

概念

安装 SQL Server 的安全注意事项


身份验证模式

身份验证模式 |
 | 请参阅
安装程序用户界面参考 >

SQL Server Express 用户：单击身份验证模式 (SQL Server Express) 可以获取 SQL Server Express 安装程序的特定信息。

使用 Microsoft SQL Server 安装向导的“身份验证模式”页选择安全模式，用来验证对本系统的客户端和服务器连接。如果选择“混合模式”，则必须输入并确认 SQL Server 系统管理员 (sa) 密码。设备建立起对 SQL Server 的成功连接之后，安全机制对于 Windows 身份验证和混合模式是相同的。

选项

Windows 身份验证模式

用户通过 Microsoft Windows 用户帐户连接时，SQL Server 使用 Windows 操作系统中的信息验证帐户名和密码。这是默认的身份验证模式，比混合模式安全得多。Windows 身份验证使用 Kerberos 安全协议，通过强密码的复杂性验证提供密码策略强制，提供帐户锁定支持，并且支持密码过期。

安全说明：
如果可能，请使用 Windows 身份验证。

如果选择 Windows 身份验证，安装程序会创建一个在默认情况下禁用的 sa 帐户。若要使用混合模式身份验证并在安装完成后激活 sa 帐户，请参阅 SQL Server 2005 联机丛书中的主题“如何更改服务器身份验证模式”。

重要事项：
设置强密码对于确保系统的安全至关重要。切勿设置空密码或弱 sa 密码。

混合模式（Windows 身份验证或 SQL Server 身份验证）

允许用户使用 Windows 身份验证或 SQL Server 身份验证进行连接。通过 Windows 用户帐户连接的用户可以使用 Windows 验证的受信任连接。

如果必须选择“混合模式身份验证”并要求使用 SQL 登录以适应旧式应用程序，则必须为所有 SQL 帐户设置强密码。这对于属于 sysadmin 角色的帐户（特别是 sa 帐户）尤其重要。

注意：
提供 SQL Server 身份验证只是为了向后兼容。如果可能，请使用 Windows 身份验证。

输入密码

选择“混合模式身份验证”时，请输入并确认系统管理员 (sa) 登录名。密码是抵御入侵者的第一道防线，因此设置强密码对于系统安全是绝对必要的。切勿设置空密码或弱 sa 密码。

注意：
SQL Server 密码可包含 1 到 128 个字符，包括字母、符号和数字的任意组合。如果选择“混合模式身份验证”，则必须输入强 sa 密码才能进入安装向导的下一页。

强密码指南

强密码不易被人猜出，也不易用计算机程序攻击。强密码不能使用禁止的条件或字词，包括：

  • 空条件或 NULL 条件

  • "Password"

  • “Admin”

  • “Administrator”

  • “sa”

  • “sysadmin”

强密码不能是下列与安装的计算机有关联的词：

  • 当前登录到计算机上的用户的名称。

  • 计算机名称。

强密码长度必须多于 8 个字符，并且至少要满足下列四个条件中的三个：

  • 必须包含大写字母。

  • 必须包含小写字母。

  • 必须包含数字。

  • 必须包含非字母数字字符；例如，#、% 或 ^。

在“身份验证模式”页中输入的密码必须满足强密码策略要求。如果有使用 SQL 身份验证的自动化设置，请确保密码满足强密码策略要求。

安全说明：
对于此版本，安装程序可能不强制非域成员计算机上的 Windows Server 2003 的某些默认配置符合强密码要求。设置强密码对于确保系统的安全至关重要。切勿设置空密码或弱 sa 密码。

请参阅

概念

安装 SQL Server 的安全注意事项

更改历史记录

版本 历史记录

已更改的内容：
  • 更新了强密码指南：强密码长度必须多于 8 个字符。


排序规则设置

排序规则设置 |
 | 请参阅
安装程序用户界面参考 >

SQL Server Express 用户：单击排序规则设置 (SQL Server Express) 可以获取 Server Express 安装程序的特定信息。

使用 Microsoft SQL Server 安装向导的 “排序规则设置”页，可以修改数据库引擎 和 Analysis Services 为语言和排序目的所使用的默认排序规则设置。选择“排序规则指示符”选项来匹配 SQL Server 的不同安装上或另一台计算机上的排序规则设置。使用“SQL 排序规则”选项匹配与 SQL Server 早期版本中排序顺序兼容的设置。

选项

为每个服务帐户进行自定义

可以为数据库引擎 和 Analysis Services 指定不同的排序规则设置，也可以为所有的服务指定单一的排序规则。如果选择安装数据库引擎 和 Analysis Services，可以选中“为每个服务帐户进行自定义”旁边的复选框，以激活下拉列表中的服务列表。从下拉列表中选择服务，然后为该服务选择排序规则和排序顺序。选择完后，单击“下一步”继续。

排序规则指示符和排序顺序

指定 SQL Server 2005 的此实例所使用的排序规则。为英语系统区域设置默认选定 SQL 排序规则。非英语区域设置的默认排序规则是您计算机上 Microsoft Windows 系统区域设置（“非 Unicode 程序语言”设置），或控制面板的“区域和语言选项”中最接近的等效设置。

仅当 SQL Server 的此安装的排序规则设置必须与 SQL Server 的另一实例所使用的排序规则设置相匹配，或者必须与另一台计算机的 Windows 系统区域设置相匹配时，才应更改默认设置。

注意 SQL 排序规则不能用于 Analysis Services。如果选择了要在安装数据库引擎 时使用的 SQL 排序规则，则 SQL Server 安装程序将基于您所选的 SQL 排序规则为 Analysis Services 选择最匹配的 Windows 排序规则。如果数据库引擎 和 Analysis Services 的排序规则不匹配，您可能得到不一致的结果。为了确保数据库引擎 与 Analysis Services 之间结果的一致性，请使用 Windows 排序规则。

有关详细信息，请参阅安装程序中的排序规则设置。

排序次序

指定要与选定的“排序规则指示符”一起使用的排序顺序。二进制是最快的排序顺序，且区分大小写。如果选择了“二进制”，则“区分大小写”、“区分重音”、“区分假名”和“区分全半角”选项将不可用。有关详细信息，请参阅 Windows 排序规则排序样式。

SQL 排序规则

匹配与 SQL Server 8.0、7.0 或更早版本相兼容的设置。“SQL 排序规则”选项用于确保与旧版本的 SQL Server 兼容。有关详细信息，请参阅使用 SQL 排序规则。

注意：
SQL 排序规则不能用于 Analysis Services。如果选择了要在安装数据库引擎 时使用的 SQL 排序规则，则 SQL Server 安装程序将基于您所选的 SQL 排序规则为 Analysis Services 选择最匹配的 Windows 排序规则。如果数据库引擎 和 Analysis Services 的排序规则不匹配，您可能得到不一致的结果。为了确保数据库引擎 与 Analysis Services 之间结果的一致性，请使用 Windows 排序规则。

典型用户应用场景

有关 SQL Server 安装程序使用的 Windows 系统区域设置和相应默认排序规则的表，请参阅安装程序中的排序规则设置。

如果可能，最佳实践应包括对组织使用标准化排序规则。如果已在组织中的所有系统上使用标准的排序规则设置，则无需在每个字符或 Unicode 表达式中显式地指定排序规则。如果必须使用具有不同排序规则和代码页设置的对象，则必须对查询进行编码以考虑排序规则优先级的规则。

为 SQL Server 安装选择排序规则时，按列出的优先顺序考虑以下建议：

  • 如果二进制顺序可接受，请选择二进制排序规则。

  • 如果应用程序同时使用 nchar/nvarchar 和 char/varchar 数据类型并且可能在比较中混合使用它们，请选择 Windows 排序规则以便在各数据类型之间进行一致的比较。

  • 如果应用程序只使用 nchar/nvarchar 数据类型，则 Windows 排序规则和 SQL 排序规则的行为没有不同。

  • 如果应用程序只使用 char/varchar 数据类型，并且您使用 Analysis Services，请选择 Windows 排序规则。

  • 如果应用程序只使用 char/varchar 数据类型，并且您关心的是字符串比较/LIKE 性能，而不是 Windows 排序规则所提供的更好的语言比较语义，而且需要 SQL 排序规则提供的字典排序顺序，请选择 SQL 排序规则。

请参阅

参考

排序规则选项与国际支持
安装程序中的排序规则设置


报表服务器安装选项

报表服务器安装选项 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导中的“报表服务器安装选项”页来指定确定报表服务器实例安装方式的选项。安装选项的可用性取决于是否在安装报表服务器的同时还安装 SQL Server 数据库引擎 的本地实例以及是否其他默认值都可用。

如果安装程序由于一条或多条要求未得到满足而无法执行默认的报表服务器配置，那么安装向导只允许选择最小化安装选项；同时，它会复制所需的文件，但要求在安装结束后，使用 Reporting Services 配置工具来配置报表服务器。

如果计算机上安装了安全套接字层 (SSL) 证书并已将其与默认的网站相关联，那么安装程序将检测该证书，并配置报表服务器配置，使其在连接其他系统时使用 SSL。如果尚未安装 SSL 或安装程序无法使用此 SSL，则可通过 Reporting Services 配置工具或者设置 RSReportServer 配置文件中的 SecureConnectionLevel 手动配置报表服务器，使其使用 SSL。有关如何更改配置文件中的 SecureConnectionLevel 的详细信息，请参阅 SQL Server 联机丛书中的Using Secure Web Service Methods。

选项

安装默认配置

用报表服务器数据库、服务帐户和虚拟目录的默认值安装报表服务器实例。如果选择此选项，那么当安装程序完成后，报表服务器实例即可使用。安装程序通过使用本地数据库引擎 实例来创建报表服务器数据库，并配置报表服务器，使其使用默认值。

仅当报表服务器安装中使用的默认值对您的系统有效时，此选项才可用。建议希望在本地安装所有组件的开发人员和评估软件的用户使用此选项。

若要查看关于安装程序所用默认设置的信息，或者要找出默认配置无法安装的原因，请单击详细信息。若要了解关于默认配置的更多信息，请参阅报表服务器安装的默认配置。

安装但不配置服务器

安装报表服务器程序文件，创建报表服务器 Windows 服务帐户，并注册报表服务器 Windows Management Instrumentation (WMI) 提供程序。此安装选项称为“仅文件”安装。如果不希望使用默认配置，可以选择此选项。如果默认配置无法安装，则这是唯一可用的选项。

安装程序完成后，必须先创建报表服务器数据库并配置报表服务器，服务器才可以使用。若要配置报表服务器并创建数据库，请使用 Reporting Services 配置工具。有关详细信息，请参阅创建报表服务器数据库和配置报表服务器数据库连接。

请参阅

任务

如何启动 Reporting Services 配置
如何创建报表服务器数据库（Reporting Services 配置）

概念

使用安装程序安装 Reporting Services
报表服务器安装的默认配置
选择要安装的 Reporting Services 组件


报表服务器安装详细信息

报表服务器安装详细信息 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“报表服务器安装详细信息”页查看报表服务器安装创建前的配置详细信息。如果安装程序无法以默认配置安装报表服务器，此页将说明缺少哪些默认值。否则，此页将说明安装过程中将要配置的设置、名称和路径。根据计算机的配置和安装选项，预计在此页上可看到以下信息：

  • 报表服务器信息将显示用于运行报表服务器 Windows 服务和 Web 服务的用户帐户。Windows 服务帐户由安装向导在“服务帐户”页中指定。Web 服务帐户是此计算机的默认ASP.NET 帐户。报表服务器将使用这些帐户访问报表服务器数据库。

  • 报表服务器数据库信息标识承载报表服务器数据库的本地 SQL Server 实例。安装程序确定使用数据库引擎 的哪个实例。它始终是个本地实例，并且始终是与报表服务器同时安装的实例。有关使用的数据库引擎 实例的详细信息，请参阅实例名称。

  • 虚拟目录信息标识用于访问报表服务器和报表管理器的虚拟目录名称。虚拟目录创建在默认的网站下。它们分别以 reportserver 和 reports 命名。安装过程中无法为虚拟目录指定不同的名称或选择不同的网站。

    安装完成后，可以使用此页上注明的 URL 访问服务器组件。如果本地安装了多个报表服务器实例，那么此 URL 将会指定计算机名和实例名。

  • 安全套接字层 (SSL) 信息会告知您 SSL 证书是否已安装在计算机上，以及是否将其用于报表服务器连接。

注意：
安装程序完成后，使用 Reporting Services 配置工具可以修改报表服务器安装。

请参阅

参考

服务帐户
报表服务器安装选项

概念

使用安装程序安装 Reporting Services
报表服务器安装的默认配置
选择要安装的 Reporting Services 组件


错误和使用情况报告设置

错误和使用情况报告设置 |
 | 请参阅
安装程序用户界面参考 >

SQL Server Express 用户：单击错误和使用情况报告设置 (SQL Server Express) 可以获取 SQL Server Express 安装程序的特定信息。

使用 Microsoft SQL Server 安装向导的“错误和使用情况报告设置”页可以启用 SQL Server 2005 的功能错误和使用情况报告功能。

选项

对于此版本中的 SQL Server 2005 及其组件，功能使用情况数据收集和错误报告功能在默认情况下是启用的。不过，可以通过清除复选框禁用其中一个选项或将两个选项都禁用。

错误报告

如果启用错误报告功能，SQL Server 将配置为在下列任意 SQL Server 组件中发生错误时，自动发送报告到 Microsoft：

  • 数据库引擎

  • SQL Server 代理

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • 复制

Microsoft 利用错误报告来改进 SQL Server 的功能，并且对所有信息保密。

有关错误的信息将通过安全 (https) 连接发送到 Microsoft，在那里保存这些信息，且对其访问将受到限制。另外，也可以将这些信息发送到您自己的“公司错误报告”服务器。有关设置“公司错误报告”服务器的详细信息，请访问此 Microsoft 网站。

错误报告包含下列信息：

  • 发生问题时 SQL Server 的状态。

  • 操作系统版本和计算机硬件信息。

  • 用户数字产品 ID（并非用于标识您的许可证）。

  • 计算机或代理服务器的网络 IP 地址。

  • 来自出错进程的内存或文件的信息。

Microsoft 无意收集您的文件、姓名、地址、电子邮件地址或任何其他私人信息。但是，错误报告可能包含来自出错进程的内存或文件的个人信息。虽然使用这些信息有可能确定您的身份，但 Microsoft 不会将这些信息用于此目的。

有关 Microsoft SQL Server 隐私和数据收集策略的信息，请访问此 Microsoft 网站。

如果启用了错误报告功能并出现致命错误，Windows 事件日志中可能会包含来自 Microsoft 的响应，该响应指向与特定错误有关的 Microsoft 知识库文章。

若要在安装程序完成后禁用 SQL Server 及其组件的所有实例的错误或功能使用情况报告，请转到“错误和使用情况报告设置”对话框并清除“功能使用情况”的复选框。如果为 SQL Server 的多个组件（SQL Server 数据库引擎、分析服务器、报表服务器和共享组件）启用了“错误报告”，可以为个别组件以及共享组件（以“其他”列出）的每个实例禁用“错误报告”。

功能使用情况

如果启用“功能使用情况”报告，SQL Server 将被配置为定期向 Microsoft 发送报告。报告将包含有关硬件配置和用户如何使用 SQL Server 2005 软件和服务的信息。Microsoft 将使用功能使用情况数据改进 SQL Server。此功能监视的 SQL Server 2005 组件包括：

  • 数据库引擎

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • 复制

  • Business Intelligence Development Studio

有关功能使用情况的信息将发送到 Microsoft，在那里保存这些信息，且其访问将受到限制。

若要在安装程序完成后禁用功能使用情况报告，请使用 SQL Server 2005 “配置工具”菜单上的“SQL Server 错误和使用情况报告”工具。

对所有已启用的 SQL Server 实例会每天收集一次信息。为了尽量减轻服务器的负载，收集时间默认为午夜。如果要更改收集时间，可以手动编辑控制收集时间的注册表项。每个 SQL Server 实例都有自己的注册表项；下面的示例针对的是服务器上安装的第一个 SQL Server 实例 (MSSQL.1)：

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting。

该注册表项的值包含运行收集的时间，以从 00:00（午夜）起的分钟数计。例如，值为 60 会在凌晨 1:00 运行收集，而值为 1200 会在晚上 8:00 运行收集，等等。

请参阅

概念

配置 SQL Server 安装


准备安装

准备安装 |
 | 请参阅
安装程序用户界面参考 >

SQL Server Express 用户：单击准备安装 (SQL Server Express) 可以获取 Server Express 安装程序的特定信息。

安装或更新 Microsoft SQL Server 2005 之前，“准备安装”页提供对 SQL Server 安装程序将安装或更改的必备组件和功能的摘要。

选项

此页上有下列选项：

  • 若要继续安装，请单击“安装”。

  • 若要更改安装设置，请单击“上一步”。

  • 若要退出安装程序，请单击“取消”。

请参阅

任务

如何验证 SQL Server 2005 服务的安装成功
如何阅读 SQL Server 2005 安装日志文件

概念

如何查看 SQL Server 2005 安装日志文件


升级登录信息

升级登录信息 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“升级登录信息”页可以为要升级的 SQL Server 实例提供登录凭据。

在升级过程中，SQL Server 2005 安装程序必须访问要升级的实例。此页上提供的凭据使安装程序可以登录到早期 SQL Server 实例。

Windows 身份验证

Windows 身份验证模式使用户可以通过 Microsoft Windows 用户帐户进行连接。Microsoft 建议使用 Windows 身份验证。

SQL Server 身份验证

当用户通过不可信连接用指定的登录名和密码进行连接时，SQL Server 通过检查是否已设置 SQL Server 登录帐户以及指定的密码是否与以前记录的密码匹配，来自行执行身份验证。如果 SQL Server 未设置登录帐户，则身份验证失败，且用户将收到错误信息。

安全说明：
请尽量使用 Windows 身份验证。

用户名

输入连接所使用的用户名。只有选择了使用 Windows 身份验证进行连接，此选项才可用。

密码

输入登录名的密码。只有选择了使用 SQL Server 身份验证进行连接，此选项才可编辑。

请参阅

任务

如何使用复制数据库向导升级至 SQL Server 2005

其他资源

升级到 SQL Server 2005


升级被阻塞

升级被阻塞 |
 | 请参阅
安装程序用户界面参考 >

您选择升级的 Microsoft SQL Server 组件被阻止。“升级被阻止”对话框显示了产生阻止的原因，以及解决阻塞问题所必需的用户操作。

若要继续升级过程，请解决阻塞问题并再次运行 Microsoft SQL Server 2005 安装程序。

请参阅

概念

使用升级顾问来准备升级

其他资源

升级到 SQL Server 2005
向后兼容性


虚拟服务器名称

虚拟服务器名称 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“虚拟服务器名称”页指定分配给虚拟服务器的名称。

选项

虚拟服务器名称

为安装输入唯一的实例名。此名称将用于在网络中标识故障转移群集。虚拟 SQL Server 名称在网络中必须是唯一的，并且必须具有与主机群集和群集节点不同的名称。

请参阅

参考

实例名称

概念

故障转移群集


虚拟服务器配置

虚拟服务器配置 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“虚拟服务器配置”页定义虚拟服务器的 IP 地址配置。

选项

虚拟服务器名称

显示所定义 IP 地址上的虚拟服务器的名称。

要使用的网络

指定要输入 IP 地址的网络。

IP 地址

指定要为客户端访问配置的每个网络的 IP 地址。为将向公共（或混合）网络上的客户端提供虚拟服务器的每个网络输入一个 IP 地址。

若要避免发生 IP 地址冲突，请确保其他应用程序不共享分配给信号和 SQL Server 2005 的 IP 地址。

网络地址

显示由 Microsoft 群集服务提供的网络地址。

网络子网

显示由 Microsoft 群集服务提供的网络子网。

添加

将网络和 IP 地址添加到“所选的网络和 IP 地址”对话框中。

删除

从“所选的网络和 IP 地址”对话框中删除所选的网络和 IP 地址。

所选的网络和 IP 地址

显示为虚拟服务器配置的任何所选网络和 IP 地址。

请参阅

概念

故障转移群集


群集组选择

群集组选择 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“选择群集组”页选择群集组。选定的群集组是放置 SQL Server 虚拟服务器资源的地方。

选项

可用群集组

选择用来放置 SQL Server 虚拟服务器资源的群集组。每个群集组只能安装一个虚拟服务器。

如果选择包含群集仲裁资源的组，将显示警告。建议不要安装到群集仲裁资源。

不可用群集组

列出所有不可用群集组和每个组不可用的原因。例如，如果群集组已包含一个虚拟服务器，则该群集组将被列为不可用。

数据文件

显示数据库引擎 数据文件和 Analysis Services 数据文件的默认位置。

如果群集组中有多个共享驱动器，使用下拉列表为共享数据文件选择驱动器。

请参阅

概念

创建虚拟服务器，安装故障转移群集


服务帐户（分类）

服务帐户（分类） |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“服务帐户（分类）”页为 SQL Server 服务分配登录帐户。此页上配置的实际服务取决于已选择要安装的功能。

选项

可以为所有的 SQL Server 服务分配相同的登录帐户，也可以分别配置各个服务帐户。还可以指定服务是否自动启动。

安全说明：
设置强密码对于确保系统的安全至关重要。始终使用强密码。

为每个服务帐户进行自定义

选中“为每个服务帐户进行自定义”复选框可以自定义各服务的设置。

此选项为各个服务分配特定的登录帐户。单击此复选框将实现最小特权原则，即 SQL Server 服务被授予完成其任务所需的最低权限。有关详细信息，请参阅设置 Windows 服务帐户。

如果未选中此复选框，将对所有 SQL Server 服务使用相同的帐户和设置。

选择下列任一服务以自定义其设置。

选择此服务 为其配置身份验证设置的主体

SQL Server

SQL Server 数据库引擎

SQL Server 代理

执行作业、监视 SQL Server 并允许管理任务自动完成的服务。

Analysis Services

Analysis Services

Reporting Services

Reporting Services。服务帐户用于配置报表服务器数据库连接。如果要连接到远程 SQL Server 实例上的报表服务器数据库，请选择域用户帐户。如果您使用的是本地报表服务器数据库，则可以使用域用户帐户或本地系统帐户来运行该服务。

SQL Server 浏览器

SQL Server 浏览器是向客户机提供 SQL Server 连接信息的名称解析服务。多个 SQL Server 和 Integration Services 实例共享此服务。
使用内置系统帐户

该选项已被禁用，因为您无法在 SQL Server 群集上使用内置系统帐户。

使用域用户帐户

指定一个使用 Windows 身份验证的域用户帐户，以设置并连接到 SQL Server。建议对 SQL Server 服务使用具有最低权限的域用户帐户，因为 SQL Server 服务不需要管理员帐户特权。

如果创建属于非 SQL Server 管理员的 CmdExec 和 ActiveScript 作业，或者使用 AutoRestart 功能，则 SQL Server 代理帐户必须具有管理员特权。如果环境中需要上述功能，请考虑为 SQL Server 和 SQL Server 代理服务使用不同的服务帐户。

有关强密码准则，请参阅身份验证模式。

注意：
域名不能为完整的 DNS 名称。例如，如果 DNS 名称为 my-domain-name.com，将在域字段中使用 my-domain-name。SQL Server 安装程序不接受域字段中的 my-domain-name.com。

SQL Server 安装结束时启动服务

当操作系统启动时自动启动服务。对于 SQL Server 2005，默认情况下会为 SQL Server、Analysis Services 和 Reporting Services 选中服务“自动启动”选项。

注意：
SQL Server 代理服务依赖于 SQL Server 服务。如果选中 SQL Server 代理的“自动启动”复选框，则自动选中 SQL Server 服务的“自动启动”，此后只有取消选中 SQL Server 代理的此选项时才能将它取消选中。

重要事项：
默认关闭 - 为了提高 SQL Server 2005 的安全性，一些服务和功能默认情况下不激活。必须在安装程序完成后配置和启用这些服务和功能。有关详细信息，请参阅 SQL Server 外围应用配置器和 安装 SQL Server 的安全注意事项。

请参阅

参考

设置 Windows 服务帐户

概念

安装 SQL Server 的安全注意事项


群集服务的域组

群集服务的域组 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“群集服务的域组”页，可以为要安装为 SQL Server 2005 故障转移群集一部分的群集服务指定域组。

若要确保安全的操作环境，必须限制对故障转移群集节点中的资源的访问。在 SQL Server 2005 故障转移群集上，所有群集节点公用的域组用来控制对注册表项、文件、SQL Server 对象以及其他群集资源的访问。所有资源权限都由包括 SQL Server 服务帐户作为成员的域级组来控制。

添加域组是域管理员的主要职责之一。请确保创建或修改 SQL Server 2005 故障转移群集的所有域组时都考虑了组织的安全策略。

选项

SQL Server 服务、SQL Server 代理服务、Analysis Services 服务以及全文搜索服务必须作为域帐户运行。运行 SQL Server 安装程序时，必须存在这些服务的域组。如果必要，请向您的域管理员询问现有域组的名称，或者为您的故障转移群集创建域组。

对于正在安装的 SQL Server 实例中的每个群集服务，请以 <DomainName>\<GroupName> 格式输入域名和组名，请遵循以下基本原则：

  • 域组必须与计算机帐户位于同一域中。例如，如果将安装 SQL Server 的计算机在 SQLSVR 域（MYDOMAIN 的子域）中，则必须在 SQLSVR 域中指定一个组。SQLSVR 域可能包含来自 MYDOMAIN 的用户帐户。

  • 用户必须是域组的直接成员，而不是通过子组才成为域组的成员。安装程序不会遵循子组成员身份来验证用户帐户是否在域组中。

  • 运行安装程序时，域和域组名必须已经存在。如果必要，请向您的域管理员询问现有域组的名称，或者为您的故障转移群集创建域组。如果在运行安装程序前刚刚创建域组，则应留出时间，以允许更改通过企业网络进行传播。

  • 应为域组添加相应的服务帐户。如果在运行安装程序时，服务帐户不是相应的域组成员，则安装程序将尝试添加这些服务帐户。在此情况下，运行安装程序的帐户必须具有向域组添加帐户的充足权限。如果 SQL Server 安装程序以无权向域组添加用户的帐户运行，则用户必须已经是相应组的成员。

  • 每个服务应使用不同的域组。但是，可对所有 SQL Server 服务使用相同的域组和相同的帐户，可对每个 SQL Server 服务使用相同的域组和不同的帐户，还可以对每个 SQL Server 服务使用不同的域组和不同的帐户。若要维护最具体的权限控制，可对域中的每个 SQL Server 服务和每个虚拟服务器使用不同的帐户和不同的域组。

  • SQL Server 域组不应与任何其他应用程序共享。

请注意，为了解决域组问题，您必须具有域控制器的访问权限。

如果卸载 SQL Server 或更改 SQL Server 帐户，这些帐户将不会从域组中删除。域管理员必须确保在删除 SQL Server 后删除所有不需要的帐户。

请参阅

概念

安装故障转移群集前的准备工作


群集节点配置

群集节点配置 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“群集节点配置”页选择要包含在虚拟服务器中的群集节点。

选项

可用节点

显示可以包含在虚拟服务器定义中的节点。请单击“添加”，将可用节点移动到“所选节点”列表。

所选节点

显示已选择要包含在虚拟服务器定义中的节点。

添加

将所选节点从“可用节点”列表移动到“所选节点”列表，从而将节点添加到虚拟服务器定义。

删除

从“所选节点”列表删除所选节点，这进而从虚拟服务器中删除节点。

所需节点

显示所需节点。所需节点拥有安装了 SQL Server 数据文件的群集组。

不可用节点

显示不可用节点的列表及每个节点不可用的原因。

请参阅

概念

故障转移群集


远程帐户信息

远程帐户信息 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“远程帐户信息”页输入虚拟服务器的远程登录信息。

选项

Username

如果登录字段未预填充，请指定一个对群集的所有节点都为有效管理员帐户的用户名。

密码

为所选管理员帐户指定密码。

安全说明：
设置强密码对于确保系统的安全性至关重要。请始终使用强密码。

请参阅

概念

故障转移群集


更改或删除实例

更改或删除实例 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“更改或删除实例”页可以选择是维护还是删除 SQL Server 的现有实例。通过“控制面板”中的“添加或删除程序”提供维护选项。

选项

更改已安装的功能

使用此选项可以向选定的 SQL Server 实例添加功能或从中删除功能。

删除 Microsoft SQL Server

选择此选项可以从计算机中删除已安装的 SQL Server。

注意：
在此版本中，故障转移群集的维护功能只能通过使用“添加或删除程序”获得。

请参阅

任务

如何在 SQL Server 2005 的现有实例中更改组件（安装程序）
如何卸载 SQL Server 2005 的现有实例（安装程序）

参考

SQL Server 2005 的版本和组件


群集维护

群集维护 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“更改或删除”页选择是否更改或删除虚拟服务器安装。

可以通过控制面板中的“添加/删除程序”访问维护选项。SQL Server 2005 的每个组件都在“添加或删除程序”中单独列出。

选项

维护虚拟服务器

使用此选项添加或删除节点。

删除 Microsoft SQL Server

选择此选项以从群集中删除虚拟服务器。

请参阅

任务

如何创建新的 SQL Server 2005 故障转移群集（安装）
如何删除 SQL Server 2005 故障转移群集实例（安装程序）


安装进度

安装进度 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“安装进度”页监视 SQL Server 安装程序的状态。

选项

SQL Server 2005 安装程序分别运行于故障转移群集的每个节点上。若要在故障转移群集安装过程中监视单个节点中的安装进度，请使用“节点”下拉菜单在群集节点之间切换。

可以通过控制面板中的“添加/删除程序”访问维护选项。

请参阅

概念

如何查看 SQL Server 2005 安装日志文件


保留关键字（安装程序）

保留关键字（安装程序） |
 | 请参阅
安装程序用户界面参考 >

Microsoft SQL Server 2005 将保留关键字用于定义、操作和访问数据库。保留关键字是 SQL Server 使用的 Transact-SQL 语法的组成部分，用于分析和理解 Transact-SQL 语句和批处理。

SQL Server 实例名不能与保留关键字相同。如果匹配将导致安装错误。下表可用于确保在 SQL Server 2005 实例名中不使用保留关键字。

ADD | EXCEPT | PERCENT
ALL | EXEC | PLAN
ALTER | EXECUTE | PRECISION
AND | EXISTS | PRIMARY
ANY | EXIT | PRINT
AS | FETCH | PROC
ASC | FILE | PROCEDURE
AUTHORIZATION | FILLFACTOR | PUBLIC
BACKUP | FOR | RAISERROR
BEGIN | FOREIGN | READ
BETWEEN | FREETEXT | READTEXT
BREAK | FREETEXTTABLE | RECONFIGURE
BROWSE | FROM | REFERENCES
BULK | FULL | REPLICATION
BY | FUNCTION | RESTORE
CASCADE | GOTO | RESTRICT
CASE | GRANT | RETURN
CHECK | GROUP | REVOKE
CHECKPOINT | HAVING | RIGHT
CLOSE | HOLDLOCK | ROLLBACK
CLUSTERED | IDENTITY | ROWCOUNT
COALESCE | IDENTITY_INSERT | ROWGUIDCOL
COLLATE | IDENTITYCOL | RULE
COLUMN | IF | SAVE
COMMIT | IN | SCHEMA
COMPUTE | INDEX | SELECT
CONSTRAINT | INNER | SESSION_USER
CONTAINS | INSERT | SET
CONTAINSTABLE | INTERSECT | SETUSER
CONTINUE | INTO | SHUTDOWN
CONVERT | IS | SOME
CREATE | JOIN | STATISTICS
CROSS | KEY | SYSTEM_USER
CURRENT | KILL | TABLE
CURRENT_DATE | LEFT | TEXTSIZE
CURRENT_TIME | LIKE | THEN
CURRENT_TIMESTAMP | LINENO | TO
CURRENT_USER | LOAD | TOP
CURSOR | NATIONAL | TRAN
DATABASE | NOCHECK | TRANSACTION
DBCC | NONCLUSTERED | TRIGGER
DEALLOCATE | NOT | TRUNCATE
DECLARE | NULL | TSEQUAL
DEFAULT | NULLIF | UNION
DELETE | OF | UNIQUE
DENY | OFF | UPDATE
DESC | OFFSETS | UPDATETEXT
DISK | ON | USE
DISTINCT | OPEN | USER
DISTRIBUTED | OPENDATASOURCE | VALUES
DOUBLE | OPENQUERY | VARYING
DROP | OPENROWSET | VIEW
DUMMY | OPENXML | WAITFOR
DUMP | OPTION | WHEN
ELSE | OR | WHERE
END | ORDER | WHILE
ERRLVL | OUTER | WITH
ESCAPE | OVER | WRITETEXT

此外，SQL-2003 标准还定义了一组保留关键字。不要使用 SQL-2003 保留关键字作为对象名和标识符。下表所示的 ODBC 保留关键字列表与 SQL-2003 保留关键字列表相同。

注意：
SQL-2003 保留关键字列表有时可能比 SQL Server 限制更多，有时则限制更少。例如，SQL-2003 保留关键字列表包含 INT，而 SQL Server 不将 INT 视为保留关键字。

ODBC 保留关键字

保留了下列关键字用于 ODBC 函数调用。这些关键字根本不约束 SQL 语法；但是，为确保与支持核心 SQL 语法的驱动程序兼容，应避免在 SQL Server 实例名中使用这些关键字。

ABSOLUTE | EXEC | OVERLAPS
ACTION | EXECUTE | PAD
ADA | EXISTS | PARTIAL
ADD | EXTERNAL | PASCAL
ALL | EXTRACT | POSITION
ALLOCATE | FALSE | PRECISION
ALTER | FETCH | PREPARE
AND | FIRST | PRESERVE
ANY | FLOAT | PRIMARY
ARE | FOR | PRIOR
AS | FOREIGN | PRIVILEGES
ASC | FORTRAN | PROCEDURE
ASSERTION | FOUND | PUBLIC
AT | FROM | READ
AUTHORIZATION | FULL | REAL
AVG | GET | REFERENCES
BEGIN | GLOBAL | RELATIVE
BETWEEN | GO | RESTRICT
BIT | GOTO | REVOKE
BIT_LENGTH | GRANT | RIGHT
BOTH | GROUP | ROLLBACK
BY | HAVING | ROWS
CASCADE | HOUR | SCHEMA
CASCADED | IDENTITY | SCROLL
CASE | IMMEDIATE | SECOND
CAST | IN | SECTION
CATALOG | INCLUDE | SELECT
CHAR | INDEX | SESSION
CHAR_LENGTH | INDICATOR | SESSION_USER
CHARACTER | INITIALLY | SET
CHARACTER_LENGTH | INNER | SIZE
CHECK | INPUT | SMALLINT
CLOSE | INSENSITIVE | SOME
COALESCE | INSERT | SPACE
COLLATE | INT | SQL
COLLATION | INTEGER | SQLCA
COLUMN | INTERSECT | SQLCODE
COMMIT | INTERVAL | SQLERROR
CONNECT | INTO | SQLSTATE
CONNECTION | IS | SQLWARNING
CONSTRAINT | ISOLATION | SUBSTRING
CONSTRAINTS | JOIN | SUM
CONTINUE | KEY | SYSTEM_USER
CONVERT | LANGUAGE | TABLE
CORRESPONDING | LAST | TEMPORARY
COUNT | LEADING | THEN
CREATE | LEFT | TIME
CROSS | LEVEL | TIMESTAMP
CURRENT | LIKE | TIMEZONE_HOUR
CURRENT_DATE | LOCAL | TIMEZONE_MINUTE
CURRENT_TIME | LOWER | TO
CURRENT_TIMESTAMP | MATCH | TRAILING
CURRENT_USER | MAX | TRANSACTION
CURSOR | MIN | TRANSLATE
DATE | MINUTE | TRANSLATION
DAY | MODULE | TRIM
DEALLOCATE | MONTH | TRUE
DEC | NAMES | UNION
DECIMAL | NATIONAL | UNIQUE
DECLARE | NATURAL | UNKNOWN
DEFAULT | NCHAR | UPDATE
DEFERRABLE | NEXT | UPPER
DEFERRED | NO | USAGE
DELETE | NONE | USER
DESC | NOT | USING
DESCRIBE | NULL | VALUE
DESCRIPTOR | NULLIF | VALUES
DIAGNOSTICS | NUMERIC | VARCHAR
DISCONNECT | OCTET_LENGTH | VARYING
DISTINCT | OF | VIEW
DOMAIN | ON | WHEN
DOUBLE | ONLY | WHENEVER
DROP | OPEN | WHERE
ELSE | OPTION | WITH
END | OR | WORK
END-EXEC | ORDER | WRITE
ESCAPE | OUTER | YEAR
EXCEPT | OUTPUT | ZONE
EXCEPTION |  |

将来的关键字

在 SQL Server 的将来版本中，实现新功能时，以下关键字可能成为保留关键字。注意，不要在 SQL Server 实例名中使用这些关键字。

ABSOLUTE | FOUND | PREPARE
ACTION | FREE | PRESERVE
ADMIN | FULLTEXTTABLE | PRIOR
AFTER | GENERAL | PRIVILEGES
AGGREGATE | GET | READS
ALIAS | GLOBAL | REAL
ALLOCATE | GO | RECURSIVE
ARE | GROUPING | REF
ARRAY | HOST | REFERENCING
ASSERTION | HOUR | RELATIVE
AT | IGNORE | RESULT
BEFORE | IMMEDIATE | RETURNS
BINARY | INDICATOR | ROLE
BIT | INITIALIZE | ROLLUP
BLOB | INITIALLY | ROUTINE
BOOLEAN | INOUT | ROW
BOTH | INPUT | ROWS
BREADTH | INT | SAVEPOINT
CALL | INTEGER | SCROLL
CASCADED | INTERVAL | SCOPE
CAST | ISOLATION | SEARCH
CATALOG | ITERATE | SECOND
CHAR | LANGUAGE | SECTION
CHARACTER | LARGE | SEQUENCE
CLASS | LAST | SESSION
CLOB | LATERAL | SETS
COLLATION | LEADING | SIZE
COMPLETION | LESS | SMALLINT
CONNECT | LEVEL | SPACE
CONNECTION | LIMIT | SPECIFIC
CONSTRAINTS | LOCAL | SPECIFICTYPE
CONSTRUCTOR | LOCALTIME | SQL
CORRESPONDING | LOCALTIMESTAMP | SQLEXCEPTION
CUBE | LOCATOR | SQLSTATE
CURRENT_PATH | MAP | SQLWARNING
CURRENT_ROLE | MATCH | START
CYCLE | MINUTE | STATE
DATA | MODIFIES | STATEMENT
DATE | MODIFY | STATIC
DAY | MODULE | STRUCTURE
DEC | MONTH | TEMPORARY
DECIMAL | NAMES | TERMINATE
DEFERRABLE | NATURAL | THAN
DEFERRED | NCHAR | TIME
DEPTH | NCLOB | TIMESTAMP
DEREF | NEW | TIMEZONE_HOUR
DESCRIBE | NEXT | TIMEZONE_MINUTE
DESCRIPTOR | NO | TRAILING
DESTROY | NONE | TRANSLATION
DESTRUCTOR | NUMERIC | TREAT
DETERMINISTIC | OBJECT | TRUE
DICTIONARY | OLD | UNDER
DIAGNOSTICS | ONLY | UNKNOWN
DISCONNECT | OPERATION | UNNEST
DOMAIN | ORDINALITY | USAGE
DYNAMIC | OUT | USING
EACH | OUTPUT | VALUE
END-EXEC | PAD | VARCHAR
EQUALS | PARAMETER | VARIABLE
EVERY | PARAMETERS | WHENEVER
EXCEPTION | PARTIAL | WITHOUT
EXTERNAL | PATH | WORK
FALSE | POSTFIX | WRITE
FIRST | PREFIX | YEAR
FLOAT | PREORDER | ZONE

请参阅

任务

如何安装 SQL Server 2005（安装程序）


组件选择 - 维护

组件选择 - 维护 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“组件选择 - 维护”页，可选择要更新的 SQL Server 实例或共享组件。

选项

本页中只允许选择一项。可选择要更新的实例或公共组件。

报表

查看安装在计算机上的 SQL Server 2005 组件和功能的列表。该报表包含安装的每个组件和功能的版本、版本类别、更新级别和语言信息。

请参阅

参考

要安装的组件
SQL Server 2005 的各种版本所支持的功能


安装示例数据库

安装示例数据库 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导中的“安装示例数据库”页，可选择将示例数据库安装到现有 SQL Server 实例的方法。

重要提示 安装 AdventureWorks 和 AdventureWorksDW 示例数据库后，使用的排序规则是 SQL_Latin1_General_CP1_CI_AS，而不是为 SQL Server 实例选定的排序规则。若要更改示例数据库的排序规则以匹配服务器排序规则，请删除数据库并从安装脚本重新创建。有关详细信息，请参阅从脚本重新安装示例数据库。

选项

安装但不附加示例数据库

AdventureWorks 数据库文件在文件夹 <drive>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks OLTP 中创建。AdventureWorksDW 文件在 <drive>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Data Warehouse 文件夹中创建。必须先附加数据库，然后才能使用它。有关详细信息，请参阅分离和附加数据库。

安装并附加示例数据库

数据库文件创建并存储在文件夹 <drive>:\Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Data 中。数据库已附加到选定的 SQL Server 实例，并已可使用。

若要附加数据库，必须具有在指定的实例中创建数据库的权限。

SQL Server 实例

选择要安装示例数据库和示例的 SQL Server 实例。

完成示例安装

若要完成示例的安装，在安装完成后，请执行下列步骤之一：

  1. 从“开始”菜单中单击“所有程序”，单击 Microsoft SQL Server 2005，单击“文档和教程”，然后单击“示例”，再单击“Microsoft SQL Server 2005 示例”。

  2. 或者使用 Windows 资源管理器，定位到 <drive>:\Program Files\Microsoft SQL Server\90\Tools\Samples\，然后双击 SqlServerSamples.msi 启动安装程序。

重要事项：
示例被安装到 <drive>:\Program Files\Microsoft SQL Server\90\Samples。请务必阅读并遵照您希望使用的示例所附带的自述文件中的安装说明。有关示例的列表，请参阅 SQL Server 2005 联机丛书中的“示例”主题。

部署 Adventure Works DW Analysis Services 项目

  1. 请确保已经安装了 AdventureWorksDW 和 Adventure Works DW 数据库。

  2. 请确保已经安装了 Analysis Services。

  3. 在 SQL Server Business Intelligence Development Studio 工具栏中单击“文件”，指向“打开”，然后单击“项目/解决方案”。

  4. 浏览到 <drive>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Analysis Services Project，选择文件 Adventure Works.sln，然后单击“打开”。

  5. 从解决方案资源管理器中，右键单击 Adventure Works DW 并选择“部署”或“处理”。

请参阅

参考

要安装的组件
SQL Server 2005 的各种版本所支持的功能

更改历史记录

版本 历史记录

已更改的内容：
  • 这是此版本中新增加的内容。


组件选择 - 卸载

组件选择 - 卸载 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“组件选择 - 卸载”页，可选择要删除的 SQL Server 实例和任何共享组件。

选项

可选择要卸载的实例和任何公共组件。

报表

查看安装在计算机上的 SQL Server 2005 组件和功能的列表。该报表包含安装的每个组件和功能的版本、版本类别、更新级别和语言信息。

请参阅

参考

要安装的组件
SQL Server 2005 的各种版本所支持的功能


确认 - 卸载

确认 - 卸载
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“确认 - 卸载”页，可确认要从 SQL Server 2005 安装中删除的功能和组件。

选项

该对话框列出已选定删除的功能和组件。确认列表中列出了所有所需项，然后单击“下一步”继续。


实例类型 - 卸载

实例类型 - 卸载 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“实例类型 - 卸载”页，可选择要卸载的组件。

选项

选择要删除的组件，然后单击“下一步”。

请参阅

参考

SQL Server 2005 的各种版本所支持的功能


孤立组件选择

孤立组件选择 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“孤立组件选择”页，可选择卸载部分组件。还可以在升级后删除上次安装的任何剩余组件。

选项

选择要删除的组件，然后单击“下一步”。

请参阅

参考

SQL Server 2005 的各种版本所支持的功能


维护功能选择

维护功能选择 |
 | 请参阅
安装程序用户界面参考 >

使用 Microsoft SQL Server 安装向导的“维护功能选择”页，可选择要维护的服务器组件。

选项

可以选择任何要维护的单个服务器组件。

报表

查看安装在计算机上的 SQL Server 2005 组件和功能的列表。该报表包含安装的每个组件和功能的版本、版本类别、更新级别和语言信息。

请参阅

参考

要安装的组件
SQL Server 2005 的各种版本所支持的功能


安装用户界面参考 (SQL Server Express)

安装用户界面参考 (SQL Server Express)
安装程序用户界面参考 >

本部分有助于引导您完成 Microsoft SQL Server 安装向导，以便可以安装 SQL Server 2005 Express Edition。

通过按 F1 键或通过单击对话框及向导页中的“帮助”，可以在用户界面上查看该节点下的这些主题。


系统配置检查 (SQL Server Express)

系统配置检查 (SQL Server Express)
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

Microsoft SQL Server 安装向导的“系统配置检查 (SCC)”页显示系统准备工具的进度。SCC 例程将扫描目标计算机来检查阻止安装的情况。对于群集，SCC 将在操作系统群集的所有节点上运行。

可以随时单击“停止”来取消 SCC 并退出安装向导。

进度符号如下所示：

  • 箭头符号 = 正在进行检查。

  • 对勾符号 = 检查项成功。

  • × 符号 = 检查项失败。

SCC 检查完成之后，“报表”按钮便可用。仅当所有检查结果成功，或者失败的检查并不严重时，“下一步”按钮才可用。对于失败的检查项，阻止问题的解决方案将包括在 SCC 报表内的结果中。

使用 SCC 页底部的“报表”按钮，您可以查看报表，将报表保存为一个文件，将文件复制到剪贴板或通过电子邮件进行发送。报表中的信息包括：

  • 在目标计算机上检查的配置项的列表：当前操作系统的要求、操作系统 Service Pack 级别、SQL Server 版本与当前操作系统的兼容性以及 Internet 信息服务 (IIS)。

  • 每次项检查的结果。

  • 解决失败的配置检查时建议使用的方法。


注册信息 (SQL Server Express)

注册信息 (SQL Server Express)
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

Microsoft SQL Server 安装向导的“注册信息”页请求用于注册 SQL Server 副本的标识信息。

选项

选项 | 说明
名称 | 输入负责管理正在运行 SQL Server 2005 Express Edition (SQL Server Express) 的服务器的用户名。只有具备用户名才能继续执行安装程序。
公司 | 输入公司的名称。如果是个人产品副本，则可以再提供您的姓名。该字段的信息是可选择填写的。
注意：
由于 SQL Server Express 是一款免费下载软件，因此“注册信息”页上没有“产品密钥”文本框。

隐藏高级配置

在“注册信息”页的底部，具有“隐藏高级配置选项”复选框。如果选中该复选框，则不会出现下列安装页：

  • 实例名

  • 服务帐户

  • 排序规则设置

  • 用户实例


功能选择 (SQL Server Express)

功能选择 (SQL Server Express)
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

“功能选择”页有两个窗格。左窗格显示可以安装的功能的树视图。单击功能旁边的“+”号可以将其展开，以查看它的子功能。当您单击功能或子功能时，“功能说明”窗格将显示所选内容及其磁盘空间要求的说明。

若要添加或删除某项功能，请单击该功能的图标，然后从下拉列表中选择下列选项之一：

选项 说明

将安装到本地硬盘上

将所选功能安装到“安装路径”下显示的位置。

整个功能将安装到本地硬盘上

安装所选功能及其所有子功能。展开父功能，以查看它的子功能

整个功能将不可用

对于新的 SQL Server 安装，该选项将跳过所选功能的安装。对于现有安装，该选项会将功能从安装中删除。选择该选项之后，功能树上功能名称的旁边将出现红色 X，树视图中父功能上的图标变为灰色。

注意：
如果选定某项功能的一项子功能，则不能清除该功能。若要清除某项功能，请确保也要清除该功能的所有子功能。

浏览

启动“更改文件夹”页，可以使用该页更改将要安装所选功能的文件夹。只有对那些用户可以配置其安装路径的功能，该按钮才可用。有关安装路径的详细信息，请参阅 SQL Server 2005 联机丛书中的 SQL Server 2005 的默认实例和命名实例的文件位置。

磁盘开销

显示计算机上不同系统驱动器中用于安装的可用空间。在“磁盘开销”对话框中检查计算机上的磁盘空间之后，单击“关闭”以继续安装 SQL Server。


实例名 (SQL Server Express)

实例名 (SQL Server Express)
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

使用 Microsoft SQL Server 安装向导的“实例名”页，可指定创建默认实例还是创建 SQL Server Express 命名实例。除非您选择默认实例，否则 SQL Server Express 将始终安装命名实例 (SQLExpress)。此行为与 SQL Server 2005 不同，后者在未选择命名实例的情况下，将始终安装默认实例。

选项

选项 说明

默认实例

如果选择“默认实例”，而计算机上已经存在默认实例，则 SQL Server 安装程序将升级该默认实例。请选择此选项来安装 SQL Server Express 的默认实例。一台计算机只能承载一个默认实例。

注意：
默认实例名为 MSSQLSERVER；它不需要客户端指定实例名称即可建立连接。

若要升级早期 SQL Server 安装的默认实例，请单击“默认实例”，然后单击“下一步”。

命名实例

运行 SQL Server Express 时，默认情况下将选中已命名的实例选项，并且实例名为 SQLExpress。

请选择此选项来创建新命名实例。命名 SQL Server 实例时，请考虑以下事项：

  • 实例名不区分大小写。

  • 实例名不能包含 Default、MSSQLServer 或其他保留关键字。如果在实例名中使用了保留关键字，则将发生错误。

  • 实例名限制为 16 个字符。

  • 实例名的首字符必须是字母或下划线 (_)。可接受的字母为 Unicode 标准 2.0 中定义的字符，包括拉丁字符 a-z 和 A-Z，以及源于其他语言的字母字符。

  • 后续字符可以是 Unicode 标准 2.0 定义的字母、源于基本拉丁语或其他国家/地区书写符号的十进制数字、美元符号 ($) 或者下划线 (_)。

  • 实例名中不允许有其他特殊字符的嵌入空格；也不允许有反斜杠 (\)、逗号 (,)、冒号 (:)、分号 (;)、单引号 (')、“and”符 (&)、数字符号 (#) 或“at”符号 (@)。

注意：
只有在当前 Microsoft Windows 代码页中有效的字符才能在 SQL Server 实例名中使用。如果使用了不支持的 Unicode 字符，将会发生错误。

已安装的实例

使用 SQL Server 安装向导的“已安装的实例”页，可以查看运行 SQL Server 安装程序的计算机上已安装的 SQL Server Express 实例和组件列表。“已安装实例的详细信息”窗格显示已安装实例的升级选项。若要选择欲升级的组件或实例，请单击实例名，然后单击“确定”。


现有组件 (SQL Server Express)

现有组件 (SQL Server Express)
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

使用 Microsoft SQL Server 安装向导的“现有组件”页，可以查看运行 SQL Server 安装程序的计算机中已安装的 SQL Server 组件的列表。

选项

选项 | 说明
详细信息 | 单击“详细信息”可以查看列出了当前已安装的每个 SQL Server 组件的可用维护和升级选项的报表。 有关单击“详细信息”之后显示的选项的详细信息，请参阅安装选项 (SQL Server Express)。


安装选项 (SQL Server Express)

安装选项 (SQL Server Express)
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

使用 Microsoft SQL Server 安装向导的“安装选项”页，可以查看现有的 SQL Server Express 实例和组件的维护和升级选项。如果为当前安装选定的组件已经是同名实例的现有安装的一部分，则会显示此页。

选项

以下各部分介绍维护和升级选项。

维护

SQL Server Express 的实例维护和功能维护是通过“控制面板”中的“添加或删除程序”进行的。选择要添加或删除功能的 SQL Server 的实例。有关详细信息，请参阅如何在 SQL Server 2005 的现有实例中更改组件（安装程序）。

升级

支持的升级路径如下：

当前的 SQL Server 实例 | 升级到 SQL Server Express（32 位） | 升级到带有高级服务的 SQL Server Express（32 位）
SQL Server Desktop Engine (MSDE) 7.0 (SP4) | 支持 | 支持
SQL Server 7.0 Desktop Edition SP4 | 不支持 | 不支持
SQL Server 7.0 Standard Edition SP4 | 不支持 | 不支持
SQL Server Developer Edition SP4 | 不支持 | 不支持
SQL Server Enterprise Edition SP4 | 不支持 | 不支持
SQL Server 7.0 Evaluation Edition SP4 | 不支持的升级 | 不支持的升级
SQL Server Desktop Engine (MSDE) 2000 SP3 或更高版本 | 支持 | 支持
SQL Server 2000 Personal Edition SP3 或更高版本 | 支持 | 支持
SQL Server 2000 Workgroup Edition SP3 或更高版本 | 不支持 | 不支持
SQL Server 2000 Standard Edition SP3 或更高版本 | 不支持 | 不支持
SQL Server 2000 Developer Edition SP3 或更高版本 | 不支持 | 不支持
SQL Server 2000 Enterprise Edition SP3 或更高版本 | 不支持 | 不支持
SQL Server 2000 Evaluation Edition 或更高版本 | 不支持 | 不支持
SQL Server 2005 Express Edition | 不支持 | 支持
SQL Server 2005 Enterprise Edition | 不支持 | 不支持
SQL Server 2005 Workgroup Edition | 不支持 | 不支持
SQL Server 2005 Standard Edition | 不支持 | 不支持
SQL Server 2005 Developer Edition | 不支持 | 不支持
SQL Server 2005 Evaluation Edition | 不支持 | 否


服务帐户 (SQL Server Express)

服务帐户 (SQL Server Express)
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

使用 Microsoft SQL Server 安装向导的“服务帐户”页可以为 SQL Server 服务分配登录帐户。

可以为所有 SQL Server 服务分配相同的登录帐户，也可以分别配置每个服务帐户。还可以指定服务是否自动启动。

安全说明：
设置强密码对于确保系统的安全性至关重要。请始终使用强密码。

选项

选项 说明

为每个服务帐户进行自定义

如果要为单个服务自定义设置，请选中该复选框，然后在“服务”列表中更改每个服务的设置。

该选项为各个服务分配特定的登录帐户。选中该复选框，用户可以实现最小特权原则，即 SQL Server 服务被授予完成其任务所需的最低权限。有关详细信息，请参阅 SQL Server 2005 联机丛书中的Setting Up Windows Service Accounts。

如果未选中该复选框，则将对所有 SQL Server 服务使用相同的帐户和设置。

服务

选择下列任一服务以自定义其设置。

SQL Server：SQL Server 数据库引擎

SQL Server 浏览器：SQL Server 浏览器是向客户端计算机提供 SQL Server 连接信息的名称解析服务。该服务在多个 SQL Server 实例之间共享。

使用内置系统帐户

您可以为可配置的 SQL Server 服务的登录分配本地系统、网络服务或本地服务。

本地系统帐户

本地系统选项指定本地系统帐户，该帐户无需密码即可连接到同一台计算机上的 SQL Server。不过，本地系统帐户可能会限制 SQL Server 安装与其他服务器进行交互，具体取决于该帐户所拥有的特权。

重要事项：
本地系统是一个功能强大的帐户。它可能不适用于所有的服务设置。有关详细信息，请参阅 SQL Server 2005 联机丛书中的安装 SQL Server 的安全注意事项。

网络服务帐户

网络服务帐户是一个特殊的内置帐户，它与通过身份验证的用户帐户类似。网络服务帐户与 Users 组的成员具有相同级别的资源和对象访问权限。以网络服务帐户身份运行的服务将使用计算机帐户的凭据访问网络资源。

重要事项：
我们不建议您对 SQL Server 使用网络服务帐户。本地用户帐户或域用户帐户会更适用于这些 SQL Server 服务。

本地服务帐户

本地服务帐户是一个特殊的内置帐户，它与通过身份验证的用户帐户类似。本地服务帐户与 Users 组的成员具有相同级别的资源和对象访问权限。如果有个别服务或进程的安全性受到威胁，则此有限访问权限有助于保护系统的安全性。以本地服务帐户身份运行的服务将以一个没有凭据的空会话形式访问网络资源。有关服务帐户的详细信息，请参阅 SQL Server 2005 联机丛书中的Setting Up Windows Service Accounts。

使用域用户帐户

指定一个使用 Windows 身份验证的域用户帐户，以设置并连接到 SQL Server。Microsoft 建议对 SQL Server 服务使用具有最低权限的域用户帐户，因为 SQL Server 服务不需要管理员帐户特权。

用户名

接受或更改域用户名。

密码

设置强密码对于确保系统安全非常重要。请始终使用强密码。有关强密码的指南，请参阅身份验证模式 (SQL Server Express)。

域

接受或更改分配给帐户的域名。

注意 域名不能为完整的 DNS 名称。例如，如果 DNS 名称为 my-domain-name.com，将在域字段中使用 my-domain-name。

SQL Server 安装结束时启动服务

当操作系统启动时自动启动服务。默认情况下，将选中 SQL Server 选项。

重要事项：
为了提高 SQL Server 2005 Express Edition 的安全性，一些服务和功能默认情况下不启用。必须在安装程序完成后配置和启用这些服务和功能。有关详细信息，请参阅 SQL Server 外围应用配置器和 安装 SQL Server 的安全注意事项。


身份验证模式 (SQL Server Express)

身份验证模式 (SQL Server Express) |
 | 请参阅
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

使用 Microsoft SQL Server 安装向导的“身份验证模式”页，可以选择用于验证该 SQL Server Express 实例连接的身份验证形式。如果选择“混合模式”，则必须输入并确认 SQL Server 系统管理员 (sa) 密码。在设备与 SQL Server 成功建立连接之后，用于 Windows 身份验证和混合模式的安全机制相同。

选项

选项 说明

Windows 身份验证模式

当用户通过 Microsoft Windows 用户帐户进行连接时，SQL Server 使用 Windows 操作系统中的信息验证帐户名和密码。这是默认的身份验证模式，比混合模式更为安全。Windows 身份验证使用 Kerberos 安全协议，根据强密码的复杂性验证提供密码策略强制实施，提供帐户锁定支持，并支持密码过期。

安全说明：
请尽可能使用 Windows 身份验证。

如果选择 Windows 身份验证，则安装程序将创建默认情况下禁用的 sa 帐户。若要使用混合模式身份验证并在安装程序完成后激活 sa 帐户，请参阅 SQL Server 2005 联机丛书中的如何更改服务器身份验证模式和 ALTER LOGIN (Transact-SQL) 主题。

重要提示 不要使用空密码。请使用强密码。

混合模式（Windows 身份验证和 SQL Server 身份验证）

允许用户使用 Windows 身份验证和 SQL Server 身份验证进行连接。通过 Windows 用户帐户进行连接的用户可以使用经过 Windows 验证的受信任连接。

如果选择混合模式身份验证，则必须为所有 SQL Server 登录名设置强密码。这对于 sa 和作为 sysadmin 固定服务器角色的登录名尤为重要。

注意 提供 SQL Server 身份验证只是为了向后兼容。 请尽可能使用 Windows 身份验证。

在下面指定 sa 登录密码

当选择混合模式身份验证时，输入并确认系统管理员 (sa) 密码。设置强密码对于确保系统的安全性至关重要。切勿设置空密码或弱 sa 密码。

注意 SQL Server 密码可包含 1 到 128 个字符，其中包括任何字母、符号和数字的组合。如果选择混合模式身份验证，则必须输入强 sa 密码，然后才能继续执行安装向导的下一页

强密码指南

强密码不容易被猜到，也不容易被计算机程序破解。当设置密码时，请遵循下列指南：

  1. 强密码不能使用禁止的条件或字词，这些条件或字词包括：

    1. 空条件或 NULL 条件

    2. “Password”

    3. “Admin”

    4. “Administrator”

    5. “sa”

    6. “sysadmin”

  2. 强密码不能使用下列与安装计算机关联的字词：

    1. 当前登录到计算机的用户的名称。

    2. 计算机名称。

  3. 强密码必须至少为六个字符的长度，并且满足下列四个条件中的至少三个条件：

    1. 它必须包含大写字母。

    2. 它必须包含小写字母。

    3. 它必须包含数字。

    4. 它必须包含非字母数字字符，例如 #、% 或 ^。

在“身份验证”页上输入的密码必须满足强密码策略要求。如果存在任何使用 SQL Server 身份验证的自动化处理过程，则确保密码满足强密码策略要求。

请参阅

其他资源

SQL Server 2005 联机丛书下载中心


排序规则设置 (SQL Server Express)

排序规则设置 (SQL Server Express) |
 | 请参阅
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

使用 Microsoft SQL Server 安装向导的“排序规则设置”页，可以修改 SQL Server 用于语言和排序用途的默认排序规则设置。选择“排序规则指示符”选项可以匹配其他 SQL Server 安装的排序规则设置或者其他计算机的排序规则设置。使用“SQL 排序规则”选项可以匹配与 SQL Server 早期版本中的排序顺序兼容的设置。

选项

选项 说明

排序规则指示符和排序顺序

指定该 SQL Server Express 实例使用的排序规则。默认情况下，为英语区域设置选择 SQL 排序规则。非英语区域设置的默认排序规则是计算机的 Microsoft Windows 区域设置（“非 Unicode 程序的语言”设置，或者是“控制面板”的“区域和语言选项”中的最接近设置。

可以使用“排序规则指示符和排序顺序”下的复选框指定用于已选定的“排序规则指示符”的排序顺序。二进制是最快的排序顺序且区分大小写。如果选择了“二进制”，则“区分大小写”、“区分重音”、“区分假名”和“区分全半角”选项将不可用。有关详细信息，请参阅 SQL Server 2005 联机丛书中的Windows 排序规则排序样式。

注意 仅当 SQL Server 安装必须匹配其他 SQL Server 实例使用的排序规则设置或者必须匹配其他计算机的 Windows 区域设置时，才更改排序顺序的默认设置。

SQL 排序规则

“SQL 排序规则”选项用于与 SQL Server 早期版本保持兼容。选择该选项可以匹配与 SQL Server 8.0、7.0 或更低版本兼容的设置。有关详细信息，请参阅 SQL Server 2005 联机丛书中的使用 SQL 排序规则。

请参阅

其他资源

SQL Server 2005 Books Online Download Center


用户实例

用户实例 |
 | 请参阅
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

使用“用户实例”页可以为非管理员用户生成数据库引擎 的单独实例，而不需要 DBCreator 权限。用户实例也称为子实例或客户端实例，是由父实例（作为服务运行的主实例，例如 SQLExpress）代表用户生成的 SQL Server 的实例。用户实例作为该用户的安全上下文下的用户进程来运行。用户实例独立于父实例和该计算机上运行的任何其他用户实例。用户实例功能也被称作“以普通用户身份运行” (RANU)。

注意：
仅当在“功能选择”页上选择了安装“数据库服务”时，才会显示“用户实例”页。另外，如果在“注册信息”页上选中了“隐藏高级配置”复选框，则会隐藏“用户实例”页，不出现在安装屏幕中。在这种情况下，默认为启用用户实例功能。如果要禁用用户实例，请在“注册信息”页上清除“隐藏高级配置”复选框。

选项

启用用户实例

默认值为“启用”。若要禁用用户实例的功能，请清除此复选框。

命令行选项

ENABLERANU 开关用于配置用户实例。

若要禁用用户实例，请执行以下命令：

Set ENABLERANU = 0

若要启用用户实例（默认），请执行以下命令：

Set ENABLERANU = 1

注意 用户实例仅适用于 SQL Server 2005 Express Edition 的各版本。

请参阅

其他资源

非管理员用户实例


错误和使用情况报告设置 (SQL Server Express)

错误和使用情况报告设置 (SQL Server Express)
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

使用 Microsoft SQL Server 安装向导的“错误报告”页可以禁用 SQL Server 2005 Express Edition (SQL Server Express) 的错误报告功能。默认情况下，SQL Server Express 的错误报告功能已启用。

选项

选项 说明

错误报告

默认情况下，错误报告复选框为选中状态。您可以通过清除该复选框来禁用错误报告功能。

如果将该功能保持为启用状态，则 SQL Server 配置为在 SQL Server 数据库引擎 中出现错误的情况下将报告自动发送到 Microsoft。Microsoft 使用错误报告来改进 SQL Server 的功能，并对所有信息进行保密。

有关错误的信息通过加密通道发送到 Microsoft，并且限制对这些信息的访问。另外，您也可以将该信息发送到您自己的“公司错误报告”服务器中。请参阅此 Microsoft Web site，以了解有关如何设置“公司错误报告”服务器的详细信息。错误报告包含如下信息：

  • 出现问题时 SQL Server 的状态。

  • 操作系统版本和计算机硬件信息。

  • 您的数字产品 ID，可使用它标识您的许可证。

  • 计算机的网络 IP 地址。

  • 来自出错进程的内存或文件的信息。

Microsoft 并不是有意收集您的文件、姓名、地址、电子邮件地址或任何其他私人信息。但是，错误报告可能包含来自出错进程的内存或文件的客户特定信息。虽然可能使用该信息来确定您的身份，但 Microsoft 不会将这些信息用于此目的。有关 Microsoft 错误报告数据收集策略，请参阅此 Microsoft Web site。

如果启用了错误报告功能并出现致命错误，则 Windows 事件日志中可能会包含来自 Microsoft 的一条响应，该响应指向与特定错误有关的 Microsoft 知识库文章。

若要在安装程序完成后禁用错误报告功能，请依次单击“开始”、“所有程序”、Microsoft SQL Server 2005 和“配置工具”，再单击“SQL Server 错误和使用情况报告”。

功能使用情况

默认情况下，功能使用情况复选框为选中状态。您可以通过清除该复选框来禁用功能使用情况。如果启用功能使用情况报告功能，则 SQL Server 会配置为定期将报告发送到 Microsoft。报告将包括有关硬件配置以及如何使用 SQL Server Express 软件和服务的信息。Microsoft 将使用功能使用情况数据来改进 SQL Server。

每天收集一次所有已启用的 SQL Server 实例的信息。收集时间默认为在午夜，以便最大程度上减小服务器的负载。如果要更改收集时间，则可以手动编辑控制收集时间的注册表项。每个 SQL Server 实例都具有自己的注册表项；以下示例用于服务器中安装的第一个 SQL Server 实例 (MSSQL.1)：

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting

该注册表项的值包含的运行收集的时间以 00:00（午夜）开始的分钟数表示。例如，值 60 表示在凌晨 1:00 运行收集，值 1200 表示在晚上 8:00 运行收集等等。

若要在安装程序完成后禁用错误报告功能，请依次单击“开始”、“所有程序”、Microsoft SQL Server 2005 和“配置工具”，再单击“SQL Server 错误和使用情况报告”。


准备安装 (SQL Server Express)

准备安装 (SQL Server Express)
安装程序用户界面参考 > 安装用户界面参考 (SQL Server Express) >

当 SQL Server 安装向导具备开始复制文件来更新系统的足够信息时，便会出现“准备安装”页。

选项

选项 | 说明
安装 | 选择该选项可以安装列出的组件。
返回 | 选择该选项可以更改任何安装设置。
取消 | 选择该选项可以退出安装程序。


数据库镜像帮助主题

数据库镜像帮助主题 |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

本节介绍如何设置和使用数据库镜像。有关数据库镜像概念的信息，请参阅数据库镜像。

常规

  • 如何指定数据库镜像的服务器网络地址

Microsoft SQL Server Management Studio

  • 如何启动配置数据库镜像安全向导 (SQL Server Management Studio)

  • 如何配置数据库镜像会话 (SQL Server Management Studio)

  • 如何对数据库镜像会话进行手动故障转移 (SQL Server Management Studio)

  • 如何暂停或继续数据库镜像会话 (SQL Server Management Studio)

  • 如何停止数据库镜像会话 (SQL Server Management Studio)

  • 如何查看数据库镜像会话的状态 (SQL Server Management Studio)

Transact-SQL

  • 如何允许使用 Windows 身份验证进行数据库镜像网络访问 (Transact-SQL)

  • 如何更改数据库镜像会话中的事务安全 (Transact-SQL)

  • 如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL)

  • How to: Create an Mirroring Endpoint for Certificate-Based Authentication (Transact-SQL) --NIB

  • 如何创建镜像数据库 (Transact-SQL)

  • 如何建立使用 Windows 身份验证的数据库镜像会话 (Transact-SQL)

  • 如何建立使用 Windows 身份验证的数据库镜像见证服务器 (Transact-SQL)

  • 如何在数据库镜像会话中强制执行服务 (Transact-SQL)

  • 如何手动故障转移数据库镜像会话 (Transact-SQL)

  • 如何暂停数据库镜像会话 (Transact-SQL)

  • 如何恢复数据库镜像会话 (Transact-SQL)

  • 如何停止数据库镜像会话 (Transact-SQL)

  • 如何关闭数据库镜像见证服务器 (Transact-SQL)

请参阅

其他资源

配置可用性帮助主题


如何暂停数据库镜像会话 (Transact-SQL)

如何暂停数据库镜像会话 (Transact-SQL) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

在任何时候，数据库所有者都可以挂起数据库镜像会话，这样可以改善瓶颈期间的性能。

暂停数据库镜像会话

  1. 连接到任一伙伴。

  2. 发出以下 Transact-SQL 语句：

    ALTER DATABASE <database_name> SET PARTNER SUSPEND

    其中 <database_name> 是要挂起其会话的镜像数据库。

    此语句将把数据库置于 SUSPENDED 状态。

请参阅

任务

如何恢复数据库镜像会话 (Transact-SQL)

其他资源

ALTER DATABASE (Transact-SQL)
数据库镜像
数据库镜像帮助主题
Pausing and Resuming Database Mirroring


如何启动配置数据库镜像安全向导 (SQL Server Management Studio)

如何启动配置数据库镜像安全向导 (SQL Server Management Studio) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

配置数据库镜像安全向导可以用在以下方面：

  • 一开始就配置在镜像过程中涉及的所有服务器实例的安全设置。

  • 一开始就配置在镜像过程中涉及的某些服务器实例的安全设置。

  • 更改在镜像过程中涉及的所有或某些服务器实例的配置设置。

该向导与用于启动该向导的“数据库属性镜像”页一起使用。

启动配置数据库镜像安全向导

  1. 连接到主体服务器实例之后，在对象资源管理器中，单击该服务器名称以展开服务器树。

  2. 展开“数据库”，再选择要镜像的数据库。

  3. 右键单击该数据库，再单击“属性”，这将打开“数据库属性”对话框。

  4. 在“选择页”窗格中，单击“镜像”。

  5. 单击“配置安全性”。

请参阅

任务

如何配置数据库镜像会话 (SQL Server Management Studio)

其他资源

数据库镜像
Database Properties (Mirroring Page)


群集服务的域组

群集服务的域组 |
 | 请参阅

使用 Microsoft SQL Server 安装向导的“群集服务的域组”页，可以为要安装为 SQL Server 2005 故障转移群集一部分的群集服务指定域组。

选项

对于正在安装的 SQL Server 实例中的每个群集服务，请以 <DomainName>\<GroupName> 格式输入域名和组名，请遵循以下指南：

  • 必须输入现有的域名和组名。如果必要，请向您的域管理员询问现有域组的名称，或者为您的故障转移群集创建域组。

  • 运行 SQL Server 安装程序的帐户必须具有向域组添加帐户的权限。

  • 每个服务应使用不同的域组。

  • SQL Server 域组不应与任何其他应用程序共享。

请注意，如果卸载 SQL Server 或更改 SQL Server 帐户，这些帐户将不会从组中删除。域管理员必须确保在删除 SQL Server 后删除所有不需要的帐户。

请参阅

概念

安装故障转移群集前的准备工作


如何对数据库镜像会话进行手动故障转移 (SQL Server Management Studio)

如何对数据库镜像会话进行手动故障转移 (SQL Server Management Studio) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

同步镜像数据库时（即数据库处于 SYNCHRONIZED 状态时），数据库所有者可以启动到镜像服务器的手动故障转移。

在手动故障转移过程中，将交换发生故障转移的数据库的主体服务器和镜像服务器的角色。镜像数据库变成主体数据库，而主体数据库变成镜像数据库。例如，下表显示了手动故障转移如何交换下面两个镜像伙伴的角色：SQLDBENGINE0_1 和 SQLDBENGINE0_2。

服务器 | 故障转移之前 | 故障转移之后
SQLDBENGINE0_1 | PRINCIPAL | MIRROR
SQLDBENGINE0_2 | MIRROR | PRINCIPAL

请注意，其他数据库镜像会话的服务器角色不会受到影响。有关详细信息，请参阅Manual Failover。

对数据库镜像进行手动故障转移

  1. 连接至主体服务器实例，在“对象资源管理器”窗格中，单击服务器名称以展开服务器树。

  2. 展开“数据库”，再选择要镜像的数据库。

  3. 右键单击该数据库，再单击“属性”，这将打开“数据库属性”对话框。

  4. 在“选择页”窗格中，单击“镜像”。

  5. 单击“故障转移”。

    将显示一个确认框。如果确认要故障转移到镜像数据库，故障转移将继续进行，并交换主体服务器和镜像服务器的角色。镜像数据库变成主体数据库，而主体数据库变成镜像数据库。

    重要事项：
    如果自打开“镜像”页面以来修改了某些属性，将不保存这些更改。

    对话框将自动关闭。

    注意：
    数据库故障转移之后，发生故障转移时已使用 MS 分布式事务处理协调器准备就绪但尚未提交的事务将视为已中止。

请参阅

任务

如何暂停或继续数据库镜像会话 (SQL Server Management Studio)
如何停止数据库镜像会话 (SQL Server Management Studio)

其他资源

数据库镜像
Manual Failover


如何允许数据库镜像将证书用于入站连接 (Transact-SQL)

如何允许数据库镜像将证书用于入站连接 (Transact-SQL) |
 | 请参阅 示例

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

本主题说明配置服务器实例以使用证书对数据库镜像的出站连接进行身份验证的步骤。在可以建立入站连接之前，必须在每个服务器实例上配置出站连接。有关详细信息，请参阅How to: Allow Database Mirroring to Use Certificates for Outbound Connections (Transact-SQL)。

配置入站连接的过程通常有以下几个步骤：

  1. 为其他系统创建登录名。

  2. 为该登录创建一个用户。

  3. 获取另一个服务器实例的镜像端点的证书。

  4. 将证书与步骤 2 中创建的用户关联在一起。

  5. 授予对该镜像端点的登录名的 CONNECT 权限。

如果存在见证，则还必须为其建立入站连接。这将要求为两个伙伴上的见证设置登录名、用户和证书（反之亦然）。

下面的过程详细说明了这些步骤。对于每个步骤，过程都提供了一个在名为 HOST_A 的系统上配置服务器实例的示例。附带的示例部分说明了同样在名为 HOST_B 的系统上配置其他服务器实例的步骤。

为入站镜像连接配置服务器实例

  1. 创建另一个系统的登录名。

    下面的示例在 HOST_A 上的服务器实例的 master 数据库中为系统 HOST_B 创建登录名，在此示例中，登录名为 HOST_B_login。请用自己的密码替换示例密码。

    复制代码
    USE master;
CREATE LOGIN HOST_B_login WITH PASSWORD = '1Sample_Strong_Password!@#';
GO

    有关详细信息，请参阅 CREATE LOGIN (Transact-SQL)。

    若要查看此服务器实例上的登录名，可以使用以下 Transact-SQL 语句：

    复制代码
    SELECT * FROM sys.server_principals

    有关详细信息，请参阅 sys.server_principals (Transact-SQL)。

  2. 为该登录创建一个用户。

    下面的示例为上述步骤中创建的登录名创建了一个用户 HOST_B_user。

    复制代码
    USE master;
CREATE USER HOST_B_user FOR LOGIN HOST_B_login;
GO

    有关详细信息，请参阅 CREATE USER (Transact-SQL)。

    若要查看此服务器实例上的用户，可以使用以下 Transact-SQL 语句：

    复制代码
    SELECT * FROM sys.sysusers;

    有关详细信息，请参阅 sys.sysusers (Transact-SQL)。

  3. 获取另一个服务器实例的镜像端点的证书。

    如果配置出站连接时还没有获取远程服务器实例的镜像端点的证书副本，请执行此操作。若要执行此操作，需备份该服务器实例上的证书，详细信息请参阅How to: Allow Database Mirroring to Use Certificates for Outbound Connections (Transact-SQL)。将证书复制到其他系统时，请使用安全的复制方法。必须格外小心地保证所有证书的安全。

    有关详细信息，请参阅 BACKUP CERTIFICATE (Transact-SQL)。

  4. 将证书与步骤 2 中创建的用户关联在一起。

    下面的示例将 HOST_B 的证书与它在 HOST_A 上的用户关联。

    复制代码
    USE master;
CREATE CERTIFICATE HOST_B_cert
   AUTHORIZATION HOST_B_user
   FROM FILE = 'C:\HOST_B_cert.cer'
GO

    有关详细信息，请参阅 CREATE CERTIFICATE (Transact-SQL)。

    若要查看此服务器实例上的证书，请使用以下 Transact-SQL 语句：

    复制代码
    SELECT * FROM sys.certificates

    有关详细信息，请参阅 sys.certificates (Transact-SQL)。

  5. 授予对远程镜像端点的登录名的 CONNECT 权限。

    例如，若要将对 HOST_A 的权限授予 HOST_B 上的远程服务器实例，以连接到其本地登录名，即连接到 HOST_B_login，请使用以下 Transact-SQL 语句：

    复制代码
    USE master;
GRANT CONNECT ON ENDPOINT::Endpoint_Mirroring TO [HOST_B_login];
GO

    有关详细信息，请参阅 GRANT Endpoint Permissions (Transact-SQL)。

这将完成对 HOST_B 登录到 HOST_A 所需的证书身份验证的设置。

现在需要在 HOST_B 上为 HOST_A 执行相同的入站步骤。下面示例部分中的入站部分说明了这些步骤。

示例

下面的示例说明了配置入站连接的 HOST_B。

注意：
此示例使用了包含 HOST_A 证书的证书文件，该证书是用How to: Allow Database Mirroring to Use Certificates for Outbound Connections (Transact-SQL) 中的代码段创建的。
复制代码
USE master;
--On HOST_B, create a login for HOST_A.
CREATE LOGIN HOST_A_login WITH PASSWORD = 'AStrongPassword!@#';
GO
--Create a user, HOST_A_user, for that login.
CREATE USER HOST_A_user FOR LOGIN HOST_A_login
GO
--Obtain HOST_A certificate. (See the note
--   preceding this example.)
--Asscociate this certificate with the user, HOST_A_user.
CREATE CERTIFICATE HOST_A_cert
   AUTHORIZATION HOST_A_user
   FROM FILE = 'C:\HOST_A_cert.cer';
GO
--Grant CONNECT permission for the server instance on HOST_A.
GRANT CONNECT ON ENDPOINT::Endpoint_Mirroring TO HOST_A_login
GO

如果打算在高可用性模式下运行，必须重复相同的设置步骤为出站连接和入站连接配置见证。

注意：
有关设置数据库镜像（包括创建镜像数据库和建立高性能模式会话）的完整示例，请参阅Example: Setting Up Database Mirroring Using Certificates。

安全性

将证书复制到其他系统时，请使用安全的复制方法。必须格外小心地保证所有证书的安全。

请参阅

概念

How to: Allow Database Mirroring to Use Certificates for Outbound Connections (Transact-SQL)

其他资源

BACKUP CERTIFICATE (Transact-SQL)
CREATE CERTIFICATE (Transact-SQL)
CREATE LOGIN (Transact-SQL)
CREATE USER (Transact-SQL)
Database Mirroring Transport Security
Example: Setting Up Database Mirroring Using Certificates
GRANT Endpoint Permissions (Transact-SQL)
sys.certificates (Transact-SQL)
sys.database_mirroring_endpoints (Transact-SQL)
sys.server_principals (Transact-SQL)
sys.syslogins (Transact-SQL)
sys.sysusers (Transact-SQL)
The Database Mirroring Endpoint
Troubleshooting Database Mirroring Setup


如何暂停或继续数据库镜像会话 (SQL Server Management Studio)

如何暂停或继续数据库镜像会话 (SQL Server Management Studio) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

若要暂停或恢复数据库镜像会话，请使用“数据库属性镜像”页。

暂停或恢复数据库镜像

  1. 在数据库镜像会话期间，连接到主体服务器实例，然后在对象资源管理器中，单击服务器名称以展开服务器树。

  2. 展开“数据库”，再选择要镜像的数据库。

  3. 右键单击该数据库，再单击“属性”，这将打开“数据库属性”对话框。

  4. 在“选择页”窗格中，单击“镜像”。

    若要暂停会话，请单击“暂停”。此时，将显示一个提示，要求您确认；如果单击“是”，则会话将暂停，并且该按钮更改为“恢复”。

    有关暂停会话的影响的详细信息，请参阅Pausing and Resuming Database Mirroring。

  5. 若要恢复会话，请单击“恢复”。

请参阅

任务

如何停止数据库镜像会话 (SQL Server Management Studio)

其他资源

数据库镜像
Suspending a database mirroring session


使用复制数据库向导

使用复制数据库向导 |
 | 请参阅

通过复制数据库向导可以在不同服务器之间轻松移动或复制数据库及其对象（在服务器不停机的情况下）。使用此向导，您可以执行以下操作：

  • 选取源服务器和目标服务器。

  • 选择要移动或复制的数据库。

  • 指定数据库的文件位置。

  • 创建目标服务器上的登录名。

  • 复制其他支持对象、作业、用户定义的存储过程以及错误消息。

  • 计划移动或复制数据库的时间。

除了复制数据库之外，您还可以复制关联的元数据，例如，master 数据库中的登录名和对象，复制的数据库需要这些登录名和对象。

注意：
不能通过复制数据库向导来复制或移动 model 数据库、msdb 数据库和 master 数据库。

另外，您可以在不同的 Microsoft SQL Server 实例之间移动和复制数据库，并且可以将数据库从 Microsoft SQL Server 2000 升级至 Microsoft SQL Server 2005。有关详细信息，请参阅本主题后面的“使用复制数据库向导升级至 SQL Server 2005”。

启动复制数据库向导

在 SQL Server Management Studio 的对象资源管理器中，展开“数据库”，右键单击数据库，指向“任务”，再单击“复制数据库”。

复制数据库向导注意事项

范围 注意事项

所需的权限

为了使复制数据库向导正常运行，用户必须具有适当的权限，具体情况取决于如何复制数据库，如下所示：

  • 对于分离和附加方法，用户必须同时是源服务器和目标服务器上 sysadmin 固定服务器角色的成员。

  • 对于 SMO 传输方法，用户必须是源数据库的数据库所有者，在目标服务器上，用户必须获得 CREATE DATABASE 权限或是 dbcreator 固定服务器角色的成员。

model 数据库、msdb 数据库和 master 数据库

不能通过复制数据库向导复制或移动 model 数据库、msdb 数据库和 master 数据库。

全文目录

SQL 管理对象方法可移动全文目录。移动后，必须重新启动索引填充。如果使用的是分离和附加方法，则必须手动移动全文目录。有关移动全文目录的详细信息，请参阅移动数据库文件。

源服务器上的数据库

如果选择“移动”选项，则移动数据库后，向导会自动删除源数据库。但复制数据库向导不会删除复制的源数据库。如果您决定手动删除复制的源数据库，请先验证是否成功复制了该数据库。

执行复制和移动进程

若要使用复制数据库向导，您必须具有所需的权限（有关详细信息，请参阅前一节）。

若要使用复制数据库向导，必须指定：

  • 要复制的数据库所在的源服务器。

  • 数据库要复制或移动到的目标服务器。

  • 要移动或复制的数据库。

  • 对于分离和附加方法，为了避免数据丢失或不一致，不能向正在移动或复制的数据库附加活动会话。如果存在活动会话，复制数据库向导不会执行移动或复制操作。

    注意：
    对于 SMO 传输方法，则允许有活动连接，因为数据库从不会进入离线状态。

  • 目标数据库的名称（如果与源数据库的名称不同）。

    只有在目标服务器上不存在名称冲突的情况下，才可以将源数据库名称用于复制或移动的数据库。如果目标服务器上存在名称冲突，在目标服务器上使用源数据库名称前必须先手动解决这些冲突。

  • 要复制或移动的其他对象，例如 master 数据库中的登录名和共享对象、作业和维护计划以及用户定义的错误消息。

  • 复制或移动操作的计划（如果希望以后执行该操作）。

  • 如果您不是 sysadmin，则需要指定一个对 Integration Services (SSIS) 包执行子系统具有访问权限的 SQL 代理的代理帐户。

当在不同的服务器或磁盘驱动器之间移动数据库时，复制数据库向导将把数据库复制到目标服务器，并验证其是否在线。当在同一台服务器上的两个实例之间移动数据库时，会执行文件系统移动操作。

使用复制数据库向导升级至 SQL Server 2005

您可以使用复制数据库向导从 SQL Server 2000 数据库升级至 SQL Server 2005 数据库。

您还可以通过将多个 SQL Server 2000 实例集成到一个 SQL Server 2005 实例中或集成到一台计算机上的数个命名实例中，从而简化数据库的管理和维护工作。

使用复制数据库向导的分离和附加方法升级数据库时，请将数据库置于单用户模式，并确保没有应用程序或服务尝试访问数据库。请勿使用只读模式，因为这会导致出现错误。在此操作过程中，您可以重命名数据库。

重要事项：
从 SQL Server 的早期版本升级数据库后，对目标服务器上的数据库运行 sp_updatestats（更新统计信息），以确保复制的数据库具有最佳性能。

使用复制数据库向导升级至 SQL Server 2005

如何使用复制数据库向导升级至 SQL Server 2005

请参阅

任务

如何使用复制数据库向导升级至 SQL Server 2005

其他资源

将数据库复制到其他服务器
从 SQL Server 6.5 或更早版本复制数据库
如何使用分离和附加来升级数据库 (Transact-SQL)


如何配置数据库镜像会话 (SQL Server Management Studio)

如何配置数据库镜像会话 (SQL Server Management Studio) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

若要建立数据库镜像会话并修改数据库的数据库镜像属性，则需要使用“数据库属性”对话框中的“镜像”页。

注意：
此过程需要使用当前镜像数据库。有关详细信息，请参阅Creating a Mirror Database。

配置数据库镜像

  1. 连接到主体服务器实例之后，在对象资源管理器中，单击服务器名称以展开服务器树。

  2. 展开“数据库”，再选择要镜像的数据库。

  3. 右键单击该数据库，再单击“属性”，这将打开“数据库属性”对话框。

  4. 在“选择页”窗格中，单击“镜像”。

  5. 若要配置安全性，请单击“配置安全性”以启动配置数据库镜像安全向导。Microsoft 建议您将配置安全性作为配置数据库镜像会话的第一步。

    如果您为会话指定的任一服务器实例缺少数据库镜像端点，则配置数据库镜像安全向导将创建一个使用 Windows 身份验证（也称为“SSPI 身份验证”）的端点。若要使用基于证书的身份验证，每个服务器实例都必须都具有已手动配置为使用证书的端点；有关详细信息，请参阅 CREATE ENDPOINT (Transact-SQL)。

    重要事项：
    此外，若要将配置数据库镜像安全向导用于基于证书的身份验证，该向导的“服务帐户”对话框的所有字段都必须保留为空。

    可以使用此向导执行下列操作：

    • 开始先配置镜像中涉及的所有服务器实例的安全设置。

    • 开始先配置镜像中涉及的某些服务器实例的安全设置。

    • 更改镜像中涉及的所有或某些服务器实例的设置配置。

  6. 如果使用配置数据库镜像安全向导来建立镜像会话，将自动指定服务器实例（“主体”、“镜像”和“见证”）的服务器网络地址。如果不使用此向导，则必须手动指定这些地址。

    服务器网络地址的基本语法如下：

    TCP://fully_qualified_domain_name:port

    其中，

    • fully_qualified_domain_name 是指服务器实例所在服务器的完全限定域名。

    • port 是指分配给服务器实例的数据库镜像端点的端口。

      服务器必须具有数据库镜像端点，才可参与数据库镜像。如果使用配置数据库镜像安全向导建立某个服务器实例的第一个镜像会话，则该向导会自动创建端点。您也可以手动创建端点；有关详细信息，请参阅如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL)。

      重要事项：
      不管要支持多少镜像会话，每个服务器实例都必须有且仅有一个数据库镜像端点。

    例如，对于名为 DBSERVER9 的计算机系统上的服务器实例，如果其端点使用端口 5022，则网络地址可能为：

    复制代码
    TCP://DBSERVER9.COMPANYINFO.MYCOMPANY.COM:5022

    有关详细信息，请参阅如何指定数据库镜像的服务器网络地址。

    注意：
    在数据库镜像会话期间，不能更改主体和镜像服务器实例；但可以更改见证服务器实例。

  7. 满足下列所有条件后，单击“开始镜像”以开始镜像：

    • 您当前已连接到主体服务器实例。

    • 已（使用 WITH NORECOVERY）还原镜像服务器实例上的主体数据库的最近备份。有关详细信息，请参阅如何创建镜像数据库 (Transact-SQL)。

    • 已指定（在“服务器网络地址”部分）主体和镜像服务器实例的完全限定的 TCP 地址。

    • 如果运行模式设置为高可用性，还需指定见证服务器实例的完全限定的 TCP 地址。

    • 安全性已经正确配置。

    单击“开始镜像”将开始会话。数据库引擎将尝试自动连接到镜像伙伴，以验证镜像服务器是否正确地进行了配置，然后开始镜像会话。

    重要事项：
    如果当前不可能连接到镜像服务器，则数据库引擎会假定已经在镜像服务器上进行了镜像配置（即端点已创建、已将主体服务器设置为伙伴等等），因此仅在主体服务器上将镜像服务器设置为伙伴。如果手动输入镜像服务器信息并单击“开始镜像”，则可能出现这种情况。

  8. 根据需要，可以选择更改运行模式。某些运行模式的可用性取决于是否为见证服务器指定了 TCP 地址。选项如下所示：

    选项 是否需要见证？ 解释

    与自动故障转移同步(高可用性)

    是（必需）

    通过包含见证服务器实例以支持自动故障转移，来实现最高可用性。请注意，只有首先指定了见证服务器地址，才可以选择“与自动故障转移同步(高可用性)”模式。

    只要伙伴之间建立了相互连接，就可以进行手动故障转移。

    重要事项：
    如果见证服务器在高可用性模式会话期间断开，那么伙伴必须相互连接，数据库才可用。有关详细信息，请参阅Quorum in Database Mirroring Sessions。

    在同步运行模式中，所有提交的事务都一定会被镜像到镜像服务器的磁盘上。

    如果存在见证服务器，丢失伙伴连接会有以下影响：

    • 如果主体服务器实例变为不可用，则会发生自动故障转移。镜像服务器实例将充当主体服务器，并且将其数据库用作主体数据库。

    • 如果镜像服务器实例变为不可用，则主体服务器继续可用。

    有关详细信息，请参阅Synchronous Database Mirroring (High-Availability and High-Protection Modes)。

    异步(高性能)

    空（存在，但不使用）

    为获得最佳性能，镜像数据库始终在某种程度上滞后于主体数据库，永远无法完全同步。但是，数据库之间的异步间隔通常很小。丢失伙伴会产生以下影响：

    • 如果镜像服务器实例变得不可用，则主体服务器继续可用。

    • 如果主体服务器实例变为不可用，则镜像服务器实例会停止但仍可以作为热备用；数据库所有者可以强制让镜像服务器实例来提供服务（但这样做可能会丢失数据）。

    有关详细信息，请参阅Asynchronous Database Mirroring (High-Performance Mode)和Forced Service (with Possible Data Loss)。

    同步(高级别保护)

    否

    所有提交的事务都一定会被镜像到镜像服务器的磁盘上。

    如果伙伴之间建立了相互连接，就可以进行手动故障转移。

    丢失伙伴会产生以下影响：

    • 如果镜像服务器实例变得不可用，则主体服务器继续可用。

    • 如果主体服务器实例变为不可用，则镜像服务器实例会停止但仍可以作为热备用；数据库所有者可以强制让镜像服务器实例来提供服务（但这样做可能会丢失数据）。

    有关详细信息，请参阅Synchronous Database Mirroring (High-Availability and High-Protection Modes)。

  9. 在镜像开始后，您可以更改运行模式，并可以通过单击“确定”保存更改。请注意，仅当先指定了见证服务器地址时，才能切换到高可用性模式。

请参阅

任务

如何暂停或继续数据库镜像会话 (SQL Server Management Studio)
如何停止数据库镜像会话 (SQL Server Management Studio)

其他资源

Automatic Failover
Creating a Mirror Database
Database Properties (Mirroring Page)
Forced Service (with Possible Data Loss)
Managing Server Metadata and Jobs After Role Switching
Manual Failover
Setting Up Database Mirroring (Transact-SQL)
Setting up Login Accounts for Database Mirroring


如何更改数据库镜像会话中的事务安全 (Transact-SQL)

如何更改数据库镜像会话中的事务安全 (Transact-SQL) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

事务安全是控制会话运行模式的属性。但是，数据库所有者可以随时更改事务安全。默认情况下，事务安全级别的设置为 FULL（同步运行模式）。

关闭事务安全可将会话切换到异步运行模式，该模式可使性能达到最佳。主体不可用时镜像将停止，但它可以作为热备份使用（故障转移需要使用可能会丢失数据的强制服务）。

注意：
有关安全打开时的运行模式的详细信息，请参阅Synchronous Database Mirroring (High-Availability and High-Protection Modes)。有关安全关闭时的运行模式的详细信息，请参阅Asynchronous Database Mirroring (High-Performance Mode)。

打开事务安全

  1. 连接到主体服务器。

  2. 发出以下 Transact-SQL 语句：

    复制代码
    ALTER DATABASE <database> SET PARTNER SAFETY FULL

    其中 <database> 是镜像数据库的名称。

关闭事务安全

  1. 连接到主体服务器。

  2. 发出以下语句：

    复制代码
    ALTER DATABASE <database> SET PARTNER SAFETY OFF

    其中 <database> 是镜像数据库。

请参阅

其他资源

Asynchronous Database Mirroring (High-Performance Mode)
ALTER DATABASE (Transact-SQL)
数据库镜像帮助主题
Synchronous Database Mirroring (High-Availability and High-Protection Modes)


如何在数据库镜像会话中强制执行服务 (Transact-SQL)

如何在数据库镜像会话中强制执行服务 (Transact-SQL) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

在高性能模式和高级别保护模式下，如果主体服务器失败而镜像服务器可用，数据库所有者可以强制将服务故障转移到镜像数据库（可能丢失数据），从而使数据库可用。此选项仅在以下情况中可用：

  • 主体服务器关闭。

  • WITNESS 设置为 OFF 或连接到镜像服务器。

强制服务将会话挂起。

注意：
强制服务可能会导致一些数据丢失。另外，强制服务还启动新的恢复分叉点。因此，只有在为了立即恢复数据库服务而不惜丢失某些数据时，才可强制执行服务。有关详细信息，请参阅Forced Service (with Possible Data Loss)。

在数据库镜像会话中强制执行服务

  1. 连接到镜像服务器。

  2. 发出以下语句：

    ALTER DATABASE <database_name> SET PARTNER FORCE_SERVICE_ALLOW_DATA_LOSS

    其中，<database_name> 为镜像数据库。

    镜像服务器将立即转换为主体服务器，并且镜像挂起。
注意：
数据库故障转移之后，发生故障转移时已使用 MS 分布式事务处理协调器准备就绪但尚未提交的事务将视为已中止。

请参阅

其他资源

ALTER DATABASE (Transact-SQL)
数据库镜像
数据库镜像帮助主题


如何创建镜像数据库 (Transact-SQL)

如何创建镜像数据库 (Transact-SQL) |
 | 请参阅 示例

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

只有存在镜像数据库才能启动数据库镜像会话。可以通过已为其还原足够日志备份的主体数据库的任意备份来创建镜像数据库。

注意：
不能镜像 master、msdb、temp 或 model 系统数据库。

过程

为进行数据库镜像创建数据库

  1. 确保主体服务器实例和镜像服务器实例都已安装了 Microsoft SQL Server 2005。

  2. 验证数据库是否使用了完整恢复模式。

  3. 备份主体数据库以生成完整数据库备份。

    注意：
    数据库镜像支持全文目录。有关详细信息，请参阅Full-Text Catalogs and Database Mirroring。

  4. 确保镜像服务器实例有足够的空间来保存数据库副本。

  5. 若要创建镜像服务器，请使用 NORECOVERY 将完整数据库备份还原到镜像服务器实例。镜像数据库的名称必须与主体数据库的名称相同。

    重要事项：
    如果按文件组逐个还原数据库，请确保还原的是整个数据库。

    另外，Microsoft 建议，如有可能，镜像数据库的路径（包括驱动器号）应该与主体数据库的路径相同。相应的 Transact-SQL 语句依赖于主体服务器实例和镜像服务器实例上的文件布局是否和所建议的相同：

    • 如果文件布局相同，则使用：

      RESTORE DATABASE database_name WITH NORECOVERY

      其中，database_name 是要进行镜像的数据库。

    • 如果文件布局不同（例如，主体数据库在驱动器 F: 上，而镜像数据库没有驱动器 F:），则使用：

      RESTORE DATABASE database_name WITH NORECOVERY, MOVE

      其中，database_name 是要进行镜像的数据库。

      重要事项：
      如果创建镜像数据库时移动了数据库文件，则不挂起镜像可能导致以后无法向数据库添加文件。在不影响会话的情况下，在镜像会话过程中添加文件要求该文件路径同时存在于两个服务器上。如果镜像服务器上不存在新文件的路径，则在主体数据库上添加文件后镜像会话将被挂起。若要继续镜像，数据库所有者必须通过以下方式解决此问题：在主体服务器上备份包含添加文件操作的日志并使用 WITH MOVE 选项手动还原镜像数据库上的日志备份。

  6. 主体数据库和镜像数据库之间需要连续的日志链。如果用完整备份创建镜像数据库后已经对主体数据库执行了日志备份，则从最早的备份开始，通过将日志备份应用于镜像数据库，可以前滚镜像数据库。

    注意：
    为使日志连续，还原到镜像的最新日志记录的日志序列号 (LSN) 必须大于或等于主体上最早活动日志记录的 LSN。有关 LSN 的详细信息，请参阅Introduction to Log Sequence Numbers。

    若要将日志应用于镜像数据库，请对镜像服务器执行以下 Transact-SQL 语句：

    RESTORE LOG <database_name> FROM <backup_device> WITH NORECOVERY。

    其中，<database_name> 是数据库的名称，<backup_device> 是包含要还原的日志备份的设备的名称。

示例

必须先创建镜像数据库，才能启动数据库镜像会话。应该在启动镜像会话之前，尽早创建镜像数据库。

此示例使用了 AdventureWorks 示例数据库，默认情况下，该数据库使用简单恢复模式。

  1. 若要对 AdventureWorks 数据库进行数据库镜像，必须将其更改为使用完整恢复模式：

    复制代码
    USE master;
GO
ALTER DATABASE AdventureWorks
SET RECOVERY FULL;
GO
  2. 将数据库的恢复模式从 SIMPLE 更改为 FULL 后，需要创建完整备份，以便用于创建镜像数据库。由于恢复模式已更改，因此指定了 WITH FORMAT 选项来创建新的媒体集。这对区分完整恢复模式下的备份与以前在简单恢复模式下创建的备份非常有用。为了实现此示例的目的，在数据库所在的驱动器上创建备份文件 (C:\AdvWorks_FullRecovery.bak)。

    注意：
    对于生产数据库，应始终备份到单独的设备。

    在 PARTNERHOST1 的主体服务器实例上，创建主体数据库的完整备份，如下所示：

    复制代码
    BACKUP DATABASE AdventureWorks
    TO DISK = 'C:\AdvWorks_FullRecovery.bak'
    WITH FORMAT
GO
  3. 将完整备份复制到镜像服务器。

  4. 使用 WITH NORECOVERY 将完整备份还原到镜像服务器实例。还原命令取决于主体数据库与镜像数据库的路径是否相同。

    • 如果路径相同：

      在 PARTNERHOST5 的镜像服务器实例上，还原完整备份，如下所示：

      复制代码
      RESTORE DATABASE AdventureWorks
    FROM DISK = 'C:\AdvWorks_FullRecovery.bak'
    WITH NORECOVERY
GO
    • 如果路径不同：

      如果镜像数据库与主体数据库的路径不同（例如，它们的驱动器号不同），则创建镜像数据库时要求还原操作包括 MOVE 子句。

      重要事项：
      如果主体数据库与镜像数据库的路径名不同，则不能添加文件。原因是在接收添加文件操作所需的日志时，镜像服务器实例尝试将新文件放置在主体数据库所在的位置。

      例如，如果主体数据库驻留在 C:\Program Files\Microsoft SQL Server\MSSQL\Data\ 中，并且要在 D:\Program Files\Microsoft SQL Server\MSSQL\Data\ 中创建镜像数据库。

      复制代码
      RESTORE DATABASE AdventureWorks
   FROM DISK='C:\AdvWorks_FullRecovery.bak'
   WITH NORECOVERY,
      MOVE 'AdventureWorks' TO
'D:\Program Files\Microsoft SQL Server\MSSQL\Data\AdventureWorks_data.mdf',
      MOVE 'AdventureWorksLog1'
TO 'D:\Program Files\Microsoft SQL Server\MSSQL\Data\AdventureWorks_Log.ldf';
GO
  5. 还原到镜像数据库的最新日志序列号 (LSN) 必须等于或大于主体数据库活动日志中最早的 LSN。如果主体数据库的完整备份是新的，则可能就是这种情况。但是，如果日志备份发生在创建完整备份之后、还原完整备份以创建镜像数据库之前，则您需要使用 WITH NORECOVERY 将该日志备份还原到镜像服务器。例如，若要从名为 C:\AdvWorks_log1.bak 的文件还原日志备份，请输入：

    复制代码
    RESTORE LOG AdventureWorks
    FROM DISK = 'C:\AdvWorks_log1.bak'
    WITH NORECOVERY
GO
注意：
有关设置数据库镜像、显示安全设置、准备镜像数据库、设置伙伴以及添加见证服务器的完整示例，请参阅Overview of Setting Up Database Mirroring。

请参阅

任务

如何配置数据库镜像会话 (SQL Server Management Studio)
如何建立使用 Windows 身份验证的数据库镜像会话 (Transact-SQL)

其他资源

备份和还原数据库
BACKUP (Transact-SQL)
数据库镜像
Database Mirroring Security
File Backup and Restore and Database Mirroring
RESTORE (Transact-SQL)


如何允许使用 Windows 身份验证进行数据库镜像网络访问 (Transact-SQL)

如何允许使用 Windows 身份验证进行数据库镜像网络访问 (Transact-SQL) |
 | 请参阅 示例

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

对于要使用 Windows 身份验证的数据库镜像，如果在镜像数据库中涉及的服务器实例都使用同一域用户帐户，则自动存在正确的登录，无需另行创建。但是，如果服务器实例使用不同的用户帐户（不论是在同一个 Microsoft Windows 域中，还是受信任的 Windows 域中），则对于每个实例，必须为所有其他实例的启动服务帐户创建一个登录。

有关详细信息，请参阅Database Mirroring Security。

注意：
确保每个服务器实例都有一个端点。有关详细信息，请参阅如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL)。

允许使用 Windows 身份验证进行数据库镜像网络访问

  1. 如果服务器实例使用不同的域用户帐户作为启动服务帐户，则使用 CREATE LOGIN 语句的 FROM WINDOWS 子句为远程服务器实例的用户帐户创建一个登录。

  2. 另外，为了确保登录用户对端点具有访问权限，应为登录授予对端点的连接权限。请注意，如果用户是管理员，则无需授予对端点的连接权限。

示例

下面的示例为属于 Adomain 域的 Otheruser 用户帐户创建了一个 SQL Server 登录名。并授予了此用户对预先存在的 Mirroring_Endpoint 数据库镜像端点的连接权限。
复制代码
USE master;
GO
CREATE LOGIN [Adomain\Otheruser] FROM WINDOWS;
GO
GRANT CONNECT on ENDPOINT::Mirroring_Endpoint TO [Adomain\Otheruser];
GO
注意：
有关安全性设置、准备镜像数据库、设置伙伴以及添加见证服务器的完整示例，请参阅Setting Up Database Mirroring.

请参阅

任务

如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL)
如何建立使用 Windows 身份验证的数据库镜像会话 (Transact-SQL)
如何创建镜像数据库 (Transact-SQL)

其他资源

CREATE LOGIN (Transact-SQL)
数据库镜像
Database Mirroring Security
GRANT (Transact-SQL)


如何建立使用 Windows 身份验证的数据库镜像会话 (Transact-SQL)

如何建立使用 Windows 身份验证的数据库镜像会话 (Transact-SQL) |
 | 请参阅 示例

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

准备好镜像数据库后（请参阅如何创建镜像数据库 (Transact-SQL)），便可以建立数据库镜像会话。请注意，主体服务器实例、镜像服务器实例和见证服务器实例都必须是单独的服务器实例，且应位于单独的主机系统中。

我们建议您在非高峰时段配置数据库镜像，因为配置会影响性能。

注意：
给定的服务器可以参与和相同伙伴或不同伙伴之间的多个并发数据库镜像会话。给定的服务器在某些会话中可能是伙伴，而在其他会话中则是见证服务器。

建立数据库镜像会话

  1. 准备要在另一台服务器上镜像的数据库副本。会话开始时，该副本将成为镜像数据库。

    重要事项：
    通常需要创建原始数据库的当前日志备份并将其还原到将来的镜像数据库，才能初始化对伙伴的镜像。有关创建和还原日志备份的信息，请参阅Using Transaction Log Backups。

    注意：
    有关对复制数据库使用数据库镜像的信息，请参阅复制和数据库镜像。

  2. 在每台主体服务器和镜像服务器上，请确保存在用于数据库镜像的端点。无论支持的镜像会话数是多少，服务器实例都只能有一个数据库镜像端点。如果只将该服务器实例用于数据库镜像会话中的主体服务器和镜像服务器，您可以为端点分配主体服务器或镜像服务器角色 (ROLE=PARTNER)。如果还要将该服务器用于其他数据库镜像会话中的见证服务器，请将端点的角色分配为 ALL。

    若要执行 SET PARTNER 语句，主体服务器和镜像服务器端点的 STATE 都必须设为 STARTED。

    若要了解服务器实例是否具有数据库镜像端点并了解其角色和状态，请对该实例使用以下 Transact-SQL 语句：

    复制代码
    SELECT role_desc, state_desc FROM sys.database_mirroring_endpoints
    重要事项：
    如果存在数据库镜像端点，并且已被任意镜像会话使用，请将该端点用于在服务器实例上建立的任何其他会话。如果已为会话设置了见证服务器，则删除数据库镜像端点会造成该会话的主体服务器失去仲裁；如果发生这种情况，数据库会进入离线状态，其用户也会断开连接。有关详细信息，请参阅Quorum in Database Mirroring Sessions。

    如果主体服务器或镜像服务器缺少端点，请参阅如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL)。

  3. 如果服务器实例正以其他域用户帐户运行，则每个实例的 master 数据库将为另一个域中运行的任意服务器实例创建登录名。有关详细信息，请参阅如何允许使用 Windows 身份验证进行数据库镜像网络访问 (Transact-SQL)。

  4. 若要将主体服务器设置为镜像数据库上的伙伴，请连接到镜像服务器，然后执行下面的语句：

    ALTER DATABASE <database_name> SET PARTNER =<server_network_address>

    其中，<database_name> 是要镜像的数据库的名称（此名称在两个伙伴上相同），<server_network_address> 是主体服务器的服务器网络地址。有关服务器网络地址结构的信息，请参阅如何指定数据库镜像的服务器网络地址。

    例如，在镜像服务器实例上，使用以下语句将 AdventureWorks 数据库的伙伴设置为位于上面服务器网络地址处的初始主体服务器实例：

    复制代码
    ALTER DATABASE AdventureWorks
SET PARTNER = 'TCP://DBSERVER1.COMPANYINFO.MYCOMPANY.COM:5022'

    与主体服务器连接时，此语句将准备镜像服务器来形成会话。

  5. 若要将镜像服务器设置为主体数据库上的伙伴，请连接到主体服务器，然后执行下面的语句：

    ALTER DATABASE <database_name> SET PARTNER =<server_network_address>

    其中，<database_name> 是要镜像的数据库的名称（此名称在两个伙伴上相同），<server_network_address> 是主体服务器的服务器网络地址。

    例如，在主体服务器实例上，使用下面的语句在位于 COMPANYINFO.MYCOMPANY.COM 域并侦听 5022 端口的名为 DBSERVER2 的计算机上，将 AdventureWorks 数据库的伙伴设置为初始镜像服务器实例，将镜像服务器设置为伙伴的语句如下：

    复制代码
    ALTER DATABASE AdventureWorks SET PARTNER = 'TCP://DBSERVER2.COMPANYINFO.MYCOMPANY.COM:5022'

    在主体服务器上输入此语句将启动数据库镜像会话。

  6. 默认情况下，会话设置为完整事务安全（SAFETY 设置为 FULL），此设置会在同步、高级别保护模式下启动会话。您可以将会话重新配置为在高可用性模式（通过添加见证服务器）或高性能模式（通过将事务安全设置为 OFF）下运行。

    • 高可用性模式

      添加一个见证服务器将使同步会话在高可用性模式下运行，在该模式下，如果主体服务器变得不可用，则会自动故障转移到镜像服务器。有关详细信息，请参阅如何建立使用 Windows 身份验证的数据库镜像见证服务器 (Transact-SQL)。

    • 高性能模式

      另外，如果您不想进行自动故障转移，或者您对性能的追求超过了高可用性，请关闭事务安全。这会使会话在异步、高性能模式下运行。有关详细信息，请参阅如何更改数据库镜像会话中的事务安全 (Transact-SQL)。

      注意：
      在高性能模式下，WITNESS 应设置为 OFF。有关详细信息，请参阅Asynchronous Database Mirroring (High-Performance Mode)。

示例

下面的示例在伙伴之间建立了数据库镜像会话。该示例显示了创建没有见证服务器的数据库镜像会话的基本步骤。两个伙伴分别是二台计算机系统（PARTNERHOST1 和 PARTNERHOST5）上的默认服务器实例。这两个伙伴实例以相同的 Microsoft Windows 域用户帐户 (MYDOMAIN\dbousername) 运行。

注意：
有关显示安全设置、准备镜像数据库、设置伙伴和添加见证服务器的完整示例，请参阅Overview of Setting Up Database Mirroring。

  1. 在主体服务器实例（PARTNERHOST1 上的默认实例）上，使用 5022 端口创建一个支持所有角色的端点。

    复制代码
    --create an endpoint for this instance
CREATE ENDPOINT Endpoint_Mirroring
    STATE=STARTED
    AS TCP (LISTENER_PORT=5022)
    FOR DATABASE_MIRRORING (ROLE=ALL)
GO
--Partners under same domain user; login already exists in master.
    注意：
    有关如何设置登录名的示例，请参阅如何允许使用 Windows 身份验证进行数据库镜像网络访问 (Transact-SQL)。

  2. 在镜像服务器实例（PARTNERHOST5 上的默认实例）上，使用 5022 端口创建一个支持所有角色的端点。

    复制代码
    --create an endpoint for this instance
CREATE ENDPOINT Endpoint_Mirroring
    STATE=STARTED
    AS TCP (LISTENER_PORT=5022)
    FOR DATABASE_MIRRORING (ROLE=ALL)
GO
--Partners under same domain user; login already exists in master.
  3. 在 PARTNERHOST1 的主体服务器实例上，备份数据库：

    复制代码
    BACKUP DATABASE AdventureWorks
    TO DISK = 'C:\AdvWorks_dbmirror.bak'
    WITH FORMAT
GO
  4. 在 PARTNERHOST5 的镜像服务器实例上，还原数据库：

    复制代码
    RESTORE DATABASE AdventureWorks
    FROM DISK = 'Z:\AdvWorks_dbmirror.bak'
    WITH NORECOVERY
GO
  5. 在镜像服务器实例上，将 PARTNERHOST1 上的服务器实例设置为伙伴（使其成为初始主体服务器）：

    复制代码
    ALTER DATABASE AdventureWorks
    SET PARTNER =
    'TCP://PARTNERHOST1.MYDOMAIN.CORP.MYCOMPANY.COM:5022'
GO
    重要事项：
    默认情况下，数据库镜像会话在同步模式下运行，这是由于将会话设置为完整事务安全（SAFETY 设置为 FULL）。若要使会话在异步、高性能模式下运行，请将 SAFETY 设置为 OFF。有关详细信息，请参阅Database Mirroring Sessions和如何更改数据库镜像会话中的事务安全 (Transact-SQL)。

  6. 在主体服务器实例上，将 PARTNERHOST5 上的服务器实例设置为伙伴（使其成为初始镜像服务器）：

    复制代码
    ALTER DATABASE AdventureWorks
    SET PARTNER = 'TCP://PARTNERHOST5.MYDOMAIN.CORP.MYCOMPANY.COM:5022'
GO
  7. 或者，如果想在会话中使用见证服务器，请设置见证服务器实例。有关详细信息，请参阅如何建立使用 Windows 身份验证的数据库镜像见证服务器 (Transact-SQL)。

注意：
有关显示安全设置、准备镜像数据库、设置伙伴和添加见证服务器的完整示例，请参阅Setting Up Database Mirroring。

请参阅

任务

如何允许使用 Windows 身份验证进行数据库镜像网络访问 (Transact-SQL)
如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL)
如何创建镜像数据库 (Transact-SQL)
如何指定数据库镜像的服务器网络地址

其他资源

ALTER DATABASE (Transact-SQL)
Asynchronous Database Mirroring (High-Performance Mode)
复制和数据库镜像
Synchronous Database Mirroring (High-Availability and High-Protection Modes)
The Role of the Witness
Transact-SQL Settings and Database Mirroring Operating Modes


 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

本主题说明配置服务器实例以使用证书对数据库镜像的出站连接进行身份验证的步骤。必须配置出站连接，才可以设置入站连接。

注意：
服务器实例上的所有镜像连接都使用单个数据库镜像端点，必须在创建端点时指定服务器实例的身份验证方法。

配置出站连接的进程分为以下基本步骤：

  1. 在 master 数据库中，创建数据库主密钥。

  2. 在 master 数据库中，为服务器实例创建加密证书。

  3. 使用服务器实例的证书为该服务器实例创建端点。

  4. 将证书备份到文件，并将其安全地复制到其他系统。

必须对每一个伙伴和见证服务器（如果存在）完成以上步骤。

下面的过程详细说明了这些步骤。对于每个步骤，该过程都提供了一个在名为 HOST_A 的系统上配置服务器实例的示例。下面的示例说明了在名为 HOST_B 的系统上配置另一服务器实例的步骤（步骤相同）。

过程

配置用于出站镜像连接的服务器实例

在 HOST_A 上，执行下列操作：

  1. 在 master 数据库上，创建数据库主密钥（如果不存在）。若要查看数据库的现有密钥，请使用 sys.symmetric_keys 目录视图。

    若要创建数据库主密钥，请使用下面的 Transact-SQL 命令：

    复制代码
    CREATE MASTER KEY ENCRYPTION BY PASSWORD = '<1_Strong_Password!>';
GO

    使用唯一的强密码，并将其记录到一个安全的位置。

    有关详细信息，请参阅 CREATE MASTER KEY (Transact-SQL)。

  2. 在 master 数据库中，对服务器实例创建一个用于其数据库镜像出站连接的加密证书。

    例如，为 HOST_A 系统创建一个证书。

    复制代码
    USE master;
CREATE CERTIFICATE HOST_A_cert
   WITH SUBJECT = 'HOST_A certificate for database mirroring';
GO

    有关详细信息，请参阅 CREATE CERTIFICATE (Transact-SQL)。

    若要查看 master 数据库中的证书，可以使用下面的 Transact-SQL 语句：

    复制代码
    USE master;
SELECT * FROM sys.certificates;

    有关详细信息，请参阅 sys.certificates (Transact-SQL)。

  3. 确保每个服务器实例上都存在数据库镜像端点。

    如果服务器实例上已存在数据库镜像端点，则您应将该端点重新用于在服务器实例上建立的任何其他会话。若要确定服务器实例上是否存在数据库镜像端点并查看其配置，请使用下面的语句：

    复制代码
    SELECT name, role_desc, state_desc, connection_auth_desc, encryption_algorithm_desc FROM sys.database_mirroring_endpoints;

    如果端点不存在，请创建一个端点，该端点使用此证书进行出站连接，并使用此证书的凭据通过其他系统的验证。这是一个服务器范围内的端点，供服务器实例参与的所有镜像会话使用。

    例如，为 HOST_A 上的示例服务器实例创建镜像端点。

    复制代码
    CREATE ENDPOINT Endpoint_Mirroring
   STATE = STARTED
   AS TCP (
      LISTENER_PORT=5024
      , LISTENER_IP = ALL
   )
   FOR DATABASE_MIRRORING (
      AUTHENTICATION = CERTIFICATE HOST_A_cert
      , ENCRYPTION = REQUIRED ALGORITHM RC4
      , ROLE = ALL
   );
GO

    有关详细信息，请参阅 CREATE ENDPOINT (Transact-SQL)。

  4. 备份证书并将其复制到其他系统。若要在其他系统上配置入站连接，此步骤是必需的。

    复制代码
    BACKUP CERTIFICATE HOST_A_cert TO FILE = 'C:\HOST_A_cert.cer';
GO

    有关详细信息，请参阅 BACKUP CERTIFICATE (Transact-SQL)。

    使用您选择的任何安全方法复制此证书。必须格外小心地保证所有证书的安全。

前面步骤中的示例代码将在 HOST_A 上配置出站连接。

您现在需要对 HOST_B 执行相同的出站步骤，下面的示例说明了这些步骤。

示例

说明

下面的示例说明了如何配置 HOST_B 以进行出站连接。

代码

复制代码
USE master;
--Create the database Master Key, if needed.
CREATE MASTER KEY ENCRYPTION BY PASSWORD = '<Strong_Password_#2>';
GO
-- Make a certifcate on HOST_B server instance.
CREATE CERTIFICATE HOST_B_cert
   WITH SUBJECT = 'HOST_B certificate for database mirroring';
GO
--Create a mirroring endpoint for the server instance on HOST_B.
CREATE ENDPOINT Endpoint_Mirroring
   STATE = STARTED
   AS TCP (
      LISTENER_PORT=5024
      , LISTENER_IP = ALL
   )
   FOR DATABASE_MIRRORING (
      AUTHENTICATION = CERTIFICATE HOST_B_cert
      , ENCRYPTION = REQUIRED ALGORITHM RC4
      , ROLE = ALL
   );
GO
--Backup HOST_B certificate.
BACKUP CERTIFICATE HOST_B_cert TO FILE = 'C:\HOST_B_cert.cer';
GO
--Using any secure copy method, copy C:\HOST_B_cert.cer to HOST_A.

使用您选择的任何安全方法将证书复制到其他系统。必须格外小心地保证所有证书的安全。

重要事项：
设置出站连接后，您必须在每个服务器实例上为其他服务器实例配置入站连接。有关详细信息，请参阅 如何允许数据库镜像将证书用于入站连接 (Transact-SQL)。

安全性

建议您对数据库镜像连接进行加密，除非您能够保证网络的安全。

在将证书复制到其他系统时，请使用安全复制方法。

请参阅

任务

如何允许数据库镜像将证书用于入站连接 (Transact-SQL)
如何指定数据库镜像的服务器网络地址

其他资源

ALTER ENDPOINT (Transact-SQL)
BACKUP CERTIFICATE (Transact-SQL)
CREATE CERTIFICATE (Transact-SQL)
CREATE ENDPOINT (Transact-SQL)
CREATE MASTER KEY (Transact-SQL)
Example: Setting Up Database Mirroring Using Certificates
sys.certificates (Transact-SQL)
sys.symmetric_keys (Transact-SQL)
The Database Mirroring Endpoint
Troubleshooting Database Mirroring Setup


如何查看数据库镜像会话的状态 (SQL Server Management Studio)

如何查看数据库镜像会话的状态 (SQL Server Management Studio) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

在数据库镜像会话期间，可以在“数据库属性”对话框的“镜像”页查看数据库镜像会话的状态。

查看数据库镜像会话的状态

  1. 连接到主体服务器实例之后，在对象资源管理器中，单击该服务器名称以展开服务器树。

  2. 展开“数据库”，再选择要镜像的数据库。

  3. 右键单击该数据库，再单击“属性”，这将打开“数据库属性”对话框。

  4. 在“选择页”窗格中，单击“镜像”。

  5. 镜像开始后，“状态”窗格将显示您选择“镜像”页或单击“刷新”按钮时的数据库镜像会话的状态。可能的状态如下：

    状态 解释

    <空>

    不存在数据库镜像会话，并且没有要在“镜像”页上报告的活动。

    已暂停

    主体数据库正在运行，但没有向镜像服务器发送任何日志。数据库的镜像副本不可用。

    无连接

    主体服务器实例无法连接到其伙伴实例或见证服务器实例（如果存在）

    正在同步

    镜像数据库的内容滞后于主体数据库的内容。主体服务器实例正在向镜像服务器实例发送日志记录，这会对镜像数据库应用更改，使其前滚。

    在数据库镜像会话开始时，镜像数据库和主体数据库处于同步状态。

    故障转移

    在主体服务器实例上，手动故障转移（角色切换）已经开始，但镜像服务器实例尚未接受。

    已同步

    镜像数据库包含的数据与主体数据库相同。只有在同步状态下，才能进行手动和自动故障转移。

请参阅

其他资源

Database States for Database Mirroring


如何手动故障转移数据库镜像会话 (Transact-SQL)

如何手动故障转移数据库镜像会话 (Transact-SQL) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

同步镜像数据库时（即数据库处于 SYNCHRONIZED 状态时），数据库所有者可以启动到镜像服务器的手动故障转移。手动故障转移只能从主体服务器启动。

手动故障转移数据库镜像会话

  1. 连接到主体服务器。

  2. 在主体服务器上执行下列语句：

    ALTER DATABASE <database_name> SET PARTNER FAILOVER

    其中，<database_name> 为镜像数据库。

    此语句将立即启动从镜像服务器到主体角色的转换。

在前一主体上，客户端断开了与数据库的连接，并且未提交的事务将回滚。

注意：
如果已经使用 Microsoft 分布式事务处理协调器准备好的事务在发生故障转移时仍未提交，则在数据库故障转移后，这些事务将被视为已中止。

请参阅

其他资源

ALTER DATABASE (Transact-SQL)
数据库镜像帮助主题
Forced Service (with Possible Data Loss)
Manual Failover
Role Switching During a Database Mirroring Session


在安装程序完成联机丛书的安装之前，您无法搜索所需的主题

在安装程序完成联机丛书的安装之前，您无法搜索所需的主题

安装程序完成之后，您可以通过以下方法查看 Microsoft SQL Server 的文档：单击“帮助”；在对话框或界面元素中按 F1 键；或者从“开始”菜单中依次指向“所有程序”、Microsoft SQL Server 2005 和“文档和教程”，然后单击“SQL Server 联机丛书”。


如何停止数据库镜像会话 (Transact-SQL)

如何停止数据库镜像会话 (Transact-SQL) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

数据库所有者可以随时手动结束数据库镜像会话。

重要事项：
停止会话将关闭与主体数据库的所有连接、删除有关镜像会话的所有信息并重新启动数据库。

停止数据库镜像会话

  1. 连接到任一伙伴。

  2. 发出以下 Transact-SQL 语句：

    复制代码
    ALTER DATABASE <database_name> SET PARTNER OFF

    其中 <database_name> 是要停止会话的镜像数据库。

    此语句将导致重新启动主体数据库、断开当前使用该数据库的所有会话的连接，并删除有关镜像会话的所有信息。这样，主体数据库和镜像数据库变为相互独立。如果恢复以前的镜像副本，它可能脱离以前的主体副本。有关停止数据库镜像会话的影响的详细信息，请参阅Stopping Database Mirroring。

请参阅

其他资源

ALTER DATABASE (Transact-SQL)
数据库镜像
数据库镜像帮助主题
Stopping Database Mirroring


如何指定数据库镜像的服务器网络地址

如何指定数据库镜像的服务器网络地址 |
 | 请参阅 示例

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

本主题说明如何指定服务器网络地址，参与数据库镜像会话的每台服务器都需要指定此信息。

指定服务器网络地址

  1. 服务器网络地址需要一个完全限定域名和服务器侦听的端口，语法格式如下：

    TCP://fully_qualified_domain_name:port

    其中，

    fully_qualified_domain_name 是一个本地定义的地址字符串。完全限定域名通常是一个复合名称，在不同地方使用不同格式。完全限定域名通常（但不总是）包含一个计算机名称和一系列以句点分隔的域段（例如 MYSYSTEM.MyOrg.MyDomain.org）：

    • computer_name . domain_segment[....n]]

      其中，

      computer_name

      指运行服务器实例的计算机的网络名称。

      domain_segment[....n]]

      指服务器的其余域信息。

      例如：localinfo.corp.mycompany.com

      域段的内容和数量由公司或组织内部决定。如果您不知道服务器的完全限定域名，请与系统管理员联系。
      重要事项：
      如果您使用的只是部分限定域名，将收到错误 1460。如果您收到此错误，请在服务器网络地址中指定完全限定域名，然后重复该操作。

    • port 是与伙伴服务器实例的镜像端点关联的端口号。（有关指定端点的信息，请参阅如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL)。）

      计算机系统上的每个端口号只能与一个端点相关联，而每个端点与一个服务器实例相关联；这样，同一服务器上的不同服务器实例便可使用不同端口来侦听各个端点。因此，设置数据库镜像会话时在服务器网络地址中指定的端口会始终将会话定向到其端点与该端口关联的服务器实例。

      在服务器实例的服务器网络地址中，只有通过与其镜像端点关联的端口号才能将实例与计算机上的所有其他实例区分开来。下图显示了一台计算机上两个服务器实例的服务器网络地址。默认实例使用端口 5022，命名实例使用端口 5033。这两个服务器实例的服务器网络地址分别为 TCP://MYSYSTEM.MyOrg.MyDomain.org:5022 和 CP://MYSYSTEM.MyOrg.MyDomain.org:5033。请注意，地址中不包含服务器实例名。

      若要标识当前与服务器实例的数据库镜像端点关联的端口，请使用以下 Transact-SQL 语句：

      复制代码
      SELECT type_desc, port FROM sys.tcp_endpoints
      找到 type_desc 值为“DATABASE_MIRRORING”的行，然后使用对应的端口号。

示例

此示例显示了名为 DBSERVER1 的计算机系统上的服务器实例（域信息为 NORTHWEST.MYCOMPANY.COM，且侦听端口 5022）的服务器网络地址。给定示例中的这些组件后，该服务器网络地址为：

TCP://DBSERVER1.NORTHWEST.MYCOMPANY.COM:5022

请参阅

任务

如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL)

其他资源

数据库镜像


如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL)

如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL) |
 | 请参阅 示例

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

每个数据库镜像服务器实例都需要一个唯一的侦听器端口用于镜像连接。若要标识服务器实例要使用的端口，需要一个唯一的数据库镜像端点用于该实例。一个服务器实例只能有一个用于镜像的端点，并且该服务器实例支持的所有镜像会话都必须使用这同一端点。创建端点时，系统管理员指定服务器实例的身份验证和加密方法。

重要事项：
如果数据库镜像端点存在并且已被使用，我们建议您对服务器实例上的所有会话都使用该端点。如果已经为某个会话设置了见证，那么删除数据库镜像端点将导致该会话的主体服务器失去仲裁；如果发生这种情况，数据库将脱机，而其用户将断开连接。有关详细信息，请参阅Quorum in Database Mirroring Sessions。

创建使用 Windows 身份验证的镜像端点

  1. 连接至要为其创建数据库镜像端点的服务器实例。

  2. 使用以下语句确定数据库镜像端点是否已经存在：

    复制代码
    SELECT name, role_desc, state_desc FROM sys.database_mirroring_endpoints
    重要事项：
    如果服务器实例已有数据库镜像端点，则可以将该端点用于在服务器实例上建立的任何其他会话。

  3. 若要使用 Transact-SQL 创建使用 Windows 身份验证的端点，请使用 CREATE ENDPOINT 语句。该语句采用以下常规形式：

    CREATE ENDPOINT <端点名称>

    STATE=STARTED

    AS TCP ( LISTENER_PORT = <侦听器端口列表> )

    FOR DATABASE_MIRRORING

    (

    [ AUTHENTICATION = WINDOWS [ <授权方法> ]

    ]

    [ [,] ENCRYPTION = REQUIRED

    [ ALGORITHM { <算法> } ]

    ]

    [,] ROLE = <角色>

    )

    其中

    • <端点名称> 是服务器实例的数据库镜像端点的唯一名称。

    • STARTED 指定端点启动并开始侦听连接。数据库镜像端点创建后通常处于 STARTED 状态。另外，可以启动处于 STOPPED 状态（默认值）或 DISABLED 状态中的会话。

    • <侦听器端口列表> 是包含一个或多个端口号 (nnnn [,nnnn]) 的列表，服务器要在这些端口号上侦听数据库镜像消息。只允许使用 TCP，指定任何其他协议都会导致发生错误。

      每个计算机系统一次只能使用一个端口号。若要识别出系统上 TCP 端点当前使用的端口，请使用以下 Transact-SQL 语句：

      复制代码
      SELECT name, port FROM sys.tcp_endpoints
      重要事项：
      每个服务器实例需要且只需要一个唯一的侦听器端口。

    • 对于 Windows 身份验证，AUTHENTICATION 选项是可选的，除非您只想让端点使用 NTLM 或 Kerberos 对连接进行身份验证。<授权方法> 指定用于对连接进行身份验证的以下方法之一：NTLM、KERBEROS 或 NEGOTIATE。默认方法 NEGOTIATE 会导致端点使用 Windows 协商协议来选择 NTLM 或 Kerberos。根据另一侧端点的身份验证级别的不同，协商协议启用具有或没有身份验证的连接。有关这些方法的信息，请参阅Endpoint Authentication Types。

    • 默认情况下，ENCRYPTION 设置为 REQUIRED。这意味着此端点的所有连接都必须加密。但您可以禁用加密，或对于端点可以选择禁用加密。可以选择的选项如下：

      值 定义

      DISABLED

      指定不对通过连接发送的数据加密。

      SUPPORTED

      指定只有在对方端点指定了 SUPPORTED 或者 REQUIRED 时，才加密数据。

      REQUIRED

      指定必须对通过连接发送的数据加密。

      如果端点要求加密，则对于其他端点，必须将 ENCRYPTION 设置为 SUPPORTED 或 REQUIRED。

    • <算法> 用来为端点指定加密标准。<算法> 的值可以是以下某个算法或这些算法的组合：RC4、AES、AES RC4 或 RC4 AES。

      AES RC4 指定此端点协商加密算法，但优先使用 AES 算法。RC4 AES 指定此端点协商加密算法，但优先使用 RC4 算法。如果两个端点都指定了这两种算法，但顺序不同，则接受连接的端点入选。

    • <角色> 定义服务器可以执行的角色。必须指定 ROLE。

      若要让服务器实例对于一个数据库镜像会话执行一个角色，对于另一个会话执行另一个角色，请指定 ROLE = ALL。若要让服务器实例限于执行伙伴角色或见证角色，请分别指定 ROLE = PARTNER 或 ROLE = WITNESS。

      注意：
      对于 SQL Server Express Edition，只能选择 WITNESS。

    有关 CREATE ENDPOINT 语法的完整说明，请参阅 CREATE ENDPOINT (Transact-SQL)。

    注意：
    若要更改现有的端点，请使用 ALTER ENDPOINT (Transact-SQL)。

示例

下面的示例为三个不同的计算机系统上的默认服务器实例创建端点：

服务器实例的角色 | 主机的名称
伙伴（最初在主体角色中） | SQLHOST01\.
伙伴（最初在镜像角色中） | SQLHOST02\.
见证 | SQLHOST03\.

在本示例中，尽管任何可用的端口号都可以，但所有三个端点都使用端口号 5022。AUTHENTICATION 选项是不必要的，因为端点使用默认类型，即 Windows 身份验证。ENCRYPTION 选项也是不必要的，因为端点都打算通过协商来决定连接的身份验证方法，这是 Windows 身份验证的默认行为。而且，所有端点都需要加密，这是默认行为。

每个服务器实例都只能作为伙伴或见证，而每个服务器端点都明确指定了角色（ROLE=PARTNER 或 ROLE=WITNESS）。

重要事项：
每个服务器实例只能有一个端点。因此，如果您希望某个服务器实例在一些会话中作为伙伴，在另一些会话中作为见证，请指定 ROLE=ALL。

复制代码
--Endpoint for initial principal server instance, which
--is the only server instance running on SQLHOST01.
CREATE ENDPOINT endpoint_mirroring
    STATE = STARTED
    AS TCP ( LISTENER_PORT = 5022 )
    FOR DATABASE_MIRRORING (ROLE=PARTNER);
GO
--Endpoint for initial mirror server instance, which
--is the only server instance running on SQLHOST02.
CREATE ENDPOINT endpoint_mirroring
    STATE = STARTED
    AS TCP ( LISTENER_PORT = 5022 )
    FOR DATABASE_MIRRORING (ROLE=PARTNER);
GO
--Endpoint for witness server instance, which
--is the only server instance running on SQLHOST03.
CREATE ENDPOINT endpoint_mirroring
    STATE = STARTED
    AS TCP ( LISTENER_PORT = 5022 )
    FOR DATABASE_MIRRORING (ROLE=WITNESS);
GO

For a complete example showing security setup, preparing the mirror database, setting up the partners, and adding a witness, see Setting Up Database Mirroring (Transact-SQL).

请参阅

任务

如何允许使用 Windows 身份验证进行数据库镜像网络访问 (Transact-SQL)
如何指定数据库镜像的服务器网络地址

其他资源

CREATE ENDPOINT (Transact-SQL)
Example of Setting Up Database Mirroring Using Windows Authentication
The Database Mirroring Endpoint


如何停止数据库镜像会话 (SQL Server Management Studio)

如何停止数据库镜像会话 (SQL Server Management Studio) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

若要停止数据库镜像会话，请使用“数据库属性镜像”页。

重要事项：
停止会话将关闭与主体数据库的所有连接并重新启动数据库。

配置数据库镜像

  1. 在数据库镜像会话期间，连接到主体服务器实例，然后在对象资源管理器中，单击服务器名称以展开服务器树。

  2. 展开“数据库”，再选择要镜像的数据库。

  3. 右键单击该数据库，再单击“属性”，这将打开“数据库属性”对话框。

  4. 在“选择页”窗格中，单击“镜像”。

  5. 若要停止会话（仅从主体服务器实例），请在主体服务器实例上单击“停止镜像”。此时，将显示一个提示，要求您确认；如果单击“是”，则会话将停止。

    有关停止会话的影响的详细信息，请参阅Stopping Database Mirroring。

请参阅

任务

如何暂停或继续数据库镜像会话 (SQL Server Management Studio)

其他资源

数据库镜像


如何建立使用 Windows 身份验证的数据库镜像见证服务器 (Transact-SQL)

如何建立使用 Windows 身份验证的数据库镜像见证服务器 (Transact-SQL) |
 | 请参阅 示例

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

为了给数据库设置见证服务器，数据库所有者为见证服务器的角色分配数据库引擎实例。见证服务器实例可以与主体服务器实例或镜像服务器实例运行于同一台计算机上，但这样会明显降低自动故障转移的可靠性。强烈建议见证服务器应位于另外一台计算机上。

注意：
给定的服务器可以参与和相同伙伴或不同伙伴之间的多个并发数据库镜像会话。给定的服务器在某些会话中可能是伙伴，而在其他会话中则是见证服务器。

重要事项：
我们建议您在非高峰时段配置数据库镜像，因为配置会影响性能。

建立见证服务器

  1. 在见证服务器实例上，请确保存在用于数据库镜像的端点。无论支持的镜像会话数是多少，服务器实例都只能有一个数据库镜像端点。如果只将该服务器实例用于数据库镜像会话中的见证服务器，您可以为端点分配见证服务器角色 (ROLE=WITNESS)。如果要将该服务器实例用于其他数据库镜像会话中的伙伴，请将端点的角色分配为 ALL。

    若要执行 SET WITNESS 语句，数据库镜像会话必须已启动（在伙伴之间），并且见证服务器端点的 STATE 必须设置为 STARTED。

    若要了解见证服务器实例是否具有数据库镜像端点以及其角色和状态，请对该实例使用以下 Transact-SQL 语句：

    复制代码
    SELECT role_desc, state_desc FROM sys.database_mirroring_endpoints
    重要事项：
    如果已存在某个数据库镜像端点，并且正由任意镜像会话使用，请将该端点用于在该服务器实例上建立的任何其他会话。如果删除正在使用的端点，将会关闭与该服务器实例上所有现有会话的主体数据库之间的所有连接，并重新启动这些数据库。

    如果见证服务器缺少端点，请参阅如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL)。

  2. 如果使用不同的域用户帐户运行伙伴实例，请在每个实例的 master 数据库中为不同帐户创建登录名。有关详细信息，请参阅如何允许使用 Windows 身份验证进行数据库镜像网络访问 (Transact-SQL)。

  3. 连接到主体服务器并执行下面的语句：

    ALTER DATABASE <database_name> SET WITNESS =<server_network_address>

    其中 <database_name> 是正在镜像的数据库的名称（此名称在两个伙伴上相同），<server_network_address> 是见证服务器实例的服务器网络地址。

    服务器网络地址的基本语法如下：

    TCP://fully_qualified_domain_name:port

    其中 fully_qualified_domain_name 是见证服务器实例的完全限定域名，port 是该实例所侦听的端点。例如，对于 COMPANYINFO.MYCOMPANY.COM 域中在名为 DBSERVER3 的计算机上的运行并侦听端口 5022 的主体服务器实例，网络地址为：

    复制代码
    TCP://DBSERVER3.COMPANYINFO.MYCOMPANY.COM:5022
    注意：
    有关详细信息，请参阅如何指定数据库镜像的服务器网络地址。

    使用 AdventureWorks 数据库和上述服务器网络地址时，设置见证服务器的语句如下：

    复制代码
    ALTER DATABASE AdventureWorks
  SET WITNESS = 'TCP://DBSERVER3.COMPANYINFO.MYCOMPANY.COM:5022'

示例

下面的示例将建立一个数据镜像见证服务器。在见证服务器实例（WITNESSHOST4 上的默认实例）上：

  1. 为仅使用端口 5022 的 WITNESS 角色创建此服务器实例的一个端点。

    复制代码
    CREATE ENDPOINT Endpoint_Mirroring
    STATE=STARTED
    AS TCP (LISTENER_PORT=5022)
    FOR DATABASE_MIRRORING (ROLE=WITNESS)
GO
  2. 如果伙伴实例与见证服务器实例的域用户帐户不同，则为伙伴实例的域用户帐户创建一个登录名；例如，假定见证服务器作为 SOMEDOMAIN\witnessuser 运行，而伙伴作为 MYDOMAIN\dbousername 运行。为伙伴创建登录名，如下所示：

    复制代码
    --Create a login for the partner server instances,
--which are both running as MYDOMAIN\dbousername:
USE master ;
GO
CREATE LOGIN [MYDOMAIN\dbousername] FROM WINDOWS ;
GO
--Grant connect permissions on endpoint to login account
--of partners
GRANT CONNECT ON ENDPOINT::Endpoint_Mirroring TO [MYDOMAIN\dbousername];
GO
  3. 在每个伙伴服务器实例上，为见证服务器实例创建登录名：

    复制代码
    --Create a login for the witness server instance,
--which is running as SOMEDOMAIN\witnessuser:
USE master ;
GO
CREATE LOGIN [SOMEDOMAIN\witnessuser] FROM WINDOWS ;
GO
--Grant connect permissions on endpoint to login account
--of partners
GRANT CONNECT ON ENDPOINT::Endpoint_Mirroring TO [SOMEDOMAIN\witnessuser];
GO
  4. 在主体服务器上，设置见证服务器（位于 WITNESSHOST4 上）：

    复制代码
    ALTER DATABASE AdventureWorks
    SET WITNESS =
    'TCP://WITNESSHOST4.SOMEDOMAIN.CORP.MYCOMPANY.COM:5022'
GO
注意：
服务器网络地址通过端口号来指示目标服务器实例，端口号映射到该实例的镜像端点。

有关显示安全设置、准备镜像数据库、设置伙伴和添加见证服务器的完整示例，请参阅Overview of Setting Up Database Mirroring。

请参阅

任务

如何允许使用 Windows 身份验证进行数据库镜像网络访问 (Transact-SQL)
如何创建使用 Windows 身份验证的镜像端点 (Transact-SQL)
如何建立使用 Windows 身份验证的数据库镜像会话 (Transact-SQL)
如何关闭数据库镜像见证服务器 (Transact-SQL)

其他资源

ALTER DATABASE (Transact-SQL)
The Role of the Witness
Transact-SQL Settings and Database Mirroring Operating Modes


如何使用复制数据库向导升级至 SQL Server 2005

如何使用复制数据库向导升级至 SQL Server 2005 |
 | 请参阅

本主题介绍如何使用复制数据库向导将 SQL Server 2000 数据库升级到 SQL Server 2005 数据库。

使用复制数据库向导升级数据库时，请遵循下列要求：

  • 升级之前，将数据库置于单用户模式，并确保当前没有应用程序或服务试图访问该数据库。请勿使用只读模式，因为这会导致出现错误。

  • 在此操作过程中，不能重命名数据库。

过程

将 SQL Server 2000 数据库升级到 SQL Server 2005 数据库

  1. 使用 SQL Server Management Studio 中的对象资源管理器连接到任何 SQL Server 数据库引擎 实例。

  2. 展开“数据库”文件夹，右键单击一个数据库，指向“任务”，再单击“复制数据库”。

  3. 完成向导中的步骤。

    重要事项：
    为了确保升级后的数据库具有最佳性能，请在 SQL Server 2005 服务器上对升级后的数据库运行 sp_updatestats（更新统计信息）。

请参阅

概念

使用复制数据库向导

其他资源

从 SQL Server 6.5 或更早版本复制数据库
如何使用分离和附加来升级数据库 (Transact-SQL)


How to: Install Analysis Services on a Remote Computer

How to: Install Analysis Services on a Remote Computer |
 | 请参阅

To install an instance of Microsoft SQL Server 2005 Analysis Services (SSAS) on a remote computer, you must run Setup from the command prompt. You cannot use the SQL Server Installation Wizard for a remote installation.

重要事项：
This topic and the other Analysis Services installation how-to topics in this section focus only on installation options that are specific to Analysis Services. However, these topics provide links to other topics for more information about installation of SQL Server.

To Install Analysis Services on a Remote Computer

  1. To install Analysis Services from the command prompt, follow the steps outlined in 如何从命令提示符安装 Analysis Services.

  2. Use the targetcomputer command-line option to specify the remote computer name. For more information, see 如何从命令提示符安装 SQL Server 2005.

请参阅

其他资源

Analysis Services 安装帮助主题


如何恢复数据库镜像会话 (Transact-SQL)

如何恢复数据库镜像会话 (Transact-SQL) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

数据库所有者可以随时恢复挂起的数据库镜像会话。

恢复数据库镜像会话

  1. 连接到任一伙伴。

  2. 发出以下 Transact-SQL 语句：

    ALTER DATABASE <database_name> SET PARTNER RESUME

    其中，<database_name> 是要恢复其会话的镜像数据库。

    注意：
    恢复数据库镜像会将镜像数据库置于 SYNCHRONIZING 状态。如果安全级别为 FULL，镜像将达到与主体相同的状态，镜像数据库将进入 SYNCHRONIZED 状态。此时，可以进行故障转移。如果见证存在并且设置为 ON，则可以进行自动故障转移。在缺少见证的情况下，可以进行手动故障转移。

请参阅

其他资源

ALTER DATABASE (Transact-SQL)
数据库镜像
数据库镜像帮助主题
Pausing and Resuming Database Mirroring
Stopping Database Mirroring


如何关闭数据库镜像见证服务器 (Transact-SQL)

如何关闭数据库镜像见证服务器 (Transact-SQL) |
 | 请参阅

重要事项：
Microsoft 支持策略不适用于 SQL Server 2005 的数据库镜像功能。根据默认设置，数据库镜像当前已被禁用，但通过使用跟踪标志 1400 作为启动参数可以启用该功能，该功能仅供评估使用。（有关跟踪日志的详细信息，请参阅 跟踪标志 (Transact-SQL) .) 不要在生产环境中使用数据库镜像，Microsoft 支持服务不支持使用数据库镜像的数据库或应用程序。在 SQL Server 2005 中包括数据库镜像文档仅供评估使用，SQL Server 2005 支持和升级文档策略不适用于数据库镜像文档。

数据库镜像会话期间的任何时候，数据库所有者都可以关闭数据库镜像会话的见证。

关闭见证将更改运行模式与事务安全设置的一致性。如果事务安全设置为 FULL（默认），则会话将使用高级别保护同步模式；如果镜像服务器不可用，则主体服务器将停止并将数据库中主体服务器的副本离线。如果事务安全设置为 OFF，会话将使用高性能异步模式，在此模式下，镜像数据库始终稍微滞后于主体数据库。

重要事项：
任何 SET WITNESS 语句都会关闭所有指向主体数据库的连接，并重新启动数据库。

关闭见证服务器

  1. 连接到任一伙伴。

  2. 发出以下语句：

    ALTER DATABASE <database_name> SET WITNESS OFF

    其中，<database_name> 是镜像数据库的名称。

请参阅

任务

如何建立使用 Windows 身份验证的数据库镜像见证服务器 (Transact-SQL)

其他资源

ALTER DATABASE (Transact-SQL)
数据库镜像帮助主题
The Role of the Witness
Transact-SQL Settings and Database Mirroring Operating Modes